Willkommen

Navigation: »Kein übergeordnetes Kapitel«

Willkommen

Willkommen

Wir freuen uns, dass Sie sich für das anwenderfreundliche Dokumentenmanagement- und Archivierungssystem Office Manager entschieden haben. Mit dieser DMS-Lösung gelingt es Ihnen künftig, elektronische und gescannte Dokumente jeden Formats so zu archivieren, dass Sie diese innerhalb weniger Sekunden finden und verwenden können. Als Instrumente dienen Ihnen hierfür die Volltextindexierung und Katalogisierung nach beliebig vielen Dokumenteigenschaften. Außerdem wird es Ihnen effektiv erleichtert, den Grundsätzen zur ordnungsgemäßen Aufbewahrung von Unterlagen in elektronischer Form (GoBD) Rechnung zu tragen.

Im Folgenden möchten wir Sie darüber informieren, wie Sie den Office Manager schnell und einfach auf Ihrem PC installieren, Ihre vorhandene Software integrieren und Ihr erstes eigenes Dokument im Archiv anlegen können. Insbesondere finden Sie auf den folgenden Seiten auch Informationen dazu, wie Sie Dokumente in das Archiv importieren und diese dort wiederfinden können.

Programmeinrichtung

Erste Schritte

Neuigkeiten in Version 25.0

Antworten auf Ihre Fragen zum Dokumentenmanagement finden Sie mit einer Online-Support-Recherche, im DMS Hotline-Blog oder der Hotline +49 3375 203620.

Typographische Konventionen

Schriftbilder in dieser Dokumentation

Text | Grundschriftart für Fließtext
Link | Link zu weiterführendem Hilfethema
Popup | Link zu Hilfe-Popup (Kurzhilfe)
Weblink | Link zu einer Internetseite außerhalb des Handbuchs
Komponente | Schaltflächen und Eingabefelder auf der Programmoberfläche
Menü | Befehl | Pfad zu einem Ribbon-Menübefehlen
Taste | Kurztasten
Siehe auch | Kursiv gedruckte Wörter kennzeichnen Tipps und Hinweise.
Code | Skript-Quelltext und Inhalt von Konfigurationsdateien
[Text] | Eckige Klammern kennzeichnen optionale Parameter in den Makro-Anweisungen.
"Text" | Hochkommata kennzeichnen feste Begriffe und Überschriften von Dialogen.

Hinweis

In dieser Dokumentation werden Warenzeichen ohne Gewährleistung der freien Verwendbarkeit benutzt. Texte und Bilder wurden mit großer Sorgfalt zusammengestellt. Herausgeber und Autoren können dennoch weder für fehlerfreie Angaben noch für deren Folgen die Haftung übernehmen.

Das Dokumenten-Management-System Office Manager und alle Zusatzprodukte sind urheberrechtlich geschützt und Eigentum von Softwarebüro Krekeler, www.krekeler.de

Alle Rechte vorbehalten, auch das der fotomechanischen Wiedergabe und Speicherung mit elektronischen Medien.

Letzte Überarbeitung im November 2025

Office Manager DMS Version 25.0

Copyright 1996-2025 Softwarebüro Krekeler


Neuigkeiten

Navigation: »Kein übergeordnetes Kapitel«

Neuigkeiten

Verbesserungen beim Upgrade auf Version 25.0

·Scan-Ziele festlegen und Dokumente erweitern

·Bildschirmlupe für die Detailvergrößerung in der Vorschau

·50-fach schnellerer Projektnavigator

·Die aktuelle Suche speichern und später wiederverwenden

·Positionen aus E-Rechnungen einlesen (nur Enterprise).

·Schreibweise in Datenfeldern vorgeben und Änderungen nachverfolgen

·Die Gesamtliste finden Sie unter https://www.officemanager.de/neu.html

Neu in Version 24.0

·Ein Meilenstein: Künstliche Intelligenz

·Elektronische Rechnungen: XRechnung und ZUGFeRD

·Aktenorientierte Aufbewahrungsfristen

Neu in Version 23.0

·Dokumentenerkennung mit Azure Cloud KI

·Individuelle Auswahl der Erkennungsalgorithmen

·Terminplanungssoftware mit Kalenderdarstellung

·Optionale Datenbank-Meldungen beim Öffnen

Neu in Version 22.0

·Formatierung und Hervorhebung von Eigenschaften in Auswahllisten

·Verschieben von Projekten mit den Dokumenten per Drag&Drop

·Direktzugriff auf Dateianlagen in der Vorschau

·Markierung der Suchbegriffe in der Vorschau

Eine vollständige Liste der Verbesserungen sowie Neuigkeiten, die mit älteren Versionen eingeführt wurden, finden Sie unter https://www.officemanager.de/neu.html


Installation

Navigation: »Kein übergeordnetes Kapitel«

Installation

Installation und Einrichtung

In diesem Kapitel:

Erstinstallation, wenn Sie Office Manager DMS neu installieren.

Upgrade-Installation, wenn Sie von einer älteren Version aufsteigen.

Programmeinrichtung

Software registrieren


Erstinstallation

Navigation: Installation >

Erstinstallation

Programminstallation

Systemvoraussetzung:

·PC mit Windows 10 bis 11

·Für die Standarddatenbanken sind keine Treiber nötig, für Access und SQL-Server siehe unter https://www.officemanager.de/support/datenbanktreiber.php

Wenn Sie von einer früheren Version umsteigen, dann beachten Sie bitte auch die Update-Hinweise.
Hinweise zur Einrichtung des Dokumentenmanagements im Netzwerk finden Sie im Internet.

1. Office Manager DMS als Download:

Laden Sie das Setup und öffnen Sie die Datei dms-setup-64.zip für die 64 Bit-Ausgabe oder die dms-setup-32.zip für die 32 Bit-Variante. Starten Sie das enthaltene Setupprogramm, es beinhaltet alle DMS-Editionen, wie "Pro" und "Enterprise", sowie Test- und Vollversion.

Oder:

1a. Office Manager von CD-ROM installieren:

Legen Sie bitte die CD in das Laufwerk ein.

Falls das Setup-Programm nicht automatisch startet, dann öffnen Sie bitte den Windows-Explorer führen Sie die Datei im Verzeichnis "Setup" auf der CD aus.

2. Folgen Sie bitte den Anweisungen auf dem Bildschirm.

WICHTIG: Bei einer Netzwerkinstallation muss auf allen Arbeitsplätzen dasselbe "Verzeichnis für gemeinsame Dateien" angegeben werden! Siehe hierzu im Whitepaper Netzwerkinstallation und im Blogartikel UNC-Pfad oder Laufwerksbuchstabe..

TIPP: Verwenden Sie möglichst den Pfad "\Office Manager DMS\Gemeinsame Dateien\" auf "C:" oder auf Ihrem Datenlaufwerk. Die Einhaltung dieser Empfehlung vereinfacht die Installation und eine zukünftige Datenübertragung auf einen neuen Computer.

Beachten Sie bitte die erforderlichen Zugriffsrechte im Verzeichnis der gemeinsamen Dateien. Wenn dieses auf einer lokalen Festplatte liegt, dann werden die Berechtigungseinstellungen vom Setup-Programm vorgenommen. Bei Netzlaufwerken ist der Systemadministrator für die Vergabe der Rechte zuständig.

Beim ersten Programmstart gelangen Sie nach der Installation automatisch zum Einrichtungsassistenten.

3. Datenbanktreiber

Treiber sind für die Standarddatenbanken nicht erforderlich. Falls Sie aber beim ersten Programmstart eine entsprechende Fehlermeldung erhalten, dann installieren Sie bitte den genannten Treiber. Downloadmöglichkeiten finden Sie im Supportbereich.

4. GPT für KI-Unterstützung

Für die Nutzung fortschrittlicher Künstlicher Intelligenz im Dokumentenmanagement können Sie das Programm mit Cloud-Diensten und lokalen GPT-Lösungen verbinden.


Upgrade-Installation

Navigation: Installation >

Upgrade-Installation

Softwareaktualisierung

Wählen Sie dazu bitte im Menü Hilfe | Internet den Befehl Software aktualisieren.

Servicepack

Im oberen Bereich des Begrüßungsfensters finden Sie Informationen zu einem kostenlosen Servicepack und zu optionalen Dateien. Dies sind Updates innerhalb der Major-Version, wie z. B. 25.x
Klicken Sie einfach auf Weiter, um die neuen Dateien zu laden.

Upgrade der Hauptversion

Wenn eine neue Hauptversion verfügbar ist, dann können Sie das (i. d. R. kostenpflichtige) Upgrade installieren.

Empfohlenes Vorgehen beim Upgrade auf neue Major-Version

Beachten Sie bitte auch die Anleitung, die Sie mit der Auftragsbestätigung zu Ihrer Upgrade-Bestellung erhalten haben.

1.Geben Sie zuerst den Freigabecode für die neue Version ein. Sie erhalten diesen nach Ihrer Bestellung. Siehe auch Upgrade-Formular, Onlineshop oder Preisliste.

2.Markieren Sie die Option Upgrade auf Office Manager 25.0, klicken Sie auf Weiter und führen Sie die folgenden Schritte durch.

3.Das Hauptmenü sollte zur Bereinigung von allen Anwendenden zurückgesetzt werden: Menü Ansicht | Anpassen | Menüband zurücksetzen und mit Ja bestätigen.

Hinweis zu Netzwerkinstallationen

Stellen Sie bitte sicher, dass alle Anwender den Office Manager beenden. Führen Sie dann das Update auf dem ersten Arbeitsplatz komplett durch und öffnen Sie alle Archive. Beginnen Sie erst danach mit der Installation auf weiteren Arbeitsplätzen. Es darf jetzt nur noch mit der neuen Version gearbeitet werden.

Siehe auch

Neuigkeiten in Version 25.0

Support zur Softwareaktualisierung

Upgrade von sehr alter Version


32 oder 64 Bit

Navigation: Installation >

32 oder 64 Bit

Office Manager DMS ist als 32 und als 64 Bit-Software für Windows verfügbar. Wenn Sie ein 64 Bit-Betriebssystem verwenden, dann können Sie entscheiden, welche Ausgabe des Programms Sie verwenden.

Sie können auch beide Ausgaben parallel installieren. Geben Sie dann bei beiden Installationen bereits im Setupprogramm dasselbe Verzeichnis der gemeinsamen Dateien an.

Vorteile der 64 Bit-Version

·Die 4-GB-Grenze des direkt nutzbaren Arbeitsspeichers ist nicht mehr vorhanden - Sie können mehr Arbeitsspeicher nutzen. Dies ist bei der Arbeit mit großen Archivdatenbanken relevant. Tatsächlich kann in der 32 Bit-Edition beim Laden von knapp 1 Million Datensätzen der Fehler "Zu wenig Arbeitsspeicher" auftreten.

·Bessere Integration im 64 Bit-Windows. 32 Bit-Anwendungen laufen auf einem 64 Bit-Windows in einem Subsystem, dem Wow64.

·Besseres Zusammenspiel mit anderer 64 Bit-Software.

·Nutzung der Miniaturansichten des Windows-Explorers als Dokumentenvorschau.

Nachteile

·Es gibt nicht für alle Geräte einen passenden Treiber. Wenn Sie beispielsweise über TWAIN einen Scanner nutzen möchten, dann benötigen Sie auch einen 64 Bit TWAIN-Treiber.

·Für das Datenbankformat Access müssen Sie eventuell vorab einen Treiber installieren.

·Windows Script Host ist nur in 32 Bit verfügbar. Sie können das Programm nicht mit VBScript oder JScript erweitern.

·Die Verschlüsselung von SQLite-Datenbanken ist nicht möglich.


Programmeinrichtung

Navigation: Installation >

Programmeinrichtung

Programmeinrichtung mit dem Assistenten

Um Ihnen den Einstieg in die Welt der komfortablen Dokumentenverwaltung mit dem Office Manager zu erleichtern, begrüßen wir Sie beim ersten Programmstart durch den Einrichtungsassistenten:

Klicken Sie im Bild auf die Komponenten, zu der Sie weitere Hilfe wünschen.

Er unterstützt Sie bei der ersten Einrichtung Ihres Dokumenten-Management-Systems:

Lizenzierung: Freischalten der Vollversion oder kostenlose Registrierung

Dokumenteinstellungen: Verzeichnisse und Optionen

Anwendungsprogramme einrichten: Programme registrieren

Datenbankeinstellungen: Systemoptimierung

Sicherheit und Administration: Einstellungen der Netzwerksicherheit

Verknüpfungen: Registrierung des Programms in der Windows-Umgebung

Hilfe automatisch öffnen: Öffnet die Programmhilfe für jede Seite des Assistenten

Der Einrichtungsassistent führt Sie sicher durch die wichtigsten Einstellungen des Office Managers. Anschließend können Sie sofort loslegen... viel Spaß!

Für weitere Hilfe klicken Sie bitte im Einrichtungsassistenten auf den Mausschalter Hilfe


Software registrieren

Navigation: Installation >

Software registrieren

Registrieren und Freischalten

Dieses Programm ist nicht kostenlos. Es handelt sich vielmehr um eine zeitlich befristete Testversion, die Sie 30 Tage kostenlos testen können.

Mit der Online-Registrierung können Sie einen Freigabecode für die uneingeschränkte Vollversion des Office Managers erwerben:

1. Wählen Sie den Menübefehl Hilfe | Internet | Internet | Version registrieren oder klicken Sie im Einrichtungsassistenten, Seite Lizenz, auf den Schalter Registrieren. Das Fenster "Online-Registrierung" wird geöffnet:

Klicken Sie im Bild auf die Komponenten, zu der Sie weitere Hilfe wünschen.

Wenn Sie bereits einen gültigen Freigabecode besitzen:

2. Geben Sie den Code einfach bei Schritt 4 ein und klicken Sie auf Freischalten.

Wenn Sie noch keinen Freigabecode besitzen:

2. Geben Sie Ihre Daten für die Freischaltung ein. Besonders wichtig ist die korrekte E-Mail-Adresse, weil der Freigabecode an diese Adresse gesendet wird.
3. Stellen Sie bitte eine Internetverbindung her und klicken Sie auf den Schalter Online-Registrierung. Das Web-Formular wird in Ihrem Browser geöffnet.

4. Wählen Sie bitte die Art der Registrierung, überprüfen Sie Ihre Adressdaten und klicken Sie auf die Schaltfläche Bestellung abschließen.
5. Das Webformular ermittelt den Freigabecode (Seriennummer) und sendet diesen an die angegebene E-Mail-Adresse. Geben Sie den Freigabecode im Office Manager ein und klicken Sie auf Freischalten.

Siehe auch

Lizenz ist abgelaufen

Lizenzmodell


Programmoberfläche

Navigation: »Kein übergeordnetes Kapitel«

Programmoberfläche

Hauptfenster

Das Fenster ist in die Bereiche Hauptmenü, Projektnavigator, Suchfelder und Datentabelle aufgeteilt.

Im Menü wählen Sie die gewünschten Befehle zur Dokumentenverwaltung und -Verarbeitung. Mit Hilfe der Suchfelder und des Projektnavigators können Sie eine Archivrecherche starten und über die Datentabelle auf alle gefundenen Dokumente zugreifen.

Screenshot: Office Manager-Hauptfenster in Archivansicht

Screenshot der Programmoberfläche. Klicken Sie im Bild auf die Komponenten, zu der Sie weitere Hilfe wünschen.

Nutzen Sie bitte die Support-Recherche im Internet mit interaktiven Screenshots. Klicken Sie dort auf einen Menübefehl oder ein anderes Element, um Hilfe und Erklärungen zum gewünschten Thema zu finden.

Siehe auch

Menü-Referenz

Bereiche positionieren

Farbstil anpassen


Arbeitsweise

Navigation: »Kein übergeordnetes Kapitel«

Arbeitsweise

Arbeitsweise

Der Office Manager verwaltet die Dokumente verschiedenster Windows-Anwendungen, Internetadressen, E-Mails und interne Textdokumente unter einer einheitlichen Oberfläche. Sie können somit Ihre E-Mails, Briefe aus der Textverarbeitung, Fotos, CAD-Zeichnungen, gescannte Papierdokumente, Internetadressen u. a. gemeinsamen Attributen, wie Projekten und Kategorien zuordnen.

Ordnung halten ohne Verzeichnisbaum

Bei der klassischen Ablage in Verzeichnissen wird versucht, möglichst viele Dokumenteigenschaften in einem Strukturbaum zu hinterlegen:

C:\Dokumente\Kunden\Mustermann\Aufträge\Rechnungen\Nr7123.pdf

Wie finden Sie jetzt alle offenen Rechnungen aller Kunden?

Im Office Manager erhält das Dokument parallele Eigenschaften: Es wird dem Kunden zugeordnet, es ist eine Rechnung mit Status "Offen" und es erhält die Belegnummer 7123 mit Buchungsdatum.

Jetzt sind beliebige Suchabfragen möglich:

·"Zeige alle offenen Rechnungen, die vor dem 7. Juli erstellt wurden",

·"Zeige mir die Rechnung mit Nummer 7123" oder

·"Zeige mir alle Angebote, die mein Kollege für Mustermann erstellt hat".

Welche Eigenschaften ein Dokument erhält, entscheiden Sie: Projekte, Bauvorhaben, Kunden und Lieferanten, Aktenzeichen und andere Gruppen - was immer Sie möchten.

Volltextsuche ohne Zeitaufwand

Die Dokumentinhalte werden in einer Datenbank indexiert. Bei einer Volltextsuche brauchen die Dokumente nicht mehr geöffnet zu werden - das Programm fragt vielmehr den schnellen Datenbankindex ab.

Sie geben nur noch die gesuchten Begriffe ein und finden das Dokument in weniger als einer Sekunde.

Siehe auch

Dokumentenverzeichnis festlegen

Dokumente erstellen

Mit Vorlagen arbeiten

Dokumente suchen


Künstliche Intelligenz

Navigation: »Kein übergeordnetes Kapitel«

Künstliche Intelligenz

Verfügbar in diesen Editionen

Generative vortrainierte Transformer unterstützen Sie bei Routinearbeiten, sie automatisiert und vereinfacht häufige Arbeitsabläufe. Die Künstliche Intelligenz

·analysiert Textdokumente und ermöglicht eine vollautomatische Archivierung,

·katalogisiert Fotos- und Bilder,

·übernimmt Kontakte aus Fließtexten,

·übersetzt Texte,

·hilft beim Skripten

·und beantwortet Alltagsfragen.

Die KI-Funktionen sind optional und für die Arbeit mit Office Manager DMS nicht erforderlich, erleichtern aber die tägliche Routine.

Voraussetzungen

Office Manager DMS beinhaltet Schnittstellen zu ChatGPT von OpenAI, Microsoft Azure, Google Gemini sowie zu lokal installierten GPT-Lösungen. Dies bietet Ihnen ein Maximum an Flexibilität und Erweiterbarkeit. Geben Sie in den Programmeinstellungen den gewünschten Dienst an und individualisieren Sie bei Bedarf die jeweilige KI-Funktion.

Nutzungsbeispiele

GPT-Dokumentenerkennung Sie importieren oder scannen ein Textdokument in das Archiv. Anstatt dieses manuell zu beschreiben, analysiert die KI den Inhalt und füllt automatisch die gewünschten Datenfelder, wie Kategorie, Belegdatum, Rechnungssumme und Beschreibung aus.

GPT-Bilderkennung Einige GPT-Lösungen beherrschen die "Computer Vision" und ermöglichen die Dokumentenerkennung auch für Bilder. Lassen Sie zum Beispiel hunderte von Baustellenfotos in Kategorien einordnen und zusammen mit durchsuchbaren Detailbeschreibungen im DMS hinterlegen.

GPT-Kontakterkennung Ein neuer Kontakt wird oft Zeile für Zeile über die Zwischenablage übernommen: Name im Text markieren, kopieren, Programm wechseln und einfügen. Dann für Straße, Postleitzahl, Stadt u. a. wiederholen sowie die passende Anrede wählen. Mit KI-Unterstützung schieben Sie einfach den gesamten Text auf die CRM-Kontakttabelle. Die Künstliche Intelligenz erkennt die einzelnen Kontaktdaten im Fließtext und übernimmt diese in die jeweiligen Datenfelder. Sogar die korrekte Anrede wird meist aus dem Namen ermittelt.

GPT-Übersetzung Ein Dokument in fremdsprachigem Text wird auf Mausklick übersetzt und in deutscher Sprache eingeblendet.


KI-Installation

Installation

Navigation: Künstliche Intelligenz >

Installation

Verfügbar in diesen Editionen

GPT-Dienste einrichten

Sie haben die Wahl zwischen

·Cloud-Diensten von OpenAI, Microsoft Azure, Google Gemini und anderen kompatiblen Anbietern

·sowie lokal installierten GPT-Lösungen (siehe unten).

Datenschutz bei Cloud beachten

Nehmen Sie die geltenden Vorschriften bitte grundsätzlich bei allen Cloud-Diensten und -Speichern ernst. Unternehmer dürfen personenbezogenen Daten nur an Cloud-Dienste geben, wenn diese die DSGVO-Anforderungen erfüllen. Dienste von Google und OpenAI auf US-Servern erfüllen die Anforderungen nicht, Microsoft bietet diese Dienste aber auch auf Servern in Deutschland und anderen EU-Ländern an.

Erste Schritte

Es gibt einige Lösungen, die lokal auf dem PC oder zentral im Unternehmensnetzwerk laufen und dabei keine Daten an Dritte weitergeben. Diese GPT (Generative Pre-trained Transformer) bzw. LLM (Large Language Model) laufen ohne Cloud und ermöglichen die Nutzung verschiedener Modelle. Der Datenschutz ist dann also kein Problem und die nutzungsabhängigen Kosten für einen Cloudservice entfallen.

Lokal installierbare quelloffene Lösungen sind beispielsweise PrivateGPT, LocalGPT und GPT4All. Letztere Lösung von Nomic AI zeichnet sich vor allem durch die unkomplizierte Installation als einfache Windows-App aus.

Systemanforderungen

KI-Systeme stellen hohe Anforderungen an die Computerhardware. Wenn Sie eine lokale GPT-Lösung nutzen möchten, dann achten Sie bitte auf die Anforderungen der jeweiligen Software. Folgende Angaben basieren auf den Informationen von Nomic AI für GPT4All unter Windows und unseren Erfahrungen:

 | Mindestanforderung | Empfohlen (Beispiele)
CPU (Hauptprozessor) | Intel Core i3-2100, Pentium 7505 Celeron 6305, AMD FX-4100 | Ryzen 5 3600 Intel Core i7-10700 oder besser
GPU (Grafikprozessor) | Beliebige | NVIDIA GTX 1080 Ti/RTX 2080 8GB AMD Radeon RX 7900 XTX Intel Arc A750 Alle GPU mit Vulkan API 1.2+
RAM (Arbeitsspeicher) | 16 GB (8 GB frei für GPT-Modell) | 24 GB
OS (Betriebssystem) | Windows 10 oder 11 | Windows 10 oder 11

Wenn eine geeignete Grafikkarte vorhanden ist, dann ist die CPU-Leistung eher unwichtig. KI-Funktionen erfordern eine hohe Parallelverarbeitung und laufen am effizientesten auf Grafikprozessoren. Falls Sie Zeitüberschreitungen bei den KI-Funktionen erhalten, können Sie die Wartezeit (Timeout) verlängern.

Installation von GPT4All

Installieren Sie das Programm auf dem Computer, auf dem auch Office Manager DMS ausgeführt wird.

1.Öffnen Sie die Download-Seite und laden Sie den GPT4All-Installer für Windows.

2.Starten Sie das Programm und wechseln Sie zur Registerseite Settings | Application.

3.Falls Sie den Speicherort für die zu installierenden Modelle anpassen möchten, dann tun Sie dies bitte jetzt bei Download Path.

4.Deaktivieren: Die Option Enable Datalaka wäre zwar hilfreich für den Softwarehersteller, aus Datenschutzgründen sollte diese aber deaktiviert sein.

5.CPU Threads: GPTs benötigen viel Rechenleistung. Sie werden dies merken, wenn die lokale KI Aufgaben für Sie erledigt. Geben Sie möglichst viele "Logische Prozessoren" für die Berechnungen frei. Im Windows-Taskmanager können Sie auf der Seite Leistung | CPU prüfen, wie viele in Ihrem Computer vorhanden sind. Das Programm nutzt aber auch, sofern geeignet, die installierte Grafikkarte, weil Grafikprozessoren mit ihrer parallelen Verarbeitung ideal für die maschinellen Lernmodelle sind. Mit der Option Device können Sie die Nutzung der GPU bei Bedarf anpassen.

6.Aktivieren Sie Enable Local API Server, damit Office Manager DMS mit GPT4All kommunizieren kann. Falls Sie den API Server Port ändern, müssen Sie dies später bei den Einstellungen im DMS manuell anpassen. Also möglichst den Port 4891 beibehalten.

7.Wechseln Sie zur Registerseite Models.

8.Laden Sie bitte das Modell "Llama 3 8b Instruct", dieses wird in der Grundeinstellung im DMS genutzt. Sie können selbstverständlich weitere Modelle, wie "Mistral Instruct" und "GPT4All Falcon", laden und mit diesen experimentieren. Beachten Sie aber immer die jeweiligen Lizenzbedingungen.

KI-Funktionen aktivieren

1.Wählen Sie in Office Manager DMS bitte den Menübefehl Datei | Optionen | Einstellungen und wechseln Sie zur Registerseite Künstliche Intelligenz.
Künsliche Intelligenz im DMS aktivieren

2.Aktivieren Sie die Option GPT-Funktionen aktivieren und beachten Sie den Hinweis. Sofern GPT4All, wie oben beschrieben installiert wurde, sind jetzt alle Funktionen bis auf die Bilderkennung fertig eingerichtet.

3.Klicken Sie auf OK.

Wenn Sie einzelne Funktionen deaktivieren möchten, lassen Sie das Modell einfach leer.

Erster Test

Menü Start | Öffnen

Haben Sie bereits ein fremdsprachiges Dokument im Archiv? Wenn ja, dann markieren Sie dieses und klicken Sie im Hauptmenü Start | Verwenden bitte auf die untere Hälfte des Mausschalters Öffnen und wählen den Befehl Übersetzung zeigen.

Oder Sie lassen sich einfach ein paar Wörter übersetzen.

GPT-Funktion im Volltext-Eingabefeld

Das Eingabefeld für die Volltext-Suche kann auch GPT-Befehle annehmen:

·Geben Sie beispielsweise "übersetze: Hello world" ein und klicken Sie auf den im Eingabefeld integrierten Mausschalter GPT-Mausschalter .

·Oder stellen Sie eine allgemeine Frage: "Frage: Was macht eine Archivierungssoftware?"


Funktion anpassen

GPT-Funktionen anpassen

Navigation: Künstliche Intelligenz >

GPT-Funktionen anpassen

Verfügbar in diesen Editionen

Die Künstliche Intelligenz individualisieren

Künsliche Intelligenz im DMS aktivieren

Wählen Sie in Office Manager DMS bitte den Menübefehl Datei | Optionen | Einstellungen und wechseln Sie zur Registerseite Künstliche Intelligenz. Mit GPT-Funktionen aktivieren wird die KI mit den Grundeinstellungen für einen lokalen GPT-Dienst eingeschaltet.

Verfügbare Funktionen

·Chat

·Text übersetzen

·Suche erzeugen im Chat und dem SQL-Editor

·Dokumentenerkennung

·Bilderkennung

·Kontakterkennung

·Unterstützung im Makro-Editor

·Benutzerdefinierte Funktionen

Funktionen anpassen

1.Klicken Sie auf das Kombinationsfeld "<Anzupassende Funktion wählen>"und wählen Sie die gewünschte Aufgabe aus, beispielsweise "Text übersetzen".

2.Klicken Sie auf den Mausschalter 'Text übersetzen' anpassen:
GPT-Funktion anpassen

3.Im Dialogfenster der GPT-Optionen klicken Sie auf den Schalter GPT-Dienst:
GPT-Dienst mit API-URL

4.Hier legen Sie die API-Adresse fest, beispielsweise "http://localhost:4891/v1" für das lokal installierte GPT4All an. "4891" ist hierbei der Port, welcher in den GPT4All-Optionen eingestellt wurde.

5.Der Schlüssel ist für den lokalen Dienst nicht relevant, geben Sie beispielsweise "mykey" ein. Falls Sie einen Cloud-Service nutzen, muss hier aber der korrekt API-Schlüssel hinterlegt sein.

6.Timeout gibt an, wie lange auf eine Antwort der KI gewartet wird.

7.Bestätigen Sie das Dialogfenster mit OK.

8.Öffnen Sie im Fenster der GPT-Optionen das Kombinationsfeld Modell. Dies ist auch ein Test für die Kommunikation mit dem Dienst: Die verfügbaren Modelle werden angefragt und bei Erfolg in der Liste gezeigt. Sie können mit verschiedenen Modellen experimentieren und das optimale für Ihren Anwendungsfall festlegen.

9.Bestätigen Sie das GPT-Fenster und anschließend auch das Fenster der Programmeinstellungen mit OK.

10.Mit System-Rolle und Benutzer-Rolle wird die Anfrage an die KI definiert. Der Platzhalter für die Eingabe ist {GPTInput} und es sind andere auch Makrovariablen möglich.

11. Maximale Tokens legt eine Obergrenze für die Eingabe plus Ausgabe bei der Kommunikation mit dem GPT fest. Tokens entsprechen ungefähr der Anzahl von Wörtern und Satzzeichen. Cloud-Dienste werden i. d. R. für die Anzahl der genutzten Tokens bezahlt.

12. Wenn Dokumenteninhalte übergeben werden, können Sie die Textmenge mit Dokumente kürzen (Tokens) auf beispielsweise 320 begrenzen. Dieser Wert muss deutlich unter Maximale Tokens liegen. Für die Übersetzung umfangreicher Dateien sind größere Werte nötig.

13. Für die Bilderkennung werden die Dateien verkleinert. Geben Sie die maximale Breite bzw. Höhe bei Bilder verkleinern (Pixel) an.

14. Falls Sie die Standardeinstellungen der gewählten Funktion laden möchten, dann klicken Sie auf Zurücksetzen.

Tipps für die Testphase

Hier einige Hinweise, falls Sie sich intensiv mit den Möglichkeiten beschäftigen und die KI anpassen möchten:

·Im Menü Datei | Information auf Seite Künstliche Intelligenz finden Sie eine Übersicht und das Log der letzten KI-Ausführung.

·Öffnen Sie in der GPT4All-App die Seite Chats und markieren Sie Server Chat bzw. den untersten Chat links in der Liste. Hier können Sie live beobachten, wie die KI Ihre Anfragen verarbeitet.

·Die Funktionen werden normalerweise im Fenster der Programmeinstellungen angepasst. Es ist etwas umständlich, die Dialoge immer wieder für jeder Änderung zu öffnen. Alternativ können Sie auch die gpt.ini ändern und speichern. Die INI wird für jeden Funktionsaufruf neu geladen.

·Pro- und Enterprise-Edition: Um die anderen Anwendenden während der Entwicklung nicht zu stören, können Sie eine eigene Konfiguration nutzen. Legen Sie dazu eine Kopie der gpt.ini im eigenen User-Verzeichnis ab.

·Beendet sich GPT4All, wenn Sie eine KI-Funktion starten? Testen Sie in so einem Fall bitte den Chat direkt im GPT-Programm. Wenn es dann auch zu einem Programmende kommt, ist vermutlich zu wenig Arbeitsspeicher frei. Das Modell "Llama 3 8b Instruct" erfordert 8 GB freien RAM.


Text übersetzen

Text mit KI übersetzen

Navigation: Künstliche Intelligenz >

Text mit KI übersetzen

Verfügbar in diesen Editionen

Dokumentdateien übersetzen

Markieren Sie ein einzelnes fremdsprachiges Dokument in der Tabelle und wählen Sie den Menübefehl Start | Verwenden | Öffnen | Übersetzung zeigen.

Der enthaltene Text wird aus der Datei extrahiert und zur Übersetzung an die KI übergeben. Die Dokumentendatei wird nicht geändert, sondern nur die (i. d. R. deutsche Übersetzung) eingeblendet.

Bei Dokumenten mit Dateianlagen, wie beispielsweise E-Mails und ZIP-Archiven, können Sie die gewünschte Anlage zur Übersetzung wählen:

Menü Start | Öffnen Übersetzung zeigen

Siehe auch

Maximale Tokens für umfangreiche Texte vergrößern

Direktübersetzung im Chat


Dokumentenerkennung

Dokumenten- und Bilderkennung

Navigation: Künstliche Intelligenz >

Dokumenten- und Bilderkennung

Verfügbar in diesen Editionen

Belege mit KI katalogisieren

Dokumente werden in der Archivdatenbank mit mehreren Eigenschaften beschrieben, um diese zum Beispiel schnell zu finden und die Aufbewahrungsfristen festzulegen. Eigenschaften sind unter anderem der Dokumentenname, das Belegdatum, eine Kategorie und das Projekt oder Buchungsjahr. Wenn Sie eine Datei importieren oder eine Papiervorlage scannen, öffnet sich eine Eingabemaske, in welcher Sie das Dokument beschreiben können.

Automatisiere Datenerfassung

Ihre DMS-Lösung bietet mehrere Methoden, um Dokumente automatisch zu beschreiben. Dies spart viel Fleißarbeit bei der täglichen Archivierung.

Die Import- und Scanprofile legen fest, welche Methoden für unterschiedliche Dokumentquellen ausgeführt werden. Aktivieren Sie dort bitte die Dokumentenerkennung "GPT - Generative Pre-trained Transformer".

GPT konfigurieren

Die KI wird bei Bedarf In den Programmeinstellungen angepasst. Für Textdokumente ist die GPT-Funktion "Dokumentenerkennung" und für Fotos sowie andere Bilder die "Bilderkennung" zuständig. Sie können dort Änderungen vornehmen, um die Ergebnisse für Ihre Anforderungen und Wünsche zu optimieren. Konfigurieren Sie die Anfrage so, dass die Antwort eigene Textzeilen für die gewünschten Datenfelder beinhaltet: Feldname=erkannter Wert. Zusätzliche Zeilen in der Antwort stören nicht.

Nachträgliche Erkennung

Über Menü Bearbeiten | Dokument | Erkennen | Dokumentenerkennung können die Erkennungsmethoden auch nachträglich ausgeführt werden. Markieren Sie die gewünschten Dokumente in der Tabelle und rufen Sie den Menübefehl auf.


Kontakterkennung

Kontakte aus Fließtext extrahieren

Navigation: Künstliche Intelligenz >

Kontakte aus Fließtext extrahieren

Verfügbar in diesen Editionen

Kontakte übernehmen

Copy&Paste - das Kopieren und Einfügen - ist eine klassische Methode, um Adressen aus einem Text in die eigene Kontaktverwaltung zu übernehmen. In der Fußzeile einer E-Mail wird der Firmenname markiert und mit Strg+C in die Zwischenablage kopiert. Wechsel zum Kontaktmanagement, neuen Kontakt anlegen und den Firmennamen einfügen. Dann Schritt für Schritt die einzelnen Adressdaten einzeln kopieren und im CRM einfügen.

Einfacher mit KI

Text per Drag&Drop ablegen und Kontakt extrahieren lassen:

Jontakt per Drag&Drop importieren

Die Künstliche Intelligenz kann das übernehmen, sie analysiert einen Fließtext und extrahiert die einzelnen Daten:

1.Markieren Sie in der Quelle, beispielsweise der eingehenden E-Mail, den Text mit den Kontaktdaten.

2.Schieben Sie diesen mit der Maus in die Office Manager-Kontakttabelle.

3.Der Eingabedialog wird geöffnet und mit den erkannten Daten gefüllt. Im obigen Beispiel sogar die Anrede anhand des Vornamens.

4.Überprüfen Sie die Daten und erweitern oder korrigieren Sie diese bei Bedarf.

5.Mit Klick auf OK wird der neue Kontakt übernommen.

Alternativ zum Drag&Drop können Sie auch

1.den Text markieren und mit Strg+C in die Zwischenablage kopieren.

2.Im DMS auf die Kontakttabelle klicken, um diese als Ziel zu aktivieren.

3.Mit Strg+V oder Bearbeiten | Zwischenablage | Einfügen importieren.

Kontakte auf Papier lassen sich mit den Scanprofilen einlesen.


Chat

Chat, Direktübersetzung und Dokumentensuche

Navigation: Künstliche Intelligenz >

Chat, Direktübersetzung und Dokumentensuche

Verfügbar in diesen Editionen

Mit der KI reden

GPT-Funktion im Volltext-Eingabefeld

Das Suchfeld Volltext dient auch der Kommunikation mit der Künstlichen Intelligenz. Geben Sie dazu eines der reservierten Wörter gefolgt von einem Doppelpunkt und der Frage ein:

·"Frage: Was macht eine Archivierungssoftware?".

·"Übersetze: I don't speak Englisch very well".

·"Suche: Alle Dokumente der Kategorie Angebot" (diese Funktion ist noch experimentell).

Sobald ein Schlüsselwort mit Doppelpunkt eingegeben ist, wird auch der Mausschalter GPT-Mausschalter sichtbar. Klicken Sie auf diesen oder drücken Sie die Eingabetaste, um die KI-Anfrage zu senden. Falls der Schalter unsichtbar bleibt, prüfen Sie bitte das reservierte Schlüsselwort und die Aktivierung der KI.

Tipp: Wenn Sie diese Funktion häufig nutzen, können Sie das Eingabefeld mit Hilfe des Layout-Designers verbreitern. Oder Sie chatten direkt in der GPT4All-App.

Freier Chat

Ein zusätzliches Feature, welches keinen Einfluss auf das DMS-Programm hat. Sie können beliebige Fragen stellen, die Antwort wird in einem Fenster eingeblendet.

Leiten Sie die Frage bitte mit einem der Schlüsselwörter ein: "Frage:", "Ask:" oder "Chat:".

Chat mit Antwort

Direktübersetzung

Geben Sie im Suchfeld z. B. "Übersetze: this text" oder alternativ "Translate: this text" ein und klicken Sie auf GPT-Mausschalter. Die Übersetzung wird, wie oben beim Chat, in einem Dialogfenster eingeblendet.

Falls Sie eine andere Zielsprache wünschen, dann können Sie diese auch anpassen. Für die Übersetzung archivierter Dokumente beachten Sie den Menübefehl Start | Verwenden | Öffnen | Übersetzung zeigen.

Dokumentensuche

Die KI soll hierbei aus Ihrer freien Eingabe eine SQL-Datenbankabfrage generieren. Beispielsweise "Suche: Alle Dokumente der Kategorie Angebot im Projekt Prinzenallee" (alternativ "search:").

Diese Funktion stellt hohe Anforderungen an das GPT-Modell und es müssen viele Daten übergeben werden, damit das Modell die Datenbankstruktur versteht. Die Funktion ist noch experimentell, klicken Sie auf Menü Start | Suchen | Suchen, um bei Fehlermeldungen zur normalen Datenabfrage zurückzukehren.


Makro-Editor

Skriptfunktionen mit KI erstellen

Navigation: Künstliche Intelligenz >

Skriptfunktionen mit KI erstellen

Verfügbar in diesen Editionen

Funktionen und Code-Schnipsel auf Anfrage

Office Manager DMS ermöglicht individuelle Features und Funktionserweiterung mit Makros und Skripten. Die KI kann Sie bei der Programmierung in Pascal unterstützen.

1.Öffnen Sie den Makro-Editor über Start | Verwenden | Makro.

2.Wählen Sie die Sprache "OmPascal".

3.Rechts in der Funktionsliste klicken Sie doppelt auf "unit", um ein Grundgerüst einzufügen.

4.Klicken Sie auf der Menüseite Hilfe auf GPT | Funktion einfügen.

5.Geben Sie zum Beispiel "Erstelle eine Funktion, die das aktuelle Datum mit Uhrzeit als String zurückgibt" ein und bestätigen Sie mit OK.

6.Die generierte Funktion wird an der Cursor-Position eingefügt.

Screenshot Makro-Editor mit KI-Assistent

Weitere GPT-Funktionen

Hilfe | GPT | Chat: Beliebige Frage an die KI stellen. Die Antwort wird in einem eigenen Fenster eingeblendet.

Hilfe | GPT | SQL-Abfrage im Archiv: SQL-Abfrage für die Dokumententabelle im Archiv generieren. Der SQL-Code wird in den Editor eingefügt.


Menü-Referenz

Navigation: »Kein übergeordnetes Kapitel«

Menü-Referenz

Referenz der Menübefehle

In diesem Kapitel:

Symbolleiste für den Schnellzugriff

Menü Datei

Menü Start

Menü Erstellen

Menü Bearbeiten

Menü Ansicht

Menü Hilfe

Kontextmenü Kontakt

Kontextmenü Aufgabe

Kontextmenü Navigator

Kontextmenü Administrator

Kontextmenü Docking

Suchfeld Was möchten Sie tun?

Menüband anpassen

Bei Fragen zu einem bestimmten Menübefehl können Sie auch das Support-Recherche-Tool im Internet verwenden. Es stellt alle Hilfekapitel, Hotline-Beiträge und weitere Dokumente für eine gewünschte Programmfunktion zusammen.


Symbolleiste für den Schnellzugriff

Navigation: Menü-Referenz >

Symbolleiste für den Schnellzugriff

Symbolleiste für den Schnellzugriff

Symbolleiste für den Schnellzugriff

Die Symbolleiste für den Schnellzugriff finden Sie links oben im Rahmen des Programmfensters. Nutzen Sie bitte die Funktion Menüband anpassen und platzieren Sie hier Menübefehle, die Sie häufig verwenden.

Systemmenü Das Systemmenü beinhaltet Windows-Standardfunktionen für das Programmfenster.
Zur letzten Suche zurückkehren.
Kurztaste: Alt+Links
Eine Suche vorwärts.
Kurztaste: Alt+Rechts
Menü mit Funktionen zum Erstellen neuer Dokumente.
Dokumente im Archiv suchen.
Die in der Tabellen markierten Dokumente verwenden, beispielsweise öffnen oder die Eigenschaften bearbeiten.
Direkthilfe: Klicken Sie auf diesen Schalter und anschließend auf eine Komponente, zu der Sie weitere Informationen wünschen.
Kurztaste: Umsch+F1
Das Menüband anpassen.

Was möchten Sie tun?

Im Ribbon-Hauptmenü finden Sie ein Eingabefeld für die Suche nach Menübefehlen.


Menü Datei

Menü Datei (Anwendungsmenü)

Navigation: Menü-Referenz >

Menü Datei (Anwendungsmenü)

Menü: Datei

Menü-Befehle

Neues Archiv: Erstellt ein neues Dokumentenarchiv, ein Synchronarchiv oder eine neue Anwendungsdatenbank.

Archiv öffnen: Das Standard-Dokumentenarchiv wird beim Programmstart i. d. R. automatisch geöffnet. Verwenden Sie diesen Befehl um ein anderes Archiv oder eine Anwendungsdatenbank zu laden.

Schließen: Die geöffnete Archiv- oder Kontaktdatenbank schließen.

Information zum Programm und wichtigen Einstellungen.

Beenden: Office Manager DMS beenden.
Kurztaste: Alt+F4

Seite "Zuletzt verwendet"

Liste der zuletzt geladenen Archive zum erneuten Öffnen.

Seite "Datenbank"

Datenaustausch | Importieren: Datensätze aus anderen Datenquellen übernehmen.

Datenaustausch | Exportieren: Datentabelle in verschiedene Formate exportieren.

Datenaustausch | Synchronisieren: Daten und Dokumente des aktiven Archivs mit einem synchronen Archiv abgleichen.

Datenaustausch | Übersicht: Exportiert die Datensätze der aktuellen Suche in eine HTML-Tabelle und druckt diese mit dem Browser.

Datenaustausch | Report: Erstellt eine Detailansicht der markierten Dokumente.

Datenaustausch | An Steuerberater senden: Dokumente zur Buchung an den Steuerberater bzw. die externe Buchhaltung geben.

Datenaustausch | DATEV Buchungstexte: Buchungsinformationen aus Datev importieren.

Datenaustausch | Lexware Buchhalter: Buchungsinformationen aus Lexware importieren.

Anpassen | Felder definieren: Attribute hinzufügen, ändern und löschen.

Anpassen | Eigenschaften: Zugriffsoptionen für SQL-Server-Datenbanken bearbeiten.

Anpassen | Dateipfade ändern: Geöffnetes Dokumentenarchiv an neue Verzeichnisstrukturen anpassen.

Pflege | Dateiexistenz prüfen: Es wird überprüft, ob die in den Datensätzen zugeordneten Dokumentdateien vorhanden sind.

Pflege | Datenbankpflege prüft, komprimiert und repariert bei Bedarf die geöffneten Datenbanken.

Pflege | Dubletten suchen: Mehrfach vorhandene Dateien im Archiv aufspüren.

Seite "Mobile Server"

Konfiguriert den Datenzugriff von mobilen Endgeräten (iPhone, Android-Smartphones) auf die Office Manager-Archive.

Seite "Optionen"

Auswahllisten: Projekte und andere Auswahllisten bearbeiten.

Dokumenttyp: Registrierung der Anwendungsprogramme.

Assistent: Startet den Einrichtungsassistenten.

Einstellungen: Programmeinstellungen ändern.

Administrator: Aktivierung der Administratorebene durch Eingabe eines Passworts, das Menü Administrator wird geöffnet.

Seite "Hilfe"

Hilfe: Hilfethemen, Zugriff auf das Handbuch und Support-Recherche für das geöffnete Programmfenster.


Menü Start

Navigation: Menü-Referenz >

Menü Start

Menü: Start

Auf der Registerseite Start finden Sie Grundfunktionen für die Arbeit mit Dokumenten.

Gruppe Suchen

Suchen startet die Suche mit den primären Suchfeldern.
Mausschaltfläche: Suchen
Kurztaste: Strg+S

Filter leeren löscht alle eingegebenen Suchkriterien. Wenn die Umschalttaste gedrückt ist, bleibt die Markierung im Projektnavigator erhalten. In der Aufgabenverwaltung schaltet der Kalender zur aktuellen Monatsansicht um.
Kurztaste: Strg+B

Markierte: Sucht die Datensätze, die derzeit markiert sind.

Weitere: Abfragen speichern und wiederverwenden, einzelne Eigenschaften suchen, leere Suche, zuletzt hinzugefügte Daten, Volltextdialog, Klone, erweiterte Suche und Datensätze fixieren.
Siehe auch: Felder definieren

Zwischenablage: Sucht Dokumente oder Kontakte, die zuvor mit dem Befehl Bearbeiten | Kopieren im Office Manager oder beispielsweise im Windows-Explorer in die Zwischenablage kopiert wurden. Wenn Dateien in der Zwischenablage enthalten sind, dann wird auch nach Dokumenten mit derselben Hash-Summe gesucht. Dies ermöglicht die Prüfung, ob eine Datei bereits im Archiv enthalten ist.

Verknüpfungen: Sucht alle Dokumente, die mit dem markierten Dokument oder der markierten Aufgabe kombiniert sind.

Caption Button : Erweiterte Suche nach beliebigen Dokumentattributen im Dialogfenster.

Gruppe Verwenden

Öffnen: Die markierten Dokumente im Anwendungsprogramm öffnen.
Kurztaste: Strg+O

Öffnen | Öffnen mit: Öffnet die markierten Dokumente mit einem beliebigen Anwendungsprogramm, welches Sie auswählen können.

Öffnen | Erneut öffnen: Enthält eine Liste mit den zuletzt geöffneten Dokumenten.

Öffnen | Übersetzung zeigen: Deutsche Übersetzung des markierte fremdsprachigen Dokuments einblenden.

Anlagen: Direkter Zugriff auf Dateianlagen einer E-Mail und den Inhalt eines ZIP-Archives. Alternativ können Sie den Öffnen-Schalter im Schnellzugriff sowie die Anlagenliste unterhalb der Vorschau und verwenden.

Vorschau: Zeigt das markierte Dokument in einem Vorschaufenster.

Eigenschaften: Dokumentattribute, wie Name, Nummer und Projekt ändern.
Kurztaste: Alt+Eingabe oder Alt+Doppelklick

Drucken | Dokument: Druckt die markierten Dokumente.
Kurztaste: Strg+P

Drucken | Übersicht: Exportiert die Datensätze der aktuellen Suche in eine HTML-Tabelle und druckt diese mit dem Browser.

Drucken | Report: Erstellt eine Detailansicht der markierten Dokumente.

Senden an | CD: Brennt die markierten Dokumentdateien auf eine CD oder DVD.

Senden an | Andere: Kopiert die markierten Dokumentdateien, Kontakte als vCard und Aufgaben als iCalendar auf einen beliebigen Datenträger.
Wenn nur ein Dokument markiert ist, dann kann die Datei umbenannt und Textdokumente (docx, doc, rtf, txt, html) auch in PDF konvertiert werden.

Senden an | Freigeben: Dokumente, Aufgaben und Kontakte mit anderen Windows-Apps teilen.

Senden an | In ZIP-Archiv speichern: Dokumentdateien oder Kontakte in ein ZIP-Archiv und andere Komprimierungscontainer exportieren.

Senden an | Extrahieren: Die Dateianlagen der markierten E-Mail oder den Inhalt eines ZIP-Archives exportieren.

Senden an | EMail Empfänger versendet die markierten Dokumentdateien oder Kontakte per E-Mail.

Senden an | FTP-Server: Dokumentdateien oder Kontakte per FTP oder SFTP hochladen.

Befehle: Sie können eigene Befehle für die Dokumentbearbeitung definieren, diese werden in diese Untermenü aufgelistet.
Siehe auch: Registrieren von Dokumenttypen

Makro | Makro-Editor öffnet den Skripteditor.

Makro | Makro ausführen: Makrodatei zur Ausführung im Öffnen-Dialog wählen.

Makro | [1 Name]: Führt ein Makro im Verzeichnis (gemeinsame Dateien)\Macro\Menu aus.
Wenn die Umschalttaste gedrückt und der Administratormodus aktiv ist, wird das Makro zur Bearbeitung im Editor geöffnet.

Folgende Befehle sind standardmäßig nicht sichtbar. Fügen Sie diese bei Bedarf ein.

Dateipfad öffnen: Öffnet den Ordner, in dem das markierte Dokument gespeichert ist.

Datei-Eigenschaften zeigt den Windows-Eigenschaftendialog der Datei.

Systemmenü: Öffnet das lokale Menü des Windows-Explorers für die markierte Datei. Diesen Befehl finden Sie auch auch im lokalen Menü (rechte Maustaste) der Dokumententabelle.

Detail-Dokumente: Zeigt eine Liste mit abhängigen Dokumenten. Diese Sonderfunktion wird vom Inventor-Einrichtungsassistenten aktiviert. Sie können damit auf Baugruppen zugreifen.


Menü Erstellen

Navigation: Menü-Referenz >

Menü Erstellen

Menü: Erstellen

Die Registerkarte Erstellen des Menübandes beinhaltet Funktionen, um neue Dokumente oder Aufgaben zu erstellen, Papierbelege einzulesen und bestehende Dateien und E-Mails zu importieren.

Gruppe Neu

Dokument: Ein neues Dokument mit Standardeinstellungen anlegen.
Kurztaste: Strg+N
Siehe auch: Dokumentvorlagen

Vorlagen | [Name] erstellt ein neues Dokument mit Hilfe der gewählten Vorlage.

Vorlagen | Dokumentvorlagen bearbeiten: Vorhandene Vorlagen bearbeiten und neue erstellen.

Kopie: Das markierte Dokument wird kopiert. Sie können hiermit ein neues Dokument auf Grundlage eines vorhandenen erstellen.
Kurztaste: Strg+K

Klon: Die Funktion erstellt einen Klon des markierten Dokuments. Der Dokumentdatensatz wird kopiert, im Gegensatz zu Kopie wird die Datei allerdings nicht kopiert, der Datensatz zeigt vielmehr auf die gleiche Datei.
Kurztaste: Strg+U

Version: Den aktuellen Stand des Dokumentes archivieren. Der Office Manager kann zu jedem Dokument mehrere Versionsstände verwalten.

Aufgabe: Eine Tätigkeit für das markierte Dokument anlegen.

Gruppe Scannen

Dialogscan: Papierdokumente im Dialogfenster scannen.
Kurztaste: F6

Scanprofile | [Name]: Papierbelege mit vorbereiteten Profilen digitalisieren.
Kurztaste: Sie können individuelle Kurztasten festlegen.

Scanprofile | Scan-Ziel: Legt fest, ob der Scan als neues Dokument archiviert, als zusätzliche Seiten an das markierte angefügt oder extern gespeichert werden soll.

Scanprofile | Scanprofile bearbeiten: Vorhandene Profile anpassen und neue hinterlegen.

Sceye: mit Sceye-Dokumentenkamera digitalisieren.
Der Menübefehl ist nur bei angeschlossener Sceye sichtbar.

Gruppe Importieren

Drag&Drop startet den Windows-Explorer. Sie können Dateien mit der Maus vom Explorer auf den Office Manager ablegen.
Siehe auch: Attribute per Drag&Drop ändern.

Importieren: Funktion für die umfangreiche Übernahme bestehender Dateien, beispielsweise Datenträger durchsuchen und Zwischenablage überwachen.

Faximport: Durchsucht das Faxeingangsverzeichnis nach neuen Dokumenten und importiert diese in das Archiv. Dieser Befehl ist nur in der Enterprise-Version sichtbar und nur, wenn der manuelle Faximport aktiviert ist.


Menü Bearbeiten

Navigation: Menü-Referenz >

Menü Bearbeiten

Menü: Bearbeiten

Zwischenablage-Funktionen und Daten im Archiv ändern.

Gruppe Dokument

Eigenschaften: Dokumentattribute, wie Name, Nummer und Projekt ändern.
Kurztaste: Alt+Eingabe oder Alt+Doppelklick

Löschen: Löscht markierte Dokumente aus der Archivdatenbank und, wenn gewünscht, auch die Dokumentdateien vom Datenträger.
Kurztaste: Strg+Entf.

Verknüpfen kombiniert die markierten Dokumente miteinander und hebt Kombinationen auf.

Erkennen | OCR-Texterkennung führt nachträglich eine Texterkennung für gescannte Dokumente durch. Dies ist nur möglich, wenn noch kein Text erkannt wurde und die Datei nicht schreibgeschützt ist. Die Erkennung startet verzögert in einer Hintergrundfunktion, wird also nicht sofort ausgeführt.

Erkennen | Dokumentenerkennung führt die Standard-, E-Rechnungs- und KI-Dokumentenerkennung aus, um nachträglich das Belegdatum, den Kontakt und weitere Dokumenteigenschaften zu ermitteln.
Kurztaste: Umsch+Strg+R

Beide Erkennen-Funktionen werden normalerweise bereits in den Scan- und Importprofilen ausgeführt, können mit dem Menübefehl aber auch nachgeholt werden.

Verschlüsseln: Adobe Acrobat PDF-Dokumente revisionssicher archivieren. Der Schutz kann nicht mehr aufgehoben werden.

Archivieren: Langzeitarchivierung alter, nicht mehr im Zugriff befindlicher Dokumente.
Siehe auch: Menü Ansicht | Archivierte Dokumente
Dieser Menüeintrag ist nur in der Ansicht "Aktive Dokumente" aktiv.

Wiederherstellen stellt zuvor archivierte und gelöschte Dokumente wieder her.
Dieser Menüeintrag ist nur in den Ansichten "Archivierte Dokumente" und "Papierkorb" aktiv.

Blockchain: Revisionssicherheit auf der Blockchain. Absicherung wichtiger Belege und beispielsweise Schutz von Urheberrechten.
Kurztaste: Strg+D

Gruppe Zwischenablage

Einfügen: Fügt den Inhalt der Zwischenablage in das aktivierte Eingabefeld oder Datentabelle ein.
Kurztaste: Strg+V

Kopieren: Kopiert den markierten Text oder die markierten Datensätze in die Zwischenablage.
Kurztaste: Strg+C
Siehe auch: Kopien und Klone sowie weitere Kopierfunktionen.

Ausschneiden löscht den markierten Text und legt ihn in der Zwischenablage ab.
Kurztaste: Strg+X

Alles markieren: Markiert den gesamten Text im aktiven Eingabefeld, alle Projekte im Navigator oder alle Datensätze in der Tabelle.

Löschen: Löscht den markierten Text, ohne ihn in der Zwischenablage abzulegen. Wenn Dokumente, Kontakte oder Aufgaben markiert sind, dann werden diese nach Rückfrage gelöscht.
Kurztaste: Entf.

Rückgängig: Ausgeführte Funktionen widerrufen.


Menü Ansicht

Navigation: Menü-Referenz >

Menü Ansicht

Menü: Ansicht

Gruppe Anzeigen

Tipp: Wenn Sie beim Wechseln der Ansicht die Umschalttaste festhalten, werden automatisch die verknüpften Datensätze gesucht.

Dokumente (in Enterprise-Edition Aktive Dokumente): Wechselt zu den aktiven, im täglichen Zugriff befindlichen Dokumenten.

Archivierte Dokumente: Wechselt zur Ansicht der archivierten Dokumente.

Kontakte: Wechselt zur Kontaktverwaltung (Customer-Relationship-Management)

Aufgaben: Zeigt den Terminplaner mit den Aufgaben (Workflow).

Papierkorb: Wechselt zum Dokumenten-Papierkorb.

Gruppe Tabelle

Datensätze in Speicher laden: Wenn markiert ist, werden die Datensätze in den Arbeitsspeicher geladen. Dies ist Voraussetzung für sortieren und gruppieren.

Editieren: Bearbeitung der Attribute direkt in der Tabelle.
Kurztaste: F2, wenn die Tabelle den Eingabefokus hat.

Gruppieren: Gruppierung der Dokumententabelle nach Felder, wie z. B. dem Projekt. Der Mausschalter ist geteilt, mit Klick auf den unteren Bereich wird ein Menü zum Speichern und Laden von Gruppierungen geöffnet.

Gruppieren | Gruppierung zurücksetzen: Die Tabelle nicht mehr gruppieren.

Gruppieren | Gruppierung speichern: Die derzeitige Darstellung speichern und im Menü hinterlegen.

Gruppieren | Gruppierung laden: Zu einer zuvor gespeicherte Darstellung zurückkehren. Halten Sie die Strg-Taste gedrückt, um einen Eintrag zu entfernen.

Knoten öffnen: Öffnet alle Baumknoten in der gruppierten Tabelle.

Knoten schließen: Schließt alle Baumknoten in der gruppierten Tabelle.

Immer geöffnet: Die Baumknoten werden automatisch expandiert.

Gruppe Anpassen

Anpassen | Menüband anpassen: Einstellungen der Menüs und Symbolleisten anpassen. Beachten Sie bitte, dass im Ribbon-Menü kein Wechsel der Registerseiten möglich ist, während diese Funktion ausgeführt wird. Rufen Sie den Befehl bitte mit dem Pfeil in der Schnellstartleiste auf.

Anpassen | Menüband zurücksetzen: Menüs, Symbolleisten und Tabelleneinstellungen werden auf den Standard zurückgesetzt. Normalerweise verwenden Sie aber den Befehl Menüband anpassen und klicken im Dialog links unten auf Zurücksetzen.

Anpassen | Layout: Das Layout der Archiv- oder Kontaktdatenbank wählen. Hiermit werden u. a. die Datenfelder festgelegt, welche für die Suche und die Datenerfassung bereitstehen.

Anpassen | Layout entwerfen: Das gewünschte Layout anpassen.

Anpassen | Sprache: Wahl der Benutzersprache, wie deutsch, englisch oder polnisch. Bei [automatisch] wird - sofern unterstützt - die Sprache des Betriebssystems verwendet.

Anpassen | Feldauswahl: Auswahl der sichtbaren Tabellenspalten.

Stil: Design der Benutzeroberfläche für die Farb- und Schriftgestaltung wählen. Vorschaubilder finden Sie auf der Website.


Menü Hilfe

Navigation: Menü-Referenz >

Menü Hilfe

Menü: Hilfe

Gruppe Kurzhilfe

Hinweise: Wenn diese Option markiert ist, dann werden Kurzinformationen zu einer Komponente eingeblendet, sobald die Maus auf dieser ruht.

Direkthilfe: Aufruf der Direkthilfe zu den einzelnen Programmkomponenten.
Kurztaste: Umsch+F1

Gruppe Dokumentation

Hilfethemen: Aufruf der Programm-Hilfe.

Benutzerhandbuch öffnet diese Dokumentation im PDF-Format.

Kurzanleitungen zu den wichtigsten Programmfunktionen im PDF-Format.

Info über Office Manager DMS, Programmversion und Impressum.

Gruppe Internet

Internet | Homepage öffnet die Programm-Homepage in Ihrem Browser.

Internet | Social Media: Aktuelle Infos und Supportartikel per RSS-Feed sowie Newsletter oder X-Timeline abonnieren.

Internet | Support und FAQ öffnet die Support-Seiten mit Antworten auf häufige Fragen.

Internet | Hotline-Blog: Im Web-Log der DMS-Hotline finden Sie Tipps zur Programmbedienung und allgemein zur Dokumentenarchivierung. Sie können an Diskussionen teilnehmen und Fragen stellen.

Internet | Online Shop: Öffnet den Online-Shop in Ihrem Browser. Sie können die Vollversion und weitere Produkte für Ihr Dokumentenmanagement im Shop beziehen.

Internet | Version registrieren: Online-Registrierung der Testversion, Bestellung der Vollversion.

Internet | Software aktualisieren prüft, ob ein aktuelles Servicepack für Ihre DMS-Version verfügbar ist - am besten regelmäßig prüfen. Sie benötigen Administrator-Rechte unter Windows.

Internet | Supportanfrage per E-Mail senden.

Internet | Fernwartung startet das Programm TeamViewer. Hiermit wird eine eine gemeinsame Betrachtung Ihres Desktops und eine Fernwartung durch den Support ermöglicht.

Neuigkeiten bietet den direkten Zugriff auf RSS-Feeds mit aktuellen Support-Artikeln. Mit Klick auf den Pfeil des Mausschalters wird die Liste der RSS-Beiträge geöffnet, ein Klick auf den Schalter aktualisiert die Liste.

Je nach Installation finden Sie hier weitere Menüeinträge für Scannerhandbücher u. ä.,OEM-Versionen können andere Menübefehle haben.


Kontextmenü Kontakt

Navigation: Menü-Referenz >

Kontextmenü Kontakt

Menü: Kontakt

Dieses Menü ist nur in der Tabellenansicht Kontakte sichtbar.

Gruppe Erstellen

Kontakt: Einen neuen Kontakt hinzufügen.
Tipp: Sie können auch Kontakte per Drag&Drop in die Tabelle einfügen.

Aufgabe: Eine neue Tätigkeit für den markierten Kontakt planen.

Serienbrief: Brief an alle gesuchten Kontakte schreiben.

Gruppe Bearbeiten

Eigenschaften: Die markierten Kontakte bearbeiten.
Kurztaste: Alt+Eingabe oder Doppelklick

Löschen: Die markierten Kontakte endgültig aus der Datenbank entfernen.

Gruppe Suchen

Suchen | Suchen: Kontakte entsprechend den primären Suchfeldern filtern.

Suchen | Felder leeren löscht den Text der primären Suchfelder.

Dokumente: sucht alle Dokumente, die dem markierten Kontakt zugeordnet sind und wechselt zur Ansicht der Dokumente.

Siehe auch

CRM-Kontaktmanagement


Kontextmenü Aufgabe

Navigation: Menü-Referenz >

Kontextmenü Aufgabe

Menü: Aufgabe

Dieses Menü ist nur in der Tabellenansicht Aufgaben sichtbar.

Gruppe Erstellen

Aufgabe: Eine neue Tätigkeit planen.

Gruppe Bearbeiten

Eigenschaften: Die markierte Tätigkeit ändern.
Kurztaste: Alt+Eingabe oder Doppelklick

Erledigen: Die markierte Tätigkeit löschen. Die Erledigung wird am verknüpften Dokument oder Kontakt protokolliert.

Gruppe Suchen

Suchen lädt die Aufgaben neu aus der Datenbank. Nutzen Sie diese Funktion regelmäßig, um Änderungen zu sehen, die von anderen Benutzern durchgeführt wurden.

Felder leeren springt im Montagskalender zum heutigen Datum.

Dokumente (oder Start | Suchen | Verknüpfungen) sucht das der Aufgabe zugeordnete Dokument und wechselt zur Ansicht der Dokumente.
Mit Start | Verwenden | Öffnen oder Strg+O können Sie das verknüpfte Dokument direkt öffnen.

Kontakte (oder Start | Suchen | Verknüpfungen) sucht den mit der Aufgabe verbundenen Kontakt und wechselt zur Ansicht der Kontakte.

Gruppe Navigieren

Heute springt im Kalender zum heutigen Tag.

Datum: Dialogauswahl der Anordnung und Markierung eines Datums.

Nächste 7 Tage springt zum heutigen Tag und ordnet die nächsten sieben Tage in einer Wochenansicht an.

Gruppe Anordnen

Tag stellt einen einzelnen Tag im Terminplaner dar.

Mo.-Fr. stellt eine Arbeitswoche ohne Samstag und Sonntag dar.

Woche: Gesamte Woche mit Samstag und Sonntag.

Monat: Ansicht eines Monats.

Zeitleiste ordnet die Aufgaben entlang einer Zeitskala von links nach rechts chronologisch an.

Jahr: Kalenderansicht über ein komplettes Jahr.

Balken zeigt die Aufgaben als horizontale Balken entlang der Zeitachse an.

Agenda zeigt die Aufgaben untereinander in einer tabellarischen Ansicht.

Gruppe Ansicht

Anpassen | Zeitskalierung setzt die Größe der Zeitauswahlleiste auf die angegebenen Minutenblöcke.

Anpassen | Datumsnavigator legt fest, ob und wo der kleine Monatskalender dargestellt wird.

Anpassen | Wochenende komprimieren: Samstag und Sonntag teilen sich in der Wochenansicht eine Tageszelle.

Anpassen | Arbeitsstunden schaltet in der Zeitleiste die Sichtbarkeit von Nicht-Arbeitszeiten um.

Anpassen | An Zeitschlitzen fangen verbindet Benutzeraufgaben visuell mit den Zeitblöcken im Planungsbereich.

Ressourcen: Aufgaben können verschiedenen Ressourcen, beispielsweise Mitarbeitende, Teams und Abteilungen zugewiesen sein. Mit diesem Menübefehl werden die Aufgaben dieser Ressourcen ein- oder ausgeblendet.

Ressourcen | Gruppierung zurücksetzen stellt die Aufgaben aller Ressourcen in einer gemeinsamen Ansicht dar.

Ressourcen | Nach Datum gruppieren: Eigener Terminplaner für jeder gewählte Ressource mit Gruppierung nach Datum.

Ressourcen | Nach Ressource gruppieren: Eigener Terminplaner für jeder gewählte Ressource mit Gruppierung nach Ressourcen.

Siehe auch

Aufgabenverwaltung


Kontextmenü Navigator

Navigation: Menü-Referenz >

Kontextmenü Navigator

Menü: Navigator

Dieses Menü ist sichtbar, wenn der Projektnavigator den Eingabefokus hat. Sie können auch das lokale Menü des Navigators verwenden, indem Sie mit der rechten Maustaste auf ein Projekt klicken.

Gruppe Ansicht

Suchen: Geben Sie bitte den gesuchten Projektnamen oder einen Teil davon ein.

Aktualisieren: Lädt die Projektliste neu, um beispielsweise die Änderungen von anderen Mitarbeitern einzulesen.
Kurztaste: F5, wenn der Navigator den Eingabefokus hat.

Knoten öffnen: Alle Knoten im Projektbaum einblenden.

Knoten schließen: Alle untergeordneten Knoten im Projektbaum ausblenden.

Optionen | Genaue Suche: Wenn diese Option markiert ist, werden nur Dokumente gefunden, die im markierten Projekt abgelegt sind. Ist "Genaue Suche" nicht markiert, dann werden alle Dokumente gefunden, deren Projektzuordnung mit dem markierten beginnt - unter anderem auch die Dokumente in Unterprojekten. Siehe auch Jokerzeichen $.

Optionen | Knoten erweitern: Die Baumknoten automatisch erweitern, sobald diese markiert werden.

Optionen | Archiv-Schnellzugriff blendet oberhalb des Navigators eine Auswahlbox zum Öffnen der Archivdatenbanken ein.

Gruppe Bearbeiten

Neu | Neuer Eintrag: Ein neues Projekt auf der Ebene des markierten hinzufügen.

Neu | Neuer Untereintrag: Dem markierten Projekt ein Unterprojekt hinzufügen.

Eigenschaften: Projekt ändern und umbenennen. Enthaltene Dokumente werden angepasst.
Kurztaste: Alt+Doppelklick oder F2, wenn der Navigator den Eingabefokus hat.

Kopieren: Die markierten Projekte in die Zwischenablage kopieren.
Kurztaste: Strg+C

Einfügen: Projekte aus der Zwischenablage einfügen.
Kurztaste: Strg+V

Löschen entfernt die markierten Projekte.

Alles markieren: Alle Hauptprojekte auswählen.

Auswahllisten: Projekte und andere Auswahllisten bearbeiten. Hierfür wird ein eigenes Dialogfenster geöffnet. Sie haben unter anderem auch die Möglichkeit, Projektlisten in Dateien zu speichern und aus diesen zu laden.

Siehe auch

Der Projektnavigator


Kontextmenü Administrator

Navigation: Menü-Referenz >

Kontextmenü Administrator

Menü: Administrator

Dieses Menü ist nur sichtbar, wenn Sie als Office Manager-Administrator angemeldet sind.

Gruppe Administration

Administrator | Abmelden: Die Administratorebene verlassen.
Dieser Befehl befindet sich auch im Menü Datei | Optionen.

Administrator | Erweiterte Einstellungen | "Gemeinsame Dateien" öffnen: Öffnet den Ordner Gemeinsame Dateien im Windows-Explorer.

Administrator | Erweiterte Einstellungen | INI-Datei öffnen: Öffnet die admin.ini im Editor.

Administrator | Erweiterte Einstellungen | INI erneut öffnen liest die admin.ini nach Änderungen neu ein.

Administrator | Erweiterte Einstellungen | Hilfe zur INI-Datei öffnet dieses Hilfethema.

Administrator | Logdatei öffnen: Öffnet die Fehler-Logdatei.

Administrator | Layout aktualisieren: Änderungen der Attribute im aktuell verwendeten Layout durchführen.
Ein manueller Aufruf dieser Funktion ist nur erforderlich, wenn Sie mehrere Layouts verwenden.

Administrator | Dokument löschen (DSGVO): Administratives Löschen aus Datenschutzgründen.

Administrator | Information zu den geöffneten Datenbanken und Programmeinstellungen.
Dieser Befehl befindet sich auch im Menü Datei.

Administrator | Info Volltextindex: Indexierte Wörter des markierten Dokuments anzeigen.

Administrator | Info Zugriffsrechte: Dateizugriffsrechte des markierten Dokuments anzeigen.

Administrator | Tabelle anzeigen: Datentabelle der Archiv-, Kontakt- oder Anwendungsdatenbank öffnen.

Administrator | Hilfe öffnet das Hilfethema "Administrator".

Das Menü beinhaltet weitere Befehle von den Registerseiten Datei und Ansicht.

Gruppe Skript

SQL-Abfrage | SQL-Editor öffnet den Editor für die Eingabe von SQL-Datenbankbefehlen.

SQL-Abfrage | Abfrage ausführen: Textdatei mit SQL-Befehlen ausführen.

SQL-Abfrage | [1 Name]: Führt eine SQL-Datei im Verzeichnis (gemeinsame Dateien)\SQL\Menu aus.
Wenn die Umschalttaste gedrückt und der Administratormodus aktiv ist, wird die Datei im Editor geöffnet.

Makro | Makro-Editor öffnet den Skripteditor.

Makro | Makro ausführen: Makrodatei zur Ausführung im Öffnen-Dialog wählen.

Makro | [1 Name]: Führt ein Makro im Verzeichnis (gemeinsame Dateien)\Macro\Menu aus.
Wenn die Umschalttaste gedrückt und der Administratormodus aktiv ist, wird das Makro im Skripteditor geöffnet.


Kontextmenü Docking

Navigation: Menü-Referenz >

Kontextmenü Docking

Menü: Docking

Dieses Menü ist nur während Docking-Operationen, dem Verschieben vom Elementbereichen sichtbar. Zur Aktivierung wählen Sie bitte zuvor den Menübefehl Ansicht | Anpassen | Layout entwerfen | Bereiche positionieren.

Siehe auch Video

Menübefehle

Bereiche positionieren: Klicken Sie diesen Befehl erneut an, um den Docking-Modus zu verlassen.
Dieser Befehl befindet sich auch im Menü Ansicht | Anpassen.

Bereiche zurücksetzen: Das Layout des Hauptfensters auf den Auslieferungszustand zurücksetzen.

Projektnavigator: Den Navigator ein- oder ausblenden.

Bereiche anpassen

Das Programmhauptfenster ist in die Bereiche Hauptmenü, Projektnavigator, Suchfelder, Ergebnistabelle und Dokumentenvorschau aufgeteilt. Sie können diese Bereiche verschieben und in der Größe anpassen. Wählen Sie dazu den Menübefehl Ansicht | Anpassen | Layout entwerfen | Bereiche positionieren, das oben beschriebene Kontextmenü wird geöffnet und die Bereiche können jetzt verschoben werden. Die Dokumentenvorschau können Sie im Gegensatz zu den anderen Bereichen übrigens immer verschieben, nicht nur in diesem Docking-Modus.

Vorgehen

Klicken Sie auf die Titelzeile eines Bereiches und halten Sie die Maustaste fest. Sie können den Bereich verschieben und an anderer Stelle andocken.

Zum Andocken bewegen Sie die Maus auf eines der Diamant-Führungssymbole:

Mit dem Symbol [image] in der Titelleiste wird der Bereich geschlossen, dies ist nur bei der Vorschau und dem Projektnavigator möglich.

Die Stecknadel [image] aktiviert die Funktion "automatisches Verbergen". Der Bereich ist dann nur sichtbar, wenn sich die Maus in diesem befindet.

Siehe auch Microsoft: Anpassen von Fensterlayouts


Menüband anpassen

Navigation: Menü-Referenz >

Menüband anpassen

Programm-Menüs anpassen

Sie können die Menüs an Ihre individuellen Wünsche und Arbeitsabläufe anpassen. Die Einstellungen werden für jeden Benutzer gesondert gespeichert. Funktionen, die bei der alltäglichen Arbeit mit dem Dokumentenmanager immer wieder genutzt werden, sollten am besten auf der Registerseite Start und/oder der Symbolleiste für den Schnellzugriff platziert werden, um unnötige Mausklicks zu vermeiden.

Der Systemadministrator hat zusätzlich die Möglichkeit, sicherheitsrelevante Programmfunktionen zu sperren oder nur für ausgewählte Anwendende freizugeben.

Das Dialogfenster "Anpassen" öffnen

Wählen Sie bitte den Menübefehl Ansicht | Anpassen | Menüband anpassen.

Das Fenster "Menüband anpassen" wird geöffnet:

Screenshot: Menüband anpassen

Menübefehle platzieren

Links sind die verfügbaren Befehle aufgelistet. Im Kombinationsfeld oberhalb der Liste können Sie bestimmen, welche in der Liste gezeigt werden. Wählen Sie beispielsweise "Alle Befehle".

Auf der rechten Seite finden Sie die Menüstruktur mit den Registerseiten.

Markieren Sie links den Befehl, den Sie dem Menü hinzufügen möchten. Öffnen Sie auf der rechten Seite die Struktur und markieren dort den Befehl, hinter dem der gewünschte platziert werden soll. Klicken Sie in der Mitte auf den Pfeil Richtung rechts.

Führen Sie alle gewünschten Anpassungen durch und bestätigen Sie mit OK.

Weitere Einstellungen finden Sie auf der Seite Optionen und in den Programmeinstellungen auf der Seite Ansicht | Menü.

Menüänderungen verhindern

Wenn Sie Änderungen verhindern möchten, dann können Sie diese Funktion sperren oder die Menüeinstellung im Layout hinterlegen.


Die Datentabelle

Navigation: »Kein übergeordnetes Kapitel«

Die Datentabelle

Die Datentabelle

Im unteren Bereich der Programmoberfläche befindet sich die Tabelle mit den Dokumenten und Kontakten:

Es werden immer die Daten gezeigt, die den eingegebenen Suchkriterien entsprechen. Doppelklicken Sie zum Öffnen auf ein Dokument bzw. einen Kontakt.

Mit den Registerkarten Aktive Dokumente, Archivierte Dokumente, Kontakte, Aufgaben und Papierkorb unterhalb der Tabelle schalten Sie zwischen den Tabellenansichten um.

Zum Sortieren der Tabelle klicken Sie bitte auf die Spaltenüberschrift oder verwenden Sie das lokale Popupmenü.

Die Daten können anhand beliebige Attribute (Projekt, Kategorie, ..) in einer Baumdarstellung gruppiert werden. Nutzen Sie diese Möglichkeit z. B. auch, um Dokumente per Drag&Drop von einem Projekt zu einem anderen zu schieben.

Bestimmen Sie, welche Felder in der Tabelle angezeigt werden und legen Sie die Breite und Reihenfolge der Felder mit der Maus fest. Siehe hierzu unter "Das Programm anpassen".

Hinweise:

Sortieren und Gruppieren stehen nur zur Verfügung, wenn alle Datensätze in den Speicher geladen werden (Menü Ansicht | Tabelle | Datensätze in Speicher laden).

Fehlender Dokumententyp

Falls in der Spalte Dokumenttyp "(unbekannt)" steht, dann ist keine oder eine falsche Anwendungsdatenbank geöffnet. Eine ausführliche Anleitung zur Problembehebung finden Sie im Hotline-Blog .


Tabelle sortieren

Navigation: Die Datentabelle >

Tabelle sortieren

Datensätze sortieren

Die Dokumente können in der Tabelle beliebig sortiert werden.

Klicken Sie einfach mit der linken Maus auf den Tabellenkopf, nach welchem Sie die Tabelle sortieren möchten.

Oder:

Klicken Sie mit der rechten Maustaste auf den Kopf und wählen Sie im Kontext-Menü den Eintrag Aufsteigend sortieren bzw. Absteigend sortieren.

Beispiel: Klicken Sie mit der linken Maustaste auf den Tabellenkopf Name, die Tabelle wird nach den Dokument-Namen aufsteigend sortiert. Rechts neben dem Wort "Name" erscheint ein Pfeil, der die aktuelle Sortierung zeigt:

steht für aufsteigende Sortierung

steht für absteigende Sortierung

Sortierreihenfolge

Neben oben genannter auf- oder absteigenden Sortierung wird zwischen numerischer und alphanumerischer Sortierung unterschieden:

Numerisch | Alphanumerisch
1 2 10 21 10000 | 1 10 10000 2 21 abc

Attribute, die in numerischen Datenfeldern gespeichert sind, werden auch numerisch sortiert. Datentypen "Zeichenkette" werden alphanumerisch sortiert. Siehe auch Menü Datei | Datenbank | Anpassen | Felder definieren.

Über mehrere Attribute sortieren

Um anhand mehrerer Attribute gleichzeitig zu sortieren, klicken Sie bitte auf den ersten Tabellenkopf, halten Sie anschließend die Umschalttaste fest und klicken Sie auf weitere Tabellenköpfe. Wenn Sie die Dokumente z. B. nach dem Projekt und der Nummer sortieren möchten: Klicken Sie auf die Spaltenüberschrift Projekt, die Tabelle ist jetzt nach den Projekten sortiert. Drücken Sie die Umschalttaste und halten Sie diese fest. Klicken Sie mit der Maus auf die Spaltenüberschrift Nummer, die Dokumente werden jetzt zusätzlich anhand der Nummer sortiert.

Sortierung zurücksetzen

Wenn Sie die Sortierung zurücksetzen möchten, dann halten Sie bitte die Taste Strg fest und klicken Sie mit der linken Maustaste auf die Spaltenüberschrift. Alternativ können Sie den Befehl Sortierung zurücksetzen im Popupmenü verwenden.

Hinweis: Die Sortierung und Gruppierung der Tabelle ist nur möglich, wenn die Option "Datensätze in Speicher laden" aktiviert ist.

Siehe auch

Datensätze gruppieren


Tabelle gruppieren

Navigation: Die Datentabelle >

Tabelle gruppieren

Tabelle gruppieren

Wählen Sie den Menübefehl Ansicht | Tabelle | Gruppieren. Über der Tabelle wird ein leerer grauer Bereich gezeigt. Wenn Sie nun per Drag&Drop einen Tabellenkopf dort ablegen, werden die Dokumente oder Kontakte nach diesem Feld gruppiert.

Beispiel: Klicken Sie mit der linken Maustaste auf den Tabellenkopf Dokumenttyp, halten Sie die Maustaste fest, schieben Sie die Maus auf den Gruppen-Bereich und lassen Sie die Maustaste wieder los. Die Datensätze sind nun nach Dokumenttyp gruppiert.

Oder:

Klicken Sie mit der rechten Maustaste auf die Spaltenüberschrift und wählen Sie im Kontextmenü den Eintrag Nach diesem Feld gruppieren.

Beachten Sie auch den Unterpunkt Tabelle in den lokalen Menüs (rechte Maustaste) der Tabelle mit folgenden Befehlen:

·Gruppierung zurücksetzen: die Gruppierung wird aufgehoben.

·Knoten öffnen: öffnet alle Baumknoten.

·Knoten schließen: schließt alle Baumknoten.

·Immer geöffnet: alle Baumknoten sind automatisch expandiert.

Sonderfall Datum

Bei der Gruppierung nach einem Datumsfeld können Sie festlegen, welcher Zeitraum in einem Knoten zusammengefasst wird - beispielsweise alle Dokumente eines Tages oder eines Monats. Klicken Sie im Tabellenkopf bitte mit der rechten Maustaste auf die Spaltenüberschrift und wählen Sie im Popupmenü Datum-Gruppierung die gewünschte Option.

Gespeicherte Gruppierungen

Sie können Gruppierungen speichern und später schnell zu dieser Darstellung zurückkehren:

1.Gruppieren Sie die Tabelle, wie oben beschrieben, nach den gewünschten Feldern.

2.Klicken Sie auf die untere Hälfte des Schalters Gruppieren und dann auf Gruppierung speichern.

3.Vergeben Sie einen Namen, die entsprechenden Felder werden als Name vorgeschlagen.

4.Klicken Sie auf OK. Die aktuelle Gruppierung wird in Ihrem Benutzerverzeichnis gespeichert.

5.Wenn Sie erneut auf die untere Hälfte des Schalters Gruppieren klicken, finden Sie die gespeicherte Darstellung in der Liste.

6.Klicken Sie auf den gewünschten Eintrag unterhalb von Gruppierung laden, um schnell zu dieser Darstellung zu wechseln.

Die verschiedenen Tabellen für Dokumente und Kontakte haben unterschiedliche Datenfelder und somit auch ihre eigenen Listen.

Löschen

Wenn Sie einen Eintrag aus der Liste entfernen möchten, dann halten Sie bitte die Strg-Taste fest und klicken Sie auf den entsprechenden Listeneintrag.

Hinweis: Die Sortierung und Gruppierung der Tabelle ist nur möglich, wenn die Option "Datensätze in Speicher laden" aktiviert ist.

Siehe auch

Dokumente sortieren

Drag&Drop

Vorgabewerte aus Gruppierung


Datensätze markieren

Navigation: Die Datentabelle >

Datensätze markieren

Datensätze markieren

Im unteren Bereich der Programmoberfläche befindet sich die Tabellen mit den Dokumenten oder Kontakten sowie der Terminplaner.

Archivsuche mit primären Feldern

Einzelnes markieren

Klicken Sie mit der Maus auf einen Datensatz (Dokument, Kontakt oder Aufgabe), um diesen zu markieren. In obiger Abbildung ist ein Dokument markiert, es hat eine weiße Schrift auf blauem Hintergrund. Sie können auch schrittweise nach Text suchen, um ein gewünschtes Dokument zu markieren.

Anschließende Befehle, wie beispielsweise Öffnen Öffnen, beziehen sich immer auf dieses markierte Dokument.

Mehrere auswählen

Sie können aber auch mehrere Datensätze gleichzeitig markieren, um diese zum Beispiel per Drag&Drop in eine E-Mail zu kopieren. Klicken Sie bitte mit der Maus auf das erste Dokument. Drücken Sie die Strg-Taste und halten Sie diese gedrückt. Markieren Sie anschließend weitere Dokumente mit einem einfachen Mausklick. Lassen Sie die Strg-Taste erst los, wenn alle gewünschten Einträge markiert sind.

Wenn Sie jetzt auf z. B. Öffnen Öffnen klicken, werden alle markierten Dokumente geöffnet. Alternativ können Sie auch doppelt auf ein markiertes Dokument klicken.

Einen Bereich markieren

Klicken Sie mit der Maus auf das erste Dokument. Drücken Sie die Umschalttaste und halten Sie diese gedrückt. Klicken Sie mit der Maus auf das letzte zu markierende Dokument.

Alles markieren

Klicken Sie bitte auf ein beliebiges Dokument, um die Tabelle zu aktivieren. Wählen Sie anschließend im Menü Bearbeiten | Zwischenablage den Befehl Alles markieren oder drücken Sie Strg+A.

Markierung aufheben

Klicken Sie auf einen nicht markierten Datensatz, um nur diesen zu wählen. Falls alle markiert sind, dann halten Sie bitte die Strg-Taste fest und klicken Sie auf einen der markierten Datensätzen, um diesen zu demarkieren.

Siehe auch

Die Datentabelle

Schrittweise weitersuchen


Summieren und zählen

Navigation: Die Datentabelle >

Summieren und zählen

Berechnungen in der Dokumententabelle

Summe in Fußzeile

In der Dokumentenansicht können Sie eine Tabellen- und Gruppen-Fußzeile mit Summen einblenden:

1.Stellen Sie bitte sicher, dass alle Datensätze in den Arbeitsspeicher geladen werden (Menü Ansicht | Tabelle).

2.Klicken Sie mit der rechten Maustaste auf den Tabellenkopf und wählen Sie im lokalen Menü den Befehl Fußzeile.

3.Die Fußzeile wird im unteren Bereich der Tabelle dargestellt. Klicken Sie nun mit der rechten Maustaste auf diese Zeile und wählen Sie einen Eintrag aus dem Menü:
Summe: zeigt die Spaltensumme aller Dokumente der aktuellen Suche *)
Minimum: den kleinsten Wert der Spalte *)
Maximum: den größten Wert der Spalte *)
Anzahl: die Anzahl der Dokumente
Durchschnitt: den durchschnittlichen Wert der Spalte *)
Nichts: entfernt den Wert aus der Fußzeile.
*) berechnete Werte sind nur bei numerischen Datenfeldern möglich (siehe auch Datei | Datenbank | Anpassen | Felder definieren)

Zusätzlich können Sie auch eine Gruppenfußzeile in der gruppierten Tabelle verwenden, um beispielsweise die Summen eines Projekts oder Kunden zu vergleichen.

Umsatz in Gruppen-Fußzeile


Dokumentenmanagement

Navigation: »Kein übergeordnetes Kapitel«

Dokumentenmanagement

Der zentrale Manager für Ihre Dokumente und Kontakte

In diesem Kapitel:

Wie Sie...

Leeres Blatt neue Dokumente erstellen

Massenimport bestehende Dokumentdateien in das Archiv importieren

Scanner Papierdokumente digitalisieren

Revisionssicher Buchungsbelege revisionssicher archivieren

Suchen Ihre Dokumente jederzeit wiederfinden


Archiv öffnen

Navigation: Dokumentenmanagement >

Archiv öffnen

Archiv öffnen

Nach dem Start des Programms ist die Standard-Dokumentendatenbank bereits geöffnet. Um ein anderes Archiv zu laden, klicken Sie bitte im Menü Datei auf den Eintrag Archiv öffnen:

Screenshot: Datenbank öffnen

Markieren Sie die gewünschte Datenbank und klicken Sie auf Öffnen.

Archiv-Schnellzugriff

Wenn Sie oft zwischen verschiedenen Archiven wechseln, können Sie diese auch aus einer Liste oberhalb des Projektnavigators wählen. Sollte die Liste nicht sichtbar sein, dann klicken Sie bitte mit der rechten Maustaste auf den Projektnavigator und wählen Sie im lokalen Menü den Befehl Optionen | Archiv-Schnellzugriff, um diese einzublenden. Ab jetzt können Sie ein Archiv schnell öffnen, indem Sie es im Kombinationsfeld wählen.

Datenbank kopieren

Datenbanken im MS Access- und SQLite-Format (.omp, .omsl, .omen, .omcs) können Sie sehr einfach in diesem Dialogfenster kopieren. Klicken Sie dazu mit der rechten Maustaste auf die Datei und wählen Sie im lokalen Menü den Befehl Kopieren. Klicken Sie erneut mit der rechten Maustaste und wählen Sie Einfügen. Anschließend können Sie die neue Datei "Kopie von ...omp" umbenennen.

Um SQL-Datenbanken zu kopieren oder ein Archiv in ein neues Datenbankformat zu übertragen, öffnen Sie bitte zuerst das zu kopierende Archiv. Wählen Sie anschließend den Befehl Datei | Neues Archiv und aktivieren Sie auf der letzten Seite die Option Datensätze kopieren.


Revisionssicherheit

Navigation: Dokumentenmanagement >

Revisionssicherheit

Verfügbar in diesen Editionen

Buchungsbelege archivieren

Jeder Gewerbetreibende ist verpflichtet, geschäftliche Unterlagen über einen bestimmten Zeitraum aufzubewahren. Auch Privatleute sollten wichtige Belege archivieren und haben beispielsweise im Zusammenhang mit Leistungen an einem Grundstück eine Aufbewahrungspflicht zu beachten.

Insbesondere bei steuerrelevanten Dokumenten müssen Gewerbetreibende unter anderem die Grundsätze zur ordnungsmäßigen Führung und Aufbewahrung von Büchern, Aufzeichnungen und Unterlagen in elektronischer Form sowie zum Datenzugriff (kurz GoBD) einhalten.

Office Manager DMS beinhaltet hierfür einen besonderen Archivierungsmodus, welcher

·dem Steuerprüfer eine klare Aussage darüber gibt, ob ein Dokument seit der Archivierung unverändert ist.

·Die Erfassung sowie jede zulässige Änderung, beispielsweise die OCR-Texterkennung, die Erweiterung von Dokumenten und das Verschlüsseln, wird dokumentiert.

·Beim Ersetzen einer Datei, beispielsweise einer nachträglichen Rechnungskorrektur, bleibt der ursprüngliche Beleg als Versionsstand erhalten (vgl. GoBD Pos. 58).

·Dokumente und deren Versionen können nicht endgültig gelöscht werden. Ausnahmen: abgelaufene Aufbewahrungsfristen und administratives Löschen aus Datenschutzgründen.

·Warnung, wenn ungeeignete Scan- und Komprimierungsverfahren erkannt werden.

·Zur Gewährleistung der geforderten Revisionssicherheit sind einige Funktionen gesperrt.

Wichtig zu wissen

Das digitale Dokumentenmanagement unterstützt Sie bei der Einhaltung Ihrer Aufbewahrungspflichten. Dies bedeutet aber nicht, dass automatisch alle Vorschriften erfüllt sind. Im Absatz "12. Zertifizierung und Software-Testate" der GoBD heißt es:

Die Vielzahl und unterschiedliche Ausgestaltung und Kombination der DV-Systeme für die Erfüllung außersteuerlicher oder steuerlicher Aufzeichnungs- und Aufbewahrungspflichten lassen keine allgemein gültigen Aussagen der Finanzbehörde zur Konformität der verwendeten oder geplanten Hard- und Software zu. [...]
Positivtestate zur Ordnungsmäßigkeit der Buchführung - und damit zur Ordnungsmäßigkeit DV-gestützter Buchführungssysteme - werden weder im Rahmen einer steuerlichen Außenprüfung noch im Rahmen einer verbindlichen Auskunft erteilt.

Es gibt leider keine offizielle Bestätigung oder Zertifizierung einer Buchführungs- oder Archivierungssoftware, die gegenüber der Finanzbehörde bindend wirkt. Office Manager DMS ist ein technisches Hilfsmittel, welches Sie bei der Archivierung unterstützt und dem Prüfer eine klare Aussage darüber gibt, ob ein Beleg seit der Archivierung unverändert ist oder welche Veränderungen durchgeführt wurden.

GoBD-Modus aktivieren

Öffnen Sie bitte das gewünschte Dokumentenarchiv und wählen Sie den Menübefehl Datei | Optionen | Einstellungen. Wechseln Sie zur Registerseite Dokument | Revision. Wichtig: Um ein wiederkehrendes Umschalten dieses Manipulationsschutzes zu verhindern, kann der GoBD-Modus nur einmal aktiviert werden. Sollten Sie ihn später wieder deaktivieren, dann ist eine erneute Aktivierung in diesem Archiv nicht mehr möglich.

Revision und Steuerprüfung

Sie können einem Prüfer unmittelbaren Zugriff auf alle Daten gewähren oder einen Archivauszug nur mit den relevanten Daten des Prüfungszeitraums zur Verfügung stellen.

Prüfung durchführen

Um zu überprüfen, ob die Dokumente unverändert vorliegen, führen Sie bitte die Revision mit dem Menübefehl Datei | Datenbank | Pflege | GoBD-Prüfung aus.

Siehe auch

Manipulationssicherheit

E-Rechnung

Archivierung von Eingangsrechnungen

White Paper Buchungsbelege archivieren

GoBD

Aufbewahrungsfristen


Elektronische Rechnungen

Navigation: Dokumentenmanagement >

Elektronische Rechnungen

XRechnung, Factur-X und ZUGFeRD

Warum die E-Rechnung eine gute Idee ist

Rechnungen gibt es ganz klassisch auf Papier gedruckt, digital als PDF-Dokument und als echte "Elektronische Rechnung", kurz E-Rechnung. Die Begriffe "digital" und "elektronisch" sind im Zusammenhang mit den Rechnungen nicht synonym.

Digitale Rechnung bedeutet nur, dass diese nicht auf Papier gedruckt, sondern in Form einer digitalen Datei vorliegt. Die bekannteste Form ist das PDF-Dokument, bevorzugt per E-Mail verschickt. PDF ist aber nur eine Seitenbeschreibungssprache, Texte sind auf einer virtuellen Papierseite positioniert, damit wir Menschen diese wie ein gedrucktes Blatt Papier wahrnehmen können. Eine PDF-Rechnung ist menschenlesbar und nicht maschinenlesbar - ein Computer versteht nicht, welche Daten enthalten sind.

Der Medienbruch war unnötiger Aufwand

In den Unternehmen werden Rechnungen mit Computersoftware erstellt, diese Maschine kennt also die Daten. Dann kommt es aber zum Medienbruch: Aus strukturierten Daten wird menschenlesbarer Text in einer PDF oder auf Papier.

Was folgt, ist eine unnötige und fehleranfällige Arbeit: Der Empfänger muss die Rechnung manuell auslesen, die relevanten Daten – wie Rechnungsbetrag, Datum und Rechnungsnummer – wieder mühsam in sein eigenes System eingeben. Bestenfalls hilft eine komplizierte Software, den Text zu analysieren und die Rechnungsdaten zu erkennen. Dieser Prozess ist zeitaufwendig und birgt die Gefahr von Fehleingaben.

Elektronische Rechnung ist auch digital, beinhaltet aber maschinenlesbare Daten. Bei den Formaten ZUGFeRD und Factur-X ist die Rechnung eine Kombination aus beiden Welten, sie besteht aus einer menschenlesbaren PDF der eine maschinenlesbare XML-Datei angefügt ist. Die XRechnung ist allerdings nur eine XML-Datei, die der Computer versteht, der Mensch ohne EDV-Kenntnisse aber nicht.

E-Rechnung im E-Archiv

Office Manager ist eine elektronische Archivierungssoftware mit der Sie all Ihre Dokumente, Belege und Informationen übersichtlich verwalten und rechtssicher archivieren. Papierbelege werden gescannt, E-Mails und andere digitale Dokumente direkt importiert. Die Belegerkennung, die oben genannte komplizierte Software, hilft beim Lesen der Daten aus den Texten.

Mit der echten Elektronischen Rechnung kommt die Software besonders gut zurecht und versteht die Daten:

1.Die Dokumentenvorschau zeigt Rechnungen für den Menschen lesbar. Bei ZUGFeRD (CII- und UBL-Formate) und dem dazu kompatiblen Factur-X sehen Sie die PDF-Version. Bei XRechnungen eine Schnellansicht der wichtigsten Daten.

2.In den Pro- und Enterprise-Editionen werden die XML-Daten beim Import eingelesen und in die gewünschten Datenfelder des Rechnungsarchivs übernommen. Das Dokument wird also vollautomatisch beschrieben, sodass Sie dieses später anhand von Rechnungsnummer, Belegdatum, Artikel oder Lieferanten finden. Auch statistische Auswertungen sind mit den gesammelten Rechnungsbeträgen möglich.

3.Die Enterprise-Edition verarbeitet darüber hinaus auch die einzelnen Rechnungspositionen.

Dokumentenvorschau

Markieren Sie die Rechnung in der Dokumententabelle und aktivieren Sie die Vorschau, falls diese noch geschlossen ist.

·Bei ZUGFeRD und Factur-X sehen Sie das PDF-Dokument. Falls Sie auch die anliegende XML einsehen möchten, dann klicken Sie unterhalb der Seitenansicht auf die Anlage. Hieran ist auch zu erkennen, dass die PDF eine elektronische Rechnung beinhaltet. Die standardisierten XML-Dateinamen sind xrechnung.xml, ZUGFeRD-invoice.xml und factur-x.xml.

Vorschau für ZUGFeRD und Factur-X

·Eine XRechnung besteht nur aus den XML-Daten, die Vorschau zeigt einen Auszug als Schnellansicht. Voraussetzung ist die Einrichtung des Dokumenttypen für XRechnung.

Vorschau für XRechnung

·Für eine vollständige Ansicht der XRechnung öffnen Sie diese mit einem Doppelklick in der Tabelle. Installieren Sie hierfür beispielsweise den quelloffenen Quba-Viewer.

Vollständige Ansicht einer XRechnung in Quba


Dokumente erstellen

Navigation: Dokumentenmanagement >

Dokumente erstellen

Neue Dokument erstellen

Der Office Manager verwaltet Dokumente verschiedenster Windows-Anwendungen, Internetadressen, E-Mails und interne Textdokumente auf einer Oberfläche. Wenn Sie ein neues Dokument erstellen, dann brauchen Sie nicht mehr extra das entsprechende Windows-Programm zu starten. Legen Sie einfach das neue Dokument im Office Manager an, das zuständige Anwendungsprogramm startet dann automatisch.

Wechseln Sie im Menü bitte auf die Registerseite Erstellen, um neue Dokumente anzulegen:

·Dokument (Strg-N): erstellt ein neues, einzelnes Dokument. Der Eigenschaften-Dialog wird geöffnet und das Dokument nach Klick auf OK erzeugt und geöffnet.

·Vorlagen: erstellt ein neues Dokument mit Hilfe einer Vorlage.

·Kopie: das markierte Dokument wird kopiert und der Eigenschaften-Dialog geöffnet. Die Felder sind mit den Attributen des kopierten Dokuments vorbelegt. Nach einem Klick auf OK wird eine Kopie der ursprünglichen Dokumentdatei erstellt und geöffnet.

·Klon: erstellt einen Klon des markierten Dokuments.

Oder nutzen Sie die Import-Funktionen, um bestehende Dokumente in das Archiv zu übernehmen, beispielsweise:

·Scannen: Papierdokumente und Bilder einscannen.

·Automatisierter Import vom Dokumentenscanner.

·Drag&Drop: startet den Windows-Explorer. Sie können eine oder mehrere Dateien aus dem Explorer, E-Mailprogramm und vielen anderen Anwendungen per Drag&Drop in das Archiv importieren.

·Links und Dateien aus dem Webbrowser übernehmen.

·Importieren: durchsucht Datenträger nach Dokumentdateien und importiert diese in das Archiv.

Tipp: wenn die Dokumenttabelle gruppiert ist, werden neue Dokumente automatisch an die Daten der Gruppierung angepasst.


Neues Dokument

Navigation: Dokumentenmanagement > Dokumente erstellen >

Neues Dokument

Verfügbar in diesen Editionen

Ein Dokument erstellen

Wenn Sie ein neues Dokument erstellen, brauchen Sie nicht mehr das entsprechende Windows-Programm zu starten. Sie können das Dokument direkt im Dokumentenmanagement anlegen, das zuständige Anwendungsprogramm startet dann automatisch.

Ein Beispiel: Sie möchten einen neuen Brief an einen Kunden schreiben. Im Hauptmenü wählen Sie den Befehl Erstellen | Neu | Dokument, das Eingabefenster für neue Dokumente wird geöffnet. Anhand des Dokumenttyps wird jetzt das zuständige Windows-Programm ausgewählt, mit welchem das neue Dokument erstellt wird. Im Feld Vorlagendatei können Sie eine Vorlage für den neuen Brief auswählen. Das neue Dokument erhält einen Namen und wird einem Projekt zugeordnet. Um den Dateinamen brauchen Sie sich nicht zu kümmern. Sobald Sie auf OK klicken wird die Textverarbeitung gestartet und der Brief ggf. mit der Vorlagendatei vorbereitet. Der Brief wird erstellt, ausgedruckt und schließlich gespeichert. Sie können jetzt noch für sich oder Ihre Kollegen eine Tätigkeit erfassen.

Wenn Sie später wieder auf diesen Brief zugreifen möchten, können Sie das Dokument anhand der Archivattribute oder mit Hilfe des Volltextindex suchen. Wenn Sie z. B. einen Projektnamen angeben, werden alle Dokumente (Briefe, Tabellen, Zeichnungen, usw.) dieses Projekts in der Tabelle gezeigt. Ein Doppelklick auf den Brief startet wiederum die Textverarbeitung und öffnet den Brief.

Ausführliches Beispiel

Einen neuen Brief schreiben.

1.Wählen Sie bitte den Menübefehl Erstellen | Neu | Dokument. Das Eingabefenster für neue Dokumente wird geöffnet:

Screenshot: Archiv-Eigenschaften eines Dokuments

2.Dokumenttyp: Wählen Sie das zuständige Anwendungsprogramm, in diesem Fall Ihre Textverarbeitung aus der Liste Dokumenttyp. Im Feld Vorlage können Sie eine Dokumentvorlage für den neuen Brief auswählen.

3.Dokumentattribute festlegen: Geben Sie bitte die gewünschten Attribute, wie Nummer, Name, Projekt und Kategorie ein. Zum Bearbeiten der Auswahllisten klicken Sie bitte mit der rechten Maustaste auf das Kombinationsfeld und wählen im lokalen Menü den Befehl Auswahlliste.
Tipp: Sie können beliebige Attribute definieren. Siehe auch Felder definieren.

4.Klicken Sie jetzt bitte auf OK. Die Textverarbeitung wird gestartet und das Dokument als Kopie der gewählten Vorlage erstellt. Sie können jetzt den Brief verfassen, ausdrucken und speichern, der Dateiname ist bereits vergeben.

Screenshot MS Word

5.Eventuell möchten Sie jetzt noch für sich oder Ihre Kollegen eine Tätigkeit erfassen. Wählen Sie dazu im Hauptmenü den Befehl Erstellen | Neu | Aufgabe.

6.Wenn Sie später auf diesen Brief zugreifen möchten, geben Sie einfach die gesuchten Attribute in den primären Suchfeldern (Eingabefelder oberhalb der Dokumenttabelle) ein:

Wenn Sie z. B. einen Projektnamen angeben, werden alle Dokumente (Briefe, Tabellen, Zeichnungen, usw.) des Projekts in der Tabelle gezeigt. Für eine Suche im Volltextindex geben Sie bitte die entsprechenden Wörter im Eingabefeld Volltext ein.

Ein Doppelklick auf den Brief startet wiederum die Textverarbeitung und öffnet den Brief.

Siehe auch

Eigenschaften-Dialog


Dokumentenvorlagen

Navigation: Dokumentenmanagement > Dokumente erstellen >

Dokumentenvorlagen

Verfügbar in diesen Editionen

Dokumentenvorlagen

Wenn Sie häufig Dokumente erstellen, die sich ähnlich sind, können Sie den Vorgang mit Hilfe der Dokumentenvorlagen automatisieren. Eine Vorlage enthält die Dokumentattribute und die Datei.

Neues Dokument von Vorlage erstellen

Öffnen Sie das Untermenü Erstellen | Neu | Vorlagen. Hier finden Sie alle vordefinierten Dokumentenvorlagen:

Menü Dokument - Vorlagen

Klicken Sie auf die gewünschte Vorlage. Der Eigenschaften-Dialog für Dokumente wird geöffnet und die Attribute mit den Vorgaben der Vorlage ausgefüllt. Geben Sie bitte - sofern gewünscht - weitere Eigenschaften, wie Name oder Projekt ein und klicken Sie auf OK, um das Dokument zu erstellen.

Hinweis: In der Vorlage kann auch festgelegt werden, dass die Dokumente erstellt werden, ohne zuvor den Eigenschaftendialog zu öffnen. Bei solchen Vorlagen fehlen im Menü die drei Punkte hinter dem Vorlagennamen.

Siehe auch

Überblick Dokumente erstellen

Vorlagen definieren

1. Melden Sie sich bitte als Administrator an (Menü Datei | Optionen | Administrator), um eventuell verborgenen Vorlagen einzublenden.

2. Wählen Sie den Befehl Erstellen | Neu | Vorlagen | Dokumentvorlagen bearbeiten.

Screenshot: Liste Dokumentvorlagen bearbeiten

Klicken Sie im Bild auf die Komponenten, zu der Sie weitere Hilfe wünschen.

3. Klicken Sie auf Neu, um eine Vorlage zu erstellen:

Screenshot: Dokumentvorlage bearbeiten

Klicken Sie im Bild auf die Komponenten, zu der Sie weitere Hilfe wünschen.

Geben Sie eine Beschreibung ein und wählen Sie den Dokumenttyp. Wenn Sie eine Vorlagendatei eingeben, wird diese für das neue Dokument verwendet. Die Option Eigenschaftendialog öffnen wird i.d.Regel markiert, damit Sie die Attribute für neue Dokumente eingeben können. Mit Sichtbarkeit können Sie festlegen, wer diese Dokumentvorlage verwenden kann.

Auf der Seite Feldwerte geben Sie bitte die Attribut-Vorlagen ein, beispielsweise Kategorie (Feld category) = "Angebot".

Für die Automatisierung des Workflows können auch Makros definiert werden.

Klicken Sie auf OK, um die Vorlage zu speichern.

Siehe auch

Vorgabewerte für Dokumentattribute

Vorlagen importieren


Archivattribute aus Gruppierung

Navigation: Dokumentenmanagement > Dokumente erstellen >

Archivattribute aus Gruppierung

Vorgabewerte aus Gruppierung

Wenn Sie innerhalb der gruppierten Dokumenttabelle neue Dokumente erstellen oder importieren, werden die Attribute der Gruppierung in das neue Dokument kopiert.

Beispiel

Sie haben die Tabelle nach Kategorie und Status gruppiert. Ein Dokument im Knoten Kategorie="Dokumentation", Status="Normal" ist markiert:

Wenn Sie jetzt ein neues Dokument erstellen (beispielsweise Erstellen | Neu | Dokument), dann werden die Attribute der Gruppierung in das neue Dokument kopiert und anschließen der Eigenschaftendialog geöffnet:

Teil-Screenshot der wichtigsten Katalogattribute

Status und Kategorie wurden hier mit den Werten der Gruppierung vorbelegt. Das Projekt ist ebenfalls ausgefüllt, weil "Prinzenallee" im Projektnavigator markiert ist.

Sie können jetzt die vorgegebenen Attribute ändern und weitere Attribute, wie beispielsweise den Name eingeben.

Klicken Sie auf OK, um das Dokument zu erstellen.

Hinweis: Wenn Sie ein Dokument mit Hilfe einer Dokumentvorlage erstellen, haben die Attributvorgaben der Vorlage eine höhere Priorität. Falls in der Vorlage z. B. ein Status vorgegeben ist, hat das Dokument dessen Status, sobald der Eigenschaftendialog geöffnet wird.

Siehe auch

Vorgabewerte für Dokumentattribute

Die Dokumenttabelle

Dokumente erstellen


Kopien und Klone

Navigation: Dokumentenmanagement > Dokumente erstellen >

Kopien und Klone

Kopien und Klone

A. Kopie eines Dokuments

Sie können ein neues Dokument erstellen, indem Sie die Attribute und die Datei eines anderen Dokuments kopieren. Markieren Sie dazu bitte ein Dokument und wählen Sie den Menübefehl Erstellen | Neu | Kopie. Die Dokumentdatei wird kopiert und dem neuen Datensatz zugeordnet.

Falls Sie nur die Attribute ohne Datei übernehmen möchten, dann klicken Sie auf Erstellen | Neu | Kopie . Im Eigenschaftenfenster öffnen Sie die Liste Vorlagendatei und wählen die leere Zeile:

Auswahlliste der Vorlagedateien

B. Mehrere Datensätze für dieselbe Datei

Verfügbar in diesen Editionen

Mit der Funktion Erstellen | Neu | Klon können Sie mehrere Archiv-Datensätze zu einer Datei erstellen. Alle Klone verweisen auf dieselbe Dokumentdatei, Änderungen des Dateinamen werden automatisch in allen Klonen berücksichtigt.

Hiermit kann ein Dokument beispielsweise mehreren Projekten oder ein Bauteil mehreren Baugruppen zugeordnet werden.

Wenn in der Tabelle ein Klon markiert ist, dann können Sie sich mit dem Menübefehl Start | Suchen | Weitere | Klone alle weiteren Datensätze dieses Dokuments anzeigen lassen.

Siehe auch Mehrfachzuordnungen
Beachten Sie bitte, dass die Option Vorgabe für bestehende Dateien nicht für Klone gilt.

C. Kopieren über Zwischenablage

Sie können auch Dokumente zwischen verschiedenen Archiven kopieren oder ein neues Dokument als Kopie eines archivierten erstellen.

Innerhalb einer Archivdatenbank kopieren: Markieren Sie ein Dokument, wählen Sie Bearbeiten | Zwischenablage | Kopieren (Strg+C) und anschließend Einfügen (Strg+V). Dieses Vorgehen ähnelt dem Menübefehl Erstellen | Neu | Kopie (s. a. Punkt A).

Aus einer anderen Datenbank kopieren: Markieren Sie bitte ein Dokument und wählen Sie Bearbeiten | Zwischenablage | Kopieren. Öffnen Sie eine andere Archivdatenbank und klicken Sie auf die Dokumenttabelle, um diese zu aktivieren. Wählen Sie den Menübefehl Bearbeiten | Zwischenablage | Einfügen.

Tipp: Sie können den Office Manager auch mehrmals starten, unterschiedliche Archive öffnen und Dokumente per Drag&Drop von einem Fenster in das andere kopieren. Beachten Sie auch das lokale Menü der Datentabelle.


Dokumente importieren

Navigation: Dokumentenmanagement >

Dokumente importieren

Vorhandene Dokumente archivieren

Nutzen Sie die Import-Funktionen, um bestehende Dateien in das Dokumentenarchiv zu importieren:

·Drag&Drop startet den Windows-Explorer. Sie können eine oder mehrere Dateien aus dem Explorer per Drag&Drop auf die Dokumententabelle schieben, um diese zu importieren.

·Aus Zwischenablage einfügen: Dateien einfügen, die beispielsweise im Explorer kopiert wurden.

·Senden an: Dokumente vom Windows-Explorer an den Office Manager senden.

·Datenträger durchsuchen: Bulk-Import ganzer Verzeichnisstrukturen in das Archiv und Überwachung der Windows-Zwischenablage.

·Scannen mit Standard-Scanner: Papierdokumente und Bilder digitalisieren. Der angeschlossene Scanner wird über die Twain- oder WIA-Schnittstelle angesprochen.

·Scannen mit Dokumenten-Scanner: Gescannte Dokumente von selbsttätig arbeitenden Geräten, wie zum Beispiel Netzwerkscannern archivieren.

·Das DMS kann auch Verzeichnisse überwachen und neue Dokumentdateien automatisiert in die Archive übernehmen.

Siehe auch

Import-Profile

Automatische Dokumentenerkennung


Drag and Drop von Dateien und E-Mails

Navigation: Dokumentenmanagement > Dokumente importieren >

Drag and Drop von Dateien und E-Mails

Verfügbar in diesen Editionen

Dokumente per Drag&Drop hinzufügen

Sie können Dokumentdateien aus dem Explorer, E-Mails aus Outlook, Windows Mail, Mozilla Thunderbird, eM Client, IBM (Lotus) Notes, Tobit David und anderen Mailprogrammen sehr einfach per Drag&Drop mit der Maus übernehmen.

Starten Sie z. B. den Windows-Explorer oder wählen Sie den Befehl Erstellen | Importieren | Drag&Drop.

Sie können nun Dateien oder Verzeichnisse mit der Maus vom Explorer auf die Dokumententabelle ziehen und ablegen.

Wenn die Tabelle gruppiert ist, werden die Attribute der Gruppierung für das neue Dokument übernommen.

Drag&Drop mit dem Explorer

Alternativ können Sie die Dokumente auch auf dem Projektnavigator ablegen, um diese einem Projekt zuzuordnen.

Beispiel

Sie haben Office Manager DMS neu installiert und möchten nun die bestehenden Dokumentdateien dem Projekt "Potsdamer Platz" hinzufügen. Der Status dieser Dokumente soll "Normal" sein.

1.Wenn noch kein Dokument mit den Felder Projekt="Potsdamer Platz" und Status="Normal" vorhanden ist: Schieben Sie die erste Dokumentdatei per Drag&Drop vom Explorer auf die Dokumententabelle. Geben Sie im Feld Projekt die Bezeichnung "Potsdamer Platz" und im Feld Status die Bezeichnung "Normal" ein. Klicken Sie ggf. mit der rechten Maustaste auf das Eingabefeld, um die Auswahlliste zu bearbeiten. Übernehmen Sie das Dokument mit Klick auf OK.

2.Gruppieren Sie die Tabelle nach den Feldern Projekt und Status. Die Dokumente werden in der Baumdarstellung angezeigt.

3.Öffnen Sie den Baum Projekt "Potsdamer Platz" und den Untereintrag Status "Normal".

4.Schieben Sie nun weitere Dateien vom Explorer in den geöffneten Baum. Die Datenfelder der neuen Dokumente werden jetzt anhand der Gruppierung belegt, das Feld Projekt erhält die Bezeichnung "Potsdamer Platz" mit dem Status "Normal".

5.Wenn Sie die Attribute später ändern möchten, dann verwenden Sie den Menübefehl Bearbeiten | Dokument | Eigenschaften.

Siehe auch

Importprofile

Drag & Drop von Internet-Links

Eigenschaftendialog beim Import öffnen

Erweiterter Import


Datei aus Zwischenablage einfügen

Navigation: Dokumentenmanagement > Dokumente importieren >

Datei aus Zwischenablage einfügen

Dokumente aus Zwischenablage einfügen

Markieren Sie beispielsweise eine Datei im Windows-Explorer und wählen Sie dort im Menü Bearbeiten den Befehl Kopieren (Kurztaste Strg+C). Wechseln Sie anschließend zum Office Manager, markieren Sie die Dokumententabelle und wählen Sie den Befehl Bearbeiten | Zwischenablage | Einfügen (Kurztaste Strg+V).

Sie können auch den umgekehrten Weg gehen, um Dokumente aus dem Office Manager zu kopieren: Dokument im Office Manager markieren, Strg+C drücken und anschließend im Explorer oder anderem geeigneten Programm Strg+V.
Beschleunigungs-Tipp: Das Kopieren sehr vieler Dokumente erfordert Arbeitsspeicher und Zeit, weil mehrere Zwischenablageformate inklusive des gesamten Textes erstellt werden. Wenn Sie nur die Datei kopieren möchten, dann können Sie auch mit der rechten Maustaste auf die Tabelle klicken und im lokalen Popupmenü den schnelleren Befehl Bearbeiten | Dateien kopieren nutzen.

Zwischenablage überwachen

Die Importfunktion im Erstellen | Importieren | Importieren ermöglicht auch eine Überwachung der Zwischenablage. Wenn die Funktion aktiviert ist, dann werden alle Dateien, die Sie in die Zwischenablage kopieren, dem Importstapel hinzugefügt.

Bilder können Sie mit Erstellen | Scannen | Dialogscan zu einem Dokument zusammenfügen. Aktivieren Sie im Scandialog die Funktion Zwischenablage überwachen und kopieren Sie Bilder in die Zwischenablage oder machen Sie Screenshots. Bilder werden automatisch, ohne dass Sie Strg+V drücken müssen, als Dokumentseiten importiert.

Siehe auch

Übersicht Importfunktionen

Eigenschaftendialog beim Import öffnen


Senden vom Explorer

Navigation: Dokumentenmanagement > Dokumente importieren >

Senden vom Explorer

Vom Explorer an Office Manager DMS senden

Klicken Sie bitte im Windows-Explorer mit der rechten Maustaste auf eine Datei und wählen Sie im lokalen Menü den Befehl Mit Office Manager verwalten:

Mit Office Manager DMS verwalten

Die Datei wird in das Dokumentenarchiv übernommen.

Hinweise

Unter Windows 11 müssen Sie im Explorer-Menü zuerst auf Weitere Optionen anzeigen klicken, um das vollständige Popupmenü zu sehen.

Falls der Menüeintrag im Explorer fehlt oder auf eine falsche DMS-Installation verweist, müssen Sie die Shell-Erweiterung neu registrieren. Wählen Sie dazu im Windows-Startmenü den Befehl Ausführen und geben Sie folgende Anweisung ein (den Pfad bitte ev. anpassen):

regsvr32 "C:\Programme\Krekeler\Office Manager DMS\omShellEx.dll"

Siehe auch

Übersicht Importfunktionen

Verzeichnis-Definitionen

Eigenschaftendialog beim Import öffnen


Internetadressen übernehmen

Navigation: Dokumentenmanagement > Dokumente importieren >

Internetadressen übernehmen

Verfügbar in diesen Editionen

Internetadresse vom Browser übernehmen

Office Manager DMS kann Links und Dateien vom Internetbrowsern übernehmen.

Drag & Drop von Internet-Links

Wenn Sie einen Link aus dem Browser per Drag&Drop auf den Office Manager schieben oder eine URL aus der Zwischenablage importieren, erscheint folgendes Popupmenü:

Sie können jetzt wählen, ob das Dokument archiviert oder mit der URL verknüpft werden soll:

Internetlink verwalten: der Office Manager verwaltet direkt die URL. Wenn Sie später die Webseite oder das Dokument öffnen, wird diese Internetadresse (i. d. R. im Browser) geöffnet.

Lokale Kopie speichern: die Dokumentdatei wird von der URL geladen und im Dokumentenverzeichnis gespeichert. Wenn die URL auf eine downloadbare Datei verweist, dann wird diese geladen. Webseiten (HTML) werden als Webarchiv (MIME HTML, *.mhtml) gespeichert.

Abbrechen: der Import wird abgebrochen.

Dieses Popupmenü wird eingeblendet, wenn Sie eine URL importieren, dessen Dokumenttyp als "Standard-Dokument in externer Datei" oder als "E-Mail" registriert ist oder wenn eine Webseite als MHTML gespeichert werden kann. In allen anderen Fällen wird ohne Rückfrage der Link verwaltet.

MIME HTML-Webarchive werden mit Windows API-Funktionen, dem IMessage Interface, erstellt. Die Darstellung kann vom Original abweichen. Es werden nicht alle Linkquellen unterstützt.

Drag & Drop aus Adressleiste

Mit dem Firefox-Browser können Sie die URL in der Adressleiste markieren und dann mit der Maus übernehmen:

Adressleiste im Web-Browser

1.Markieren Sie bitte die URL, wie im obigen Bild gezeigt.

2.Klicken Sie mit der linken Maustaste in den markierten Text und halten Sie die Maustaste fest.

3.Schieben Sie die Maus auf die Dokumententabelle im Office Manager und lösen Sie erst jetzt die Maustaste.


Verzeichnisüberwachung

Navigation: Dokumentenmanagement > Dokumente importieren >

Verzeichnisüberwachung

Verfügbar in diesen Editionen

Verzeichnisüberwachung

Menü Datei | Optionen | Einstellungen, Seite Überwachen

Der Office Manager kann Verzeichnisse (Ordner) überwachen und neue Dateien übernehmen.

Beispiel: Sie erstellen mit Ihrer Textverarbeitung ein neues Dokument. Sobald Sie das Dokument im Ordner "Eigene Dateien" speichern, erscheint die Eingabemaske des Office Managers und Sie können die Attribute eingeben.

Es können auch Unterverzeichnisse überwacht werden, beispielsweise ein komplettes Laufwerk. Mit dieser Funktion kann die Dokumentenverwaltung auf Wunsch komplett automatisiert werden: Die Anwender speichern ihre Dokumente einfach in der gewohnten Verzeichnisstruktur. Der Office Manager überwacht die Verzeichnisse und übernimmt neue Dokumente automatisch in das Archiv. Die Attribute werden dabei aus der Verzeichnisstruktur übernommen und/oder für jedes Dokument manuell bearbeitet. Im Netzwerkbetrieb sollte die Option "Nur Dateien des angemeldeten Benutzers übernehmen" markiert werden.

Versteckte Dateien werden ignoriert und nicht übernommen.

Überwachung aktivieren:

Klicken Sie im Menü Datei | Optionen auf Einstellungen und wählen Sie die Kategorie Importieren | Überwachen. Markieren Sie die Option Verzeichnis überwachen und neue Dateien importieren. Geben Sie das zu überwachende Verzeichnis an und legen Sie die Importeinstellungen fest:

·Auf der Seite Importieren | Überwachen | Erweitert geben Sie an, ob auch Unterverzeichnisse überwacht werden sollen.

·Auf Seite Importieren | Profile können Sie weitere verzeichnisabhängige Einstellungen vornehmen.

Verzeichnis mit Archiv synchronisieren:

Die Überwachung funktioniert nur, wenn der Office Manager ausgeführt wird. Um nachträglich alle Dateien zu importieren, die noch nicht im Archiv enthalten sind, wählen Sie bitte den Menübefehl Erstellen | Importieren. Klicken Sie bei Startverzeichnis auf Durchsuchen und wählen Sie Überwachtes Verzeichnis.

Siehe auch

Import-Optionen

Importprofile

Erweiterte Einstellungen

Übersicht Importfunktionen


Eingehende Faxe importieren

Navigation: Dokumentenmanagement > Dokumente importieren >

Eingehende Faxe importieren

Verfügbar in diesen Editionen

Faximport

Diese automatisierte Importfunktion übernimmt neue Dateien aus dem Faxeingangsverzeichnis in das Dokumentenarchiv.

1. Vorbereitungen

Definieren Sie bitte einen Dokumenttypen für die Faxe. Wählen Sie dazu im Menü Datei | Optionen | Dokumenttyp oder schieben Sie einfach eine Faxdatei (z. B. *.tif, *.001, *.sff oder *.pdf) per Drag&Drop auf den Office Manager, der Dokumenttyp wird dann automatisch eingerichtet.

Wählen Sie bitte im Menü Datei | Optionen den Befehl Einstellungen und öffnen Sie die Seite Importieren | Fax. Wählen Sie dort Eingangsordner aus, in welchem die Faxsoftware neue Dokumente ablegt. Geben Sie dann noch die Dateimaske an, sodass bei Eingangsordner beispielsweise "C:\Faxeingang\*.tif" eingestellt ist.

Wählen Sie ein Projekt (z. B. "Faxeingang") und einen Status (z. B. "zu bearbeiten") für neue Faxe. Geben Sie bitte den zuvor definierten Dokumenttyp an.

2a. Manueller Import

Wählen Sie im Feld Faximport bitte "Manuell auf neue Faxe prüfen". Auf der Optionsseite Importieren sollte die Option Faximport markiert sein, damit der Eigenschaftendialog für neue Dokumente automatisch geöffnet wird.

Klicken Sie auf OK, um die Einstellungen zu speichern.

Sobald Faxe im Eingangsverzeichnis vorhanden sind, können Sie diese mit dem Menübefehl Erstellen | Importieren | Faximport in das Archiv übernehmen.

Beim manuellen Import werden die Dokumentattribute aus der Gruppierung und dem Projektnavigator übernommen. Wenn Sie die Faxe beispielsweise einem bestimmten Projekt zuordnen möchten, dann markieren Sie dieses im Projektnavigator, bevor Sie den Import aufrufen.

2b. Automatisierter Import

Wählen Sie im Feld Faximport bitte "Neue Faxe automatisch importieren" und geben Sie bitte den zuständigen Mitarbeiter im Feld Benutzer o. PC ein.

Klicken Sie auf OK, um die Einstellungen zu speichern.

Das Eingangsverzeichnis wird regelmäßig auf neue Faxe geprüft. Sobald Dateien vorhanden sind, öffnet sich beim zuständigen Mitarbeiter der Eingabedialog für neue Dokumente. Der Benutzer kann jetzt weitere Attribute, wie Projekt und Name angeben, und eine Tätigkeit für einen zuständigen Kollegen erstellen.

2c. Vollautomatischer Import

Wählen Sie im Feld Faximport bitte "Vollautomatisch ohne Eigenschaftendialog" und geben Sie den zuständigen Mitarbeiter im Feld Benutzer o. PC ein. Markieren Sie die Option Tätigkeit erstellen.

Klicken Sie auf OK, um die Einstellungen zu speichern.

Das Eingangsverzeichnis wird regelmäßig auf neue Faxe geprüft. Sobald Dateien vorhanden sind, werden diese automatisch importiert. Der zuständigen Mitarbeiter wird über die Aufgabenverwaltung informiert und kann das neue Fax bearbeiten.

Siehe auch

Beschreibung für FRITZ!fax

Übersicht Importfunktionen

Erweiterte Einstellungen (ImportFax und ImportFaxDefaultFields)

Grafikviewer

Importprofile


Massenimport

Navigation: Dokumentenmanagement > Dokumente importieren >

Massenimport

Verfügbar in diesen Editionen

Dokumentdateien suchen und importieren

Mit dem leistungsstarken Bulk-Import können Sie die auf Ihren Datenträgern vorhandenen Dokumentdateien schnell in das DMS-Archiv einlesen. Diese Funktion dient vor allem der Übernahme großer Datenbestände.

1.Wählen Sie den Menübefehl Erstellen | Importieren | Importieren:

Dokumentdateien importieren

2.Wählen Sie das Verzeichnis, in welchem die Suche nach Dokumentdateien beginnen soll.
Wenn Sie mehrere Verzeichnisse angeben möchten, können Sie diese im Durchsuchen-Dialog mit der Strg- oder Umschalt-Taste markieren.
Falls die Verzeichnisüberwachung aktiviert ist, dann haben Sie nach einem Klick auf Durchsuchen auch die Auswahlmöglichkeit Überwachtes Verzeichnis. Hiermit werden alle Dateien aus dem überwachten Pfad nachträglich importiert, die noch nicht im Archiv enthalten sind.

3.Mit der Dateimaske können sie die zu importierenden Dateien einschränken, beispielsweise "*.pdf" oder "*.doc;*.docx".

4.Wenn die Option Unterverzeichnisse einbeziehen markiert ist, werden auch alle Unterverzeichnisse durchsucht.

5.Klicken Sie bitte auf Suchen. Das Archivierungsprogramm durchsucht das gewählte Verzeichnis nach geeigneten Dokumentdateien und blendet diese anschließend auf der rechten Fensterseite ein.
Tipp: Wenn Nur neue Dateien importieren markiert ist, dann wird bereits bei der Suche vorab geprüft, ob die jeweilige Datei bereits im Archiv vorhanden ist. Dies ergibt eine bessere Übersicht zu den zu importierenden Dateien, dauert aber länger. Eine zweite Prüfung erfolgt direkt vor dem Import.

6.Optional können Sie die Liste überprüfen und unerwünschte Dateien ausschließen: Entfernen Sie dazu den Haken vor den entsprechenden Dateien. Ein Klick mit der sekundären (normalerweise der rechten) Maustaste öffnet das lokale Popupmenü.

7.Wenn Sie der Liste zusätzliche Dateien hinzufügen möchten, dann können Sie weitere Verzeichnisse durchsuchen, Dateien per Drag&Drop vom Explorer auf die Liste schieben oder die Zwischenablage überwachen.

8.Klicken Sie bitte auf die Schaltfläche Optionen (s. a. Import-Profile). Sie können hier festlegen, ob die Dokumentattribute -wie Projekt und Name- automatisch aus dem Dateinamen ermittelt werden sollen. Eine weitere wichtige Einstellung ist das Verschieben von Dateien in das Dokumentenverzeichnis.

9.Klicken Sie auf den Schalter Importieren, um die Dokumente in das Archiv zu übernehmen.

10.Der Dialog "Neues Dokument" wird geöffnet. Hier können Sie die Archivattribute beliebig bearbeiten und weitere Informationen hinzufügen. Wenn Sie den Inhalt des Dokuments nicht kennen, dann können Sie zur Seite Vorschau wechseln oder auf die Schaltfläche rechts neben Dateiname klicken und Öffnen wählen.
Klicken Sie auf OK, um dieses Dokument zu übernehmen, Verwerfen, um es nicht zu übernehmen, Alle OK, um alle gefundenen Dokumente ohne weitere Bearbeitung zu übernehmen oder Abbrechen, um den Import weiterer Dokumente abzubrechen.

Tipp: Diese Funktion kann auch mit Programm-Startparametern ausgeführt werden.

Ohne Rückfrage importieren

Wenn Sie umfangreiche Datenbestände einlesen möchten, ist eine unbeaufsichtigte Ausführung beispielsweise über Nacht sinnvoll. Wählen Sie dazu, wie oben beschrieben, das Verzeichnis aus und passen Sie bei Bedarf die Optionen an. Klicken Sie anschließend auf den Pfeil des Mausschalters Suchen und im sich öffnenden Menü auf Ohne Rückfrage importieren.

Die Dateisuche wird ausgeführt und der Import anschließend automatisch gestartet. Der Eigenschaftendialog für die Dokumentbeschreibung öffnet sich nicht. Auch Rückfragen und Warnungen werden nicht eingeblendet.

Zwischenablage überwachen

Neben dem Durchsuchen von Verzeichnisstrukturen ermöglicht die Importfunktion auch eine Überwachung der Zwischenablage. Wenn die Funktion aktiviert ist, dann werden alle Dateien, die Sie in die Zwischenablage kopieren, dem Importstapel hinzugefügt.

1.Wählen Sie bitte Erstellen | Importieren | Importieren, um den Importdialog zu öffnen.

2.Markieren Sie die Option Zwischenablage überwachen.

3.Wechseln Sie in den Windows-Explorer oder ein anderes geeignetes Programm.

4.Markieren Sie dort die gewünschten Dateien und drücken Sie die Tastenkombination Strg+C, um die Dateien in die Zwischenablage zu kopieren. Oder schieben Sie die Dateien per Drag&Drop auf das Dialogfenster. Wenn eine nicht unterstütze Datei kopiert wird, dann gibt das Programm einen Piepton aus.

5.Office Manager fügt die Dateien dem Importstapel hinzu.

6.Klicken Sie bitte auf Importieren, um die Dokumente zu archivieren.

Siehe auch

Import-Optionen

Erweiterte Import-Optionen

Drag&Drop mit dem Explorer

Dokumenten-Eigenschaftendialog

Alle Dateien importieren


Importprofile

Navigation: Dokumentenmanagement > Dokumente importieren >

Importprofile

Importverzeichnisse definieren

Eine häufige Aufgabe des Dokumentenmanagements ist der Import von Dateien aus verschiedenen Quellen. Office Manager DMS bietet hierfür mehrere Importfunktionen, wie beispielsweise Drag&Drop, Einfügen aus der Zwischenablage und die Verzeichnisüberwachung.

Die Dokumentattribute, wie Name und Projekt, können beim Import z. B. aus dem Dateipfad oder einer KI-Analyse übernommen werden. Hierfür können Sie verschiedene Importprofile definieren.

Anwendungsbeispiele

·Einmaliger Import aller bestehenden Dateien aus einem Dokumentenverzeichnis mit Übernahme des Projektes aus der Verzeichnisstruktur.

·Regelmäßiger Abgleich des Dokumentenverzeichnisses mit Import aller Dateien, die noch nicht im digitalen Archiv erfasst sind.

·Beim Import von CD-ROM, USB-Sticks u. a. Wechsellaufwerken die Dateien immer in das Dokumentenverzeichnis kopieren.

·Überwachung eines Verzeichnisses mit automatischem Import aller neuen Dateien.

·Scannen von Papierdokumenten mit einem Netzwerkscanner oder Multifunktionsgerät, der die Dokumente selbständig in einem Verzeichnis ablegt. Hierbei können die Attribute vom Papier gelesen und Dokumentenstapel in Einzeldokumente aufgeteilt werden (s. a. Beispiel).

·Drag&Drop von Dateien aus einem Eingangsverzeichnis mit automatischer Bearbeitung der Dokumente vor dem Import. Beispielsweise könnten eingehende Bilder in ein vorgegebenes Grafikformat oder DXF-Dateien in das Format Ihres CAD-Systems konvertiert werden.

Importprofile definieren

Wählen Sie bitte im Menü Datei | Optionen den Befehl Einstellungen und markieren Sie links die Kategorie Importieren | Profile.

Sie können eigene Definitionen für die unterschiedlichen Quellen erstellen, um beispielsweise für die Dokumente aus "Eigene Dateien", den Netzlaufwerken und der CD verschiedene Einstellungen zuzuordnen.

Die Definition "[Standard]" gilt immer dann, wenn keine spezielle Definition für die Importquelle erstellt wurde. Um zu ermitteln, welche Importeinstellung für eine bestimmte Datei verwendet würde, können Sie die Datei per Drag and Drop vom Explorer auf dem Testfeld ablegen.

"[E-Mail]" gilt für alle Mails, die direkt vom Mailprogramm übernommen wurden (beispielsweise Drag&Drop aus Outlook).

·Um einen bestehenden Eintrag zu ändern, markieren Sie diesen bitte in der Liste und klicken anschließend auf Bearbeiten.

·Klicken Sie auf Neu, wenn Sie ein neues Profilhinzufügen möchten.

·Alternativ können Sie auch einen bestehenden Eintrag kopieren: Klicken Sie zuerst auf Übernehmen, um ev. Änderungen zu speichern. Markieren Sie anschließend das zu duplizierende Profil und klicken Sie auf Kopieren.

Das Dialogfenster

Klicken Sie im Bild auf die Komponenten oder Registerseite, zu der Sie weitere Hilfe wünschen.

Geben Sie eine aussagekräftige Beschreibung und die weiteren Optionen ein. Verwenden Sie bitte die Direkthilfe, um Informationen zu den einzelnen Konfigurationsfeldern im Dialogfenster zu erhalten.

Mit der Option Eigenschaftendialog für neue Dokumente öffnen legen Sie fest, ob der Dialog beim Import geöffnet wird. Wenn die Option nicht markiert ist, wird das Dokument sofort übernommen.

Siehe auch

Beispiel Import vom Netzwerkscanner

Automatische Dokumentenerkennung

Scanprofile


Erweiterter Import

Navigation: Dokumentenmanagement > Dokumente importieren >

Erweiterter Import

Verfügbar in diesen Editionen

Erweiterter Import

Wenn Sie beim Drag&Drop eine einzelne Datei auf der Datentabelle ablegen die Strg-Taste gedrückt halten, wird folgendes Auswahlmenü geöffnet:

Popupmenü für erweiterten Import

Legen Sie bitte fest, wie die Datei zu behandeln ist:

Hinweis: mit "Zieldokument" ist das Dokument in der Tabelle gemeint, auf dem Sie die Datei per Drag&Drop abgelegt haben.

Als neues Dokument importieren: Normaler Import, dies entspricht dem Drag&Drop ohne gedrückte Strg-Taste.

Dem Dokument als alte Version hinzufügen: Dem Zieldokument wird eine Dokumentversion hinzugefügt. Die importierte Datei wird in die Versionsverwaltung des Zieldokuments importiert. Dies entspricht dem Ablegen einer Datei auf die Versionsliste im Eigenschaftendialog.

Dem Dokument als aktuelle Version hinzufügen: Der aktuelle Stand des Zieldokuments wird als Dokumentversion archiviert. Die importierte Datei wird als neuer aktueller Stand des Zieldokuments übernommen. Mit dieser Funktion können Sie auch im GoBD-Modus ein fehlerhaftes Dokument durch ein korrigiertes ersetzen. Die ursprüngliche Version bleibt erhalten, die Änderung wird dadurch nachvollziehbar.

Dokument mit dieser Datei verlinken: Dem Zieldokument wird die importierte Datei zugeordnet. *)

Dokument mit durch diese Datei ersetzen: Die Datei des Zieldokuments wird durch die importierte Datei überschrieben. Die alte Datei geht hierbei verloren, sie wird nicht als Version archiviert! *)

Datei nach .. kopieren: Kopiert die abgelegte Datei in das Verzeichnis des Zieldokuments.

Importieren und Felder von .. übernehmen: Die Datei wird importiert und die Attribute des Zieldokuments übernommen.

Hilfe: Öffnet diese Hilfeseite und bricht den Import ab.

Abbrechen: Der Import wird abgebrochen.

Je nach Zugriffsberechtigungen und abgelegtem Dateityp sind nicht alle Optionen möglich.

*) Diese Funktion ist in GoBD-Archiven gesperrt.

Siehe auch

Dokumente importieren

Versionsmanagement

Neue Dokumentdatei zuordnen


Office Manager-Dateien

Navigation: Dokumentenmanagement > Dokumente importieren >

Office Manager-Dateien

Import von Office Manager-Dateien

Wenn Sie per Drag&Drop eine einzelne Systemdatei importieren, öffnet sich folgendes Auswahlmenü:

Popupmenü für Systemdateien des DMS

Legen Sie hier bitte fest, wie die Datei zu behandeln ist:

Als neues Dokument importieren: Die Datei wird wie ein beliebiges Dokument behandelt und in das Archiv übernommen.
Wenn Sie beispielsweise mit sehr vielen Archiven arbeiten, können Sie ein Übersichtsarchiv anlegen, in dem wiederum die einzelnen Dokumentenarchive mit Ihren Beschreibungen und Projektzuordnungen verwaltet sind.

Datei in gemeinsame Dateien kopieren: Die Datei wird in das entsprechende Unterverzeichnis der gemeinsamen Dateien kopiert. Eine Archivdatenbank beispielsweise nach "..\Archive". Diese Auswahl wird z. B. verwendet, wenn Sie ein Archiv oder Makro von außerhalb erhalten.

Datei in gemeinsame Dateien kopieren (Menüeintrag): Ist nur bei abgelegter Makrodatei sichtbar. Das Makro wird in das Verzeichnis "..\macro\menu" kopiert und ist dann im Menü Start | Makros verfügbar.

Datei jetzt öffnen: Das Archiv o. a. wird direkt in Office Manager DMS geöffnet ohne die Datei zu kopieren.

Datei installieren (nur bei .omini und .omtup): Das enthaltene Toolup installieren. Hierfür ist eine Administratoranmeldung erforderlich, falls ein Passwort vergeben wurde.

Hilfe öffnet diese Hilfeseite und bricht den Import ab.

Abbrechen bricht den Import ab.

Das Popupmenü erscheint nur, wenn Sie eine einzelne Datei ablegen. Beim Drag&Drop mehrerer Dateien, werden diese wie Dokumente behandelt und in das Archiv importiert.

Siehe auch

Dokumente importieren


Scannen

Navigation: Dokumentenmanagement >

Scannen

Papierdokumente scannen

Der Office Manager beinhaltet verschiedene Scanner-Schnittstellen für:

1. TWAIN- und WIA-kompatible Geräte

TWAIN ist eine Schnittstelle zur direkten Kommunikation zwischen Anwendungsprogrammen und digitalen Bildgeräten. WIA steht für Windows Image Acquisition. Der Office Manager kann über diese Schnittstellen Dokumente und Bilder von Scannern und Digitalkameras importieren. Sie können Scanprofile vordefinieren.

2. Ricoh ScanSnap

Das Programm beinhaltet eine Schnittstelle zum eigenständig arbeitenden Ricoh/Fujitsu ScanSnap. Die Bedienung erfolgt am Gerät oder im Office Manager mit Scanprofilen.

3. Nicht TWAIN-kompatible Geräte

Neben der TWAIN- und WIA-Unterstützung übernimmt der Office Manager auch Dokumente von eigenständig arbeitenden Scannern.

4. Sceye-Dokumentenkamera

Der Office Manager kann Sceye über eine direkte Schnittstelle auch ohne TWAIN ansteuern.


Standard-Scanner

Navigation: Dokumentenmanagement > Scannen >

Standard-Scanner

Verfügbar in diesen Editionen

Papierdokumente scannen

Beschreibung für TWAIN- und WIA-kompatible Geräte.

1.Zum Scannen klicken Sie bitte auf den Mausschalter Erstellen | Scannen | Dialogscan. Das Eigenschaftenfenster für neue Dokumente wird geöffnet:

Screenshot: Dokument scannen

Klicken Sie im Bild auf die Komponenten, zu der Sie weitere Hilfe wünschen.

2.Legen Sie das Dokument ein und wählen Sie das Gerät bitte bei Scanner aus.

3.Wenn die Option Benutzeroberfläche des Scanners öffnen markiert ist, können Sie die Auflösung und andere Einstellungen in der Scannersoftware vornehmen. Ist die Option nicht markiert, nehmen Sie die Einstellungen direkt im obigen Dialog vor. Testen Sie doch einmal beide Varianten, um den Unterschied kennen zu lernen.

4.Klicken Sie bitte auf Scannen, um das Bild vom Gerät ein zu lesen. Sie können auch die Kurztaste F6 verwenden.

5.Wenn Sie dem Dokument weitere Bilder hinzufügen möchten, können Sie den Vorgang wiederholen oder Grafiken aus einer Datei oder der Zwischenablage importieren.

6.Sofern das Bild Text beinhaltet, sollte die Option Volltextsuche ermöglichen markiert sein. Der Office Manager kann dann den Text indexieren und eine spätere Volltextsuche ermöglichen (siehe auch Datei | Optionen | Einstellungen, Seite Volltextindex | OCR).
Für gute Texterkennungs-Ergebnisse sollte die Auflösung mindestens 300dpi betragen.

7.Wählen Sie bitte den Dokumenttypen und die weiteren Attribute im oberen Bereich des Dialogfensters.

8.Klicken Sie anschließend auf OK, um das Dokument in das Archiv zu übernehmen.

Temporäres Scannen

In manchen Situationen möchten Sie das Dokument zwar scannen, aber nicht im Dokumentenarchiv ablegen. Beispielsweise um einen Papierbeleg per E-Mail zu versenden. Scannen Sie zuerst, wie oben beschrieben, die Papiervorlage ein, bestätigen Sie das Dialogfenster aber nicht mit OK. Klicken Sie vielmehr rechts neben der Seitenvorschau auf Diskettensymbol, um den Scan in eine Datei zu speichern. Anschließend können Sie den Scandialog abbrechen oder das Dokument mit OK zusätzlich in das Archiv übernehmen. Siehe auch Scan-Ziel der Profile.

Erweiterte Funktionen

Klicken Sie bitte am rechten Rand des Dialoges auf den Menüschalter Menü oder klicken Sie mit der rechten Maustaste auf die gescannte Grafik:

Popupmenü mit Scanoptionen

·Datei importieren: Grafik aus einer Datei laden. Alternativ können Sie auch Grafikdateien per Drag&Drop hinzufügen.

·In Datei externe speichern: Gescanntes Dokument in eine externe Datei speichern (s. o.)

·Einfügeposition legt fest, wo neue Seiten im Stapel eingefügt werden.

·Speicher-Transfer vermeidet Pausen zwischen den einzelnen Seiten im Stapel, wird aber nicht von allen Scannern unterstützt. Ändern Sie diese Einstellung bitte, wenn Sie die Fehlermeldung "Ungültige Bitmap" erhalten.

·Autozoom: Ganze Grafik in der Vorschau darstellen.

·Grafik drehen: Manuell um einen vorgegebenen Winkel drehen und
Geraderücken, um schief eingezogene Seite zukorrigieren.

·Grafik bearbeiten: Die Grafik in einem Windowsprogramm bearbeiten. Diese Funktion ist in GoBD-Archiven gesperrt.

·Rückgängig: Letzte Bearbeitung widerrufen. Muss vor einem Bildwechsel aufgerufen werden.

·In schwarz/weiß konvertieren: Markierte Grafik in schwarz/weiß-Format konvertieren (s. a. erweiterte Einstellung)

·Zuschneiden: Automatischer Zuschnitt nach dem Scan auf A4 o. a.

·Verschieben: Seiten im Stapel verschieben
Duplex-Stapel 1: wenn "1. Vorderseite - 2. Vorderseite - 1. Rückseite - 2. Rückseite" gescannt wurde,
Duplex-Stapel 2: wenn "1. Vorderseite - 2. Vorderseite - 2. Rückseite - 1. Rückseite" gescannt wurde.

·Zwischenablagefunktionen zum Einfügen und Kopieren

·Zwischenablage überwachen fügt Bilder automatisch hinzu, sobald diese in die Zwischenablage kopiert werden.

·Löschen: Aktuelle Grafik aus dem Stapel entfernen.

Hinweise

·Um ein Detail im Vorschaufenster zu vergrößern, halten Sie bitte die Strg-Taste gedrückt und bewegen den Mauszeiger über den gewünschten Bereich.

·Mehrseitige Dokumente (mehr als ein Bild) können nur in geeigneten Dokumenttypen, wie Adobe Acrobat und TIFF gespeichert werden. Ist hingegen nur ein Bild eingelesen, können Sie auch Dokumenttypen, wie Bmp, JPeg und andere Bildformate wählen.

·Wenn die Option Volltextsuche ermöglichen markiert ist, können Sie nur Dokumenttypen wählen, welche für die eingestellte OCR-Software geeignet sind.

·Die Scan-Funktion eignet sich auch, um Grafikdateien in ein PDF-Dokument zu importieren. Stellen Sie das Dokument zusammen, indem Sie die Bilder aus Dateien Öffnen importieren und wählen Sie den Dokumenttyp Adobe Acrobat.

·Wenn Sie Fotos scannen oder von der Digitalkamera einlesen, sollte die Option Volltextsuche ermöglichen nicht markiert sein. OCR ist nur erforderlich, wenn Sie enthaltene Texte für eine Volltextsuche indexieren möchten.

·Falls Sie einen Duplex-Scanner gewählt haben, die Duplex-Option aber nicht wählbar ist, dann klicken Sie bitte auf den Schalter rechts neben Scanner und markieren Sie Alle Treiberoptionen aktivieren.

Siehe auch

Scanprofile

Scannen mit Dokumentenscanner

Übersicht Importfunktionen

Eigenschaftendialog

Kein Dokumenttyp vorhanden

Papierformate definieren


Ricoh ScanSnap

Ricoh/Fujitsu ScanSnap

Navigation: Dokumentenmanagement > Scannen >

Ricoh/Fujitsu ScanSnap

ScanSnap iX1500

Dokumente mit ScanSnap einlesen

Für die Aktivierung der ScanSnap-Schnittstelle wählen Sie bitte den Menübefehl Datei | Optionen | Einstellungen. Wechseln Sie auf die Seite Scannen | ScanSnap und klicken Sie auf ScanSnap-Anbindung einrichten. Dies trägt den Office Manager als App im ScanSnap an und erstellt einige Scanprofile.

Um ein neues Dokument ein zu scannen,

1.öffnen Sie bitte die Scannerabdeckung, das Gerät schaltet sich ein.

2.Legen Sie das Dokument in den Einzelblatteinzug.

3.Wechseln Sie im Office Manager zur Menüseite Erstellen und klicken Sie auf Scanprofile (in einigen OEM-Versionen auf Menüseite Start, Schalter ScanSnap)

4.Klicken Sie das gewünschte Scanprofil an, um die Papiervorlagen einzuziehen. Später können Sie auch die Scan-Taste am Gerät drücken, es wird dann das zuletzt gewählte Profil oder das eingestellte Profil verwendet.
Tipp: Wenn Sie die Umschalttaste gedrückt halten und dann ein Scanprofil anklicken, wird nicht gescannt, sondern nur das Profil für die Scantaste festgelegt.

5.Während des Scanvorgangs erscheint das Statusfenster der ScanSnap-Software.

6.Der Office Manager wird jetzt gestartet, falls er nicht bereits läuft.

7.Anschließend öffnet sich das Eigenschaftenfenster zur Beschreibung des Dokuments im Archiv. Geben Sie hier bitte die gewünschten Attribute, wie Name, Projekt u. a. ein. Beachten Sie auch die Belegerkennung.

8.Sobald Sie auf OK klicken, wird die Datei in das Dokumentenverzeichnis verschoben und im Office Manager-Archiv verwaltet.

Sie können das Dokument später anhand der eingegebenen Attribute und des enthaltenen Textes (Volltextindex) wiederfinden.

ScanSnap speichert seine Einstellungen im Profil des Windows-Benutzers. Nach einem Benutzerwechsel müssen Sie mindestens einmal ein Scanprofil im Office Manager-Menü Erstellen aufrufen, bevor Sie die Scantaste am Gerät verwenden können.

Internet-Links

ScanSnap-FAQ

Support-Recherche

Produktbeschreibung

PDF-Kurzanleitung

Ricoh oder Fujitsu?


Netzwerkscanner und MFC

Navigation: Dokumentenmanagement > Scannen >

Netzwerkscanner und MFC

Funktionsweise der Dokumentenscanner-Schnittstelle
für nicht TWAIN-kompatible Geräte.

A. Wenn das Gerät nach dem Scannen ein Programm starten kann
(wie beispielsweise Ricoh ScanSnap)

1.Das Gerät scannt die Papierdokumente auf Knopfdruck ein und speichert diese auf der Festplatte. Gängige Formate sind PDF, Tiff und JPeg.

2.Die Scannersoftware startet die angegebene Zielanwendung und übergibt dieser die gespeicherte Datei als Parameter. Als Zielanwendung wird das Office Manager-Hilfsprogramm "SendToOM.exe" angegeben.

3.SendToOM startet Office Manager DMS, falls dieses noch nicht ausgeführt wird, und übermittelt die gescannte Datei.

4.Sofern eine OCR-Texterkennung eingerichtet ist, wird diese nun durchgeführt.

5.Die OCR-Software wandelt die gescannten Bilder in Text um und speichert das Dokument in einem kombinierten Bild- und Textformat, wie beispielsweise PDF.

6.Das Dokument wird in die Archivdatenbank importiert und die Datei in das voreingestellte Dokumentenverzeichnis verschoben.

B. Wenn der Scanner kein Programm starten kann
(zum Beispiel Kopierer mit Scan-Funktion)

1.Das Gerät scannt die Papierdokumente auf Knopfdruck ein und speichert diese auf der Festplatte.

2.Office Manager DMS überwacht das Verzeichnis, in welchem der Scanner die Dokumente speichert. Das DMS reagiert auf alle Dateien, die in diesem Verzeichnis gefunden werden.

3.Sofern eine OCR-Software angegeben ist, wird diese gestartet.

4.Die OCR-Software wandelt die gescannten Bilder in Text um und speichert das Dokument in einem kombinierten Bild- und Textformat, wie beispielsweise PDF.

5.Das Dokument wird in die Archivdatenbank importiert und die Datei in das voreingestellte Dokumentenverzeichnis verschoben.

Siehe auch

Importprofil für Scanner definieren

Scannen mit Standard-Scannern

Einstellungen Volltextindex


Sceye-Dokumentenkamera

Navigation: Dokumentenmanagement > Scannen >

Sceye-Dokumentenkamera

Verfügbar in diesen Editionen

Nur in Office Manager 32 Bit-Edition.

Sceye geöffnet

Dokumente mit Sceye scannen

Sceye ist der erste Vertreter einer neuen Generation von Scannern: die Dokumente werden nicht "gescannt", sondern mit einer Kamera erfasst.
Im Office Manager können Sie Sceye neben der Twain-Schnittstelle auch direkt ansteuern.

Eine angeschlossene und installierte Sceye-Dokumentenkamera wird vom Office Manager automatisch erkannt, Sie finden das Symbol Sceye-Icon auf der Registerseite Erstellen.

Tipp: Sollte das Symbol trotz installiertem Sceye nicht vorhanden sein, verwenden Sie bitte die Funktion Menüband anpassen.

A. Ein Dokument mit Sceye erfassen

1.Öffnen Sie bitte die Kamera, um das Gerät zu aktivieren.

2.Klicken Sie auf der Registerseite Erstellen auf Sceye-Icon, das Scan-Fenster wird geöffnet:

Screenshot: mit Sceye digitalisieren

3.Legen Sie bitte die Scan-Parameter Auflösung, Modus und JPeg-Qualität (nur bei Farbe) fest.

4.Beim Scannen von Dokumenten können Sie die Texterkennung verbessern, indem Sie die erweiterte Einstellung "Kontrastanhebung" oder "Textfilter" verwenden.

5.Wenn Sie später die Volltextsuche im Dokumentinhalt verwenden möchten, aktivieren Sie die Option Volltextsuche ermöglichen (s. a. OCR-Einstellungen).

6.Legen Sie bitte ein Papierdokument unter die Kamera. Sie können den Laser als Positionshilfe aktivieren und bei einigen Modellen die LED-Beleuchtung einschalten. Einen Ausschnitt der Dokumentenvorschau sehen Sie links im Livebild.

7.Klicken Sie nun auf den Schalter Scannen. Das Dokument wird erfasst und rechts in der Grafikliste dargestellt. Wenn Sie dem Dokument weitere Bilder hinzufügen möchten, können Sie den Vorgang wiederholen oder Grafiken aus einer Datei oder der Zwischenablage importieren.

8.Wählen Sie bitte den Dokumenttyp und die weiteren Attribute im oberen Bereich des Dialogfensters.

9.Klicken Sie anschließend auf OK, um das Dokument in das Archiv zu übernehmen.

Siehe auch Hinweise beim Scannen mit Standard-Scanner.

B. Produktives Scannen

Bei dieser erweiterten Funktion werden die Papiervorlagen in einem vorgegebenen Zeitintervall automatisch erfasst. Sie können hiermit ein mehrseitiges Dokument sehr schnell einlesen.

1.Legen Sie bitte den Stapel Papier bereit und positionieren Sie die erste Seite unter der Kamera.

2.Stellen Sie die gewünschten Scanparameter ein.

3.Klicken Sie bitte auf den Schalter Stapelscan, das Fenster "Produktives Scannen" wird geöffnet:

Produktives Scannen mit Sceye

4.Das Scanintervall gibt die Zeitspanne für das Wechseln der Papiervorlage an, verwenden Sie für erste Versuche 4-6 Sekunden. Aktivieren Sie die Option Signalton nach Scan.

5.Klicken Sie bitte auf Scannen, der Schalter bleibt jetzt gedrückt.

6.Wenn das Dokument erfasst wurde, hören Sie den Signalton. Positionieren Sie nun das nächste Blatt unter der Kamera, es wird nach Ablauf des eingestellten Zeitintervalls automatisch gescannt. Wiederholen Sie diesen Schritt für alle Seiten des Dokuments.

7.Sobald alle Seiten erfasst sind, klicken Sie bitte erneut auf Scannen oder drücken Sie eine beliebige Taste.

8.Klicken Sie auf den Schalter Schließen.

9.Im Fenster "Dokument scannen" können Sie eventuell fehlerhaft erfasste Seite löschen und weitere Seiten hinzufügen.

10.Wählen Sie bitte den Dokumenttyp und die weiteren Attribute im oberen Bereich des Dialogfensters.

11.Klicken Sie anschließend auf OK, um das Dokument in das Archiv zu übernehmen.

Tipp: wenn die Vorlagen bereits in einem Aktenordner abgelegt sind, können Sie auch Folgendes versuchen: Positionieren Sie den geöffneten Ordner unter der Kamera und blättern Sie die Seiten zum Scannen einfach um.

Siehe auch

Sceye-Benutzerhandbuch

Scannen über Twain-Schnittstelle

Einstellungen Volltextindex

Dokumente suchen


Scan-Profile

Navigation: Dokumentenmanagement > Scannen >

Scan-Profile

Vordefinierte Scan-Profile

Für TWAIN- und WIA-kompatible Geräte sowie für Ricoh/Fujitsu ScanSnap

Die Profile ermöglichen Ihnen eine Automatisierung beim Scannen und Archivieren von Papierdokumenten. Sie können beispielsweise Profile für einseitige und mehrseitige Dokumente erstellen, das Gerät und seine Einstellungen bestimmen sowie die Bildverbesserungs- und die OCR-Optionen festlegen.

Profile verwenden

Zum Scannen mit Profilen wechseln Sie bitte zur Menüseite Erstellen und klicken auf den Schalter Scanprofile:

Das Untermenü enthält die Liste der vorhandenen Profile. Klicken Sie auf einen Eintrag, um mit diesem Profil zu digitalisieren.

Mit Scanprofile bearbeiten können Sie neue Profile erstellen und die vorhandenen ändern.

Hilfe öffnet dieses Hilfekapitel.

Alternativ zum Menü sind auch Kurztasten möglich. Im obigen Bild ist beispielsweise die Tastenkombination Umsch+Strg+E für das Profil "Einzelblatt einseitig" festgelegt.

Wenn sich die Maus im Menü auf einem Profil befindet, wird in der Statuszeile (unterer Rand des Hauptfensters) eine Info mit den Scanoptionen gezeigt:

Fußzeile mit Profil-Info

Die Kurztasten und Hinweise können Sie beliebig definieren.

Scan-Ziel

Verfügbar in diesen Editionen

Unter den Profilen finden Sie das Untermenü Scan-Ziel. In Ausnahmefällen stellen Sie hier ein, wo die mit den Profilen gescannten Dokumente abgelegt werden. Beispielsweise, um einem bestehenden PDF-Dokument weitere Seiten hinzuzufügen. Oder für einen temporären Scan, um die eingelesenen Dokumentseiten per E-Mail zu verschicken, ohne diese zuvor im Archiv abzulegen.

·Neues Dokument erstellen (Standard): Die normale Option mit der die Papiervorlagen digitalisiert und in das Dokumentenarchiv übernommen werden.

·Das markierte Dokument erweitern: Ist nur möglich, wenn genau ein PDF-Dokument in der Tabelle markiert ist. Die gescannten Seiten werden an das das Ende des markierten Dokuments angefügt. Prüfen Sie bitte, ob diese nachträgliche Änderung Ihren Archivierungsregeln entspricht, besondere Eigenschaften des bestehenden Dokuments können verloren gehen, beispielsweise PDF/A. Administratoren können diese Funktion auch sperren. Das bisherige Dokument wird automatisch als Dokumentenversion archiviert.
Verwenden Sie nur Scan-Profile mit einem Dokumententyp für PDF. Stapeltrennung ist für dieses Scan-Ziel nicht sinnvoll, weil alle eingelesenen Seiten dem Dokument hinzugefügt werden. Falls Sie den Ricoh ScanSnap nutzen, dann starten Sie den Scan bevorzugt aus dem Programm-Menü und nicht mit der Taste am Gerät.

·In externe Datei speichern: Nach dem Scan geben Sie einen Dateinamen an, um außerhalb des Dokumentenarchivs zu speichern. Siehe auch temporäres Scannen.

·In Windows-Zwischenablage kopieren: Die erstellten Dokumente werden in temporären Dateien gespeichert und in die Zwischenablage kopiert. Anschließend wechseln Sie beispielsweise zum Windows-Explorer und drücken Sie Strg+V oder den Menübefehl Einfügen, um die Dateien in das gewünschte Verzeichnis zu kopieren. Oder erstellen Sie eine neue E-Mail und fügen Sie die Scans als Anlagen hinzu.

Nach einem Programmneustart wird das Scan-Ziel auf die Standardoption "Neues Dokument erstellen" zurückgesetzt.

Kontakterkennung

Sie haben auch die Möglichkeit, Kontakte von Papiervorlagen einzulesen. Hierzu ist i. d. R. eine Künstliche Intelligenz erforderlich, welche den Text analysiert und die Adressinformationen extrahiert. Wechseln Sie zur Ansicht der Kontakte und starten Sie das gewünschte Scanprofil. Bei Standard-Scannern wird auf jeder Seite nach einem Kontakt gesucht, beim ScanSnap in jeder PDF.

Profile erstellen

Wählen Sie bitte, wie oben beschrieben, den Befehl Scanprofile bearbeiten oder öffnen Sie die Seite Scannen | Profile in den Programmeinstellungen:

Einstellungen - Scanprofile

Klicken Sie im Bild auf die Komponenten, zu der Sie weitere Hilfe wünschen.

Die Liste beinhaltet alle derzeit definierten Profile. Klicken Sie bitte auf:

Neu um ein neues Profil zu erstellen,

Kopieren zum Kopieren des markierten Eintrags,

Bearbeiten zur Bearbeitung des markierten Eintrags oder

Löschen zum Löschen des markierten Eintrags.

Wenn die Option Möglichst als PDF/A archivieren markiert ist und die gescannten Dokumente als Acrobat-Datei gespeichert werden, dann wird das PDF/A 1b-Format verwendet. Diese Option gilt für alle Scanvorgänge. Beachten Sie bitte, dass eine OCR-Texterkennungssoftware den PDF/A-Modus wieder aufheben kann.

Eigenschaften der Scanprofile

Nach Klick auf Neu oder Bearbeiten können Sie das Profil konfigurieren:

Konfigurationsdialog für Scanprofile

Klicken Sie im Bild auf die Komponenten, zu der Sie weitere Hilfe wünschen.

Verwenden Sie bitte die Direkthilfe, um Informationen zu den einzelnen Konfigurationsfeldern im Dialogfenster zu erhalten.

Seite Allgemein

Geben Sie eine aussagekräftige Bezeichnung ein, mit der das Profil im Scanner-Menü gelistet wird. Hinweis wird als Kurzhilfe in der Fußzeile des Hauptfensters gezeigt.

Die Option Eigenschaftendialog öffnen wird i. d. R. markiert, damit Sie das Dokument beschreiben können. Es gibt aber auch Möglichkeiten, die Attribute automatisch zu vergeben:

·Markieren Sie vor dem Scannen ein Projekt im Navigator, um das Dokument diesem zuzuordnen.

·Gruppieren Sie die Dokumenttabelle.

·Auf der Seite Feldwerte können Sie eine Belegerkennung konfigurieren.

Seite Scanner

Wählen Sie das zu verwendenden Gerät in der Liste Scanner aus. Hier werden alle installierten TWAIN- und WIA-Treiber sowie der ScanSnap aufgeführt. Die weiteren Einstellungen auf dieser Seite unterscheiden sich je nach verwendetem Gerätetyp.

Wenn Benutzeroberfläche des Scanners öffnen markiert ist, können Sie vor jedem Scan die Geräteeinstellungen anpassen. Ist die Option nicht markiert, geben Sie bitte hier die Auflösung und den Modus an. Graustufen- und Farbbilder können anschließend automatisch in schwarz/weiß konvertiert werden. Je nach Beleg kann dies bessere Ergebnisse bringen, als ein direkter Scan in schwarz/weiß (s. a. erweiterte Einstellung).

Bei Geräten mit automatischem Dokumenteneinzug können Sie die Optionen Einzelblatteinzug und Automatisch einziehen vorgeben.

Wenn Duplex markiert ist, wird -sofern vom Gerät unterstützt- die Vorder- und Rückseite der Papiervorlage gleichzeitig erfasst.

Beim Scannen von Textdokumenten sollten Sie eine Auflösung von mindestens 300dpi einstellen und auf der Registerseite Allgemein die Option Volltextsuche ermöglichen aktivieren. OCR erkennt den Text und ermöglicht so eine spätere Volltextsuche.

Seite Gültigkeit

Die Scanprofile sind grundsätzlich für alle Benutzer sichtbar. Sie können dies hier einschränken und festlegen, ob das Profil nur von den angegebenen Benutzern, an einem Computer oder in einem bestimmten Dokumentenarchiv verwendet werden soll.

Seite Stapel

Ermöglicht die Dokumententrennung bei einem Stapelscan.

Seite Feldwerte

Legt den Dokumententyp (das Dateiformat) sowie die Archivattribute fest. Für einzelne Datenfelder können konstante Texte und Makrovariablen hinterlegt werden. Die Standard-Dokumentenerkennung sucht nach einem Belegdatum und einer passenden Kategorie.

Seite Makros

Optionale Makros unterstützen beispielsweise die Belegerkennung und einen Dokumenten-Workflow.

Siehe auch

Manuelles Scannen ohne Profil

Geraderücken

Papierformate definieren


Texterkennung

Navigation: Dokumentenmanagement > Scannen >

Texterkennung

Einstellungen OCR-Software

Papierdokumente liegen nach dem Scannen nur als Bilddaten vor. Eine OCR-Software kann den enthaltenen Text erkennen und eine Volltextsuche ermöglichen.

Wählen Sie bitte im Menü Datei | Optionen | Einstellungen die Seite Volltextindex | OCR und legen Sie die gewünschten Optionen fest:

Klicken Sie im Bild auf die Komponenten, zu der Sie weitere Hilfe wünschen.

Office Manager DMS bietet mehrere Schnittstellen zur OCR-Software, wählen Sie:

·keine: wenn Sie die Dokumente nicht indexieren möchten.

·Windows RT: ist ab Windows 10 im Betriebssystem integriert.

·Kofax/Nuance OmniPage kann vom Office Manager direkt gesteuert werden und bietet sehr gute Ergebnisse.
Siehe auch Option Nur OCR.

·Tesseract Open Source OCR Engine ist unter der Apache Lizenz verfügbar und wird zusammen mit Office Manager DMS installiert.
Siehe auch https://github.com/tesseract-ocr/tesseract.

·ABBYY FineReader for ScanSnap wird zusammen mit dem Dokumentenscanner ScanSnap von Ricoh bzw. Fujitsu installiert. Aktivieren Sie im ScanSnap Manager bzw. in ScanSnap Home bitte die Option "In durchsuchbare PDF konvertieren" oder realisieren Sie die nachträgliche OCR-Ausführung mit einem Makrobefehl.
Sie können den FineReader auch verwenden, wenn Sie Dokumente über ein anderes Gerät, beispielsweise einen Twain-Scanner einlesen. Die Datei "Scan2Pdf.exe" muss vorhanden sein. Passen Sie bitte wichtige Einstellungen an, siehe Hotline-Blog.

·ABBYY Hot Folder, OmniPage Agent, ReadIRIS u. ä.: OCR-Programme, die ein Verzeichnis überwachen und neue Dokumente automatisch verarbeiten. Beachten Sie bitte die Anleitung zum Einrichten dieser Funktion.

·Transym OCR (TOCR ab 2.0) ist eine preisgünstige Software, die Sie vorab auch kostenlos testen können (s. a. erweiterte Optionen). Eine Downloadmöglichkeit finden Sie unter https://transym.com.

·Azure Read Cloud-OCR/ICR (nur in Pro- und Enterprise-Editionen) nutzt die kostenpflichtigen Onlinedienste von Microsoft für maschinelles Lernen. Als ICR (Intelligent Character Recognition) kann diese Lösung auch handschriftliche Texte erkennen.

·Andere, Parametergesteuert: diese Option ist flexibel und arbeitet mit OCR-Programmen zusammen, die den Text in einer Grafikdatei erkennen und dieses selbständig in der Grafik- oder PDF-Datei hinterlegen können.

·Andere, Makrogesteuert: die flexibelste Möglichkeit OCR-Software programmiert anzusteuern.

Klicken Sie bitte, sofern möglich, auf den Schalter Testen, um die Funktion der gewählten OCR zu prüfen.

Mit der Option Ausführungszeit können Sie die OCR als Hintergrundfunktion definiert und während der Erkennung ungestört weiterarbeiten. Beim Fujitsu ScanSnap mit sofortiger Texterkennung wird diese von der Scannersoftware ausgeführt.

Wenn bei Ausführen auf der Name eines Computers angegeben ist, dann wird die Texterkennung nur auf diesem ausgeführt. Eine OCR-Software muss dann nur auf einem Computer im Netzwerk installiert sein - das spart Lizenzkosten.

Die Option Texterkennung auch für Dateianlagen ausführen ist sehr zeitaufwendig und nur sinnvoll, wenn Sie regelmäßig gescannte Dateianlagen per E-Mail erhalten.

Hinweise:

Die OCR-Software wird nur automatisch ausgeführt, wenn die Volltextindexierung auf "Index über alle Datenfelder und Dokumentinhalte" eingestellt ist.

Siehe auch

OCR beim Import

Texterkennung manuell ausführen

Papierdokumente scannen

Einstellungen Volltextindex

Hotline-Blog: OCR-Texterkennung


Dokumenten-Eigenschaftendialog

Navigation: Dokumentenmanagement >

Dokumenten-Eigenschaftendialog

Dokumenten-Eigenschaftendialog

Wählen Sie bitte im Hauptmenü den Befehl Erstellen | Neu | Dokument, um ein neues Dokument zu erstellen, oder Bearbeiten | Dokument | Eigenschaften (Alt+Eingabe), um die Attribute der markierten Dokumente zu ändern.

Screenshot: Archivattribute bearbeiten

Klicken Sie im Bild auf die Komponenten, zu der Sie weitere Hilfe wünschen.

Die Attribute (Tags) beschreiben das Dokument und bilden neben dem Volltextindex eine wichtige Grundlage zum späteren Wiederfinden. Sie können selbst festlegen, welche Tags Sie vergeben möchten und welche Optionen die einzelnen Datenfelder haben. Das Layout des Dialogfensters können Sie mit dem Designer anpassen.

Dokumenttyp: Anwendungsprogramm. Welche Art von Dokument möchten Sie erstellen, z. B. PDF-Dokument, Foto oder CAD-Zeichnung.

Status: Aktueller Dokumentenstatus, wie Normal, Eilig oder Ablage.

Nummer: Eine beliebige Dokumentennummer.

Name: Bezeichnung des Dokumentes.

Projekt: Zuordnung des Dokumentes zu einem Projekt.

Kategorie: Zuordnung zu einer beliebigen Kategorie (z. B. Brief oder Rechnung).

Zum Bearbeiten der Auswahlliste eines Kombinationsfeldes klicken Sie bitte mit der sekundären (i. d. R. der rechten) Maustaste auf das Eingabefeld, um das lokale Menü zu öffnen.

Seite "Datei"

Vorlagendatei: Ist nur beim manuellen Erstellen eines neuen Dokuments sichtbar und ermöglicht die Auswahl einer Vorlagendatei (Brief, Angebot, Rechnung, ..) mit der das neue Dokument vorbereitet wird.

Dokumentdatei "name.ext" importieren: Diese Beschriftung ist nur beim Import einer Dokumentendatei sichtbar. Klicken Sie mit der sekundären Maustaste auf diesen Text um das lokale Menü für weitere Informationen zu öffnet.

Datei: Name der Datei, in der das Dokument gespeichert wird. Der Dateiname wird normalerweise automatisch im voreingestellten Dokumenten-Verzeichnis vergeben. Sie können hier aber auch einen Dateinamen vorgeben.

Adresse (nur für Internet): URL der Internet-Seite. Geben Sie die Adresse (https://www.....) ein, die beim Aufruf dieses "Dokumentes" im Browser geöffnet werden soll.

Schreibschutz: Solange die Option markiert ist, kann die Dokumentdatei nicht geändert werden.

Dokumentdatei komprimieren: Komprimierte Dateien belegen weniger Speicherplatz auf dem Datenträger, der Zugriff ist aber etwas langsamer. Die Komprimierung erfolgt mit Windows-Funktionen.

Zugriffsrechte: Legt die Datei-Berechtigungen der Benutzer und Benutzergruppen für dieses Dokument fest.

Seite "Vorschau"

Zeigt die Dokumentdatei in der integrierten Vorschau.

Seite "Versionen"

Listet die Versionen des Dokuments auf.

Seite "Aufgaben"

Tätigkeiten des Dokuments.

Seite "Notizen"

Geben Sie beliebige Notizen zu diesem Dokument ein.

Seite "Protokoll"

Die Dokumentbearbeitung wird protokolliert, sofern die Option Dokumentbearbeitung protokollieren aktiviert ist.

Es ist auch möglich, die Änderungen an einzelnen Daten nachzuverfolgen, aktivieren Sie dazu die Option Änderungen protokollieren für die gewünschten Datenfelder.

Um Vorgänge manuell zu protokollieren, geben Sie bitte Text im Feld Letzte Ereignisse ein.

Die Historie kann nur vom Administrator bearbeitet oder gelöscht werden.

Seite "Zeichnung" und "Weitere"

Spezielle Angaben, beispielsweise für CAD-Zeichnungen. Der Office Manager Pro und Enterprise kann den Schriftkopf einer neuen CAD-Zeichnung automatisch mit den hier eingegebenen Daten ausfüllen. Die Seiten sind nur sichtbar, wenn im Layout Komponenten enthalten sind.

Seite "Rechnung"

Verfügbar in diesen Editionen

Elektronische Rechnungen beinhalten Datensätze für die einzelnen Rechnungspositionen. Diese können hier aus der E-Rechnung gelesen, dargestellt sowie um Kostenstelle und Notizen erweitert werden.

Ein Klick auf Importieren liest die Posten aus der E-Rechnung in die Tabelle ein. Mit Editieren können Notizen hinzugefügt und eine Kostenstelle hinterlegt werden.

Dokument speichern

Klicken Sie auf die Schaltfläche OK, um die Dokumentattribute in der Archivdatenbank zu speichern.

Siehe auch

Eigenschaftendialog beim Import öffnen


Dokumente suchen

Navigation: Dokumentenmanagement >

Dokumente suchen

Dokumente suchen

Im unteren Bereich der Office Manager-Oberfläche finden Sie die Tabelle mit den Dokumenten. Die angezeigten Dokumente werden mit den Suchfunktionen gefiltert. Wenn Sie z. B. im Projektnavigator einen Eintrag markieren und auf Suchen klicken, werden nur die Dokumente angezeigt, die diesem Projekt zugeordnet sind.

Wählen Sie bitte ein Projekt und geben Sie weitere Attribute in den Suchfeldern oberhalb der Tabelle eingeben. Grenzen Sie die gezeigten Dokumente solange ein, bis Sie das gesuchte Dokument in der Tabelle sehen. Mit einem Doppelklick auf den Tabelleneintrag wird das Dokument geöffnet.

Es stehen Ihnen mehrere Funktionen für die Suche zur Verfügung:

·Der Projektnavigator

·Die primären Suchfelder

·Der Volltextindex

·Steuer- und Jokerzeichen

·Die Suche nach ähnlichen Dokumenten

·Datumssuche

·Zusätzliche Funktionen

·Datensätze fixieren

·Schrittweise weitersuchen

·Die erweiterte Suche

·Wechsel zwischen zuvor verwendeten Abfragen

·Zur Suche hinzufügen

·SQL-Datenabfragen

·Gespeicherte Standardabfragen


Projektnavigator

Navigation: Dokumentenmanagement > Dokumente suchen >

Projektnavigator

Der Projektnavigator

Der Navigator ermöglicht Ihnen unter anderem eine schnelle Suche nach Dokumenten, die bestimmten Projekten zugeordnet sind.

Screenshot eines einfachen Projektnavigators

Einfache Projektliste
Screenshot mit erweiterten Projekeigenschaften

Erweiterte Eigenschaften

Blenden Sie den Navigator ein, falls dieser nicht sichtbar ist.

Öffnen Sie die Projekt-Baumstruktur und klicken Sie doppelt auf das Projekt oder Unterprojekt, mit dem Sie arbeiten möchten. Es werden jetzt nur die Dokumente gezeigt, die dem gewählten Projekt zugeordnet sind. Siehe auch unter primäre Suchfelder.

Sie können auch mehr als ein Projekt markieren, wenn Sie die Dokumente mehrerer Projekte suchen (Oder-Verknüpfung). Klicken Sie dazu bitte auf den ersten Eintrag, halten Sie die Strg-Taste gedrückt und klicken Sie auf weitere Einträge.

Projektliste bearbeiten

Wählen Sie bitte im Menü Datei | Optionen den Befehl Auswahllisten, um die Projekte zu bearbeiten oder klicken Sie mit der sekundären (i. d. R. der rechten) Maustaste auf den Navigator und verwenden Sie den Eintrag Projekte im lokalen Menü.

Projekte kopieren

Innerhalb des Navigators können Sie bestehende Projekte mit allen Unterknoten kopieren:

1.Über die Zwischenablage: Markieren Sie die zu kopierenden Projekte und klicken Sie auf Bearbeiten | Zwischenablage | Kopieren. Markieren Sie anschließend das Projekt, unterhalb dem die kopierten eingefügt werden sollen; oder markieren Sie "[alle Projekte]" zum Einfügen in der ersten Ebene. Klicken Sie anschließend auf Bearbeiten | Zwischenablage | Einfügen Einfügen.

2.Mit Drag&Drop: schieben Sie die zu kopierenden Projekte mit der Maus auf das Projekt, unterhalb dessen die kopierten eingefügt werden sollen.

Anschließend können Sie die Kopien umbenennen: Rechtsklick, Befehl Projekte | Eigenschaften im lokalen Menü.

Projekte verschieben

Sie können die Projekte auch innerhalb der Struktur verschieben und dabei die Dokumente entsprechend mitnehmen. Schieben Sie dazu, wie beim oben beschriebenen Kopieren, ein einzelnes Projekt per Drag&Drop an die gewünschte Position in der Struktur, halten Sie aber vor dem Lösen der Maustaste die Strg-Taste fest.

Beachten Sie bitte, dass die Projektstruktur den Verzeichnissen im Windows-Explorer zwar ähnlich sieht, technisch aber etwas völlig anderes ist. Beim Verschieben wird die Projektstruktur und anschließend jeder einzelne Dokumentdatensatz angepasst. Je nach Einstellung werden auch die Dokumentdateien auf dem Datenträger verschoben. Der Vorgang dauert also deutlich länger als das Verschieben eines Verzeichnisses im Explorer.

In revisionssicheren GoBD-Archiven wird eine nachträgliche Änderung des Projekts bzw. Buchungsjahres für jedes Dokument protokolliert. Führen Sie Änderungen nur durch, wenn diese erforderlich und nachvollziehbar sind.

Projekt suchen

Wenn Sie in einer umfangreichen Projektstruktur einen Eintrag suchen, dann klicken Sie bitte mit der rechten Maustaste auf den Navigator. Wählen Sie im lokalen Menü den Befehl Suchen und geben Sie den gewünschten Projektnamen, die erweiterte Beschreibung oder einen Teil davon ein. Klicken Sie auf OK.

Wenn Sie erneut den gleichen Begriff verwenden, dann wird die Suche beim derzeit markierten Projekt fortgesetzt. Geben Sie einen neuen Begriff ein, wird vom Anfang der Liste an gesucht. Sie können die Tastenkombination Strg+F verwenden, wenn der Navigator den Eingabefokus hat.

Lokales Menü

Klicken Sie bitte mit der sekundären Maustaste (dies ist meist die rechte Taste) auf den Navigator, um das lokale Popupmenü zu öffnen:

Lokales Menü des Projektnavigators

Suchen: Ermöglicht die Suche nach Projekten in einer umfangreichen Struktur, siehe oben.

Aktualisieren: Lädt die Projektliste neu, um beispielsweise die Änderungen anderer Mitarbeitenden einzulesen. Sie können auch F5 drücken, wenn der Navigator den Eingabefokus hat.

Knoten öffnen: Öffnet die gesamte Projektstruktur.

Knoten schließen: Schließt die Struktur, sodass nur noch die Hauptebene gezeigt wird.

Optionen | Genaue Suche: Wenn diese Option markiert ist, dann werden nur Dokumente gefunden, die im markierten Projekt abgelegt sind. Ist "Genaue Suche" nicht markiert, dann werden alle Dokumente gefunden, deren Projektzuordnung mit dem markierten beginnt - unter anderem auch die Dokumente in Unterprojekten. Siehe auch Jokerzeichen $.

Optionen | Knoten erweitern: Die Baumknoten automatisch erweitern, sobald diese markiert werden.

Optionen | Archiv-Schnellzugriff: Blendet oberhalb des Navigators eine Auswahlbox mit den Archivdatenbanken ein.

Hilfe: Öffnet diese Hilfeseite.

Untermenü Projekte

Die Bezeichnung des Untermenüs wird dynamisch angepasst. Wenn Sie das Projektattribut umbenannt haben, dann wird die benutzerdefinierte Bezeichnung verwendet. Im Buchhaltungsarchiv ist dies z. B. "Jahr".

Neuer Eintrag: Ein neues Projekt auf der Ebene des markierten hinzufügen.

Neuer Untereintrag: Dem markierten Projekt ein Unterprojekt hinzufügen.

Eigenschaften: Den markierten Eintrag umbenennen. Die enthaltenen Dokumente werden dabei entsprechend angepasst.

Kopieren: Markierte Projekte in die Zwischenablage kopieren.

Einfügen: Projekte aus der Zwischenablage einfügen.

Alles markieren: Wählt alle Hauptprojekte aus.

Löschen: Alle markierten Projekte löschen. Hierbei werden die enthaltenen Dokumente aber nicht gelöscht. Sie werden gewarnt, falls noch Dokumente vorhanden sind.

Auswahllisten: Projekte und andere Auswahllisten bearbeiten. Hierfür wird ein eigenes Dialogfenster geöffnet. Sie haben unter anderem auch die Möglichkeit, Projektlisten in Dateien zu speichern und aus diesen zu laden.

Tipp: Dokumentzuordnung ändern

Sie können die Projektzuordnung eines oder mehrerer Dokumente per Drag&Drop ändern.

Beispiel: Sie möchten drei Dokumente aus dem Projekt "Prinzenallee" dem Projekt "Zernsdorf" zuordnen. Markieren Sie die drei Dokumente in der Tabelle und schieben Sie diese mit der Maus auf den Eintrag "Zernsdorf" im Navigator.

Der Navigator ist immer eingeblendet, wenn kein Projekt-Suchfeld vorhanden oder die Option "Projekte vorselektieren" markiert ist.

Siehe auch

Hauptmenü Navigator

Dokumente suchen

Projekte vorselektieren

Archiv-Schnellzugriff


Primäre Suchfelder

Navigation: Dokumentenmanagement > Dokumente suchen >

Primäre Suchfelder

Primäre Suchfelder

Die primären Suchfelder befinden sich im Hauptfenster von Office Manager DMS oberhalb der Datentabelle. Sie können die Dokumente oder Kontakte anhand ihrer Eigenschaften, wie Nummer, Name, Projekt, Kategorie, Dokumenttyp u. a. suchen.

Wählen Sie z. B. aus der Liste des Suchfeldes Projekt einen Eintrag aus (oder geben Sie das gesuchte Projekt in das Eingabefeld ein) und klicken anschließend auf die Schaltfläche Suchen. Die Dokumenttabelle zeigt jetzt nur noch die Dokumente des ausgewählten Projektes. Sollte die erhaltene Anzahl der Treffer zu groß sein, selektieren Sie in weiteren Feldern: wählen Sie beispielsweise den Dokumenttyp oder geben Sie Wörter Volltext ein, bis Sie Ihr Dokument gefunden haben. Mit einem Doppelklick wird das Dokument im entsprechenden Anwendungsprogramm geöffnet.

Sie brauchen die Suchfelder nicht vollständig auszufüllen. Wenn im Feld Projekt z. B. "Prin" eingegeben wurde, wird nach allen Projekten gesucht, die mit "Prin" beginnen. Sie können auch folgende Jokerzeichen verwenden: Fragezeichen (?) für ein einzelnes Zeichen und Stern (*) für eine Folge von Zeichen.

Wenn Sie den Projektnavigator eingeblendet haben, dann können Sie mit Doppelklick auf einen Eintrag die Suche schnell auf die Dokumente des Projektes filtern.

Die Schaltfläche Suchen kann festgestellt werden. Klicken Sie auf den Pfeil der Schaltfläche oder klicken Sie diese mit der sekundären Maustaste an. Aktivieren Sie Automatisch im Popupmenü. Der Schalter Suchen ist jetzt permanent gedrückt. Die Suche wird automatisch gestartet, sobald Sie eine Änderung in einem Eingabefeld vornehmen. Alternativ können Sie in einem Suchfeld auch die Enter-Taste drücken, um die Suche zu starten.

Um der aktuellen Suche weitere Dokumente hinzuzufügen, halten Sie bitte die Umschalttaste gedrückt oder fixieren Sie Datensätze in der Tabelle.

Standardfelder

(Die folgenden Felder sind im Standardlayout verfügbar, s. a. Layoutdesigner)

·Nur Favoriten: Markieren Sie dieses Feld, um nur die Dokumente zu suchen, die als Favorit gekennzeichnet sind.

·Volltext: Suche im Volltextindex

·Nummer: Suche nach Dokument- bzw. Belegnummer

·Name: Suche nach Dokumentbenennung

·Projekt: Eingrenzung nach Projekten bzw. Buchungsjahren (s. a. Projektnavigator)

·Kategorie: Suche nach Kategorien, wie Rechnungen, Angebote, Fotos u. a.

·Dokumenttyp: Eingrenzung nach Dokumenttypen, wie Word, E-Mail, CAD.

·Kontakt: Nur die Dokumente eines Kontakts zeigen. Tipp: das Eingabefeld wird mit Entf. vollständig geleert.

·Belegdatum: Filterung nach Datum. Es werden nur die Dokumente des angegebenen Zeitraums gezeigt.

Siehe auch

Dokumente suchen

Eigene Suchfelder platzieren

Suche mit Oder-Verknüpfung

Erweiterte Datumssuche

Erweiterte Einstellungen: Suchmodus, Verzögerung

Steuer- und Jokerzeichen


Volltextsuche

Navigation: Dokumentenmanagement > Dokumente suchen >

Volltextsuche

Suche im Volltextindex

Office Manager DMS ermöglicht Ihnen neben der Suche in den einzelnen Attributen auch eine schnelle Abfrage über den Volltextindex. Hier sind, je nach Einstellung, die Wörter aus allen Attributen (Projekt, Name, usw.), den Notizen und den Dokumentinhalten enthalten.

Geben Sie im primären Suchfeld Volltext die gewünschten Wörter ein (Groß-/ Kleinschreibung wird nicht berücksichtigt) und drücken Sie die Eingabetaste oder klicken Sie auf den Schalter Suchen.

Die Dokumententabelle enthält jetzt nur noch Dokumente, die alle gesuchten Wörter enthalten. Falls Sie Dokumente suchen, die nur eines der eingegebenen Wörter enthalten, dann geben Sie bitte den großgeschriebenen OR-Operator ein: wort1 OR wort2. Das Eingabefeld verwendet die vorherigen Abfragen für eine Autovervollständigung.

Bei den meisten Textdokumenten (PDF, Word u. a.) werden die Suchbegriffe in der Vorschau hervorgehoben.

Wenn die KI-Funktionen mit GPT aktiviert sind, können Sie das Eingabefeld auch für Chats und Übersetzungen nutzen.

Alternativ können Sie auch auf den Schalter rechts im Eingabefeld klicken, um ein Dialogfenster für die Volltextrecherche zu öffnen:

Suche im Standard-Volltextindex

Mit diesem Dialog suchen Sie immer in allen Dokumenten, die primären Suchfelder und die Markierung im Projektnavigator wird nicht berücksichtigt.

Hinweis: Im Papierkorb ist keine Volltextsuche möglich.

Erweiterte Volltextsuche

Neben der einfachen Wortsuche gibt es, abhängig vom Datenbankformat des geöffneten Archivs, noch weitere Möglichkeiten. Beispielsweise Jokerzeichen und Phrasensuche. Wenn Sie im oben gezeigten Dialogfenster auf Hilfe oder im Hauptfenster auf das Fragezeichen im Suchfeld klicken, dann gelangen Sie direkt zur passenden Hilfeseite:

·Standard-Volltextsuche mit Access (*.omp), Firebird und MySQL

·Suche in SQLite-Archiven (*.omsl und *.omen)

·Microsoft SQL Server

Siehe auch

Einstellungen für den Volltextindex

Dokumente suchen

Info Volltextindex


Steuer- und Jokerzeichen

Navigation: Dokumentenmanagement > Dokumente suchen >

Steuer- und Jokerzeichen

Steuer- und Jokerzeichen für die Suche im Dokumentenarchiv

OR | Oder-Verknüpfung von Suchbegriffen (s. u.)
* | Platzhalter für eine Folge von Zeichen
% | Platzhalter für eine Folge von Zeichen (SQL-Standard)
? | Platzhalter für ein einzelnes Zeichen
_ | Platzhalter für ein einzelnes Zeichen (SQL-Standard)
! | Ungleich. Muss das erste Zeichen im Suchtext sein.
$ | Exakte Suche statt "beginnt mit"
^ | Normale Suche in Mehrfachauswahlfeldern.

Beispiele

Geben Sie !* ein, um nach leeren Felder zu suchen, bzw. nur * für eine Suche nach nicht leeren Feldern.

!begriff gibt alle Dokumente zurück, bei denen "begriff" im durchsuchten Feld nicht vorkommen.

meine * wörter findet beispielsweise "meine gesuchten Wörter".

me?er für "Meier" oder "Meyer".

wort$: Im durchsuchten Feld muss "wort" stehen und es darf kein weiterer Text darauf folgen.

^projekt$: Findet in einem Mehrfachauswahlfeld nur Dokumente, die nur genau "projekt" zugeordnet sind. Dokumente mit mehreren Zuordnungen werden nicht zurückgegeben.

Volltextsuche

Je nach verwendetem Datenbankformat haben Sie unterschiedliche Möglichkeiten bei der Volltextsuche. Beispielsweise Jokerzeichen oder Phrasensuche.

Oder-verknüpfte Suche

Wenn Sie beispielsweise alle Dokumente aus den Projekten "Prinzenallee" und "Kurfürstendamm" suchen, können Sie im primären Suchfeld Projekt den Text "Prinzenallee OR Kurfürstendamm" eingeben. Die Archivtabelle zeigt dann alle Dokumente, die entweder dem Projekt "Prinzenallee" oder "Kurfürstendamm" zugeordnet sind.

Bei einer Suche nach Projekten können Sie alternativ mehrere Einträge im Navigator markieren.

Für eine Oder-verknüpfte Suche im Volltextindex können Sie auch den Suche-Dialog verwenden. Klicken Sie dazu bitte auf den Schalter rechts im Eingabefeld Volltext.

Siehe auch

Dokumente suchen

Zur Suche hinzufügen

SearchOperatorOR


Suche nach ähnlichen Dokumenten

Navigation: Dokumentenmanagement > Dokumente suchen >

Suche nach ähnlichen Dokumenten

Suche nach ähnlichen Dokumenten

Archivtabelle - Popupmenü

Eine kleine aber schnelle Hilfsfunktion für die Suche. In der Tabelle sehen Sie beispielsweise ein Dokument mit dem Status "Eilig" und möchten nun alle Dokumente mit diesem Status suchen.

Klicken Sie dazu bitte mit der rechten Maustaste auf die Tabellenzelle Status, also auf den Text "Eilig". Wählen Sie nun im lokalen Menü den Befehl Suchen | Status=Eilig, die Tabelle wird sofort auf alle Dokumente mit Status "Eilig" gefiltert.

Siehe auch

Dokumente suchen


Datumssuche

Navigation: Dokumentenmanagement > Dokumente suchen >

Datumssuche

Suche mit Datumsfeldern

Die primären Suchfelder befinden sich im Hauptfenster oberhalb der Datentabelle. Sie können hier nach den wichtigsten Dokumentattributen, wie Name, Nummer, Projekt oder dem Erstellungsdatum suchen.

Einfache Datumssuche

Wenn Sie die Dokumente über ein Datum, wie beispielsweise dem Beleg- oder Erstellungsdatum suchen, dann zeigt die Tabelle alle Dokumente, die ab dem angegebenen Datum erstellt wurden. Eine einfache Datumssuche erfolgt also nach dem Schema "größer oder gleich".

Erweiterte Datumssuche

Sie können aber auch folgende Abfragen durchführen:

·Dokumente mit genau einem Datum (gleich),

·mit Datum ab dem gesuchten (größer oder gleich),

·mit Datum bis zum gesuchten (kleiner oder gleich),

·Zeitraumsuche mit Datum zwischen zwei Daten (größer/gleich Datum 1 und kleiner/gleich Datum 2).

Die erweitere Suche steht automatisch zu Verfügung, wenn ein Datumsfeld zweimal in den primären Suchfeldern platziert ist:

Screenshot Office Manager-Hauptfenster

Das Feld "Belegdatum" wurde hier zweimal in den primären Suchfeldern platziert: hinter dem Wort "Belegdatum" und hinter "bis".

Das Layout der Suchfelder können Sie mit dem Menübefehl Ansicht | Anpassen | Layout entwerfen | Dokumenten-Suche anpassen. Platzieren Sie das gewünschte Datumsfeld wie im obigen Screenshot zweimal. Achten Sie hierbei genau auf den Abstand vom oberen Rand, der Wert Y (oben) im Layoutdesigner muss für beide Suchfelder identisch sein. Wenn das rechte Feld auch nur einen Pixel höher positioniert ist, dann steht es in der Tabulator-Reihenfolge vor dem linken Feld und wird bei der Suche als Wert für "Von" betrachtet.

Erweiterte Suche am Beispiel des Erstellungsdatums:

Erstellt ab Datum
Von: nur das erste Feld enthält ein Datum. Es werden alle Dokumente gefunden, die ab dem 10.05.2025 erstellt wurden.
Erstellt bis Datum
Bis: findet Dokumente, die bis zum 31.05.2025 erstellt wurden.
Erstellt im Zeitraum
Von/bis: Dokumente mit Erstellungsdatum im Zeitraum vom 10.05.2025 bis 31.05.2025
Erstellt am
Am: beide Felder beinhalten dasselbe Datum. Hier werden nur Dokumente vom 18.05.2025 zurückgegeben.
Beide Datum-Suchfelder leer
Kein Filter: beide Felder sind leer, es werden alle Dokumente unabhängig vom Datum gefunden.

Schnelles Ausfüllen mit dem Popupmenü

Klicken Sie bitte mit der rechten Maustaste auf ein Datum-Suchfeld. Wenn dieses mehrfach vorhanden ist, können Sie im lokalen Menü auf vorbereitete Datums-Bereiche, wie Heute und Letzte Woche zurückgreifen. Beide Suchfelder werden entsprechend ausgefüllt und eine schnelle Zeitraumsuche ermöglicht. Mit dem Befehl Alle können Sie den Filter aufheben - die Suchfelder werden deaktiviert. Mit dem letzten Befehl oberhalb von Hilfe kopieren Sie das Datum des jeweils anderen Eingabefeldes in das angeklickte.

Mit rechter Maustaste klicken

Alternative Datum-Eingabe

Im Eigenschaftenfenster können Sie bei der Eingabe des Datums auch auch Texte, wie zum Beispiel "heute", "gestern" und "morgen" eingeben. Das Programm ermittelt daraus das Datum.

Siehe auch

Dokumente suchen

Primäre Suchfelder

Layout-Designer


Erweiterte Suche

Navigation: Dokumentenmanagement > Dokumente suchen >

Erweiterte Suche

Erweiterte Suche

Erweiterte Suche mit Hilfe des Eigenschaftendialogs. Klicken Sie bitte auf den Schalter [image] im Menü Start | Suchen und geben Sie im Dialogfenster die Attribute ein, nach denen die Dokumente gefiltert werden soll.

Sie können auch folgende Joker verwenden: Unterstrich "_" oder "?" für ein einzelnes Zeichen und "%" oder "*" für eine Folge von Zeichen. Geben Sie bitte "!*" oder "<<LEER>>" ein, um nach Dokumenten zu suchen, die im entsprechenden Attribut keinen Inhalt haben.

Dialog für erweiterte Archivsuche

Mausschaltflächen:

·OK führt die erweiterte Suche aus.

·SQL-Abfrage (nur sichtbar für Administrator): Die Suche wird in die SQL-Syntax umgewandelt. Sie können dann den SQL-Code direkt bearbeiten.

·Löschen leert den Inhalt aller Eingabefelder.

·Abbrechen schließt das Dialogfenster ohne eine Suche auszuführen.

·Hilfe: Hilfeüberblick zur erweiterten Suche.


Weitere Möglichkeiten

Navigation: Dokumentenmanagement > Dokumente suchen >

Weitere Möglichkeiten

Klicken Sie bitte auf der Menüseite Start | Suchen auf Weitere. Hier finden Sie zusätzliche Möglichkeiten für die Archivsuche:

Gespeicherte Abfragen

Dies ist für häufig wiederkehrende Recherchen sinnvoll. Suchen Sie zuerst mit den verschiedenen Filtermöglichkeiten nach Dokumenten oder Kontakten. Klicken Sie anschließend auf den Menübefehl Start | Suchen | Weitere | Gespeicherte Abfragen | Hinzufügen und geben Sie eine sinnvolle Bezeichnung ein. Später können Sie dann zu dieser Abfrage zurückkehren, indem Sie den entsprechenden Menüpunkt unter Gespeicherte Abfragen anklicken.

Diese Funktion ist benutzer- und datenbankspezifisch. Sie sehen die gespeicherten Abfragen nur, wenn Sie dieselbe Archiv- oder CRM-Datenbank geöffnet haben, mit der Sie die Abfrage gespeichert hatten. Zum Löschen halten Sie bitte die Strg-Taste gedrückt während Sie den gewünschten Eintrag im Menü anklicken.

Suche nach bestimmten Attributen

Falls Sie nach einem Attribut suchen möchten, welches nicht in den primären Suchfelder enthalten ist, dann klicken Sie bitte auf der Menüseite Start | Suchen auf Weitere. Wählen Sie das gewünschte Datenfeld und geben Sie den gesuchten Text ein. Nach einem Klick auf OK wird die Dokument- bzw. Kontakttabelle entsprechend gefiltert.

Wenn das Attribut nicht im Untermenü enthalten ist, dann können Sie

·[Andere...] wählen, um mit dem Feldnamen oder der Feldbezeichnung zu suchen,

·die erweiterte Suche verwenden oder

·das Menü um den gewünschten Eintrag erweitern: In Datei | Datenbank | Anpassen | Felder definieren das gewünschte Datenbankfeld markieren und die Option Eintrag im Menü "Start | Suchen | Weitere" aktivieren.

Leere Suche

Wählen Sie diesen Befehl, um die Tabelle zu leeren. Es werden anschließend keine Datensätze gezeigt. Dies ist beispielsweise sinnvoll, wenn Sie neue Dokumente hinzufügen und anschließend mit diesen weiterarbeiten möchten.

Zuletzt hinzugefügt

Fragt die dem Archiv zuletzt hinzugefügten Dokumente ab. Standardmäßig werden 15 Datensätze gesucht. Wenn Sie eine andere Anzahl wünschen, dann halten Sie beim Klick auf den Menübefehl die Taste Strg fest. Besonderheiten:

·Aktuelle und archivierte Dokumente: Es werden nur die vom angemeldeten Anwender erstellte gesucht. Um die Dokumente aller Anwender zu sehen, halten Sie bitte die Umschalttaste fest, wenn Sie den Menübefehl anklicken. In dem Fall werden die Dokumente aber auch der aktuellen Suche hinzugefügt.

·In der Papierkorb-Ansicht werden die zuletzt gelöschten gezeigt. Bedingt durch die Sortierung nach Datum werden nicht genau, sondern mindestens 15 Datensätze abgefragt.

Volltext

Öffnet das Dialogfenster für die Volltextsuche. Dies entspricht einem Klick auf den Schalter rechts im Eingabefeld Volltext.

Klone

Verfügbar in diesen Editionen

Sucht alle Klone des markierten Dokuments. Dies sind weitere Datensätze, die mit derselben Datei verknüpft wurden.

Kontakte

Zu den Kontakten springen, die mit den markierten Dokumenten verknüpft sind

Erweitert

Suche mit Hilfe des Eigenschaftendialogs. Dies entspricht einem Klick auf den Schalter [image] im Menü Start | Suchen.

Datensatz fixieren

Fixierte Dokumente bzw. Kontakte bleiben immer in der Tabelle sichtbar, auch wenn sie nicht den eingegebenen Suchfiltern entsprechen.

Siehe auch

Dokumente suchen

Felder definieren


Schrittweise weitersuchen

Navigation: Dokumentenmanagement > Dokumente suchen >

Schrittweise weitersuchen

Text in Tabellen suchen

Mit Hilfe der zuvor beschriebenen Suchfunktionen werden die Dokumente aus der Datenbank abgerufen - sie bestimmen die Dokumente, welche in der Tabelle sichtbar sind.

Mit dem schrittweise Weitersuchen können Sie in der Tabelle zu den gewünschten Daten springen.

Beispiel

Betrachten Sie bitte folgende Dokumententabelle:

Sie möchten in diesem Suchergebnis zu einem Dokument springen, dessen Name mit "Antwort" beginnt:

1.Klicken Sie bitte zuerst mit der primären (i. d. R. der linken) Maustaste auf die gewünschte Zelle. In diesem Fall auf einen Namen, beispielsweise auf "Angebot Landhausdiele".

2.Geben Sie dann den gesuchten Text über die Tastatur ein, beispielsweise "antw".

In der Tabelle wird nun das erste Dokument markiert, dessen Name mit dem eingetippten Text beginnt:

Mit Hilfe den Tastenkombinationen Strg + Cursor aufwärts/abwärts können Sie zwischen den passenden Datensätzen blättern.

Diese Funktion ist in der Dokumententabelle sowie in vielen anderen Tabellen z. B. bei den Programmeinstellungen möglich.

Siehe auch

Dokumente suchen


Vor und zurück

Suche vor und zurück blättern

Navigation: Dokumentenmanagement > Dokumente suchen >

Suche vor und zurück blättern

Zwischen bereits ausgeführten Abfragen wechseln

Eine vergleichbare Funktion kennen Sie vermutlich aus Ihrem Internet-Browser: Dort wechseln Sie mit den Pfeilen links und rechts zu den zuvor besuchten Seiten.

In Office Manager DMS können Sie bequem zu den zuvor durchgeführten Archivabfragen bzw. Suchen nach Kontakten zurückkehren und zwischen diesen wechseln. Die Schaltflächen finden Sie in der Symbolleiste für den Schnellzugriff am oberen linken Rand des Hauptfensters:

Symbolleiste für den Schnellzugriff

Zur vorherigen Suche wechseln

Klicken Sie bitte auf den Schalter Zurück oder drücken Sie die Tastenkombination Alt+Links, um zur letzten Suche zurückzukehren.

Eine Suche vorwärts

Klicken Sie auf Vor oder drücken Sie die Tastenkombination Alt+Rechts, um anschließend wieder vorwärts zu blättern.

Hinweis

Das Programm speichert eine Abfrage sobald Sie auf Suchen klicken. Mit den Schaltflächen können Sie auch zwischen den Dokument-, Kontakt- und Aufgaben-Ansichten wechseln sowie die zuletzt verwendeten Archive öffnen.

Siehe auch

Dokumente suchen

Felder leeren rückgängig machen


Zur Suche hinzufügen

Navigation: Dokumentenmanagement > Dokumente suchen >

Zur Suche hinzufügen

Aktuelle Dokumentenabfrage erweitern

Nach Durchführung einer Suche zeigt die Tabelle nur die Dokumente, welche den Suchkriterien entsprechen; die vorherige Suche wird dabei ersetzt. Wenn Sie bei Ausführung der Suche allerdings die Umschalttaste gedrückt halten, dann bleibt die vorherige Suche erhalten, die Dokumente werden hinzugefügt.

Beispiel 1

Sie geben im primären Suchfeld Nummer den Text "AR09" ein, die Tabelle beinhaltet nach Klick auf Suchen alle Dokumente, dessen Nummer mit "AR09" beginnt.

Anschließend geben Sie den Text "LS09" ein.

·Wenn Sie jetzt auf Suchen klicken, dann finden Sie nur Dokumente mit Nummer "LS09...".

·Wenn Sie aber die Umschalttaste gedrückt halten, während Sie auf Suchen klicken, dann beinhaltet die Tabelle anschließend alle Dokumente, dessen Nummer mit "AR09" oder mit "LS09" beginnt.

Beispiel 2

Die Tabelle enthält -wie im Beispiel 1- alle Dokumente mit Nummer "AR09..." und Sie möchten zusätzlich die mit der Rechnung AR09123 verknüpften Dokumente sehen. Dazu markieren Sie die Rechnung, halten die Umschalttaste gedrückt, klicken auf Start | Suchen | Verknüpfungen und lösen die Umschalttaste wieder.

Datensatz fixieren

Fixierte Datensätze (Dokumente oder Kontakte) bleiben in der Tabelle sichtbar, auch wenn sie nicht dem eingegebenen Suchfilter entsprechen.

Markieren Sie die gewünschten Datensätze und wählen Sie anschließend den Menübefehl Start | Suchen | Weitere | Datensatz fixieren.

Darstellung fixierter Dokumente

Das erste, dritte und vierte Dokument ist in der Tabelle fixiert. Sie erkennen dies am Symbol Stecknadel vor der ersten Datenspalte.

Um die Datensätze wieder zu lösen, markieren Sie diese und öffnen Sie das Untermenü Start | Suchen | Weitere. Achten Sie darauf, dass das aktuelle Dokument ein fixiertes ist. Der Menübefehl heißt dann Fixierten Datensatz lösen - klicken Sie diesen an.

Sie können den Status fixiert/gelöst einzelner Datensätze auch direkt mit einem einzigen Mausklick umschalten: Klicken Sie dazu mit der Maus links neben der ersten Datenspalte auf den Bereich, auf dem das Symbol Stecknadel dargestellt wird.

Siehe auch

Dokumente suchen

Oder-verknüpfte Suche


SQL-Abfragen

Navigation: Dokumentenmanagement > Dokumente suchen >

SQL-Abfragen

Suche mit SQL-Abfragen

Die SQL-Abfrage werden Sie für Ihre tägliche Arbeit nicht benötigen. Wenn Sie die SQL-Datenbanksprache beherrschen, bietet sie Ihnen jedoch vielfältige Archiv- und Kontaktabfragen und vereinfacht einige Wartungsarbeiten. Die Künstliche Intelligenz unterstützt bei der Erzeugung von SQL-Abfragen.

In der Grundkonfiguration ist der Befehl nur im Administrationsmodus sichtbar.

Mit dem Menübefehl Administrator | Skript | SQL-Abfrage | SQL-Editor öffnen Sie den Editor zur Eingabe von Befehlen. Sie können auch eine erweiterte Suche in SQL umwandeln.

Editor für SQL

Sie können Makro-Variablen verwenden, um z. B. die Suche nach einem Schlüsselbegriff in mehreren Feldern zu realisieren.

Menübefehle im Fenster SQL-Abfrage

Menü Datei

·Öffnen liest eine gespeicherte SQL-Abfrage aus einer Datei.

·Speichern: Speichert die SQL-Abfrage in eine Datei. Auf gespeicherte Abfragen kann direkt aus dem Hauptmenü zugegriffen werden, siehe unten.

·Speichern unter: Speichert die SQL-Abfrage unter einem neuen Dateinamen.

·Aktuelle Abfrage lädt die aktuelle Archivabfrage (die derzeitige Suche) und überschreibt damit den Text im Editor.

·GPT-Assistent erzeugt mit Hilfe der KI aus Ihrer freien Texteingabe, wie "Die Dokumente des Projekts Musterstraße", eine SQL-Abfrage und überschreibt damit den Text im Editor.

·Schließen: Schließt das Fenster SQL-Abfrage ohne eine Suche auszuführen.

Menü Abfrage

·Ausführen sendet SQL-Anweisungen an die Datenbank.

·Ausführen und schließen: Die SQL-Abfrage wird ausgeführt und das Fenster geschlossen.

·Temporäre Ergebnismenge verwenden: Die Abfrage wird in einem neuen Fenster dargestellt, die Suche im Hauptfenster bleibt unverändert.

·In Anwendungsdatenbank ausführen: SQL-Anweisungen an die Anwendungsdatenbank senden, kein Select.

Menü Hilfe

·Hilfeübersicht und spezielle Themen zur SQL-Abfrage.

·SQL-Syntax öffnet eine SQL-Beschreibung im Internet.

ACHTUNG: Mit SQL können auch Datenbanken gelöscht werden! Führen Sie nur Abfragen (SELECT) und keine Datenänderungen oder -Definitionen aus.

Siehe auch:

SQL-Beispiele im OMDN

Gespeicherte SQL-Abfragen

Verfügbar in diesen Editionen

Führt eine gespeicherte SQL-Abfrage aus. Im Menü Administrator | Skript | SQL-Abfrage werden alle *.sql-Dateien gelistet, die sich im Verzeichnis "\SQL\Menu\" unterhalb der gemeinsamen Dateien befinden.

Menü Suchen | SQL-Abfrage

Wählen Sie Administrator | Skript | SQL-Abfrage | Abfrage ausführen, um SQL-Dateien auszuführen, die nicht im Menü gelistet sind.

Siehe auch

Gespeicherte Standard-Abfragen


Dokumente öffnen

Navigation: Dokumentenmanagement >

Dokumente öffnen

Dokumente öffnen und bearbeiten

1.Betrachten Sie die Dokumenteinträge in der Tabelle. Verwenden Sie die Suchfunktionen, um die Dokumente zu filtern.

Menü Start im Hauptfenster

2. Markieren Sie bitte das gewünschte Dokument - oder mehrere gleichzeitig - in der Tabelle. Zum Öffnen können den Menübefehl Start | Verwenden | Öffnen verwenden, die Eingabetaste drücken oder doppelt auf das Dokument klicken.

3.Das entsprechende Anwendungsprogramm wird gestartet und das Dokument geöffnet.

4.Dokumente, die nicht schreibgeschützt archiviert sind, können Sie jetzt bei Bedarf bearbeiten und speichern.

5.Sobald Sie zu Office Manager DMS zurückkehren, wird bei geänderten Dokumenten der Volltextindex aktualisiert. Den Fortschritt der Aktualisierung sehen Sie links unten in der Programm-Statuszeile:
Aktualisiere Gesamtindex

6.Das Programm protokolliert je nach Einstellung den Zugriff auf die Dokumente, siehe Eigenschaftendialog auf Seite Protokoll.

Wenn Sie nicht die Dokumentdatei, sondern die Attribute in der Archivdatenbank ändern möchten, dann markieren Sie bitte das Dokument und wählen auf der Menüseite Bearbeiten den Befehl Eigenschaften.

Dateianlagen direkt öffnen

Verfügbar in diesen Editionen

Die Anlagen einer E-Mail, PDF sowie die in ZIP- und anderen Komprimierungsarchiven enthaltenen Dateien können Sie direkt öffnen oder extrahieren, ohne die Dokumentdatei zuvor öffnen zu müssen. Klicken Sie bitte auf Start | Verwenden | Anlagen oder auf den Schalter Öffnen der Schnellzugriff-Leiste, um die enthaltenen Anlagen direkt zu öffnen:

Ein Klick auf eine Anlage speichert diese im temporären Verzeichnis und öffnet sie, ohne dass zuvor das Hauptdokument geladen werden muss. Um alle enthaltenen Dateien in ein Verzeichnis zu exportieren, wählen Sie bitte Start | Verwenden | Senden | Extrahieren.

Beachten Sie auch die Liste der Dateianlagen unterhalb der Dokumentenvorschau.

Office Manager ermöglicht hier auch den Zugriff auf Dateianlagen, die in einer winmail.dat gespeichert sind.


Vorschau-Fenster

Navigation: Dokumentenmanagement >

Vorschau-Fenster

Vorschau für Dokumente, Kontakte und Aufgaben

Damit Sie sich innerhalb der gefundenen Dokumente noch besser zurechtfinden, können Sie eine Vorschau einblenden. In der Dokumentenansicht sehen Sie den Dateiinhalt, bei den Kontakten und Aufgaben den Datensatz.

Markieren Sie das gewünschte Dokument (bzw. Kontakt oder Aufgabe) in der Tabelle und klicken Sie auf Start | Verwenden | Vorschau, falls das Vorschaufenster noch nicht geöffnet ist.

Wenn Sie eine Volltextsuche ausgeführt haben, dann werden die Suchbegriffe in den meisten Textdokumenten farblich hervorgehoben.

Bei Dokumenten mit Dateianlagen, wie beispielsweise E-Mails ZIP- und PDF-Dateien, haben Sie auch die Möglichkeit, direkt im Vorschaufenster auf die Anlagen zuzugreifen. Ist ein Kontakt oder eine Aufgabe dargestellt, wird die Visitenkarte bzw. das iCalender-Format als Anlage angeboten.

Vergrößern und Bildschirm-Lupe

Falls das dargestellte Dokument zu klein ist, um die gewünschten Details zu erkennen, können Sie

·die Vorschau vergrößern, indem Sie den linken Rand mit der Maus verschieben.

·Die Vorschau als eigenständiges Fenster nutzen, auch auf einem anderen Monitor.

·Details mit der Lupe vergrößern. Halten Sie die Taste Strg gedrückt und bewegen Sie die Maus über den Vorschaubereich. Für eine stärkere Vergrößerung halten Sie Strg und Umsch. gleichzeitig gedrückt.

·Mit einem Rechtsklick auf das Dokument öffnen Sie das lokale Menü mit Zoom-Optionen.

Siehe auch

Einrichten des Vorschauprogramms

Report drucken


Attribute bearbeiten

Navigation: Dokumentenmanagement >

Attribute bearbeiten

Dokumentdatensatz bearbeiten

1. Beschreibung eines einzelnen Dokuments ändern

Wenn Sie die Attribute eines Dokumentes ändern möchten, dann markieren Sie dieses bitte in der Tabelle und klicken auf Bearbeiten | Dokument | Eigenschaften. Das Dialogfenster "Bearbeite Datensatz" wird geöffnet:

Ändern Sie die gewünschten Dokumentattribute und speichern Sie diese mit Klick auf OK.

In der Tabelle bearbeiten

Sie können die Attribute auch direkt in der Tabelle ändern. Wählen Sie dazu bitte Ansicht | Tabelle | Editieren und klicken Sie mit der Maus auf die Tabellenzelle, die Sie bearbeiten möchten. Geben Sie Text ein oder wählen Sie einen Eintrag aus der Liste. Bitte beachten Sie, dass die Änderungen erst gespeichert werden, wenn Sie die Tabellenzelle wechseln. Im GoBD-Modus können relevante Daten nur mit dem Eigenschaftendialog korrigiert werden.

Mittels Drag&Drop können Sie Dokumente in ein anderes Projekt oder einen Knoten innerhalb der gruppierten Tabelle verschieben.

2. Mehrere Datensätze gleichzeitig ändern

Markieren Sie die gewünschten Dokumente (oder auch Kontakte) in der Tabelle und klicken Sie auf Bearbeiten | Dokument | Eigenschaften. Das Eigenschaftenfenster wird geöffnet. Im Gegensatz zur Bearbeitung eines einzelnen Datensatzes sind die Felder jetzt aber leer.

Wenn Sie Daten in ein oder mehrere Felder eingeben und anschließend auf OK klicken, dann werden die Änderungen nach einer Rückfrage auf alle markierten Dokumente bzw. Kontakte angewandt. Zum Löschen der Daten eines Feldes geben Sie <<LEER>> ein. Sie können auch Makro-Variablen verwenden, um beispielsweise Inhalte aus anderen Feldern zu kopieren.

Im GoBD-Modus werden Sie zusätzlich gewarnt, falls revisionsrelevante Felder geändert werden sollen. Nach dem Durchlauf erhalten Sie die Information, wie viele Dokumente angepasst wurden. Dies können weniger sein, beispielsweise werden Daten nur geändert, wenn der bisherige Wert auch tatsächlich vom neuen abweicht. Auch mangelnde Berechtigungen können ein Grund sein.

Beispiel:

Das Projekt "Prinzenallee" beinhaltet unter anderem 24 Dokumente mit dem Status "Erledigen". Sie möchten den Status dieser Dokumente nun auf "Normal" ändern:

Geben Sie im Suchfeld Projekt den Wert "Prinzenallee" und im Feld Status "Erledigen" ein, klicken Sie auf Suchen. Die Tabelle zeigt jetzt nur noch die 24 Dokumente an. Markieren Sie diese und wählen Sie den Menübefehl Bearbeiten | Dokument | Eigenschaften. Das Fenster "Felder mehrerer Dokumente ersetzen" wird geöffnet. Geben Sie im Eingabefeld Status den Wert "Normal" ein, klicken Sie auf OK und beantworten Sie die Sicherheitsabfrage mit Ja.

Für die Änderung von Dateinamen benötigen Sie Administrator-Rechte. Wenn Sie die Dokumentendatenbank an neue Verzeichnisstrukturen anpassen möchten, nutzen Sie bitte die Funktion Datei | Datenbank | Anpassen | Dateipfade ändern.

Mausschaltflächen

OK führt die Funktion aus

Löschen leert die Eingabefelder

Abbrechen schließt das Fenster ohne die Funktion auszuführen

Hilfe öffnet dieses Hilfefenster


Mehrfachzuordnungen

Navigation: Dokumentenmanagement >

Mehrfachzuordnungen

Verfügbar in diesen Editionen

Mehrfachzuordnungen

Ein Dokument oder Kontakt lässt sich gleichzeitig mehreren Einträgen einer Auswahlliste (Kategorien u. ä.) zuordnen.

Voraussetzung (siehe Datei | Datenbank | Anpassen | Felder definieren): das Attribut muss den Eingabestil "Nur Auswahl aus strukturierter Liste" mit der Option Mehrfachauswahl verwenden.

Wenn Sie einen neuen Datensatz erstellen oder einen bestehenden bearbeiten, dann können Sie in der Auswahlliste mehrere Einträge markieren:

Dokument gleichzeitig in 2 Projekten

Öffnen Sie bitte die Liste und klicken Sie mit der primären Maustaste auf die Checkboxen der Einträge, denen das Dokument bzw. der Kontakt zugeordnet werden soll. Klicken Sie einen der bereits gewählten Texte oder den Pfeil an, um die Auswahlliste zu schließen. Wenn Sie einen noch nicht markierten Text anklicken, wird nur dieser ausgewählt und die Liste geschlossen.

Die gewählten Einträge sind mit Semikolon plus Leerzeichen getrennt im Datenfeld gespeichert. Einträge lassen sich nur hinzufügen, wenn die Länge des Datenfeldes für alle Listeneinträge mit den Trennzeichen ausreicht.

Siehe auch

Dokumente kombinieren

Dokumentenklone

Steuer- und Jokerzeichen


Rückgängig

Navigation: Dokumentenmanagement >

Rückgängig

Ausgeführte Funktion widerrufen

Menü Bearbeiten | Zwischenablage | Rückgängig

Einige Programmfunktionen können Sie rückgängig machen:

·Das Löschen von Dokumenten, sofern dabei der Papierkorb verwendet wird.

·Änderungen an den Dokument- und Kontakteigenschaften, wenn diese im Eigenschaftendialog vorgenommen wurden.

·Das Leeren der Suchfelder.

Klicken Sie auf den Pfeil des Mausschalters, um eine Liste mit den verfügbaren Schritten zu öffnen. Oder auf den oberen Schalterbereich, wenn Sie den letzten Schritt direkt widerrufen möchten.

Nur für geöffnete Datenbanken

Auch beim Schließen des Dokumentenarchivs und der Kontaktdatenbank bleiben die Rückgängig-Funktionen erhalten. Sie müssen aber zuerst zur jeweiligen Datenbank zurückkehren, um Funktionen in dieser zu widerrufen.

Die Meldung "Keine Rückgängig-Funktion für geöffnete Datenbanken" bedeutet, dass für die derzeit geöffneten Datenbanken keine Rückgängig-Funktionen vorhanden sind, für zuvor geschlossene aber sehr wohl.

Hinweise

Insgesamt werden bis zu 30 Schritte bis zum Programmende gespeichert. Da das Leeren der Suchfelder im Vergleich zu Datensatzänderungen unwichtig ist, speichert das Programm maximal 3 dieser Vorgänge.

Datenänderungen sind im ev. Protokoll und dem GoBD-Revisionslog nachvollziehbar hinterlegt. Auch wenn Sie die Änderungen später rückgängig machen, bleiben diese Protokolle erhalten.


Auswahllisten bearbeiten

Navigation: Dokumentenmanagement >

Auswahllisten bearbeiten

Projekte und andere Auswahllisten

Einige Dokument- und Kontakteigenschaften ermöglichen die Auswahl der gewünschten Daten aus einer Liste:

Sie können selbst festlegen, welche Datenfelder eine einfache oder strukturierte Liste verwenden.

Standardwerte für die schnelle Auswahl hinterlegen

Zum Anpassen der Listen wählen Sie bitte den Menübefehl Datei | Optionen | Auswahllisten oder klicken mit der sekundären (i. d. R. der rechten) Maustaste auf ein Eingabefeld und wählen Auswahlliste bearbeiten im lokalen Menü.

Das Dialogfenster wird geöffnet:

Klicken Sie im Bild auf die Komponenten, zu der Sie weitere Hilfe wünschen.

Markieren Sie zuerst auf der linken Seite das Datenfeld, dessen Liste Sie anpassen möchten. Klicken Sie auf:

·Neu, um einen neuen Eintrag oder dem markierten einen Untereintrag hinzuzufügen,

·Ändern, um den markierten Eintrag anzupassen oder

·Löschen, um die markierten Einträge zu entfernen.

·Mit der rechten Maustaste in die Liste, um das lokale Menü zu öffnen. Hier können Sie beispielsweise die Einträge aus einer Textdatei laden oder einfügen (*.itm beinhaltet auch die erweiterten Eigenschaften, *.txt nur die Texte).

Ungültige Zeichen

Aus technischen Gründen sind einige Zeichen in den Auswahllisten nicht erlaubt oder nicht geeignet:

·= und \ dürfen nicht in den Listenwerten enthalten sein. Das Gleichheitszeichen und der Backslash sind programminterne Trennzeichen.

·{ und } kennzeichnen die Makroverarbeitung und sollten vermieden werden.

·Auf ; darf kein Leerzeichen folgen. Das Semikolon ist zwar unproblematisch, in Kombination mit einem folgenden Leerzeichen steht dies aber für die Trennung in Mehrfachauswahllisten.

·Der Text darf nicht mit (* beginnen.

·Leerzeichen am Textanfang und -ende werden entfernt.

·Der Text ist auf die Länge des entsprechenden Datenfeldes begrenzt. In strukturierten Listen ist dies die Länge des gesamten Pfades mit allen Ebenen.

Automatische Belegerkennung

Den Auswahllisten können Begriffe oder ganze Phrasen hinzugefügt werden, an denen der jeweilige Wert automatisch erkannt wird. Im Bearbeiten-Dialog finden Sie den Bereich Belegerkennung:

Geben Sie hier eindeutige Schlagwörter oder Phrasen ein, an denen der Listeneintrag erkannt wird.

Wenn Sie beispielsweise öfters E-Mail mit dem Text "Eingangsbestätigung Ihrer Bestellung" erhalten und diese Mails die Kategorie "Bestellung" bekommen sollen, dann gehen Sie bitte folgendermaßen vor:

1.Menü Datei | Optionen | Auswahllisten wählen.

2.Links Dokumente | Kategorie markieren.

3.Doppelklick auf "Bestellung" oder mit Klick auf Neu eine entsprechende Kategorie hinzufügen.

4.Im Eingabefeld unter Belegerkennung "Eingangsbestätigung Ihrer Bestellung" eingeben. Beachten Sie, dass die Phrasen nur in Kleinbuchstaben und ohne Leerzeichen gespeichert werden. Dies erfolgt automatisch nach Klick auf OK.

Sobald ein Dokument mit diesem Text hinzugefügt wird, bekommt es automatisch die Kategorie "Bestellung". Diese können Sie im Eigenschaftenfenster aber noch ändern.

Jede Zeile ist eine eigene Phrase. Im oben gezeigten Beispiel würde die Kategorie "Bestellung" erkannt, wenn im Dokumenteninhalt der Text "Eingangsbestätigung Ihrer Bestellung" oder "Ihr Artikel wurde verkauft:" enthalten ist.

Siehe auch Blogartikel

Erweiterte Eigenschaften

Die Eigenschaften der Dokumente und Kontakte erlauben zusätzliche Gestaltungsmöglichkeiten: Schriftformatierung, farbige Hervorhebung, Textbeschreibung und Grafik. Diese werden auf der Seite Erweitert angepasst:

Klicken Sie im Bild auf die Komponenten, zu der Sie weitere Hilfe wünschen.

Geben Sie zuerst die Bezeichnung auf Seite Allgemein ein. Zur Hervorhebung bzw. Gestaltung können Sie die Schrift- und Hintergrundfarbe wählen, sowie den Text fett, kursiv und durchgestrichen formatieren. Mit Warnung wird der Datensatz im Eigenschaften-Dialog farbig hervorgehoben.

Wenn Sie eine Grafik wählen, dann wird diese in den Auswahllisten und der Tabelle vor der Bezeichnung platziert. Sie können auch eigene Grafiken hinzufügen: speichern Sie die Bilder bitte im Verzeichnis "(Gemeinsame Dateien)\DocImages\" als Bitmap (*.bmp) in der Größe 16x16 Pixel oder als skalierbare Vektorgrafik (*.svg) ab. Das Programm liest die Bilder nach einem Neustart ein.

Mit Klick auf Zurücksetzen werden die Anpassungen auf Standardwerte gesetzt.

Im Textfeld Beschreibung können Sie eine ausführliche Bezeichnung hinterlegen. Diese Daten dienen aber auch häufig der automatisierten Belegerfassung: Die Makrofunktionen AutoCaptSelectionListFindItem und SelectionListFindItem können diesen Text auswerten.

Siehe auch

Kategorien mit Aufbewahrungsfristen

Darstellungsoption der Tabellen

Automatische Erkennung von Kontakten

Beispiel "Datenfeld Gruppe"

Mehrfachzuordnungen

Felder definieren


Aufbewahrungsfristen

Kategorien mit Aufbewahrungsfristen

Navigation: Dokumentenmanagement >

Kategorien mit Aufbewahrungsfristen

Verfügbar in diesen Editionen

Aufbewahrungsfristen für Dokumente

Sie können festlegen, wie lange bestimmte Dokumente aufbewahrt werden müssen bzw. dürfen. Bei personenbezogenen Daten sind Sie eventuell verpflichtet, Dokumente aus Datenschutzgründen nach dem Ablauf zu löschen.

Funktion aktivieren

Die Verwendung der Aufbewahrungsfristen können Sie in den Programmeinstellungen aktivieren.

Die jeweilige Frist wird über die Kategorie festgelegt.

1.Wählen Sie hierzu bitte den Menübefehl Datei | Optionen | Auswahllisten.

2.Markieren Sie links die Auswahlliste "Dokumente | Kategorie".

3.Markieren Sie eine Kategorie und ändern Sie diese mit Doppelklick oder dem Mausschalter Ändern.

4.Wenn die Nutzung von Fristen aktiv ist, können Sie im Dialog zur Registerseite Aufbewahrungsfristen wechseln:

Hinweise

Wenn ein Kennwort für den Programmadministrator hinterlegt ist, dann müssen Sie sich für die Bearbeitung der Fristen als Administrator anmelden.

Die Standard-Aufbewahrungsfrist beträgt 10 Jahre ab Schluss des Kalenderjahres. Diese wird verwendet, wenn keine abweichende Frist angegeben ist.

Für einige Kategorien sind Mindestfristen in Jahren (6, 8 und 10 Jahre) fest hinterlegt, diese können nicht unterschritten werden und Tagesfristen sind nicht erlaubt.

Wenn ein bisher gesperrtes Dokument nach dem Ablauf der Aufbewahrungsfrist gelöscht werden soll, fragt Office Manager das aktuelle Datum bei einem Zeitserver im Internet an.

Die Aufbewahrungsfristen werden für alle Dokumenten-Archive zentral verwaltet. Wenn Sie eine Kategorie löschen, werden Sie gefragt, ob auch die Aufbewahrungsfrist entfernt werden soll.

Für eine Liste der vorhandenen Fristen klicken Sie mit der rechten Maustaste in die Kategorienliste und wählen den Menübefehl Aufbewahrungsfristen.

Aktenorientierte Aufbewahrungsfristen

Neben den oben beschriebenen Fristen, bei denen jedes Dokument für sich betrachtet wird, können die Fristen auch anhand einer Gesamtakte berechnet werden. Dies ist zum Beispiel bei Patientenakten der Regelfall. Siehe hierzu in der Beschreibung zur Konfigurationsdatei "retention-period.ini".

Siehe auch

Auswahllisten bearbeiten

Löschen nach Ablauf der Frist

Revisionssicheres Archiv

Weblinks

Liste der Aufbewahrungsfristen

Wikipedia-Artikel Aufbewahrungsfrist

Supportartikel Archivierung von Eingangsrechnungen

Blogartikel DSGVO-Konformität

Handelsgesetzbuch §257 Aufbewahrungsfristen

Abgabenordnung §147 Aufbewahrung von Unterlagen


Dokumente kombinieren

Navigation: Dokumentenmanagement >

Dokumente kombinieren

Dokumentverknüpfungen

Sie haben mehrere Möglichkeiten, Dokumente zu kombinieren:

·die Zuordnung zu einem gemeinsamen Projekt, einer Gruppe und anderen Attributen,

·die hier beschriebenen internen Dokumentverknüpfungen

·und die Erstellung von Klonen, wenn sich die Dokumente auf dieselbe Datei beziehen.

Beispiel

In einem Archiv mit Buchungsbelegen werden Bestellungen, Rechnungen, Lieferscheine und andere steuerrelevante Dokumente archiviert. Sie möchten jederzeit sehr schnell auf alle Informationen eines Auftrags zugreifen können.

Zu unserem Beispielauftrag gehört Ihr Angebot an den Kunden, seine Faxbestellung, Ihre Auftragsbestätigung und Rechnung. Später kommt noch der Kontoauszug mit dem Zahlungseingang hinzu. Eventuell müssen Sie für den Auftrag auch Waren einkaufen und möchten die Eingangsrechnung mit dem Auftrag verknüpfen.

Möglichkeit 1: Verknüpfung mit Attributen

Dokumente haben verschiedene Attribute: unter anderem sind sie einem Buchungsjahr und einer Kategorien (Rechnung, Lieferschein, ...) zugeordnet und sie haben eine Belegnummer. Für die Verknüpfung aller Dokumente eines Auftrags eignet sich ein weiteres Attribut mit der Auftragsnummer (s. a. Attribute definieren).

Wenn Sie einen Beleg scannen oder importieren, dann geben Sie die gemeinsame Auftragsnummer ein. Später können Sie nach dieser Nummer suchen und finden alle Dokumente mit der gemeinsamen Auftragsnummer. Geeignet ist hierfür auch die Suche nach ähnlichen Dokumenten.

Ein Kontoauszug muss eventuell mit mehreren Aufträgen verknüpft werden - auf diesem befinden ja häufig mehrere Zahlungsvorgänge. Hierfür können Sie Mehrfachzuordnungen nutzen oder Sie erfassen alle Auftragsnummern: trennen Sie die Nummern dann am besten mit Semikolon und Leerzeichen "; ":

Verwenden Sie bei der späteren Suche nach einer Auftragsnummer dann das Jokerzeichen *, z. B. "*Au273".

Bei großen Archiven mit umfangreichen Querverknüpfungen kann dieses Vorgehen aber an seine Grenzen stoßen.

Möglichkeit 2: Interne Dokumentverknüpfungen

Verfügbar in diesen Editionen

Die Dokumente werden unabhängig von ihren Attributen kombiniert. In unserem Beispielauftrag könnte dies wie folgt ablaufen:

1.Ein Kunde bittet telefonisch um ein Produktangebot, welches Sie ihm sogleich per E-Mail zusenden. Die Mail importieren Sie per Drag&Drop in den Office Manager.
Sie können jetzt auch eine Tätigkeit erfassen, die Sie später daran erinnert, beim Kunden nachzufragen.

2.Am nächsten Tag geht die Bestellung per Fax ein, welche Sie sofort importieren bzw. scannen. Mit Hilfe der Dokumentvorlagen oder der Warenwirtschaft schreiben Sie dem Kunden eine Auftragsbestätigung und eine Warenbestellung an Ihren Lieferanten.

3.Markieren Sie in der Dokumententabelle bitte alle Belege, die zu diesem Auftrag gehören. Nutzen Sie ggf. die Suchfunktion. Zum Kombinieren der markierten Dokumente wählen Sie den Menübefehl Bearbeiten | Dokument | Verknüpfen:

Screenshot Interne Dokumentverknüpfungen

4.Wählen Sie die obere Option Die markierten Dokumente miteinander verknüpfen und geben Sie einen Verknüpfungsnamen ein. Dieser ist beliebig.
Ein aussagekräftiger Name, z. B. die Auftragsnummer, hat Vorteile, wenn Sie später weitere Dokumente mit diesen kombinieren möchten.
Klicken Sie bitte auf OK.

5.Zwei Tage später trifft die Warenlieferung bei Ihnen ein. Sie scannen Lieferschein und Eingangsrechnung und erstellen die Ausgangsrechnung für den Kunden. Markieren Sie diese neuen Dokumente und mindestens einen bereits verknüpften Beleg des Auftrages. Wählen Sie Bearbeiten | Dokument | Verknüpfen:

Screenshot Dokumentverknüpfungen erweitert

6.Markieren Sie die Option Dokumente zu bestehender Verknüpfung hinzufügen und unten in der Tabelle die Verknüpfung Au273. Derzeit gibt es nur eine, weil alle markierten Dokumente nur diese eine Verknüpfung haben. Zur Kontrolle können Sie den Konten erweitern; Sie sehen dann, welche Dokumente bereits mit Au273 verknüpft sind.
Klicken Sie bitte auf OK.

7.Nach drei Wochen scannen Sie einen Kontoauszug mit zwei Buchungen: dem Zahlungseingang unseres Beispielauftrages Au273 und einer EC-Kartentransaktion vom letzten Tankstellenbesuch.

8.Markieren Sie den Auszug und mindestens ein Dokument des Auftrages Au273. Verknüpfen Sie diese wie unter Punkt 5 beschrieben.

9.Markieren Sie anschließend den Kontoauszug und die Tankquittung und erstellen Sie eine neue Verknüpfung (siehe auch Punkt 3).

Verknüpfte Dokumente suchen

10. Sie haben beispielsweise die Ausgangsrechnung markiert und möchten alle Belege sehen, die zu dieser Rechnung gehören. Klicken Sie einfach auf Start | Suchen | Verknüpfungen. Die Tabelle beinhaltet jetzt nur noch die Dokumente des Auftrages Au273.

11.Markieren Sie den Kontoauszug und wählen Sie erneut Verknüpfungen. Die Tabelle beinhaltet jetzt alle Dokumente von Au273 und zusätzlich die Tankquittung.

12.Markieren Sie die Tankquittung und wählen Sie Verknüpfungen. Die Tabelle enthält anschließend nur die Quittung und den Kontoauszug.

Die Suche nach Verknüpfungen funktioniert auch im Terminkalender und der CRM-Kontaktverwaltung. Wenn eine Aufgabe markiert ist, können Sie mit Start | Suchen | Verknüpfungen zum verknüpften Dokument bzw. Kontakt wechseln. Ist ein Kontakt markiert, werden dessen Dokumente gesucht.

Siehe auch

Zur Suche hinzufügen

Fenster Dokumentverknüpfungen

Alternative Suchmethode und Standardverknüpfungsname

Mit Makrofunktion automatisieren


Dokumente versenden

Dokumente, Kontakte und Termine versenden

Navigation: Dokumentenmanagement >

Dokumente, Kontakte und Termine versenden

Start | Senden an

Funktionen für das Teilen und Versenden von Dokumentdateien und Kontakten. Wechseln Sie zuerst zur Ansicht der Dokumente oder Kontakte und markieren Sie die Daten, die Sie senden möchten. Klicken Sie anschließend auf den Menüschalter Start | Verwenden | Senden:

Popupmenü "Senden an"

Sind Dokumente ausgewählt, erfolgt der Versand der entsprechenden Datei. Notizen werden im RTF-Format, Internetlinks als Verknüpfungen. Kontakte werden als vCards (elektronische Visitenkarten) und Aufgaben als iCalendar übermittelt.

Tipp: Sie können die markierten Dokumente, Kontakte und Aufgaben auch per Drag&Drop und über die Zwischenablage mit anderen Anwendungen teilen.

Dokumentdateien auf CD brennen

1.Legen Sie eine beschreibbare CD oder DVD in das Laufwerk ein.

2.Markieren Sie die Dokumente in der Tabelle und wählen Sie den Menübefehl Start | Verwenden | Senden | Senden an CD.

Siehe auch: Senden an CD

Zum Kopieren auf andere Datenträger und zum Konvertieren

1.Markieren Sie die Dokumente, Kontakte oder Aufgaben in der Tabelle und wählen Sie den Menübefehl Start | Verwenden | Senden | Senden an andere.

2.Wählen Sie im Dateidialog das Kopierziel für die Datei aus. Einige Office-Dokumente (doc, docx, rtf, txt, html, xls, xlsx, ppt, pptx) können Sie auch in PDF konvertieren, sofern nur ein Dokument für den Export markiert ist. Wählen Sie dazu im Dateidialog den gewünschten Dateityp aus.

Oder mit dem Windows-Explorer:

1.Markieren Sie die Dokumente oder Kontakte in der Tabelle und kopieren Sie diese mit Strg+C in die Zwischenablage (oder Menü Bearbeiten | Zwischenablage | Kopieren).

2.Wechseln Sie in den Windows-Explorer und fügen Sie die Dateien mit Strg+V im gewünschten Ordner ein.

Office Manager DMS unterstützt selbstverständlich auch das Drag&Drop (Ziehen und Ablegen): Schieben Sie Dokumente oder Kontakte einfach aus der Tabelle in ein Explorerverzeichnis oder zum Beispiel in eine E-Mail, um es als Anlage zu versenden.

Freigeben und Teilen

1.Markieren Sie genau ein Dokument, genau einen Kontakt oder beliebig viele Aufgaben und klicken Sie auf Start | Verwenden | Senden | Freigeben.

2.Wählen Sie im Windows-Dialog "Freigeben" die gewünschte Ziel-App.

Je nach Format des ausgewählten Dokuments und installierten Windows-Apps stehen Ihnen unterschiedliche Ziele zur Verfügung. "Freigeben", oder auch "Teilen", nutzt die Windows-Funktion "Share Contract".

In ZIP-Archiv komprimieren

3.Markieren Sie die Dokumente oder Kontakte in der Tabelle und klicken Sie auf Start | Verwenden | Senden | In ZIP-Archiv speichern.

4.Geben Sie im Dateidialog den Namen einer ZIP-Datei ein und klicken Sie auf OK.

Wenn Sie die Datei mit einem Passwort verschlüsseln möchten, wählen Sie bitte im Dateidialog den entsprechenden Dateifilter aus. Beachten Sie bitte, dass das Inhaltsverzeichnis der ZIP-Datei immer noch eingesehen werden kann, die Dateien selbst können aber nur mit dem Passwort geöffnet werden.

Siehe auch: Dokumente komprimieren

ZIP-Datei oder E-Mail-Anlagen extrahieren

Verfügbar in diesen Editionen

1.Markieren Sie ein geeignetes Dokument (E-Mail, PDF, ZIP-Archiv u. a. Komprimierungsformate) in der Tabelle und klicken Sie auf Start | Verwenden | Senden | Extrahieren.

2.Wählen Sie im Dialogfenster das gewünschte Zielverzeichnis.

Siehe auch: Dateianlagen öffnen

Senden an E-Mail-Empfänger

Menübefehl Start | Verwenden | Senden | Senden an E-Mail-Empfänger.

Dokumente senden

1.Markieren Sie die gewünschten Dokumente in der Tabelle und wählen Sie den Menübefehl.

2.Eine neue E-Mail wird in Ihrem Standard-Mailprogramm erstellt. Die ausgewählten Dokumente sind bereits als Anhänge hinzugefügt. Sie können die E-Mail nun bearbeiten und Empfänger hinzufügen.

Kontakte als vCard senden

1.Markieren Sie die gewünschten Kontakte und klicken Sie auf den Menübefehl.

2.Sollten gleichzeitig Dokumente ausgewählt sein, werden Sie gefragt, ob Sie Kontakte oder Dokumente senden möchten. Klicken Sie auf Kontakte.

3.Eine neue E-Mail wird erstellt, wobei die Kontakte als vCards (digitale Visitenkarten) angehängt sind. Sie können die Mail bearbeiten und Empfänger hinzufügen.

Dokumente an Kontakte senden

1.Markieren Sie die Dokumente, die Sie versenden möchten, in der Dokumententabelle.

2.Wechseln Sie zur Kontakttabelle und markieren Sie die Kontakte, an die Sie die Dokumente senden möchten.

3.Wählen Sie den Menübefehl und beantworten Sie die Rückfrage mit Dokumente.

4.Die E-Mail wird in Ihrem Mail-Programm erstellt. Die ausgewählten Dokumente sind als Anhänge beigefügt und die markierten Kontakte als Empfänger eingetragen.

Hinweise und Tipps

Mit der Datei "sendmail.txt" können Sie den Standard-Mailtext ("Sehr geehrte Damen und Herren...") individualisieren.

Die Anlagen werden komprimiert, sofern diese insgesamt mehr als 200 KB enthalten und die Komprimierung mehr als 10% Speicherplatz einspart.

Ihr Mail-Programm muss MAPI-fähig sein und die gleiche Bit-Architektur (32 oder 64 Bit) wie Office Manager DMS verwenden. Alternativ können Sie auch im Mailprogramm eine neue E-Mail erstellen und die Dokumente per Drag&Drop in die E-Mail kopieren.

Auf FTP-Server hochladen

Verfügbar in diesen Editionen

1.Markieren Sie die gewünschten Dokumente oder Kontakte in der Tabelle und klicken Sie auf Start | Verwenden | Senden | Senden an FTP-Server.

2.Geben Sie im Dialogfenster die Verbindungsdaten ein. Öffnen Sie die Liste des Kombinationsfeldes Server, um erneut auf zuvor genutzte Verbindungen zuzugreifen.

3.Nach Klick auf OK wird eine Verbindung zum Server aufgebaut und die Dateien werden hochgeladen.

Siehe auch

Datenbankexport: An Steuerberater senden


Dokumente drucken

Navigation: Dokumentenmanagement >

Dokumente drucken

Drucken

Das Drucken der verwalteten Dokumente erfolgt in der Regel mit Hilfe der entsprechenden Windowsanwendung: Word-Dokumente werden beispielsweise mit Word gedruckt.

Sie haben aber grundsätzlich zwei Möglichkeiten, den Ausdruck zu steuern:

Methode

Vorteil

Aus der Anwendung drucken

Sicherste Methode mit allen Druckoptionen.

Mit Office Manager-Dialog

Mehrere Dokumente zum Drucken markieren.

1. Aus der Anwendung drucken

Markieren Sie die zu druckenden Dokumente und klicken Sie auf Start | Verwenden | Öffnen Öffnen. Die Dokumente werden im verknüpften Programm geladen. Starten Sie nun den Druckvorgang direkt in der Anwendung: In der Regel wählen Sie hierzu im Menü Datei den Befehl Drucken (Strg+P).

Diese Methode funktioniert mit allen Anwendungen und bietet sämtliche von der Anwendung vorgesehenen Druckoptionen.

2. Mit Office Manager-Dialog drucken

Verfügbar in diesen Editionen

Markieren Sie die zu druckenden Dokumente in der Tabelle und klicken Sie auf den Befehl Start | Verwenden | Drucken | Dokument:

Wählen Sie den zu verwendenden Drucker. Unter Eigenschaften können Sie die Druckoptionen anpassen. Nach Klick auf OK wird die dem Dokument zugeordnete Windows-Anwendung mit dem Druckbefehl gestartet. Dieses Vorgehen entspricht der Auswahl des Druckbefehls (print) im Windows-Explorer.

Beachten Sie bitte:

·Der Office Manager stellt den gewählten Drucker als Windows-Standarddrucker ein.

·Der Druckbefehl wird nicht von allen Anwendungen unterstützt. Bei Problemen drucken Sie bitte direkt aus der Anwendung.

Siehe auch

Report drucken

Übersicht drucken


Notizen

Navigation: Dokumentenmanagement >

Notizen

Textverarbeitung für Notizen

Der Editor ermöglicht Ihnen die Erstellung von einfachen Textdokumenten, ohne auf eine externe Windowsanwendung zurückgreifen zu müssen. Nutzen Sie diese Möglichkeit, um beispielsweise Notizen zu erfassen. Umfangreiche Dokumente werden besser mit einer externen Textverarbeitung, wie Word, OpenOffice oder dem Briefeditor erstellt.

Die Dokumente werden nicht in Dateien, sondern in der Archivdatenbank gespeichert.

Erstellen Sie ein neues Dokument mit Klick auf Erstellen | Neu | Dokument. Wählen Sie den Dokumenttyp "Notiz" und geben Sie die Beschreibungen für Nummer, Name, Projekt usw. ein. Die Textverarbeitung wird geöffnet, sobald Sie auf den Mausschalter OK klicken:

Klicken Sie im Bild auf die Komponenten, zu der Sie weitere Hilfe wünschen.

Revisionssicherheit

Falls der GoBD-Modus im Archiv aktiviert ist, können Sie bestehende Texte nicht mehr löschen oder ändern. Sie haben aber die Möglichkeit, eine Notiz oder einen Korrekturhinweis hinzuzufügen: Bewegen Sie den Eingabecursor bitte an die gewünschte Stelle und klicken Sie oberhalb des Editors auf den entsprechenden Link. Geben Sie den gewünschten Text ein und bestätigen Sie mit OK. Falls Sie den Hinweis dann doch nicht übernehmen möchten, klicken Sie bitte vor dem Schließen des Fensters auf Alles rückgängig.


Versionsmanagement

Navigation: Dokumentenmanagement >

Versionsmanagement

Verfügbar in diesen Editionen

Versionsmanagement

Zu jedem Dokument können beliebig viele Versionsstände archiviert werden. Wenn Sie beispielsweise eine Preisliste überarbeiten, dann können Sie die alte Preisliste als Versionsstand beibehalten. Siehe auch Beispiel im Blog.

In der Dokumententabelle im Hauptfenster befindet sich immer der aktuelle Versionsstand, die älteren Version finden Sie im Eigenschaftendialog (siehe unten).

Dokumentversion archivieren

Um den derzeitigen Stand eines Dokuments zu archivieren, markieren Sie bitte das Dokument in der Tabelle und wählen den Menübefehl Erstellen | Neu | Version Icon Nummer. Das Dialogfenster "Dokumentversion" wird geöffnet:

Eigenschaften der Dokumentversion

Beschreiben Sie den bisherigen Stand des Dokuments: Geben Sie eine aussagekräftige Bezeichnung im Feld Name ein und ev. umfangreiche Informationen und Notizen auf der Seite Details.

Der Dateiname wird automatisch vergeben, Sie können aber auch auf die Schaltfläche Durchsuchen klicken und ihn selbst festlegen.

Markieren Sie das Optionsfeld Schreibschutz, um die Datei schreibgeschützt zu archivieren und Dokumentdatei komprimieren, um Speicherplatz zu sparen.

Klicken Sie auf OK, um den derzeitigen Stand des Dokuments als Version aufzubewahren.

Dokumentversion öffnen

Um später auf eine Version zuzugreifen, markieren Sie das Dokument in der Tabelle und wählen den Befehl Bearbeiten | Dokument | Eigenschaften Icon Eigenschaften. Wechseln Sie zur Registerseite Versionen:

Tabelle der Dokumentversionen

Markieren Sie die gewünschte Dokumentversion. Mit einem Doppelklick wird diese geöffnet und mit einem Rechtsklick auf die lokalen Menübefehle zugegriffen:

Nummer Version: eine weitere Version des aktuellen Dokumentes archivieren.

Eigenschaften Eigenschaften: die Attribute der markierten Version bearbeiten.

Öffnen Öffnen: Versionsdatei öffnen.

Vorschau Vorschau: wechselt zur Vorschau-Registerseite und zeigt die markierte Version.

Löschen Löschen: die markierte Dokumentversion löschen. Diese Funktion ist in GoBD-Archiven gesperrt.

Wenn Sie eine bereits vorhandene Datei als Version hinzufügen möchten, können Sie die Datei per Drag&Drop (z. B. vom Windows-Explorer) in die oben dargestellte Tabelle einfügen oder den erweiterten Import im Programmhauptfenster nutzen.

Hinweise

Versionen können nur in der Ansicht der aktiven Dokumente erstellt oder bearbeitet werden.

Unabhängig von der Einstellung des Importprofils, wird die Quelldatei beim Import als Dokumentenversion immer kopiert.

Siehe auch

Dokumente archivieren

Anzahl der Versionen einblenden

Syntax der Versionsdateinamen


Blockchain

Navigation: Dokumentenmanagement >

Blockchain

Dokumentenrevision mittels dezentraler Blockchain

Einleitung

Blockchain bezeichnet eine manipulationssichere und zumeist verteilte Datenbank. Die einzelnen Datenblöcke werden mittels kryptografischer Funktionen miteinander verkettet und die Unveränderbarkeit einzelner Datensätze sichergestellt.

Siehe auch Einführung in das Thema sowie Wikipedia-Artikel zu Blockchain und Kryptowährung.

Die Documentchain ist eine speziell für das Dokumentenmanagement entwickelte dezentrale Blockchain. Für die Dokumentenrevision werden Hashwerte der Dokumentdatei und der Beschreibung gespeichert und später mit dem Dokument verglichen. Dies führt zu einer manipulationssicheren Bestätigung, seit wann das Dokument vorliegt. Im Urheberrecht ermöglicht dies beispielsweise den Nachweis, wer die Idee zuerst hatte.

Datenschutz

Die Dokumente werden nicht veröffentlicht und verbleiben bei Ihnen. Auf der Blockchain werden nur Hashwerte (Checksummen) hinterlegt, die keinen Rückschluss auf den Inhalt des Dokuments erlauben. Nur wer das Dokument besitzt, kann dieses mit den Hashwerten der Blockchain abgleichen.

Voraussetzungen

Das Softwarebüro Krekeler betreibt Server für die Kommunikation mit der Blockchain, sodass Sie die Funktion ohne zusätzliche Software nutzen können Aktivieren Sie hierzu in den Einstellungen Web-Wallet verwenden. Anwender der Vollversion haben ein kostenfreies Kontingent für Dokumententransaktionen.

Oder Sie installieren die lokale Wallet-Software DMS Core.

Blockchain-Funktionen

Dokument auf Blockchain absichern

1. Dokument absichern

Sie können Informationen zu einem Dokument, insbesondere die Datei-Checksumme, auf der Documentchain speichern. Das Dokument selbst wird dabei nicht übertragen, es verbleibt bei Ihnen im Archiv. Vorgehen:

1.Markieren Sie die gewünschten Dokumente in der Office Manager-Datentabelle und wählen Sie den Menübefehl Bearbeiten | Dokument | Blockchain (Kurztaste: Strg+D).

2.Klicken Sie auf den Mausschalter Vorschau (optional) und anschließend auf Hinterlegen, um die Hashwerte auf der Blockchain zu speichern.

Siehe auch Video
Neue Dokumente automatisch absichern

2. Revision

Mit Hilfe der öffentlichen Blockchain erhalten Sie eine manipulationssichere Bestätigung, ab wann ein Dokument vorhanden ist und ob es seitdem unverändert vorliegt. Die Datenabfrage ist gebührenfrei.

1.Markieren Sie die gewünschten Dokumente in der Datentabelle und wählen Sie den Menübefehl Bearbeiten | Dokument | Blockchain.

2.Klicken Sie auf den Mausschalter Dokument prüfen.

Sie können diese Funktion auch während einer GoBD-Prüfung aufrufen. Auf der Seite mit den Dokumentdetails wird der Mausschalter Blockchain-Revision eingeblendet, wenn dem Dokument Transaktions-Daten hinterlegt sind.

Mehrere Dokumente verarbeiten

Sie können mehrere Dokumente in der Tabelle markieren und diese gemeinsam in einem Schritt verarbeiten. Das beim Markieren zuletzt angeklickte Dokument gibt dabei vor, welche Funktion (absichern oder prüfen) ausgeführt wird.

Kosten und kostenlose Tests

Transaktionsgebühren für die Hinterlegung der Hashwerte werden in DMS-Coins, der projekteigenen Kryptowährung, erhoben und an die Unterstützer des Netzwerks (Miner und Masternodes) verteilt.

·Office Manager-Testversion: Standardmäßig ist das Testnet der Blockchain eingestellt. Sie können dies kostenlos verwenden, es ist aber auch nur für Testzwecke und zum Kennenlernen dieser modernen Technologie geeignet.

·Office Manager-Vollversion: Sobald das Programm als Vollversion freigeschaltet ist, wird die "echte" Blockchain verwendet. Sie können eine begrenzte Anzahl Dokumente kostenlos absichern und weitere für 0,1 DMS je Dokument.

Siehe auch

FAQ: Lösungen für mögliche Fehlermeldungen

Makro StoreHashesOnBlockchain


Dokumente archivieren

Navigation: Dokumentenmanagement >

Dokumente archivieren

Verfügbar in diesen Editionen

Dokumente archivieren

Menü Bearbeiten | Dokument | Archivieren

Langzeitarchivierung und Archivierung alter, nicht mehr im Zugriff befindlicher Dokumente.

Der Lebenszyklus eines Dokumentes umfasst das Erfassen/Erstellen, Nutzen, Archivieren und Vernichten.

Dokumente, die Sie für die tägliche Arbeit nicht mehr benötigen, die aber auch nicht gelöscht werden sollen, können Sie mit dieser Funktion archivieren:

1.Die Dokumentdatei wird entsprechend den Einstellungen in das Archivverzeichnis verschoben, schreibgeschützt und ggf. komprimiert. PDF-Dokumente werden ggf. für die revisionssichere Archivierung geschützt.

2.Der Dokumentdatensatz wird in eine spezielle Archivtabelle verschoben.

3.Der Datensatz ist schreibgeschützt. Löschen ist nur möglich, wenn Aufbewahrungsfristen verwendet werden und die Frist bereits abgelaufen ist.

4.Wenn Sie eine Suche in den archivierten Dokumenten durchführen möchten, markieren Sie bitte im Menü Ansicht den Eintrag Archivierte Dokumente. Um wieder in den normalen Dokumenten zu suchen, markieren Sie bitte Aktive Dokumente.

Siehe auch

Dokumentversion archivieren

Revisionssicherheit mit moderner Blockchain

Einschränkungen in der Ansicht "Archivierte Dokumente"

Dokumente zählen

Einstellungen

Archivierte Dokumente wiederherstellen
Menü Bearbeiten | Dokument | Wiederherstellen

Diese Funktion stellt zuvor archivierte Dokumente wieder her.

Die Dokumentdatei wird entsprechend den Einstellungen in das Dokumentenverzeichnis und der Archivdatensatz in die normale Dokumenttabelle verschoben. Der Datei-Schreibschutz wird, sofern möglich, wieder aufgehoben.

Der Menü-Befehl ist nur in der Ansicht Archivierte Dokumente aktiv. In einem GoBD-Archiv können einmal archivierte Dokumente nur wiederhergestellt werden, solange das Archiv geöffnet ist.

Hinweise

Es werden auch alle Versionen des Dokuments archiviert bzw. wiederhergestellt.

Wenn mehrere Dokumentdatensätze auf die zu archivierende Datei verweisen (z. B. Klone), dann werden die Dokumentversionen dieser Datensätze ebenfalls archiviert oder wieder hergestellt.


Dokumente löschen

Navigation: Dokumentenmanagement >

Dokumente löschen

Dokumente löschen

Markieren Sie bitte die zu löschenden Dokumente in der Tabelle und klicken Sie auf den Mausschalter Bearbeiten | Dokument | Löschen. Der Bestätigungsdialog wird geöffnet:

Dokument in Papierkorb löschen

In den Papierkorb verschieben

Prüfen Sie die Option Endgültig löschen im unteren Bereich des Dialoges. Diese ist standardmäßig nicht markiert - die Dokumente werden dann nach der Bestätigung in den Papierkorb verschoben und können später wiederhergestellt werden.

Ist die Option markiert, wird das Dokument aus dem Archiv gelöscht und kann später nicht mehr wiederhergestellt werden. Der Bestätigungsdialog zeigt dann links oben ein rotes Kreuz als Symbol:

Dokument unwiderruflich löschen

Endgültig löschen

Sie können dann auch zusätzlich Datei löschen markieren, um nicht nur den Datenbankeintrag zu entfernen, sondern auch die Dokumentdatei vom Datenträger zu löschen.

Einschränkungen

In den Programmeinstellungen kann festgelegt werden, dass Anwender immer den Papierkorb nutzen müssen. Der Administrator kann die Funktion auch mit Zugriffsberechtigungen für Programmbefehle und Dateien einschränken.

In revisionssicheren Archiven und im Bereich der Langzeitarchivierung unterliegen die Dokumente einigen Restriktionen. Das Entfernen aus der Archivdatenbank ist, je nach Einstellung, nicht oder erst nach Ablauf der Aufbewahrungsfrist möglich. Für die Bestätigung des aktuellen Datums ist dann eine Internetverbindung erforderlich. Wenn mehrere Dokumente zum Löschen ausgewählt sind, wird anschließend bei jedem Dokument geprüft, ob ein (endgültiges) Löschen zulässig ist.

Wenn ein gesperrtes Dokument aus Datenschutzgründen gelöscht werden muss, können Sie die administrative Funktion verwenden.

Aus Papierkorb wiederherstellen

Wählen Sie bitte den Menübefehl Ansicht | Anzeigen | Papierkorb oder klicken Sie unterhalb der Tabelle auf die Registerseite Papierkorb. Nutzen Sie die Suchfunktionen, um das gewünschte Dokument zu finden. Nur die Volltextsuche steht im Papierkorb nicht zur Verfügung, weil der Index hier nicht gepflegt wird. Mit Klick auf die Tabellenspalte Gelöscht am werden die Dokumente entsprechend sortiert, beispielsweise die zuletzt gelöschten ganz oben oder ganz unten.

Markieren Sie das gewünschte Dokument oder auch mehrere gleichzeitig. Wählen Sie den Menübefehl Bearbeiten | Dokument | Wiederherstellen oder klicken Sie doppelt auf das Dokument. Bestätigen Sie die Rückfrage, um das Dokument wiederherzustellen.


Das Programm anpassen

Navigation: Dokumentenmanagement >

Das Programm anpassen

Anpassen

Sie haben die Möglichkeit, die Office Manager-Programmoberfläche an Ihre persönlichen Vorstellungen anzupassen. Wechseln Sie dazu bitte auf die Menüregisterseite Ansicht.

·Stil: Wählen Sie den gewünschten Darstellungsstil für die gesamten Benutzeroberfläche. Siehe auch Screenshots.
Tipp: Falls Sie nach dem Umschalten zu einem anderen Stil Darstellungsprobleme sehen, dann starten Sie das Programm bitte neu.

Für weitere Anpassungsmöglichkeiten öffnen Sie Untermenü Anpassen:

·Menüband anpassen, um Befehle zu den Menüs und Symbolleisten hinzuzufügen oder zu entfernen.

·Menüband zurücksetzen, um die Menüs und Symbolleisten auf den Auslieferungszustand zurückzusetzen. Ihre Änderungen gehen dabei verloren. Dies ist nach einem Upgrade aber sinnvoll, um das Menü zu bereinigen.

·Layout zur manuellen Auswahl der aktuellen Programmoberfläche.

·Layout entwerfen | Bereiche positionieren ermöglicht das Verschieben der Hauptelemente (Navigator, Suche, Tabelle und Vorschau).

·Layout entwerfen, um Datenfelder für die Suche und Datenerfassung zu platzieren.

·Sprache, um die Benutzersprache, wie deutsch oder englisch festzulegen.

·Feldauswahl zur Auswahl der Spalten, die in der Dokumenttabelle gezeigt werden sollen. Sie können auch eigene Spalten definieren.

Tabellendesign

In der Dokumenten- und Kontakttabelle können Sie die Breite und Ausrichtung der Spalten anpassen. Zum Verschieben einer Spalte klicken Sie bitte im Tabellenkopf auf die Überschrift und halten die Maustaste fest. An die gewünschte Position schieben und dann die Maustaste lösen. Alternativ mit der rechten Maustaste auf die Spaltenüberschrift klicken und im Popupmenü Spalte verschieben wählen. Letzteres ist besonders geeignet, um ein neu erstelltes Datenfeld von ganz rechts nach vorne zu holen.

Die Darstellung wird in der Regel gespeichert und nach einem Neustart wiederhergestellt. Beachten Sie aber bitte die Speicheroptionen - der Administrator kann das Design auch vorgeben. In diesem Fall werden Ihre Änderungen nicht wiederhergestellt.

Siehe auch

Felder definieren zum Bearbeiten der Attribute und Eingabestile

Datentabelle

Einstellungen

Administration


Layout wählen

Navigation: Dokumentenmanagement >

Layout wählen

Aktuelles Layout auswählen

Im Menü Ansicht | Anpassen | Layout legen Sie fest, welches Layout für die Suche und Datenerfassung genutzt wird. Wechseln Sie zuerst zur Ansicht der Dokumente oder Kontakte, um das Layout der entsprechende Datenbank zu bestimmen. Neben der empfohlenen automatischen Auswahl können Sie auch eine Layoutdatei fest vorgeben:

[automatisch]: Die Layoutdatei wird in folgender Reihenfolge gesucht und die zuerst gefundene verwendet:

1.Eintrag "LayoutFile" in der Datenbank-Optionstabelle,

2.Datei mit dem gleichen Namen, wie die geöffnete Archiv- bzw. Kontaktdatenbank. Dokumente.omsl verwendet beispielsweise Dokumente.lay, wenn vorhanden, Kontakte.crmsl das Layout Kontakte.crmlay.

3."Layout.lay/.crmlay" im Unterverzeichnis "Layouts" der gemeinsamen Dateien,

4."Default.lay/.crmlay" im Programmverzeichnis.

(Layoutname): verwendet die gewählte Layoutdatei.

[Neu...]: erstellt eine neue Layoutdatei als Kopie der aktuellen und verwendet diese. Sie können das Layout anschließend bearbeiten: Menü Ansicht | Anpassen | Layout entwerfen.

[Hilfe]: öffnet diese Hilfeseite.

Siehe auch

Layoutdesigner


Mobiler Datenzugriff

Navigation: Dokumentenmanagement >

Mobiler Datenzugriff

Verfügbar in diesen Editionen

Smartphone in Hand

Zugriff von mobilen Endgeräten (iPhone, iPad sowie Adroid-Smartphones und Tablets) auf die Dokumentenarchive.

Hierbei dient der heimische Office Manager als Server für die Mobilgeräte. Die Daten können also bei Ihnen bleiben und müssen nicht in der Cloud abgelegt werden. Die mobile App "Office Manager DMS to go" können Sie kostenlos im App Store oder bei Google Play laden.

In diesem Kapitel:

·Beschreibung der App für mobile Geräte

·Ihr Office Manager als Server für mobile Geräte

Weitere Informationen und Support

·App-Beschreibung im Internet

·Supportrecherche


DMS App

DMS App "Office Manager DMS to go"

Navigation: Dokumentenmanagement > Mobiler Datenzugriff >

DMS App "Office Manager DMS to go"

Verfügbar in diesen Editionen

Schauen Sie sich die App am besten gleich einmal an - noch bevor Sie den Datenzugriff konfigurieren. Sie können sich sofort mit dem Demo-Server im Softwarebüro Krekeler verbinden und die App kennenlernen.

Öffnen Sie dazu auf Ihrem Smartphone oder Tablet den App Store und suchen Sie nach "office manager dms" oder nach "krekeler" - so finden Sie die App am schnellsten.

Für iPhone und iPad

Bedienung

Starten Sie nach der Installation "Office Manager" auf dem Handy:

App "DMS to-go" Startbildschirm

Startbildschirm

Die Einstellungen brauchen Sie erstmal nicht zu beachten. Die Verbindungsdaten für den Demoserver sind standardmäßig aktiviert. Tippen Sie auf den ersten Eintrag Archiv öffnen:

App "DMS to-go" Archivliste

Liste der Dokumentenarchive

Hier werden alle verfügbaren Dokumentenarchive aufgelistet. Beim Demoserver sind dies zum Beispiel "Archiv.omsl" und "Buchhaltung.omsl" - je nachdem, welche Beispiele wir gerade online haben. Mit einem Fingertipp auf das i-Symbol kommen Sie zu den Archivdetails mit der Anzahl von enthaltenen Dokumenten u. a. Dies ist auch der Weg, um auf die Daten der Ansicht "Archivierte Dokumente" zuzugreifen.

Tippen Sie entweder direkt auf einen Archivnamen oder auf das i-Symbol und anschließend auf n aktive Dokumente, um zur Recherche-Seite zu gelangen:

App "DMS to-go" Suchmaske

Recherche-Seite

Sie können hier, ähnlich der Suche im Office Manager Windows-Programm, Suchfilter eingeben, um die Dokumente zu begrenzen. Wählen Sie beispielsweise ein Projekt oder geben Sie gesuchte Begriffe bei Volltestsuche ein. Klicken Sie anschließend auf Suchen, um die gewünschten Dokumentdatensätze aus der Archivdatenbank abzufragen:

App "DMS to-go" Dokumentenliste

Tippen Sie auf ein Dokument, um dieses vom Server zu laden und darzustellen. Alternativ können Sie mit dem i-Symbol weitere Informationen einsehen, das Dokument laden, ohne es darzustellen oder auch Aufgaben hinterlegen. Aufgaben finden Sie später im heimischen Office Manager.

Auf Dokumente, die einmal geladen wurden, können Sie auch ohne Internetverbindung auf dem Handy erneut öffnen. Wählen Sie dazu auf der App-Startseite den Befehl Offline-Daten und tippen Sie auf das gewünschte Dokument.

Um diese zu löschen, wischen Sie mit dem Finger auf dem jeweiligen Dokumenteneintrag von rechts nach links und bestätigen Sie den dann sichtbaren Schalter Löschen.

Weiter mit: Zugriff auf Ihren Office Manager einrichten.


Mobile Server

Navigation: Dokumentenmanagement > Mobiler Datenzugriff >

Mobile Server

Verfügbar in diesen Editionen

Mobilen Datenzugriff einrichten

Hinweise: Mit der auf dieser Seite beschriebenen Methode dient der Client-Computer als mobiler Server. Wenn Sie Office Manager im Firmennetzwerk einsetzen, dann beachten Sie bitte auch die optionale Software, die zentral auf Ihrem Netzwerkserver eingesetzt werden kann.

Das Office Manager-Hauptprogramm muss später nicht ausgeführt werden. Die Kommunikation mit dem mobilen Gerät erfolgt über das Dienstprogramm "DMSService.exe", welches im Hintergrund ausgeführt wird.

Ihr heimischer Office Manager dient als Server für Ihre Mobilgeräte, die Daten können also bei Ihnen bleiben und müssen nicht in der Cloud abgelegt werden. Hierfür muss das Handy den PC aus dem Internet erreichen - dies ist nicht ganz trivial und muss konfiguriert werden. Im ersten Schritt stellen wir aber nur eine Verbindung vom Handy zum PC über Ihr lokales Netzwerk bzw. WLAN her.

Erste Verbindung zwischen Handy und PC

1.Wählen Sie im Office Manager Windows-Programm bitte den Menübefehl Datei | Mobile Server.

2.Aktivieren Sie die Option Zugriff von mobiler App "Office Manager DMS to go" zulassen.

3.Geben Sie einen Benutzernamen und ein Passwort ein.

4.Legen Sie einen freien Computer-Port fest. Beispielsweise 211 oder 8080.

5.Klicken Sie auf Einstellungen speichern. Sie benötigen Administrator-Rechte unter Windows.

6.Verbinden Sie Ihr mobiles Gerät mit dem Netzwerk, in welchem sich auch der PC befindet. In der Regel müssen Sie es nur mit Ihrem WLAN verbinden.

7.Laden Sie die App auf Ihr Handy oder Tablet und starten Sie diese.

8.Wählen Sie auf der App-Startseite den Befehl Einstellungen. Der Switch Mit Demo-Server verbinden ist standardmäßig aktiviert.

9.Tippen Sie auf den Switch, um diesen zu deaktivieren und geben Sie Benutzer, Passwort sowie Port entsprechend den gerade eingestellten Werten ein.

10. Bei Host geben Sie den Namen oder die IP-Nummer des PCs ein. Diese finden Sie im Office Manager-Dialog "Mobile Server" unterhalb der Option "Zugriff zulassen".

11. Tippen Sie in der App auf Speichern und zurück.

12. Wählen Sie Archiv öffnen. Falls Sie keine Verbindung aufbauen können, dann wird diese vermutlich von einer Firewall oder einem Antiviren-Programm blockiert.

Sie können die Funktionsweise jetzt ausprobieren.

Alle Dokumente, die Sie einmal auf das Handy geladen haben, stehen dort auch im Startmenü unter Offline-Daten zur Verfügung. Falls Sie keine Online-Verbindung für unterwegs einrichten möchten, dann können Sie jetzt alle benötigten Dokumente auf das mobile Gerät laden und mitnehmen. Interessanter wird es aber, wenn Sie von unterwegs auf Ihre Archive zugreifen können. Hierzu muss das Handy Ihren PC aus dem Internet erreichen können:

Verbindung von unterwegs

Router konfigurieren

Die Internetverbindungen laufen in der Regel über einen Router, den Sie von Ihrem Internetprovider bekommen haben. Wir müssen den Router so einstellen, dass er den eingehenden Port (siehe Eingabefeld Computer-Port) an den Computer mit dem Office Manager weiterleitet.

·Anleitung für FRITZ!Box

·In anderen Routern ist es meist ähnlich einzustellen.

Dauerhaft erreichbar sein

Wenn Sie der obigen Anleitung für FRITZ!Box gefolgt sind, dann haben Sie diesen Schritt bereits erledigt.

Computer im Internet werden über ihre Adressen (IP-Nummern) angesprochen. In der Regel sind diese Nummern aber nicht konstant - Ihrem heimischen Computer bzw. Ihrem Router wird bei jeder neuen Internetverbindung eine andere IP zugewiesen. Das Handy kennt die jeweilige Adresse nicht.

Abhilfe schafft hier das dynamische DNS (DDNS). Sie erhalten bei einem DDNS-Anbieter einen Domännamen und Ihr Router meldet dort nach jeder Änderung seine neue IP-Nummer. Der Anbieter leitet dann die Anfragen für den Domännamen an Ihren PC weiter. Mehr zu diesem Thema finden Sie u. a. auf Wikipedia.

·Anleitung für Fritz!Box

·Inhaber einer Domain bei Strato können ev. eine Subdomain erstellen und diese für DynDNS konfigurieren.

·Anbieter für Dynamisches DNS suchen

Geben Sie die vom DynDNS erhaltene Internetadresse bitte in der Office Manager App auf dem mobilen Gerät ein: Im Startmenü auf Einstellungen tippen und die Adresse bei Host eingeben.

Siehe auch

Supportrecherche zum Thema

Erweiterte Einstellungen


Kontakte und Adressen

Navigation: »Kein übergeordnetes Kapitel«

Kontakte und Adressen

Verfügbar in diesen Editionen

CRM - Customer-Relationship-Management

Zum Öffnen der Kontaktverwaltung wählen Sie den Befehl Ansicht | Anzeigen | Kontakte oder klicken Sie am unteren Rand der Tabelle auf Kontakte.

Hauptfenster in Kontakt-Ansicht

Kontakte filtern

Geben Sie bitte die Suchkriterien, wie Firma, Nachname oder E-Mail ein und klicken Sie anschließend auf Suchen, um die gewünschten Kontakte zu suchen. Oder klicken Sie auf Kontakt | Suchen | Felder leeren und anschließend auf Suchen, wenn Sie alle Kontakte sehen möchten. Die Suchfunktionen entsprechen der Suche nach Dokumenten, siehe dazu auch Primäre Suchfelder und Datumssuche.

Befehle auf der Menüseite Kontakt

·Erstellen | Kontakt: einen neuen Kontakt hinzufügen.

·Erstellen | Aufgabe: eine Tätigkeit für den markierten Kontakt planen.

·Erstellen | Serienbrief: einen Brief an alle Kontakte der aktuellen Suche schreiben.

·Bearbeiten | Eigenschaften: Den markierten Kontakt im Eigenschaftendialog einsehen oder überarbeiten. Sie können auch mehrere markieren, um diese zu ändern.

·Bearbeiten | Löschen: Markierten Kontakte endgültig löschen.

·Suchen | Suchen: Kontakte entsprechend den primären Suchfeldern filtern.

·Suchen | Felder leeren: Löscht den Text der primären Suchfelder.

·Suchen | Dokumente: Wechselt zur Ansicht der Dokumente und sucht alle Dokumente des markierten Kontakts.

·Suchen | Datensatz fixieren: Fixierte Kontakte bleiben auch in der Tabelle sichtbar, wenn sie nicht dem Suchfilter entsprechen.

·Beachten Sie weitere Suchfunktionen auf der Menüseite Start.

Neuen Kontakt hinzufügen

Wählen Sie bitte den Menübefehl Erstellen | Kontakt, geben Sie die Daten, wie Name und Anschrift ein. Der Matchcode ist eine Kurzfassung des Kontaktes, der standardmäßig für die Suche verwendet wird. Er sollte eindeutig sein, in der Kontaktdatenbank also nur einmal vorkommen, und die wichtigsten Merkmale, wie Firmenbezeichnung oder Nach- und Vorname beinhalten. Bei neuen Kontakten wird der Code automatisch festgelegt, wenn Sie ihn leer lassen.
Speichern Sie den Kontakt mit Klick auf OK.

Sie können zusätzliche Datenfelder festlegen.

Drag&Drop

Klicken Sie eine Visitenkartendatei (VCard mit Endung .vcf), eine E-Rechnung oder einen Kontakt in MS Outlook mit der Maus an, halten Sie die Maustaste fest, schieben diese auf die Kontakttabelle und lösen Sie die Maustaste.

Das Drag&Drop ist auch mit Text möglich, wenn eine geeignete Adresse markiert ist.

Mit KI-Unterstützung funktioniert die Kontaktextraktion sogar mit beliebigem Volltext.

Wie bei den Dokumenten, können Kontaktdaten per Drag&Drop in der gruppierten Tabelle angepasst werden.

Dokumentenzuordnung

Dokumente können einem Kontakt zugeordnet werden. Beachten Sie hierfür bitte im Dialogfenster die Registerseite Belegerkennung und hinterlegen Sie Schlagwörter, an denen ein Kontakt im Dokumententext erkannt wird. Gut geeignet sind eindeutige und längere Daten, wie beispielsweise zusätzliche E-Mail-Adressen und Telefonnummern, IBAN, USt-IdNr. oder Kundennummer. Ein Begriff je Zeile, Leerzeichen sowie Groß-, Kleinschreibung werden nicht beachtet.

Siehe auch

Kontakte importieren

Aufgabenverwaltung

Nachträgliche Zuordnung von Dokumenten


Terminplaner

Navigation: »Kein übergeordnetes Kapitel«

Terminplaner

Aufgabenverwaltung

Zum Öffnen der Aufgabenverwaltung wählen Sie den Befehl Ansicht | Anzeigen | Aufgaben oder klicken Sie am unteren Rand der Tabelle auf Aufgaben.

Sie können hier Ihre Tätigkeiten zu den Dokumenten und Kontakten sowie alle Aufgaben und Events zentral managen:

Hauptfenster in Aufgaben-Ansicht

Klicken Sie im Bild auf die Komponenten, zu der Sie weitere Hilfe wünschen.

Aufgaben suchen

Wenn Sie das Programm mit mehreren Benutzerinnen und Benutzern verwenden, können Sie die Aufgaben verschiedenen Ressourcen, beispielsweise Mitarbeitenden und Teams, zuordnen. Mit Klick auf Aufgabe | Ansicht | Ressourcen wählen Sie, welche Aufgaben derzeit im Terminplaner sichtbar sind, i. d. R. markieren Sie hier Ihren eigenen Benutzernamen.

Klicken Sie auch regelmäßig auf Suchen, um die Daten zu aktualisieren. Dies ist insbesondere nötig, um Änderungen anderer Benutze zu sehen.

Erinnerung

Wenn bei der Aufgabenplanung die Option Erinnerung aktiviert wurde, dann werden Sie bei fälligen Terminen benachrichtigt:

Diese Erinnerungen erscheinen nur für Tätigkeiten des angemeldeten Benutzers (Ressource). Sie sehen die Liste auch im Vorschaufenster, wenn keine Aufgabe markiert ist.

Relevante Befehle im Hauptmenü

In der Ansicht des Terminplaners wird das Hauptmenü um die Registerkarte Aufgabe erweitert. Hier finden Sie alle Menüfunktionen zum Planen der Tätigkeiten und zum Anpassen der Darstellungsoptionen.

Neue Aufgabe planen

Sie können Tätigkeiten für sich und Ihre Kollegen planen. Wählen Sie dazu den Befehl Erstellen | Aufgabe, geben Betreff und den Termin ein. Mit dem Betreff beschreiben Sie die Aufgabe möglichst kurz und deutlich. Ausführliche Hinweise und Anweisungen können Sie unten im mehrzeiligen Editor hinzufügen Im Feld Ressource wird der Mitarbeiter ausgewählt, der die Aufgabe erledigen soll.

Beispiel

Ein Kunde bittet per E-Mail um das Angebot für eines Ihrer Produkte. Sie erfassen zuerst die Mail im Dokumentenarchiv und planen dann für den zuständigen Sachbearbeiter eine Tätigkeit.

1.Schieben Sie die Mail per Drag&Drop in das Archiv.

2.Achten Sie darauf, dass diese Anfrage in der Tabelle markiert, damit die zu planende Aufgabe mit dieser verknüpft wird.

3.Klicken Sie im Hauptmenü auf Erstellen | Neu | Aufgabe und beschreiben Sie die Tätigkeit.

Aufgabe planen

4.Ab jetzt ist die Tätigkeit in der Aufgabenliste Ihrer Kollegin Karin vorhanden. Sie markiert die Tätigkeit in der Ansicht Aufgaben, klickt auf Start | Verwenden | Öffnen und liest Ihre Telefonnotiz. Mit Hilfe der Dokumentvorlage "Produkt-Angebot" erstellt Sie das Angebot und wird sich freuen, wenn sie in den nächsten Tagen die schriftliche Bestellung mit Office Manager DMS einscannt. Sie kann jetzt eine Versand-Tätigkeit für den Kollegen Manfred und eine weitere für Sabine in der Buchführung planen.

Aufgabe erledigen

Markieren Sie bitte eine oder mehrere erledigte Aufgaben in der Tabelle und klicken Sie auf den Menübefehl Aufgabe | Bearbeiten | Erledigen.

Datenaustausch

Beachten Sie die Menübefehle Datei | Datenbank | Datenaustausch. Mit Importieren können Sie Ihren kompletten Outlook-Kalender übernehmen. Exportieren erlaubt die Ausgabe in verschiedene visuelle und Datenformate.

Für einzelne Kalendereinträge nutzen Sie am besten Drag&Drop mit der Maus oder Start | Senden | Senden an andere. Auch in der Vorschau können Sie die markieren Aufgaben als iCalendar exportieren, schieben Sie dazu Aufgabe (iCalendard) vom unteren Rand des Vorschaufensters in die Zielanwendung.


Zeichnungsverwaltung

Navigation: »Kein übergeordnetes Kapitel«

Zeichnungsverwaltung

Verfügbar in diesen Editionen CAD-Zeichnungsverwaltung mit erweiterten Funktionen für AutoCAD, Inventor und MegaCAD

Computer-Aided Design ist rechnergestützt, die Zeichnungsverwaltung muss es ebenfalls sein.

In diesem Kapitel:

Assistent für die AutoCAD-Einrichtung

Zeichnungsverwaltung mit AutoCAD

Assistent für die Inventor-Einrichtung

Zeichnungsverwaltung mit Inventor

Assistent für die MegaCAD-Einrichtung

Zeichnungsverwaltung mit MegaCAD

CAD-Viewer

Beispiel: Schriftkopferzeugung für MegaCAD


Assistent für die AutoCAD-Einrichtung

Navigation: Zeichnungsverwaltung >

Assistent für die AutoCAD-Einrichtung

Verfügbar in diesen Editionen

Assistent für die AutoCAD-Einrichtung

Der Assistenten richtet die erweiterten AutoCAD-Funktionalitäten des Office Managers ein:

·Erstellung von Schriftköpfen für neue Zeichnungen,

·dynamische Verbindung zwischen AutoCAD und dem Zeichnungsarchiv,

·Blöcke in Zeichnungen einfügen

·und weitere benutzerdefinierbare Befehle.

AutoCAD einrichten

1.Wählen Sie den Menübefehl Datei | Optionen | Dokumenttyp, um das Fenster "Registrierte Dokumenttypen" zu öffnen.

2.Klicken Sie dort im Menü Start | Neu auf den Befehl AutoCAD einrichten. Das Fenster "AutoCAD-Einrichtung" wird geöffnet:

Screenshot AutoCAD-Einrichtung

3.Klicken Sie bitte auf Weiter und folgen Sie den Anweisungen des Assistenten.

Tipp: Nutzen Sie auch die Direkthilfe. Klicken Sie auf das Fragezeichen rechts im Fenstertitel und anschließend auf die Komponente, zu der Sie weitere Informationen benötigen.

Siehe auch

Zeichnungsverwaltung mit AutoCAD

CAD-Vorschauprogramm

Produktbeschreibung


AutoCAD-Zeichnungsverwaltung

Navigation: Zeichnungsverwaltung >

AutoCAD-Zeichnungsverwaltung

Verfügbar in diesen Editionen

Zeichnungsverwaltung mit AutoCAD

Hinweis: Das Beispielarchiv cad.omsl enthält spezielle Datenfelder für die Zeichnungsverwaltung.

Stellen Sie bitte zuerst sicher, dass die erweiterten AutoCAD-Funktionen im Office Manager eingerichtet sind. Starten Sie ggf. den Assistenten:

Das AutoCAD-Menü

Nach erfolgreicher Einrichtung finden Sie die neue Registerseite CAD im Programm-Hauptfenster:

Neue Zeichnung: Erstellt eine neue AutoCAD-Zeichnung. Dieser Befehl entspricht dem Menüeintrag Erstellen | Neu | Dokument, der Dokumenttyp "AutoCAD" wird aber automatisch ausgewählt.

Neues Bauteil: erstellt einen neuen Block.

Ausführen | AutoCAD: führt das AutoCAD-Programm aus.

Ausführen | acad.ini öffnen: öffnet die INI-Datei im Editor.

Ausführen | AutoCAD einrichten: den Assistenten für die AutoCAD-Einrichtung starten.

Je nach Installation sind weitere Befehle vorhanden, beispielsweise:

Ausführen | Bauteil einfügen: fügt das markierte Bauteil in die geöffnete Zeichnung ein.

Ausführen | DXF erzeugen: speichert die markierte Zeichnung als DXF-Datei.

Ausführen | Attribute aus Zeichnung lesen: übernimmt Änderungen in das Archiv.

Ausführen | Attribute in Zeichnung speichern: aktualisiert den Zeichnungsrahmen u. a. Attribute nach Änderungen im Archiv.

Sie können eigene Befehle für AutoCAD erstellen, siehe unter "Registrieren von Dokumenttypen".

Zeichnungsschriftkopf ausfüllen

Da in einem Zeichnungs-Schriftkopf oftmals die gleichen Daten stehen, wie sie auch in der Zeichnungsverwaltung erfasst wurden, liegt eine Kopplung von Datenbank und Zeichnung auf der Hand.

Wir beschreiben hier, wie Sie eine AutoCAD-Zeichnung mit fertig ausgefülltem Schriftfeld anlegen. Die Daten für das Zeichnungsschriftfeld werden dabei aus der Archivdatenbank übernommen.

Zeichnungsdaten eingeben

Die Erfassung der Zeichnungsdaten, die an AutoCAD übergeben werden sollen, geschieht bei der Neuanlage einer Zeichnung.

1.Wählen Sie den Menübefehl Erstellen | Neu | Dokument oder CAD | AutoCAD | Neue Zeichnung. Der Dialog "Neues Dokument‘ wird geöffnet:

Archivattribute einer Zeichnung

2.Geben Sie wie bei anderen Dokumenten die allgemeinen Attribute ein und öffnen Sie dann die Registerkarte "Zeichnung".

3.Geben Sie die Daten für das Schriftfeld ein. Im Feld Schriftkopf werden alle DWG-Dateien gelistet, die sich im Schriftkopfverzeichnis befinden (dieses Verzeichnis wurde vom AutoCAD-Assistenten bei der Einrichtung abgefragt).

4.Klicken Sie auf OK, AutoCAD wird jetzt geöffnet. Der Office Manager fügt den ausgefüllten Schriftkopf in die neue Zeichnung ein:

AutoCAD-Screenshot

5.Die dynamische AutoCAD-Anbindung aktualisiert das Archiv bei Änderungen am Schriftkopf (oder anderen AutoCAD-Attributen) und übernimmt Änderungen im Archiv automatisch in die Zeichnung. Um diese Funktion zu testen, ändern Sie jetzt bitte die Bezeichnung im Schriftkopf (AutoCAD-Befehl "eattedit"). Speichern Sie die Zeichnung und beenden Sie bitte AutoCAD. Sobald der Office Manager aktiviert wird, liest er die Zeichnungsdaten aus, erstellt den Volltextindex und aktualisiert den Dokumentnamen.

Erstellen einer eigenen Vorlage für Schriftfelder

Unser Schriftkopfmuster wird nicht für alle Anwender so zu verwenden sein. Wir zeigen Ihnen hier, wie Sie Ihre eigenen Schriftköpfe einbinden.

1.Kopieren Sie Ihre Schriftkopf-Zeichnungen (dwg-Dateien) bitte in das Verzeichnis, welches Sie im AutoCAD-Assistenten eingegeben hatten (z. B. C:\Dokumente und ..\Office Manager\Template\CadFrame)

2.Wählen Sie den Menübefehl CAD | AutoCAD | Ausführen | acad.ini öffnen. Siehe auch Beschreibung der Konfigurationsdatei im Internet.

3.In der Sektion "[Attribute2Field]" werden alle Attribute aufgelistet, die zwischen AutoCAD und dem Office Manager ausgetauscht werden. Die Namen der AutoCAD-Attribute können Sie sich mit dem AutoCAD-Befehl "eattedit" anzeigen lassen, wenn die Schriftkopfdatei geöffnet ist. Für die Liste der Office Manager-Attribute wählen Sie bitte im Menü Datei | Datenbank | Anpassen | Felder definieren. Beispiele für die Zuordnung der Attribute finden Sie in der INI-Datei.

4.Speichern Sie bitte die Datei acad.ini.


Assistent für die Inventor-Einrichtung

Navigation: Zeichnungsverwaltung >

Assistent für die Inventor-Einrichtung

Verfügbar in diesen Editionen

Assistent für die Inventor-Einrichtung

Inventor-Screenshot (Dank an www.bikeview.de)

Autodesk Inventor

Der Assistenten richtet die Befehle und Makros für den Inventor ein:

·Lesen und Schreiben der iProperties,

·dynamische Verbindung zwischen Inventor und dem Zeichnungsarchiv,

·Liste der zugehörigen Zeichnungen, wenn nur die Projektdatei verwaltet wird,

·Zeichnungs-Vorschau.

Inventor einrichten

1.Wählen Sie den Menübefehl Datei | Optionen | Dokumenttyp, um das Fenster "Registrierte Dokumenttypen" zu öffnen.

2.Klicken Sie dort im Menü Start | Neu auf den Befehl Inventor einrichten. und bestätigen Sie die Rückfrage mit Ja.

Siehe auch

Zeichnungsverwaltung mit Inventor


Inventor-Zeichnungsverwaltung

Navigation: Zeichnungsverwaltung >

Inventor-Zeichnungsverwaltung

Verfügbar in diesen Editionen

Zeichnungsverwaltung mit Autodesk Inventor

Hinweis: Das Beispielarchiv cad.omsl enthält spezielle Datenfelder für die Zeichnungsverwaltung.

Stellen Sie bitte zuerst sicher, dass die erweiterten Inventor-Funktionen im Office Manager eingerichtet sind. Starten Sie ggf. den Assistenten.

Einfache Projektverwaltung

Der Inventor verwaltet die Zeichnungen eines Projekts mit Hilfe der *ipj-Dateien. Wenn gewünscht, können Sie ausschließlich diese Projektdateien im Archiv verwalten. Zum Öffnen einer Zeichnung markieren Sie dann bitte dieses Dokument in der Tabelle und wählen anschließend im Menü Start | Verwenden | Öffnen den Befehl Detail-Dokumente:

Das Menü enthält alle Inventor-Dateien im Verzeichnis der Projektdatei. Klicken Sie bitte auf die zu öffnende Zeichnung.

Verwaltung der einzelnen Zeichnungen

Sie können auch alle gewünschten Zeichnungen in das Archiv importieren. Hierbei ist es möglich, die Zeichnungsattribute (iProperties) aus den Inventordateien zu lesen und in diese zu schreiben: Nach Änderung im Inventor wird das Archiv aktualisiert bzw. nach Änderungen im Archiv wird die Zeichnung aktualisiert. Die iProperties werden beispielsweise im Zeichnungsschriftkopf verwendet.

Ein Abgleich des Archivs mit der Zeichnung kann entweder automatisch erfolgen oder manuell mit den Menübefehlen Start | Verwenden | Befehle | Attribute aus Zeichnung lesen und Attribute in Zeichnung speichern.

Siehe auch

Makros für Inventor


Assistent für die MegaCAD-Einrichtung

Navigation: Zeichnungsverwaltung >

Assistent für die MegaCAD-Einrichtung

Verfügbar in diesen Editionen

Assistent für die MegaCAD-Einrichtung

Der Assistenten richtet die erweiterten MegaCAD-Funktionalitäten für das Zeichnungsarchiv ein:

·Erstellung von Schriftköpfen für neue Zeichnungen,

·Plotten von Zeichnungen,

·Bauteile in Zeichnungen einfügen,

·Importieren und Exportieren von Dateien im DWG- und DXF-Format.

·MegaHaustechnik-Vorlagen einrichten, wenn das Verzeichnis "HTVorlagen" vorhanden ist.

·Weitere benutzerdefinierbare Befehle.

MegaCAD einrichten

1.Wählen Sie den Menübefehl Datei | Optionen | Dokumenttyp, um das Fenster "Registrierte Dokumenttypen" zu öffnen.

2.Klicken Sie dort im Menü Start | Neu auf den Befehl MegaCAD einrichten. Das Fenster "MegaCAD-Einrichtung" wird geöffnet:

MegaCAD-Einrichtung

3.Klicken Sie bitte auf Weiter und folgen Sie den Anweisungen des Assistenten.

Tipp: Nutzen Sie auch die Direkthilfe. Klicken Sie auf das Fragezeichen rechts im Fenstertitel und anschließend auf die Komponente, zu der Sie weitere Informationen benötigen.

Siehe auch

Zeichnungsverwaltung mit MegaCAD

Produktbeschreibung


MegaCAD-Zeichnungsverwaltung

Navigation: Zeichnungsverwaltung >

MegaCAD-Zeichnungsverwaltung

Verfügbar in diesen Editionen

Zeichnungsverwaltung mit MegaCAD

Hinweis: Das Beispielarchiv cad.omsl enthält spezielle Datenfelder für die Zeichnungsverwaltung.

Stellen Sie bitte zuerst sicher, dass die erweiterten MegaCAD-Funktionen im Office Manager eingerichtet sind. Starten Sie ggf. den Assistenten:

Das MegaCAD-Menü

Nach erfolgreicher Einrichtung finden Sie die neue Registerseite CAD im Programm-Hauptfenster:

Neue Zeichnung: Erstellt eine neue MegaCAD-Zeichnung. Dieser Befehl entspricht dem Menüeintrag Erstellen | Neu | Dokument mit vorgewähltem Dokumenttyp "MegaCAD".

Neues Makro: Erstellt ein neues Bauteil.

Plotten: Öffnet die markierte Zeichnung im Plotprogramm.

Importieren: Hiermit lassen sich PRT-, DXF- oder DWG-Dateien per Drag&Drop importieren.

Exportieren: Die markierte Zeichnung als PRT, DXF oder DWG speichern.

Ausführen: Enthält die benutzerdefinierten Funktionen und Befehle.

Ausführen | Z. als Bauteil einfügen: Fügt die im DMS markierte Zeichnung wie ein Bauteil in die derzeit in MegaCAD geöffnete Zeichnung ein.

Ausführen | MegaCAD: Startet das CAD-Programm

Ausführen | Plotprogramm: Startet das Plotprogramm

Ausführen | MegaCAD einrichten: Den Assistenten für die Einrichtung starten.

Zeichnungsschriftkopf ausfüllen

Da in einem Zeichnungs-Schriftkopf oftmals die gleichen Daten stehen, wie sie auch in der Zeichnungsverwaltung erfasst wurden, liegt eine Kopplung von Datenbank und Zeichnung auf der Hand.

Wir beschreiben hier, wie Sie eine MegaCAD-Zeichnung mit fertig ausgefülltem Schriftfeld anlegen. Die Daten für das Zeichnungsschriftfeld werden dabei aus dem Archiv übernommen.

Hinweis: Nutzen Sie den MegaCAD-Einrichtungsassistent, um die erweiterten MegaCAD-Funktionen einzurichten. Sie können diese Einstellungen aber auch noch individuell anpassen.

Zeichnungsdaten eingeben

Die Erfassung der Zeichnungsdaten, die an MegaCAD übergeben werden sollen, geschieht bei der Neuanlage einer Zeichnung.

1.Wählen Sie den Menübefehl Erstellen | Neu | Dokument oder CAD | MegaCAD | Neue Zeichnung. Der Dialog "Neues Dokument" wird geöffnet:

Archivattribute einer Zeichnung

2.Geben Sie wie bei anderen Dokumenten die allgemeinen Attribute ein und öffnen Sie dann die Registerkarte "Zeichnung". Die Seite Zeichnung ist nur vorhanden, wenn Komponenten auf ihr platziert wurden, s. a. Layoutdesigner.

3.Geben Sie die Daten für das Schriftfeld ein.

4.Klicken Sie auf OK. Sofern MegaCAD noch nicht gestartet ist, wird es jetzt gestartet. Der Office Manager erzeugt einen Schriftkopf und fügt diesen in die neue MegaCAD-Zeichnung ein. Speichern Sie die Zeichnung in MegaCAD.

MegaCAD-Screenshot

Erstellen einer eigenen Vorlage für Schriftfelder

Unser Schriftkopfmuster wird nicht für alle Anwender so zu verwenden sein. Wir zeigen Ihnen nachfolgend, wie Sie einen eigenen Schriftkopf mit Hilfe von MegaCAD erstellen.

Im Vorlagenverzeichnis (z. B. C:\...\Office Manager\Template) finden Sie unsere Beispieldatei ZNGKOPF.CDL.

In diesem Schriftkopf sind Textvariablen positioniert worden. Diese Textvariablen setzen sich aus *DTM_ und einem Feldbezeichner aus der Office Manager-Datenbank zusammen.

Diese Änderungen nehmen Sie komplett in MegaCAD vor.

1.Erstellen Sie eine Sicherheitskopie unserer Beispieldatei ZNGKOPF.CDL

2.Starten Sie MegaCAD und laden Sie die Datei ZNGKOPF.CDL als Vorlage über die MegaCAD CDL-Schnittstelle ein.

3.Verändern Sie nun den Schriftkopf mit den MegaCAD-Funktionen. Überall dort, wo Daten vom Office Manager eingetragen werden sollen, müssen Sie den *DTM_ gefolgt vom Feldbezeichner einfügen.

4.Speichern Sie den Schriftkopf als CDL-Datei in das Vorlagenverzeichnis des Office Manager.


CAD-Viewer

Navigation: Zeichnungsverwaltung >

CAD-Viewer

Verfügbar in diesen Editionen

Zeichnungsvorschau

Programminterne Vorschaufunktion für CAD-Zeichnungen.

Diese Funktion ist nur in der Enterprise-Edition mit endgültigem Freigabecode verfügbar und muss vor der ersten Verwendung aktiviert werden. Klicken Sie dazu auf den entsprechenden Link im Vorschaufenster.

Bedienung

Mausrad zum Zoomen.

Primäre (linke) Maustaste für Direktzoom.

Mittlere Maustaste zum Verschieben des Ausschnitts.

Unterstützte Formate (Dateitypen)

·3DS: 3D Studio und andere

·ASE: ASCI Scene Export

·B3D: Blitz 3D model files

·CGM: Computer Graphics Metafile

·DWF, DWFX: Autodesk Design Web Format

·DWG: AutoCAD-Zeichnung

·DWT: AutoCAD-Zeichnungsvorlage

·DXF: Drawing Interchange File Format, Ascii und binär

·DXT: Zeichnungsvorlage

·GP2: Gerber-Plotdatei

·GTS: GNU Triangulated Surface

·HPGL, HPGL2, PLT, HGL, HG, HPG, PLO, HP, HP1, HP2, HP3, HPP, GL, GL2, PRN, SPL, RTL, PCL: Hewlett Packard Graphics Language

·IGES, IGS: Initial Graphics Exchange Specification

·MDC: MDSfiles

·OBJ: Wave Front und andere

·PLY: Stanford Triangle Format vector file

·SAT

·SLDPRT: SolidWorks

·STEP, STP, STPZ: Standard for the Exchange of Product model data

·STL: Stereolithography File Format (Ansi und binär)

·STEP: Standard for the Exchange of Product model data

·SVG, SVGM, SVGZ: Scalable Vector Graphics

·TIN: Triangular Irregular Network vector file format

·VRML: Virtual Reality Modeling Language vector file

·X_B, X_T: Parasolid

·und einige mehr

Einige Formate erfordern die Installation von Open Cascade (MeshBuilder.dll). Sie können dies über die Softwareaktualisierung laden.

Die Hintergrundfarbe kann in der admin.ini in Sektion [View] angepasst werden. Beispielsweise PreviewColor=clBlack oder PreviewColor=clBlue.

Siehe auch

Dokumentenvorschau


Beispiel: Schriftkopferzeugung für MegaCAD

Navigation: Zeichnungsverwaltung >

Beispiel: Schriftkopferzeugung für MegaCAD

Verfügbar in diesen Editionen

Schriftkopf-Erzeugung für MegaCAD manuell einstellen

Hinweis: der MegaCAD-Einrichtungsassistent erstellt die MegaCAD-Dokumenttypen automatisch. Sie können hier die Vorgaben des Assistenten nachvollziehen und die Einstellungen individuell anpassen.

1.Wählen Sie den Menübefehl Datei | Optionen | Dokumenttyp.

2.Markieren Sie den MegaCAD-Dokumenttypen in der Tabelle und wechseln Sie auf die Registerkarte Befehle.

3.Markieren Sie bitte den Befehl new.

4.Die Optionen In das Verzeichnis der Anwendung wechseln und Benutzerdefinierte Steuerung müssen markiert sein. Stellen Sie bitte sicher, dass die richtige MegaCAD-Programmdatei angegeben ist.

5.Klicken Sie auf den Schalter Erweitert.

6.Markieren Sie die Option Makro-Steuerung und geben im Eingabefeld Makro folgende Befehle ein:
{ShellExecute:{CurrApplExe},,3,WaitForInputIdle}
{DDEOpenLink:MegaCAD_3D,System,Synchron}
{DDESendMacro:"PrtLoad ""{CurrDocFileName}""","CDLRead {MegaCreateFrame:G:\..\ZNGKOPF.CDL}"}
{DDECloseLink}

Beachten Sie unbedingt die Groß- und Kleinschreibung im DDE-Befehl "PrtLoad und CDLRead", da MegaCAD hier unterscheidet. Eine Liste der MegaCAD-Befehle finden Sie im MegaCAD-Verzeichnis in der Datei FUNCNAM.INI.

Erklärungen:

PrtLoad: MegaCAD-Funktion, öffnet eine Zeichnungsdatei

{CurrDocFileName}: die Dokumentdatei

CDLRead: MegaCAD-Funktion, liest eine CDL-Datei ein

MegaCreateFrame: Office Manager-Funktion "Schriftkopf" aufrufen

G:\..\ZNGKOPF.CDL: Dateiname der Vorlagendatei. Geben Sie die Datei bitte mit komplettem Pfad ein.


Datenbankoperationen

Navigation: »Kein übergeordnetes Kapitel«

Datenbankoperationen

Datenbankoperationen

In diesem Kapitel:

Menü Datei

Neues Archiv: Eine neue Datenbank erstellen.

Archiv öffnen: Das Standardarchiv ist beim Programmstart bereits geöffnet. Verwenden Sie diese Funktion, um eine andere Dokument- oder Anwendungsdatenbank zu öffnen. Siehe auch Archiv-Schnellzugriff.

Menü Datei | Datenbank, Schalter Datenaustausch

Die Funktionen beziehen sich auf die aktuelle Ansicht. Wechseln Sie zuvor bitte zur gewünschten Tabelle der Dokumente, Aufgaben oder Kontakte.

Importieren: Datensätze aus anderen Datenquellen übernehmen.

Exportieren: Datentabelle in verschiedene Formate exportieren.

Übersicht drucken: Exportiert die Dokumentdatensätze der aktuellen Suche in eine HTML-Datei und öffnet diese im Browser.

Synchronisieren: Die auf ein Notebook ausgelagerte Daten mit der Hauptdatenbank abgleichen.

An Steuerberater senden: Datenübergabe an Steuerberater oder Buchungsbüro.

Mit Buchhaltung synchronisieren: Buchungsdaten von DATEV oder Lexware importieren.

Menü Datei | Datenbank, Schalter Anpassen

Felder definieren: Datenfelder der Dokumenttabelle erstellen.

Eigenschaften: Einstellungen und Verbindungsparameter der geöffneten Server-Datenbanken bearbeiten.

Dateipfade ändern: Dokumentendatenbank an neue Verzeichnisstrukturen anpassen.

Menü Datei | Datenbank, Schalter Pflege

Dateiexistenz prüfen: Es wird überprüft, ob die in den Datensätzen zugeordneten Dokumentdateien vorhanden sind.

Datenbankpflege: Prüft und komprimiert die derzeit geöffneten Datenbanken.

Dublette suchen: Spürt mehrfach vorhandene Dokumente oder Kontakte auf.


Neues Archiv erstellen

Neues Archiv oder andere Datenbank erstellen

Navigation: Datenbankoperationen >

Neues Archiv oder andere Datenbank erstellen

Klicken Sie bitte auf die Funktion Datei | Neues Archiv, das Fenster "Neue Datenbank" wird geöffnet:

Neue Datenbank (Dokumentarchiv)

Wählen Sie den Typ der neuen Datenbank

Dokumentenarchiv erstellt ein neues Archiv. Die Datenfelder und einige Optionen des geöffneten Archivs werden übernommen. Öffnen Sie zuvor das Dokumentenarchiv, welches Sie als Vorlage für das neue verwenden möchten.

Synchrones Dokumentenarchiv erstellt eine synchrone Datenbank mit den Dokumenten der aktuellen Suche. Hiermit können Sie z. B. ausgewählte Dokumente auf ein Notebook übertragen und später wieder mit dem Netzwerk synchronisieren. Diese Option ist nur bei einer Netzwerkinstallation und nicht in GoBD-Archiven möglich.

Archiv zur Prüfungsvorlage für einen Steuer- oder Wirtschaftsprüfer nur mit den relevanten Daten des Prüfungszeitraumes erstellen. Diese Option ist nur in GoBD-Archiven möglich.

Anwendungsdatenbank erstellt eine neue Datenbank für die Definition von Dokumenttypen.

Kontaktdatenbank für Customer-Relationship-Management (CRM).

Klicken Sie bitte auf die Schaltfläche Weiter.

Datenbanktreiber wählen

Je nach eingesetzter Programmedition können Sie unterschiedliche Datenbankformate nutzen.

a. Wählen Sie "SQLite" oder "Microsoft Access" in der Auswahlliste Datenbanktreiber und klicken Sie auf Weiter, wenn Sie eine Datenbank mit einem Standardtreiber erstellen möchten. In der 32-Bit-Edition können SQLite-Datenbanken verschlüsselt und mit Passwort geschützt werden.

b. Oder, wenn Sie mit mehreren Benutzern gleichzeitig im Netzwerk arbeiten:

Wählen Sie den Treiber für den Zugriff auf Ihren bestehenden SQL-Server. Klicken Sie bitte auch auf den Link Online-Hinweise für den Zugriff auf SQL-Server - dort finden Sie ausführliche Informationen und Anleitungen.

Je nach verwendetem Treiber werden weitere Eingabefelder sichtbar. Geben Sie bitte zuerst den Namen des Datenbankservers im Eingabefeld Server ein und klicken Sie auf Verbindung testen. Siehe auch MS SQL-Supportseite bei Verbindungsproblemen.

Als Datenbank können Sie eine zuvor erstellte (aber noch leere) oder eine noch nicht vorhandene Datenbank angeben. Ein erneutes Testen der Verbindung ist nur sinnvoll, wenn die Datenbank bereits vorhanden ist. Im anderen Fall wird diese erst mit Abschluss des Assistenten erstellt.

Benutzer-Authentifizierung: Wir empfehlen insbesondere bei Microsoft SQL, die integrierte Sicherheit zu verwenden. Hierbei werden die Windows-Logindaten auch für den SQL-Server verwendet. Anderenfalls geben Sie bitte den Benutzer und das Kennwort an, mit welchem alle Anwender automatisch angemeldet werden. Beachten Sie hierbei, dass das Kennwort über Menü Datei | Datenbank | Anpassen | Eigenschaften eingesehen werden kann - schützen Sie den Menübefehl, wenn dies vermieden werden soll.

Klicken Sie bitte auf die Schaltfläche Weiter.

Dateiname

Geben Sie bitte den Namen für die neue Datenbank ein:

Archiv-Name und -Datei

Archiv-Name (nur Dokumentenarchiv): Bezeichnung des neuen Archivs.

Dateiname der neuen Datenbank.

Klicken Sie auf die Schaltfläche Weiter. Für den Zugriff auf SQL-Server müssen Sie jetzt mit Hilfe der Datenbanksoftware die erforderlichen Benutzerkonten einrichten.

Datenbank erstellen

Wenn die Option Datensätze kopieren markiert ist, wird die derzeit geöffnete Datenbank in die neu erstellte kopiert.

Der GoBD-Modus ist für steuerrelevante Dokumente nötig. Die Option ist nicht wählbar, wenn die Datensätze kopiert werden sollen und das geöffnete Archiv keinen GoBD-Modus hat. Aktivieren Sie den Modus in so einem Fall anschließend in den Programmeinstellungen.

Ein Datenbank-Login ist nur erforderlich, falls Sie mit Ihrem Windows-Konto nicht die erforderlichen Datenbank-Berechtigungen haben und diese mit einem manuellen Login vom SQL-Server anfordern können.

Klicken Sie auf Fertigstellen, um die neue Datenbank zu erzeugen. Der Office Manager erstellt die erforderlichen Tabellen und Daten.

Siehe auch

Datenbank kopieren


Datenbankexport

Navigation: Datenbankoperationen >

Datenbankexport

Diese Funktion speichert die aktuelle Suche der aktiven Tabelle (Aktive Dokumente, archivierte Dokumente, Kontakte oder Aufgaben) in verschiedene Datenformate:

·Archiv mit Dokumentdateien (.omexc), beispielsweise für die Datenübergabe an Partnerfirmen oder den Steuerberater. Sie können einen Kommentar mit Hinweisen hinterlegen, der beim späteren Import eingeblendet wird. Dies ist das einzige Export-Format, welches neben den Datensätzen auch die Dokumentdateien beinhaltet.

·Austauschdateien (.adb) beinhalten die jeweilige Datentabelle mit allen Feldern. Diese sind geeignet, um Daten mit anderen Archiven im selben Netzwerk auszutauschen.

·Visueller Export: HTML-, XML-, Excel-, CSV- und Text-Formate enthalten ebenfalls nur Datensätze ohne Dokumentdateien. Sie können beispielsweise dem Datenaustausch mit anderen Programmen dienen oder eine Übersichtstabelle für Excel liefern, wenn Sie spezielle Auswertungen vornehmen möchten. Die erstellte Tabelle entspricht dem Aussehen (auch Gruppierung, Sortierung und Spaltenbreite) der Datentabelle in Office Manager DMS und beinhaltet nur Datenfelder, die in dieser sichtbar sind.
Hinweis zum CSV-Format: Semikolon-getrennte Daten werden in ANSI, kommagetrennte in UTF8 (Unicode) gespeichert.

·Die Aufgaben können in den Kalender von Microsoft Outlook geschrieben werden. Beachten Sie bitte, dass ein wiederholter Export derselben Aufgaben zu doppelten Einträgen im Outlook-Kalender führt. Geben Sie bei Schritt 3 einen beliebigen Dateinamen an, der Export erfolgt nicht in die Datei, sondern direkt in Outlook..

Dokumente, Kontakte und Aufgaben exportieren

1.Wechseln Sie bitte zur gewünschten Ansicht der Dokumente, Kontakte oder Aufgaben.

2.Wenn Sie Dokumente oder Kontakte exportieren möchten, dann filtern Sie die zu schreibenden Datensätze.

3.Klicken Sie auf den Menübefehl Datei | Datenbank | Datenaustausch | Exportieren:

Aktive Dokumente exportieren

4.Wählen Sie den gewünschten Dateityp und geben Sie den Namen für die zu erstellende Datei ein. Das Programm wählt das zu erstellende Datenformat anhand der Auswahl bei Dateityp, achten Sie also bitte darauf, diesen korrekt aus der Liste zu wählen.

5.Klicken Sie bitte auf OK, um diese zu erstellen.

In ein neues Archiv exportieren

Wenn Sie das gesamte Archiv in eine neue Datenbank speichern möchten, dann verwenden Sie bitte die Funktion Datei | Datenbank | Neues Archiv. Als Datenbanktyp wählen Sie "Dokumentenarchiv" und markieren auf der letzten Seite die Option Datensätze kopieren.

Für die Übertragung auf einen SQL-Datenbankserver beachten Sie bitte die Supportseiten.

Tipp: Für den Tabellenexport in Text und Excel können Sie auch die Zwischenablage verwenden.

Siehe auch

Dokumentenreport

Report-Generator


Datenbankimport

Navigation: Datenbankoperationen >

Datenbankimport

Import von Dokumentdatensätzen, Kontakten oder Aufgaben aus verschiedenen Datenquellen.

Mögliche Quellformate:

·Fremddateien im Access- und CSV-Format.

·Datenbanken von Office Manager DMS, Gonz@les Web-Runner 6.0 (.gwr), ELOoffice und Rack2-Filer Smart.

·Austauschdateien (.omexc, .adb), die zuvor mit dem Datenbankexport erstellt wurden.

·ACT! Customer-Relationship-Management

·Microsoft Outlook

Austauschdateien mit der Endung .omexc sowie ELO-Archive und Rack2-Filer beinhalten neben den Datensätzen auch die Dokumentdateien. Bei allen anderen Formaten werden nur Datenbankinhalte eingelesen.

Anleitung für Dokumente und Kontakte

1.Wechseln Sie zu der Tabellenansicht Dokumente oder Kontakte, in der Enterprise-Edition auch zu den archivierten Dokumenten. Dies legt fest, ob Sie in das Dokumentenarchiv oder in die CRM-Kontaktdatenbank importieren möchten.

2.Wählen Sie bitte den Menübefehl Datei | Datenbank | Datenaustausch | Importieren:

Import in Archiv- oder Kontakdatenbank

Klicken Sie im Bild auf die Komponenten, zu der Sie weitere Hilfe wünschen.

3.Klicken Sie auf Ordner im Eingabefeld Quelldatei und wählen Sie die Datei, aus der Sie importieren möchten. Wenn die Quelldatei mehrere Datenbanktabelle beinhalten, müssen Sie anschließend die gewünschte Tabelle angeben.

4.Bei einigen Datenquellen können Sie jetzt die Felder zuordnen: Wählen Sie in der rechten Spalte Ziel die entsprechenden Felder aus der Liste, um sie den Datenfeldern der Quelle zuzuordnen. Bereits zugeordnete werden in der Liste durchgestrichen. Die Auswahl mehrerer Quellfelder ist nur bei Zielfeldern mit mehrzeiligem Text sinnvoll.

5.Klicken Sie auf Importieren.

6.Beim Dokumentenimport aus .omexc-Dateien öffnet sich der Eigenschaftendialog.

Hinweise

Diese Funktion ist in GoBD-Archiven gesperrt.

Wurde beim Archivimport der Dokumenttyp (Feld applname) nicht importiert, dann wird versucht eine passende Anwendung zuzuordnen.

Programmeigene Datenbanken

Falls Sie eine Archiv- oder Kontaktdatenbank in ein anderes Datenbankformat konvertieren möchten, dann verwenden Sie besser die Funktion Datei | Neues Archiv.

CSV-Dateien

Textdateien im "Comma-separated values"-Format werden direkt verarbeitet, wenn die Felder mit einem Komma getrennt sind oder das Trennzeichen automatisch erkannt wird. Andere Trennzeichen können Sie mit Hilfe der Datei "Schema.ini" definieren, siehe hierzu im MSDN.

Access-Datenbanken

Der Import erfolgt mithilfe der Windows-Datenbankschnittstellen und ist nur möglich, wenn die entsprechenden Treiber vorhanden sind. Installieren Sie die 32 Bit-Edition von Office Manager DMS, falls ein Zugriff mit der 64 Bit-Edition nicht möglich ist.

Anleitung für Aufgaben

Sie können die Aufgaben aus MS Outlook in den Kalender von Office Manager DMS importieren:

1.Wechseln Sie mit Ansicht | Anzeigen | Aufgaben zur Aufgabenansicht.

2.Wählen Sie den Menübefehl Datei | Datenbank | Datenaustausch | Importieren.

3.Wenn Sie die Rückfrage mit Ja beantworten, werden alle Aufgaben aus Ihrem Outlook importiert.

Beachten Sie bitte, dass dies keine Synchronisierung, sondern ein Datenimport ist. Ein mehrfacher Import derselben Daten führt dazu, dass dieselben Aufgaben auch mehrmals vorhanden sind.


Daten synchronisieren

Navigation: Datenbankoperationen >

Daten synchronisieren

Verfügbar in diesen Editionen

Archivdatenbank synchronisieren

Diese Funktion ermöglicht den Abgleich des Firmenarchivs mit einem zuvor erstellten Synchronarchiv. Zum Beispiel können Sie die für eine Geschäftsreise relevanten Daten auf Ihr Notebook auslagern und nach Ihrer Rückkehr mit den Daten im Firmennetzwerk abgleichen. Bei der Synchronisierung werden die Dokumentdateien und die Datensätze aktualisiert.

Diese Funktion ist in GoBD-Archiven gesperrt.

Ein synchrones Archiv erstellen

Voraussetzung: Das Notebook ist als Client-Computer mit dem Netzwerk verbunden. Siehe hierzu im Whitepaper Netzwerkinstallation.

Führen Sie folgende Schritte auf dem Notebook durch, auf dem die synchronen Daten abgelegt werden sollen.

1.Öffnen Sie das Hauptarchiv, welches sich auf dem Netzwerkserver befindet.

2.Grenzen Sie die aktuelle Suche so ein, dass nur die Dokumente gezeigt werden, die Sie auf das Notebook kopieren möchten.

3.Wählen Sie bitte im Menü Datei | Datenbank den Befehl Neues Archiv. Markieren Sie "Synchrones Dokumentenarchiv" und klicken Sie auf Weiter.

4.Geben Sie auf den Folgeseiten die gewünschten Optionen ein. Als Treiber für die lokalen Datenbanken wird in der Regel "SQLite" verwendet. Stellen Sie das neue Synchronarchiv bitte fertig.

Tipp: Nutzen Sie auch die Direkthilfe. Klicken Sie auf das Fragezeichen rechts im Fenstertitel und anschließend auf die Komponente, zu der Sie weitere Informationen benötigen.

5.Das synchrone Archiv wird mit den Datensätzen der aktuellen Suche erzeugt und die Dokumentdateien kopiert.

6.Beenden Sie den Office Manager und trennen Sie das Notebook vom Firmennetzwerk.

7.Beim nächsten Programmstart werden Sie informiert, dass die lokalen Daten verwendet werden.

8.Sie können die Daten und Dokumente im lokalen Archiv wie gewohnt verwenden und bearbeiten. Wenn Sie sich später wieder mit dem Netzwerk verbinden, können Sie das Archiv mit dem originalen im Netzwerk synchronisieren:

Synchronisieren

1.Stellen Sie bitte sicher, dass das Quellarchiv (das Hauptarchiv im Firmennetzwerk) geöffnet ist. Hierzu müssen Sie mit dem Netzwerk verbunden sein. Wählen Sie ggf. im Menü Datei den Befehl Archiv öffnen, um dieses zu laden.

2.Erstellen Sie eine Suche nach den Dokumenten die Sie abgleichen möchten.

3.Wählen Sie den Menübefehl Datei | Datenbank | Datenaustausch | Synchronisieren:

Klicken Sie im Bild auf die Komponenten, zu der Sie weitere Hilfe wünschen.

3.Geben Sie den Namen des synchronen Archivs im Feld synchronisieren mit ein (z. B. auf der Notebook-Festplatte).

4.Legen Sie bitte die Datenpriorität fest:
Daten des geöffneten Archivs, wenn die Attribute der geöffneten Datenbank gültig sind. Das synchrone Archiv wird aktualisiert.
Daten des Synchronarchivs, wenn die Attribute der synchronen Datenbank gültig sind. Das geöffnete Archiv wird aktualisiert.

5.Wählen Sie die Gültige Dokumentdatei:
Einzeln fragen: Sie müssen bei jeder Datei auswählen, welche gültig ist. Beachten Sie bitte, dass diese Option bei großen Datenbanken sehr zeitaufwendig sein kann.
Die neuere Datei: die Dateien mit dem neueren Bearbeitungsdatum sind gültig. Die älteren Dateien werden überschrieben.
Datei des geöffneten Archivs: die originalen Dateien (z. B. im Firmennetzwerk) sind immer gültig. Die ausgelagerten werden überschrieben.
Datei des Synchronarchivs: die ausgelagerten Dateien (z. B. auf dem Notebook) sind gültig. Die originalen werden überschrieben.
Die Dateien werden nur abgeglichen, wenn Datum/Zeit der letzten Bearbeitung unterschiedlich ist. Falls eine Datei nicht existiert, wird die synchrone kopiert.
Legen Sie die Dateipriorität sehr sorgfältig fest und markieren Sie die Option Sicherungskopien erstellen, um Datenverluste zu vermeiden.

6.Klicken Sie bitte auf Starten, um den Datenabgleich auszuführen.

Hinweis: Interne Dokumentverknüpfungen werden beim Erstellen des Synchronarchivs übernommen, bei einer späteren Synchronisierung aber nicht berücksichtigt.

Siehe auch

Mobile App für Smartphone und Tablet

Steuerprüfung vorbereiten

Mit Buchhaltung synchronisieren

Startparameter "UseLocalFiles"


Report drucken

Navigation: Datenbankoperationen >

Report drucken

Verfügbar in diesen Editionen

Report drucken

Generiert Detailansichten der markierten Dokumente bzw. Kontakte im PDF-Format oder druckt diese aus. Auf den Reportblättern werden die Daten und bei Dokumenten auch das Vorschaubild ausgegeben.

Beispiel:

Reportblätter erstellen

1.Markieren Sie ein oder mehrere Dokumente bzw. Kontakte in der Tabelle.

2.Wählen Sie bitte den Menübefehl Datei | Datenbank | Datenaustausch | Report oder Start | Verwenden | Drucken | Report.

3.Markieren Sie auf der Seite Felder die Attribute, welche ausgegeben werden sollen. Um die Position der Felder auf dem Ausdruck anzupassen, können Sie diese in der Liste per Drag&Drop sortieren: Feld anklicken, Maustaste festhalten, an die gewünschte Postion schieben und die Maustaste lösen.

Report drucken: Datenfelder

Klicken Sie im Bild auf die Komponenten, zu der Sie weitere Hilfe wünschen.

4.Auf der Seite Optionen können Sie verschiedene Einstellungen vorgeben.

Report drucken: Optionen

Klicken Sie im Bild auf die Komponenten, zu der Sie weitere Hilfe wünschen.

Hinweis: Die Kopfzeile enthält Ihre Adresse, wie in den Programmeinstellungen auf Seite Lizenz eingegeben.

5.Wählen Sie auf der Seite Allgemein, ob der Report gedruckt oder in eine PDF-Datei gespeichert werden soll und klicken Sie anschließend auf OK, um die Funktion auszuführen.

Report drucken: Allgemein

Klicken Sie im Bild auf die Komponenten, zu der Sie weitere Hilfe wünschen.

Siehe auch

Beispiel-Report

Dokumente drucken

Dokumentenvorschau

Übersicht drucken

Datenbank- und Tabellenexport

Report-Generator


An Steuerberater senden

Navigation: Datenbankoperationen >

An Steuerberater senden

Verfügbar in diesen Editionen

Belege an den Steuerberater geben

Für die regelmäßige Datenübergabe an den Steuerberater oder das externe Buchungsbüro. Die Funktionsweise wird einmalig durch den Administrator festgelegt und kann dann sehr einfach vom zuständigen Anwender genutzt werden, um beispielsweise jeden Monat die buchungsrelevanten Belege zu versenden.

1.Markieren Sie links im Navigator das gewünschte Buchungsjahr bzw. Projekt, es können auch mehrere gewählt werden.

2.Menübefehl Datei | Datenbank | Datenaustausch | An Steuerberater senden
Belege an Steuerberater senden

3.Mit Klick auf Starten werden die Daten kopiert.

4.Im Anschluss werden Sie gefragt, ob die Dokumente als bereits weitergegeben markiert werden sollen. Bestätigen Sie dies mit Ja, wenn die Datenübergabe erfolgreich war. Die Dokumente werden dann beim nächsten Aufruf dieser Funktion nicht erneut kopiert.


Mit Buchhaltung synchronisieren

Navigation: Datenbankoperationen >

Mit Buchhaltung synchronisieren

Verfügbar in diesen Editionen

Buchungsinformationen aus Lexware oder Datev importieren

Für die Archivierung von Buchungsbelegen bietet Ihnen der Office Manager zahlreiche Importfunktionen für Papierdokumente, E-Mails und andere Dokumente. Bei einer einfachen Archivierung können Sie die Belege wie in einem Aktenordner ablegen: dazu wird im Projektnavigator eine Struktur für Buchungsjahre und Quartale oder Monate angelegt. Die Belege werden in der gleichen Reihenfolge erfasst, wie diese in der Akte abgelegt wurden. Bei der späteren Suche nach einem Beleg wird der entsprechende Zeitraum im Projektnavigator markiert und einige Begriffe für die Volltextsuche eingegeben. Mit Hilfe der angedockten Vorschau wird der Beleg schnell gefunden.

Für noch bessere Recherchemöglichkeiten können Sie beim Erfassen der Belege aber auch weitere Daten, wie die Belegnummer, den Kunden- oder Lieferantennamen, Rechnungsstatus und Buchungsbeträge eingeben. Dann sind erweiterte Abfragen möglich, wie beispielsweise:

·"Zeige alle offenen Rechnungen, die vor dem 7. Juli erstellt wurden",

·"Zeige mir die Rechnung mit Nummer 7123" oder

·"Errechne mir eine Umsatz-Statistik meiner Kunden.

Hier setzt die Synchronisierung mit der Buchhaltung ein: Beim Erfassen der Belege geben Sie nur die Belegnummer ein. Alle weiteren Informationen, Buchungskonten und Beträge kommen aus der Buchhaltung!

Tipp: Die Synchronisierung eignet sich auch gut zur Kontrolle, ob alle Belege archiviert wurden. Insbesondere, falls Sie die Originalbelege anschließend vernichten möchten. Nach dem Durchlauf wird eine Logdatei mit den fehlenden Belegen geöffnet.

1. Belege archivieren

Bei der Installation des Office Managers wurde das Beispielarchiv "Buchhaltung.omp" mit installiert. Wenn Sie neu beginnen, dann öffnen Sie dieses jetzt bitte.

Wenn Sie bereits ein Archiv mit Buchungsbelegen erstellt haben, dann können Sie dieses selbstverständlich verwenden. Sie sollten aber im Vorfeld die "Nummer" in "Belegnr." umbenennen, weil der Begriff in dieser Beschreibung verwendet wird. Wählen Sie dazu Felder definieren, markieren Sie DOCNO und geben Sie bei Bezeichnung bitte "Belegnr." ein.

Markieren Sie bitte zuerst das Buchungsjahr im Navigator.
Papierdokumente werden mit einem Scanner eingelesen. Digitale Dokumente müssen i. d. R. auch im digitalen Format archiviert werden: E-Mails importieren Sie z. B. per Drag&Drop aus dem Mailprogramm in den Office Manager (s. a. Kapitel Dokumente importieren).

Es ist wichtig, dass Sie die Belegnummer der Buchhaltungssoftware im Office Manager-Datenfeld "Belegnr." eingeben. Über diese eindeutige Nummer werden die Daten synchronisiert.

Buchung z. B. in Lexware erfassen

DMS-Screenshot Archivattribute beim Scannen

Gleiche Belegnummer und das Buchungsjahr im Office Manager eingeben.

Weitere Daten sind nicht erforderlich. Das Buchungsjahr ist nötig, wenn die Zählung der Belegnummern in einem neuen Jahr wieder bei 1 beginnt, sie also nur innerhalb eines Jahres eindeutig sind.

2. Synchronisierungsdatei erstellen

2a. Lexware Buchhalter

Verfügbar in diesen Editionen

Starten Sie bitte den Buchhalter und prüfen Sie, ob die entsprechende Firma und das Buchungsjahr aktiviert sind. Wählen Sie im Menü Datei | Export den Befehl Text/ASCII. Wenn Sie den Export zum ersten Mal durchführen, dann achten Sie bitte darauf, dass Sie die Einstellungen von den Screenshots übernehmen. Beim nächsten Export wählen Sie einfach das Profil "Office Manager".

2b. DATEV

Verfügbar in diesen Editionen

Starten Sie bitte die DATEV-Software und prüfen Sie, ob die entsprechende Firma und das Buchungsjahr aktiviert sind.

Grundeinstellungen: Klicken Sie bitte im Menü Extras auf ASCII-Formate und wählen Sie dann Exportformate, Buchungsprotokoll und klicken Sie auf den Schalter Anzeigen. Prüfen Sie bitte die ausgewählten Felder. Diese müssen in folgender Reihenfolge aufgelistet werden: Vorlaufnr, BSZaehler, SollHaben, WKZUmsatz, Umsatz, Kurs, BUFeld, GegKto, Belegfeld1, Belegfeld2, Belegdatum, Konto, KOST1, KOST2, KOSTMenge, Buchungstext, HerkunftKZ, UstSatz, EGSteuerSatz. Tipp: eine andere Reihenfolge kann in der datev.ini des Office Managers eingestellt werden.

Datei erstellen: Wählen Sie im Menü Bestand | Exportieren den Befehl ASCII-Format. Im Dialogfenster "ASCII-Daten exportieren" stellen Sie bitte folgende Optionen ein: Datenformat = "Buchungsprotokoll", Formatname = "Buchungsprotokoll", Zeichensatz = "Ansi". Markieren Sie Ohne Personensammelkonten. Bei Pfad wählen Sie am besten Ihren Ordner "Eigene Dateien", weil Sie die Dateien in diesem Verzeichnis sehr einfach wiederfinden. Den Dateinamen können Sie beliebig festlegen, Sie müssen diesen gleich im Office Manager wählen.

3. Buchungsdaten in das Archiv übernehmen

Erstellen Sie bitte zuerst eine Sicherungskopie des Office Manager-Archivs.

Wählen Sie anschließend im Menü Datei | Datenbank | Datenaustausch den Befehl Lexware Buchhalter bzw. DATEV Buchungstexte. Sie werden beim ersten Datenabgleich eventuell gefragt, ob die erforderlichen Datenfelder hinzugefügt werden sollen. Antworten Sie bitte mit Ja.

Im Dateidialog wählen Sie bitte die Exportdatei aus dem Buchhalter, z. B. "Eigene Dateien\Buchhalter 2010.txt" und anschließend das Buchungsjahr.

Bestätigen Sie bitte die Rückfrage "Buchungsdaten werden gelöscht und anschließend neu aus Lexware/Datev eingelesen".

Die Synchronisierung wird durchgeführt:

Sie erhalten anschließend einen Bericht, falls Belege während der Synchronisierung nicht gefunden wurden. Prüfen Sie diese bitte unbedingt: wurden die Belege eventuell vergessen oder mit einer falschen Belegnummer/falschem Buchungsjahr erfasst?

4. Die Buchungsdaten im Belegarchiv

Screenshot eines GDPdU-Belegarchives


Felder definieren

Navigation: Datenbankoperationen >

Felder definieren

Attribute definieren

Sie können hier die Datenbankstruktur der geöffneten Archiv- und Kontaktdatenbank an Ihre individuellen Anforderungen anpassen: neue Attribute hinzufügen, überflüssige löschen, die Bezeichnung ändern und den Eingabestil, z. B. Listenauswahl, festlegen.

Melden Sie sich bitte als Office Manager-Administrator an und wechseln Sie zur Ansicht der Dokumente oder Kontakte. Wählen Sie anschließend den Menübefehl Datei | Datenbank | Anpassen | Felder definieren:

Klicken Sie im Bild auf die Komponenten, zu der Sie weitere Hilfe wünschen.

Um ein neues Datenfeld hinzuzufügen, klicken Sie auf den Schalter Neu und geben Sie die im Folgenden beschriebenen Daten ein. Spezielle Felder für Datei- und E-Mail-Attribute erstellen Sie mit Klick auf den Pfeil des Schalters Neu.

Seite "Ansicht"

·Beschreibung: die im Programm sichtbare Bezeichnung

·Eingabestil: die Art, wie Daten erfasst werden

·Erweitert / Währung: zusätzliche Stil-Eigenschaft je nach Datentyp

·Mehrfachauswahl: Möglichkeit, z. B. ein Dokument mehreren Projekten zuzuordnen

·Liste automatisch erweitern

·Globale Liste für alle Datenbanken

·Format für erweiterte Listen (Kontakte, Makros und Dateilisten)

·Eintrag im Menü Start | Suchen | Weitere.
Markieren Sie diese Option auch, wenn das Feld in der Kontaktvorschau gezeigt werden soll.

·Eingabe erforderlich: das Attribut darf nicht leer sein

·Eindeutiger Wert: Daten sollen in der Datenbank bzw. im Buchungsjahr nur einmal vorkommen

·Änderungen protokollieren: Datenänderungen sind nachvollziehbar

Seite "Eigenschaften"

·Feldname: programminterner Name des Datenbankfeldes

·Datentyp: Felder für Zeichen, Zahlen, Datum u. a.

·Feldgröße: maximale Zeichenanzahl für den Datentyp Zeichenkette ein

·Kommentar: beliebige Hinweise

Seite "Feldwerte"

·Attribut-Vorgabewerte nur für neue

·oder für neue und bestehende Datensätze.

·Schreibweise: Texte in Groß- oder Kleinbuchstaben speichern

Siehe auch Vorgabewerte für Dokumentattribute

Seite "Sicherheit"

·Feld ist sichtbar für: Datenfeld für unberechtigte Anwender verbergen

·Berechtigung zum Bearbeiten

Die Sicherheitseinstellungen können mit Strg-C kopiert und mit Strg-V eingefügt werden.

Klicken Sie anschließend auf Übernehmen, um das Feld zu speichern.

Tipp: Erstellen Sie eine Sicherungskopie der Archivdatenbank, bevor Sie die Felder ändern.

Für eine bessere Performance sollten Sie nur die Felder anlegen, die Sie auch verwenden. Geben Sie die Feldgröße nicht unnötig groß an.

Siehe auch

Beispiel "Datenfeld Gruppe"

Layoutdesigner

Auswahllisten bearbeiten

Dateiabhängige Dokumentattribute

Supportrecherche

Hinweise zur Enterprise-Version


Beispiel: Datenfeld Gruppe

Navigation: Datenbankoperationen >

Beispiel: Datenfeld Gruppe

Beispiel: Datenfeld "Gruppe"

Im Folgenden erfahren Sie am Beispiel des Attributs "Gruppe", wie ein neues Datenfeld erstellt und im Layout eingefügt wird.

1. Datenfeld "Gruppe" anlegen

Melden Sie sich bitte als Office Manager-Administrator an und wählen Sie anschließend im Menü Datei | Datenbank | Anpassen den Befehl Felder definieren.

Klicken Sie auf den Schalter Neu und geben die gewünschten Daten ein:

Tipp: Nutzen Sie auch die Direkthilfe. Klicken Sie auf das Fragezeichen rechts im Fenstertitel und anschließend auf die Komponente, zu der Sie weitere Informationen benötigen.

Die Seite Eigenschaften

enthält alle datenbankinternen Parameter des neuen Feldes:

Feldname: Name des Datenbankfeldes

Datentyp: Felder für Zeichen, Zahlen, Datum u. a.

Feldgröße: maximale Zeichenanzahl

Für das Feld "gruppe" verwenden wir den Datentyp Zeichenkette mit einer Länge von 30 Zeichen.

Dokumentenattribute: Eigenschaften

Auf der Seite Ansicht

werden die Parameter für die Benutzeroberfläche eingegeben:

Beschreibung: die auf der Programmoberfläche sichtbare Bezeichnung.

Eingabestil: die Art, wie Daten erfasst werden. Wählen Sie beispielsweise "Eingabefeld mit Liste" oder "Nur Auswahl aus Liste".

Mehrfachauswahl erlaubt die Zuordnung eines Dokumentes zu mehreren Gruppen. Dies ist nur beim Eingabestil "Nur Auswahl aus strukturierter Liste" möglich.

Liste automatisch erweitern: Neue Einträge (hier Gruppen) werden der Auswahlliste automatisch hinzugefügt, wenn sie im Editor eingetippt wurden.

Globale Liste für alle Datenbanken: wenn markiert, verwenden alle Dokumentenarchive dieselbe Auswahlliste (in diesem Fall dieselbe Gruppenliste).

Format: Filter für Kontakt-Eingabestil, Dateiliste oder Makro.

Eintrag im Menü "Suchen | Weitere": das Datenfeld wird im Startmenü eingetragen.

Eingabe erforderlich: markieren Sie diese Option, wenn Sie verhindern möchten, dass Dokumente ohne Gruppenzuordnung erstellt werden.

Dokumentenattribute: Ansicht

Die Registerseiten Feldwerte und Sicherheit sind für dieses Beispiel nicht relevant. Unter "Sicherheit" können Sie festlegen, wer dieses Datenfeld sehen und bearbeiten darf.

Klicken Sie bitte auf Übernehmen, um das Feld zu speichern und schließen Sie das Fenster.

2. Gruppenliste erstellen

Um die Auswahlliste mit Daten zu füllen, also die Gruppen einzugeben, verwenden Sie bitte die Funktion Auswahllisten:

In der linke Liste markieren Sie bitte den Eintrag "Dokument | Gruppe". Auf der rechten Seiten finden Sie dann die Liste der Gruppen. Klicken Sie bitte auf den Schalter Neu, um eine Gruppe einzugeben.

Falls Sie eine Textdatei mit den Gruppen besitzen, können Sie diese auch direkt einlesen: Klicken Sie dazu bitte mit der rechten Maustaste in die rechte Liste und wählen Sie im lokalen Menü den Befehl Laden oder Einfügen. In der Textdatei muss jede Gruppe in einer eigenen Zeile stehen.

Klicken Sie anschließend auf OK, um die Änderungen zu speichern.

3. Dokumenttabelle anpassen

Neue Felder werden in der Dokumenttabelle als Spalte am rechten Rand eingefügt. Sie können die Tabelle mit der Bildlaufleiste verschieben, um die Spalte sichtbar zu machen. Wichtige Attribute (wie z. B. "Gruppe") sollten aber auf der ersten Tabellenseite sichtbar sein.

Klicken Sie mit der linken Maustaste auf den Tabellenkopf (z. B. Gruppe), halten Sie die Maustaste fest und schieben Sie die Spalte an die gewünschte Position:

Spalte in Archivtabelle verschieben

Oder schneller: Klicken Sie mit der rechten Maustaste auf die Spaltenüberschrift, wählen Sie Spalte verschieben und geben Sie die gewünschte Position ein.

4. Layout-Designer

Sie können die Programmoberfläche Ihren individuellen Wünschen anpassen. Wählen Sie dazu im Menü Ansicht | Anpassen | Layout entwerfen den Eintrag des Layouts, welches Sie bearbeiten möchten. Der Layout-Designer wird geöffnet. Sie können die bestehenden Komponenten mit der Maus verschieben, in Ihrer Größe ändern oder löschen, sowie neue Komponenten hinzufügen.

Für unser Beispiel klicken Sie bitte auf Ansicht | Anpassen | Layout entwerfen | Dokument-Eigenschaften (Weitere). Der Eigenschaftendialog wird im Layoutdesigner geöffnet:

Datenbankfelder hinzufügen

Klicken Sie auf die Schaltfläche Feldbeschriftung hinzufügen Feldbeschriftung und platzieren Sie das Textfeld im Eigenschaftendialog. Wählen Sie das Datenbankfeld "gruppe" aus der Liste Datenfeld.

Klicken Sie auf die Schaltfläche Datenfeld hinzufügen Datenfeld und platzieren Sie das Feld rechts neben dem zuvor eingefügten Textfeld. Wählen Sie das Datenbankfeld "Gruppe" aus der Liste Datenfeld.

Sie können die Elemente jetzt noch mit der Maus verschieben und in der Größe ändern.

Klicken Sie anschließend im Fenster "Layout" bitte auf OK, um die Änderungen zu speichern.


Eigenschaften

Navigation: Datenbankoperationen >

Eigenschaften

Verfügbar in diesen Editionen

Datenbank | Eigenschaften

Einstellungen und Verbindungsparameter der geöffneten Datenbanken bearbeiten.

Wählen Sie bitte den Menübefehl Datei | Datenbank | Anpassen | Eigenschaften:

Gehen Sie bei Änderungen der Verbindungsparameter sorgfältig vor. Dieser Menüpunkt sollte für normale Anwender gesperrt werden.

Datei: Kompletter Dateiname der .omcs, .crmcs- oder .aplcs-Datei.
Tipp: In dieser Konfigurationsdatei können erweiterte Verbindungseinstellungen hinterlegt werden.

Treiber: Bezeichnung des Datenbanktreibers.

Verbindung: Parameter der Datenbankverbindung. Klicken Sie bitte auf [...], um die Verbindung anzupassen.

Login beim Öffnen: Manuelle Datenbankanmeldung. Beachten Sie bitte, dass diese z. B. beim MS SQL Server nur sinnvoll ist, wenn keine Windows-Authentifizierung verwendet wird.

Nachricht beim Öffnen: Optionale Benachrichtigung mit maximal 254 Zeichen, die beim jedem Öffnen der Datenbank eingeblendet wird.
Beispielsweise "Beachten Sie unsere Vorgaben für das Buchungsarchiv."
oder mit HTML-Link "Unsere Vorgaben für das Buchungsarchiv <a href="G:\Office Manager DMS\Dokumente\Intern\Vorgaben Buchungsarchiv.pdf">finden Sie hier</a>.".


Dateipfade ändern

Navigation: Datenbankoperationen >

Dateipfade ändern

Dateipfade ändern
Menü Datei | Datenbank | Anpassen | Dateipfade ändern

Die Funktion ermöglicht Ihnen die Anpassung des Dokumentenarchivs an neue Verzeichnisstrukturen. Die Dateinamen werden in der Datenbank aktualisiert, die Dokumentdateien können kopiert oder verschoben werden. Die Funktion ändert nur die Einträge der aktuellen Suche.

Wenn Sie alle Dokumente anpassen möchten, dann wählen Sie bitte zuvor den Befehl Start | Suchen | Felder leeren und Start | Suchen | Suchen, bevor Sie diese Funktion aufrufen.

Bestehender Pfadeintrag: Gibt das Verzeichnis an, welches geändert werden soll. Es werden alle Dokumente angepasst, deren Dateinamen mit diesem Pfad beginnen.

Ändern in: Gibt das neue Verzeichnis an.

Dateien kopieren: Legt fest, ob nur die Datenbank aktualisiert oder auch Dokumentdateien kopiert oder verschoben werden sollen.

Klicken Sie auf Starten, um die Änderungen durchzuführen.

Beispiele für den Einsatz dieser Funktion:

1.Die Dokumentdateien wurden bisher auf "G:\Daten\" abgelegt, durch eine Serverumstellung befinden sich die Dateien jetzt unter "\\Server1\Daten\Dokumente\": Geben Sie im Feld Bestehender Pfadeintrag "G:\Daten\" und in Ändern in "\\Server1\Daten\Dokumente\" ein. In der Auswahlliste Dateien kopieren wählen Sie "nicht kopieren" und klicken auf Starten. Die Dateinamen werden jetzt in der Datenbank aktualisiert. Falls eine Datei im neuen Pfad nicht vorhanden ist, dann wird der Datensatz nicht geändert.

2.Sie möchten alle lokal unter "C:\Eigene Dateien\" gespeicherten Dokumente in das Server-Verzeichnis "G:\Daten\" verschieben: Geben Sie im Feld Bestehender Pfadeintrag "C:\Eigene Dateien\" und bei Ändern in "G:\Daten\" ein. In der Auswahlliste Dateien kopieren wählen Sie "in das neue Verzeichnis verschieben" oder "in das neue Verzeichnis kopieren" und klicken auf Starten. Die Dateien werden jetzt nach "G:\Daten\" verschoben bzw. kopiert und die Datenbankeinträge aktualisiert. Die Datei "C:\Eigene Dateien\Projektname\Dokument.txt" befindet sich dann z. B. unter "G:\Daten\Projektname\Dokument.txt".

Sie müssen sich für diese Funktion als Office Manager-Administrator anmelden, wenn ein Passwort vergeben ist. Überprüfen Sie Ihre Eingaben sehr sorgfältig, die Funktion kann nicht rückgängig gemacht werden.


Datenbankpflege

Navigation: Datenbankoperationen >

Datenbankpflege

Datenbankpflege
Menü Datei | Datenbank | Pflege | Datenbankpflege

Mit der Datenbankpflege werden Access- und SQLite-Datenbanken komprimiert, die Datenintegrität sichergestellt sowie der Volltextindex und der Kontaktindex aktualisiert. Markieren Sie bitte die gewünschten Optionen und klicken Sie auf Starten.

Unabhängig von der aktuellen Suche werden alle Datensätze verarbeitet.

Klicken Sie im Bild auf die Komponenten, zu der Sie weitere Hilfe wünschen.

Datenbank komprimieren

Markieren Sie diese Option, um die geöffneten Datenbanken zu überprüfen und den nicht mehr genutzten Speicherplatz freizugeben. Diese Funktion sollte z. B. ausgeführt werden, nachdem viele Datensätze in der Dokumententabelle gelöscht wurden. Bei Firebird ist diese Funktion nur für defekte Datenbanken erforderlich.

Diese Option gilt nur für Datenbanken im MS Access- und SQLite-Format.

Daten-Integrität sicherstellen

Überprüft die Datenintegrität (Schlüsselnummern, verbundene Tabellen) und führt bei Bedarf erforderliche Korrekturen durch.

Bereinigt die Liste der bekannten Datenbanken, welche beispielsweise für die Spalte "Datenbank" in der Aufgabenverwaltung relevant ist.

Volltextindex und Dateiattribute aktualisieren

Synchronisiert die Archivdatenbank mit dem Dateninhalt und den Attributen.

Der Index wird bei Änderungen der Dokumente automatisch aktualisiert. Wenn Sie ein Dokument aber ohne Office Manager öffnen, werden eventuelle Änderungen nicht berücksichtigt.

Aktivieren Sie bitte bei der Datenbankpflege diese Option, um alle Dokumentdateien, die seit der letzten Indexierung geändert wurden, erneut einzulesen.

Index für Kontakterkennung

Neue Dokumente werden, sofern möglich und gewünscht, automatisch einem Kontakt zugeordnet. Beispielweise über die eindeutige E-Mail-Adresse, IBAN oder Kundennummer. Der Index mit den eindeutigen Phrasen wird automatisch gepflegt.

Markieren Sie diese Optionen, falls Sie den Index vollständig neu erstellen möchten.


Dubletten suchen

Navigation: Datenbankoperationen >

Dubletten suchen

Mehrfach vorhandene Datensätze aufspüren
Menü Datei | Datenbank | Pflege | Dubletten suchen

Wechseln Sie vor dem Aufruf der Funktion zur Ansicht der Dokumente oder Kontakte, um in der entsprechenden Datenbank zu suchen. Der Administrator kann diese Funktion nutzen, um Dubletten zu entfernen. Prüfen Sie aber genau, bevor Sie Daten löschen.

A. Dokumentdateien

Die Funktion sucht nach identischen Dokumentdateien (Dateien mit gleicher Checksumme). Ausgenommen sind Klone und Dokumente mit leerer Checksumme. Nach dem Durchlauf finden Sie die Dokumentdubletten im Suchergebnis.

Funktionsablauf

1.Die Datentabelle wird nach mehrfach vorhandenen Checksummen durchsucht.

2.Wenn diese vorhanden sind, wird zuerst geprüft, ob die Checksummen aktuell sind. Die Funktion wird mit einer entsprechenden Meldung abgebrochen, falls veraltete Daten vorliegen. Führen Sie dann bitte eine Aktualisierung der Dateiattribute durch.

3.Konnte die aktuelle Checksumme nicht ermittelt werden, weil die Dokumentdatei nicht (mehr) vorhanden ist, dann erhalten Sie eine entsprechende Meldung.

4.Mehrfach vorhandene Dokumente werden in der Datentabelle dargestellt. Sie werden gefragt, ob die Dokumente nach der Checksumme gruppiert werden sollen.

Siehe auch Hotline-Blog: SQL-Abfragen für die Suche nach Dubletten

B. Kontakte

Um auch bei unterschiedlichen Schreibweisen eine Dublette zu finden, sucht die Funktion nach ähnlichen Adressdaten. Kontakte werden als "mögliches Duplikat" betrachtet, wenn die Telefonnummer, E-Mail, Kombination aus Firma und Nachname, Firma und Postleitzahl oder Postleitzahl und Straße übereinstimmt.

Ein Gruppierung der Duplikate ist in der Tabelle nicht möglich. Sortieren Sie die Tabelle beispielsweise nach PLZ oder Firmenbezeichnung, um die möglichen Duplikate zu vergleichen.


Administration

Navigation: »Kein übergeordnetes Kapitel«

Administration

In diesem Kapitel:

Der Administrator

Programmeinstellungen

Gemeinsame Dateien

Dokumentenverzeichnis

Layout-Designer

Dokumenttypen

Übersicht Attribut-Vorgabewerte

Vorgabewerte beim Import

Benutzerverwaltung

Dateizugriffsrechte

Zugriffsrechte für Menübefehle

Konfigurationsdatei admin.ini

Weitere Systemdateien


Der Administrator

Navigation: Administration >

Der Administrator

Der Administrator

Wenn der Office Manager von mehreren Benutzern eingesetzt wird, sollten einige Programmfunktionen für den normalen Anwender gesperrt werden. Sonst besteht beispielsweise die Gefahr, dass ein Dokumenttyp versehentlich gelöscht wird und die zugeordneten Dokumente nicht mehr mit dem Office Manager geöffnet werden können. Es ist auch sinnvoll, das Einrichten immer von derselben Person durchführen zu lassen, dem Administrator, damit keine doppelten Dokumenttypen definiert werden und Auswahllisten nicht unnötig lang werden. Die gezielte und gute Einrichtung Ihres Office Manager bedeutet bei jeder Suche einen Zeitvorteil.

Mit dem Befehl Datei | Optionen | Administrator wird die Administratorebene aktiviert und das zusätzliche Menü Administrator geöffnet. Ein Zugangs-Passwort können Sie im Menü Datei | Optionen | Einstellungen auf der Registerkarte Sicherheit definieren. Sobald das Passwort vergeben ist, sind einige Programmfunktionen nur noch für den Administrator zugänglich: beispielsweise die Sicherheitseinstellungen und gefährliche SQL-Abfragen.

Wenn Sie den Office Manager im Netzwerk betreiben, kann es schwierig sein, alle Nutzer von administrativen Notwendigkeiten zu überzeugen. Um dem Administrator die Arbeit zu erleichtern, gibt es für ihn Möglichkeiten, bestimmte Programmfunktionen zu sperren (die Funktionen sind dann nur für ausgewählte Anwender oder nur in der Administratorebene sichtbar). Wählen Sie hierzu im Menü Datei | Optionen | Einstellungen die Seite Sicherheit | Befehle.

Erforderliche Einstellungen

1.Passwort vergeben: Menü Datei | Optionen | Einstellungen auf der Seite Sicherheit.

2.Dokumenttypen definieren: Mit den Dokumenttypen werden die verschiedenen Anwendungsprogramme im Office Manager registriert. Dokumenttypen sind z. B.: "Word Dokument", "AutoCAD-Zeichnung", "Excel Tabelle", "Bitmap" usw. Es können für jedes Anwendungsprogramm auch mehrere Dokumenttypen registriert werden (z. B. "Excel Tabelle" und "Excel Diagramm").
Wählen Sie dazu den Befehl Datei | Optionen | Dokumenttyp oder Assistent.

3.Berechtigungen im Verzeichnis der gemeinsamen Dateien festlegen.

4.Datenverzeichnis: Sie sollten ein Verzeichnis auf Ihrem PC bzw. auf dem Netzwerkserver anlegen, in dem die Dokumente gespeichert werden. Ein einheitliches Verzeichnis ist zwar nicht zwingend erforderlich, es verbessert aber die Datenstrukturen.

5.Projekte, Gruppen und Status-Eigenschaften: Ein großer Vorteil des Office Manager ist die Zuordnung beliebiger Dokumente zu einem gemeinsamen Projekt. Wenn der Anwender später in der Suche ein Projekt wählt, werden alle Briefe, Zeichnungen usw. zu diesem Projekt angezeigt. Sie sollten schon jetzt einige aktuelle Projekte und Gruppen definieren.
Wählen Sie dazu Datei | Optionen | Auswahllisten.

6.Felder definieren: Sie können das Archiv Ihren individuellen Anforderungen anpassen.
Menübefehl Datei | Datenbank | Anpassen | Felder definieren.

7.Verschiedene Programmeinstellungen: Menü Datei | Optionen | Einstellungen.

8.Datenzugriff von mobilen Endgeräten konfigurieren, wenn Sie von unterwegs auf Ihre heimischen Dokumente zugreifen möchten.

Siehe auch

Einstellungen

Konfigurationsdatei admin.ini

Dokumenttypen

Benutzerverwaltung

Struktur der Dokumentendatenbank

Datenbankoperationen


Programmeinstellungen

Navigation: Administration >

Programmeinstellungen

Programmeinstellungen

Menü Datei | Optionen | Einstellungen.

Klicken Sie im Bild auf die Komponenten, zu der Sie weitere Hilfe wünschen.

Auf der linken Seite befindet sich die Liste der Kategorien. Markieren Sie eine Kategorie, um die entsprechenden Einstellungen vornehmen zu können.

Unterhalb der Liste können Sie auch einen Suchbegriff eingeben, um eine Option zu finden.

Tipp: Nutzen Sie auch die Direkthilfe. Klicken Sie auf das Fragezeichen rechts im Fenstertitel und anschließend auf die Komponente, zu der Sie weitere Informationen benötigen.

Options-Kategorien

·Ansicht: Optionen der Benutzeroberfläche.

·Optimieren der Zugriffsgeschwindigkeit.

·Datenbank: Wichtige Verzeichnisse und Standarddatenbanken.

·Dokument: Ablagepfad, Einstellung für Dateinamen und Dokumentennummer.

·Archivieren: Dateiname und Ablagepfad für archivierte (alte) Dokumente, s. a. Menü Bearbeiten | Dokument | Archivieren.

·Volltextindex: Optionen für den Volltextretrieval, der Ihnen neben der Suche in den einzelnen Attributen auch eine sehr schnelle Abfrage über den Volltextindex ermöglicht. Einstellung der OCR-Software für gescannte Dokumente.

·Scannen: Dokumentenscanner mit oder ohne TWAIN-Schnittstelle.

·Importieren: Grundeinstellungen für die verschiedenen Importfunktionen.

·Künstliche Intelligenz: Aktivierung und Einstellung der GPT-Funktionen.

·Terminplaner: Anpassungen der Aufgabenverwaltung und des Kalenders.

·Sicherheit: Zugriffsberechtigungen auf Programmfunktionen und Dokumentdateien.

·Verknüpfungen: Archive mit dem Office Manager verknüpfen und Autostart-Optionen.

·Lizenz: Office Manager-Freischaltung.

Gültigkeit der verschiedenen Einstellungen

Das Programm unterscheidet zwischen benutzerspezifischen, lokalen und globalen Einstellungen.


Gemeinsame Dateien

Navigation: Administration >

Gemeinsame Dateien

Gemeinsam genutzte Dateien
Menü Datei | Optionen | Einstellungen, Seite Datenbank

Das Verzeichnis für gemeinsam genutzte Dateien beinhaltet die Archive, Anwendungsdatenbanken, Programmeinstellungen, globale Auswahllisten und weitere Dateien:

Dateien:

admin.ini: globale Konfigurationsdatei,

(Feldname).itm: globale Auswahllisten für Datenbankfelder,

logs\error.log: globale Fehler-Logdatei,

sql\menu\*.*: benutzerdefinierte Menüeinträge (SQL-Abfragen),

macro\menu\*.*: benutzerdefinierte Menüeinträge (Makros),

archive\*.*: Dokumentenarchive sowie Kontakt- und Anwendungsdatenbanken,

layouts\*.*: Layoutdateien,

template\*.*: Dateivorlagen.

user\(Name.Domäne)\*.*: benutzerspezifische Einstellungen.

Eine ausführliche Beschreibung der Verzeichnisse und Dateien finden Sie auf unseren Supportseiten.

Verzeichnis ermitteln:

Bei einer Einzelplatzinstallation ist das Verzeichnis "C:\Office Manager DMS\Gemeinsame Dateien\" empfohlen. Bei Netzwerkinstallationen verwenden alle Arbeitsplätze ein gemeinsames Verzeichnis auf dem Dateiserver. Sie sollten das Verzeichnis bereits bei der Installation angeben. Stellen Sie bitte sicher, dass alle Anwender Lese- und Schreibrechte in diesem Verzeichnis haben (s. a. Fehlermeldung). Falls Sie die Einstellung später ändern möchten, dann beachten Sie bitte diesen Supportartikel.

Um zu ermitteln, welches Verzeichnis auf Ihrem Rechner eingestellt ist, klicken Sie bitte auf Datei | Information. Auf der Seite Allgemein finden Sie die Einstellung "Gemeinsame Dateien":

Berechtigungen im Verzeichnis "Gemeinsame Dateien"

Im Verzeichnis der gemeinsamen Dateien müssen alle Anwender Lese- und Schreibrechte besitzen:

1.Melden Sie sich unter Windows bitte als Administrator an. Wenden Sie sich ggf. an Ihren Administrator.

2.Ermitteln Sie das verwendete Verzeichnis.

3.Falls Sie den Office Manager in einer Netzwerkumgebung mit mehreren Arbeitsplätzen einsetzen: Stellen Sie bitte sicher, dass alle Arbeitsplätze das gleiche Verzeichnis auf einem Dateiserver verwenden (s. a. Internet-FAQ: Netzwerkinstallation).

4.Starten Sie den Windows-Explorer und klicken Sie mit der rechten Maustaste auf das Verzeichnis. Wählen Sie im lokalen Menü den Befehl Eigenschaften und wechseln Sie auf die Seite Sicherheit:

Dateieigenschaften - Sicherheit

5.Erweitern Sie z. B. die Berechtigungen der Gruppe "Benutzer" oder "Jeder" auf "Vollzugriff". Oder fügen Sie alle Benutzernamen der Office Manager-Anwender mit "Vollzugriff" ein.

6.Klicken Sie bitte auf den Schalter Erweitert und aktivieren Sie die Option
Berechtigungen für alle untergeordneten Objekte ... ersetzen

7.Klicken Sie in beiden Fenstern auf OK, um die Änderungen durchzuführen.

Um die Sicherheit des System im Netzwerkbetrieb zu erhöhen, sollten Sie die Sicherheitseinstellungen der Datei admin.ini ändern: Alle Anwender, welche die Programmeinstellungen ändern dürfen, benötigen Lese- und Schreibrechte. Andere Anwender benötigen nur Leserechte.

Siehe auch

Administration

Menü Gemeinsame Dateien öffnen im Administrator-Untermenü.

UNC-Pfad oder Laufwerksbuchstabe

Beschreibung der Office Manager-Systemdateien


Dokumentenverzeichnis

Navigation: Administration >

Dokumentenverzeichnis

Dokumentenverzeichnis

Menü Datei | Optionen | Einstellungen, Seite Dokument

Standardverzeichnis für Dokumentdateien. Geben Sie das Datenträgerverzeichnis ein, in welchem der Office Manager neue Dokumente speichern soll. Sinnvoll ist ein Verzeichnis, das regelmäßig gesichert wird, wie z. B. "\\Server\Freigabe\Office Manager DMS\Dokumente\" auf einem Netzwerkserver.

Unterverzeichnisse für Projekte erstellen

Sie können Makro-Variablen verwenden, um die Dokumente in einer projektabhängigen Struktur zu speichern, z. B.: "\\Server\Freigabe\Office Manager DMS\Dokumente\{Self:DocDB,Name}\{Doc:Project}\". Markieren Sie bitte die Option Unterverzeichnisse für Projekte erstellen, um die empfohlene Dateistruktur zu erzeugen. Falls die Option nicht möglich ist, dann müssen Sie zuvor alle anderen Makrovariablen entfernen.

Hinweise

In den Importprofilen wird festgelegt, ob importierte Dokumente in dieses Verzeichnis verschoben bzw. kopiert werden. In der Grundeinstellung werden Dokumentkopien archiviert, die ursprüngliche Datei bleibt erhalten. Um dies zu ändern, öffnen Sie in den Einstellungen bitte die Seite Importieren | Profile, doppelklicken Sie auf [Standard] und ändern Sie die Dateioperation.

Wenn Sie die Verzeichnisüberwachung aktiviert haben, darf das Dokumentenverzeichnis nicht dem überwachten Verzeichnis entsprechen.

Nachträgliche Änderung des Verzeichnisses

Die Einstellung gilt nur für neue Dokumente. Um die Verzeichnisse/Dateinamen bestehender Dokumente zu ändern, wählen Sie bitte im Menü Datei | Datenbank | Anpassen den Befehl Dateipfade ändern. Beachten Sie bitte auch die Option Vorgabe gilt auch für bestehende Dateien.

Individuelle Einstellungen je Archiv

Die Einstellungen auf der Seite Allgemein gelten für alle Dokumentenarchive. In der Enterprise-Edition können Sie unten auch auf die Registerseite mit dem Archivnamen wechseln, um Einstellungen nur für das geöffnete Archiv anzupassen.

Siehe auch

UNC-Pfad oder Laufwerksbuchstabe

Unterschiedliche Dokumentenverzeichnisse mit Makrovariablen definieren


Layout-Designer

Navigation: Administration >

Layout-Designer

Layout-Designer

Sie können die Programmoberfläche Ihren individuellen Wünschen anpassen. Wählen Sie dazu im Menü Ansicht | Anpassen | Layout entwerfen den Eintrag des Layouts, welches Sie bearbeiten möchten. Der Layout-Designer wird geöffnet. Sie können die bestehenden Elemente (Eingabefelder u. a.) mit der Maus verschieben, in Ihrer Größe ändern oder löschen.

Änderungen wirken sich für alle Anwender aus. Im Netzwerkbetrieb sollte diese Funktion nur vom Administrator bzw. dem zuständigen Mitarbeiter durchgeführt werden.

Falls Sie mehrere Monitore mit unterschiedlicher Skalierung verwenden, dann führen Sie den Designer bitte nur auf dem Monitor aus, auf dem das Formular erstmalig nach dem Programmstart geöffnet wurde. Starten Sie das Programm im Zweifel neu und rufen Sie anschließend den Designer auf.

Klicken Sie im Bild auf die Komponenten, zu der Sie weitere Hilfe wünschen.

Ein Datenbankfeld hinzufügen

1.Klicken Sie bitte auf die Schaltfläche Datenfeld hinzufügen Datenfeld und platzieren Sie das Feld mit der Maus auf der Programmoberfläche.

2.Wählen Sie das Datenbankfeld aus der Liste Datenfeld.

3.Klicken Sie auf die Schaltfläche Feldbeschriftung hinzufügen Feldbeschriftung und platzieren Sie den Text auf der Programmoberfläche.

4.Wählen Sie das Datenbankfeld aus der Liste Datenfeld.

5.Sie können die Größe der Elemente jetzt mit der Maus anpassen.

6.Zum Verschieben mit der Maus anklicken, Maustaste festhalten und schieben (wie Drag and Drop). Oder anklicken und mit den Cursor-Tasten positionieren. Falls das Fenster des Designers den Eingabefokus hat, dann können Sie das im Layout markierte Element mit den Cursor-Tasten verschieben, indem Sie gleichzeitig die Strg-Taste festhalten.

7.Klicken Sie anschließend auf OK, um das Layout zu speichern.

Komponenten löschen

Markieren Sie das Element mit der Maus und klicken Sie anschließend auf die Schaltfläche Löschen x.

Fenstergröße im Layout speichern

Verändern Sie die Größe des Eigenschaftendialogs einfach mit der Maus. Um die Größe des oberen und unteren Fensterbereiches zu ändern, müssen Sie den Designer mit dem Menübefehl Eigenschaften | Hauptfenster öffnen.
Die Größe wird im Layout gespeichert und beim Öffnen des Archivs entsprechend gesetzt. Mit dem Befehl Optionen | Fenstergröße zurücksetzen kann die Standardgröße wieder hergestellt werden.

Weitere Layoutkomponenten

A fügt eine Beschriftung mit beliebigem Text ein;

Bevel Linien und Boxen für die Layoutgestaltung;

Bild Hintergrundgrafik aus einer Datei laden;

Computermaus fügt eine Mausschaltfläche für den Aufruf eines Makros hinzu.

Speichern der Menü- und Tabellen-Einstellung im Layout

Das Hauptmenü und die Dokumenttabelle können vom Anwender an seine individuellen Wünsche angepasst werden. In manchen Fällen ist es aber auch sinnvoll, diese Einstellungen in der Layoutdatei zu speichern. Beim Öffnen des Archivs werden dann die Menüs und die Tabelle entsprechend angepasst.

Diese Option gilt für alle Anwender im Netzwerk: ein Grund mehr, die Layoutgestaltung nur dem Administrator zu erlauben.

Um die Tabelleneinstellungen im Layout zu hinterlegen, aktivieren Sie bitte den Speichermodus "Global für alle Benutzer".

In der Enterprise-Version können Sie auch das Hauptmenü hinterlegen: Passen Sie es zuerst an, öffnen Sie dann den Layoutdesigner und klicken Sie auf Optionen | Hauptmenü im Layout speichern.

Siehe auch

Layout wählen

Bereiche positionieren

Layoutdesigner-Optionen

Beispiel "Datenfeld Gruppe"

Erweiterte Datumssuche

Makro-Funktion SetControl

Mausschaltfläche im Layout


Dokumenttypen

Navigation: Administration >

Dokumenttypen

Anwendungsprogramme im DMS

Der Office Manager verwaltet Informationen und Einstellungen zu den verschiedenen Windows-Programmen in seiner Anwendungsdatenbank. Dies ermöglicht die individuelle Steuerung der Programme, benutzerdefinierte Funktionen und beispielsweise die erweiterte Zeichnungsverwaltung.

Beim ersten Programmstart richtet der Assistent bereits die wichtigsten Windowsanwendungen ein. Fehlende Anwendungen werden, sofern möglich, bei Bedarf automatisch registriert.

Neue Anwendung registrieren

Dateitypen, die im Windows-System bekannt sind, können Sie sehr einfach definieren:

·Schieben Sie dazu eine entsprechende Datei per Drag&Drop in die Dokumententabelle. Wenn noch keine passende Anwendung definiert ist, dann wird diese nach Rückfrage registriert.

·Oder wählen Sie im Fenster "Registrierte Dokumenttypen" (siehe unten) den Befehl Neu für Dateiendung.

Falls für die Automatismen keine ausreichenden Informationen vorhanden sind, dann können Sie diese manuell eintragen. Beachten Sie dafür die Beschreibungen auf dieser Hilfeseite sowie den Supportartikel Exotischen Dokumenttyp registrieren.

Das Fenster "Registrierte Dokumenttypen"

Sie können weitere Programme definieren oder bestehende bearbeiten und beispielsweise zusätzliche Funktionen erstellen. Wählen Sie dazu bitte die Funktion Datei | Optionen | Dokumenttyp:

Screenshot Registrierte Dokumenttypen

In der linken Tabelle finden Sie die Liste aller registrierten Anwendungen. Um einen neuen Dokumenttypen zu erstellen, wählen Sie im Menü Start den Schalter Neu. Klicken Sie auf:

·Neuer Dokumenttyp, um manuell einen neuen Eintrag zu erstellen;

·Neu für Dateiendung, um den Dokumententyp für die vorgegebene Dateierweiterung automatisch zu erstellen.

·Assistent, um neue Standardanwendungen automatisch einzurichten;

·E-Mail einrichten für einen allgemeinen E-Mail-Dokumenttypen;

·AutoCAD einrichten, um einen Assistenten für die Einrichtung der erweiterten AutoCAD-Unterstützung aufzurufen.

·Inventor einrichten für Autodesk Inventor (s. a. Detail-Dokumente).

·MegaCAD einrichten für die erweiterten MegaCAD-Funktionen.

Beschreibung der Optionen

Tipp: Nutzen Sie auch die Direkthilfe. Klicken Sie auf das Fragezeichen rechts im Fenstertitel und anschließend auf die Komponente, zu der Sie weitere Informationen benötigen.

1. Seite "Allgemein"

·Beschreibung des Dokumenttypen, wie z. B. "Word-Dokument", "Excel-Tabelle", "AutoCAD-Zeichnung", "XRechung", "Foto", "Fax". Wählen Sie bitte Umbenennen a , um die Bezeichnung zu ändern.

·Grafik: Die Dokumente können in der Tabelle anhand ihrer Grafiken schneller gefunden werden, wählen Sie bitte eine passende Grafik aus. "Standard-Dateisymbol" und "Programmsymbol" sind erst möglich, nachdem auf Seite Datei der Dateityp angegeben wurde.

·Typ: Für "normale" Dokumente, die mit anderen Anwendungen erstellt werden, wählen Sie die Option Standarddokument in externer Datei.
Für die spezielle Internetfunktion markieren Sie bitte Internetadresse. Es werden dann keine Dokumentdateien sondern Internetadressen verwaltet.
Der Typ E-Mail ermöglicht Ihnen die Verwaltung von E-Mails aus Outlook, Mozilla Thunderbird, IBM Notes (eh. Lotus Notes) und anderen Mailprogrammen. Die E-Mails können sehr einfach per Drag&Drop vom Mailprogramm übernommen werden.
Für einfache Textdokumente (z. B. Notizen) markieren Sie bitte die Option Office Manager-Textverarbeitung. Es werden dann keine externen Dokumentdateien verwaltet, die Texte werden direkt in der Archivdatenbank gespeichert.

2. Seite "Datei"

·Dateityp: Primäre Erweiterung der Dokumentdateien, wie z. B.: "txt", "docx", "prt", "xml".

·Weitere: Liste mit weiteren Dateitypen, die mit dieser Anwendung geöffnet werden können.

·Standardvorlage: Eine Datei, die als Vorlage für neue Dokumente verwendet wird. Diese Standardvorlage ist in der Regel ein leeres Dokument. Viele Windowsanwendungen benötigen immer eine Vorlagendatei, wenn ein neues Dokument erzeugt wird. Beachten Sie bitte, dass eine Vorlage im selben Format wie die Dokumente erforderlich ist. Bei Word also keine .dotx, sondern eine .docx-Datei.

·Vorlagendateien: Eine Liste mit weiteren Vorlagendateien. Definieren Sie z. B. für die Textverarbeitung verschiedene Vorlagen für Briefe, Angebote, Notizen usw. Siehe auch Dokumentvorlagen.

3. Seite "Befehle"

Enthält die Liste aller Befehle, die der Office Manager mit den Dokumenten ausführen kann. Sie können neben den Standardbefehlen "Neu", "Öffnen" und "Drucken" beliebige weitere Befehle erstellen und viele Arbeitsabläufe automatisieren.

Siehe auch

Benutzerdefinierte Steuerung

4. Seite "Vorschau"

Auswahl einer Vorschau für die Dokumente.

5. Seite "Sicherheit"

Verfügbar in diesen Editionen

In der Enterprise-Edition können Sie die Zugriffsrechte für jede einzelne Dokumentdatei festlegen. Die Rechte werden auf Ebene des Betriebssystems zugewiesen und bieten somit die höchste Sicherheit. Unberechtigte Anwender können auch nicht unter Umgehung des Office Managers, also beispielsweise mit dem Windows-Explorer, auf die Dateien zugreifen.

Hier wird die Vorgabe für neue Dokumente diesen Typs festgelegt. Neue Dokumente erhalten die hier eingestellte Sicherheitsrichtlinie als Vorgabewert.

Sofern die Option Berechtigte Benutzer dürfen Richtlinie ändern markiert ist, kann die Sicherheitseinstellung der einzelnen Dokumente angepasst werden (s. a. Eigenschaftendialog). Wenn die Option nicht markiert ist, werden auch eventuelle Vorgabewerte der Importeinstellungen ignoriert.


Übersicht Attribut-Vorgabewerte

Navigation: Administration >

Übersicht Attribut-Vorgabewerte

Vorlagen für Dokumentattribute

Für die Dokumentattribute können unterschiedliche Vorgabewerte definiert werden. Das Programm unterscheidet hierbei zwischen neuen und geänderten Dokumenten, zwischen Importfunktionen, dem Scannen und den Dokumentvorlagen.

·Allgemein gültige Vorgabewerte für Dokumente und Kontakte können Sie im Fenster Felder definieren eingeben.

·Vorgaben für Dokumente, die mit Hilfe der Vorlagen erstellt werden, geben Sie bei der Definition von Dokumentvorlagen ein.

·Für das Scanner von Papiervorlagen und den Import digitaler Dateien können Scan- und Importprofile mit automatisierter Belegerkennung durch hinterlegte Schlagwörter, Künstliche IntelligenzI und E-Rechnung, festgelegt werden.

Verwendung

In Office Manager DMS werden die unterschiedlichen Vorgaben folgendermaßen angewandt:

A. Neues Dokument erstellen

1.Sie wählen den Befehl Erstellen | Neu | Dokument.

2.Wenn die Tabelle gruppiert oder ein Projekt im Navigator markiert ist, werden die Attribute als Vorgabewert übernommen.

3.Im Eigenschaftendialog geben Sie die gewünschten Attribute, wie Name und Projekt ein.

4.Nach einem Klick auf OK werden die allgemein gültigen Vorgaben in alle noch leeren Attribute kopiert.

B. Neues Dokument von Vorlage erstellen

1.Sie wählen im Menü Erstellen | Vorlagen einen Eintrag in der Liste Dokument erstellen.

2.Wenn die Tabelle gruppiert oder ein Projekt im Navigator markiert ist, werden die Attribute als Vorgabewert übernommen.

3.Die Attribute der Dokumentenvorlage werden übernommen.

4.Im Eigenschaftendialog geben Sie jetzt weitere Attribute, wie beispielsweise den Namen ein und klicken auf OK.

5.Sofern vorhanden, kopiert das Programm nun die allgemein gültigen Vorgaben in alle noch leeren Attribute.

C. Dokumentdatei importieren

1.Beim manuellen Import, beispielsweise Drag&Drop oder Bearbeiten | Einfügen, werden die Dokumentattribute aus der Gruppierung und dem Projektnavigator übernommen.

2.Die Ergebnisse der Belegerkennung des Importprofils werden kopiert, sofern das jeweilige Attribut nicht durch die Gruppierung festgelegt wurde.

3.Im Eigenschaftendialog geben Sie jetzt weitere Attribute, wie beispielsweise den Namen ein und klicken auf OK.

4.Das Programm kopiert nun die allgemein gültigen Vorgaben in alle noch leeren Attribute.

Siehe auch

Künstliche Intelligenz

Belegerkennung skripten


Belegerkennung

Navigation: Administration >

Belegerkennung

Dokumente automatisch klassifizieren

Im professionellen Dokumenten-Management-System beschreiben Sie die einzelnen Dokumente mit verschiedensten Eigenschaften (Datenfeldern): Ein Beleg hat beispielsweise die Kategorie "Eingangsrechnung", ein Belegdatum und die Zuordnung zum Lieferanten. Welche Eigenschaften dies sind, entscheiden Sie selbst. Je mehr Eigenschaften Sie nutzen, desto gezielter können Sie die Archive durchsuchen, haben aber auch mehr Aufwand beim Einpflegen. Konfigurieren Sie die automatisierte Dokumentenerkennung, um diesen Aufwand zu minimieren.

Beim Import und Scan neuer Dokumente

Sie können verschiedene Profile für die Import- und Scanfunktionen hinterlegen. Diese ermöglichen u. a. die automatisierte Erkennung der Dokumenteigenschaften, wie Name, Belegdatum und Kategorie abhängig vom Quelldokument.

Öffnen Sie ein Import- oder Scanprofil und wechseln Sie zur Dialogseite Feldwerte:

Importprofil definieren: Feldwerte

Im oberen Bereich finden Sie das Kombinationsfeld Dokumentenerkennung. Wählen Sie dort die gewünschten Erkennungsalgorithmen:

Standard-Dokumentenerkennung

In allen Editionen verfügbar

Das Dokument wird nach einem Kontakt, dem Belegdatum und passenden Werten in den Auswahllisten durchsucht. Wenn die Projektliste Buchungsjahre enthält, wird das zum Datum gehörende Jahr gewählt, und wenn vorhanden, auch der Monat (z. B. "2017\03"). Bei E-Mails werden Standard-Mail-Attribute, wie Betreff und das Datum übernommen, bei Fotos das Aufnahmedatum.
Beachten Sie bei Scanprofilen bitte, dass die OCR-Texterkennung sofort nach dem Scan ausgeführt wird, wenn diese Dokumentenerkennung aktiviert ist. Siehe auch Blog-Artikel.

E-Rechnung

Verfügbar in diesen Editionen

Nur für XML-Dateien und native PDF-Dokumente, nicht für Scans. Wertet die XML-Daten für elektronische Rechnungen gemäß dem XRechnung- und ZUGFeRD-Standard aus. Belegdatum, Buchungsjahr, Belegnummer, Bezeichnung und Rechnungsbetrag werden automatisch übernommen. Weitere Daten können Sie mit Hilfe der Makrovariablen AutoCaptEInvoice den einzelnen Feldern zuweisen.

GPT - Generative Pre-trained Transformer (lokal oder Cloud)

Verfügbar in diesen Editionen

Dokumenten- und Bilderkennung mit Künstlicher Intelligenz. Die Antwort des GPT muss eigene Textzeilen für die gewünschten Datenfelder beinhalten: Feldname=erkannter Wert.

Azure Form Recognizer (Cloud)

Verfügbar in diesen Editionen

Formularerkennung durch Künstliche Intelligenz der Azure-Cloud. Belegdatum und Buchungsjahr werden automatisch übernommen. Weitere Daten können Sie mit Hilfe der Makrovariablen AutoCaptAzureAI den einzelnen Feldern zuweisen. Siehe auch Blog-Artikel

Individuell

In der Tabelle werden den einzelnen Datenfeldern individuelle Daten, Makro-Variablen oder feste Texte zugewiesen. Die linke Spalte beinhaltet die Datenfelder (Attribute) des geöffneten Archivs, die rechte die Feldwerte.

Sie können Makro-Variablen verwenden, um die Attribute aus der o. g. Dokumentenerkennung oder beispielsweise aus dem Dateipfad zu übernehmen. Die Auswahllisten in der Spalte Feldwerte beinhalten Beispiele für die Verwendung der Makro-Variablen.

Die individuellen Einstellungen haben eine höhere Priorität als die Standard-Dokumentenerkennung.

Beispiele

Feldname | Feldwert | Beschreibung
name | {Source:Name} | Der Dateiname ohne Endung
name | {OleSummaryInformation:Title,{Source}} | Das erweiterte Dateiattribut "Titel"
docno | {AutoCaptEInvoice:CrossIndustryDocument/HeaderExchangedDocument/ID} | Belegnummer aus ZUGFeRD-Rechnung
docno | { AutoCaptAzureAI :analyzeResult.documents[0].fields.InvoiceId.valueString} | Belegnummer aus Azure-Formularerkennung
name | {GetFirstNotEmpty:{OleSummaryInformation:Title,{Source}},{Source:Name}}
project | {Source:DirPart,2,4} | Die 2. bis 4. Verzeichnisebene
notes | Datei importiert | Fester Text "Datei importiert"

Siehe auch

Dokumentenerkennung für bereits archivierte Dokumente

Vorgabewerte für Dokumentattribute

Auswahllisten mit Belegerkennung

Makrofunktionen für Dokumentenerkennung


Benutzerverwaltung

Navigation: Administration >

Benutzerverwaltung

Benutzerverwaltung
Menü Datei | Optionen | Einstellungen, Seite Sicherheit | Benutzer

Office Manager DMS nutzt die Kontenverwaltung des Windows-Betriebssystems, ein manuelle Login in das Programm ist nicht erforderlich. Sollte der Windows-Benutzername nicht verfügbar ein, beispielsweise im abgesicherten Modus von Windows, ist nur eine manuelle Anmeldung als Administrator möglich

Die Benutzernamen werden für die Dokumentenverwaltung und Aufgabenplanung verwendet. Das Datensatzfeld "Besitzer" beinhaltet den Benutzernamen, mit welchem das Dokument dem Archiv hinzugefügt wurde. Im Protokoll werden alle Benutzer aufgeführt die mit dem Dokument gearbeitet haben. Wenn in der Suchmaske das Feld Private Suche markiert ist, werden nur die Dokumente angezeigt, die der aktuelle Benutzer angelegt hat.

In der Aufgabenverwaltung wird über diese Namen die Ressource festgelegt.

Sobald sich ein neuer Benutzer anmeldet, wird der Benutzername in der Anwendungsdatenbank gespeichert.

Die Verwendung des Windows-Benutzernamen hat einige Vorteile. Es wird vermieden, dass sich Anwendende mehrmals anmelden müssen: unter Windows selbst und dann noch beim Office Manager. Es ist sichergestellt, dass Anwendende denselben Namen unter Windows und im Dokumentenmanagement haben. Die Benutzer- und Gruppenverwaltung mit den Sicherheitseinstellungen kann zentral im Betriebssystem vorgenommen werden.

Siehe auch

Dateizugriffsrechte

Zugriffsrechte für Menübefehle


Dateizugriffsrechte

Navigation: Administration >

Dateizugriffsrechte

Verfügbar in diesen Editionen

Datei-Zugriffsrechte

Menü Datei | Optionen | Einstellungen, Seite Sicherheit | Dokumente

In der Office Manager Enterprise-Version können Sie die Zugriffsrechte für jede einzelne Dokumentdatei festlegen. Die Rechte werden auf Ebene des Betriebssystems zugewiesen und bieten somit die höchste Sicherheit. Unberechtigte Anwender können auch nicht unter Umgehung der Archivierungssoftware, also beispielsweise mit dem Windows-Explorer, auf die Dateien zugreifen.

Voraussetzungen für diese Sicherheitsrichtlinien:

·Speicherung der Dokumentdateien auf einem Windows-System. NAS-Festplatten sind häufig nicht kompatibel.

·Office Manager Enterprise-Edition.

Definieren Sie hier bitte die gewünschten Sicherheitsstufen, wie

·"Normal" oder "Alle" mit Vollzugriff für jeden Benutzer.

·"Office" mit Vollzugriff für die Benutzergruppe Office und Nur-Lesen für alle anderen.

·"Personal" mit Vollzugriff für die Personalabteilung und Geschäftsführung, aber keinerlei Rechte für andere Benutzer.

Im Eigenschaften-Dialog der Dokumente kann dann später für jedes einzelne Dokument eine vordefinierte Sicherheitsstufe ausgewählt werden.

Wichtig: Stellen Sie sicher, dass die eingesetzte Datensicherungslösung Leseberechtigungen für alle Dateien hat!

Siehe auch

Dokumenttypen, Seite Sicherheit.

Erweiterte Einstellungen

Zugriffsrechte für Menübefehle


Zugriffsrechte für Menübefehle

Navigation: Administration >

Zugriffsrechte für Menübefehle

Verfügbar in diesen Editionen

Geschützte Programmfunktionen

Menü Datei | Optionen | Einstellungen, Seite Sicherheit | Befehle

Wird das Dokumenten-Management-System im Netzwerk eingesetzt oder der Computer von mehreren Personen genutzt? Dann ist es sinnvoll, bestimmte Programmfunktionen für den normalen Benutzer zu sperren.

Zugriffsrechte für Programmfunktionen

Sie können zu jedem Menüeintrag die Zugriffsrechte definieren. Markieren Sie dazu bitte den gewünschten Menüeintrag in der Tabelle und klicken Sie auf die Schaltfläche Sichtbarkeit. Im Dialogfenster "Sichtbarkeit" können Sie festlegen, ob die Funktion für jeden oder nur für den Office Manager-Administrator sichtbar ist. In der Enterprise-Version ist es auch möglich, die Programmfunktion nur für ausgewählte Windows-Benutzer und -Gruppen zugänglich zu machen.

Der Baumknoten "(Grundfunktionen)" beinhaltet einige grundlegende Berechtigungen zu Funktionen, die keinem Menüpunkt zugeordnet sind. Sie können hier beispielsweise festlegen, dass die Attribute oder Dateien aller Dokumente nur von bestimmten Anwendern geändert werden dürfen. Siehe hierzu aber auch die Seite Sicherheit | Regeln, auf der Sie bestimmen können, ob die Anwender nur ihre eigenen Dokumente bearbeiten können.

Tipp: Sie können die Sichtbarkeit von einer anderen Funktion kopieren. Klicken Sie dazu mit der rechten Maustaste auf eine Funktion, wählen Sie Sichtbarkeit kopieren, klicken Sie mit der rechten Maustaste auf eine andere Funktion und wählen Sie Einfügen/Ersetzen.

Einschränkungen

Grundsätzlich können Sie alle Menübefehle sperren. Dies führt aber nicht immer zu einer Verhinderung der entsprechenden Programmfunktion. Beispielsweise wird ein Dokumentenarchiv vor dem Öffnen eines anderen geschlossen, auch wenn Datei | Schließen gesperrt ist. Sie können theoretisch auch Befehle zum Suchen sperren. Trotzdem würden Datenabfragen stattfinden, weil diese auch von anderen Funktionen ausgeführt werden.

Andererseits können einige systemkritische Funktionen nur vom Administrator ausgeführt werden, wenn ein Kennwort für die Admin-Anmeldung vergeben ist.

Sonderfälle

Beenden: Wenn der Befehl gesperrt ist, dann wird nicht nur der Menüeintrag ausgeblendet, sondern ein Schließen des Office Manager verhindert. Dies ersetzt die frühere Einstellung "AllowClose=0". In der Regel wird gleichzeitig die automatische Programmausführung beim Start von Windows aktiviert (Menü Datei | Optionen | Einstellungen, Seite Verknüpfungen).
Das Programm kann nur noch von berechtigten Anwendern, dem Updateprogramm und beim Beenden von Windows geschlossen werden.

Dokument | Löschen: Verhindert auch das Löschen von Dokumenten mit anderen Menübefehlen.

Optionen | Auswahllisten: Sperrt auch die Befehle zum Ändern von Projekten im lokalen Menü des Navigators und verhindert das Kopieren von Projekten.

Optionen | Datensätze in Speicher laden: Wenn gesperrt, dann ist die Option immer deaktiviert.

Ansicht | Menüband anpassen verhindert alle Menü-Änderungen durch den Anwender. Zurücksetzen ist aber möglich, wenn nicht zusätzlich gesperrt.

Suche | Volltextindex blendet auch das primäre Suchfeld Volltext aus.

Siehe auch

Menüband anpassen

Dateizugriffsrechte

Supportartikel: Welche Funktionen sollten gesperrt werden?

Supportartikel: DMS-Funktionen über Statusattribut sperren (Ein-/Auschecken)


Konfigurationsdatei admini.ini

Navigation: Administration >

Konfigurationsdatei admini.ini

Konfigurationsdatei admin.ini

Die INI-Datei "admin.ini" beinhaltet globale Programmeinstellungen. Änderungen nehmen Sie in der Regel nicht in der Datei selbst, sondern mit dem Menübefehl Datei | Optionen | Einstellungen vor.

Um die Systemsicherheit zu erhöhen, können Sie den Menübefehl für normale Anwender verbergen. Ändern Sie die Zugriffsberechtigungen der Datei admin.ini, so dass nur noch der Administrator Schreibrechte hat. Ausführliche Empfehlungen hierzu finden Sie auf den Supportseiten.

Zum Öffnen der INI-Datei melden Sie sich bitte als Administrator an (Datei | Optionen | Administrator) und wählen anschließend im Menü Administrator | Administrator | Erweiterte Einstellungen | INI-Datei öffnen.

Erweiterte Einstellungen

Folgende Einstellungen können direkt in der admin.ini vorgenommen werden. Sie sind für den normalen Betrieb des Programms nicht erforderlich, können aber in Ausnahmefällen hilfreich sein.

[Document]

DocVersFileName={Doc:FileName,NoExt}_Vers{DocVers:DocVers}.{Doc:FileName,FileExt}

FileNameAllowChar=;.

DeleteOrphanedFolder=1

DocTypeIgnoreDFEF=.Internet.AutoCAD.

UseSystemPopupMenu=1 ab 17.0 nicht mehr enthalten, "Systemmenü" verwenden

WarningExecuteCount=20

SendToMailAllowZIP=0

PrevCreateOle=1 ab Version 13.0 nicht mehr enthalten

PrevTryThumbnail=0 ab Version 13.0 nicht mehr enthalten

AcroPdfShowToolbar=1 ab 18.0 nicht mehrt enthalten

QuickPdfDpi=72

PdfPageMode=2

DocCombinDefLinkName={Doc:DOCNO}

OpenShellCommand=open

OpenNewDocuments=0

DeleteFileDefault=1

[Image]

JPegQuality=80

SkewDetectWidth=

SkewDetectAngle=

ConvBWMode=-2

[Database]

QuoteChar="

SysChar2WildeCard=1

SearchOperatorOR=<<OR>>

SearchExactChar=$

DefaultSearchMode=2

CommandTimeout=120

SysThreadInterval=60000

QuickSelectContactDB=1 (für Entwickler)

[Admin]

HttpProxy=123.123.123.123:80:User:Password

AllowClose=0 ab Version 11.0 nicht mehr möglich: "Beenden" sperren

[Optimize]

AutoSearchDelay=1000

DocUpdateEditDate=0 ab 10.0 nicht mehr möglich: EDITDATE löschen

[View]

LanguageIniFile=G:\Office Manager DMS\Gemeinsame Dateien\english.ini

PreviewColor=clBlack

[DocumentHighlight] wurde mit 22.0 entfernt

STATE=Erledigen

NAME=Porto

[FullTextIndex]

OleToTxt=0

OmftiPath=T:\OmFti\

DeleteOmftiFile=1

UpdateOnActivate=0

FileUpdateSpan=2 wurde mit 17.0 entfernt

UseSearchWords=1

CharsetAdd=+

IndexAttachments=0

TiffOcrTag=10

RtfMode=1000000

UseAutoInc=1

OcrTransymOpt=1

OcrCreateBackup=0

UseDebenuPDF=1

UseReservedIDs=1 wurde mit 14.0 entfernt

[Import]

BrowserDDE=ddeservice wurde mit 17.0 entfernt

IgnoreExt=.omp.tmp. wurde mit 22.0 entfernt

IgnoreOmExt=.lay.itm.

ShowDlgDirWatch=1

FindDuplicateByFileName=1

RegApplInAutoImp=1

DefaultAppl=Sonstige

SpeedUp=1

ConfirmDuplicate=1

[DirWatch]

AcceptorMachines=.rechner1.rechner2.

AllowCancel=0

MaxFileListCount=150

FileListEx=1

HandledEvents=.1.

FileListEx=1

[ImportFax]

AllowCancel=0

[ImportFaxDefaultFields]

Category=Faxeingang

[Secure]

DefineAccessRights=0

CompareAccessRights=1

AllowOwnerToUnlock=0

[ToDo] wurde mit 23.0 entfernt

TimerInterval=60000

TimerFirstInterval=10000

RemindSoundFile=C:\Windows\Media\sound.wav

[ScriptControl]

TimeOut=-1

UseSafeSubset=1

[Blockchain]

DMS.URL=http://192.168.0.123

DMS.User=DmsRpcUser

DMS.PasswordEn=xyz

DocFeeDocz=1000000

AutoStoreTaskOwner=MeinComputer

AutoStoreInclude=.Archiv.Buchhaltung.

AutoStoreExclude=.Archiv.Buchhaltung.

[MobileServer]

TodoLabelColor=8689404

DocGroupByField=category

[Macro_ReadAdminIni]

Variable=123


Datenbankverknüpfungsdateien

Navigation: Administration >

Datenbankverknüpfungsdateien

Verfügbar in diesen Editionen

Format der .omcs, .crmcs und .aplcs-Dateien

Die Verknüpfungsdateien sind als Konfigurationsdateien aufgebaut und enthalten Treiberinformationen zum Dokumentenarchiv (.omcs), der Kontakt (.crmcs)- oder Anwendungsdatenbank (.aplcs). Diese Dateien werden beim Anlegen neuer Datenbanken (Menü Datei | Datenbank | Neues Archiv) mit den entsprechenden Parametern erstellt. Wählen Sie bitte im Menü Datei | Datenbank den Befehl Eigenschaften, wenn Sie Änderungen an den Treiber-Einstellungen vornehmen möchten oder bearbeiten Sie die Datei für erweiterte Optionen mit einem Texteditor.

Beispiel einer Verknüpfungsdatei

[ConnectionParams]

DriverID=MSSQL

Server=Servername

Database=Datenbankname

OSAuthent=Yes

ApplicationName=Office Manager

MARS=Yes

[ConnectionOptions]

LoginPrompt=0

CommandTimeout=120

SetUpdateCriteria=2

LockMode=1

[Info]

Description=https://www.officemanager.de/handbuch/formatcsfile.html

OMClientVersion=14.0.0.500

Beispiel aus veraltetem Office Manager DMS 6.0 bis 13.0

Beim Update auf das neue Format bleibt die Sektion "AdoConnection" erhalten, sie wird aber nicht mehr verwendet.

[AdoConnection]

ConnectionString=Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=OmArchiveNew;Data Source=Mathilde

LoginPrompt=0

ConnectionTimeout=15

CommandTimeout=30

CursorLocation=1

SetUpdateCriteria=1

[Database]

Caption=Meine Datenbank

CursorType=3

LockType=1

CacheSize=10

DateFormat=yyyy"-"mm"-"dd hh:nn:ss

MySQL_sqlmode=NO_BACKSLASH_ESCAPES,STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION


Entwicklerhilfe

Navigation: »Kein übergeordnetes Kapitel«

Entwicklerhilfe

Der Office Manager bietet Ihnen eine umfangreiche Makrosprache, einen integrierten Pascal-Interpreter sowie in der 32 Bit-Version mittels Windows Script den Zugriff auf weitere Skriptsprachen, wie VBScript und JScript. Sie können das Programm mit diversen Programmiersprachen automatisieren.

Makros finden Verwendung bei der Steuerung von Anwendungsprogrammen, den benutzerdefinierten Menübefehlen, Import-Feldwerten und vielen Programmoptionen, wie beispielsweise dem Dokumentenverzeichnis.

In diesem Kapitel:

Makro-Editor

Menübefehle im Makro aufrufen

Aufruf aus Fremdprogrammen

Benutzerdefinierte Steuerung von Programmen

Ereignisgesteuerte Skripte

Mausschaltfläche im Layout

Formatparameter für Dateien

Formatparameter für Datum

Struktur der Archivdatenbank

Struktur der Kontaktdatenbank

Struktur der Anwendungsdatenbank

Makro-Referenz

Pascal-Referenz

COM-Referenz

Siehe auch

Office Manager Developer Network omdn.officemanager.de


Makro-Editor

Navigation: Entwicklerhilfe >

Makro-Editor

Skripteditor mit Syntaxhervorhebung und Funktionshilfen

Zum Öffnen des Editors wählen Sie bitte Start | Verwenden | Makro | Makro-Editor:

Editor für Makros und Skripte

Klicken Sie im Bild auf die Komponenten, zu der Sie weitere Hilfe wünschen.

Zum Bearbeiten eines vorhandenen Makros wählen Sie bitte im Menü Datei | Öffnen. Die Skriptsprache wird anhand der Dateiendung erkannt: VBScript prüfen Sie diese bitte.

Geben Sie Quelltext in den Editor ein. Sie können auch eine Funktion aus der rechten Liste übernehmen: bewegen Sie dazu den Cursor an die gewünschte Stelle im Editor und doppelklicken Sie auf eine Funktion in der Liste. Die markierte Funktion wird dann an der Cursorposition im Editor eingefügt.

Bei OmAPI und Pascal können mit einem Klick auf ? die Hilfeseite zur markierten Funktion öffnen.

Zum Testen des Skripts wählen Sie bitte den Befehl Start | Makro | Ausführen Run oder drücken Sie F9. Eventuelle Meldungen des Interpreters werden in der unteren Liste ausgegeben. OmAPI-Makros können Sie auch debuggen: Klick auf den Pfeil des Mausschalters Ausführen und Debuggen wählen oder Funktionstaste F8.

Positionsmarken

Sie können bis zu 10 Zeilen im Quelltext mit Positionsmarken markieren. Drücken Sie Strg+Umsch+0 bis 9, um in der aktuellen Zeile eine Marke zu setzen. Mit Strg+0 bis 9 können Sie dann zu dieser Zeile zurückspringen.

Verschlüsselte Makros

Eine verschlüsselte Makrodatei schützt vor Manipulationen, verhindert aber auch die Überprüfung des Quelltextes. Erstellen Sie dazu das Makro im Editor und speichern Sie es ab (z. B. Datei.omac). Wählen Sie anschließend den Befehl Datei | Speichern und Senden | Verschlüsselt speichern. Es wird eine gleichnamige Datei mit der Endung *.*en erstellt (z. B. Datei.omacen). Geben Sie diese verschlüsselte Datei weiter und heben Sie die Originaldatei auf, damit Sie weiterhin auf den Code zugreifen können. Die verschlüsselte Version kann nicht mehr entschlüsselt und bearbeitet werden!

Siehe auch

Referenz OmAPI

Referenz OmPascal

Ereignisgesteuertes Scripting


Aufruf aus Fremdprogrammen

Navigation: Entwicklerhilfe >

Aufruf aus Fremdprogrammen

Office Manager aus Fremdprogrammen steuern

Sie können von Fremdprogrammen aus auf die Office Manager-API zugreifen und Makro-Variablen oder -Funktionen ausführen. Senden Sie dazu bitte eine Windows-Botschaft an das Office Manager-Hauptfenster, nutzen Sie das Tool "SendToOM.exe" oder die COM-Automatisierung:

1. Eine Windows-Botschaft senden Sie mit der Windows API-Funktion SendMessage:

LRESULT SendMessage(

HWND hWnd, // Fensterhandle

UINT Msg, // zu sendende Nachricht

WPARAM wParam, // erste Parameter

LPARAM lParam // zweiter Parameter

);

Das Fensterhandle ermitteln Sie mit der Windows API-Funktion FindWindow('TFormOmMain', NULL).

Die zu sendende Nachricht Msg ist "WM_COPYDATA". Der erste Parameter ist NULL. Der zweite Parameter enthält die Office Manager Makrobefehle, beispielsweise "{ImportFile:C:\Import\Erste Datei.pdf}{ImportFile:C:\Import\Zweite Datei.pdf}".

2. Eine einfachere Möglichkeit ist die Verwendung des Hilfsprogramms SendToOM:

Starten Sie das Programm einfach mit den Makrobefehlen als Parameter. Beispielsweise ein Dokument öffnen:

C:\Programme\..\SendToOM.exe {OpenDocument:Archiv.omp,1137,1,0}

Eine Datei importieren:

C:\Programme\..\SendToOM.exe "{ImportFile:C:\Import\Erste Datei.pdf}{ImportFile:C:\Import\Zweite Datei.pdf}"

Die Makrofunktion ImportFile ist die primäre Funktion von SendToOM. Für den Dateiimport können Sie also auch einfach mehrere Dateien als Startparameter übergeben:

C:\Programme\..\SendToOM.exe "C:\Import\Erste Datei.pdf" "C:\Import\Zweite Datei.pdf"

Das Installationsverzeichnis können Sie über die Windows-Registrierungsdatenbank ermitteln: Wert "Path" im Registry-Pfad.

3. Office Manager COM-Server

Erzeugen Sie bitte das COM-Objekt "om.OfficeManagerApp" beispielsweise mit Visual Basic Script:

set omapp = CreateObject("om.OfficeManagerApp")

omapp.ImportFile("C:\Import\Erste Datei.pdf")

Siehe auch

Referenz der Variablen und Funktionen

Referenz des COM-Servers


Benutzerdefinierte Steuerung von Programmen

Navigation: Entwicklerhilfe >

Benutzerdefinierte Steuerung von Programmen

Benutzerdefinierte Steuerung von Anwendungsprogrammen

Wenn die vom Windows bereitgestellten Funktionen zur Bearbeitung der Dokumente an ihre Grenzen stoßen, dann können Sie eigene Befehle erstellen und Ihre Arbeit mit den Dokumenten automatisieren. Die Befehle werden für die jeweiligen Anwendungsprogramme hinterlegt, also beispielsweise eigene Funktionserweiterungen für PDF-Dokumente und andere für Word.

Eigene Befehle definieren

Wählen Sie bitte im Menü Datei | Optionen den Eintrag Dokumenttyp, markieren Sie den entsprechenden Dokumenttyp und wechseln Sie auf die Registerseite "Befehle".

Wählen Sie den gewünschten Befehl aus oder erstellen Sie einen neuen Befehl. Markieren Sie bitte die Option Benutzerdefinierte Steuerung der Anwendung und klicken Sie auf den Schalter Erweitert, um die Befehlsparameter zu definieren.

Befehlszeilen-Steuerung

Das Anwendungsprogramm wird mit den angegebenen Parametern gestartet. Markieren Sie Datei als Startparameter und/oder geben Sie weitere Startparameter an. Siehe auch Beispiel.

Makro-Steuerung

Der Befehl wird mit einem Skript ausgeführt. Geben Sie bitte die Variablen und Funktionen ein. Siehe auch: Beispiel Schriftkopf-Erzeugung für MegaCAD.

Das Kombinationsfeld Befehl automatisch ausführen, wenn folgendes Ereignis eintritt bleibt in der Regel leer. Mit diesen Ereignissen wird beispielsweise die dynamische CAD-Anbindung realisiert.

Eigene Befehle verwenden

Markieren Sie ein Dokument oder mehrere vom selben Dokumenttyp in der Tabelle. Die benutzerdefinierten Befehle finden Sie dann im Menü Start | Befehle und im lokalen Menü der Tabelle (rechte Maustaste auf das Dokument). Die Funktionen können nicht für Dokumente im Papierkorb ausgeführt werden.


Ereignisgesteuertes Scripting

Event Scripting - Ereignisgesteuerte Skripte

Navigation: Entwicklerhilfe >

Event Scripting - Ereignisgesteuerte Skripte

Verfügbar in diesen Editionen

Ereignisgesteuerte Skripte

Ereigisgesteuerte Skripte werden bei bestimmten Programm-Ereignissen automatisch ausgeführt. Dies ermöglicht individuelle Anpassungen und Reaktionen auf Programmfunktionen.

Hinweise

·Das Event Scripting muss vom Administrator freigegeben werden.

·Alle Ereignis-Funktionen werden in der Datei EventScripting[.Computername].pas deklariert. Eine verschlüsselte Datei ist nicht zulässig, weil der Code dann nicht sicherheitskritisch überprüft werden könnte. Die Pascal-Datei kann für einzelne Computer oder für alle hinterlegt sein:
Eine Datei "EventScripting.Computername.pas" ist nur für den Computer mit dem angegebenen Namen gültig. Diese wird bevorzugt geladen und ist in der Entwicklungsphase empfohlen.
Wenn keine Datei mit dem entsprechenden Computernamen vorliegt, wird die allgemeingültige "EventScripting.pas" verwendet.

·Sicherheit: Um Manipulationen auszuschließen, schützen Sie bitte das Verzeichnis "(Gemeinsame Dateien)\macro\eventscripting\" mit Dateizugriffsrechten. Leserechte für alle Benutzer, Schreibrechte nur für berechtigte Administratoren.

·Fehlerhafte Skripte können zu einer Vielzahl von Fehlern und Meldungen im Programm führen!

Ereignissteuerung einrichten

1.Der Administrator muss das Scripting zulassen: Menü Datei | Optionen | Einstellungen, Seite Sicherheit.

2.Öffnen Sie anschließend den Makro-Editor, Menü Start | Verwenden | Makro | Makro-Editor. Klicken Sie im Editor auf Start | Makro | Event Scripting | Event Scripting installieren. Der Befehl ist nur sichtbar, wenn die Funktion noch nicht eingerichtet ist.
Das Verzeichnis "..\Macro\EventScripting" wird mit einer Beispiel Pascal-Datei erstellt und in den Editor geladen. Diese Datei ist vorerst nur für den Computer gültig, an dem die Einrichtung ausgeführt wird.

3.Wenn das Skript fertiggestellt und ausgiebig getestet ist, können Sie die Datei in "EventScripting.pas" ohne Computernamen umbenennen, sodass sie für alle Arbeitsplätze gilt.

4.Zum Deaktivieren der Funktion können Sie die EventScripting-Dateien umbenennen/löschen oder, wie unter Punkt 1 beschrieben, wieder deaktivieren.

Liste der Ereignisse

Bei Funktionen mit booleschem Ergebnis wird die programminterne Ausführen abgebrochen, wenn das Funktionsergebnis false ist. Weitere Informationen erhalten Sie, wenn Sie eine Ereignis-Funktion im Skripteditor aus der Funktionsliste einfügen.

function AfterAutoCaptAzureAI(AFileName: string; AFieldValues: TStrings): boolean

function AfterAutoCaptDate(AFileName: string; AFieldValues: TStrings): boolean

function AfterAutoCaptEInvoice(AFileName: string; AFieldValues: TStrings): boolean

function AfterAutoCaptGPT(AFileName: string; AFieldValues: TStrings): boolean

function AfterAutoCaptPhrases(AFileName: string; AFieldValues: TStrings): boolean

function AfterAutoCaptYear(AFileName: string; AFieldValues: TStrings): boolean

procedure AfterCreateDocFile(AFileName: string; ADocID: integer)

procedure AfterImportDoc(ADataset: TDataset; ASrcFileName: string)

procedure AfterInitializationMenu(AForm: TForm; ABarManager: TdxBarManager; ARibbon: TdxRibbon)

procedure AfterLoadFormSettings(AForm: TForm; ASettingsFileName: string)

procedure AfterLoadMenuSettings(AForm: TForm; ABarManager: TdxBarManager; ASettingsFileName: string)

procedure AfterPostDoc(ADataset: TDataset; AIsNewDocument: boolean)

procedure AfterSendFileToAccountant(ADocID: integer; ASrcFileName, ADestFileName: string)

procedure AfterSendToAccountant(AArchiveFileName, ADestPath, ADestZipFileName: string)

function AppOnActivate(ADocWasOpened: boolean): boolean

procedure BeforePostDoc(ADataset: TDataset; AIsNewDocument: boolean)

procedure DatasetDocBeforeDelete(ADataset: TDataset)

procedure DatasetDocBeforeEdit(ADataset: TDataset)

procedure DatasetDocBeforeInsert(ADataset: TDataset)

procedure DatasetDocBeforeOpen(ADataset: TDataset)

procedure DatasetDocAfterOpen(ADataset: TDataset)

procedure DatasetDocBeforePost(ADataset: TDataset)

procedure DatasetDocAfterPost(ADataset: TDataset)

procedure DatasetDocversBeforePost(ADataset: TDataset)

procedure DatasetDocversAfterPost(ADataset: TDataset)

function DBImportTableBeforeAppend(ADBCategory: integer; ASrcDBName: string; ASrcDataset, ADstDataset: TDataset): boolean;

function DocumentGetPassword(ACalledFrom, AFileName: string; ACalledCount: integer): string

procedure FormDBEdit_AfterLoadLayout

function FormDBEdit_OnCloseQuery: boolean
Mit result=false kann z. B. die Eingabe eines Datenfelder im Eigenschaftenfenster erzwungen werden.

procedure FormDBEdit_OnExitFieldEdit(AField: TField)

procedure FormOmMain_AfterCreate

procedure FormOmMain_AfterCreateDocGridColumns

function FormOmMain_AfterExecuteActFileDbExport(AFileName: string): boolean

procedure FormOmMain_AfterExecuteActFileDbReport(AFileName: string)

procedure FormOmMain_AfterLoadLayout

function FormOmMain_OnCloseQuery: boolean
Mit result=false wird das Beenden des Programms verhindert.

procedure FormOmMain_OnExitSearchEdit(AFieldName, AEditText: string)

function FormOmMain_OnGridClipbordPaste: boolean

function FormOmMain_OnGridDnDDrop: boolean

function FormOmMain_OnNavigatorClipbordPaste: boolean

function FormOmMain_OnNavigatorDnDDrop: boolean

procedure FormOmMain_tvDocumentEditValueChanged(AField: TField; AEditingValue: string)

procedure OnAdminLogin(IsLoggedIn: boolean)

procedure OmApiAfterInterpretToken(ATokenName, AMacroCmd: string; ATokens: TStrings; AResult: string)

function OmApiBeforeInterpretToken(ATokenName, AMacroCmd: string; ATokens: TStrings): boolean

procedure OnDocumentFileMoved(AOldFileName, ANewFileName: string; AType, ASourceType: integer)

function OnExecuteAction(AForm: TForm; AAction: TBasicAction): boolean
Wird vor dem Ausführen einer Action aufgerufen. Siehe auch {OmAPI:ListMainMenuEntries} für eine Liste der Actions im Hauptfenster.

procedure OnFileChange(AType: integer; AFileName: string; ADataset: TFDQuery)

function OnFileDelete(AType: integer; AFileName: string; ADataset: TFDQuery): boolean
Löschen einer Dokumentdatei. Mit result=false wird nur das Löschen der Datei, aber nicht das Entfernen aus dem Archiv verhindert. Typ 1 ist das Hauptdokument, 2 eine Dokumentversion.

function OnFtiAddDocument(AFileName: string; ADocID: integer): boolean

procedure OnFtiReadFile(AFileName: string; ADocID: integer)

function OnHelp(ACommand: Word; AData: Integer): boolean

function OnImporterAddItem(ASourceOrFileName: string; AImportSource: integer; AFieldValues: TStrings): boolean

function OnImporterExecute(AItemCount: integer): boolean

function OnLoadFormSettings(AForm: TForm; ASettingsFileName: string): boolean

function OnLoadMenuSettings(AForm: TForm; ABarManager: TdxBarManager; ASettingsFileName: string): boolean

function OnSchedulerEventComplete(ACompleted: boolean; ADataset: TFDQuery; ACaption, AGuid: string): boolean


Menübefehle im Makro aufrufen

Navigation: Entwicklerhilfe >

Menübefehle im Makro aufrufen

Makro-Prozedur OmAPI

Zugriff auf Office Manager DMS-Menübefehle aus einem Makro.

Syntax

{OmAPI:Function[,Parameter]}

Parameter

Function:

(Action): Ruft einen Menübefehl auf, sofern der Anwender die Berechtigung dafür besitzt. Die Namen der Befehle finden Sie in der Liste der Hauptmenüeinträge (siehe unten in Beschreibung) oder mit Hilfe der menüorientierten Support-Suche.

DocEditTabIdx,Index: Legt fest, welche Registerseite beim Öffnen des Eigenschaftendialogs aktiv ist: -1=keine Vorgabe, 0=Datei, 1=Scannen usw.

ListMainMenuEntries: Erstellt eine Liste mit den Namen aller Menübefehle.

RegisterOMP: Verknüpft die Office Manager-Dateitypen (*.omp u. a.) mit Office Manager.

SetAutoRun: Setzt die Autostart-Option. Parameter 1 aktiviert und Parameter 0 deaktiviert den Autostart.

CreateDemoDocs: Erzeugt Demodatensätze im geöffneten Archiv. Liest dazu die Datei "..\Examples\import.xml" ein.

CreateTestDocs,(Anzahl): Erzeugt Dokumentdatensätze und Dateien für Testzwecke.

DisableImport: Deaktiviert den Dateiimport bis zum Programmneustart.

DisableNotivication: Deaktiviert das Einblenden der Tätigkeiten-Erinnerungen.

SaveDocGridProperties,Dateiname: Speichert die Spalteneinstellungen der Dokumenttabelle in der angegebenen Datei (*.grd).

LoadDocGridProperties,Dateiname: Lädt die Spalteneinstellungen der Dokumenttabelle aus der angegebenen .grd-Datei.

SaveMenuProperties,Dateiname: Speichert die Menüeinstellungen in der angegebenen Datei (*.mnu).

LoadMenuProperties,Dateiname: Lädt die Menüeinstellungen aus der angegebenen .mnu-Datei.

RegisterTemplates,Dokumenttyp: Registriert alle Vorlagendateien im Pfad (gemeinsame Dateien)\Template für den Dokumenttyp.

ViewTable,TableName: Zeigt eine Office Manager-Datenbank-Tabelle.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Einschränkung

Der Aufruf eines Menübefehls mit (Action) ist standardmäßig gesperrt.

Beschreibung

Die Prozedur ermöglicht Ihnen u. a. die Ausführung eines Office Manager-Menübefehls aus der Makrobearbeitung.

Hinweis: Der Begriff "OmAPI" steht auch allgemeiner für die Makrosprache "Office Manager Application Programming Interface".

Um eine Liste aller Menübefehle zu erhalten, öffnen Sie bitte den Makroeditor. Wählen Sie die Sprache "OmAPI" und geben Sie den Quelltext {OmAPI:ListMainMenuEntries} ein. Klicken Sie auf Start | Makro | Ausführen (s. a. Funktionsnamen ermitteln).

Siehe auch

Makro-Referenz

Self

AdoViewTable


Mausschaltfläche im Layout

Navigation: Entwicklerhilfe >

Mausschaltfläche im Layout

Schaltfläche im Layout platzieren

Mit Hilfe des Layout-Designers können Sie Mausschalter für die Makro-Ausführung erstellen.

·Wählen Sie bitte im Hauptmenü Ansicht | Anpassen | Layout entwerfen das gewünschte Formular.

·Der Layout-Designer wird geöffnet:
Layout bearbeiten

·Klicken Sie auf Schalter und platzieren Sie den Schalter im Layout.

·Geben Sie bei Text bitte die Schalterbeschriftung und bei Makro die auszuführenden Makrobefehle ein.

·Wenn der Schalter eine Grafik enthalten soll, dann können Sie entweder ein Bild darauf platzieren oder bei Text die Nummer der Menügrafik in geschweiften Klammern angeben, beispielsweise "{25}Anleitung".

·In der geschweiften Klammer kann zusätzlich ein Hinweis (Kurzhilfe) angegeben werden. Trennen Sie den Text bitte mit Komma von der Grafik: "{25,Öffnet die Anleitung}Anleitung". Falls keine Grafik, aber ein Hinweis angegeben werden soll, dann geben Sie bitte -1 für die Grafik an: "{-1,Öffnet die Anleitung}Anleitung".

Im obigen Beispiel lautet die Beschriftung "Anleitung" und der Makrobefehl "{ShellExecute:G:\Office Manager\Anleitung Archivierung.pdf}". Wenn der Benutzer auf den Schalter klickt, wird das PDF-Dokument "Anleitung Archivierung.pdf" geöffnet.

Für die Ausführung umfangreicher Skripte nutzen Sie bitte ExecuteMacroFile.

Sicherheitshinweis

Der auszuführende Makrobefehl wird in der Layoutdatei (*.lay) gespeichert. Schützen Sie diese Datei vor unberechtigten Manipulationen mit Hilfe von Dateizugriffsberechtigungen von Windows.

Siehe auch

Makro-Referenz

Layout-Designer

OMDN: Schaltfläche im Menü hinterlegen


Zugriff auf Auswahllisten

Navigation: Entwicklerhilfe >

Zugriff auf Auswahllisten

Office Manager-Auswahllisten von außen lesen oder bearbeiten

Die Auswahllisten für Projekte, Gruppen u. a. werden entweder in der Archiv- bzw. Kontaktdatenbank oder in Textdateien (*.itm) gespeichert. Innerhalb des Office Managers bearbeiten Sie die Listen mit dem Menübefehl Datei | Optionen | Auswahllisten.

In den Feldeigenschaften legen Sie fest, ob die Liste in der Datenbank oder in Textdateien (Option Globale Liste für alle Datenbanken) gespeichert wird.

A. Auswahllisten in Textdateien

Wenn Sie die Listen mit einer anderen Software aktualisieren möchten, empfiehlt sich die Speicherung in Textdateien:

1.Wählen Sie bitte im Menü Datei | Datenbank | Anpassen | Felder definieren und markieren Sie die Auswahlliste, auf die Sie von außen zugreifen möchten.

2.Verwenden Sie einen Eingabestil mit Liste oder strukturierter Liste. Aktivieren Sie die Option Globale Liste für alle Datenbanken (dies legt das Speichern in Textdatei fest):
Eingabestil festlegen

3.Klicken Sie auf Übernehmen und anschließend auf Schließen.

4.Wählen Sie im Menü Datei | Information. Auf der Seite "Auswahllisten" finden Sie den Namen der .itm-Datei, in der die Liste gespeichert wird. Alle globalen Listen befinden sich im Verzeichnis der gemeinsamen Dateien.
System-Informationen: Auswahllisten

5.Sie können die Textdatei mit einer anderen Software lesen und schreiben. Der Office Manager liest die Listen beim Öffnen der Datenbank neu ein.

B. Auswahllisten in der Archivdatenbank

1.Wählen Sie, wie unter A, den Menübefehl Datei | Datenbank | Anpassen | Felder definieren und deaktivieren Sie die Option Globale Liste für alle Datenbanken.

2.Die Listen werden in der Archivdatenbank in Tabelle itemlists gespeichert.

3.Erstellen Sie vor ersten Tests bitte eine Sicherungskopie der Datenbank.

4.Sie können sich mittels ODBC oder OLE-DB/ADO mit der Datenbank verbinden. Archive mit der Endung .omp sind MS Access-Datenbanken, .omsl SQLite und Dateien mit der Endung .omcs sind Verweise auf SQL-Datenbankserver. Auf verschlüsselte SQLite-Safes (.omen) können Sie von außen nicht zugreifen.

Format der Auswahllisten

Die Listen sind als UTF8-Textdatei mit BOM gespeichert, jeder Listeneintrag steht in einer eigenen Zeile.

Beispiel einer einfachen Liste

Erster Wert

Zweiter Wert

Beispiel einer Liste mit Formatierungen

Erster Wert=3,clRed,clWindow,1,1,,1,1

Zweiter Wert=8,clBlue,clWindow,1,0,,0,1

Beispiel einer strukturierten Liste

Haupteintrag

Haupteintrag\Zweite Ebene

Haupteintrag\Zweite Ebene\Erster Eintrag in 3. Ebene

Haupteintrag\Zweite Ebene\Zweiter Eintrag in 3. Ebene

Haupteintrag\Zweite Ebene\Dritter Eintrag in 3. Ebene

Zweiter Haupteintrag


Office Manager-Dateitypen

Navigation: Entwicklerhilfe >

Office Manager-Dateitypen

Office Manager-Dateitypen

Endungen der Dateien, die vom Office Manager verwendet werden.

.omsl | Archivdatenbank im SQLite-Format
.omp | Archivdatenbank im MS Access-Format
.omen | Verschlüsselte Archivdatenbank im SQLite-Format (nur 32-Bit-Version).
.omcs | Steuerdatei für Archivdatenbanken auf SQL-Servern
.crmsl | Kontaktdatenbank im SQLite-Format
.crmac | Kontaktdatenbank im Access-Format
.crmen | Verschlüsselte Kontaktdatenbank im SQLite-Format (nur 32-Bit-Version).
.crmcs | Steuerdatei für Kontaktdatenbank auf SQL-Servern
.aplsl | Anwendungsdatenbank im SQLite-Format, Eigenschaften der Dokumenttypen
.apl | Anwendungsdatenbank im Access-Format
.aplcs | Steuerdatei für Anwendungsdatenbank auf SQL-Servern
.omac | Makro mit Office Manager API-Befehlen
.omacen | Verschlüsseltes Makro mit Office Manager API-Befehlen. (Visual Basic=.vbsen, JScript=.jsen).
.omexc | Austauschdatei mit Archivdatenbank und Dokumentdateien.
.omini, .omtup | Toolup-Dateien, die Sie bei Bedarf vom Support erhalten
.grd | Einstellungen der Dokumenttabelle
.gppg | Tabellengruppierung
.dxb | Einstellungen des Hauptmenüs
.repini | Einstellungen "Report drucken"
.omfti | Temporäre Textdatei der Volltextindexierung
.lay | Layout
.itm | Auswahllisten, die für alle Archive oder Kontaktdatenbanken gelten
.lst | Textdatei mit Listen

Die Datenbankdateien sind unter Windows dem Office Manager zugeordnet. Sie können z. B. eine omp-Datei im Windows-Explorer doppelklicken, um den Office Manager mit diesem Archiv zu starten.

Datenbanken auf SQL-Servern (nur Enterprise-Edition) werden über eine .omcs bzw. .aplcs-Datei geöffnet. Die Treiber- und Datenbankverbindungsparameter sind in dieser Verknüpfungsdatei gespeichert. Wählen Sie bitte im Menü Datei | Datenbank | Anpassen den Eintrag Eigenschaften, um die Verknüpfungsdatei zu bearbeiten.

Siehe auch: Beschreibung der Office Manager-Systemdateien.


Startparameter

Navigation: Entwicklerhilfe >

Startparameter

Office Manager-Startparameter

Office Manager DMS öffnet beim Programmstart die in den Einstellungen angegebenen Datenbanken. Diese Einstellungen sind in der Windows-Registrierdatenbank oder in Konfigurationsdateien hinterlegt. Sie können das Programm aber auch mit einer Datenbank als Parameter starten, um diese zu öffnen.

Beispiel

·om.exe G:\Office Manager DMS\Gemeinsame Dateien\Archive\Mein Archiv.omsl

·om.exe G:\Office Manager DMS\Gemeinsame Dateien\Archive\Meine Kontakte.crmsl

·om.exe G:\Office Manager DMS\Gemeinsame Dateien\Archive\Meine Anwendungsdatenbank.aplsl

Erweiterte Parameter

Verfügbar in diesen Editionen

·/ImportPath=Verzeichnis, automatisiert den Dateiimport

·/StartLog=Dateiname, Startvorgang in Logdatei schreiben (in allen Editionen verfügbar)

·/WriteErrorsToFile=Dateiname: Fehlermeldungen werden nicht als Dialog ausgegeben, sondern in die Textdatei gespeichert (gilt nicht für alle Meldungen). Mit /WriteErrorsToFile=EventLog können Sie die Meldungen auch in der Windows Ereignis-Anzeige speichern.

·/UseLocalFiles: Die lokalen Synchrondaten auch dann verwenden, wenn das Verzeichnis der gemeinsamen Dateien vorhanden - der Computer also am Netzwerk angeschlossen ist. Der Parameter wird ignoriert, wenn das lokale Verzeichnis nicht gefunden wird.

·/UseLocalFilesNoMsg: Wie "UseLocalFiles", jedoch ohne Hinweis beim Start.

·/Audit: Programm für eine Archivrevision, beispielsweise eine Steuer- oder Wirtschaftsprüfung starten.

Geben Sie immer den kompletten Pfad an. Die Parameter werden mit einem Leerzeichen voneinander getrennt. Wenn Sie Pfade mit Leerzeichen angeben, dann muss der komplette Parameter in Anführungszeichen geschrieben werden.

Siehe auch

Aufruf aus Fremdprogrammen


Sprachdateien

Navigation: Entwicklerhilfe >

Sprachdateien

Teil-Übersetzung der Programmoberfläche

Neben der Auswahl einer Standardsprache (Menü Ansicht | Anpassen | Sprache) erlaubt der Office Manager eine Übersetzung der Menübefehle in beliebige andere Sprachen.

1.Melden Sie sich bitte als Administrator an (Menü Datei | Optionen | Administrator).

2.Öffnen Sie den Makroeditor (Start | Verwenden | Makro | Makro-Editor).

3.Wählen Sie die Skriptsprache "OmAPI".

4.Geben Sie folgenden Quelltext ein (statt "english" verwenden Sie den Namen der Sprache):
{SaveLanguageFile:{Self:CommonFilesPath}english.ini}

5.Klicken Sie bitte auf Start | Makro | Ausführen Run und schließen Sie den Editor.

6.Öffnen Sie die admin.ini und geben Sie Folgendes ein (statt "G:\Office.." verwenden Sie bitte den Dateinamen der zuvor erzeugten Datei):
[View]
LanguageIniFile=G:\OfficeManager\english.ini

7.Speichern Sie die admin.ini

8.Öffnen Sie die zuvor erstellte Datei "english.ini" im Notepad oder einem anderen Texteditor und übersetzen Sie die gewünschten Texte.

9.Speichern Sie die Datei und starten Sie den Office Manager neu.

Format der Sprachdateien

Es handelt sich um Standard-INI-Dateien:

[Sektion]

Name=Wert

Sie dürfen nur die Werte übersetzen, keinesfalls den Namen oder die Sektion.

Einige Sektion beinhalten mehrere Zeilen mit unterschiedlichen Texten:

[PageControl2]

PCImageListIndexError=Index (%d) muss zwischen 0 und %d liegen

PCNoBaseImages=BaseImages wurde nicht zugewiesen

Übersetzen Sie jeweils den Text hinter dem Gleichheitszeichen. Beachten Sie unbedingt, dass Variablen, wie "%d" oder "%s" erhalten bleiben und in ihrer Reihenfolge nicht geändert werden. Es würde sonst zu Laufzeitfehlern kommen.

Die Sektionen der Menübefehle haben folgenden Aufbau:

[FormOmMain.BarManager.MDocNew]

Caption=&Neues Dokument...

Hint=Neues Dokument|Neues Dokument mit Standardfeldwerten erstellen

ShortCut=Strg+N

Caption: der Text des Befehls im Menü. Das Zeichen & kennzeichnet die im Menü unterstrichene Zugriffstaste. Es ist üblich, drei Punkte hinter den Text zu schreiben, wenn der Befehl nicht sofort ausgeführt wird. Wenn sich z. B. ein Dialogfenster öffnet, in welchem man den Befehl abbrechen kann.

Menübefehl mit Kurztasten

Hint: Hinweis, der an der Maus erscheint, sobald diese über einer Schaltfläche ruht. Wenn gewünscht, kann eine kurze und eine lange Hilfe definiert werden: vor dem | steht die kurze und dahinter die lange Hilfe. Die kurze Version erscheint an der Maus und die lange Version in der Statuszeile. Lassen Sie da Zeichen | einfach weg, wenn Sie nicht zwischen kurzer und langer Version unterscheiden möchten.

Kurzhilfe, kurze Version

Kurzhilfe, lange Version

Shortcut: Angabe einer Kurztaste, wie beispielsweise Strg-N.

Glyph: zusätzlich können Sie die Zeile Glyph=(Dateiname) hinzufügen, um das Symbol durch eine andere Grafik zu ersetzen. Die Grafikdatei muss eine Windows-Bitmap (*.bmp) mit 16x16 Punkten sein.

Siehe auch

Menüband anpassen

Menü Ansicht | Anpassen | Sprache


Struktur der Archivdatenbank

Navigation: Entwicklerhilfe >

Struktur der Archivdatenbank

Datenbankstruktur des Dokumentenarchivs

Das Dokumentenarchiv beinhaltet folgende Datenbank-Tabellen:

document | Tabelle der aktiven Dokumente
docarch | Tabelle der archivierten Dokumente
doctrash | Dokumenten-Papierkorb
doccombin | Verknüpfungstabelle für Kombinationen
docfld | Eigenschaften der Dokument-Datenfelder
docblobs | Binäre Felder (mit Version 18.0.3.549 entfernt)
docvers | Dokumentversionen
fldtempl | Dokumentvorlagen
docaudit | Revisionssicherheit
history | Protokoll (vor 20.0 docprtcl)
todo | Tätigkeiten (ab 20.0 in Anwendungsdatenbank)
itemlists | Auswahllisten, die nur für dieses Archiv gelten
itemrecognition | Belegerkennung für Auswahllisten
ftiword | Wörter des Standard-Volltextindex
ftiwid | Dokumentverknüpfungen Standard-Volltextindex
tmpsystask | Systemaufgaben, wie beispielsweise OCR-Texterkennung
layout | (reserviert)
identno | Schlüsselnummern
dboption | Einstellungen der Datenbank
documentfts*) | SQLite-Volltextsuche in document
docarchfts*) | SQLite-Volltextsuche in docarch

*) Nur bei Archiven im SQLite-Datenformat (*.omsl) vorhanden

Sie können den Inhalt einer Tabelle betrachten, indem Sie im Menü Administrator | Tabelle anzeigen auf die entsprechende Tabelle klicken.

Je nach Datenbankformat sind gespeicherte Prozeduren vorhanden.

Die Tabellennamen sind seit Programmversion 17.0 in neuen Datenbanken kleingeschrieben, zuvor groß.

Siehe auch

Struktur der Anwendungsdatenbank und der Kontakte

Dokumentattribute definieren


Tabelle document

Navigation: Entwicklerhilfe > Struktur der Archivdatenbank >

Tabelle document

Archivdatenbank: Standardfelder der Dokumenttabellen

Tabellen document, docarch, doctrash und fldtempl

Feldname

Typ

Beschreibung

docid

N *

Schlüssel

applname

A(100)

Dokumenttyp

docno

A(20)

Nummer

name

A(20)

Name

project

A(80)

Projekt

category

A(30)

Kategorie

state

A(30)

Status

receiptdate

@

Belegdatum, z. B. Ausstellungsdatum einer Rechnung

username

A(30)

Besitzer

template

A(254)

Vorlagendatei

storemode

A(2)

(reserviert für Speichermodus)

filename

A(254)

Name der verknüpften Datei

favorite

L

Favorit

doctype

A(2)

Typ des Dokuments

accessrights

A(40)

Dateizugriffsrechte

ftiwords

A(100)

Zusätzliche Schlagwörter für Volltextsuche

fileprotected

L

Verschlüsselungsstatus

filepagecount

N

Seitenanzahl der Datei

createdate

@

Erstellt

ftiupdate

@

Datum Datei-Indexierung

filehashmd5

A(32)

Datei-Checksumme

blockchain

A(80)

Transaktions-ID für Blockchain-Revision

lastremark

A(150)

Ereignisse

combincnt

N

Anzahl von Kombinationen

docguid

A(38)

Global eindeutiger Schlüssel

contactguid

U

GUID des verknüpften Kontakts

combincnt

N

Anzahl von Kombinationen

notes

M

Notizen

rtftext

Dokumenteninhalt der Notizen

Nur bei Bedarf vorhanden

contenttext

M

Volltext für die Indexierung

clonegrp

N

Verknüpfungs-ID von Klonen

accountant

@

An Steuerberater gesendet

Nur in Tabelle doctrash:

deletedate

@

Lösch-Datum

Nur in Tabelle fldtempl:

templatename

A(50)

Vorlagenname

templatetype

A(10)

Vorlagentyp

showdlg

L

Eigenschaftendialog öffnen

secvisible

M

Sichtbarkeit der Vorlage

Siehe auch

Struktur der Archivdatenbank

Dateiabhängige Dokumentattribute

Dokumentattribute definieren


Dateiabhängige Dokumentattribute

Navigation: Entwicklerhilfe > Struktur der Archivdatenbank >

Dateiabhängige Dokumentattribute

Die Archivdatenbank kann Datenfelder für verschiedene Datei- und E-Mail-Attribute verwalten und diese automatisch aktualisieren. Wählen Sie bitte den Menübefehl Datei | Datenbank | Anpassen | Felder definieren, um diese hinzuzufügen. Klicken Sie dort mit der rechten Maustaste auf den Schalter Neu.

Die entsprechenden Befehle des Popupmenüs sind deaktiviert (grau), falls das Feld bereits vorhanden ist.

Dateiattribut

Archiv-Feldname

Empfohlene Bezeichnung im Archiv

Bemerkung

Besitzer (Owner)

fileowner

Dateibesitzer

Benutzername oder Gruppe 4)

fileownerfull

Dateibesitzer

Domain\Username 4)

username

Besitzer

1)

Erstellt am

filecreate

Datei erstellt

4)

createdate

Erstellt

2)

Geändert am

fileedit

Datei geändert

4)

Letzter Zugriff am

filelastaccess

Letzter Dateizugriff

Zuletzt geöffnet 3) 4)

Dateigröße

filesize

Dateigröße

4)

Seitenzahl

filepagecount

Seiten

4), s. a. unterstützte Formate

Wortanzahl

filewordcount

Wörter

4) 5), s. a. Supportartikel

Datei-Checksumme

filehashmd5

Datei-Hash

Mehrfachablagen finden 4)

Dateischutz,
Revisionssicherheit

fileprotected

Schloss Geschützt

Erkennt nur verschlüsselte und signierte PDF 4)

Dateianlage vorhanden

mailattachico

Büroklammer Anlage

4) 8)

Liste der Dateianlagen

mailattachlst

Anlagen

4) 8)

E-Mail-Empfänger

mailto

An

E-Mail-Absender

mailfrom

Mail von

E-Mail Message-ID

mailmsgid

Message-ID

4) 6)

Letzte Indexierung

ftiupdate

Letzte Indexierung

Dateidatum des letzten Einlesens der Attribute und des Volltextes

Anzahl Dokumentversionen

versioncount

Versionen

7)

1) Das Dokumentattribute "username" enthält den Office Manager-Namen des Anwenders, der das Dokument erstellt bzw. importiert hat.
2) createdate wird beim Hinzufügen des Dokuments von der aktuellen Zeit oder, wenn geeignet, vom Dateidatum "Erstellt" übernommen und später nicht mehr aktualisiert.
3) filelastaccess hat wenig Aussage, beispielsweise wird das Datum auch aktualisiert, wenn der Office Manager die Seitenzahl einer PDF ermittelt.
4) Felder werden auch für archivierte Dokumente aktualisiert.
5) Eine Aktualisierung findet bei den meisten Dateitypen nur während der Volltextindexierung statt.
6) Die Message-ID wird zusätzlich für die Dublettenvermeidung bei E-Mails verwendet, wenn dieses Datenfeld vorhanden ist und die Hash-Suche keine identische Mail im Archiv gefunden hat.
7) Das Datenfeld ist nicht von der Datei, sondern von anderen Automatismen abhängig. Zur Aktualisierung ist die Option "Daten-Integrität" der Datenbankpflege vorgesehen.

8) Dateianlegen werden nicht nur bei E-Mails gezeigt, sondern beispielsweise auch bei ZIP-Archiven und PDF-Dokumenten.

Siehe auch

Datenbankpflege, Option Dateiattribute aktualisieren

Makro-Funktion UpdateDocAttributesFromFile


Tabelle doccombin

Navigation: Entwicklerhilfe > Struktur der Archivdatenbank >

Tabelle doccombin

Archivdatenbank: Tabelle doccombin

Verknüpfungstabelle der internen Dokument-Kombinationen.

Feldname

Typ

Beschreibung

docid

N *

Schlüsselnummer des Dokuments

linkid

A(38) *

Verknüpfungsname

Siehe auch

Struktur der Archivdatenbank

Fenster Dokumentverknüpfungen


Tabelle docfld

Tabelle docfld und contactfld

Navigation: Entwicklerhilfe > Struktur der Archivdatenbank >

Tabelle docfld und contactfld

Archivdatenbank: Tabelle docfld
Kontaktdatenbank: Tabelle contactfld

Die Tabelle beinhaltet die programminternen Eigenschaften der Dokument- und Kontaktattribute.

Feldname

Typ

Beschreibung

fieldname

A(30) *

Name des Attributs

caption

A(30)

Bezeichnung des Attributs

visible

L

(nicht mehr verwendet)

allowempty

L

Pflichtfeld

uniqueval

L

Eindeutiger Feldwert

showinsearchmenu

L

Eintrag im Menü Start | Suchen | Weitere u. a.

editstyle

N

Bearbeitungs-Stil

styleex

A(50)

Erweiterter Bearbeitungs-Stil

updatelist

L

Liste automatisch erweitern

filepath

A(200)

Format für Datei- und Kontaktlisten

multiselect

L

Mehrfachauswahl

globallist

L

Liste für alle Archive

omcase

N

Schreibweise (groß/klein)

valnew

A(254)

Vorgabewert für neue Datensätze

valedit

A(254)

Vorgabewert bestehender Datensätze

seceditable

M

Zugriffsrechte Sichtbarkeit

secvisible

M

Zugriffsrechte zum Bearbeiten

comment

A(254)

Benutzer-Kommentar

options

A(100)

Erweiterte und zukünftige Optionen

Siehe auch

Struktur der Archiv- und Kontaktdatenbank

Felder definieren


Tabelle docvers

Navigation: Entwicklerhilfe > Struktur der Archivdatenbank >

Tabelle docvers

Archivdatenbank: Tabelle docvers

Tabelle beinhaltet die Dokumentversionen.

Feldname

Typ

Beschreibung

docid

N *

Dokumentenschlüssel

docvers

N *

Schlüssel der Version

name

A(80)

Name

filename

A(254)

Name der verknüpften Datei

filehashmd5

A(32)

Datei-Checksumme

blockchain

A(80)

Transaktions-ID für Blockchain-Revision

createdate

@

Erstellt

username

A(30)

Besitzer

cmdusage

A(30)

(reserviert)

notes

M

Notizen und Details

Siehe auch

Struktur der Archivdatenbank


Tabelle docaudit

Navigation: Entwicklerhilfe > Struktur der Archivdatenbank >

Tabelle docaudit

Archivdatenbank: Tabelle docaudit

Überwachung der Revisionssicherheit in GoBD-Archivdatenbanken.

Feldname

Typ

Beschreibung

docid

N *

Schlüsselnummer des Dokuments

revid

N *

Schlüssel des Revisionseintrags

docvers

N

Schlüssel der Dokumentversion

revtype

N

Revisionstyp

createdate

@

Protokolldatum

username

A(60)

Benutzername

dmsvers

A(20)

Office Manager-Version

filehashmd5

A(32)

aktuelle Datei-Checksumme

filehashprev

A(32)

Datei-Checksumme vor dem Ereignis

attrhashmd5

A(32)

(reserviert)

audithash

A(32)

Revisions-Checksumme

filename

A(254)

Dateiname

fileinfo

A(40)

Dateiinfo

comment

A(32)

Kommentar

attrchange

A(250)

Log für Attributänderungen

Siehe auch

Struktur der Archivdatenbank


Tabelle history

Navigation: Entwicklerhilfe > Struktur der Archivdatenbank >

Tabelle history

Archiv und Kontaktdatenbank: Tabelle history

In der Tabelle werden die Dokumentzugriffe protokolliert.

Feldname

Typ

Beschreibung

fkguid

U *

Fremdschlüssel

rowguid

U *

Tabellenschlüssel

createdate

@

Protokolldatum

username

A(60)

Besitzer

protocol

M

Protokolltext

prtcltype

N

Protokolltyp

dmsvers

A(20)

Office Manager-Version

hash

A(64)

Datei-Checksumme

revision

A(64)

Revisions-Checksumme

Siehe auch

Struktur der Archivdatenbank


Tabelle itemlists

Navigation: Entwicklerhilfe > Struktur der Archivdatenbank >

Tabelle itemlists

Archivdatenbank: Tabelle itemlists

Die Tabelle beinhaltet Auswahllisten, die nur für dieses Archiv bzw. diese Kontaktdatenbank gelten. Globale Listen werden in *.itm-Dateien im Verzeichnis der gemeinsamen Dateien gespeichert.

Feldname

Typ

Beschreibung

itmname

A(30)

Listenname

itmlist

M

Listeninhalt

Siehe auch

Struktur der Archivdatenbank


Tabelle itemrecognition

Navigation: Entwicklerhilfe > Struktur der Archivdatenbank >

Tabelle itemrecognition

Archivdatenbank: Tabelle itemrecognition

Die Tabelle beinhaltet Schlagwörter für die Belegerkennung der Auswahllisten.

Feldname

Typ

Beschreibung

phrase

A(64) *

Phrase der Belegerkennung

fieldname

A(30) *

Datenbankfeld der Auswahlliste

itmvalue

A(254)

Zugeordneter Feldwert

Siehe auch

Struktur der Archivdatenbank


Tabelle ftiword

Navigation: Entwicklerhilfe > Struktur der Archivdatenbank >

Tabelle ftiword

Archivdatenbank: Tabelle ftiword

Die Tabelle beinhaltet Wörter und Schlüsselnummern für den Standard-Volltextindex. Bei der Suche wird zuerst die Schlüsselnummer des Wortes aus ftiword und anschließend alle Dokument-Schlüssel aus der Tabelle ftiwid gelesen.

Feldname

Typ

Beschreibung

word

A(30) *

Indexiertes Wort

wordid

N

Wort-Schlüsselnummer

Siehe auch

Tabelle ftiwid

Struktur der Archivdatenbank

Option UseAutoInc


Tabelle ftiwid

Navigation: Entwicklerhilfe > Struktur der Archivdatenbank >

Tabelle ftiwid

Archivdatenbank: Tabelle ftiwid

Die Tabelle beinhaltet die Schlüsselnummern der Wörter und Dokumente für den Standard-Volltextindex. Bei der Suche wird zuerst die Schlüsselnummer des Wortes aus ftiword und anschließend alle Dokument-Schlüssel aus der Tabelle ftiwid gelesen.

Feldname

Typ

Beschreibung

wordid

N*

Wort-Schlüsselnummer

docid

N*

Dokument-Schlüsselnummer

Siehe auch

Tabelle ftiword

Struktur der Archivdatenbank


Tabelle tmpsystask

Navigation: Entwicklerhilfe > Struktur der Archivdatenbank >

Tabelle tmpsystask

Archivdatenbank: Tabelle tmpsystask

Die Tabelle beinhaltet Systemaufgaben.

Feldname

Typ

Beschreibung

tblguid

A(38) *

Tabellenschlüssel

docid

N*

Dokument-Schlüsselnummer

tasktype

N

Aufgabentyp

taskdate

@

Datum/Zeit der Ausführung

value1

A(254)

(reserviert)

valuei

N

(reserviert)

createdate

@

Datum/Zeit der Erstellung

trycount

N

Anzahl bisheriger Versuche

ownername

A(254)

Name des Erstellers

taskex

N

(reserviert)

lockedby

A(254)

Sperrvermerk

TaskType

1100: nachträgliche OCR-Texterkennung

1101: nachträgliche OCR-Texterkennung und Verschlüsselung von PDF-Dokumenten für die Revisionssicherheit

1102: nachträgliche OCR-Texterkennung und Signierung von PDF-Dokumenten für die Revisionssicherheit

Siehe auch

Struktur der Archivdatenbank


Tabelle identno

Navigation: Entwicklerhilfe > Struktur der Archivdatenbank >

Tabelle identno

Archivdatenbank: Tabelle identno

Aufzählungsvariablen für Dokumentenschlüssel und anderes.

Feldname

Typ

Beschreibung

idname

A(50) *

Schlüsselname

nextid

N

Nächste Nummer

Siehe auch

Struktur der Archivdatenbank

ReadIdentNo


Tabelle dboption

Navigation: Entwicklerhilfe > Struktur der Archivdatenbank >

Tabelle dboption

Archiv- und Anwendungsdatenbank: Tabelle dboption

Die Tabelle speichert Datenbankoptionen.

Feldname

Typ

Beschreibung

optname

A(100) *

Optionsname

optvalue

A(254)

Optionswert

optvalueex

M

Langer Optionswert (reserviert)

Siehe auch

Struktur der Archivdatenbank

Struktur der Anwendungsdatenbank


Struktur der Kontaktdatenbank

Navigation: Entwicklerhilfe >

Struktur der Kontaktdatenbank

Struktur der Kontaktdatenbank (CRM)

Die CRM-Datenbank beinhaltet folgende Tabellen:

contact | Tabelle der Kontakte mit Adressdaten u. a.
contactfld | Eigenschaften der Kontakt-Datenfelder
dboption | Einstellungen der Datenbank
history | Protokoll
itemlists | Auswahllisten, die nur für diese Datenbank gelten
recognition | Eindeutige Werte für automatische Dokumentenerkennung

Sie können den Inhalt einer Tabelle betrachten, indem Sie im Menü Administrator | Tabelle anzeigen auf die entsprechende Tabelle klicken.

Siehe auch

Struktur des Archivs und der Anwendungsdatenbank

Dokumentattribute definieren


Struktur der Anwendungsdatenbank

Navigation: Entwicklerhilfe >

Struktur der Anwendungsdatenbank

Struktur der Anwendungsdatenbank

Die Anwendungsdatenbank beinhaltet folgende Datenbank-Tabellen:

dblist | Liste der bekannten Datenbanken
scheduler | Zentrale Aufgabenverwaltung
resource | Benutzerverwaltung
appl | Dokumenttypen
applcmd | Benutzerdefinierte Befehle
fileext | Dateiendungen
template | Vorlagendateien
dboption | Einstellungen der Datenbank

Sie können den Inhalt einer Tabelle betrachten, indem Sie im Menü Administrator | Tabelle anzeigen auf die entsprechende Tabelle klicken.

Die Tabellennamen sind seit Programmversion 17.0 kleingeschrieben, zuvor groß.

Siehe auch

Struktur des Archivs und der Kontaktdatenbank

Dokumenttypen


Tabelle dblist

Navigation: Entwicklerhilfe > Struktur der Anwendungsdatenbank >

Tabelle dblist

Anwendungsdatenbank: Tabelle dblist

Tabelle der bekannten Kontakt- und Archivdatenbanken.

Feldname

Typ

Beschreibung

dbguid

U *

GUID der Datenbank

dbcategory

N

1=Anwendungsdatenbank, 2=Archiv, 3=Kontakte

dbversion

N

Datenformat

name

A(80)

Bezeichnung

filename

A(254)

Vollständiger Dateiname

Siehe auch

Struktur der Anwendungsdatenbank


Tabelle scheduler

Navigation: Entwicklerhilfe > Struktur der Anwendungsdatenbank >

Tabelle scheduler

Anwendungsdatenbank: Tabelle scheduler

Tabelle der Aufgabenverwaltung.

Feldname

Typ

Beschreibung

dbguid

U *

GUID der Datenbank, zu der die Tätigkeit geplant ist

fkguid

U *

GUID des verknüpften Kontakts oder Dokuments

rowguid

U *

Aufgabenschlüssel

dbcategory

N

2=Aufgabe zu Dokument, 3=zu Kontakt

createdate

@

Geplant am

starttime

@

Datum und Uhrzeit der Aufgabe

finish

@

Geplantes Ende

parentid

U

actualstart

N

actualfinish

N

caption

A(80)

Tätigkeitsbezeichnung

eventtype

N

Normale oder wiederkehrende

groupid

N

labelcolor

N

Hervorhebung

location

A (80)

Ort

message

M

Notizen

options

N

recurrenceidx

N

Wiederholung

recurrenceinfo

blob

reminderdate

@

Erinnerungsdatum

reminderminbs

N

Erinnerung in Minuten vor Beginn

reminderres

blob

resourceguid

blob

userstate

N

Zeit anzeigen als

taskcomplete

N

taskindex

N

tasklinks

blob

taskstatus

N

Seit Programmversion 20.0 sind die Aufgaben aller Dokument- und Kontaktdatenbanken zentral in der Anwendungsdatenbank hinterlegt. Zuvor hatte jedes Archiv eine eigene Aufgabentabelle. In Version 23.0 wurde die Aufgabenverwaltung neu entwickelt und die Tabelle von "todo" in "scheduler" umbenannt.

Siehe auch

Struktur der Anwendungsdatenbank


Tabelle resource

Navigation: Entwicklerhilfe > Struktur der Anwendungsdatenbank >

Tabelle resource

Anwendungsdatenbank: Tabelle resource

Tabelle der Benutzer- und Aufgabenverwaltung.

Feldname

Typ

Beschreibung

rowguid

U *

Datensatzschlüssel

username

A (30)

Name der Benutzerin, des Benutzers

visible

L

Optionen für den Terminplaner

color

N

imageidx

N

workdays

N

workstart

@

workfinish

@

Siehe auch

Struktur der Anwendungsdatenbank


Tabelle appl

Navigation: Entwicklerhilfe > Struktur der Anwendungsdatenbank >

Tabelle appl

Anwendungsdatenbank: Tabelle appl

Eigenschaften der registrierten Dokumenttypen.

Feldname

Typ

Beschreibung

applname

A(40) *

Dokumenttyp-Bezeichnung

applintern

A(40)

Windows-Name

applimage

G

Grafik

doctype

A(2)

Typ

fileext

A(20)

Primäre Dateiendung

visiblecmds

A(10)

Sichtbare Standardbefehle

hasexecevent

L

Ist ein ereignisgesteuerter Befehl vorhanden

template

A(150)

Standard-Vorlagendatei

copytemplate

L

(reserviert, seit 17.0 veraltet)

docpath

A(150)

(seit 17.0 veraltet)

docpreview

A(2)

Vorschau-Modus

clsid

A(38)

(seit 17.0 veraltet)

shellnewvalue

A(30)

Art der Windowsvorlage

shellnewdata

A(150)

Windows-Vorlagendatei

iconfile

A(100)

Windows-Symboldatei

accessrights

A(40)

Standard-Dateizugriffsrechte

editrights

L

Rechte dürfen geändert werden

webhandling

N

Beschreibt den Modus im Online-Archiv

notes

A(250)

Kommentare und Notizen

nextvers

A(20)

(reserviert)

Siehe auch

Struktur der Anwendungsdatenbank

Dokumenttypen


Tabelle applcmd

Navigation: Entwicklerhilfe > Struktur der Anwendungsdatenbank >

Tabelle applcmd

Anwendungsdatenbank: Tabelle applcmd

Befehle der registrierten Dokumenttypen.

Feldname

Typ

Beschreibung

applname

A(40) *

Dokumenttyp-Bezeichnung

cmdname

A(30) *

Befehlsname

cmdcaption

A(40)

Befehlsbezeichnung

changedir

A(1)

Verzeichnis wechseln

visible

L

Sichtbarer Befehl

swshow

N

Fenstergröße

confirmmsg

A(60)

(reserviert)

cmdtype

A(1)

Art der Anwendungssteuerung:
D=Windows-Standard

C=Befehlszeilensteuerung

M=Makrosteuerung

applexe

A(254)

Programmdatei

termwait

L

Auf Programmende warten

fileasparam

L

Datei als Parameter

params

A(254)

Weitere Parameter

macrolang

A(30)

Sprache des Befehlsmakros

ommacro

M

Makro

execevent

A(20)

Ereignissteuerung

nextvers

A(20)

(reserviert)

Siehe auch

Struktur der Anwendungsdatenbank

Benutzerdefinierte Steuerung von Anwendungen


Tabelle fileext

Navigation: Entwicklerhilfe > Struktur der Anwendungsdatenbank >

Tabelle fileext

Anwendungsdatenbank: Tabelle fileext

Die Tabelle enthält weitere Dateiendungen, für die der Dokumenttyp geeignet ist.

Feldname

Typ

Beschreibung

applname

A(40) *

Dokumenttyp-Bezeichnung

fileext

A(80) *

Dateiendung

cmdimport

A(30)

(seit 17.0 veraltet

cmdexport

A(30)

(seit 17.0 veraltet

dlgfiltername

A(30)

Bezeichnung

nextvers

A(20)

(reserviert)

Siehe auch

Struktur der Anwendungsdatenbank


Tabelle template

Navigation: Entwicklerhilfe > Struktur der Anwendungsdatenbank >

Tabelle template

Anwendungsdatenbank: Tabelle template

Die Tabelle enthält Vorlagendateien.

Feldname

Typ

Beschreibung

applname

A(40) *

Dokumenttyp-Bezeichnung

templatename

A(40) *

Vorlagenbezeichnung

templatefile

A(254)

Dateiname

templateactive

L

(reserviert)

nextvers

A(20)

(reserviert)

Siehe auch

Struktur der Anwendungsdatenbank


Makro-Referenz OmAPI

Navigation: Entwicklerhilfe >

Makro-Referenz OmAPI

Variablen und Funktionen der Office Manager-Makrosprache "OmAPI"

Tipp: Alternativ zur Makrosprache können Sie auch den Pascal-Interpreter. In der 32 Bit-Version ist auch "Windows Script Host" mit Visual Basic Script, JScript u. a. möglich.

Begriffe

Makro-Variable: Gibt eine Variable oder den Wert eines Datenfeldes zurück, ohne dass umfangreiche Operationen ablaufen. Häufig sind Formatparameter möglich.

Makro-Funktion: Führt Anweisungen aus und liefert einen Wert zurück.

Makro-Prozedur: Führt Anweisungen aus ohne einen Wert zurückzugeben, vergleichbar mit void-Funktionen in C.

Rückgabewert: Die Anweisung in geschweiften Klammern {} wird durch den Rückgabewert bzw. durch einen Leer-String ersetzt.

Sprach-Referenz

Felder der Dokumententabelle

{Doc:FieldName [,FormatParameter]}
Z. B.: Name des Dokumentes = {Doc:Name}, Projekt = {Doc:Project}.

Für den Dateinamen sollte die Variable {CurrDocFileName} verwendet werden, da diese auch die Dokumentversionen berücksichtigt.

{FieldAttribute:DocDB,FieldName,Variable,[Trennzeichen]}: erweiterte Feldeigenschaften.

Felder der Kontaktverwaltung

{Contact:FieldName[,FormatParameter]}

{FieldAttribute:CRMDB,FieldName,Variable,[Trennzeichen]}: erweiterte Feldeigenschaften.

Felder der Tätigkeiten

{Scheduler:FieldName[,FormatParameter]}

Felder der archivierten Dokumente

{DocArch:FieldName[,FormatParameter]}

Felder des Dokumentversions-Archivs

{DocVers:FieldName[,FormatParameter]}

Felder der Anwendungsdatenbank

{Appl:FieldName [,FormatParameter]}
Z. B.: Befehlszeile des Anwendungsprogramms = {Appl:ApplExe}

Felder der benutzerdefinierten Befehle

{ApplCmd:FieldName[,FormatParameter]}
Z. B.: Befehlszeile des Anwendungsprogramms = {ApplCmd:Cmd.ApplExe}

Felder der zusätzlichen Dateierweiterungen

{FileExt:FieldName[,FormatParameter]}

Felder der Vorlagendateien

{Template:FieldName[,FormatParameter]}

Format-Parameter

Mit dem optionalen Formatparameter können Sie Teile aus einer Variablen extrahieren: z. B. Teile eines Dateinamen, des Projektes oder einer kombinierten Datum- und Zeitvariablen.

Kommentarzeilen

Zeilen, die mit # beginnen, und leere Zeilen werden ignoriert. Siehe auch Sonderzeichen.

Bedingte Ausführung

{IF:Bedingung}Anweisungen{ENDIF}: Anweisung für bedingte Ausführung.

{GetFirstNotEmpty:Parameter-Liste}: gibt den ersten, nicht leeren Parameter zurück.

{GetFirstExistingFile:Parameter-Liste}: gibt den ersten Parameter zurück, der den Namen einer vorhandenen Datei enthält.

Liste aller Variablen und Funktionen

AcadArchiveUpdateAttributes

AcadComNewDwg

AcadGetAttributes

AcadGetLayoutNames

AcadSetAttributes

AcroExchGetTextFromRect

AcroExchMergeDocuments

AddDoc

AddDocEx

AddSysTask

AddToDo

AdoDestroy

AdoGetField

AdoGetFieldValues

AdoOperation

AdoRecordCount

AdoSetConnection

AdoSetField

AdoViewTable

AdminINI

Appl

ApplCmd

ArchiveDocument

AutoCaptAzureAI

AutoCaptCreate

AutoCaptCreateTxt

AutoCaptDefault

AutoCaptDestroy

AutoCaptDocumentText

AutoCaptFtiText

AutoCaptFindDate

AutoCaptFindMask

AutoCaptFirstCrspWord

AutoCaptKeywordValue

AutoCaptFtiWord

AutoCaptSelectionListFindItem

AutoCaptEInvoice

CachedDoc

Calculate

ChangeDir

Chr

CombineDocuments

ComCreateNewDocument

Contact

ContactSearch

CopyDocFile

CopyFile

CopyToClipboard

CreateDir

CreateDocFromTemplate

CreateDocVers

CreateKey

CreateKeyStr

CreateLnkFile

CSVFindRow

CSVGetCell

CurrApplExe

CurrDatabase

CurrDocFileName

CurrTableView

DatasetReport

Date

DBCheckFieldValue

DBLocate

DBLookup

DBOperation

DBSearch

DBSetField

DDECloseLink

DDEOpenLink

DDESendLine

DDESendMacro

DDESetExeParam

DeleteFile

Dest

Doc

DocArch

Document

DocumentSearch

DocVers

DxfCreateFrame

ExcelGetCell

ExcelSetCell

ExecDirDlg

ExecInputQuery

ExecOpenDlg

ExecPrintDlg

ExecSaveDlg

ExecSQL

ExecSQLScalar

ExecStringDlg

ExecuteDocuments

ExecuteGPT

ExecuteMacroFile

ExecuteOCR

Exit

ExtractAttachment

ExtractDocumentText

ExtractImages

ExtractPages

FDDestroy

FDGetField

FDGetFieldValues

FDOperation

FDRecordCount

FDSetConnection

FDSetField

FDTableNames

FDViewTable

FieldAttribute

FieldInfo

FileAttr

FileConvert

FileExecuteMacro

FileExists

FileExt

FilePageCount

FileSecureTakeOwnership

FileSecureSetRights

FileSetAttr

FldTempl

Format

FtiFindMask

FtiGetFirstCrspWord

FtiGetKeywordValue

FtiGetWord

FtiUpdate

GetBackupFileName

GetControl

GetFirstExistingFile

GetFirstNotEmpty

GetPrivVar

GetPublVar

GetTempFileName

GridDocClearSelection

GridDocSelect

GridDocSelectedCount

GridSelectedCell

GridSortOrder

GUID

HelpContext

IF

IfThen

ImgCalcDensityHistogram

ImgExtractMetaWords

ImgGetBlackDotsRatio

ImgGetProperty

ImgGetTextFromRect

ImgReadBarcode

ImgWriteProperty

ImportAbort

ImportFile

IncludeMacroFile

InifileOperation

InifileReadSection

InifileReadStr

InifileWriteStr

LastAppendedDocID

LoadLanguageFile

MailGetProperty

MapiCreateEMail

MegaCreateFrame

MergeDocuments

MessageBeep

MessageDlg

MessageDlgCB

MinimizeApplication

MoveFile

OleDocumentSummaryInformation

OleMessageRegisterFilter

OleMessageRevokeFilter

OleSummaryInformation

OleUserDefinedProperties

OleSetDocumentSummaryInformation

OleSetSummaryInformation

OleSetUserDefinedProperties

OmAPI

OmApiCsvParams

OpenDatabase

OpenDlg
OpenDocument
Ord

OS

PackFiles

PasteFromClipboard

PDFAddComment

PDFAddStamp

PDFGetTextFromRect

PDFProtectDocument

ProcessMessages

RaiseError

ReadAdminIni

ReadIdentNo

ReadLnFile

ReadShortcutURL

RecordCount

RecoverDocument

RegistryReadInt

RegistryReadStr

RegistryWriteInt

RegistryWriteStr

SaveAsPDF

SaveAsWebarchive

SaveDlg

SaveLanguageFile

ScanSnap

ScriptControl

ScriptControlSetOption

SearchField

SearchGridSelection

SelectDocVersions

SelectionListFindItem

Self

SendKey

SendKeyStr

SendMouseClick

SetActiveApplication

SetComApplName

SetControl

SetPrivVar

SetPublVar

SetStayOnTop

Scheduler

ShellExecute

ShowApplication

SignDocument

Source

SplitDocument

StoreHashesOnBlockchain

StringReplace

Template

UpdateDocAttributesFromFile

UploadFile

Wait

WaitForApplication

WaitForFile

WinAPI

WriteJournal

WriteLnFile

WriteStatusbar

Siehe auch

Makro-Editor

Zugriff aus Fremdprogrammen

COM-Referenz


Sonderzeichen

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

Sonderzeichen

Sonderzeichen in der Office Manager-Makrosprache

1. Kommentarzeilen

Zeilen, die mit # beginnen, werden ignoriert.

2. Klammern

Makrovariablen und -Funktionen werden in geschweiften Klammern { } eingeschlossen. Wenn es erforderlich ist, diese Klammern als Text innerhalb eines Makros auszugeben, sollten Sie die Chr-Variable verwenden, um Komplikationen zu verhindern:

Statt "{" geben Sie bitte "{Chr:123}" und statt "}" bitte "{Chr:125} ein.

3. Kommata

Die Parameter der Makrovariablen und -Funktionen werden mit einem Komma "," getrennt. Wenn ein Parameter das Komma im Text benötigt, dann verwenden Sie bitte die Variable {Chr:44}. Siehe auch Komma-Problem.


Formatparameter Datei und Text

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

Formatparameter Datei und Text

Format-Parameter für Dateivariablen und Texte

Mit dem optionalen Formatparameter können Sie Teile aus einer Variablen extrahieren: z. B. Teile eines Dateinamen, des Projektes oder einer kombinierten Datum- und Zeitvariablen.

Format-Parameter:

AsUNC: Datei im UNC-Format (z. B. "\\Server\Freigabe\Daten\Texte\Angebote\Datei.txt").

ChangeExt,ext: Dateiendung ändern

CharToOem: Konvertiert den Text in den OEM-Zeichensatz (ASCII). Ist z. B. für ältere MegaCAD-Versionen erforderlich.

Clean: Ersetzt Zeilenumbrüche und Tabulatoren durch Leerzeichen, trimmt den Text und ersetzt mehrfache Leerzeichen durch einfache.

CleanSpaces: Entfernt mehrfache Leerzeichen sowie Leerzeichen am Zeilenanfang und -ende in mehrzeiligem Text.

CopyChar: Einzelne Zeichen der Variablen. CopyChar müssen 6 Zahlen oder '-' und 6 Zahlen folgen. Die ersten 3 Zahlen geben den Startpunkt an, die letzten 3 Zahlen die Anzahl Zeichen.
Schreiben Sie z. B. "CopyChar012003" um die Zeichen 12 bis 15 zu erhalten.
Oder "CopyChar-002002" für die beiden letzten Zeichen.

DataType: nur für Datenfelder mit Selektion Current. Der zurückgegebene Text beschreibt den Typ des Datenfeldes, z. B. "ftWideString".

DataTypeOrd: nur für Datenfelder mit Selektion Current. Ordinalwert des Datenfeldtypen (kann in verschiedenen Programmversionen unterschiedlich sein).

Date: Extrahiert den Datumsteil aus einer kombinierten Datum-, Zeitvariablen (s. a. Variable Date).

Dir: Der Dateipfad ohne Laufwerksangabe und abschließendem Backslash (z. B. "Daten\Texte\Angebote").

DirPart,n,m: Ein Teil des Dateipfades. Es werden die Verzeichnisebenen von n bis m zurückgegeben. Wenn n oder m negativ sind, erfolgt die Zählung von hinten.
Bei temporären Dateien ist die Rückgabe immer leer.
Beispiele:
- "DirPath,2,2" gibt die 2. Verzeichnisebene zurück, also "Texte" von der Datei "C:\Daten\Texte\Angebote\Datei.txt"
- "DirPart,1,2" ergibt "Daten\Texte"
- "DirPart,-1,-1" ergibt die letzte Ebene "Angebote"
- "DirPart,-1,-3" ergibt "Daten\Texte\Angebote"
- "DirPart,1,-1" ergibt alle Ebenen (von erster bis letzter), entspricht also dem Parameter Dir.

File: Der Dateiname ohne Pfad, mit Dateiendung wird zurückgegeben (z. B. "Datei.txt").

FileDir: Der Dateipfad ohne abschließendem Backslash (z. B. "C:\Daten\Texte\Angebote").

FileDrive: Die Laufwerksangabe des Dateinamen (z. B. "C:" oder "\\Server\Freigabe").

FileExt: Die Dateiendung ohne den Punkt (z. B. "txt").

FileName: Der komplette Dateiname mit Pfad und Dateiendung (z. B. "C:\Daten\Texte\Angebote\Datei.txt"). Der Parameter FileName ist die Standard-Vorgabe und braucht nicht angegeben werden. Die Rückgabe von {Doc:FileName} entspricht {Doc:FileName,FileName}

FilePath: Der Dateipfad mit abschließendem Backslash (z. B. "C:\Daten\Texte\Angebote\").

FillLeft: Füllt die Variable mit einem angegebenen Zeichen auf, bis eine vorgegebene Länge erreicht ist. FillLeft müssen 3 Zahlen und ein Zeichen folgen. Z. B.: Sie möchten die Dokument-Schlüsselnummer achtstellig mit führenden Nullen erhalten: {Doc:DocID,FillLeft0080}. "008" steht für achtstellig, die folgende "0" beschreibt das Zeichen, mit dem die Variable linksbündig gefüllt wird.

FillRight: Wie FillLeft, die Variable wird jedoch mit folgenden Zeichen aufgefüllt.

FirstChars: Gibt das erste Zeichen des Textes zurück. Bei Backslash-getrennten Texten (z. B. Attribute mit strukturierter Liste) wird das erste Zeichen jeder Ebene zurück gegeben.
Beispiel: {Format:Buchhaltung\Ausgangsrechnung,FirstChars} gibt "BA" zurück.

FirstCrspWord,Words: Gibt das zuerst vorkommende Wort aus der punktgetrennte Liste Words zurück. Dieser Parameter ist für den Import großer Dateimengen geeignet, um beispielsweise die Kategorie (Angebot, Rechnung u. a.) aus dem Dateinamen zu ermitteln.
Beispiel: {Source:FirstCrspWord,{FieldAttribute:DocDB,Category,Pickitems,.}}
Siehe auch FtiGetFirstCrspWord

IncludeTrailingBackSlash: Stellt sicher, dass der Pfadname mit einem "\" endet.

Length: Gibt die Zeichenanzahl des Textes zurück.

Line,Number: Gibt die mit Number angegebene Zeile eines mehrzeiligen Textes zurück. Negative Nummern zählen von hinten, -1 ist z.B. die letzte Zeile.

LineIE,Number: Wie Line, jedoch werden alle leeren Zeilen (auch Zeilen, die nur Leerzeichen enthalten) ignoriert.

Main: Gibt den Teil bis vor den ersten "\" zurück. {Doc:Project,Main} extrahiert z. B. das Hauptprojekt bei untergliederten Projekten.

Name: Der Dateiname ohne Pfad und ohne Dateiendung (z. B. "Datei").

NoExt: Der Dateiname mit Pfad, ohne Dateiendung (z. B. "C:\Daten\Texte\Angebote\Datei").

NoSpace: Entfernt alle Leerzeichen. Siehe auch Clean und Trim.

OemToChar: Konvertiert den OEM-Text (ASCII) in ANSI oder Unicode.

Quote: Setzt den Dateinamen bzw. Text in doppelte Anführungszeichen, wenn er Leerzeichen enthält.

QuoteEver: Setzt den Dateinamen bzw. Text immer in doppelte Anführungszeichen.

Separate,Char,Pos[,Default]: Gibt Teile des Dateinamen bzw. Textes zurück. Char gibt das Trennzeichen und Pos die Nummer des gewünschten Teils an. Als Trennzeichen ist nur ein einfaches Zeichen möglich. Der optionale Parameter Default wird als Rückgabewert verwendet, falls das Trennzeichen nicht vorhanden ist.
Tipp: für mehrere Zeichen vorher StringReplace aufrufen. Beachten Sie, dass bei Dateinamen der komplette Pfad interpretiert wird.
Siehe auch Beispiele und Formatparameter Line.

SeparateName,Char,Pos: Wie Separate, allerdings wird nur der Dateiname ohne Pfad und Endung interpretiert.

SqlEscapeGUID: Nur für Datenfeld-Variablen. Die GUID-Datenfelder haben in den unterstützten Datenbankformaten unterschiedliche Datentypen. Mit SqlEscapeGUID wird ein GUID-Feldwert für eine SQL-Abfrage formatiert, beispielsweise {doc:contactguid,sqlescapeguid}.

Time: Extrahiert den Zeitteil aus einer kombinierten Datum-, Zeitvariablen.

ToLower: Gibt den Text in Kleinbuchstaben zurück.

ToUpper: Gibt den Text in Großbuchstaben zurück.

Trim: Entfernt alle Leer- und Steuerzeichen am Anfang und Ende des Textes. Siehe auch Clean und NoSpace.

TrimLeft: Entfernt alle Leer- und Steuerzeichen am Anfang des Textes.

TrimRight: Entfernt alle Leer- und Steuerzeichen am Ende des Textes.

Validate: Entfernt alle ungültigen Zeichen aus einem kompletten Dateinamen und vereinfacht mehrfache Leerzeichen.

Validate2: Entfernt alle ungültigen Zeichen aus einem Dateinamen ohne Pfad und ohne Endung. Entfernt z. B. auch ".", "\", ":"

Validate3: Hoch kompatibler Dateiname ohne Pfad und Endung. Erlaubt nur a bis z, A bis Z, Ziffern, Unter- und Bindestriche. Ersetzt Leerzeichen durch Bindestriche, ersetzt Umlaute und Eszett durch Umschreibungen (ä=ae, ß=ss). Entfernt alle anderen Zeichen.

Values,Name: Für mehrzeiligen Text mit der Syntax "Name=Value", siehe auch Beispiele.

%...: Format-Strings %d, %u, %x, %e, %f, %g, %n, %m, %s.
Syntax: "%" [Index ":"] ["-"] [Breite] ["." Genauigkeit] Typ
Mögliche Typen:
%d: Dezimal. Wenn der Format-String einen Bezeichner für die Genauigkeit enthält, muss der resultierende String mindestens die angegebene Anzahl von Stellen aufweisen. Enthält er weniger Stellen, wird der String auf der linken Seite mit Nullen aufgefüllt.
%e: Wissenschaftliche Notation für Gleitkommawerte. Der Wert wird in einen String mit der folgenden Form umgewandelt: "-d,ddd...E+ddd". Die Gesamtzahl der Stellen im Ergebnis wird durch den Genauigkeitsbezeichner festgelegt.
%f: Fest. Das Argument muss ein Gleitkommawert sein. Der Wert wird in einen String mit der folgenden Form umgewandelt: "-ddd,ddd...". Die Anzahl der Stellen nach dem Dezimalkomma wird durch den Genauigkeitsbezeichner festgelegt. Beispiel: "%8.2f"
%g: Allgemein. Das Argument muss ein Gleitkommawert sein. Der Wert wird unter Verwendung des Formats Fest oder wissenschaftliche Notation in den kürzestmöglichen Dezimal-String umgewandelt.
%m: Währung. Das Argument muss ein Gleitkommawert sein. Der Wert wird in einen String umgewandelt, der einen Währungsbetrag darstellt. Die Steuerung der Konvertierung erfolgt mit Hilfe der Windows-Ländereinstellungen.
%n: Zahl. Das Argument muss ein Gleitkommawert sein. Der Wert wird in einen String mit der folgenden Form umgewandelt: "-d.ddd.ddd,ddd...". Das Format "n" entspricht dem Format "f", allerdings enthält der resultierende String Tausendertrennzeichen.
%s: String. Das Argument muss ein Zeichen, ein String oder ein PChar-Wert sein. Der String bzw. das Zeichen wird anstelle des Formatbezeichners eingefügt. Wenn im Format-String ein Genauigkeitsbezeichner angegeben ist, bestimmt er die maximale Länge des resultierenden Strings. Ist das Argument ein String, der diese Maximallänge überschreitet, wird der String abgeschnitten.
%u: Vorzeichenlose Dezimalzahl. Das Format "u" entspricht dem Format "d", allerdings enthält der resultierende String kein Vorzeichen.
%x: Hexadezimal. Der Wert wird in einen String umgewandelt, der aus hexadezimalen Stellen besteht. Wenn der Format-String einen Bezeichner für die Genauigkeit enthält, muss der resultierende String mindestens die angegebene Anzahl von Stellen aufweisen. Enthält er weniger Stellen, wird der String auf der linken Seite mit Nullen aufgefüllt.

Hinweis: Wenn Sie keinen oder einen falschen Parameter angeben (z. B. durch einen Schreibfehler), dann wird der Parameter ignoriert und der komplette Text bzw. Dateiname zurückgegeben.

Beispiele:

{Doc:Filename}: Es ist kein Formatparameter angegeben. Die Variable liefert den kompletten Dateinamen des Dokumentes zurück: "C:\Daten\Datei.txt".

{Doc:Filename,Name}: Die Variable liefert nur "Datei" zurück.

{Appl:ApplExe,Path}: Das Verzeichnis des Anwendungsprogramms wird zurück gegeben: "C:\Programme\Editor".

{ExecSaveDlg:Textdatei|*.txt,Name}: Der Dateiname ohne Endung, den der Benutzer im Speichern-Dialog eingegeben hat: "Datei".

{Doc:CreateDate,Date}: Liefert nur das Datum der Dokumenterstellung zurück.

{Doc:Name,CopyChar008007}: Gibt "Manager" aus "Office Manager DMS" zurück.

{Doc:Notes,Values,Name}: Gibt "Das ist mein Name" zurück, wenn in den Notizen eine Zeile "Name=Das ist mein Name" enthalten ist.

Siehe auch

Makro-Referenz

Format

Formatparameter für Datum

Komma-Problem


Formatparameter für Datum

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

Formatparameter für Datum

Formatierung von Datums-/Zeitwerten

Mit dem Parameter wird bei der Konvertierung von Datums- und Zeitwerten deren Format festgelegt.

Einfache Formatparameter

ArchiveSqlDT gibt Datum/Zeit als Escape-Sequenz für die Archiv-Datenbank zurück: "{dt yyyy-mm-dd hh:nn:ss}".

ApplSqlDT gibt Datum/Zeit als Escape-Sequenz für die Anwendungsdatenbank zurück.

Year4 gibt das Jahr vierstellig zurück, z. B. "2008".

DayOfTheWeek gibt 1 bis 7 zurück. 1 entspricht Montag (ISO 8601-konform).

DayOfTheMonth gibt den Tag des Monats zurück. Mögliche Werte sind 1 bis 31.

DayOfTheYear gibt den Tag des Jahres zurück, 1 entspricht dem 1. Januar.

HourOfTheDay gibt die Stunde des Tages zurück. Mögliche Werte sind 0 bis 23.

MonthOfTheYear gibt den Monat zurück. Mögliche Werte sind 1 bis 12.

WeekOfTheMonth gibt die Woche des Monats zurück. Mögliche Werte sind 1 bis 6.

WeekOfTheYear gibt die Woche des Jahres zurück. Mögliche Werte sind 1 bis 53.

QuarterOfTheYear gibt das Quartal des Jahres zurück. Mögliche Werte sind 1 bis 4.

QuarterOfTheYearEx gibt das Quartal des Jahres gefolgt von einem Bindestrich und der zweistelligen Jahreszahl zurück (z. B. "2-06").

Erweiterte Formatierung

Die folgende Übersicht enthält die Formatbezeichner in Kleinbuchstaben. Die Groß-/Kleinschreibung in Formaten wird nur bei den Bezeichnern "am/pm" und "a/p" berücksichtigt.

Bezeichner Anzeige

c Zeigt das Datum in dem in der globalen Variable ShortDateFormat angegebenen Format an. Dahinter wird die Uhrzeit, in dem in der globalen Variable LongTimeFormat festgelegten Format dargestellt. Die Uhrzeit erscheint nicht, wenn der Datums-/Zeitwert exakt Mitternacht ergibt.
d Zeigt den Tag als Zahl ohne führende Null an (1-31).
dd Zeigt den Tag als Zahl mit führender Null an (01-31).
ddd Zeigt den Wochentag als Abkürzung (Son-Sam) in den in der globalen Variable ShortDayNames festgelegten Strings an.
dddd Zeigt den ausgeschriebenen Wochentag (Sonntag-Samstag) in den in der globalen Variable LongDayNames festgelegten Strings an.
ddddd Zeigt das Datum in dem in der globalen Variable ShortDateFormat angegebenen Format an.
dddddd Zeigt das Datum in dem in der globalen Variable LongDateFormat angegebenen Format an.
m Zeigt den Monat als Zahl ohne führende Null an (1-12). Wenn der Bezeichner m unmittelbar hinter dem Bezeichner h oder hh steht, wird anstelle des Monats die Minute angezeigt.
mm Zeigt den Monat als Zahl mit führender Null an (01-12). Wenn der Bezeichner mm unmittelbar hinter dem Bezeichner h oder hh steht, wird anstelle des Monats die Minute angezeigt.
mmm Zeigt den Monatsnamen als Abkürzung (Jan-Dez) in den in der globalen Variable ShortMonthNames festgelegten Strings an.
mmmm Zeigt den ausgeschriebenen Monatsnamen (Januar-Dezember) in den in der globalen Variable LongMonthNames festgelegten Strings an.
yy Zeigt das Jahr als zweistellige Zahl an (00-99).
yyyy Zeigt das Jahr als vierstellige Zahl an (0000-9999).
h Zeigt die Stunde ohne führende Null an (0-23).
hh Zeigt die Stunde mit führender Null an (00-23).
n Zeigt die Minute ohne führende Null an (0-59).
nn Zeigt die Minute mit führender Null an (00-59).
s Zeigt die Sekunde ohne führende Null an (0-59).
ss Zeigt die Sekunde mit führender Null an (00-59).
z Zeigt die Millisekunde ohne führende Null an (0-999).
zzz Zeigt die Millisekunde mit führender Null an (000-999).
t Zeigt die Uhrzeit in dem in der globalen Variable ShortDateFormat angegebenen Format an.
tt Zeigt die Uhrzeit in dem in der globalen Variable LongDateFormat angegebenen Format an.
am/pm Verwendet die 12-Stunden-Zeitanzeige für den vorhergehenden Bezeichner h oder hh und zeigt alle Stunden vor Mittag mit dem String "am" und alle Stunden nach Mittag mit dem String "pm" an. Für den Bezeichner am/pm können Kleinbuchstaben, Großbuchstaben und jede Kombination davon angegeben werden.
a/p Verwendet die 12-Stunden-Zeitanzeige für den vorhergehenden Bezeichner h oder hh und zeigt alle Stunden vor Mittag mit dem Zeichen "a" und alle Stunden nach Mittag mit dem Zeichen "p" an. Für den Bezeichner a/p können Kleinbuchstaben, Großbuchstaben und jede Kombination davon angegeben werden.
ampm Verwendet die 12-Stunden-Zeitanzeige für den vorhergehenden Bezeichner h oder hh und zeigt alle Stunden vor Mittag mit dem String aus der globalen Variable TimeAMString und alle Stunden nach Mittag mit dem String aus der globalen Variable TimePMString an.
/ Zeigt als Datumstrennzeichen das in der globalen Variable DateSeparator angegebene Zeichen an.
: Zeigt als Uhrzeittrennzeichen das in der globalen Variable TimeSeparator angegebene Zeichen an.
'xx'/"xx" Zeichen, die in einfache oder doppelte Anführungszeichen eingeschlossen sind, werden ohne spezielle Formatierung übernommen.

Beispiel

{Date:Now,Year4}

{Date:{Doc:FileName},dd.mm.yyyy}

Siehe auch

Makro-Referenz

Format

Date

Formatparameter für Dateien


AcadArchiveUpdateAttributes

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

AcadArchiveUpdateAttributes

Verfügbar in diesen Editionen

Makro-Prozedur AcadArchiveUpdateAttributes

Alle AutoCAD-Zeichnungsdatensätze der aktuellen Suche mit den Zeichnungen abgleichen.

Syntax

{AcadArchiveUpdateAttributes[:IniFileName]}

Optionaler Parameter

IniFileName kann den Dateinamen der acad.ini enthalten. Wenn nicht angegeben, wird die Standarddatei acad.ini im Verzeichnis der gemeinsamen Dateien verwendet. Sie können die Datei auch ohne Pfad angeben, sie wird dann in den gemeinsamen Dateien erwartet.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Diese Prozedur ruft AcadGetAttributes für alle Zeichnungen auf, die derzeit im Archiv abgefragt sind. Die Archivattribute werden aus der Zeichnungsdatei gelesen und die entsprechenden Datenfelder geschrieben.

Siehe auch

Makro-Referenz

AcadGetAttributes


AcadComNewDwg

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

AcadComNewDwg

Verfügbar in diesen Editionen

Makro-Prozedur AcadComNewDwg

Erstellt eine neue AutoCAD-Zeichnung mit Schriftkopf.

Syntax

{AcadComNewDwg:Frame,X,Y,Z,Scale}

Parameter

Frame: Dateiname des Schriftkopfs.

X, Y, Z: Einfüge-Koordinaten des Schriftkopf.

Scale des Schriftkopf. Die Fließkommazahl wird an die AutoCAD Automatisierungs-Funktion "InsertBlock" gegeben.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Prozedur erstellt eine neue AutoCAD-Zeichnung mittels COM-Automatisierung (OLE). Die Schriftkopfdatei wird als Block eingefügt und die Attribute im Schriftkopf (Zeichnungsname u. a.) gesetzt. Die Zuordnung der AutoCAD- und Archiv-Attribute wird in der Datei acad.ini im Verzeichnis der gemeinsamen Dateien definiert.

In Zusammenhang mit den Funktionen AcadGetAttributes und AcadSetAttributes wird eine dynamische Verbindung zu AutoCAD realisiert: Änderungen am AutoCAD-Schriftkopf werden im Office Manager übernommen, Änderungen im Office Manager-Archiv werden im Schriftkopf übernommen.

Beispiel

{AcadComNewDwg:G:\dwgs\Schriftkopf.dwg,100,100,0,1}

Siehe auch

Makro-Referenz

AcadGetAttributes

AcadSetAttributes


AcadGetAttributes

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

AcadGetAttributes

Verfügbar in diesen Editionen

Makro-Prozedur AcadGetAttributes

Liest Attribute aus der AutoCAD-Zeichnung und aktualisiert die Datenfelder im Archiv.

Syntax

{AcadGetAttributes[:IniFileName]}

Optionaler Parameter

IniFileName kann den Dateinamen der acad.ini enthalten. Wenn nicht angegeben, wird die Standarddatei acad.ini im Verzeichnis der gemeinsamen Dateien verwendet. Sie können die Datei auch ohne Pfad angeben, sie wird dann in den gemeinsamen Dateien erwartet.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt. Die gelesenen Daten werden direkt in die Datenfelder übernommen.

Beschreibung

Die Prozedur liest die AutoCAD-Attribute mittels COM-Automatisierung (OLE) aus der aktuellen Zeichnung und aktualisiert die Datenfelder im Office Manager-Archiv entsprechend. Die Zuordnung der AutoCAD- und Archiv-Attribute wird in der Datei acad.ini im Verzeichnis der gemeinsamen Dateien definiert.

In Zusammenhang mit AcadSetAttributes und AcadComNewDwg wird eine dynamische Verbindung zu AutoCAD realisiert: Änderungen am AutoCAD-Schriftkopf werden im Office Manager übernommen, Änderungen im Office Manager-Archiv werden im Schriftkopf übernommen.

Siehe auch

Makro-Referenz

AcadGetLayoutNames

AcadComNewDwg

AcadSetAttributes

AcadArchiveUpdateAttributes


AcadGetLayoutNames

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

AcadGetLayoutNames

Verfügbar in diesen Editionen

Makro-Prozedur AcadGetAttributes

Liest die Layout-Namen aus der aktuellen Zeichnung.

Syntax

{AcadGetLayoutNames}

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt. Die gelesenen Daten werden in das Datenfeld geschrieben.

Beschreibung

Liest die Layout-Namen mittels COM-Automatisierung aus der aktuellen Zeichnung und speichert diese in das Archiv-Datenfeld ACADLAY. Die Prozedur wird nicht ausgeführt, wenn das Datenfeld nicht vorhanden ist.

Siehe auch

Makro-Referenz

AcadGetAttributes


AcadSetAttributes

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

AcadSetAttributes

Verfügbar in diesen Editionen

Makro-Prozedur AcadSetAttributes

Aktualisiert die Attribute in der aktuellen AutoCAD-Zeichnung entsprechend den neuen Attributen im Archiv.

Syntax

{AcadSetAttributes[:IniFileName]}

Optionaler Parameter

IniFileName kann den Dateinamen der acad.ini enthalten. Wenn nicht angegeben, wird die Standarddatei acad.ini im Verzeichnis der gemeinsamen Dateien verwendet. Sie können die Datei auch ohne Pfad angeben, wenn sie in den gemeinsamen Dateien abgelegt ist.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

In Zusammenhang mit den Funktionen AcadGetAttributes und AcadComNewDwg wird eine dynamische Verbindung zu AutoCAD realisiert: Änderungen am AutoCAD-Schriftkopf werden im Office Manager übernommen, Änderungen im Office Manager-Archiv werden im Schriftkopf übernommen.

Siehe auch

Makro-Referenz

AcadComNewDwg

AcadGetAttributes


AcroExchGetTextFromRect
PDFGetTextFromRect

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

AcroExchGetTextFromRect
PDFGetTextFromRect

Makro-Funktion AcroExchGetTextFromRect (nur Enterprise-Edition)
Makro-Funktion PDFGetTextFromRect (alle Editionen)

Liest Text von einer fest vorgegebenen Position in PDF-Dokumenten.

Syntax

{AcroExchGetTextFromRect:FileName,PageNum,Left,Right,Bottom,Top,Relative[,ReplaceFrom,ReplaceTo,DebugInfo]}

{PDFGetTextFromRect:FileName,PageNum,Left,Right,Bottom,Top,Relative[,ReplaceFrom,ReplaceTo,DebugInfo]}

Parameter

FileName: Dateiname des Dokumentes, z. B. {CurrDocFileName} oder {Source}.

PageNum: Seitennummer "1" für Seite 1 usw. "-1" für die letzte, "-2" für die vorletzte usw.
Während einer Stapeltrennung mit Makros könne Sie mit StackScanPage auf die aktuelle Seite zugreifen.

Left, Right, Bottom, Top: Definiert ein Rechteck auf der Seite, in dem sich der zu extrahierende Text befindet. Left und Right geben den Abstand vom linken Seitenrand, Bottom und Top den Abstand vom unteren Rand an. Es sind nur ganze Zahlen erlaubt. Tipp: der Wert von Bottom ist immer kleiner als Top, Left ist kleiner als Right.
Die beiden Funktionen unterscheiden sich bei der Ermittlung, welcher Text im Rechteck enthalten ist. Die Acrobat-Funktion schneidet den Text so aus, als wäre die Seite ein Bild. PDFGetTextFromRect hingegen prüft bei jedem Wort des Dokuments, ob dieses vollständig vom Rechteck umschlossen ist und gibt die enthaltenen Wörter mit Leerzeichen getrennt zurück..

Relative: 0, 1 oder 2. Bei 0 wird das Rechteck in der Maßeinheit des PDF-Dokuments (z. B. absolute Pixel) angegeben.
Bei 1 enthalten Left, Right, Bottom und Top prozentuale Werte, wobei Left=10 beispielsweise 10% der Seitenbreite angibt. Berechnungsbeispiel für A4-Seitenbreite: Prozentwert = Runden([mm von links] x 100 / 210).
2 ist ebenfalls relativ, jedoch mit einer berechneten Auflösung von 10.000 statt 100. Berechnungsbeispiel für A4-Seitenbreite: Wert = Runden([mm von links] x 10000 / 210).

Optionale Parameter:

ReplaceFrom, ReplaceTo: Mit diesen optionalen Parametern kann eine Textersetzung (s. a. StringReplace) durchgeführt werden.
Beispiel: {AcroExchGetTextFromRect:...,1,{Chr:13}{Chr:10},-} ersetzt alle Zeilenumbrüche durch einen Bindestrich.
Es müssen beide Parameter angegeben werden: {PDFGetTextFromRect:...,1,-,} würde z. B. Bindestriche entfernen.

DebugInfo: 0 oder 1. Bei 1 wird eine temporäre PDF-Datei geöffnet, in welcher Sie den angegebenen Ausschnitt überprüfen können. Der Parameter sollte nach erfolgreichen Tests wieder entfernt oder auf 0 gesetzt werden.

Rückgabewert

Dokumententext, der sich im definierten Rechteck befindet.

Beschreibung

Die Funktion gibt den Text zurück, der sich innerhalb des angegebenen Rechtecks im PDF-Dokument befindet. Sie wird beispielsweise beim Scannen oder Importieren für eine Formularerkennung verwendet, um die Dokumentattribute, wie Kategorie oder Kundenname, automatisch zu erfassen. Bei gescannten Dokumenten muss zuvor eine OCR-Texterkennung ausgeführt werden, welche die erkannten Texte wortgenau hinter dem Pixelbild positioniert..

AcroExchGetTextFromRect nutzt einen installierten Adobe Acrobat, PDFGetTextFromRect wird mit programminternen Funktionen ausgeführt.

Beispiele

Das Adressfeld im aktuell markierten Dokument einlesen und zur Kontrolle das Rechteck in einer Debug-Datei einblenden:

{AcroExchGetTextFromRect:{CurrDocFileName},1,7,40,70,90,1,,,1}

{PDFGetTextFromRect:{CurrDocFileName},1,7,40,70,90,1,,,1}

Systemvoraussetzungen für AcroExchGetTextFromRect

Office Manager Enterprise-Edition

Adobe Acrobat-Vollversion

Siehe auch

Tipps zu AcroExch-Funktionen

Makro-Referenz

Automatische Belegerkennung

ImgGetTextFromRect

ExtractDocumentText

Scan-Profile


AcroExchMergeDocuments
MergeDocuments

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

AcroExchMergeDocuments
MergeDocuments

Makro-Prozedur AcroExchMergeDocuments (nur Enterprise-Edition)
Makro-Prozedur MergeDocuments (alle Versionen)

Erstellt ein neues PDF-Dokument aus mehreren Einzeldokumenten.

Syntax

{AcroExchMergeDocuments:DestFile,ErrorMode,SrcFiles}

{MergeDocuments:DestFile,ErrorMode,SrcFiles}

Parameter

DestFile: Dateiname des neuen Dokuments.

ErrorMode: Bei "1" wird die Funktion mit einem Fehler abgebrochen, wenn eine Quelldatei nicht vorhanden ist oder im falschen Format vorliegt. Bei "0" werden fehlerhafte Quelldateien übersprungen.

SrcFiles: Liste der zusammenzufassenden Dateien:
- Eine kommagetrennte Auflistung von Dateinamen, wie "C:\Datei1.pdf,C:\Datei2.pdf[,...]". Hier sind auch Jokerzeichen erlaubt, wie "C:\Daten\*.pdf".
- Oder "Selected" für alle in der Tabelle markierten Dokumentdateien
- oder "Filter" für alle Dokumentdateien der aktuellen Suche.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Mit diesen Funktionen können Sie mehrere Einzeldokumente zu einem neuen Dokument zusammenfassen. Derzeit wird nur PDF unterstützt. Beachten Sie bei geschützten Dateien bitte auch, dass die Funktion beispielsweise bei "Seiten entnehmen = gesperrt" scheitert.

Die Zieldatei darf nicht vorhanden sein. Wenn eine vorhandene überschrieben werden soll, führen Sie zuvor bitte DeleteFile aus.

AcroExchMergeDocuments verwendet die Vollversion von Adobe Acrobat, MergeDocuments nutzt programminterne Funktionen.

Beispiele

{AcroExchMergeDocuments:C:\Test\Merge.pdf,1,C:\Test\Erste Datei.pdf,C:\Test\Erste Datei.pdf}

{MergeDocuments:C:\Test\Merge.pdf,1,Filter}

Systemvoraussetzungen für AcroExchMergeDocuments

Office Manager Enterprise-Edition

Adobe Acrobat-Vollversion

Siehe auch

Makro-Referenz

Tipps zu AcroExch-Funktionen

ExtractPages

AcroExchGetTextFromRect


AddDoc

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

AddDoc

Makro-Funktion AddDoc

Erstellt einen neuen Dokumentdatensatz.

Syntax

{AddDoc[:ReturnField]}

Optionaler Parameter

ReturnField gibt das Datenfeld an, durch welches die Anweisung ersetzt wird.

Rückgabewert

Leer oder Inhalt des angegebenen Datenfeldes.

Beschreibung

Die Funktion erstellt einen neuen Dokumentdatensatz und öffnet das Eigenschaftenfenster des neuen Dokuments. Es wird keine Dokumentdatei angelegt.

Das Makro wird beendet, falls der Anwender im Eigenschaftendialog auf Abbrechen klickt.

Siehe auch

Makro-Referenz

AddDocEx

CreateDocFromTemplate

DBOperation

DBSetField


AddDocEx

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

AddDocEx

Makro-Prozedur AddDocEx

Erstellt einen neuen Dokumentdatensatz mit vorgegebenen Feldwerten.

Syntax

Syntax 1: {AddDocEx}

Syntax 2: {AddDocEx:IniFile,Section}

Syntax 3: {AddDocEx:Fieldname=Text[,Fieldname=Text,...]}

Parameter

IniFile: Dateiname inkl. Pfad einer INI-Datei mit Feldnamen und -werten.

Section: Name der INI-Sektion. Die Sektionen sind in der Datei in "["-Klammern eingeschlossen, geben Sie die Sektion hier ohne die Klammern an.

Fieldname=Text: in der zweiten Syntax werden Feldnamen und -werte als kommagetrennte Liste aufgeführt. Die Feldwerte dürfen keine Kommata enthalten!

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Prozedur erstellt einen neuen Dokumentdatensatz, trägt die vorgegebenen Werte in den Datenfeldern ein und öffnet das Eigenschaftenfenster für die Eingabe weiterer Attribute. Wenn der Anwender auf OK klickt wird die Dokumentdatei erstellt und geöffnet. Das Makro wird beendet, falls der Anwender im Eigenschaftendialog auf Abbrechen klickt.

Die Prozedur kann ohne oder mit zwei unterschiedlichen Parameterlisten verwendet werden: Angabe eines Dateinamen oder Liste der Feldnamen mit Werten. Sind keine Parameter angegeben, wird Syntax 1 verwendet. Wenn im ersten Parameter eine vorhandene Datei angegeben ist die Syntax 2, andernfalls die Syntax 3.

Beispiele

{AddDocEx} ohne Vorgabe der Feldwerte.

{AddDocEx:G:\OM\Template\attributes.ini,Angebot}

Lädt die Feldwerte aus der Datei attributes.ini:

[Angebot]

ApplName=Microsoft Word-Dokument

State=Normal

{AddDocEx:ApplName=Microsoft Word-Dokument,State=Normal}

Siehe auch

Makro-Referenz

AddDoc

CreateDocFromTemplate

DBOperation

DBSetField

CreateDocVers

ArchiveDocument


AddSysTask

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

AddSysTask

Makro-Prozedur AddSysTask

Eine Systemaufgabe erstellen.

Syntax

{AddSysTask:TaskType,DocID,TaskDate[,OwnerName,ValueI,Value1]}

Parameter

TaskType: Typ der Systemaufgabe:
1100 für OCR-Texterkennung
1101 für OCR-Texterkennung und Verschlüsselung von PDF-Dokumenten
1102 für OCR-Texterkennung und digitaler Signierung von PDF-Dokumenten.
1300 für die Hinterlegung der Dokument-Hashwerte auf der Blockchain (optimale Revisionssicherheit).

DocID: Schlüsselnummer des zugeordneten Dokuments.

TaskDate: Datum und Zeit der Ausführung oder Anzahl Sekunden ab jetzt.

OwnerName: Zuständigkeit. Hier können Sie beispielsweise einen Computernamen angeben, auf dem die OCR ausgeführt werden soll. Der Client führt die Systemaufgabe nur aus, wenn OwnerName leer ist bzw. dem Computernamen oder "Benutzername@Domäne" entspricht.

ValueI: sonstiger Integer-Wert

Value1: sonstiger String-Wert

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Prozedur erstellt eine neue Systemaufgabe für eine Hintergrundfunktion, wie beispielsweise nachträgliches OCR.

OCR für Netzwerkscanner u. ä.

Mit dieser Anweisung können Sie eine nachträgliche OCR-Texterkennung für Scanner realisieren, die ihre Dokumente in einem Verzeichnis ablegen (z. B. Netzwerkscanner oder Ricoh ScanSnap):

·Deaktivieren Sie dazu die OCR des Scanners.

·Wählen Sie Datei | Optionen | Einstellungen und wechseln Sie auf die Seite Volltextindex | OCR.

·Stellen Sie dort die gewünschte OCR ein.

·Wechseln Sie auf die Seite Importieren | Profile und öffnen Sie Verzeichnisdefinition des Scanners (z. B. "ScanSnap an Rechnername").

·Geben Sie auf Seite Makros bei Nach Speichern bitte "{AddSysTask:1100,{Doc:DocID},60}" ein oder wählen Sie "OCR-Texterkennung" aus der Liste des Kombinationsfeldes.

Beispiele

{AddSysTask:1100,{Doc:DocID},22.01.2008 20:00:00}

{AddSysTask:1100,{Doc:DocID},{Date:Now,dd.mm.yyyy} 20:00:00}

{AddSysTask:1100,{Doc:DocID},60}

{AddSysTask:1100,{Doc:DocID},60,Computername}

{AddSysTask:1300,{Doc:DocID},400}

Siehe auch

Makro-Referenz

OCR manuell starten


AddToDo

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

AddToDo

Makro-Prozedur AddToDo

Eine neue Tätigkeit erstellen.

Syntax

{AddToDo:ForeignDB,ForeignKey,Name,UserName[,StartDate,Duration,Notes,Label,ReminderDate]}

Parameter

ForeignDB: GUID der verknüpften Archiv- oder Kontaktdatenbank. Oder:
"1" keine Verknüpfung
"2" mit Dokument in geöffnetem Archiv verknüpft
"3" mit Kontakt in geöffneter CRM-Datenbank verknüpft

ForeignKey: Schlüsselnummer des Dokuments oder Kontakts.

Name: Bezeichnung der Tätigkeit. Geben Sie kein Komma im Text ein.

UserName: Login-Name des Anwenders, für den die Tätigkeit erstellt wird. Neue User werden automatisch erstellt.

Optionale Parameter:

StartDate: Datum und Zeit der Tätigkeit, Vorgabewert ist die aktuelle Zeit.

Duration: Dauer in Minuten, Vorgabewert ist 10.

Notes: Ausführliche Beschreibung. Geben Sie kein Komma im Text ein.

Label: Hervorhebung mit Farbwerten:
-1: keine
8689404: Wichtig
14982788: Business
6610596: Persönlich
13952740: Urlaub
7649020: Teilnahmepflicht
16051844: Reise
8703700: Vorbereitung
16033476: Geburtstag
12897956: Jubiläum
7661308: Anruf

ReminderDate: Datum und Zeit der Erinnerung. Alternativ zum Datum können Sie die Anzahl der Tage vor dem Tätigkeitsbeginn angeben, beispielsweise "-6.5" steht für 6 Tage und 12 Stunden. Diese Syntax wird am Minuszeichen erkannt.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Syntax 2 (veraltet)

{AddToDo:Name,Type,User,Private,DocID,Popup[,TodoDate,HintDate,Period]}

Diese Syntax (erster Parameter ist keine GUID und nicht gleich "1", "2" oder "3") ist seit Version 23.0 veraltet und wird in einer zukünftigen Version entfernt. Verwenden Sie diese nicht mehr.

Beschreibung

Die Funktion erstellt eine neue Tätigkeit für den genannten User. Sinnvoll ist dies vor allem bei der zeitgesteuerten Verarbeitung der Verzeichnisüberwachung: wenn das Programm beispielsweise über Nacht die neuen Dokumente indexiert und es dabei zu Fehlern kommt, kann für den Administrator automatisch eine Tätigkeit erstellt werden. Der Administrator sieht dann am nächsten Tag die Tätigkeit zum fehlerhaften Dokument und kann entsprechend reagieren.

Die neue Aufgabe ist erst sichtbar, nachdem die Datentabelle "scheduler" neu eingelesen wurden. Dies kann mit{DBOperation:scheduler,Refresh} im Makro erfolgen oder durch Suchen in der Benutzeroberfläche.

Beispiel

{AddTodo:2,{doc:docid},Rechnung prüfen,{Self:UserName},14.09.2023 10:00:00,10}

{DBOperation:scheduler,Refresh}

Siehe auch

Makro-Referenz

DBSetField

IF-Bedingung

Aufgaben-Verwaltung


AdoDestroy
FDDestroy

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

AdoDestroy
FDDestroy

Verfügbar in diesen Editionen

Makro-Prozedur AdoDestroy
Makro-Prozedur FDDestroy

ADO- bzw. FD-Datenverbindung beenden.

Syntax

{AdoDestroy}

{FDDestroy}

Parameter

Keine

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Gibt den Speicher frei, der durch {AdoSetConnection} bzw. {FDSetConnection} belegt wurde. Der Aufruf ist nicht zwingend erforderlich, der Speicher würde auch beim Programmende freigegeben.

Siehe auch

Makro-Referenz


AdoGetField
FDGetField

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

AdoGetField
FDGetField

Verfügbar in diesen Editionen

Makro-Variable AdoGetField
Makro-Variable FDGetField

Gibt einen Datenwert zurück.

Syntax

{AdoGetField:FieldName}

{FDGetField:FieldName}

Parameter

FieldName: Name des Datenbankfeldes.

Rückgabewert

Inhalt des angegebenen Datenfeldes.

Beschreibung

Die Variable gibt den Feldwert von FieldName des aktuellen Datensatzes einer mit Ado/FD Operation geöffneten Tabelle zurück.

Siehe auch

Makro-Referenz

Beispiel ADO-Datenbank

Ado/FD GetFieldValues

Ado /FD Operation

Ado /FD SetConnection

Ado /FD SetField

Ado /FD ViewTable


AdoGetFieldValues
FDGetFieldValues

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

AdoGetFieldValues
FDGetFieldValues

Verfügbar in diesen Editionen

Makro-Variable AdoGetFieldValues
Makro-Variable FDGetFieldValues

Gibt die Werte aller Spalten zurück.

Syntax

{AdoGetFieldValues:FieldName,Separator}

{FDGetFieldValues:FieldName,Separator}

Parameter

FieldName: Name des Datenbankfeldes.

Separator: Trennzeichen für die zurückgegebenen Datensätze.

Rückgabewert

Inhalt des angegebenen Feldes aller Zeilen.

Beschreibung

Die Variable gibt die Feldwerte von FieldName aller Datensätze einer mit Ado/FD Operation geöffneten Tabelle zurück.

Siehe auch

Makro-Referenz

Beispiel ADO-Datenbank

Ado /FD GetField

Ado /FD Operation

Ado /FD SetConnection

Ado /FD SetField

Ado /FD ViewTable


AdoOperation
FDOperation

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

AdoOperation
FDOperation

Verfügbar in diesen Editionen

Makro-Prozedur AdoOperation
Makro-Prozedur FDOperation

Allgemeine Datenbank-Funktionen.

Syntax

{AdoOperation:Operation[,SQL-Anweisung]}

{FDOperation:Operation[,SQL-Anweisung]}

Parameter

Operation: auszuführende Funktion:
Append: neuen Datensatz am Ende der Tabelle hinzufügen
Cancel: Änderungen am Datensatz verwerfen
Close: schließt die Tabelle
Delete: aktuellen Datensatz löschen
Edit: aktuellen Datensatz bearbeiten
Execute SQL-Anweisung: einen SQL-Befehl ausführen, nur für AdoOperation, nicht in systemeigenen Datenbanken erlaubt
Insert: neuen Datensatz hinter dem aktuellen hinzufügen
Open SQL-Anweisung: öffnet die Datenabfrage
Post: Änderungen am Datensatz speichern

SQL-Anweisung: der SQL-Befehl, wie beispielsweise "SELECT * FROM tablename" für die Funktion "open".

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Einschränkung

Diese potenziell gefährliche Funktion ist standardmäßig gesperrt.

Beschreibung

Anweisungen an eine Datenbank, die zuvor mit Ado/FD SetConnection definiert wurde.

Siehe auch

Makro-Referenz

Beispiel ADO-Datenbank

DBOperation

Ado /FD RecordCount

Ado /FD GetField

Ado/FD GetFieldValues


AdoRecordCount
FDRecordCount

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

AdoRecordCount
FDRecordCount

Verfügbar in diesen Editionen

Makro-Variable AdoRecordCount
Makro-Variable FDRecordCount

Anzahl der Datensätze in einer geöffneten ADO-Datenbanktabelle.

Syntax

{AdoRecordCount}

{FDRecordCount}

Parameter

Keine

Rückgabewert

Datensatz-Anzahl

Beschreibung

Die Variable enthält die Anzahl der Dateisätze (Zeilen) einer Tabelle, die zuvor mit SetConnection und Open geöffnet wurde.

Siehe auch

Makro-Referenz

Beispiel ADO-Datenbank

Bedingte Ausführung


AdoSetConnection
FDSetConnection

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

AdoSetConnection
FDSetConnection

Verfügbar in diesen Editionen

Makro-Prozedur AdoSetConnection
Makro-Prozedur FDSetConnection

Mittels ADO (ActiveX Data Objects) oder FD (FireDAC) mit einer Datenbank verbinden.

Syntax

{AdoSetConnection:ConnectionStr}

{FDSetConnection:ConnectionStr}

Parameter

ConnectionStr: Verbindungsdefinition zur Datenbank.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Stellt eine Verbindung mit einer beliebigen Datenbank her.

Ein Zugriff auf die Office Manager Dokumenten-, Kontakt- oder Anwendungsdatenbank erfolgt in der Regel mit den DB...-Funktionen. Der ADO- und FD-Zugriff verwendet eigene Datenabfragen und ist vor allem für die Verbindung zu fremden Datenbanken geeignet.

Beispiel

{AdoSetConnection:Provider=MSDataShape.1;Data Provider=Microsoft.Jet.OLEDB.4.0;Data Source=G:\MeineDB.mdb}

{FDSetConnection:Provider=DriverID=SQLite;GUIDFormat=String;Synchronous=Normal;LockingMode=Normal;BusyTimeout=20000;Database=G:\MeineDB.sql}

Siehe auch

Makro-Referenz

Beispiel ADO-Datenbank

Ado /FD Destroy

Ado /FD GetField

Ado/FD GetFieldValues

Ado /FD Operation

Ado /FD SetField

Ado /FD ViewTable

FDTableNames

DBOperation


AdoSetField
FDSetField

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

AdoSetField
FDSetField

Verfügbar in diesen Editionen

Makro-Prozedur AdoSetField
Makro-Prozedur FDSetField

Text in ein Datenbankfeld schreiben.

Syntax

{AdoSetField:FieldName=Value,FieldName2=Value,...}

{FDSetField:FieldName=Value,FieldName2=Value,...}

Parameter

FieldName: Name des Datenbankfeldes.

Value: Der neue Wert des Datenbankfeldes.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Einschränkung

Diese potenziell gefährliche Funktion ist standardmäßig gesperrt.

Beschreibung

Ändert den Inhalt eines oder mehrerer Datenbankfelder. Die geöffnete Tabelle muss sich im Bearbeitungsmodus befinden.

Siehe auch

Makro-Referenz

Beispiel ADO-Datenbank

DBSetField

Ado /FD GetField

Ado/FD GetFieldValues


AdoViewTable
FDViewTable

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

AdoViewTable
FDViewTable

Verfügbar in diesen Editionen

Makro-Funktion AdoViewTable
Makro-Funktion FDViewTable

Eine Datenbanktabelle zeigen und Datensatz auswählen.

Syntax

{AdoViewTable[:Caption,ReadOnly,reserved,reserved,Separator,ResultField1,...,ResultFieldn]}

{FDViewTable[:Caption,ReadOnly,reserved,reserved,Separator,ResultField1,...,ResultFieldn]}

Optionale Parameter

Caption: Fenstertitel.

ReadOnly: Bei 0 kann die Tabelle bearbeitet werden, 1 (und alle anderen Werte) öffnen schreibgeschützt.

reserved: Zwei reservierte Parameter, geben Sie z. B. "res" ein.

Separator: Trennzeichen (auch mehrere) für die zurückgegebenen Feldwerte.

ResultField: Kommagetrennte Liste der Feldnamen, dessen Werte zurückgegeben werden sollen.

Rückgabewert

Leer oder Inhalte der im Parameter angegebenen Felder.

Beschreibung

Zeigt eine Tabelle der geöffneten ADO- bzw. FD-Datenbank in einem Fenster und erlaubt die Auswahl eines Datensatzes durch den Anwender. Die Variable kann optional die Werte der angegebenen Felder zurückgeben.

Siehe auch

Makro-Referenz

OmAPI:ViewTable

Beispiel ADO-Datenbank

Ado /FD RecordCount

Ado /FD GetField

Ado/FD GetFieldValues

Ado /FD Operation

Ado /FD SetConnection

Ado /FD SetField

FDTableNames


AdminINI

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

AdminINI

Makro-Variable AdminINI

Zugriff auf Einstellungen aus der admin.ini

Syntax

{AdminINI:Section,Ident}

Parameter

Section gibt die in eckigen Klammern eingeschlossene Sektion der INI-Datei an

Ident ist der Name der Variablen.

Rückgabewert

Die Variable wird durch den Wert der Einstellung ersetzt.

Beschreibung

Ermöglicht den Zugriff auf Programmeinstellungen, die in der admin.ini gespeichert sind. Öffnen Sie die admin.ini im Editor, um die möglichen Sektionen und Variablen zu erfahren.

Beispiel

{AdminINI:Document,DefaultFilePath}

Gibt das Standard-Dokumentenverzeichnis (z. B. C:\Office Manager DMS\Dokumente\) zurück.

Siehe auch

Makro-Referenz

ReadAdminiINI

Self


Appl

Variablen für Datenfelder

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

Variablen für Datenfelder

Makro-Variablen für Datenfelder

Zugriff auf Datenfelder des Archivs, der Kontakte und der Anwendungsdatenbank.

Syntax

{TableName:FieldName[,FormatParam,Selection,Separator]}

Parameter

TableName: Kennung der Datenbank-Tabelle. Beachten Sie bei der Enterprise-Version bitte, dass die Kennungen "Document" und "DocArch" immer auf die derzeit gewählte Dokumenttabelle verweisen.

FieldName: Name des Datenbankfeldes oder
"*RecordCount" für die Anzahl der Datensätze.
"*SelectFieldNames" für die SQL SELECT-Liste der Feldnamen. Dies ist meisten "*", bei der Dokumententabelle aber die Liste (feldname1,feldname2,...) ohne contenttext, wenn der Volltextkatalog von SQLite oder des MS SQL Servers verwendet wird.
"*FieldNames": Liste der Datenfelder getrennt mit dem angegebenen Separator.
"*SQL" für den SQL-Abfragetext, sofern die programminterne Datenbankabfrage SQL verwendet.
"*SQLWhere" für den Teil der SQL-Abfrage ab dem (ersten) WHERE-Token.

FormatParam: Mit dem optionalen Formatparameter können Sie Teile des Feldinhalts übernehmen.

Selection: Optionale Angabe einer Selektion:
"Current" oder keine Angabe bezieht sich nur auf den aktuellen Datensatz.
"Filter" gibt die Feldwerte der aktuellen Datenabfrage zurück. Bei der Dokumenttabelle ist dies die aktuelle Suche.
"Selected" nur in der Dokumenttabelle: gibt die Feldwerte der markierten Dokumente zurück.

Separator in Verbindung mit Selection und für die Feldliste mit "*FieldNames": Enthält ein oder mehrere Zeichen, mit denen die Feldwerte der Selektion getrennt werden. Das Trennzeichen wird auch am Ende angefügt. Oder spezielle Trennungen mit "csv", "csvquoted" und "json".

Rückgabewert

Die Variable wird durch den Inhalt des Datenfeldes ersetzt.

Beschreibung

Ermöglicht den Zugriff auf Datenfelder des geöffneten Dokumentenarchivs und der Anwendungsdatenbank. Wenn Selection nicht angegeben ist, wird auf den aktuellen Datensatz zugegriffen.

Beispiele:

{Doc:Project} wird standardmäßig für das Dokumentenverzeichnis verwendet, um die Dateien in der Projektstruktur abzulegen.

{Document:Name} der Name des aktuellen Dokuments aus der aktuellen Tabelle document oder docarch.

{Doc:Name} wie oben, die Dokumenttabelle kann auch abgekürzt mit "Doc" angesprochen werden.

{CachedDoc:Name} wie oben, jedoch nur in besonderen Formularen, wie z. B. dem HTML-Index einer CD.

{Document:Project,DirPart,1,1} die erste Ebene des Projekts, dem das Dokument zugeordnet ist.

{DocVers:Name} Name der aktuellen Dokumentversion, wenn eine Dokumentversion geöffnet wird.

{Appl:ApplName} Name des Dokumenttypen.

{Contact:company} Firma des aktuellen Kontakts.

{Document:FileName,Selected,{Chr:0}} gibt die Dateinamen aller markierten Dokumente nullterminiert, z. B. für einen Kopierbefehl zurück.

{Document:FileName,File,Selected,{Chr:13}} gibt die Dateinamen ohne Pfad aller markierten Dokumente zeilenweise zurück.

Siehe auch

Makro-Referenz

Datenfelder im Dokumentenarchiv und Kontaktdatenbank

FieldInfo

FieldAttribute

ExecSQLScalar

RecordCount

DBSearch

DBSetField

Datenfelder definieren


ArchiveDocument

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ArchiveDocument

Verfügbar in diesen Editionen

Makro-Funktion ArchiveDocument

Archiviert ein Dokument.

Syntax

{ArchiveDocument[:DocID,RaiseError]}

Optionale Parameter

DocID: Schlüsselnummer des zu archivierenden Dokumentes, Standard ist das aktuelle Dokument.

RaiseError: Der Standardwert '1' löst bei Fehlern eine Exception aus und beendet das Makro. '0' unterdrückt den Fehler und gibt die Fehlermeldung als Funktionsergebnis zurück.

Rückgabewert

Leerstring oder Fehlertext bei RaiseError=0.

Beschreibung

Dokument für die Langzeitarchvierung in die Tabelle DOCARCH verschieben. Die externe Datei wird ev. entsprechend den Einstellungen verschoben.

Siehe auch

Makro-Referenz

RecoverDocument

CreateDocVers

Dokumente archivieren


AutoCapt: Automatische Dokumentenerkennung

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

AutoCapt: Automatische Dokumentenerkennung

Makrofunktionen für die automatisierte Belegerkennung.

Attribut- und Belegerkennung

Die Auto Capture-Funktionen ermöglichen eine automatisierte oder vollautomatische Archivierung von Dokumenten. Die gewünschten Attribute, wie zum Beispiel Belegnummer, Datum, Kontakt oder Kategorie, werden dabei aus dem Dokumenteninhalt ermittelt. Bei gescannten Papiervorlagen muss zuvor eine OCR-Texterkennung ausgeführt werden.

Möglichkeiten

·Feste Position (Bereich-OCR)
Bei der Erkennung von Ausgangsrechnungen und anderen Dokumenten Ihrer Warenwirtschaft stehen die Attribute immer an der gleichen Position des Dokuments. Hier werden die Funktionen AcroExchGetTextFromRect, PDFGetTextFromRect und ImgGetTextFromRect verwendet. Sie geben beispielsweise an, dass die Rechnungsnummer 2cm von links und 7cm vom oberen Papierrand entfernt zu finden ist.

·Masken-Erkennung
Die Dokumentennummer steht an einer beliebiger Position, sie hat aber immer die gleiche Syntax. Beispielsweise 2 Zeichen, einen Punkt und 4 Zahlen: "AA.0000".
Siehe AutoCaptFindMask, FtiFindMask, AutoCaptFindDate und AutoCaptSelectionListFindItem

·Schlüsselwort-Suche
Das gesuchte Attribut folgt auf ein fest vorgegebenes Schlüsselwort. Beispielsweise steht vor der Belegnummer immer der Text "Rechnung-Nr:".
Siehe AutoCaptKeywordValue und FtiGetKeywordValue

·Wort-Suche
Insbesondere für die Erkennung der Kategorie, wie z. B. Rechnung, Angebot oder Lieferschein. Der Funktion wird eine Liste möglicher Wörter übergeben. Sie gibt das Wort zurück, welches zuerst im Dokument vorkommt.
Siehe AutoCaptFirstCrspWord und FtiGetFirstCrspWord

·Strukturierte Daten
Auswertung einer E-Rechnung gemäß dem XRechnung- und ZUGFeRD-Standard sowie Einlesen von E-Mail-Attributen.
Siehe AutoCaptEInvoice, MailGetProperty und InifileReadStr

·Künstliche Intelligenz (KI)
Lokal installierte GPT und die Cloud-Funktionen von OpenAI, Google und Microsoft erkennen beispielsweise die Daten auf menschenlesbaren Rechnungen.
Siehe AutoCaptGPT und AutoCaptAzureAI

·Weitere Möglichkeiten
Die Attribute werden häufig auch aus dem Speicherpfad ermittelt. Zum Beispiel: das Projekt setzt sich aus dem zweiten bis vierten Teil des Verzeichnisses zusammen und der Kundenname entspricht dem fünften Unterverzeichnis. Oder der Dateiname beinhaltet mehrere Attribute, die mit einem vorgegebenen Zeichen getrennt sind.
Erweiterte Dateieigenschaften, wie Titel und Thema von Office-Dokumenten oder die Metadaten von Digitalfotos.

Verwendung

Die Funktionen werden häufig in Scan- und Importprofilen verwendet. Wechseln Sie dort auf die Seite Feldwerte, wählen Sie die erforderlichen Algorithmen bei Dokumentenerkennung aus und hinterlegen Sie hinter den Feldnamen die gewünschten Variablen oder Funktionen.

Initialisierung und Freigabe der automatischen Belegerfassung

Makrofunktionen

Auto Capture

Nutzen Sie diese bevorzugt, wenn mehrere Funktionen für dasselbe Dokument verwendet werden.

·AutoCaptCreate initialisiert die o. g. Dokumentenerkennung in einem Makro

·AutoCaptCreateTxt initialisiert die Dokumentenerkennung mit einem Text statt einer Datei

·AutoCaptDestroy beendet Auto-Capture eines Dokuments

·AutoCaptDefault ruft die Standard-Dokumentenerkennung auf

·AutoCaptDocumentText enthält den gesamten Dokumententext

·AutoCaptFtiText beinhaltet alle indexierten Wörter des Dokuments

·AutoCaptFindMask Masken-Erkennung

·AutoCaptFirstCrspWord sucht passendes Wort aus einer Liste

·AutoCaptKeywordValue Schlüsselwort-Suche

·AutoCaptFtiWord gibt ein bestimmtes Wort zurück

·AutoCaptSelectionListFindItem sucht passende Einträge in Auswahllisten, automatische Projektzuordnung

·AutoCaptEInvoice gibt Daten einer elektronischen Rechnung gemäß dem ZUGFeRD-Standard zurück

Alleinstehende Erkennungsfunktionen

Die Funktionen werden nicht mit AutoCaptCreate eingeleitet. Jeder Aufruf wertet das Dokument erneut aus.

·AcroExchGetTextFromRect Text von fester Position im PDF-Dokument lesen

· CSVGetCell CSV-Daten auswerten, beispielsweise für Scanner-Indexdatei

·FtiFindMask Masken-Erkennung

·FtiGetFirstCrspWord sucht passendes Wort aus einer Liste

·FtiGetKeywordValue Schlüsselwort-Suche

·ImgGetTextFromRect Text von fester Position in Grafik-Datei lesen

·ImgReadBarcode Barcode-Erkennung

·MailGetProperty E-Mail-Eigenschaften

Pfad und Dateiattribute

·FileAttr einfache Dateiattribute

·Formatparameter DirPart und Separate

·ImgExtractMetaWords Meta-Daten von Grafiken

·SelectionListFindItem sucht passende Einträge in Auswahllisten, automatische Projektzuordnung.

·OleDocumentSummaryInformation erweiterte Dateiattribute

·OleSummaryInformation

·OleUserDefinedProperties

Hilfsfunktionen

·ExecuteOCR OCR-Texterkennung ausführen

·ExtractAttachment Dateianlagen extrahieren

·ExtractDocumentText Dokumentinhalt

·GetFirstNotEmpty ermöglicht die Verwendung von alternativen Erkennungsfunktionen


AutoCaptAzureAI

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI > AutoCapt: Automatische Dokumentenerkennung >

AutoCaptAzureAI

Verfügbar in diesen Editionen

Makro-Variable AutoCaptAzureAI

Daten der KI-Formularerkennung von Microsoft Azure (Cognitive Services, Form Recognizer) einlesen.

Syntax

{AutoCaptAzureAI:Path}

Parameter

Path: Pfad zum gewünschten Wert.
Oder:
TagList: alle erfassten Werte als mehrzeiliger Text in Form "Path=Value".

Rückgabewert

Von der Azure-Formularerkennung gelieferter Wert.

Beschreibung

Microsoft bietet mit den Cognitive Services einen kostenpflichtigen Dienst für die Dokumentenerkennung mittels Künstlicher Intelligenz (KI). Die erforderlichen API-Aufrufe sind in Office Manager DMS integriert.

Mit {AutoCaptAzureAI:Path} können Sie einzelne erkannte Daten abrufen. Nutzen Sie auch den Parameter TagList, um das gesamte Erkennungsergebnis mit den einzelnen Pfaden einzusehen, zum Beispiel {MessageDlg:{AutoCaptAzureAI:TagList}}.

Beispiel

{AutoCaptAzureAI:analyzeResult.documents[0].fields.CustomerAddressRecipient.valueString}

{AutoCaptAzureAI:analyzeResult.documents[0].fields.InvoiceTotal.valueCurrency.amount}

Siehe auch

Makro-Referenz

Übersicht Belegerfassung

Importprofile. Insbesondere Seite "Feldwerte". Hier werden die erkannten Daten den Archivfeldern zugewiesen.


AutoCaptCreate
AutoCaptCreateTxt

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI > AutoCapt: Automatische Dokumentenerkennung >

AutoCaptCreate
AutoCaptCreateTxt

Makro-Prozedur AutoCaptCreate
Makro-Prozedur AutoCaptCreateTxt

Initialisiert die automatische Belegerkennung (interne Funktionen, elektronische Rechnung und Künstliche Intelligenz) innerhalb eines Makros.

Syntax 1

{AutoCaptCreate:FileName[,MaxBytes,Recognizers]}

Parameter

FileName: Dateiname des auszuwertenden Dokuments, z. B. {Source}.

MaxBytes (optional): Standardmäßig werden bei programminternen Erkennungsfunktionen maximal 100.000 Bytes an Text (entspricht ca. 100.000 Zeichen) aus der Datei verarbeitet. Sie können optional einen anderen Wert angeben. Der Wert 0 oder ein leerer Wert verwenden ebenfalls dem Standard.

Recognizers (optional) Auswahl der Algorithmen:
I=Standard-Dokumentenerkennung
Z=E-Rechnung
G=Künstliche Intelligenz (GPT)
A=Azure KI-Formularerkennung
Der Standardwert, wenn nicht angegeben, ist "IZ".

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Syntax 2

{AutoCaptCreateTxt:Text}

Parameter

Text: Beliebiger Text für die automatische Belegerfassung. Dieser kann beispielsweise aus einem Aufruf von ImgGetTextFromRect stammen.

Rückgabewert

Keiner

Beschreibung

Die Prozedur liest den Dokumenten- oder freien Text in den Arbeitsspeicher ein. Dieser steht dann für folgende Funktionen zur automatischen Belegerkennung zur Verfügung. Bei Scan- und Importprofilen wird die automatische Dokumentenerkennung über die gleichnamige Einstellung auf Seite Feldwerte aktiviert.

Die Variable AutoCaptDocumentText beinhaltet anschließend den Rohtext, AutoCaptFtiText eine punkgetrennte Liste von für die Volltextindexierung aufbereiteten Wörtern. Verwenden Sie die "AutoCapt..."-Funktionen, um Daten für die Katalogisierung des Dokuments zu ermitteln.

ZUGFeRD: Bei Verwendung der Syntax 1 wird auch geprüft, ob das Dokument eine elektronische Rechnung gemäß dem ZUGFeRD-Standard enthält. Wenn ja, dann werden die strukturierten Daten der Rechnung eingelesen und können anschließend mit AutoCaptEInvoice ausgewertet werden. Als Quelldatei kann die PDF-Rechnung oder eine Containerdatei (E-Mail, ZIP o. ä.) mit enthaltener PDF-Rechnung übergeben werden.

Beispiel

{AutoCaptCreate:{CurrDocFileName},0,IZA}

Siehe auch

Makro-Referenz

Übersicht Belegerfassung

AutoCaptDestroy


AutoCaptDefault

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI > AutoCapt: Automatische Dokumentenerkennung >

AutoCaptDefault

Makro-Funktion AutoCaptDefault

Standard-Dokumentenerkennung

Syntax

{AutoCaptDefault:FieldName}

Parameter

FieldName: Name des Datenbankfeldes in der Dokumententabelle
oder * für eine Liste mit allen erkannten Werten "Feldname=erkannter Wert".

Rückgabewert

Vorgeschlagener Wert für das Datenfeld, sofern gefunden.

Beschreibung

Ruft die fest programmierte automatische Dokumentenerkennung für Belegdatum, Kontakt, Kategorie u. a. aus einem Makro auf.

Siehe auch

Makro-Referenz

Übersicht Belegerfassung


AutoCaptDestroy

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI > AutoCapt: Automatische Dokumentenerkennung >

AutoCaptDestroy

Makro-Prozedur AutoCaptDestroy

Beendet die automatische Belegerfassung eines Dokuments innerhalb von Makros.

Syntax

{AutoCaptDestroy}

Parameter

Keine

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Prozedur gibt den belegten Arbeitsspeicher frei. Programmintern werden hier die String-Variablen mit dem Dokumententext geleert und die E-Rechnungs- sowie KI-Objekte gelöscht, sofern vorhanden

Es sind aber keine Speicherlücken zu befürchten, falls die Prozedur nicht aufgerufen wird. Der Speicher wird bei der nächsten Verwendung von AutoCaptCreate oder spätestens beim Programmende freigegeben.

Siehe auch

Makro-Referenz

Übersicht Belegerfassung

AutoCaptCreate


AutoCaptDocumentText

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI > AutoCapt: Automatische Dokumentenerkennung >

AutoCaptDocumentText

Makro-Variable AutoCaptDocumentText

Beinhaltet den auszuwertenden Text während der automatischen Belegerfassung.

Syntax

{AutoCaptDocumentText}

Parameter

Keine

Rückgabewert

Volltext für Belegerkennung.

Beschreibung

Die Variable wird bei der Initialisierung der Dokumentenerkennung und einem Aufruf von AutoCaptCreate mit dem Dokumententext gefüllt.

Siehe auch

Makro-Referenz

Übersicht Belegerfassung

AutoCaptFtiText

ExtractDocumentText


AutoCaptEInvoice

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI > AutoCapt: Automatische Dokumentenerkennung >

AutoCaptEInvoice

Verfügbar in diesen Editionen

Makro-Variable AutoCaptEInvoice

Daten einer E-Rechnung für die automatische Belegerkennung einlesen.

Der veraltete Name AutoCaptZUGFeRD ist nur noch aus Kompatibilitätsgründen gültig, bitte nicht mehr verwendet.

Syntax

{AutoCaptEInvoice:Path}

Parameter

Path: Pfad zum gewünschten Wert, wie in der technischen Dokumentation des jeweiligen Formats beschrieben. Oder ein für alle Formate gültiger Name der Rechnungsdaten:
Amount: Rechnungssumme
BuyerCity: Stadt des Käufers bzw. Rechnungsempfängers
BuyerCountryID: Ländercode, wie "DE"
BuyerName: Name des Käufers
BuyerStreet: Straße
BuyerTaxID: eine Steuernummer des Käufers
BuyerZip: Postleitzahl
Currency: Währung der Rechnung
DeliveryDate: Lieferdatum
Description für die Dokumentenbezeichnung geeigneter Text
DocNo: Rechnungsnummer
DocTypeText: Dokumentenart, wie "Rechnung", "Gutschrift" oder "Rechnungskorrektur"
DocTypeCode: Code der Dokumentenart: 326, 380, 381, 384, 389, 875, 786, 877 u. a.
DueDate: Fälligkeitsdatum
EInvoiceCount: Anzahl der E-Rechnungen in der verarbeiteten verarbeiteten Datei
PayableAmount: Zahlbetrag (z. B. Rechnungsbetrag abzgl. Anzahlungen)
PeriodEndDate: Leistungszeitraum Enddatum
PeriodStartDate: Leistungszeitraum Startdatum
ReceiptDate: Rechnungsdatum
SellerCity: Stadt des Verkäufers bzw. Rechnungssteller
SellerCountryID: Ländercode, wie "DE"
SellerName: Name des Verkäufers
SellerStreet: Straße
SellerTaxID: eine Steuernummer des Verkäufers
SellerZip: Postleitzahl
TagList: alle erfassten Werte als mehrzeiliger Text in Form "Path=Value"
Version des verwendeten Rechnungsprofils
XML gibt den Inhalt der elektronischen Rechnung als String zurück
XMLFileName: Dateiname der verarbeiteten (ev. temporär gespeicherten) XML-Datei
(Pfad)/dmsAsString: nur bei Datum, siehe Beschreibung
(Pfad)/dmsAsDate: nur bei Datum, siehe Beschreibung
(Pfad)/dmsDateCode: nur bei Datum, siehe Beschreibung

Rückgabewert

Wert aus der E-Rechnung (xrechnung.xml, factur-x.xml oder ZUGFeRD-invoice.xml).

Beschreibung

Elektronische Rechnungen beinhalten maschinenlesbare Daten. Die Formate ZUGFeRD und Factur-X bestehen aus einer PDF/A-3 Datei zur visuellen Darstellung der Rechnung und einer anliegenden XML-Datei mit den maschinenlesbaren strukturierten Daten. XRechnung besteht nur aus einer XML-Datei.

Die Dokumentenerkennung liest bereits wichtige Attribute ein, ohne dass Makro-Variablen erforderlich sind.

Mit der Initialisierung der Dokumentenerkennung und beim Aufruf der Prozedur {AutoCaptCreate:FileName} wird die XML-Datei ausgewertet und eine Liste aller enthaltenen Daten zusammengestellt. Mit {AutoCaptEInvoice:Path} können Sie diese Daten abrufen. Als Path geben Sie bitte bevorzugt die o. g. allgemeingültigen Namen an. Falls Sie weitere Daten aus der Rechnung extrahieren möchten, dann nutzen Sie auch den Parameter TagList, um das gesamte Erkennungsergebnis mit den Pfaden einzusehen, zum Beispiel {MessageDlg:{AutoCaptEInvoice:TagList}}.

Falls in der verarbeiteten Datei mehrere E-Rechnungen enthalten sind (z. B. bei einer E-Mail), wird die erste Rechnung ausgewertet. Beachten Sie auch EInvoiceCount als Parameter.

ZUGFeRD-Versionen

In den Versionen 1.0 und 2.x unterscheiden sich einige Pfade, der Hauptknoten wurde beispielsweise von "CrossIndustryDocument" in "CrossIndustryInvoice" umbenannt. Sie können aber immer die neuen oder alten Pfadnamen verwenden, diese werden programmintern in die neuen Pfade konvertiert:

ZUGFeRD Version 1.0 | ZUGFeRD Version 2.x
CrossIndustryDocument | CrossIndustryInvoice
SpecifiedExchangedDocumentContext | ExchangedDocumentContext
HeaderExchangedDocument | ExchangedDocument
SpecifiedSupplyChainTradeTransaction | SupplyChainTradeTransaction
ApplicableSupplyChainTradeAgreement | ApplicableHeaderTradeAgreement
ApplicableSupplyChainTradeDelivery | ApplicableHeaderTradeDelivery
ApplicableSupplyChainTradeSettlement | ApplicableHeaderTradeSettlement
SpecifiedTradeSettlementMonetarySummation | SpecifiedTradeSettlementHeaderMonetarySummation

Datum

Wenn Sie ein Datum, welches nicht als vordefinierter Variablenname verfügbar ist, einlesen möchten, müssen Sie den gesamten Pfad angeben. Ein Datum kann als Kalenderdatum (Code 102 JJJJMMTT), Kalenderwoche (Code 616 JJJJWW) oder Monat (Code 610 JJJJMM) angegeben sein. Die Pfade enden bei einem Datum mit "/DateTimeString". Beispiel XML-Knoten:

<ram:IssueDateTime>

<udt:DateTimeString format="102">20141219</udt:DateTimeString>

</ram:IssueDateTime>

Mit der Makrovariablen

{AutoCaptEInvoice:CrossIndustryInvoice/ExchangedDocument/IssueDateTime/DateTimeString}

erhalten Sie den kodierten Wert "20141219". Um Ihnen die Abfrage zu vereinfachen, dekodiert Office Manager DMS alle Datumsangaben und stellt diese in drei Unterpfaden zur Verfügung:

·(Pfad)/dmsAsString: enthält bei Code 102 z. B. "19.12.2014", bei Code 610 "Dezember 2014" und bei Code 616 "KW 51, 2014".

·(Pfad)/dmsAsDate: gibt immer ein Kalenderdatum zurück und ist bei Code 102 mit dmsAsString identisch. Bei Code 610 der letzte Tag im Monat, bei Code 616 der Freitag in der angegebenen Woche.

·(Pfad)/dmsDateCode: der Code "102", "610" oder "616".

Beispiel für die Abfrage eines dekodierten Datums:

{AutoCaptEInvoice:CrossIndustryInvoice/ExchangedDocument/IssueDateTime/DateTimeString/dmsAsDate}

Beispiele

Den Verkäufernamen und die Rechnungsnummer in globale Variablen kopieren:

{AutoCaptCreate:{Source}}

{RaiseError:Ungültige E-Rechnung,{AutoCaptEInvoice:DocFileName}=}

{SetPublVar:EInvcSeller={AutoCaptEInvoice:SellerName}}

{SetPublVar:EInvcDocNo={AutoCaptEInvoice:DocNo}}

{AutoCaptDestroy}

{MessageDlg:{GetPublVar:*List}}

Netto-Betrag bei ZUGFeRD

{AutoCaptEInvoice:CrossIndustryInvoice/SupplyChainTradeTransaction/ApplicableHeaderTradeSettlement/ApplicableTradeTax/BasisAmount}

Rechnungsbetrag bei allen Formaten

{AutoCaptEInvoice:Amount}

Siehe auch

Makro-Referenz

Belegerkennung im Importprofil aktivieren

Forum elektronische Rechnung Deutschland

Hinweise zur elektronischen Rechnungsarchivierung


AutoCaptFindDate

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI > AutoCapt: Automatische Dokumentenerkennung >

AutoCaptFindDate

Verfügbar in diesen Editionen

Makro-Funktion AutoCaptFindDate

Automatische Belegerkennung mit Maskensuche nach einem Datum.

Syntax

{AutoCaptFindDate[:Result,Masks,StartPos,EndPos,IgnoreBlanks,SearchOption]}

Parameter

Optionale Parameter:

Result: "Default" (Vorgabewert) gibt, wie bei der Standarderkennung, das Belegdatum zurück.
"Latest" das neuste der gefundenen Daten,
"Earliest" das älteste.
"Auto" das neueste der Daten, die nicht in der Zukunft liegen.
"All" alle gefundenen Daten mit Leerzeichen getrennt.
"List" alle als mehrzeiliger Text.

Masks: Verwendete Suchmasken für Datum-Schreibweisen:
Vorgabe, wenn nicht angegeben, ist "1235"
Die folgenden Nummern können Sie kombinieren: "1" nur 1, "134" für 1, 3 und 4, "13c" 1 und 3 mit Komma-Korrektur.
"1": 09.01.2019
"2": 09.01.19
"3": 9.1.2019
"4": 9.1.19
"5": 9. Januar 2019
"c" kann zusätzlich angegeben werden. Es wird dann auch nach Komma statt Punkt gesucht, um OCR-Erkennungsfehler zu beheben (09,01.2019).

StartPos: Zur Beschleunigung kann eine Startposition in Zeichen (Byte) angegeben werden. Wenn Sie sich z. B. sicher sind, dass der gesuchte Text erst nach 1.000 Zeichen vorkommt, dann geben Sie "1000" ein. Die Auswertung beginnt dann erst beim zehntausenden Zeichen. Geben Sie 1 ein, wenn vom ersten Zeichen an ausgewertet werden soll. Der Vorgabewert, wenn nicht angegeben, ist "1".

EndPos: Zur Beschleunigung kann eine Endposition in Zeichen (Byte) angegeben werden, bei der die Suche endet. Geben Sie 0 ein, um bis zum Textende zu suchen. Vorgabewert ist "10000".

IgnoreBlanks: 0 (Vorgabewert) oder 1. Bei 1 werden Leerzeichen ignoriert.

SearchOption: 0 oder leer für keine Option, 1 (Vorgabewert) für die Suche nur nach ganzen Wörtern.
Alle anderen Werte definieren eine Präfix, die im Text vor der eigentlichen Maske stehen muss.

Rückgabewert

Datum aus dem Dokumententext.

Beschreibung

Die Funktionen sucht im Dokument nach einem Datum zwischen 1900 und 2099. Wenn mehrere Daten gefunden wurden, kann das gewünschte mit dem Parameter Result gewählt werden.

Beispiele

{AutoCaptFindDate:Latest}

{AutoCaptFindDate:Latest,123c}

Siehe auch

Makro-Referenz

Übersicht Belegerfassung

AutoCaptFindMask


AutoCaptFindMask
FtiFindMask

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI > AutoCapt: Automatische Dokumentenerkennung >

AutoCaptFindMask
FtiFindMask

Verfügbar in diesen Editionen

Makro-Funktion AutoCaptFindMask
Makro-Funktion FtiFindMask

Automatische Belegerkennung mit Maskensuche.

Syntax

{AutoCaptFindMask:StartPos,EndPos,IgnoreBlanks,SearchOption,Mask}

{FtiFindMask:FileName,StartPos,EndPos,IgnoreBlanks,SearchOption,Mask}

Parameter

FileName: Nur bei der FtiFindMask: Dateiname des Dokuments.

StartPos: Zur Beschleunigung kann eine Startposition in Zeichen (Byte) angegeben werden. Wenn Sie sich z. B. sicher sind, dass der gesuchte Text erst nach 1.000 Zeichen vorkommt, dann geben Sie "1000" ein. Die Auswertung beginnt dann erst beim zehntausenden Zeichen. Geben Sie 1 ein, wenn vom ersten Zeichen an ausgewertet werden soll.

EndPos: Zur Beschleunigung kann eine Endposition in Zeichen (Byte) angegeben werden, bei der die Suche endet. Geben Sie 0 ein, um bis zum Textende zu suchen.

IgnoreBlanks: 0 oder 1. Bei 1 werden Leerzeichen ignoriert.

SearchOption: 0 oder leer für keine Option, 1 für die Suche nur nach ganzen Wörtern.
Alle anderen Werte definieren eine Präfix, die im Text vor der eigentlichen Maske stehen muss.

Mask: Die Maske, nach der gesucht wird. Sie kann literale Zeichen und Mengen enthalten, als Platzhalter ist nur das Fragezeichen erlaubt, kein Stern. Die Groß-/Kleinschreibung wird nicht berücksichtigt. Mengen werden mit eckigen Klammern eingeschlossen. Beispiele:
?: steht als Platzhalter für ein beliebiges Zeichen
!: invertiert die Mengendefinition (NOT)
[0-9]: eine beliebige Ziffer
[!0-9]: keine Ziffer
4: nur die 4
[04]: 0 oder 4
[2-6]: eine Ziffer von 2 bis 6
[A-Z]: ein Buchstabe

Rückgabewert

Mit der Maske übereinstimmender Text im Dokumenteninhalt.

Beschreibung

Die Funktionen ermitteln den ersten zur Maske passenden Text im Dokument. Falls keine Übereinstimmung vorliegt, ist das Ergebnis leer. Eine Maskensuche ist sinnvoll, wenn ein zu erkennendes Attribut immer die gleiche Syntax hat. Beispielsweise eine Projektnummer, die aus zwei Zeichen, einem Bindestrich und vier Zahlen besteht: Mask = "[A-Z][A-Z]-[0-9][0-9][0-9][0-9]"

Beispiel

Maske für Datum (s. a. AutoCaptFindDate) in amerikanischer Schreibweise mit vierstelliger Jahreszahl zwischen 1900 und 2099, wie "09/22/2019":

{AutoCaptFindMask:1,0,1,,[0-1][0-9]/[0-3][0-9]/[12][90][0-9][0-9]}

Auftragsnummer wie "2015012345" mit Jahreszahl, einer 0 und fünfstelliger Nummer. Vor der Auftragsnummer darf kein "R" stehen.

{AutoCaptFindMask:1,0,1,[!R],201[0-9]0[0-9][0-9][0-9][0-9][0-9]}

Ausführlicher Blog-Artikel zur Nummernerkennung

Siehe auch

Makro-Referenz

Übersicht Belegerfassung

AutoCaptSelectionListFindItem


AutoCaptFtiText

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI > AutoCapt: Automatische Dokumentenerkennung >

AutoCaptFtiText

Makro-Variable AutoCaptFtiText

Beinhaltet während der automatischen Belegerfassung alle Volltextindex-Wörter des Dokuments.

Syntax

{AutoCaptFtiText}

Parameter

Keine

Rückgabewert

Punktgetrennte Liste der Index-Wörter.

Beschreibung

Die Variable wird bei der Initialisierung der Dokumentenerkennung und einem Aufruf von AutoCaptCreate gefüllt. Sie beinhaltet eine punktgetrennte Liste aller Dokumentenwörter, die der Office Manager in den Volltextindex schreiben würde. Die Wortliste ist somit von den Indexeinstellungen abhängig.

Beispielinhalt: ".auftragsbestaetigung.rechnung.wort3.wort4."

Siehe auch

Makro-Referenz

Übersicht Belegerfassung

AutoCaptDocumentText

AutoCaptFtiWord


AutoCaptFirstCrspWord

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI > AutoCapt: Automatische Dokumentenerkennung >

AutoCaptFirstCrspWord

Verfügbar in diesen Editionen

Makro-Funktion AutoCaptFirstCrspWord

Gibt ein passendes Wort aus AutoCaptFtiText zurück.

Syntax

{AutoCaptFirstCrspWord:Words}

Parameter

Words: Punktgetrennte Liste von Wörtern ".Wort1.Wort2.Wort3.". Die Liste beginnt und endet jeweils mit einem Punkt! Sie kann z. B. mit {FieldAttribute:DocDB,Feldname,Pickitems,.} erzeugt werden, um den Inhalt einer Auswahlliste zur Verfügung zu stellen. Sie darf nur einzelne Wörter beinhalten.

Rückgabewert

Das erste Wort der Liste, welches in AutoCaptFtiText enthalten ist.

Beschreibung

Die Variable gibt das erste Wort der Liste Words zurück, welches im Volltext des Dokuments enthalten ist.

Beispiel

{AutoCaptFirstCrspWord:{FieldAttribute:DocDB,Category,Pickitems,.}}

Siehe auch

Makro-Referenz

Übersicht Belegerfassung

AutoCaptSelectionListFindItem

FtiGetFirstCrspWord

Formatparameter FirstCrspWord


AutoCaptKeywordValue

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI > AutoCapt: Automatische Dokumentenerkennung >

AutoCaptKeywordValue

Verfügbar in diesen Editionen

Makro-Funktion AutoCaptKeywordValue

Sucht in dem mit AutoCaptCreate eingelesenen Rohtext nach einem Schlüsselwort und gibt den darauf folgenden Text zurück.

Syntax

{AutoCaptKeywordValue:Keywords,CharCount[,CutMultiLine,MatchCase,IgnoreChars]}

Parameter

Keywords: Punktgetrennte Liste von Schlüsselwörtern ".Wort1.Wort2.Wort3.". Die Liste beginnt und endet jeweils mit einem Punkt. Die Schlüsselwörter selbst dürfen keinen Punkt und kein Komma enthalten. Ein Punkt kann aber mit "OMProVarPoint" und ein Komma mit "OMProVarComma" maskiert werden.

CharCount: Anzahl Zeichen, die nach dem Schlüsselwort übernommen werden sollen.

CutMultiLine: (optional) 1 = Ergebnis bei Zeilenumbruch (#10 oder #13) abschneiden, 0 = nicht abschneiden. Vorgabe ist 1.

MatchCase: (optional) 1 = Groß-/Kleinschreibung berücksichtigen, 0 = ignorieren. Vorgabe ist 0.

IgnoreChars: Optionale Liste von Zeichen, die aus dem Ergebnis gelöscht werden sollen, z. B. "-. ;,"

Rückgabewert

Der auf das Schlüsselwort folgende Text im Dokument.

Beschreibung

Die Funktion dient der automatisierten Dokumentenverarbeitung. Das Dokument wird nach Schlagwörtern, wie "Kunden-Nr" oder "Rechnungs-Nr" durchsucht und der danach folgende Text (z. B. die Kunden- oder Rechnungsnummer) für die Speicherung in einem Attribut zurückgegeben.

Der resultierende String wird getrimmt: Leer- und Steuerzeichen am Anfang und Ende werden entfernt.

Beachten Sie bei Problemen mit PDF-Dokumenten bitte das Seitenlayout und nutzen Sie bei Bedarf die alternative Konvertierungsfunktion.

Siehe auch

Makro-Referenz

Übersicht Belegerfassung

FtiGetKeywordValue, hier finden Sie auch Beispiele


AutoCaptFtiWord

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI > AutoCapt: Automatische Dokumentenerkennung >

AutoCaptFtiWord

Makro-Variable AutoCaptFtiWord

Gibt ein Wort aus AutoCaptFtiText zurück.

Syntax

{AutoCaptFtiWord:WordNum}

Parameter

WordNum: Nummer des Wortes, welches zurückgegeben werden soll. 1 steht für das erste Wort im Volltext.

Rückgabewert

Das mit der Nummer angegebene Wort aus der Index-Liste.

Beschreibung

Die Variable gibt das Wort mit der angegebenen Nummer aus dem Volltext des aktuellen Dokuments zurück.

Siehe auch

Makro-Referenz

Übersicht Belegerfassung

AutoCaptFtiText

FtiGetWord


AutoCaptGPT

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI > AutoCapt: Automatische Dokumentenerkennung >

AutoCaptGPT

Verfügbar in diesen Editionen

Makro-Variable AutoCaptGPT

Vom GPT generierte Antwort der Dokumenten- oder Bilderkennung.

Syntax

{AutoCaptGPT[:FieldName]}

Parameter

FieldName: optionaler Feldname des gewünschten Wertes.

Rückgabewert

GPT-Output

Beschreibung

Diese Variable wird in der Regel nicht benötigt. Die Dokumentenerkennung mit GPT ist so konfiguriert, dass sie bereits die Namen der Datenfelder mit den Erkennungsergebnissen in Form "Feldname=Feldwert" zurückgibt. Office Manager DMS übernimmt diese Daten beim Scan oder Import selbsttätig in die Datenbank.

Die Auswertung des Outputs kann aber beim Skripten hilfreich sein.

Beispiel

{AutoCaptGPT:category} # gibt die erkannte Kategorie zurück

{AutoCaptGPT} # gesamter GPT-Output als mehrzeiliger Text

Siehe auch

Makro-Referenz

Übersicht Belegerfassung

ExecuteGPT


AutoCaptSelectionListFindItem

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI > AutoCapt: Automatische Dokumentenerkennung >

AutoCaptSelectionListFindItem

Verfügbar in diesen Editionen

Makro-Funktion AutoCaptSelectionListFindItem

Belegerkennung. Sucht einen passenden Eintrag in einer Auswahlliste.

Syntax

{AutoCaptSelectionListFindItem:FieldName,SearchMode[,Extended,Default]}

Parameter

FieldName: Name des Datenbankfeldes, dessen Auswahlliste durchsucht werden soll.

SearchMode: Suchmodus 0 bis 3.
0: Exakt. Der Listeneintrag muss als Wort im Dokument vorkommen. Im Dokumententext müssen die Zeichen vor und nach dem Suchtext Trennzeichen (weder Buchstabe noch Zahl) sein.
1: Beginnt mit. Das Zeichen vor dem Suchtext muss ein Trennzeichen sein.
2: Maskensuche mit Jokern *,? und Mengen. Dies ist i. d. R. nur mit Extended sinnvoll.
3: Endet mit. Das Zeichen nach dem Suchtext muss ein Trennzeichen sein.
Die Groß-, Kleinschreibweise wird in keinem Fall berücksichtigt.

Optionale Parameter

Extended: erweiterter Modus
0 oder nicht angegeben: Standardmodus
1: In der der Projektliste wird auch die Beschreibung durchsucht. Das entsprechende Projekt wird zurückgegeben, wenn der gesuchte Text in der Bezeichnung oder Beschreibung gefunden wird. Auch die Projekthinweise werden zeilenweise durchlaufen.
11 bis 19 für Auswahllisten mit der Syntax "Key=Value", beispielsweise "Kundenname=Debitorenkonto":
11: Suche Key, Rückgabe des gesamten Listeneintrags
12: Suche Key, Rückgabe Key
13: Suche Key, Rückgabe Value
14: Suche Value, Rückgabe des gesamten Listeneintrags
15: Suche Value, Rückgabe Key
16: Suche Value, Rückgabe Value
17: Suche Key und Value, Rückgabe des gesamten Listeneintrags. Es wird zuerst nach Key gesucht und anschließend nach Value.
18: Suche Key und Value, Rückgabe Key
19: Suche Key und Value, Rückgabe Value

Default: Text, der zurückgegeben wird, wenn kein passender Eintrag gefunden wurde.

Rückgabewert

Gibt den entsprechenden Eintrag aus der Liste zurück oder einen Leerstring, wenn kein passender Eintrag gefunden wurde.

Beschreibung

Einigen Datenfeldern sind Auswahllisten zugeordnet - beispielsweise dem Projekt und der Kategorie. Mit Hilfe dieser Funktion können Sie passende Listeneinträge im eingelesenen Dokumenten-Volltext suchen.

Programmintern wird die Auswahlliste zeilenweise durchlaufen und der jeweilige Text im Dokument gesucht. Zurückgegeben wird

·bei SearchMode 2 der erste passende Listeneintrag unabhängig von der Position im Text.

·In anderen Fällen der Listeneintrag, welcher zuerst im Dokumententext vorkommt.

Hinweise

Wenn Sie Extended verwenden und nicht den gesamten Listeneintrag zurückgeben (Extended 12,13,15,16,18,19), sollte das Zieldatenfeld nicht den Eingabestil "Nur Auswahl aus (strukturierter) Liste" verwenden. Solche Kombinationsfelder zeigen nur Texte, die in der Liste enthalten sind.

Beispiele

{AutoCaptSelectionListFindItem:Category,0,0,Nicht definiert}
Der Dokumententext wird nach einer passenden Kategorie durchsucht. Wenn Begriffe, wie "Angebot" oder "Rechnung" vorkommen, dann wird die Kategorie entsprechend zurückgegeben. Anderenfalls "Nicht definiert".

{AutoCaptSelectionListFindItem:Project,2,1}
In den Projekthinweisen sind Straßennamen mit Jokerzeichen enthalten, die zum jeweiligen Projekt gehören. Beispielsweise "*Friedrich-Engels-Str*45*".

Siehe auch

Makro-Referenz

Übersicht Belegerkennung

AutoCaptFirstCrspWord

SelectionListFindItem


CachedDoc

CD-Dokumentenindex

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

CD-Dokumentenindex

HTML-Dokumententabelle auf CD

Die vom Office Manager erstellten CDs können automatisch mit einer HTML-Dokumententabelle versehen werden:

HTML-Inhaltsverzeichnis einer Archiv-CD

HTML-Tabelle erstellen

Markieren Sie im Dialogfenster "Dokumente auf CD brennen" bitte die Option Dokumentenindex, bevor Sie die CD oder DVD brennen. Die HTML-Datei wird dann automatisch mit auf den Datenträger geschrieben.

Dokumente sortieren

Die Sortierung entspricht der aktuellen Dokumenten-Sortierung im Office Manager-Hauptfenster. Sortieren Sie die Dokumente einfach entsprechend, bevor Sie den Menübefehl Senden an CD wählen.

Layout der HTML-Tabelle bearbeiten

Klicken Sie bitte mit der rechten Maustaste auf das Optionsfeld Dokumentenindex und wählen Sie im lokalen Menü den Befehl Layout bearbeiten. Die HTML-Vorlagendatei wird dann im Windows-Editor geöffnet.

Alternativ können Sie auch die Datei "sendcd_xxx.html" im Verzeichnis der gemeinsamen Dateien mit einem anderen Editor bearbeiten.

Hinweise zu den Makrovariablen:

·Die Schleife durch alle Dokumente ist mit {BeginLoop} und {EndLoop} eingeschlossen. Achten Sie bitte darauf, dass diese Anweisungen in einer eigenen Zeile stehen.

·Verwenden Sie keine Datenbankvariablen! Diese würden auf den derzeit aktuellen Datensatz in der Datenbank zugreifen. Innerhalb der BeginLoop-, EndLoop-Schleife verwenden Sie bitte {CachedDoc:FieldName} statt {Doc:FieldName}, um auf die Dokumentattribute zuzugreifen.

CD-Symbol definieren

Die CD/DVD wird im Explorer mit dem Office Manager DMS-Symbol dargestellt. Um ein anderes Symbol zu verwenden, legen Sie bitte vor dem Brennen eine gültige Windows-Symboldatei unter "(Gemeinsame Dateien)\sendcd.ico" ab.

Siehe auch

Senden an CD


Calculate

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

Calculate

Makro-Funktion Calculate

Berechnung ausführen.

Syntax

{Calculate:Formula}

Parameter

Formula: Berechnungsformel mit folgenden Operatoren:
"+" Addition
"-" Subtraktion
"*" Multiplikation
"/" oder ":" Division
"(" Klammer auf
")" Klammer zu
"^" Potenz
"div" Ganzzahldivision (programmintern werden die Werte zuvor gerundet)
"mod" Rest (programmintern werden die Werte zuvor gerundet)

und Funktionen:
abs() Absolutwert
trunc() Nachkommastellen abschneiden
round() runden
roundcu() auf Währung der Gebietseinstellung runden
sin() Sinus eines Winkels im Bogenmaß
cos() Kosinus
tan() Tangens
arctan() Arcustangens
log() Logarithmus
ln() natürlicher Logarithmus
exp() Potenz (wie ^)
sqrt() Quadratwurzel

Rückgabewert

Berechnungsergebnis

Beschreibung

Die Funktion führt mathematische Berechnungen durch und gibt das Ergebnis der im Parameter übergebenen Formel zurück. Der gesamte Text hinter dem Doppelpunkt wird ausgewertet, es sind keine Formatparameter möglich.

Das Dezimaltrennzeichen wird entsprechend der Windows-Gebietseinstellungen erwartet: bei deutscher Einstellung z. B. "123,45" oder amerikanisch "123.45". Tausendertrennzeichen dürfen nicht angegeben werden.

Beispiel 1

Rechnungsbetrag inkl. 19% MwSt. aus einem Nettobetrag (im Datenfeld "netto") ermitteln:

{Calculate:roundcu({Doc:netto}*1,19)}

Beispiel 2

AutoCAD-Zeichnung an den gewählten Maßstab anpassen:

varia _all 0,0 {Calculate:1/({Doc:ZchngMst})}

Die Variable {Doc:ZchngMst} wird durch den eingegebenen Maßstab ersetzt (z. B. "1:10").
{Calculate:1/(1:10)} ergibt den Wert "10", die bestehenden Elemente in der AutoCAD-Zeichnung (z. B. der Zeichnungsschriftkopf und Rahmen) werden also um den Faktor 10 vergrößert.

Wenn Sie, wie in diesem Beispiel, eine Berechnung mit Datenfelder aus der Dokumentendatenbank vornehmen, dann sollten Sie das entsprechende Datenfeld in die Liste der Pflichtfelder aufnehmen.

Siehe auch

Makro-Referenz

Ord


ChangeDir

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ChangeDir

Makro-Prozedur ChangeDir

Legt das aktuelle Windows-Verzeichnis fest.

Syntax

{ChangeDir:Dir[,Create]}

Parameter

Dir: Verzeichnisname mit oder ohne abschließenden Backslash, z. B. "C:\Daten"

Create: Wenn der optionale Parameter "Create" angegeben ist, dann wird das Verzeichnis erstellt, sofern es noch nicht existiert.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Setzt das aktuelle Verzeichnis auf das im Parameter angegebene Verzeichnis. Wenn dieses nicht existiert und der optionale Parameter Create angegeben ist, so wird versucht, das Verzeichnis zu erstellen. Die weitere Abarbeitung des Makros wird beendet, falls ChangeDir fehlschlägt.

Siehe auch

Makro-Referenz

CreateDir


Chr

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

Chr

Makro-Variable Chr

Gibt das im Parameter definierte Zeichen zurück.

Syntax

{Chr:ASCII-Code}

Parameter

ASCII-Code: Der Parameter gibt den ASCII-Code des Zeichens an.

Rückgabewert

Das Zeichen, welches dem angegebenen Ordinalwert entspricht.

Beschreibung

Mit Chr können Sie Sonderzeichen in das Makro einfügen, die sich nicht als Text darstellen lassen.

Beispiele

{Chr:13} Eingabe-Taste
{Chr:13}{Chr:10} Zeilenumbruch nach Windows-Standard
{Chr:9} Tabulator

Siehe auch

Makro-Referenz
Ord

SendKey

SendKeyStr

CreateKey


CombineDocuments

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

CombineDocuments

Verfügbar in diesen Editionen

Makro-Prozedur CombineDocuments

Dokumente miteinander verknüpfen. Die Funktion bezieht sich auf die aktuelle Tabellenansicht "Aktive Dokumente" oder "Archivierte Dokumente".

Syntax 1

{CombineDocuments:LinkName,DocID1,DocID2[,DocIDn]}

Parameter

LinkName: Name der Verknüpfung.

DocID: Liste der Schlüsselnummern aller Dokumente, die miteinander verknüpft werden sollen. Geben Sie mindestens 2 Dokumente an.

Rückgabewert

Keiner

Beschreibung

Makrogesteuerter Zugriff auf die Funktion Bearbeiten | Dokument | Verknüpfen. Syntax 1 wird verwendet, wenn mehr als 2 Parameter angegeben wurden.

Syntax 2

{CombineDocuments:FieldName[,SQL-Where]}

Parameter

FieldName: Name des Datenfeldes.

SQL-Where: Optionaler Filter (z. B. "WHERE PROJECT='Mein Projekt'"), wenn die Funktion nicht für alle Dokumente der aktuellen Tabelle ausgeführt werden soll.

Rückgabewert

Keiner

Beschreibung

Automatische Verknüpfung aller Dokumente, die im Datenfeld FieldName den gleichen Wert haben. Der Interpreter verwendet diese Syntax, wenn 1 oder 2 Parameter angegeben wurden.

Der Verknüpfungsname ist die MD5-Hashsumme des Feldwertes: Wenn Sie die Funktion erneut aufrufen, werden Dokumente den bestehenden Verknüpfungen hinzugefügt. Es ist aber theoretisch möglich, dass unterschiedliche Feldwerte eine identische Hashsumme haben.

Siehe auch

Makro-Referenz

Dokumente kombinieren

SplitDocument

MergeDocuments


ComCreateNewDocument

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ComCreateNewDocument

Makro-Prozedur ComCreateNewDocument

Erzeugt ein neues Dokument mittels COM-Automatisierung (OLE).

Syntax

{ComCreateNewDocument[:Application,FileName]}

Optionale Parameter

Application: OLE-Name der Anwendung, z. B. "Word.Application" oder "AutoCAD.Application". Wenn der Parameter nicht angegeben ist, dann wird die zuvor mit {SetComApplName} gesetzte Anwendung verwendet.

FileName: Dateiname des neuen Dokuments. Wenn der Parameter nicht angegeben ist, wird der aktuelle Dokument-Dateiname verwendet.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Funktion startet die Anwendung (den COM-Server), wenn Sie noch nicht gestartet ist, erzeugt ein neues Dokument mit der COM-Anweisung "Documents.Add" und speichert es unter dem Dateinamen FileName.

Siehe auch

Makro-Referenz

SetComApplName

Dokumentvorlagen


ContactSearch

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ContactSearch

Makro-Prozedur ContactSearch

Dokumente suchen

Syntax

{ContactSearch:SQL-Where}

Parameter

SQL-Where: WHERE-Teil der SQL-Abfrage, z. B. "WHERE lastname={s Musterfrau}".

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Mit der Methode ContactSearch können Sie Kontakte in CRM-Datenbank-Tabelle contact suchen.

Das Makro bricht mit einer Fehlermeldung ab, falls die Tabelle gerade bearbeitet wird.

Beispiele:

{ContactSearch:WHERE lastname={Self:DBQuoteChar}gesuchter Name{Self:DBQuoteChar}}

{ContactSearch:WHERE lastname LIKE {s gesuchter Na%}

Siehe auch

Makro-Referenz

DBSearch

DocumentSearch


CopyDocFile

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

CopyDocFile

Makro-Prozedur CopyDocFile

Kopiert die aktuelle Dokumentdatei.

Syntax

{CopyDocFile:DstFileName}

Parameter

DstFileName: Dateiname der Zieldatei.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Funktion kopiert die Hauptdatei (keine Dokumentversionen) des aktuellen Dokuments nach DstFileName. Wenn die die Zieldatei bereits vorhanden ist, dann wird der Anwender gefragt, ob diese überschrieben werden soll.

Alternativ können Sie auch {CopyFile:{CurrDocFileName},DstFileName} aufrufen. Dann wird das Makro mit einem Fehler abgebrochen, falls die Zieldatei bereits vorhanden ist. Ein weiterer Unterschied ist das Fehlerverhalten: CopyDocFile gibt eine Meldung aus, das Makro wird fortgesetzt. CopyFile gibt einen Fehler aus und beendet das Makro. CopyFile kann außerdem das Zielverzeichnis erstellen und den Zieldateinamen in einen noch nicht vorhandenen ändern.

Siehe auch

Makro-Referenz

GetBackupFileName

CopyFile

DeleteFile


CopyFile

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

CopyFile

Makro-Prozedur CopyFile

Eine Datei kopieren oder Download aus dem Internet.

Syntax

{CopyFile:SrcFileName/URL,DstFileName[,CreateDir,MakeUnique]}

Parameter

SrcFileName: Dateiname oder URL der Quelldatei.

DstFileName: Dateiname der Zieldatei.

CreateDir (optional): Wenn 1 angegeben ist, dann wird das bei Bedarf Zielverzeichnis erstellt.

MakeUnique (optional): Bei 1 wird ein neuer noch nicht vorhandener Zieldateiname verwendet, falls DstFileName bereits vorhanden ist.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Prozedur kopiert die Datei SrcFileName nach DstFileName. Als Quelldatei können Sie auch eine URL angeben, um eine Datei aus dem Internet zu laden.

Bei Fehlern, oder falls die Zieldatei bereits vorhanden ist, wird eine Fehlermeldung erzeugt und das Makro beendet. Falls Sie die Funktion auch ausführen möchten, wenn die Zieldatei bereits vorhanden ist, können Sie vor CopyFile die Funktion {DeleteFile:DstFileName,NoConfirm} aufrufen oder den Parameter MakeUnique verwenden.

Siehe auch

Makro-Referenz

CopyDocFile

MoveFile

UploadFile

GetBackupFileName

IF-Bedingung


CopyToClipboard

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

CopyToClipboard

Makro-Prozedur CopyToClipboard

Daten in die Zwischenablage kopieren.

Syntax

{CopyToClipboard:Format,Data}

Parameter

Format:
"CF_TEXT" für Text
"CF_HDOP" für Dateien. Trennen Sie mehrere Dateien bitte mit NULL {Chr:0}. Am Ende der Liste werden zwei NULL-Zeichen von Windows erwartet. Diese werden bei Bedarf aber automatisch hinzugefügt, Sie können 0 bis 2 NULL-Zeichen am Ende angeben.

Data: Die zu kopierenden Daten.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Anweisung kopiert Text oder Dateien in die Windows-Zwischenablage. Der Inhalt der Zwischenablage wird dabei überschrieben.

Beispiele

{CopyToClipboard:CF_TEXT,{Doc:FileName}} kopiert den aktuellen Dokument-Dateinamen in die Zwischenablage.

{CopyToClipboard:CF_HDROP,{Doc:FileName}} kopiert die aktuelle Dokument-Datei in die Zwischenablage.

Siehe auch

Makro-Referenz

PasteFromClipboard


CreateDir

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

CreateDir

Makro-Funktion CreateDir

Erstellt ein neues Verzeichnis.

Syntax

{CreateDir:Dir,Result}

Parameter

Dir: Das zu erstellende Verzeichnis.

Result: 1 = Die Variable wird durch das erstellt Verzeichnis ersetzt. 0 = Die Variable wird durch "" ersetzt.

Rückgabewert

Das erstellte Verzeichnis oder ein Leerstring.

Beschreibung

Die Funktion erstellt das Verzeichnis Dir auf dem Datenträger und gibt das Verzeichnis zurück, wenn Result = 1 ist.

Beispiel

{CreateDir:G:\Daten\OMPro\{Doc:Project,Main},1}

Siehe auch

Makro-Referenz

ChangeDir

DeleteFile

IF-Bedingung


CreateDocFromTemplate

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

CreateDocFromTemplate

Makro-Prozedur CreateDocFromTemplate

Erstellt die Datei des aktuellen Dokuments.

Syntax

{CreateDocFromTemplate}

Parameter

Keine

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Datei des aktuellen Dokuments wird als Kopie der Standard-Vorlagendatei des zugeordneten Dokumenttypen erstellt. Falls die Datei bereits vorhanden ist, wird sie nicht überschrieben.

Siehe auch

Makro-Referenz

AddDoc

AddDocEx


CreateDocVers

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

CreateDocVers

Verfügbar in diesen Editionen

Makro-Prozedur CreateDocVers

Erstellt eine Version des aktuellen Dokuments.

Syntax

{CreateDocVers[:-1,Name,ShowDlg,ReadOnly,Compress,Notes,RaiseError,SourceFileName,AsNewVers]}

Optionale Parameter

-1: Reserviert, bitte -1 eingeben.

Name: Kurze Beschreibung der archivierten Version.

ShowDlg: 1 = das Dialogfenster für die Benutzereingabe öffnen, 0 = nicht öffnen (Standardwert).

ReadOnly: 1 = Dateiattribut "Schreibschutz" setzen, 0 = nicht setzen. 1 ist der Standardwert.

Compress: 1 = Dateiatribut "Komprimiert" setzen, 0 = nicht setzen (Standardwert).

Notes: Notizen, lange Beschreibung der archivierten Version.

RaiseError: Der Standardwert 1 löst bei Fehlern eine Exception aus und beendet das Makro. 0 unterdrückt den Fehler und gibt die Fehlermeldung als Variablenwert zurück.

SourceFileName: Für die Dokumentversion wird nicht die Dokumentdatei, sondern die mit SourceFileName angegebene Datei verwendet.

AsNewVers: 1 archiviert das aktuelle Dokument als Version und übernimmt die mit SourceFileName angegebene Datei als aktuelle Version des Dokuments. 0 = normales Verhalten.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Hauptdatei des aktuellen Dokumentes wird als Version archiviert.

Siehe auch

Makro-Referenz

DocVers

ArchiveDocument

SelectDocVersions

PDFAddComment

Versionsmanagement

Erweiterter Import


CreateKey

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

CreateKey

Makro-Prozedur CreateKey

Emuliert einen Tastendruck.

Syntax

{CreateKey:ASCII-Code[,Parameter]}

Parameter

ASCII-Code: Der ASCII-Code des zu sendenden Tastendruckes.

Parameter: Geben Sie 'Virtual' an, wenn virtuelle Tasten übergeben wurden (z. B. F10).
'VK_SHIFT' für gedrückte Umschalttaste,
'VK_CONTROL' für Strg,
'VK_MENU' für Alt.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Einschränkung

Diese potenziell gefährliche Funktion ist standardmäßig gesperrt.

Beschreibung

Erzeugt einen Tastendruck. Als Parameter wird der ASCII-Code der Taste übergeben. Im Gegensatz zu SendKey sendet CreateKey den Tastendruck nicht als Windows-Botschaft, sondern schreibt direkt in den Tastaturpuffer. Bringen Sie vor einem Aufruf von CreateKey den Empfänger der Taste mit {WinAPI:BringWindowToTop} in den Vordergrund.

Siehe auch

Makro-Referenz

CreateKeyStr

Chr

WaitForApplication

WinAPI

SendKey

SendKeyStr


CreateKeyStr

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

CreateKeyStr

Makro-Prozedur CreateKeyStr

Emuliert Tastendrücke für den angegebenen Text.

Syntax

{CreateKeyStr:Text}

Parameter

Text: Der zu "schreibende" Text.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Schreibt den angegebenen Text in den Tastaturpuffer. Bringen Sie vor einem Aufruf von CreateKeyStr den Empfänger der Taste mit {WinAPI:BringWindowToTop} in den Vordergrund.

Siehe auch

Makro-Referenz

CreateKey

WinAPI

SendKey

SendKeyStr


CreateLnkFile

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

CreateLnkFile

Makro-Prozedur CreateLnkFile

Erzeugt eine Windows-Verknüpfung.

Syntax

{CreateLnkFile:FileName,LnkFileName,Description}

Parameter

FileName, kompletter Name der Zieldatei.

LnkFileName: kompletter Dateiname der zu erzeugenden lnk-Datei.

Description: Kommentar/Beschreibung

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Prozedur erzeugt eine Windows-Dateiverknüpfung (.lnk-Datei) mit den angegebenen Parametern.

Siehe auch

Makro-Referenz

CopyFile


CSVFindRow

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

CSVFindRow

Makro-Funktion CSVFindRow

Sucht in einer CSV-Datei nach einer passenden Zeile.

Syntax

{CSVFindRow:Column,Value,FileName}

Parameter

Column: Die Spaltennummer in der CSV-Datei: 1 = erste Spalte, -1 = letzte, 0 = alle.

Value: Gesuchter Wert in der angegebenen Spalte. Die Jokerzeichen ? und * sind möglich, außer bei Column=0. Zwischen Groß- und Kleinschreibung wird nicht unterschieden. In Value darf kein Komma enthalten sein.

FileName: Vollständiger Name mit Pfad der CSV-Datei.

Rückgabewert

Die Zeilennummer, wenn gefunden. Das Ergebnis ist leer, falls keine passende Zeile vorhanden ist.

Beschreibung

Auswertung mehrzeiliger CSV-Dateien (Comma-separated values). Mit CSVFindRow wird die passende Datenzeile gesucht, um diese beispielsweise mit CSVGetCell auszuwerten.

Die Funktion wurde für die Verarbeitung von Index-Dateien des Ricoh-Scanprogramms "PaperStream Capture" mit Barcode-Erkennung und Bereich-OCR eingeführt, kann aber für beliebige CSV-Daten verwendet werden.

Beispiel

Eine vom Scanner erzeugt Index-Datei beinhaltet für jedes erfasste Dokument eine Zeile. Office Manager importiert die gescannten PDF-Dateien und soll den Wert aus Spalte 19 in ein Archivfeld übernehmen. Der Dateiname steht in Spalte 9.

{CSVGetCell:{CSVFindRow:9,{Source},C:\Scan\index.csv},19,C:\Scan\index.csv}

Dieses Makro wird im Scanner-Importprofil dem gewünschten Datenfeld als Feldwert hinzugefügt.

Siehe auch

Makro-Referenz

Automatische Belegerfassung

CSVGetCell

ReadLnFile


CSVGetCell

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

CSVGetCell

Makro-Funktion CSVGetCell

Gibt einen Wert aus einem CSV-Text oder einer CSV-Datei zurück.

Syntax

{CSVGetCell:Row,Column,TextOrFilename}

Parameter

Row: Die Zeilennummer in der CSV-Datei: 1 = erste Zeile, -1 = letzte. Oder 0, wenn der CSV-Text direkt angegeben ist.

Column: Spaltennummer

TextOrFilename: Dateiname der CSV-Datei oder, bei Row=0, der auszuwertende einzeilige CSV-Text.

Rückgabewert

Der Inhalt der angegebenen Zelle.

Beschreibung

Dient der Auswertung von CSV-Text (Comma-separated values). Sie können eine CSV-Datei oder einen einzeiligen Text übergeben. Row und Column geben die Zeilen- bzw. Spaltennummer an, Zählung ab 1. Mit negativen Werten kann von hinten gelesen werden.

Für ein optimales Zusammenspiel mit CSVFindRow wird kein Fehler ausgelöst, falls Row leer ist. Die Funktion gibt dann einen Leer-String zurück.

Programmintern wird die CSV-Zeile als SDF verarbeitet.

Die Funktion wurde für die Verarbeitung von Index-Dateien des Ricoh-Scanprogramms "PaperStream Capture" mit Barcode-Erkennung und Bereich-OCR eingeführt, kann aber für beliebige CSV-Daten verwendet werden.

Beispiele

{CSVGetCell:0,3,"eins",zwei","drei","vier"} Ergebnis: drei
{CSVGetCell:0,3,eins,zwei,drei,vier} Ergebnis: drei
{CSVGetCell:0,-1,"eins",zwei","drei","vier"} Ergebnis: vier
{CSVGetCell:-1,3,C:\Test\meine.csv} gibt den dritten Wert in letzter Zeile der CSV-Datei zurück.

Siehe auch

Makro-Referenz

Automatische Belegerfassung

CSVFindRow

InifileReadStr


CurrApplExe

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

CurrApplExe

Makro-Variable CurrApplExe

Programm-Dateiname der aktuellen Anwendung.

Syntax

{CurrApplExe[:FormatParameter]}

Parameter

FormatParameter: Optionaler Parameter für die Formatierung.

Rückgabewert

Dateiname der aktuellen Anwendung.

Beschreibung

Gibt den Dateinamen der aktuellen Anwendung zurück. Im Gegensatz zur Variablen {Appl:ApplExe} sucht {CurrApplExe} die für den Arbeitsplatz gültige Programmdatei.

Für Windows-Standardanwendungen wird die der Dokumentdatei zugeordnete Anwendung zurückgegeben.

Bei "Benutzerdefinierte Steuerung der Anwendung" wird das Programm aus dem Datenbankfeld {Appl:ApplExe} gelesen. Falls dort keine gültige Programmdatei gefunden wurde, gibt die Variable die Windows-Standardanwendung zurück.

Siehe auch

Makro-Referenz

Appl

CurrDocFileName


CurrDatabase

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

CurrDatabase

Makro-Variable CurrDatabase

Information zur aktuell im Programmhauptfenster aktivierten Datenbank.

Syntax

{CurrDatabase:Result}

Parameter

Result gibt an, welcher Datenbankparameter gewünscht ist:
Category (Datenbankkategorie): 1 für Anwendungsdatenbank, 2 für Dokumentenarchiv, 3 für Kontaktdatenbank.
ConnectionString: alle Verbindungsparameter
ColumnFulltext: Datenbankfeld des Dokumententextes oder *
DatabaseName: Dateiname mit Pfad
dbid (Datenbankkennung): DocDB, ApplDB oder CRMDB
DriverCaption: Bezeichnung des Datenbankformats, wie "Microsoft SQL Server"
DriverName: Kennung des Datenbankformats, wie "MSSQL"
MainTablename: Haupttabelle der Datenbank
UserName: ggf. Anmeldename
Version des DMS-Datenbankformats

Rückgabewert

Geforderter Datenbank-Parameter

Beschreibung

Im Datentabelle im Hauptfenster zeigt je nach Ansicht die Dokumente, Kontakte oder den Terminplaner. Die Makrovariable bezieht sich auf diese Ansicht und gibt den geforderten Parameter des Dokumentenarchivs, der Kontakt- oder Anwendungsdatenbank zurück.

Diese Variable wird für Anfragen an die GPT-KI auch vorab interpretiert. Sie bezieht sich dann nicht auf die aktuelle Ansicht des Hauptfensters, sie ist vielmehr von der GPT-Funktion abhängig und gibt bei der Dokumentenerkennung die Parameter des Archivs zurück..

Siehe auch

Makro-Referenz

CurrTableView

Self


CurrDocFileName

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

CurrDocFileName

Makro-Variable CurrDocFileName

Der Dateiname des aktuellen Dokumentes bzw. Dokumentversion.

Syntax

{CurrDocFileName[:FormatParameter]}

Parameter

FormatParameter: optionaler Parameter für die Formatierung.

Rückgabewert

Dateiname des aktuell markierten Dokuments oder der Version.

Beschreibung

Gibt den Dateinamen des Dokumentes zurück, das geöffnet werden soll. Im Gegensatz zur Variablen {Doc:FileName} berücksichtigt {CurrDocFileName} auch die Dokumentversionen. Die Variable sollte in Makros immer dann verwendet werden, wenn beispielsweise eine Datei mit DDE-Befehlen geöffnet wird.

Verwenden Sie die Variable nur innerhalb eines Befehlsmakros.

Siehe auch

Makro-Referenz

Doc:FileName

Source oder FileName


CurrTableView

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

CurrTableView

Makro-Variable CurrTableView

Gibt die aktuelle Ansicht der Datentabelle zurück.

Syntax

{CurrTableView:Result}

Parameter

Result gibt an, welche Information gewünscht ist:
Index: Gibt 0 für aktive, 1 für archivierte Dokumente, 2 für Aufgaben, 3 für Kontakte und 4 für den Papierkorb zurück.
TableName: Name der zugrundeliegenden Datenbanktabelle (document, docarch, doctrash, contact, scheduler).
Caption: Sprachabhängige Bezeichnung der Ansicht, z. B. "Archivierte Dokumente".

Rückgabewert

Siehe Parameter Result.

Beschreibung

Die Datentabelle im Hauptfenster kann aktive, archivierte und gelöschte Dokumente, Kontakte und Aufgaben darstellen. CurrTableView gibt Informationen zur momentan geöffneten Ansicht zurück.

Zum Umschalten der Ansicht können Sie {OmAPI:ActViewDtsDocument}, {OmAPI:ActViewDtsDocArchive} , {OmAPI:ActViewShowTrash} , {OmAPI:ActViewContact} und {OmAPI:ActViewToDo} verwenden.

Siehe auch

Makro-Referenz

CurrDatabase

OmAPI


DatasetReport

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

DatasetReport

Verfügbar in diesen Editionen

Makro-Prozedur DatasetReport

Datenbank-Report-Generator für Textdateien.

Syntax

{DatasetReport:TemplateFileName,DestFileName,Table[,CopyFormat]}

Parameter

TemplateFileName: Dateiname der Vorlage. Die Datei wird im Verzeichnis "(Gemeinsame Dateien)\Template" erwartet, wenn sie ohne Pfad angegeben ist.

DestFileName: Vollständiger Dateiname des zu erstellenden Reports. Die Datei darf nicht vorhanden sein.

Table: Programminterne Kennung der Datenbanktabelle oder "AdoDataset". Die Tabelle muss geöffnet sein.

Nur bei Excel-Formaten:

CopyFormat: 0 oder 1. Bei 1 wird auch das Format der Excel-Zelle kopiert. Diese Funktion ist zeitaufwendig, versuchen Sie es zuerst mit 0 = nicht kopieren.

Zusätzliche Variablen

Neben den Standard-Variablen und -Funktionen können auch die folgenden in der Vorlagendatei verwendet werden:

{BeginLoop}: Schleifenbeginn.

{EndLoop}: Schleifenende. Der Bereich zwischen Begin- und EndLoop wird für jeden Datensatz der Tabelle verarbeitet. Diese Anweisungen müssen enthalten sein.

{FieldValue:FieldName}: Die Variable wird durch den Inhalt des mit FieldName bezeichneten Datenfeldes ersetzt.

{ReportRecordCount}: Anzahl der Datensätze.

{ReportRecordNumber}: Nummer des Datensatzes in der Schleife.

Nur bei Text-Formaten:

{BeginLoopDetailName} und {EndLoopDetailName}: Schleifen durch Detailtabellen.

Nur bei Excel-Formaten:

{EndOfSheet}: Excel-Arbeitsblätter enthalten oft sehr viele leere Zeilen, dessen Abarbeitung unnötig Zeit kostet. Zur Beschleunigung können Sie die Variable unterhalb der letzten Zeile eingeben. Die nachfolgenden Zeilen werden dann ignoriert.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Ermöglicht die benutzerdefinierte Erstellung von tabellenbasierten Berichten aus Datenbank-Quellen, wie beispielsweise eine Dokumentenübersicht.

Als Vorlage kann eine Excel- oder eine beliebige Textdatei, wie HTML verwendet werden. Das Programm ersetzt die enthaltenen Variablen durch die Tabellendaten. Es werden alle Dokumente der aktuellen Suche ausgegeben.

Excel-Format

Microsoft Office Excel muss auf dem Rechner installiert sein, Office Manager nutzt das Programm per COM-Automatisierung für die Erstellung des Reports. Schleifen durch Detailtabellen sind derzeit nicht möglich.

BeginLoop-/ EndLoop-Schleife

Halten Sie für die Daten-Schleife beim Excel-Format bitte folgende Vorgabe genau ein. Die Begin- und EndLoop-Variablen müssen in der ersten Spalte enthalten sein. Es sind immer drei Zeilen nötig, eine mit BeginLoop, eine als Vorlage für die Daten und die dritte Zeile mit EndLoop:

1.Zeile n: {BeginLoop} in erster Spalte. Diese Zeile dient nur der Schleifen-Einleitung und wird gelöscht.

2.Zeile n+1: Datenzeile, die für alle Datensätze kopiert und ausgewertet wird.

3.Zeile n+2: {EndLoop} in erster Spalte. Diese Zeile dient nur der Erkennung des Schleifen-Endes und wird gelöscht.

Text-Format

Interner Funktionsablauf bei den Textformaten

1.Die Vorlagendatei wird eingelesen und in drei Bereiche aufgeteilt: Header bis zur Anweisung {BeginLoop}, Content zwischen {BeginLoop} und {EndLoop}, Footer ab {EndLoop}.

2.Header und Footer werden durch den OmAPI-Interpreter verarbeitet.

3.Programminterne Schleife für alle Datensätze der Tabelle mit Content: In einer Unterschleife durch alle Felder der Tabelle werden die Variablen {FieldValue:FieldName} durch die Daten ersetzt. Anschließend wird Content vom OmAPI-Interpreter verarbeitet.

4.Rückkehr zum zuvor markierten Datensatz in der Tabelle und Speichern des Textes in die Zieldatei.

Sonderfall Dokumententabelle

Wenn Sie einen Report der Dokumententabelle (document oder docarch) des derzeit geöffneten Archives erstellen, können Sie auch die Detailtabellen der Versionen und des Protokolls ausgeben. Verwenden Sie hierfür die Schleifenanweisungen {BeginLoopDetailDocvers} und {EndLoopDetailDocvers} für die Versionstabelle, {BeginLoopDetailDocPrtcl} für das Protokoll.

Hinweise

·Die Hauptschleife BeginLoop/EndLoop muss immer genau einmal vorhanden sein.

·Detailschleifen mit BeginLoopDetailDocvers, BeginLoopDetailDocptrcl und dem entsprechenden EndLoop sind nur in der Dokumententabelle des geöffneten Archivs möglich und dürfen maximal je einmal vorhanden sein.

·Wenn Sie für die Haupttabelle einen nicht vorhandenen Feldnamen angeben, dann bleibt die Variable "{FieldValue:unbekannt}" erhalten.

·Wenn in einer Detailtabelle ein nicht vorhandenes Feld angegeben ist, dann wird dieses eventuell mit den Daten der Haupttabelle gefüllt. Sie erhalten dann aber auch eine entsprechende Warnung.

Beispiel 1

Eine Text-Vorlage zum Kennenlernen des Report-Generators:

{BeginLoop}

Dokument {ReportRecordNumber}/{ReportRecordCount}

Name : {FieldValue:Name}

Projekt: {FieldValue:Project}

Dokumentversionen:

{BeginLoopDetailDocVers} {ReportRecordNumber}

{EndLoopDetailDocVers}

Protokoll:

{BeginLoopDetailDocPrtcl} - {FieldValue:CreateDate}: {FieldValue:UserName} {FieldValue:Protocol}

{EndLoopDetailDocPrtcl}

------------------------------------------------------------

{EndLoop}

Beispiel 2

Eine HTML-Tabelle:

<HTML>

<HEAD>

<TITLE>DMS-Report</TITLE>

</HEAD>

<BODY bgcolor=white>

<TABLE BORDER=0 CELLSPACING=0 WIDTH=1154>

<TR>

<TD NOWRAP ALIGN=CENTER HEIGHT=0px>{FieldAttribute:DocDB,project,Caption}</TD>

<TD NOWRAP ALIGN=CENTER HEIGHT=0px>{FieldAttribute:DocDB,docno,Caption}</TD>

<TD NOWRAP ALIGN=CENTER HEIGHT=0px>{FieldAttribute:DocDB,name,Caption}</TD>

<TD NOWRAP ALIGN=CENTER HEIGHT=0px>{FieldAttribute:DocDB,filename,Caption}</TD>

</TR>

{BeginLoop}

<TR>

<TD NOWRAP ALIGN=LEFT HEIGHT=0px>{FieldValue:Project}</TD>

<TD NOWRAP ALIGN=LEFT HEIGHT=0px>{FieldValue:DocNo}</TD>

<TD NOWRAP ALIGN=LEFT HEIGHT=0px>{FieldValue:Name}</TD>

<TD NOWRAP ALIGN=LEFT HEIGHT=0px><a title="{FieldValue:ApplName}" target="_blank" href="{FieldValue:FileName}">{FieldValue:FileName}</a></TD>

</TR>

{EndLoop}

</TABLE>

<br>

<p align="center"><font size="1" face="Arial">

____________________________________________________________________________________________<br>

<nobr>Erstell mit <a href="https://www.officemanager.de/" target="_blank">Office&nbsp;Manager</a></nobr><br>

<nobr>Archiv: {Self:DocDB,Name}, Datum: {Date:Now,dd.mm.yyyy}</nobr><br>

</font></p>

</BODY>

</HTML>

Siehe auch

Datenbankexport

Report drucken

Makro-Referenz


Date

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

Date

Makro-Variable Date

Gibt einen formatierten Datums-/Zeitwert zurück.

Syntax

{Date:TheDate,Format}

Parameter

TheDate: Geben Sie "Now" für das aktuelle Datum mit Uhrzeit, einen Dateinamen oder ein Datum an.
Tage addieren, nur bei Now: Wenn auf "Now" ein + oder - mit einer Fließkommazahl folgt, dann wir die Anzahl Tage auf das aktuelle Datum addiert.
Monate addieren, nur bei Now: Geben Sie + oder - gefolgt von einer Ganzzahl und "m" ein, um die Anzahl Monate auf das aktuelle Datum zu addieren.

Format enthält die Formatierungsanweisung, wie DayOfTheWeek, HourOfTheDay, QuarterOfTheYearEx oder erweiterte Formatierungen, wie: "dd.mm.yyyy hh:nn:ss".

Rückgabewert

Formatiertes Datum/Zeit.

Beschreibung

Gibt das aktuelle Datum mit Uhrzeit oder den Zeitstempel (letzte Änderung) einer Datei formatiert zurück.

Beispiele

{Date:Now,dd.mm.yyyy} formatiert das aktuelle Datum.

{Date:Now,Year4} oder {Date:Now,yyyy} gibt das aktuelle Jahr vierstellig zurück.

{Date:Now+1.5,dd.mm.yyyy} Datum und Zeit in 36 Stunden ab jetzt.

{Date:Now-12m,dd.mm.yyyy} Datum und Zeit vor genau einem Jahr.

{Date:{Doc:FileName},dd.mm.yyyy} formatiert das Dateidatum des aktuellen Dokuments.

{Date:{Doc:ReceiptDate},dd.mm.yyyy} formatiert das Belegdatum des aktuellen Dokuments.

{Date:22.09.2015,yymmdd} formatiert das angegebene Datum in "150922".

{Date:Now,ArchiveSqlDT} formatiert das aktuelle Datum zum Eintragen in die Archiv-Datenbank mit SQL-Befehlen.

Siehe auch

Makro-Referenz

Formatparameter für Datum

FileAttr


DBCheckFieldValue

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

DBCheckFieldValue

Makro-Prozedur DBCheckFieldValue

Sicherstellen, dass der aktuelle Datensatz den gewünschten Wert im angegebenen Datenfeld hat.

Syntax

{DBCheckFieldValue:Table,FieldName=Value}

Parameter

Mögliche Operatoren: =, <>, < und >, siehe auch ausführliche Beschreibung.

Table: Kennung der Datenbanktabelle.

FieldName: Interner Name des Datenbankfeldes.

Value: Der vorgegebene Wert des Datenbankfeldes.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Funktion DBCheckFieldValue erzeugt eine Fehlermeldung und bricht die weitere Ausführung des Makros ab, wenn der aktuelle Datensatz in der Tabelle nicht den vorgegebenen Feldwert hat. Beim Vergleich wird nicht zwischen Groß- und Kleinschreibung unterschieden.

Beispiel

Ein Dokumentdatensatz soll mit den Makrofunktionen aktualisiert werden. Mit der Funktion {DBSearch:Document,Name=Alter Name} wird der Datensatz gesucht und mit {DBSetField:document,Name=Neuer Name} aktualisiert. Um nach der Suche sicherzustellen, dass ein Datensatz mit dem Namen "Alter Name" gefunden wurde, sollte vor der Aktualisierung {DBCheckFieldValue:document,Name=Alter Name} aufgerufen werden. Falls der aktuelle Datensatz nicht den Namen "Alter Name" hat, löst die Funktion eine Fehlermeldung aus und verhindert, dass ein falscher Datensatz geändert wird.

Siehe auch

Makro-Referenz

DBSearch

ExecSQL

DBLocate

Bedingte Ausführung

Exit

RaiseError


DBLocate

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

DBLocate

Makro-Prozedur DBLocate

Datensatz in aktueller Suche markieren.

Syntax

{DBLocate:Table,FieldName=Value}

Parameter

Table: Kennung der Datenbanktabelle.

FieldName: Interner Name des Datenbankfeldes.

Value: Der gesuchte Wert des Datenbankfeldes.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Mit der Methode DBLocate können Sie einen Datensatz in der Tabelle zum aktuellen Datensatz machen.

Es werden nur die Datensätze der aktuellen Suche berücksichtigt! DBLocate erlaubt keine Jokerzeichen, zwischen Groß- und Kleinschreibung wird nicht unterschieden.

Soll das Makro beendet werden, falls kein Datensatz gefunden wurde, rufen Sie anschließend DBCheckFieldValue auf.

Siehe auch

Makro-Referenz

DBSearch

DBLookup

ExecSQLScalar

DBCheckFieldValue


DBLookup

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

DBLookup

Makro-Funktion DBLookup

Gibt den Feldwert eines Datensatzes innerhalb der aktuellen Datenabfrage zurück, der mit dem angegebenen Filter übereinstimmt.

Syntax

{DBLookup:Table,ResultField,FieldName=Value}

Parameter

Table: Kennung der Datenbanktabelle.

ResultField: Name des Datenbankfeldes, dessen Wert zurückgegeben wird.

FieldName: Name des Datenfeldes für den Filter.

Value: Filterwert

Rückgabewert

Inhalt des Datenbankfeldes.

Beschreibung

Ist in der aktuellen Datenabfrage (Suche) ein Datensatz mit dem Wert Value im Datenfeld FieldName vorhanden, dann wird der Inhalt des Feldes ResultField zurückgegeben.

Siehe auch

Makro-Referenz

DBLocate

ExecSQLScalar für eine Suche in der kompletten Datenbanktabelle

DBCheckFieldValue


DBOperation

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

DBOperation

Makro-Prozedur DBOperation

Daten bearbeiten oder speichern.

Syntax

{DBOperation:Table,Operation}

Parameter

Table: Kennung der Datenbanktabelle.

Operation:

Append: neuen Datensatz am Ende der Tabelle hinzufügen

Cancel: Änderungen am Datensatz verwerfen

Close: schließt die Tabelle

Delete: aktuellen Datensatz löschen

Edit: aktuellen Datensatz bearbeiten

Insert: neuen Datensatz hinter dem aktuellen hinzufügen

Open: öffnet die Tabelle

Post: Änderungen am Datensatz speichern

Refresh: liest die Daten neu aus der Datenbank ein

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Einschränkung

Das Löschen mit Parameter "Delete" ist als potenziell gefährliche Funktion standardmäßig gesperrt.

Beschreibung

Die Prozedur aktiviert den Bearbeitungsmodus einer Datenbank-Tabelle, führt Operationen aus oder speichert Änderungen. Sie bezieht sich auf den derzeit markierten Datensatz (die Zeile) der Tabelle.

Siehe auch

Makro-Referenz

DBSetField

AdoOperation

ExecSQL

DBLocate

IF-Bedingung


DBSearch

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

DBSearch

Makro-Prozedur DBSearch

Datensätze in Office Manager-Archivtabelle suchen.

Syntax

{DBSearch:Table[,FieldName=Value]}

Parameter

Table: Kennung der Datenbanktabelle.

FieldName: Interner Name des Datenbankfeldes. Wenn der Parameter "FieldName=Value" nicht angegeben ist, werden alle Datensätze der Tabelle gesucht.

Value: Der gesuchte Wert des Datenbankfeldes. Bei Text-Datenfeldern können Sie die Jokerzeichen %*_? verwenden. Bei der Suche in einfachen Textfelder (Feldtyp CHAR) wird zwischen Groß- und Kleinschreibung nicht unterschieden.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Mit der Methode DBSearch können Sie Datensätze in einer Tabelle der geöffneten Archivdatenbank suchen. Nach erfolgreicher Ausführung ist die Tabelle auf Datensätze mit den angegebenen Kriterien gefiltert.

Das Makro bricht mit einer Fehlermeldung ab, falls die Tabelle gerade bearbeitet wird.

Diese Funktion kann nicht mit Tabellen der Anwendungsdatenbank verwendet werden. Um sicherzustellen, dass die Suche erfolgreich war, können Sie DBCheckFieldValue aufrufen.

Siehe auch

Makro-Referenz

DocumentSearch

ContactSearch

ExecSQLScalar

DBCheckFieldValue

DBLocate

IF-Bedingung


DBSetField

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

DBSetField

Makro-Prozedur DBSetField

Feldwerte des aktuellen Datensatzes ändern.

Syntax

{DBSetField:Table,FieldName=Value,FieldName2=Value,...}

Parameter

Table: Kennung der Datenbanktabelle.

FieldName: Interner Name des Datenbankfeldes.

Value: Der neue Wert des Datenbankfeldes.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Ändert den Wert des Datenbankfeldes in der angegebenen Tabelle. Bei Bedarf wird automatisch der Bearbeitungs-Modus aktiviert.

In der Regel sind Änderungen in der Tabelle der archivierten Dokumente nicht erlaubt. Um dies sicherzustellen, sollte das Makro mit folgender Zeile beginnen:

{RaiseError:Funktion in archivierten Dokumenten nicht erlaubt,{Self:DocTable}=DOCARCH}

Siehe auch

Makro-Referenz

AdoSetField

DBLocate

DBOperation

ExecSQL

Variablen für Datenfelder

IF-Bedingung


DDECloseLink

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

DDECloseLink

Verfügbar in diesen Editionen

Makro-Prozedur DDECloseLink

Beendet eine bestehende DDE-Verbindung.

Syntax

{DDECloseLink}

Parameter

Keine

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Beendet die DDE-Konversation. Rufen Sie DDECloseLink auf, um eine mit DDEOpenLink aufgebaute Verbindung wieder zu beenden.

Siehe auch

Makro-Referenz

DDE Hintergrundinformation

DDEOpenLink

DDESendLine

IF-Bedingung


DDEOpenLink

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

DDEOpenLink

Verfügbar in diesen Editionen

Makro-Prozedur DDEOpenLink

Eine DDE-Verbindung öffnen.

Syntax

{DDEOpenLink:Service,Topic[,Synchron]}

Parameter

Service: DDE-Kennung des Anwendungsprogramms.

Topic: Thema der DDE-Kommunikation, i. d. R. "System".

Synchron: geben Sie diesen optionalen Parameter an, um die DDE-Steuerung zu synchronisieren.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Öffnet die DDE-Verbindung zum Anwendungsprogramm. Falls der Verbindungsaufbau scheitert, wird die Programmdatei gestartet und der Verbindungsaufbau erneut versucht.

Vergessen Sie nicht die Verbindung mit DDECloseLink wieder zu schließen.

Siehe auch

Makro-Referenz

DDE-Beispiel

DDESetExeParam

ShellExecute

DDESendLine

DDECloseLink

DDE Hintergrundinformation

IF-Bedingung


DDESendLine

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

DDESendLine

Verfügbar in diesen Editionen

Makro-Prozedur DDESendLine

Einen einzeiligen DDE-Befehl senden.

Syntax

{DDESendLine:Command}

Parameter

Command: Der zu sendende DDE-Befehl.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Sendet den im Parameter angegebenen DDE-Befehl (Dynamic Data Exchange). Die DDE-Verbindung muss zuvor mit {DDEOpenLink} geöffnet werden.

Siehe auch

Makro-Referenz

DDE-Beispiel

DDESendMacro

DDEOpenLink

DDECloseLink

DDE Hintergrundinformation


DDESendMacro

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

DDESendMacro

Verfügbar in diesen Editionen

Makro-Prozedur DDESendMacro

Ein mehrzeiliges DDE-Makro senden.

Syntax

{DDESendMacro:Macro}

Parameter

Macro: Kommagetrennte Liste im SDF-Format mit den zu sendenden DDE-Befehlen.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Sendet den im Parameter angegebenen DDE-Befehle (Dynamic Data Exchange). Die DDE-Verbindung muss zuvor mit {DDEOpenLink} geöffnet werden.

Siehe auch

Makro-Referenz

DDE synchronisieren

DDESendLine

DDEOpenLink

DDECloseLink

DDE Hintergrundinformation

DDE-Beispiel


DDESetExeParam

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

DDESetExeParam

Verfügbar in diesen Editionen

Makro-Prozedur DDESetExeParam

Definiert die Programm-Startparameter der DDE-Anwendung.

Syntax

{DDESetExeParam:Parameter}

Parameter

Parameter: Startparameter mit der die Anwendung ausgeführt wird. Mehrere Parameter werden mit Leerzeichen getrennt. Falls ein Parameter Leerzeichen beinhaltet, muss er mit doppelten "Anführungszeichen" eingeschlossen werden.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Falls der Verbindungsaufbau mit DDEOpenLink scheitert, wird die Anwendung gestartet und der Verbindungsaufbau erneut versucht. Sie können mit dieser Prozedur einen oder mehrere Startparameter für die Anwendung definierten.

Siehe auch

Makro-Referenz

DDE-Beispiel

DDEOpenLink


DeleteFile

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

DeleteFile

Makro-Prozedur DeleteFile

Datei oder temporäres Verzeichnis löschen.

Syntax

{DeleteFile:FileName[,NoConfirm]}

Parameter

FileName: Name der zu löschenden Datei oder eines temporären Verzeichnisses.

NoConfirm: Wenn dieser optionale Parameter angegeben ist, wird die Datei immer ohne Rückfrage gelöscht. Es wird keine Fehlermeldung erzeugt, wenn die angegebene Datei nicht vorhanden ist. Ist die Option nicht angegeben, dann steuert Windows, ob eine Rückfrage gestellt wird. Beachten Sie hierzu auch die Einstellung "Recycelbestätigung anzeigen" im Windows-Explorer.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Einschränkung

Diese potenziell gefährliche Funktion ist standardmäßig gesperrt.

Beschreibung

Löscht die angegebene Datei vom Datenträger oder verschiebt sie, sofern möglich, in den Papierkorb.

Zusätzlich ist es auch möglich, ein temporäres Verzeichnis mit allen enthaltenen Elementen zu löschen. Aus Sicherheitsgründen werden aber nur Verzeichnisse gelöscht, die sich innerhalb des temporären Windows-Ordners befinden, sowie Verzeichnisse, die mit ~ beginnen.

Siehe auch

Makro-Referenz

CopyDocFile

GetBackupFileName

IF-Bedingung


Dest

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

Dest

Makro-Variable Dest

Dateiname einer Zieldatei.

Syntax

{Dest[:FormatParameter]}

Parameter

FormatParameter: mit dem optionalen Formatparameter können Sie Teile des Dateinamen übernehmen.

Rückgabewert

Vollständiger Name der Zieldatei.

Beschreibung

Die Variable enthält den Dateiname einer Zieldatei, beispielsweise den Dateinamen des letzten Aufrufs der Funktion "Senden an".

Siehe auch

Makro-Referenz

Source


DocumentSearch

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

DocumentSearch

Makro-Prozedur DocumentSearch

Dokumente suchen.

Syntax

{DocumentSearch:SQL-Where}

Parameter

SQL-Where: WHERE-Teil der SQL-Abfrage, z. B. "WHERE DOCID=100".

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Mit der Methode DocumentSearch können Sie Dokumente in den Tabellen DOCUMENT und DOCARCH suchen. Wenn in der aktuellen Tabelle kein Dokument vorhanden ist, dann wird die andere Tabelle durchsucht und bei Erfolg automatisch umgeschaltet.

Das Makro bricht mit einer Fehlermeldung ab, falls die Tabelle gerade bearbeitet wird.

Beispiele:

{DocumentSearch:WHERE DOCID=100}

{DocumentSearch:WHERE NAME={Self:DBQuoteChar}gesuchter Name{Self:DBQuoteChar}}

Siehe auch

Makro-Referenz

DBSearch

ContactSearch


DxfCreateFrame

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

DxfCreateFrame

Verfügbar in diesen Editionen

Makro-Funktion DxfCreateFrame

Einen ausgefüllten Schriftkopf für die neue CAD-Zeichnung erstellen.

Syntax

{DxfCreateFrame:FileName}

Parameter

FileName: Dateiname der DXF-Vorlage mit dem Schriftkopf.

Rückgabewert

Vollständiger Name der erzeugten DXF-Datei mit Schriftkopf.

Beschreibung

Erzeugt den Schriftkopf für eine neue CAD-Zeichnung als DXF-Datei. Ersetzen Sie FileName durch den Namen der DXF-Datei, welche die Vorlage des Schriftkopfes beinhaltet. Die Funktion gibt den Namen der erzeugten DXF-Datei mit dem Schriftkopf zurück.

Platzhalter für Archivdatenfelder beginnen mit "*DTM_" gefolgt vom Feldnamen. Beispielsweise *DTM_DocNo für die Zeichnungsnummer.

Hinweis: Für MegaCAD verwenden Sie besser MegaCreateFrame, für AutoCAD AcadComNewDwg. Bei Datenfelder vom Typ "Datum und Zeit" wird nur das Datum ausgegeben.

Siehe auch

Makro-Referenz

Einrichtungsassistent für AutoCAD

Zeichnungsverwaltung mit AutoCAD

MegaCreateFrame

AcadComNewDwg


ExcelGetCell

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ExcelGetCell

Verfügbar in diesen Editionen

Makro-Funktion ExcelGetCell

Text aus Excel-Zelle lesen.

Syntax

Syntax 1: {ExcelGetCell:FileName,SheetName,Column,Row}

Syntax 2: {ExcelGetCell:FileName,SheetName,Column,Row,VarName[,SheetName2,Column2,Row2,VarName2,...]}

Parameter

FileName: Dateiname einer existierenden Excel-Datei.

SheetName: Name des Excel-Blattes.

Column: Spaltennummer der Zelle, z. B. 1 für Spalte A und 3 für Spalte C.

Row: Zeilennummer der Zelle.

VarName (nur Syntax 2): Name der privaten Variablen, die mit GetPrivVar abgefragt werden kann.

Rückgabewert

Zelleninhalt des Excel-Arbeitsblattes.

Beschreibung

Die Funktion gibt den Text aus einer oder mehreren Excel-Zellen zurück. Bei Syntax 1 wird die Variable direkt durch den Zellinhalt ersetzt.

Die Excel-Datei wird für jeden Aufruf der Variablen geöffnet. Verwenden Sie die Syntax 2, wenn Sie mehrere Zellen aus einer Datei lesen möchten.

Beispiel Syntax 2:

{ExcelGetCell:G:\Daten\Beispiel.xls,Tabelle1,2,5,Variable1,Tabelle1,2,8,Variable2}

{MessageDlg:Zelle B5: {GetPrivVar:Variable1}{Chr:13}Zelle B8: {GetPrivVar:Variable2}}

Siehe auch

Makro-Referenz

ExcelSetCell

GetPrivVar


ExecDirDlg

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ExecDirDlg

Makro-Funktion ExecDirDlg

Ein Verzeichnis wählen.

Syntax

{ExecDirDlg:Title[,FormatParameter]}

Parameter

Title: Überschrift des Dialogfensters, z. B. "Verzeichnis wählen".

FormatParameter: Mit dem optionalen Formatparameter können Sie Teile des Pfades übernehmen.

Rückgabewert

Vom Anwender gewähltes Verzeichnis.

Beschreibung

Öffnet einen Windows-Dialog, in welchem der Anwender ein Verzeichnis wählen kann. Die Funktion gibt das ausgewählte Verzeichnis zurück. Die Abarbeitung des Makros wird beendet, wenn der Anwender auf die Schaltfläche Abbrechen klickt.

Siehe auch

Makro-Referenz

ExecOpenDlg

ExecSaveDlg

ExecInputQuery


ExecInputQuery

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ExecInputQuery

Makro-Funktion ExecInputQuery

Eingabedialog für Text öffnen.

Syntax

{ExecInputQuery:Title[,Default]}

Parameter

Title: Überschrift des Dialogfensters.

Default: Optionaler Vorgabewert.

Rückgabewert

Vom Anwender eingegebener Text.

Beschreibung

Öffnet einen Eingabedialog, in welchem der Benutzer einen Text eingeben kann. Die Funktion gibt den eingegebenen Text zurück. Die Abarbeitung des Makros wird beendet, wenn der Anwender auf die Schaltfläche Abbrechen klickt.

Siehe auch

Makro-Referenz

ExecOpenDlg

ExecSaveDlg

ExecDirDlg


ExecOpenDlg

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ExecOpenDlg

Makro-Funktion ExecOpenDlg

Eine Datei zum Öffnen wählen.

Syntax

{ExecOpenDlg:Filter[,FormatParameter]}

Parameter

Filter beinhaltet die Endungen der auszuwählenden Dateien, z. B. "Textdatei|*.txt|Alle Dateien|*.*" oder "Bilddateien|*.bmp;*.jpg;*.jpeg;*.png;*.tif;*.tiff".

FormatParameter: Mit dem optionalen Formatparameter können Sie Teile des Dateinamen übernehmen.

Rückgabewert

Vom Anwender gewählter Dateiname.

Beschreibung

Öffnet einen Windows-Dialog, in welchem der Anwender eine Datei zum Öffnen eingeben kann. Die Funktion gibt diesen zurück. Die Abarbeitung des Makros wird beendet, wenn der Anwender auf die Schaltfläche Abbrechen klickt.

Siehe auch

Makro-Referenz

OpenDlg

ExecSaveDlg

ExecDirDlg

ExecInputQuery


ExecPrintDlg

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ExecPrintDlg

Makro-Prozedur ExecPrintDlg

Den Windows-Dialog "Drucken" öffnen.

Syntax

{ExecPrintDlg}

Parameter

Keine

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Öffnet den Drucker-Dialog und macht den dort ausgewählten Drucker zum Windows-Standarddrucker. Die Abarbeitung des Makros wird beendet, wenn der Anwender auf die Schaltfläche Abbrechen klickt.

Siehe auch

Makro-Referenz


ExecSaveDlg

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ExecSaveDlg

Makro-Funktion ExecSaveDlg

Eine Datei zum Speichern wählen.

Syntax

{ExecSaveDlg:Filter[,FormatParameter]}

Parameter

Filter beinhaltet die Endungen der auszuwählenden Dateien, z. B. "Textdatei|*.txt|Alle Dateien|*.*" oder "Bilddateien|*.bmp;*.jpg;*.jpeg;*.png;*.tif;*.tiff".

FormatParameter: Mit dem optionalen Formatparameter können Sie Teile des Dateinamen übernehmen.

Rückgabewert

Vom Anwender gewählter Dateiname.

Beschreibung

Öffnet einen Windows-Dialog, in welchem der Anwender eine Datei zum Speichern eingeben kann. Die Funktion gibt diesen Dateinamen zurück. Die Abarbeitung des Makros wird beendet, wenn der Anwender auf die Schaltfläche Abbrechen klickt.

Der Dateiname muss inklusive der Dateiendung angegeben werden.

Siehe auch

Makro-Referenz

SaveDlg

ExecOpenDlg

ExecDirDlg

ExecInputQuery


ExcelSetCell

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ExcelSetCell

Verfügbar in diesen Editionen

Makro-Prozedur ExcelSetCell

Text in Excel-Zelle überschreiben.

Syntax

{ExcelSetCell:FileName,SheetName,Column,Row,Value[,SheetName2,Column2,Row2,Value2,...]}

Parameter

FileName: Dateiname einer existierenden Excel-Datei.

SheetName: Name des Excel-Blattes.

Column: Spaltennummer der Zelle, z. B. 1 für Spalte A und 3 für Spalte C.

Row: Zeilennummer der Zelle.

Value: zu schreibender Text

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Prozedur schreibt Text in eine oder mehrere Excel-Zellen.

Siehe auch

Makro-Referenz

ExcelGetCell

Office-Sicherheitseinstellungen


ExecSQL

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ExecSQL

Verfügbar in diesen Editionen

Makro-Prozedur ExecSQL

SQL-Anweisung ausführen.

Syntax

{ExecSQL:Connection,SQL}

Verwenden Sie ExecSQL mit besonderer Vorsicht. Falsche Anweisungen können ganze Tabellen zerstören! Führen Sie umfangreiche Testläufe mit Kopien der Datenbank durch.

Parameter

Connection gibt die Datenverbindung an. Verwenden Sie "DocDB" für das Dokumentenarchiv, "CRMDB" für die Kontakt- oder "ApplDB" für die Anwendungsdatenbank.

SQL: auszuführende SQL-Anweisung.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Einschränkung

Diese potenziell gefährliche Funktion ist standardmäßig gesperrt.

Beschreibung

Mit der Methode ExecSQL wird eine SQL-Anweisung in der angegebenen Datenbankverbindung ausgeführt.

Sie können Daten editieren (UPDATE), die Tabellenstruktur ändern (ALTER TABLE) und andere SQL-Anweisungen ausführen. Wenn Sie Jokerzeichen verwenden, achten Sie bitte auf den SQL-Standard % und _.

Für SELECT-Anweisungen (Datenabfrage) ist diese Methode nicht vorgesehen. Prüfen Sie, ob alternativ DocumentSearch oder DBSearch genutzt werden kann. Einige systemkritische Funktionen werden abgelehnt, beispielsweise die Bearbeitung archivierter Dokumente.

Beispiele:

Feldwerte ändern:
{ExecSQL:DocDB,UPDATE document SET name="Neuer Name" WHERE name="Alter Name"}

Datensatz hinzufügen:
{ExecSQL:DocDB,INSERT INTO document (name,project) VALUES ("MeinName","MeinProjekt")}

Hinweis: ExecSQL kann Makrovariablen in eine Tabelle schreiben. Die Variablen werden nicht ausgeführt, wenn die Klammern mit Chr definiert sind.

Siehe auch

Makro-Referenz

ExecSQLScalar

DBCheckFieldValue

DocumentSearch

DBSearch

DBLocate


ExecSQLScalar

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ExecSQLScalar

Verfügbar in diesen Editionen

Makro-Funktion ExecSQLScalar

Einzelnen Datenwert aus einer Tabelle abfragen.

Syntax

{ExecSQLScalar:Connection,TableName,ResultFieldName,Default,SqlWhere}

Parameter

Connection gibt die Datenverbindung an. Verwenden Sie "DocDB" für das Dokumentenarchiv, "CRMDB" für die Kontakt- oder "ApplDB" für die Anwendungsdatenbank.

TableName: Name der Datenbanktabelle

ResultFieldName: Name des Datenbankfeldes, welches als Ergebnis zurückgegeben wird.

Default: Vorgabewert, welcher bei einem auftretendem Fehler oder bei einem leeren Abfrageergebnis zurückgegeben wird. Darf kein Komma enthalten.

SqlWhere: Filter-Teil der SQL-Anweisung.

Rückgabewert

Wert der mit ResultFieldName angegebenen Spalte der ersten gefundenen Zeile.

Beschreibung

Die Funktion ExecSQLScalar fragt mit Hilfe einer SQL-Anweisung einen einzelnen Datenwert aus der angegebenen Datenbank-Tabelle ab. Aus Sicherheitsgründen kann nur der Filter für die SQL-Anweisung angegeben werden, "SELECT ResultFieldName FROM TableName WHERE " ist fest kodiert.

Beispiel:

Bezeichnung (Matchcode) des Kontakts, der mit dem aktuellen Dokument verknüpft ist:

{ExecSQLScalar:crmdb,contact,matchcode,Sonstiger Kontakt,contactguid={doc:contactguid,sqlescapeguid}}

Nummer des ersten Lieferscheins im Buchungsjahr 2023:

{ExecSQLScalar:docdb,document,docno,,project='2023' AND category='Lieferschein' ORDER BY receiptdate}

Siehe auch

Makro-Referenz

ExecSQL

DBLookup


ExecStringDlg

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ExecStringDlg

Makro-Funktion ExecStringDlg

Einen Text aus einer Liste wählen.

Syntax

{ExecStringDlg:StringList[,VisibleEdit,MultiSelect,ReturnWithPath,Title]}

Parameter

StringList kann Folgendes beinhalten:
- Name einer vorhandenen Textdatei. Die Zeilen der Datei werden gelistet.
- Vorhandenes Verzeichnis mit Dateimaske, um alle entsprechenden Dateien in diesem Verzeichnis aufzulisten.
- Name eines Office Manager-Datenbankfeldes mit Auswahlliste zur Wahl eines Listeneintrages.
- Ein beliebiger, i. d. R. mehrzeiliger Text

Optionale Parameter

VisibleEdit: 0 oder 1, Vorgabe ist 0. Bei 1 kann der Anwender zusätzlich zur Auswahlliste einen freien Text eingeben.

MultiSelect: 0, 1 oder 2, Vorgabe ist 0. Der Wert 1 oder 2 ermöglicht es, mehrere Texte zu markieren. Diese werden dann bei 1 durch Komma bzw. bei 2 mit Zeilenumbruch getrennt zurückgegeben.

ReturnWithPath: 0 oder 1, Vorgabe ist 0. Nur für die Auswahl von Dateien (StringList enthält ein Verzeichnis): bei 1 wird der vollständige Dateiname mit Pfad zurückgegeben.

Title: Titel des Dialogfensters.

Rückgabewert

Vom Anwender gewählter oder eingetippter Text.

Beschreibung

Öffnet einen Dialog zur Auswahl eines Textes aus einer Liste. Das Dialogfenster beinhaltet auch eine Filterfunktion, um die Auswahl aus umfangreichen Liste zu vereinfachen.

Die Abarbeitung des Makros wird beendet, falls der Anwender auf die Schaltfläche Abbrechen klickt.

Beispiele

{ExecStringDlg:G:\Daten\Liste.txt}

{ExecStringDlg:USERNAME,1}

{ExecStringDlg:G:\Daten\*.txt,0,1,1,Das steht im Titel}

{MessageDlg:{ExecStringDlg:G:\Daten\*.txt,0,2,1}}

{ExecStringDlg:Zeile 1{Chr:13}Zeile 2}

Siehe auch

Makro-Referenz

Benutzerverwaltung

Beispiel Kundenliste


ExecuteDocuments

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ExecuteDocuments

Makro-Prozedur ExecuteDocuments

Befehl für Dokumente ausführen.

Syntax

{ExecuteDocuments:Command[,CmdParams]}

Parameter

Command: Name des Befehls (z. B. "open") oder der Dateiname einer Anwendung bzw. eines Makros. Makro- oder Skriptdateien werden im Verzeichnis "(Gemeinsame Dateien)\Macro" erwartet, falls kein Pfad angegeben ist.

CmdParams: Optionale Startparameter, wenn für Command eine Anwendung angegeben wurde. Als erster Parameter wird i. d. R. "{CurrDocFileName}" verwendet. Mehrere Parameter werden durch Leerzeichen getrennt. Wenn ein Parameter Leerzeichen beinhaltet, muss er in doppelten Anführungszeichen stehen.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Prozedur führt Dokumentbefehle, wie beispielsweise Öffnen, Drucken oder benutzerdefinierte Befehle für die markierten Dokumente in der aktiven Tabelle aus. Verwenden Sie DBSearch und GridDocSelect, um die gewünschten Dokumente zu markieren.

Siehe auch

Makro-Referenz

DBSearch

GridDocSelect

OpenDocument

ShellExecute


ExecuteGPT

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ExecuteGPT

Makro-Funktion ExecuteGPT

Künstliche Intelligenz mit "Generative Pre-trained Transformer" ausführen.

Syntax 1

{ExecuteGPT:Function,Database,Input}

Parameter

Function: Nummer der KI-Standardfunktion:
1: Chat
2: Text übersetzen
3: Suche erzeugen
4: Dokumentenerkennung
5: Bilderkennung
6: Kontakterkennung
7: Makro-Editor

Database: gibt die Datenverbindung für die Funktionen 3, 4, 5 und 6 an. Verwenden Sie "DocDB" für das Dokumentenarchiv oder "CRMDB" für die Kontaktdatenbank.

Input: Die Frage an die KI, der zu analysierende Text oder der Bilddateiname für die Bilderkennung. Diese Eingabe wird als {GPTInput} an die Standardfunktion gegeben. Kommata im Input stören nicht

Rückgabewert

Antwort (Output) des GPT.

Syntax 2

{ExecuteGPT:BaseURL,Key,Model,MaxTokens,Reduce,SystemRole,UserRole}

Parameter

BaseURL: URL des GPT

Key: API-Schlüssel

Model: GPT-Modell

MaxTokens: Anweisung an GPT für maximale Tokenanzahl

Reduce: Dokumententext des Inputs auf diese Tokenanzahl kürzen. Bei Bilderkennung das Bild auf diese Pixelhöhe oder -breite verkleinern.

SystemRole: Input der Systemrolle. Diese darf kein Komma enthalten, siehe OmApiCsvParams.

UserRole: Input der Benutzerrolle, diese darf kein Komma enthalten.

Rückgabewert

Antwort (Output) des GPT.

Beschreibung

Die Funktion kommuniziert mit der Künstlichen Intelligenz und gibt die Antwort (Output) zurück. Syntax 1 führt eine der Standradfunktionen aus, Syntax 2 ist frei definierbar.

Eine KI-Funktion kann beispielsweise abhängig vom Dokumententyp im Hauptmenü Start | Verwenden | Befehl oder als Datei in Makro hinterlegt werden.

Beispiele

{ExecuteGPT:2,,The computer is in the office}

{ExecuteGPT:http://localhost:4891/v1,Key,Llama 3 8B Instruct,1024,320,,Was ist eine XRechnung?}

Siehe auch

Makro-Referenz

Künstliche Intelligenz

AutoCaptGPT


ExecuteMacroFile

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ExecuteMacroFile

Makro-Funktion ExecuteMacroFile

Führt ein OmAPI-Makro oder ein OmPascal-Skript in der angegebenen Textdatei aus.

Syntax

{ExecuteMacroFile:FileName[,CallFunction=FunctionName]}

Parameter

FileName: Dateiname des OmAPI-Makros (*.omac, *.omacen) oder des Pascal-Skriptes (*.pas, *.pasen).
Die Datei wird im Verzeichnis "Gemeinsame Dateien\Macro" gesucht, falls sie ohne Pfad angegeben wurde. "menu\Dateiname" ist ebenfalls möglich.

Optionaler Parameter

FunctionName: Aufruf einer Funktion im Pascal-Skript.

Rückgabewert

Rückgabewert des ausgeführten Makros ohne Zeilenumbrüche.

Beschreibung

ExecuteMacroFile führt das in der Datei enthaltene OmAPI-Makro oder Pascal-Skript sofort aus und gibt die Ergebnisse der enthaltenen Variablen als Text ohne Zeilenumbrüche zurück.

Wenn Sie bei der benutzerdefinierte Steuerung von Anwendungen den Inhalt der Datei in ein DDE-Makro einfügen möchten, verwenden Sie bitte IncludeMacroFile.

Siehe auch

Makro-Referenz

IncludeMacroFile

ScriptControl für andere Sprachen (nur 32 Bit)


ExecuteOCR

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ExecuteOCR

Makro-Prozedur ExecuteOCR

Führt die voreingestellte OCR-Software aus.

Syntax

{ExecuteOCR:ImgFileName[,ExeName,FileSuffix]}

Parameter

ImgFileName: Kompletter Dateiname der Grafikdatei, z. B. "{Source}" beim Importieren.

ExeName: Optionale Angabe der OCR-Programmdatei. Wenn der Parameter nicht angegeben oder die Datei nicht vorhanden ist, wird die voreingestellte OCR-Software verwendet.

FileSuffix: Optionale Angabe einer Suffix für den OCR-Zieldateinamen. Beispielsweise hängt "ABBYY FineReader for ScanSnap" den Text "_OCR" an den PDF-Dateinamen an. Die gescannte Datei "12345.pdf" wird nach "12345_OCR.pdf" kopiert und der erkannte Text in dieser Kopie gespeichert. Der Office Manager verwendet die Kopie und löscht die ursprüngliche Datei. Falls eine falsche Suffix angegeben wurde, "12345_OCR.pdf" also nicht vorhanden ist, wird die ursprüngliche Datei verwendet.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

ExecuteOCR führt die voreingestellte oder im Parameter angegebene Texterkennungs-Software (OCR) aus. Anschließend sollte FtiUpdate und WriteJournal aufgerufen werden.

Hinweis

Die Funktion ist mit der "Hot Folder OCR" nicht möglich. Verwenden Sie in diesem Fall AddSysTask.

Siehe auch

Makro-Referenz

FtiUpdate

ShellExecute

Einstellungen OCR-Software

OCR nachträglich ausführen


Exit

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

Exit

Makro-Prozedur Exit

Beendet das Makro.

Syntax

{Exit[:Condition]}

Parameter

Condition: optionale Angabe einer Bedingung: das Makro wird nur verlassen, wenn die Bedingung erfüllt ist. Condition erlaubt die Operatoren =, <>, < und >.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Mit einem Aufruf von {Exit} wird das Makro beendet, folgende Zeilen werden nicht mehr ausgeführt. Diese Funktion wird i. d. R. zusammen mit der IF-Anweisung oder der Condition eingesetzt.

Beispiel

{Exit:{Doc:STATE}<>Normal}: Das Makro verlassen, wenn der Status des aktuellen Dokuments nicht "Normal" ist.

Siehe auch

Makro-Referenz

Bedingte Ausführung

IF-Bedingung

DBCheckFieldValue

RaiseError


ExtractAttachment

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ExtractAttachment

Verfügbar in diesen Editionen

Makro-Prozedur ExtractAttachment

Extrahiert die einer E-Mail anliegenden oder in einem Komprimierungscontainer enthaltenen Dateien.

Syntax

{ExtractAttachment:SrcFileName,DstPath[,Overwrite,AttachFileName]}

Parameter

SrcFileName: Dateiname des Dokuments, z. B. {Doc:FileName}.

DstPath: Zielverzeichnis. In der Regel ein temporärer Ordner, der am Ende des Skriptes wieder gelöscht wird. Das Verzeichnis wird automatisch angelegt, wenn es noch nicht vorhanden ist.

Optionale Parameter

Overwrite: 0 oder 1. Bei 1 werden alle Zieldateien oder Rückfrage überschrieben, falls diese bereits vorhanden sind. Bei 0 (dies ist auch der Vorgabewert) werden neue Zieldateinamen verwendet, falls die Originaldateinamen bereits vorhanden sind.
Sonderfall alle Dateien aus einem Komprimierungscontainer (inkl .exe) entpackten: Wenn Overwrite=0 ist und das Zielverzeichnis DstPath bereits existiert, dann wird ein neues Unterverzeichnis mit den Dateien angelegt.

AttachFileName: Alternativ zur Extrahierung aller Dateien können Sie auch eine einzelne angeben, um nur diese zu kopieren.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Funktion speichert E-Mail-Anlagen und entpackt komprimierte Archivdateien in ein vorgegebenes Verzeichnis.

Folgende Quelldateitypen werden unterstützt:

·.eml, .nws: E-Mail

·.msg: binäre Outlook-Datei

·PDF-Datei

·.jar, .tar, .gz, .tgz, .cab, .zip: Komprimierungs-Container

·.exe: nur selbstextrahierende ZIP-Dateien

Siehe auch

Makro-Referenz

ExtractImages

PackFiles

MailGetProperty

GetFirstExistingFile


ExtractDocumentText

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ExtractDocumentText

Makro-Prozedur ExtractDocumentText

Extrahiert den Text aus einer Dokumentdatei.

Syntax

{ExtractDocumentText:SrcFileName,DstFileName[,InclAttr]}

Parameter

SrcFileName: Dateiname des Dokuments, z. B. {Source} oder {CurrDocFileName}.

DstFileName: Name der Zieldatei.

InclAttr (optional): Geben Sie "0" an, um den Dokumenteninhalt ohne Attribute (Datei-, PDF, E-Mail-Attribute u. a.) zurückzugeben. Standardwert ist "1" mit Attributen.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Prozedur liest den Volltext eines Dokuments und speichert ihn in eine Textdatei.

Beispiel

Siehe FtiGetKeywordValue

Siehe auch

Makro-Referenz

FtiGetKeywordValue

FtiGetWord

PDFGetTextFromRect

ImgExtractMetaWords

FileConvert

ExtractImages

Scan-Profile


ExtractImages

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ExtractImages

Makro-Prozedur ExtractImages

Extrahiert Grafiken aus einer PDF-Datei.

Syntax

{ExtractImages:FileName,ImgPath[,PageNum]}

Parameter

FileName: Name der PDF-Datei.

ImgPath: Zielverzeichnis für die Grafiken. Das Verzeichnis muss vorhanden sein, geben Sie es bitte mit abschließendem Backslash "\" an.

PageNum: wenn die optionale Seitennummer angegeben wird, werden nur Grafiken dieser Seite extrahiert. Anderenfalls alle Grafiken.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die in einer Acrobat-Datei enthaltenen Grafiken werden extrahiert und nach ImgPath kopiert.

Beispiel

{ExtractImages:{CurrDocFileName},C:\Bilder}

Siehe auch

Makro-Referenz

AcroExchGetTextFromRect

ImgExtractMetaWords

ExtractDocumentText

ExtractAttachment

ExtractPages

FileConvert


ExtractPages

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ExtractPages

Makro-Prozedur ExtractPages

Seiten aus einer Acrobat-Datei in eine neue PDF kopieren.

Syntax

{ExtractPages:SourceFileName,DestFileName,Pages}

Parameter

SourceFileName: Quelldateiname. Die Datei, welche die zu kopierenden Seiten beinhaltet.

DestFileName: Zieldateiname. In diese werden die Seiten kopiert.

Pages: Liste der zu kopierenden Seiten. Die Seiten werden in der aufgeführten Reihenfolge in das Zieldokument kopiert, es sind auch Mehrfachnennungen möglich. Einzelne Seiten bitte mit Komma trennen. Mehrere in Folge können mit Bindestrich definiert werden.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Prozedur extrahiert Seiten aus einer bestehenden PDF-Datei und kopiert diese in ein neues Dokument. Die Quelldatei wird dabei nicht verändert.

Beispiel

{ExtractPages:C:\Quelldatei.pdf,C:\Zieldatei.pdf,1,5,1,23-30,7}

Siehe auch

Makro-Referenz

ExtractImages

SplitDocument

MergeDocuments


FDTableNames

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

FDTableNames

Verfügbar in diesen Editionen

Makro-Variable FDTableNames

Listet die Tabellen der geöffneten FD-Datenbank.

Syntax

{FDTableNames}

Parameter

Keine

Rückgabewert

Datensatz-Anzahl

Beschreibung

Die Variable enthält die Tabellennamen der zuvor mit FDSetConnection n geöffnet Datenbank als mehrzeiligen Text.

Siehe auch

Makro-Referenz


FieldAttribute

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

FieldAttribute

Makro-Variable FieldAttribute

Erweiterte Eigenschaften der Dokumenten- und Kontaktdatenfelder.

Syntax

{FieldAttribute:DBID,FieldName,Result[,Separator]}

{OmDBFieldDoc:FieldName,Result[,Separator]} (veraltet für Archivfelder, nicht mehr verwenden)

Parameter

DBID: Verwenden Sie "DocDB" für das Dokumentenarchiv und "CRMDB" für die Kontaktdatenbank.

FieldName: Name des Datenbankfeldes

Result

Caption: Sichtbare Bezeichnung des Datenfeldes

Pickitems: Einträge der Auswahlliste

PickitemsFilename: Dateiname der Auswahlliste, wenn diese als globale Liste für alle Archive und Kontaktdatenbanken definiert ist. Anderenfalls wird "ITMNAME" zurückgegeben.

FilePath: Format der erweiterten Eingabestile, wie z. B. Dateiliste.

Separator: Wenn Result gleich "PickItems" ist, dann müssen Sie in diesem Parameter ein Trennzeichen für die einzelnen Werte eingeben. Dies ist in der Regel ein Punkt. Das Trennzeichen wird auch als erstes und letztes Zeichen hinzugefügt. Oder spezielle Trennungen mit "csv", "csvquoted" und "json".

Rückgabewert

Wert entsprechend dem Parameter Result.

Beschreibung

Ermöglicht den Zugriff auf die erweiterten Eigenschaften der Datenbankfelder des geöffneten Dokumentenarchivs und der Kontaktdatenbank.

Beispiel

{FieldAttribute:{CurrDatabase:DBID},category,PickItems,JSon}

Siehe auch

Makro-Referenz

Variablen für Datenfelder

FieldInfo

Datenfelder definieren

Pascal TFieldAttribute


FieldInfo

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

FieldInfo

Makro-Funktion FieldInfo

Gibt Datenbank-Feldinformationen zurück.

Syntax

{FieldInfo:Table,Result,reserved,TypeFilter,NameFilter,Separator}

Parameter

Table: Programminterne Kennung der Datenbanktabelle oder "AdoDataset". Die Tabelle muss geöffnet sein.

Result: Beschreibt die Daten, die zurückgegeben werden sollen:

FieldName: Feldnamen

DataType: Datentypen

Size: Feldgrößen

reserved: Reserviert, bitte 0 eingeben.

TypeFilter: Nur Felder das angegebenen Typs zurückgeben. Jokerzeichen * und ?.

NameFilter: Nur Felder mit passendem Namen zurückgeben. Jokerzeichen * und ?.

Separator: Trennzeichen zwischen den Feldnamen.

Rückgabewert

Je nach Parameter Result die Feldnamen, Typen oder Größen.

Beschreibung

Die Funktion gibt Feldnamen, Typ oder Größe der geöffneten Datenquelle zurück.

Beispiel

{FieldInfo:Document,FieldName,0,*,*,,}

{FieldInfo:Document,Size,0,ftWideString,*,#13#10}

Siehe auch

Makro-Referenz

FieldAttribute

Feldwerte abfragen


FileAttr

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

FileAttr

Makro-Funktion FileAttr

Gibt Dateiattribute zurück.

Syntax

{FileAttr:FileName,Attribute[,DateFormat]}

Parameter

FileName: Name mit komplettem Pfad der Datei.

Attribute: mögliche Dateiattribute:
Compressed gibt "1" für komprimierte Dateien zurück, sonst "0"
CreateDate: Datum und Zeit der Dateierzeugung
CreateDateUTC als koordinierte Weltzeit
Domain: Domäne
EditDate: Datum und Zeit der letzten Bearbeitung
EditDateUTC als koordinierte Weltzeit
FileSize: Größe der Datei in Byte
HashSumMD5: MD5-Hashsumme der Datei.
LastAccessDate: Datum und Zeit des letzten Zugriffs. Sonderfall RDX WORM: Ende der Aufbewahrungsfrist.
LastAccessDateUTC als koordinierte Weltzeit
ReadOnly gibt "1" für schreibgeschützte Dateien zurück, sonst "0"
Owner: Dateibesitzer
Version: Dateiversion, sofern vorhanden (s. a. Self:ExeVersion)

DateFormat: optionale Formatierung des Datums (nur bei EditDate und CreateDate).

Rückgabewert

Das gewünschte Dateiattribut.

Beschreibung

Mit dieser Funktion können die Attribute einer beliebigen Datei ermittelt werden.

Beispiel

{FileAttr:{Doc:FileName},CreateDate,dd.mm.yyyy}

Siehe auch

Makro-Referenz

FileSetAttr

Date

OleSummaryInformation

OleDocumentSummaryInformation

OleUserDefinedProperties

FileSecureTakeOwnership

Dateiabhängige Dokumentattribute


FileConvert

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

FileConvert

Makro-Prozedur FileConvert

Dateien, insbesondere Grafiken konvertieren.

Syntax

{FileConvert:SrcFileName,DstFileName}

Parameter

SrcFileName: Name der Quelldatei.

DstFileName: Name der Zieldatei.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Diese Prozedur dient in ersten Linie der Konvertierung von Grafikdateien in andere Grafikformate und zur Einbettung von Bildern in PDF-Dokumente. Sie kann aber auch Dokumententexte extrahieren, wenn eine .txt-Datei als Ziel angegeben wird und das Quellformat vom Programm eingelesen werden kann.

Mögliche Grafikformate sind: TIFF, GIF, JPEG, PCX, BMP, ICO, CUR, PNG, WMF, EMF, TGA, PXM, GreyMap, AVI, WBMP, Postscript, PDF, DCX, Digital Camera RAW, Bitmap RAW, WMV, MPEG, Adobe Photoshop PSD, IEV Vectorial objects, LYR Layers, DICOM medical imaging, HDP. Beachten Sie bitte, dass die Grafikkonvertierung nicht in allen Richtungen möglich ist - probieren Sie die gewünschten Formate bitte aus.

Die Zieldatei darf nicht vorhanden sein. Wenn Sie diese überschreiben möchten, dann rufen Sie zuvor bitte DeleteFile auf.

Beispiel

{FileConvert:C:\Temp\Bild.bmp,C:\Temp\konvertiert.jpg}

{FileConvert:C:\Temp\Bild.bmp,C:\Temp\eingebettet.pdf}

{FileConvert:{Doc:FileName},C:\Temp\konvertiert.bmp}

Siehe auch

Makro-Referenz

ExtractDocumentText

ExtractImages


FileExecuteMacro

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

FileExecuteMacro

Makro-Funktion FileExecuteMacro

Experimentelle Funktion, um Makros in PDF-Dokumenten auszuwerten und die Platzhalter zu ersetzen.

Syntax

{FileExecuteMacro:SrcFileName,DstFileName}

Parameter

SrcFileName: Name der Vorlagendatei

DstFileName: Zieldateidname

Rückgabewert

Gibt bei Erfolg den Zieldateinamen zurück, andernfalls einen Leerstring.

Beschreibung

Die Funktion öffnet die Vorlagendatei, liest den enthaltenen Text und interpretiert alle enthaltenen Makros. Der resultierende Text wird in die Zieldatei geschrieben.

Beachten Sie aber bitte, dass die PDF-Vorlage einige Voraussetzungen erfüllen muss, um korrekt verarbeitet werden zu können. Nur einfache Layouts werden korrekt dargestellt.

Siehe auch

Makro-Referenz

Serienbriefe


FileExists

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

FileExists

Makro-Funktion FileExists

Prüft, ob eine Datei auf dem Datenträger oder im Archiv vorhanden ist.

Syntax

{FileExists:SearchIn,Option,FileName}

Parameter

SearchIn:
FileSystem: prüfen, ob der angegebene Dateiname auf eine vorhandene Datei verweist. Der Rückgabewert ist 1, wenn vorhanden und 0, wenn nicht vorhanden.
Database: die Archivdatenbank durchsuchen, um beispielsweise einen Import abzubrechen, wenn die gleiche Datei bereits im Archiv enthalten ist. Die Datenbank wird nach aktiven und archivierten Dokumenten (nur Enterprise-Edition) sowie nach Dokumentversionen mit der gleichen Hashsumme durchsucht und zusätzlich der Dateiinhalt verglichen.

Option: reserviert, bitte "0" eingeben.

FileName: Vollständiger Dateiname, z. B. {Source}.

Rückgabewert

Rückgabewert "0", wenn nicht vorhanden. "1", wenn in den aktiven Dokumenten gefunden, "2" in den archivierten und "3", wenn in den Versionen gefunden. Es sind auch Kombinationen möglich, zum Beispiel: "12": in den aktiven und archivierten oder "13": in aktiven und den Versionen.

Beschreibung

Mit dieser Funktion können Sie prüfen,

·ob eine Datei auf dem Datenträger existiert

·oder, ob diese bereits in der Dokumentendatenbank enthalten ist.

Beispiele

{MessageDlg:{IfThen:{FileExists:FileSystem,0,{CurrDocFileName}}>0,Dokumentdatei vorhanden,Datei fehlt oder Notiz/URL}}}

{RaiseError:Dokument bereits vorhanden,{FileExists:Database,0,{Source}}>0}

Siehe auch

Makro-Referenz

Bedingte Ausführung


FilePageCount

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

FilePageCount

Makro-Funktion FilePageCount

Gibt die Seitenzahl eines Dokumentes zurück.

Syntax

{FilePageCount:FileName}

Parameter

FileName: Dateiname des Dokuments, z. B. {CurrDocFileName}

Rückgabewert

Seitenzahl

Beschreibung

Die Funktion ermittelt die Seitenzahl der Dokumentdatei, siehe Liste der unterstützten Formate.

Für andere Dateien und bei Misserfolg wird "-1" zurückgegeben.

Siehe auch

Makro-Referenz

Dateiabhängige Dokumentattribute


FileSecureTakeOwnership

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

FileSecureTakeOwnership

Verfügbar in diesen Editionen

Makro-Prozedur FileSecureTakeOwnership

Besitzrechte einer Datei übernehmen.

Syntax

{FileSecureTakeOwnership:FileName[,UserName]}

Parameter

FileName: kompletter Dateiname mit Pfad.

UserName: kompletter Windows-Benutzername, ggf. mit Domäne "domain\user". Wenn der Parameter nicht angegeben ist, wird der aktuelle Benutzer verwendet.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Einschränkung

Diese potenziell gefährliche Funktion ist standardmäßig gesperrt.

Beschreibung

Der Windows-Benutzer UserName übernimmt die Besitzrechte der Datei FileName.

Siehe auch

Makro-Referenz

Dateizugriffsrechte

FileSecureSetRights

ExecUserDlg

FileAttr


FileSecureSetRights

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

FileSecureSetRights

Verfügbar in diesen Editionen

Makro-Prozedur FileSecureSetRights

Zugriffsrechte einer Datei setzen.

Syntax

{FileSecureSetRights:FileName,Definition[,SkipLoggedOnUser]}

Parameter

FileName: kompletter Dateiname mit Pfad.

Definition: Name der im Office Manager vordefinierten Zugriffsrechte.

SkipLoggedOnUser: Der aktuelle Benutzer (welcher die Rechte ändert) erhält i. d. R. volle Zugriffsrechte für die Datei. Mit diesem optionalen Parameter wird das verhindert, auch der aktuelle Benutzer erhält dann nur die Rechte entsprechend der Definition.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Prozedur setzte die Windows NT-Zugriffsrechte der angegebenen Datei.

Siehe auch

Makro-Referenz

Dateizugriffsrechte

FileSecureTakeOwnership


FileSetAttr

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

FileSetAttr

Verfügbar in diesen Editionen

Makro-Prozedur FileSetAttr

Dateiattribute schreiben.

Syntax

{FileSetAttr:FileName,Attribute=Value}

Parameter

FileName: Name mit komplettem Pfad der Datei.

Attribute: mögliche Dateiattribute:
Compressed: Komprimierungsattribut setzen
ReadOnly: Schreibschutz der Datei

Value: 0 oder 1: Mit 1 wird das Attribut gesetzt, mit 0 gelöscht.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Mit der Prozedur können die Dateiattribute "schreibgeschützt" und "komprimiert" gesetzt werden. Die Komprimierung ist nur auf NTFS-Laufwerken möglich.

Berücksichtigen Sie vor dem Setzen des Schreibschutz-Attributes, dass dies auf einigen revisionssicheren Datenträgern (z. B. RDX WORM) nicht rückgängig gemacht werden kann.

Beispiel

{FileAttr:{Doc:FileName},ReadOnly=1} aktiviert den Schreibschutz.

Siehe auch

Makro-Referenz

FileAttr

OleSummaryInformation

OleDocumentSummaryInformation

OleUserDefinedProperties

FileSecureTakeOwnership

Dateiabhängige Dokumentattribute


Format

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

Format

Makro-Funktion Format

Gibt einen Teil des übergebenen Textes zurück.

Syntax

{Format:Text,FormatParameter}

Parameter

Text: der zu formatierende Text.

FormatParameter: legt fest, welcher Teil von Text zurückgegeben werden soll.

Rückgabewert

Formatierter Text

Beschreibung

Viele Makrovariablen- und Funktionen können mit einem optionalen Formatparameter aufgerufen werden. Beispielsweise gibt {Doc:Filename,File} nur den Dateinamen ohne Pfad des aktuellen Dokuments zurück. Makrovariablen, die den optionalen Parameter nicht bieten, können innerhalb der Variablen Format aufgerufen werden.

Beispiele:

{Format:C:\Daten\Datei.txt,File} ergibt "Datei.txt".

{Format:{CurrDocFileName},File} entspricht {CurrDocFileName,File}

Siehe auch

Makro-Referenz

Formatparameter

StringReplace


FtiGetFirstCrspWord

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

FtiGetFirstCrspWord

Verfügbar in diesen Editionen

Makro-Funktion FtiGetFirstCrspWord

Gibt beim Dokumentenimport ein passendes Wort aus dem Volltextindex zurück.

Syntax

{FtiGetFirstCrspWord:Words}

Parameter

Words: Punktgetrennte Liste von Wörtern ".Wort1.Wort2.Wort3.". Die Liste beginnt und endet jeweils mit einem Punkt! Sie kann z. B. mit {FieldAttribute:DocDB,Feldname,Pickitems,.} erzeugt werden. Sie darf nur einzelne Wörter beinhalten, also "Auftragsbestätigung" und nicht "Auftrags-Bestätigung".

Rückgabewert

Passendes Wort aus der Liste.

Beschreibung

Die Funktion ermittelt das erste Wort der Liste Words, welches im Volltext des zu importierenden Dokuments enthalten ist. Sie kann eingesetzt werden, um importierte Dokumente automatisch zu katalogisieren.

Beispiel:

In den Import-Feldwerten wird dem Feld "Categorie" folgende Makrovariable zugeordnet:

{FtiGetFirstCrspWord:{FieldAttribute:DocDB,category,Pickitems,.}}

Die Auswahlliste Kategorie enthält die Einträge "Angebot" und "Rechnung".

Importierte Dokumente werden automatisch der Kategorie "Angebot" zugeordnet, wenn dieses Wort im Volltext als erstes Wort (vor dem Wort "Rechnung") enthalten ist.

Siehe auch

Makro-Referenz

Übersicht Belegerkennung

SelectionListFindItem

AutoCaptFirstCrspWord

Formatparameter FirstCrspWord

Scan-Profile


FtiGetKeywordValue

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

FtiGetKeywordValue

Verfügbar in diesen Editionen

Makro-Funktion FtiGetKeywordValue

Sucht im Dokument nach einem Schlüsselwort und gibt den darauf folgenden Text zurück.

Syntax

{FtiGetKeywordValue:FileName,Keywords,CharCount[,CutMultiLine,MatchCase,IgnoreChars]}

Parameter

FileName: Dateiname der Dokumentdatei, z. B. {Source}.

Keywords: Punktgetrennte Liste von Schlüsselwörtern ".Wort1.Wort2.Wort3.". Die Liste beginnt und endet jeweils mit einem Punkt. Die Schlüsselwörter selbst dürfen keinen Punkt und kein Komma enthalten. Ein Punkt kann aber mit "OMProVarPoint" und ein Komma mit "OMProVarComma" angegeben werden.

CharCount: Anzahl Zeichen, die nach dem Schlüsselwort übernommen werden sollen.

CutMultiLine: (optional) 1 = Ergebnis bei Zeilenumbruch (#10 oder #13) abschneiden, 0 = nicht abschneiden. Vorgabe ist 1.

MatchCase: (optional) 1 = Groß-/Kleinschreibung berücksichtigen, 0 = ignorieren. Vorgabe ist 0.

IgnoreChars: optionale Liste von Zeichen, die aus dem Ergebnis gelöscht werden sollen, z. B. "-. ;,"

Rückgabewert

Dokumententext, der auf ein Schlüsselwort folgt.

Beschreibung

Die Funktion dient der automatisierten Dokumentenverarbeitung. Das Dokument wird nach Schlagwörtern, wie "Kunden-Nr" oder "Rechnungs-Nr" durchsucht und der danach folgende Text (z. B. die Kunden- oder Rechnungsnummer) für die Speicherung in einem Attribut zurückgegeben.

Der resultierende String wird getrimmt: Leer- und Steuerzeichen am Anfang und Ende werden entfernt.

Beispiele

In den Dokumenten ist eine Kundennummer enthalten, die beim Import bzw. Scan automatisch einem Dokumentattribut zugewiesen werden soll. Im Text steht vor der Kundennummer das Schlüsselwort "Kunden-Nr" oder "KDNr":

{FtiGetKeywordValue:{Source},.kunden-nr.kdnr.,10,1,0,-. ;,}

Beispiel 2:

Es sollen mehrere Attribute eingelesen werden. Um zu verhindern, dass bei jedem Aufruf der Funktion eine erneute Dokument-Konvertierung in das Textformat durchgeführt werden muss, sollte der Text zuvor in eine temporäre Datei gespeichert werden. Folgendes wird beispielsweise im entsprechenden Importprofil definiert:

Makro "Vor Hinzufügen"

{SetPublVar:FtiFileName={GetTempFileName:.omfti}}{ExtractDocumentText:{Source},{GetPublVar:FtiFileName}}

Feldwert "Kundennr."

{FtiGetKeywordValue:{GetPublVar:FtiFileName},.kunden-nr.kdnr.,10,1,0, :}

Feldwert "Rechnungsnr."

{FtiGetKeywordValue:{GetPublVar:FtiFileName},.rechnungs-nr.,4,1,0,{Chr:9}}

Feldwert "Kunde."

{FtiGetKeywordValue:{GetPublVar:FtiFileName},.adresse: .adr.,25}

Makro "Nach Speichern"

{DeleteFile:{GetPublVar:FtiFileName},NoConfirm}}

Siehe auch

Makro-Referenz

Übersicht Belegerkennung

AutoCaptKeywordValue

AcroExchGetTextFromRect

Scan-Profile


FtiGetWord

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

FtiGetWord

Makro-Variable FtiGetWord

Gibt ein Wort aus dem Volltextindex zurück.

Syntax

{FtiGetWord:WordNum}

Parameter

WordNum: Nummer des Wortes, welches zurückgegeben werden soll. 1 steht für das erste Wort im Volltext.

Rückgabewert

Wort mit angegebener Nummer.

Beschreibung

Die Variable gibt das Wort mit der angegebenen Nummer aus dem Volltext des aktuellen Dokuments zurück. Sie wird in der Regel nur bei den Import-Feldwerten verwendet.

Siehe auch

Makro-Referenz

Übersicht Belegerkennung

AutoCaptFtiWord

FtiGetFirstCrspWord


FtiUpdate

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

FtiUpdate

Makro-Prozedur FtiUpdate

Aktualisiert den Volltextindex.

Syntax

{FtiUpdate}

Parameter

Keine

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Prozedur indexiert das aktuelle Dokument neu. Anschließend sollte UpdateDocAttributesFromFile aufgerufen werden, um beispielsweise FileWordCount zu aktualisieren.

Siehe auch

Makro-Referenz

ExecuteOCR


GetBackupFileName

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

GetBackupFileName

Makro-Funktion GetBackupFileName

Gibt einen sinnvollen Dateinamen für eine Sicherungskopie der genannten Datei zurück.

Syntax

{GetBackupFileName:FileName[,FormatParameter]}

Parameter

FileName: Name der Datei, für die eine Sicherungskopie erstellt werden soll.

Rückgabewert

Dateiname für Sicherungskopie.

Beschreibung

Diese Funktion können Sie beispielsweise in Zusammenhang mit den Prozeduren {CopyFile}} und {CopyDocFile} einsetzen, um eine Sicherungskopie der Dokument- oder einer anderen Datei zu erstellen. Der Text "_Copy", gefolgt von einer Zahl wird dabei an den Dateinamen angehängt.

Beispiel

{CopyFile:{CurrDocFileName},{GetBackupFileName:{CurrDocFileName}}} erstellt eine Sicherungskopie der aktuellen Dokumentdatei.

Siehe auch

Makro-Referenz

CopyFile

ExecSaveDlg


GetControl

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

GetControl

Makro-Funktion GetControl

Eigenschaft eines Formular-Controls lesen.

Syntax

{GetControl:Path,Property}

Parameter

Path: Kompletter Pfad und Name des Controls: FormName.Container.ControlName, z. B.
FormDBEdit.LayoutPanelMainFields.CoBoxApplName

Property: Name der Eigenschaft:
enabled: Bool (0 oder 1)
visible: Bool
left: Integer
top: Integer
width: Integer
height: Integer
hint: String

Rückgabewert

Control-Eigenschaften

Beschreibung

Mit GetControl können Sie Eigenschaften eines Controls (Eingabefeld, Schalter u. ä.) aus einem Makro heraus einlesen.

Die Funktion richtet sich an Applikations-Entwickler.

Siehe auch

Makro-Referenz

SetControl

Layout-Designer


GetFirstExistingFile

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

GetFirstExistingFile

Makro-Variable GetFirstExistingFile

Gibt den ersten Parameter zurück, der den Namen einer vorhandenen Datei beinhaltet.

Syntax

{GetFirstExistingFile:FileName1,FileName2, ...}

Parameter

Kommagetrennte Liste von Dateinamen.

Rückgabewert

Dateiname

Beschreibung

Mit GetFirstExistingFile können Sie eine Liste von alternativen Dateinamen angeben. Es wird der erste Dateiname zurückgegeben, der auf eine existierende Datei verweist.

In den Dateinamen sind auch die Jokerzeichen * und ? möglich.

Siehe auch

Makro-Referenz

Bedingte Ausführung

GetFirstNotEmpty


GetFirstNotEmpty

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

GetFirstNotEmpty

Makro-Variable GetFirstNotEmpty

Gibt den ersten, nicht leeren Parameter zurück.

Syntax

{GetFirstNotEmpty:Params}

Parameter

Params: Kommagetrennte Liste von Makrovariablen.

Rückgabewert

Erster nicht leerer Parameter.

Beschreibung

Mit GetFirstNotEmpty können Sie eine Liste von alternativen Variablen angeben. Es wird die erste, nicht leere Variable zurückgegeben. Variablen, die nur Leerzeichen enthalten werden als leer betrachtet.

Beispiel

Beim Import von Dokumentdateien wird als Name die erweitere Dateieigenschaft "Titel" verwendet. Falls "Titel" leer ist, wird der Dateiname verwendet:

{GetFirstNotEmpty:{OleSummaryInformation:Title,{Source}},{Source:Name}}

Siehe auch

Makro-Referenz

Beispiel Dokumentenverzeichnis definieren

Bedingte Ausführung

GetFirstExistingFile


GetPrivVar

GetPrivVar, GetPublVar

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

GetPrivVar, GetPublVar

Makro-Variable GetPrivVar

Makro-Variable GetPublVar

Benutzer-Variable lesen.

Syntax

{GetPrivVar:Variable[,FormatParam]}

{GetPublVar:Variable[,FormatParam]}

Parameter

Variable: Name der benutzerdefinierten Variablen oder ein reservierter Bezeichner:
*List: gibt eine Liste aller privaten oder öffentlichen Variablen in Form "Name=Wert(Umbruch)" zurück.
{MessageDlg:{GetPrivVar:*List}} wird zum Beispiel häufig beim Debuggen von Makros verwendet.

FormatParam: Optionaler Formatparameter

Rückgabewert

Inhalt der privaten bzw. globalen Variablen.

Beschreibung

Liest den Wert einer zuvor mit SetPrivVar oder SetPublVar definierten Variablen.

Private Variablen (GetPrivVar) sind nur innerhalb des Makros gültig. Öffentliche (GetPublVar) gelten zur gesamten Laufzeit des DMS-Programms.

Siehe auch

Makro-Referenz

SetPrivVar, SetPublVar

InifileReadStr


GetTempFileName

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

GetTempFileName

Makro-Funktion GetTempFileName

Gibt einen temporären Dateinamen zurück.

Syntax

{GetTempFileName[:Extension]}

Parameter

Extension: Optionale Dateiendung inklusive Punkt. Vorgabe ist der Windows-Standard ".tmp".

Rückgabewert

Temporärer Dateiname.

Beschreibung

Die Funktion erstellt eine neue, leere Datei im temporären Verzeichnis und gibt den Dateinamen zurück. Wenn keine Extension vorgegeben wurde, dann wird die Windows API-Funktion GetTempFileName aufgerufen.

Siehe auch

Makro-Referenz

GetBackupFileName

OS


GridDocClearSelection

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

GridDocClearSelection

Makro-Prozedur GridDocClearSelection

Markierung der Dokumenttabelle aufheben.

Syntax

{GridDocClearSelection}

Parameter

Keine

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Nach einem Aufruf von GridDocClearSelection ist in der Tabelle kein Dokument mehr markiert.

Siehe auch

Makro-Referenz

GridDocSelect

GridDocSelectedCount

ExecuteDocuments


GridDocSelect

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

GridDocSelect

Makro-Prozedur GridDocSelect

Dokumente in der Tabelle markieren.

Syntax

{GridDocSelect:Range}

Parameter

Range: "Current" markiert den aktuellen Datensatz, "Search" alle Dokumente der aktuellen Suche.
Alternativ können Sie auch die Schlüsselnummern der zu markierenden Dokumente angeben, z. B. {GridDocSelect:123,518,685}

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Prozedur markiert Dokumente in der Tabelle und dient beispielsweise der Vorbereitung für ExecuteDocuments.

Siehe auch

Makro-Referenz

GridDocClearSelection

GridDocSelectedCount

DBSearch

ExecuteDocuments


GridDocSelectedCount

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

GridDocSelectedCount

Makro-Variable GridDocSelectedCount

Anzahl der markierten Dokumente.

Syntax

{GridDocSelectedCount}

Parameter

Keine

Rückgabewert

Anzahl markierter Dokumente

Beschreibung

Die Variable enthält die Anzahl der in der Tabelle markierten aktiven oder archivierten Dokumente.

Siehe auch

Makro-Referenz

GridDocClearSelection

GridDocSelect


GridSelectedCell

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

GridSelectedCell

Makro-Variable GridSelectedCell

Feldname oder Wert der zuletzt mit der rechten Maustaste angeklickten Tabellenzelle.

Syntax

{GridSelectedCell:Result}

Parameter

Result: "FieldName" gibt den Feldnamen, "Value" den Wert zurück.

Rückgabewert

Feldname oder -wert.

Beschreibung

Für die Suche nach ähnlichen Dokumenten können Sie eine Zelle mit der rechten Maustaste anklicken. Hierfür merkt sich das Programm den Feldnamen und -wert der angeklickten Tabellenzelle. Diese können sie mit GridSelectedCell abfragen. Sinnvoll ist die Verwendung i. d. R. nur im lokalen Popupmenü einer Datentabelle.

Beispiel

Eintrag in der usermenu.ini:

[usrPopupTvDocumentCellInfo]

RibbonBar=PopupTvDocument

Parent=PopupTvDocument

Position=0

BeginGroupInMenu=0

Caption=Angeklickte Zelle

MacroCmd={MessageDlg:{GridSelectedCell:FieldName}={GridSelectedCell:Value}}

Hint=Zeigt die mit der rechten Maustaste angeklickte Zelle

Siehe auch

Makro-Referenz


GridSortOrder

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

GridSortOrder

Makro-Funktion GridSortOrder

Die Sortierung einer Tabellenspalte abfragen oder setzen.

Syntax

{GridSortOrder:TableID,FieldName[,SortOrder]}

Parameter

TableID: "document" für die Dokumententabellen oder "contact" für die Kontakte.

FieldName: Feldname der Tabellenspalte.

SortOrder: Wenn dieser dritte Parameter angegeben ist, wird die Sortierung gesetzt, anderenfalls abgefragt.

Rückgabewert

Wenn nur zwei Parameter angegeben sind, wird die derzeitige Sortierung zurückgegeben.

Beschreibung

Anwendende können die Tabellen im Hauptfenster mit einem Klick auf die Tabellenüberschrift sortieren. Voraussetzung ist die aktivierte Option Datensätze in Speicher laden.

Mit dieser Funktion kann die alphanumerische Sortierung auch in einem Makro gelesen oder gesetzt werden:

0=nicht sortiert

1=aufsteigend sortiert

2=absteigend sortiert

Beispiele

Die Sortierung nach Belegdatum abfragen:

{GridSortOrder:document,receiptdate}

Aufsteigend sortieren:

{GridSortOrder:document,receiptdate,1}

Siehe auch

Makro-Referenz


GUID

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

GUID

Makro-Variable GUID

Gibt eine neue GUID zurück.

Syntax

{GUID[:Option]}

Parameter

Option: 0 oder nicht angegeben: komplette GUID mit Klammern und Bindestrichen
1: ohne Klammern,
2:. ohne Bindestriche,
3: ohne Klammern und ohne Bindestriche.

Rückgabewert

Eindeutiger Bezeichner

Beschreibung

Die Variable erzeugt mit Hilfe der Windows-Funktion CoCreateGuid eine neue GUID und wird durch diese ersetzt.

Globally Unique Identifier (globaler eindeutiger Bezeichner) sind eine Implementierung des UUID-Standards, sie sind sehr wahrscheinlich eindeutig.

Beispiel-GUID: {FADD311E-DEB5-4BDA-9212-F63E8B07990C}

Siehe auch

Makro-Referenz

StringReplace

Formatparameter SqlEscapeGuid

Wikipedia


HelpContext

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

HelpContext

Makro-Prozedur HelpContext

Öffnet ein Office Manager-Hilfethema.

Syntax

{HelpContext:ContextID}

Parameter

ContextID: ID-Nummer der Hilfeseite.
Oder: "FTIHelp" für das Thema Volltextsuche oder Volltextsuche mit MS SQL-Server je nach aktueller Einstellung.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Prozedur zeigt das mit ContextID angegebene Hilfethema.

Siehe auch

Makro-Referenz


Bedingte Ausführung

Bedingte Ausführung in OmAPI-Makros

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

Bedingte Ausführung in OmAPI-Makros

Übersicht der Makro-Funktionen und -variablen, die für bedingtes Ausführen (if then) geeignet sind.

Tipp: Wenn Sie umfangreiche Skripte schreiben möchten, dann können Sie alternativ mit Pascal, JScript und VBScript programmieren.

Geeignete Funktionen und Variablen

DBCheckFieldValue

Makro abbrechen, falls der aktuelle Datensatz nicht den gewünschten Wert in einem Datenfeld hat.

Exit

Das Makro verlassen, wenn eine Bedingung erfüllt ist.

FileExists

Datei vorhanden oder als Dokument bereits im Archiv.

FtiGetFirstCrspWord

Aus einer Liste von möglichen Wörtern das erste zurückgeben, welches im Dokument enthalten ist.

GetFirstExistingFile

Gibt aus einer Liste den ersten Parameter zurück, der den Namen einer vorhandenen Datei beinhaltet.

GetFirstNotEmpty

Gibt den ersten, nicht leeren Parameter zurück.

IF

IF- und IF not-Bedingung für DDE-Makros und Makro-Dateien.

IfThen

Werte abhängig von einer Bedingung zurückgeben.

MessageDlg

Öffnet eine Message-Box und ermöglicht den Abbruch des Makros durch den Benutzer.

RaiseError

Das Makro mit einem Fehler verlassen, wenn eine Bedingung erfüllt ist.

WaitForFile

Ermöglicht neben dem Warten auf eine Datei auch einen Abbruch, wenn eine Datei vorhanden oder nicht vorhanden ist.


IF

IF-Anweisung

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

IF-Anweisung

Makro IF-Anweisung

Anweisung für bedingte Ausführung.

Syntax:

{IF:Condition}Ausführung nur unter der Bedingung{ENDIF}

{IF:not Condition} Ausführung nicht unter der Bedingung{ENDIF}

Condition

AlreadyRunning: die Bedingung ist erfüllt, wenn die Anwendung bereits geöffnet war.

FileExists,FileName: ist erfüllt, wenn die Datei mit dem angegebenen Namen vorhanden ist. (s. a. WaitForFile). Sie können auch die Jokerzeichen * und ? verwenden.

FileExists ohne Dateiparameter ist erfüllt, wenn die aktuelle Dokumentdatei vorhanden ist.

DocTableExists,Table: ist erfüllt, wenn die Tabelle im Dokumentenarchiv vorhanden ist.

MessageDlg,Text: ist erfüllt, wenn der Anwender im Dialogfenster auf OK klickt.

Rückgabewert

Eingeschlossener Text, sofern die Bedingung erfüllt ist.

Beschreibung

In der Office Manager Makro-Sprache können Sie die IF-Anweisung verwenden, um Teile des DDE-Makros nur auszuführen bzw. zu senden, wenn eine vorgeschriebene Bedingung erfüllt ist. Der gesamte Text zwischen {IF:Condition} und {ENDIF} wird ignoriert, wenn die Bedingung nicht erfüllt ist.

Einschränkungen

Geschachtelte IF-Anweisungen sind nicht erlaubt. IF kann nur innerhalb eines Makros der benutzerdefinierte Steuerung von Anwendungen und in Makrodateien verwendet werden. Innerhalb der Condition (Bedingung) sind keine Variablen möglich. Für umfangreiche bedingte Ausführungen sind Skriptsprachen - wie Pascal, JScript oder Visual Basic - besser geeignet.

Siehe auch

Makro-Referenz

Bedingte Ausführung

IfThen

GetFirstNotEmpty

Exit

RaiseError

GetPrivVar


IfThen

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

IfThen

Makro-Funktion IfThen

Rückgabe von Werten entsprechend einer Bedingung.

Syntax

{IfThen:Condition,TrueValue[,FalseValue]}

Parameter

Condition: Die Variable gibt den ersten Parameter TrueValue zurück, wenn die Bedingung erfüllt ist.
Condition erlaubt die Operatoren =, <>, < und >. Zwischen Groß- und Kleinschreibung wird nicht unterschieden.
Hinweis: '=' und '<>' vergleichen den Text, '01' ist dabei ungleich '1'.
'<' und '>' sind nur für ganze Zahlen erlaubt, '01' ist dabei gleich '1'.

TrueValue: Wird zurückgegeben, wenn die Bedingung erfüllt ist.

FalseValue (optional): Wird zurückgegeben, wenn die Bedingung nicht erfüllt ist.

Rückgabewert

Einen der Parameter, je nach Bedingung.

Beschreibung

Die Funktion gibt TrueValue zurück, wenn die Bedingung erfüllt ist. Wenn die Bedingung nicht erfüllt wird, ist die Rückgabe leer bzw. der Wert im optionalen Parameter FalseValue. Im Gegensatz zu IF kann diese Variable in beliebigen Makros verwendet werden.

Wenn Sie in TrueValue oder FalseValue Variablen oder Funktionen verwenden, dann beachten Sie bitte, dass diese unabhängig von der Bedingung immer interpretiert werden. In der Regel werden also nur Variablen und keine Funktionen als Parameter angegeben, siehe unten "Fehlerhaftes Beispiel".

Beispiele

Korrektes Beispiel

{DBSetField:Doc,STATE={IfThen:{Doc:CATEGORY}=Anfrage,Zu erledigen,Archiv}}

Wenn die Dokumentenkategorie "Anfrage" ist, dann wird "Zu erledigen" in das Statusfeld kopiert. Anderenfalls ist der Status "Archiv".

Fehlerhaftes Beispiel

{IfThen:{Doc:CATEGORY}=Anfrage,{DBSetField:Doc,STATE=Zu erledigen},{DBSetField:Doc,STATE=Archiv}}

Auf den ersten Blick sollte dies zum gleichen Ergebnis führen. Tatsächlich ist der Status anschließend aber immer "Archiv". Der Interpreter führt zuerst "{DBSetField:Doc,STATE=Zu erledigen}" aus, dann "{DBSetField:Doc,STATE=Archiv}" und wertet zuletzt die IfThen-Variable aus. Diese hat aber keine Bedeutung, weil die beiden DBSetField-Funktionen keinen Wert zurückgeben.

Siehe auch

Makro-Referenz

Bedingte Ausführung

IF-Anweisung


ImgCalcDensityHistogram

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ImgCalcDensityHistogram

Verfügbar in diesen Editionen

Makro-Funktion ImgCalcDensityHistogram

Histogramm der Bild-Pixeldichte.

Syntax

{ImgCalcDensityHistogram:FileName,PageNum,Left,Right,Top,Bottom,Relative,Direction,ConvBW[,TestFileName]}

Parameter

FileName: Dateiname der Grafik- oder PDF-Datei (z. B. {Source}) oder Sonderfall StackScanImg.

PageNum: Seitennummer bei PDF-Dokumenten und mehrseitigen TIFF-Dateien.

Left, Right, Top, Bottom: Definiert ein Rechteck auf der Seite, in dem sich der zu extrahierende Text befindet. Left und Right geben den Abstand vom linken Seitenrand, Top und Bottom den Abstand vom oberen Rand an. Es sind nur ganze Zahlen erlaubt. Tipp: der Wert von Top ist immer kleiner als Bottom, Left ist kleiner als Right.

Relative: 0, 1 oder 2. Bei 0 wird das Rechteck in absoluten Pixel angegeben.
Bei 1 enthalten Left, Right, Top und Bottom prozentuale Werte, wobei Left=10 beispielsweise 10% der Seitenbreite angibt.
2 ist ebenfalls relativ, jedoch mit einer berechneten Auflösung von 10.000 statt 100 (Left=1000 gibt 10% der Seitenbreite).
Beachten Sie bitte, dass die Pixel mit der Scanner-Auflösung variieren, verwenden Sie bevorzugt die relative Werte.

Direction: v für vertikal oder h für horizontal.

ConvBW: 0 oder 1: Bei 1 wird der Bildausschnitt vor der Verarbeitung in Schwarzweiß konvertiert.

TestFileName: Wenn dieser optionale Parameter angegeben ist, wird der Grafikausschnitt in der angegebenen Bilddatei gespeichert. Sie können überprüfen, ob der korrekte Ausschnitt definiert wurde. Der Parameter sollte nach erfolgreichen Tests wieder entfernt werden. Geben Sie den Dateinamen bitte ohne Endung an, z. B. "C:\Temp\Test". Wenn die Datei bereits vorhanden ist, wird automatisch eine Zahl angehängt.

Rückgabewert

Histogramm der Pixeldichte als CSV-Text.

Beschreibung

Hilfsfunktion für die automatische Formularerkennung, insbesondere dem Optical Mark Recognition (Erkennung von s. g. Ankreuzfeldern).

Hinweis: Bei PDF-Dokumenten wird immer die erste Grafik auf der Seite verwendet.

Siehe auch

Makro-Referenz

ImgGetBlackDotsRatio

Übersicht Belegerkennung

Scan-Profile


ImgExtractMetaWords

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ImgExtractMetaWords

Makro-Funktion ImgExtractMetaWords

Gibt den EXIF- und IPTC-Daten aus einer Bilddatei zurück.

Syntax

{ImgExtractMetaWords:FileName}

Parameter

FileName: Dateiname der JPEG- oder TIFF-Datei.

Rückgabewert

Alle EXIF- und IPTC-Daten.

Beschreibung

In Bilddateien werden, beispielsweise von Digitalkameras, zusätzliche Informationen gespeichert. Die Makro-Variable ImgExtractMetaWords gibt alle enthaltenen Einträge als leerzeichengetrennte Liste zurück.

Diese Funktion wird intern für die Volltextindexierung verwendet.

Siehe auch

Makro-Referenz

FtiGetFirstCrspWord

WriteLnFile

ImgGetProperty

FileConvert


ImgGetBlackDotsRatio

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ImgGetBlackDotsRatio

Makro-Funktion ImgGetBlackDotsRatio

Gibt den Schwarzanteil eines Bildausschnittes in Prozent zurück.

Syntax

{ImgGetBlackDotsRatio:FileName,PageNum,Left,Right,Top,Bottom,Relative[,TestFileName]}

Parameter

FileName: Dateiname der Grafik- oder PDF-Datei (z. B. {Source}) oder Sonderfall StackScanImg.

PageNum: Seitennummer bei PDF-Dokumenten und mehrseitigen TIFF-Dateien.

Left, Right, Top, Bottom: Definiert ein Rechteck auf der Seite, in dem sich der zu extrahierende Text befindet. Left und Right geben den Abstand vom linken Seitenrand, Top und Bottom den Abstand vom oberen Rand an. Es sind nur ganze Zahlen erlaubt. Tipp: der Wert von Top ist immer kleiner als Bottom, Left ist kleiner als Right.

Relative: 0, 1 oder 2. Bei 0 wird das Rechteck in absoluten Pixel angegeben.
Bei 1 enthalten Left, Right, Top und Bottom prozentuale Werte, wobei Left=10 beispielsweise 10% der Seitenbreite angibt.
2 ist ebenfalls relativ, jedoch mit einer berechneten Auflösung von 10.000 statt 100 (Left=1000 gibt 10% der Seitenbreite).
Beachten Sie bitte, dass die Pixel mit der Scanner-Auflösung variieren, verwenden Sie bevorzugt die relative Werte.

TestFileName: Wenn dieser optionale Parameter angegeben ist, wird der Grafikausschnitt in der angegebenen Bilddatei gespeichert. Sie können überprüfen, ob der korrekte Ausschnitt definiert wurde. Der Parameter sollte nach erfolgreichen Tests wieder entfernt werden. Geben Sie den Dateinamen bitte ohne Endung an, z. B. "C:\Temp\Test". Wenn die Datei bereits vorhanden ist, wird automatisch eine Zahl angehängt.

Rückgabewert

Schwarzanteil in Prozent.

Beschreibung

Hilfsfunktion für die automatische Formularerkennung, insbesondere dem Optical Mark Recognition (Erkennung von s. g. Ankreuzfeldern).

Hinweis: Bei PDF-Dokumenten wird immer die erste Grafik auf der Seite verwendet.

Siehe auch

Makro-Referenz

ImgCalcDensityHistogram

Übersicht Belegerkennung

Scan-Profile


ImgGetProperty

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ImgGetProperty

Makro-Variable ImgGetProperty

Enthält Informationen (EXIF "Exchangeable Image File Format", IPTC u. a.) einer Bilddatei.

Syntax

{ImgGetProperty:FileName,ItemName}

Parameter

FileName: Dateiname der JPeg- oder Tiff-Datei.

ItemName: Name der gewünschten Information. Mögliche Werte sind:

FILENAME

FILETYPESTR

FILETYPE

BITSPERSAMPLE

SAMPLESPERPIXEL

WIDTH

HEIGHT

DPIX

DPIY

COLORMAPITEM (ItemNum)

COLORMAPCOUNT

ISNATIVEPIXELFORMAT

ENABLEADJUSTORIENTATION

TIFF_COMPRESSION

TIFF_IMAGEINDEX

TIFF_SUBINDEX

TIFF_IMAGECOUNT

TIFF_JPEGQUALITY

TIFF_ZIPCOMPRESSION

TIFF_PHOTOMETINTEPRET

TIFF_PLANARCONF

TIFF_XPOS

TIFF_YPOS

TIFF_GETTILE

TIFF_DOCUMENTNAME

TIFF_IMAGEDESCRIPTION

TIFF_PAGENAME

TIFF_PAGENUMBER

TIFF_PAGECOUNT

TIFF_JPEGCOLORSPACE

TIFF_FILLORDER

TIFF_ORIENTATION

TIFF_ENABLEADJUSTORIENTATION

TIFF_BYTEORDER

DCX_IMAGEINDEX

GIF_VERSION

GIF_IMAGEINDEX

GIF_IMAGECOUNT

GIF_XPOS

GIF_YPOS

GIF_DELAYTIME

GIF_TRANSPARENT

GIF_TRANSPCOLOR

GIF_INTERLACED

GIF_WINWIDTH

GIF_WINHEIGHT

GIF_BACKGROUND

GIF_RATIO

JPEG_COLORSPACE

JPEG_QUALITY

JPEG_DCTMETHOD

JPEG_OPTIMALHUFFMAN

JPEG_SMOOTH

JPEG_PROGRESSIVE

JPEG_SCALE_USED

JPEG_SCALE

JPEG_ENABLEADJUSTORIENTATION

JPEG_GETEXIFTHUMBNAIL

JPEG_WARNINGTOT

JPEG_WARNINGCODE

JPEG_ORIGINALWIDTH

JPEG_ORIGINALHEIGHT

ORIGINALWIDTH

ORIGINALHEIGHT

JPEG_CROMASUBSAMPLING

PCX_VERSION

PCX_COMPRESSION

BMP_VERSION

BMP_COMPRESSION

BMP_HANDLETRANSPARENCY

BMPRAW_CHANNELORDER

BMPRAW_PLANES

BMPRAW_ROWALIGN

BMPRAW_HEADERSIZE

ICO_IMAGEINDEX

ICO_BACKGROUND

CUR_IMAGEINDEX

CUR_XHOTSPOT

CUR_YHOTSPOT

CUR_BACKGROUND

PNG_INTERLACED

PNG_BACKGROUND

PNG_FILTER

PNG_COMPRESSION

PSD_LOADLAYERS

PSD_REPLACELAYERS

PSD_HASPREMULTIPLIEDALPHA

TGA_XPOS

TGA_YPOS

TGA_COMPRESSED

TGA_DESCRIPTOR

TGA_AUTHOR

TGA_DATE

TGA_IMAGENAME

TGA_BACKGROUND

TGA_ASPECTRATIO

TGA_GAMMA

TGA_GRAYLEVEL

J2000_COLORSPACE

J2000_RATE

J2000_SCALABLEBY

PS_PAPERWIDTH

PS_PAPERHEIGHT

PS_COMPRESSION

PS_TITLE

PDF_PAPERWIDTH

PDF_PAPERHEIGHT

PDF_COMPRESSION

PDF_TITLE

PDF_AUTHOR

PDF_SUBJECT

PDF_KEYWORDS

PDF_CREATOR

PDF_PRODUCER

EXIF_HASEXIF

EXIF_IMAGEDESCRIPTION

EXIF_MAKE

EXIF_MODEL

EXIF_ORIENTATION

EXIF_XRESOLUTION

EXIF_YRESOLUTION

EXIF_RESOLUTIONUNIT

EXIF_SOFTWARE

EXIF_DATETIME

EXIF_COPYRIGHT

EXIF_EXPOSURETIME

EXIF_FNUMBER

EXIF_EXPOSUREPROGRAM

EXIF_EXIFVERSION

EXIF_DATETIMEORIGINAL

EXIF_DATETIMEDIGITIZED

EXIF_COMPRESSEDBITSPERPIXEL

EXIF_SHUTTERSPEEDVALUE

EXIF_APERTUREVALUE

EXIF_BRIGHTNESSVALUE

EXIF_EXPOSUREBIASVALUE

EXIF_MAXAPERTUREVALUE

EXIF_SUBJECTDISTANCE

EXIF_METERINGMODE

EXIF_LIGHTSOURCE

EXIF_FLASH

EXIF_FOCALLENGTH

EXIF_SUBSECTIME

EXIF_SUBSECTIMEORIGINAL

EXIF_SUBSECTIMEDIGITIZED

EXIF_FLASHPIXVERSION

EXIF_COLORSPACE

EXIF_EXIFIMAGEWIDTH

EXIF_EXIFIMAGEHEIGHT

EXIF_RELATEDSOUNDFILE

EXIF_FOCALPLANEXRESOLUTION

EXIF_FOCALPLANEYRESOLUTION

EXIF_FOCALPLANERESOLUTIONUNIT

EXIF_EXPOSUREINDEX

EXIF_SENSINGMETHOD

EXIF_FILESOURCE

EXIF_SCENETYPE

EXIF_USERCOMMENT

EXIF_USERCOMMENTCODE

EXIF_EXPOSUREMODE

EXIF_WHITEBALANCE

EXIF_DIGITALZOOMRATIO

EXIF_FOCALLENGTHIN35MMFILM

EXIF_SCENECAPTURETYPE

EXIF_GAINCONTROL

EXIF_CONTRAST

EXIF_SATURATION

EXIF_SHARPNESS

EXIF_SUBJECTDISTANCERANGE

EXIF_IMAGEUNIQUEID

EXIF_ARTIST

EXIF_XPRATING

EXIF_XPTITLE

EXIF_XPCOMMENT

EXIF_XPAUTHOR

EXIF_XPKEYWORDS

EXIF_XPSUBJECT

EXIF_GPSVERSIONID

EXIF_GPSLATITUDEREF

EXIF_GPSLATITUDEDEGREES

EXIF_GPSLATITUDEMINUTES

EXIF_GPSLATITUDESECONDS

EXIF_GPSLONGITUDEREF

EXIF_GPSLONGITUDEDEGREES

EXIF_GPSLONGITUDEMINUTES

EXIF_GPSLONGITUDESECONDS

EXIF_GPSALTITUDEREF

EXIF_GPSALTITUDE

EXIF_GPSTIMESTAMPHOUR

EXIF_GPSTIMESTAMPMINUTE

EXIF_GPSTIMESTAMPSECOND

EXIF_GPSSATELLITES

EXIF_GPSSTATUS

EXIF_GPSMEASUREMODE

EXIF_GPSDOP

EXIF_GPSSPEEDREF

EXIF_GPSSPEED

EXIF_GPSTRACKREF

EXIF_GPSTRACK

EXIF_GPSIMGDIRECTIONREF

EXIF_GPSIMGDIRECTION

EXIF_GPSMAPDATUM

EXIF_GPSDESTLATITUDEREF

EXIF_GPSDESTLATITUDEDEGREES

EXIF_GPSDESTLATITUDEMINUTES

EXIF_GPSDESTLATITUDESECONDS

EXIF_GPSDESTLONGITUDEREF

EXIF_GPSDESTLONGITUDEDEGREES

EXIF_GPSDESTLONGITUDEMINUTES

EXIF_GPSDESTLONGITUDESECONDS

EXIF_GPSDESTBEARINGREF

EXIF_GPSDESTBEARING

EXIF_GPSDESTDISTANCEREF

EXIF_GPSDESTDISTANCE

EXIF_GPSDATESTAMP

IPTC_OBJECTNAME

IPTC_EDITSTATUS

IPTC_URGENCY

IPTC_CATEGRORY

IPTC_SUPPCATEGORY

IPTC_FIXTUREID

IPTC_KEYWORDS

IPTC_RELEASEDATE

IPTC_RELEASETIME

IPTC_SPECIALINSTRU

IPTC_REFSERVICE

IPTC_REFDATE

IPTC_REFNUMBER

IPTC_DATECREATED

IPTC_TIMECREATED

IPTC_ORIGINATINGPROGRAM

IPTC_PROGRAMVERSION

IPTC_OBJECTCYCLE

IPTC_BYLINE

IPTC_BYLINETITLE

IPTC_CITY

IPTC_STATE

IPTC_LOCATIONCODE

IPTC_LOCATIONNAME

IPTC_TRANSMISSIONREF

IPTC_IMAGECREDIT

IPTC_SOURCE

IPTC_COPYRIGHT

IPTC_IMAGECAPTION

IPTC_IMAGECAPTIONWRITER

IPTC_IMAGETYPE

RAW_HALFSIZE

RAW_GAMMA

RAW_BRIGHT

RAW_REDSCALE

RAW_BLUESCALE

RAW_QUICKINTERPOLATE

RAW_USEAUTOWB

RAW_USECAMERAWB

RAW_FOURCOLORRGB

RAW_CAMERA

RAW_GETEXIFTHUMBNAIL

RAW_AUTOADJUSTCOLORS

RAW_EXTRAPARAMS

MEDIAFILE_FRAMECOUNT

MEDIAFILE_FRAMEDELAYTIME

IMAGEINDEX

IMAGECOUNT

GETTHUMBNAIL

XMP_INFO

Rückgabewert

Die angeforderte EXIF- oder IPTC-Information.

Beschreibung

In Bilddateien (JPeg, Tiff u. a.) werden, beispielsweise von Digitalkameras, zusätzliche Informationen gespeichert. Die Makro-Variable ImgGetProperty gibt die im Parameter ItemName angegebenen Information zurück.

Siehe auch

Makro-Referenz

ImgExtractMetaWords

ImgWriteProperty


ImgGetTextFromRect

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ImgGetTextFromRect

Verfügbar in diesen Editionen

Makro-Funktion ImgGetTextFromRect

Bereich-OCR: Extrahiert Text aus einer Bilddatei, der sich an der angegebenen Position befindet.

Syntax

{ImgGetTextFromRect:FileName,PageNum,Left,Right,Top,Bottom,Relative[,TestFileName]}

Parameter

FileName: Dateiname der Grafik- oder PDF-Datei (z. B. {Source}) oder Sonderfall StackScanImg.

PageNum: Seitennummer bei PDF-Dokumenten und mehrseitigen TIFF-Dateien.

Left, Right, Top, Bottom: Definiert ein Rechteck auf der Seite, in dem sich der zu extrahierende Text befindet. Left und Right geben den Abstand vom linken Seitenrand, Top und Bottom den Abstand vom oberen Rand an. Es sind nur ganze Zahlen erlaubt. Tipp: der Wert von Top ist immer kleiner als Bottom, Left ist kleiner als Right.

Relative: 0, 1 oder 2. Bei 0 wird das Rechteck in absoluten Pixel angegeben.
Bei 1 enthalten Left, Right, Top und Bottom prozentuale Werte, wobei Left=10 beispielsweise 10% der Seitenbreite angibt.
2 ist ebenfalls relativ, jedoch mit einer berechneten Auflösung von 10.000 statt 100 (Left=1000 gibt 10% der Seitenbreite).
Beachten Sie bitte, dass die Pixel mit der Scanner-Auflösung variieren, verwenden Sie bevorzugt die relative Werte.

TestFileName: Wenn dieser optionale Parameter angegeben ist, wird der Grafikausschnitt in der angegebenen Bilddatei gespeichert. Sie können überprüfen, ob der korrekte Ausschnitt definiert wurde. Der Parameter sollte nach erfolgreichen Tests wieder entfernt werden. Geben Sie den Dateinamen bitte ohne Endung an, z. B. "C:\Temp\Test". Wenn die Datei bereits vorhanden ist, wird automatisch eine Zahl angehängt.

Rückgabewert

Von der OCR erkannter Text.

Beschreibung

Die Funktion gibt den Text zurück, der sich im vorgegebenen Rechteck auf dem Bilddokument befindet. Es werden diverse Grafikformate (bmp, jpeg, tiff und viele andere) unterstützt. Das Bild kann auch in einem PDF-Dokument eingebettet sein. Der Text wird mit Hilfe der OCR-Software erkannt.

Die Funktion wird beispielsweise beim Scannen von Formularen verwendet, um die Dokumentattribute, wie Kategorie oder Kundenname, automatisch vom Papier zu lesen.

Tipp: Wenn Sie Dokumente im PDF-Format scannen und anschließend eine OCR-Software ausführen, können Sie alternativ die Funktion AcroExchGetTextFromRect verwenden.

Hinweis: Bei PDF-Dokumenten wird immer die erste Grafik auf der Seite verwendet.

Systemvoraussetzungen:

Office Manager Enterprise-Edition

OCR-Software OmniPage, Transsym, Tesseract oder WindowsRT. Falls keine geeignete OCR-Software eingestellt ist, wird Tesseract verwendet.

Siehe auch

Makro-Referenz

Übersicht Belegerkennung

AcroExchGetTextFromRect

PDFGetTextFromRect

ImgReadBarcode

ImgExtractMetaWords

Scan-Profile


ImgReadBarcode

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ImgReadBarcode

Verfügbar in diesen Editionen

Makro-Funktion ImgReadBarcode

Liest Barcodes

Syntax

Syntax 1: {ImgReadBarcode:FileName,PageNum,BarType}

Syntax 2: {ImgReadBarcode:FileName,PageNum,Left,Right,Top,Bottom,Relative,BarType[,Result,TestFileName]}

Parameter

FileName: Dateiname der Grafik- oder PDF-Datei (z. B. {Source}) oder Sonderfall StackScanImg.

PageNum: Seitennummer bei PDF-Dokumenten und mehrseitigen TIFF-Dateien.

Left, Right, Top, Bottom: Definiert ein Rechteck auf der Seite, in dem sich der Barcode befindet. Left und Right geben den Abstand vom linken Seitenrand, Top und Bottom den Abstand vom oberen Rand an. Es sind nur ganze Zahlen erlaubt. Tipp: der Wert von Top ist immer kleiner als Bottom, Left ist kleiner als Right. Für eine Auswertung des ganzen Bildes kann Syntax 1 verwendet oder die Positionswerte mit -1 angegeben werden.

Relative: 0, 1 oder 2. Bei 0 wird das Rechteck in absoluten Pixel angegeben.
Bei 1 enthalten Left, Right, Top und Bottom prozentuale Werte, wobei Left=10 beispielsweise 10% der Seitenbreite angibt.
2 ist ebenfalls relativ, jedoch mit einer berechneten Auflösung von 10.000 statt 100 (Left=1000 gibt 10% der Seitenbreite).
Beachten Sie bitte, dass die Pixel mit der Scanner-Auflösung variieren, verwenden Sie bevorzugt relative Werte.

BarType: Geben Sie "Unknown" für eine automatische Erkennung aller unterstützten Codes außer PDF417 oder die Kurzbezeichnung des gewünschten Barcodes ein.

Result optional:
"Value" gibt den Wert des ersten Barcodes zurück.
"Type" gibt den Typ des ersten Barcodes zurück.
"Infos" Informationen zu allen gefundenen Barcodes.
"Values" für die Werte aller gefundenen Barcodes mit Zeilenumbruch getrennt.
Nur für 2D-Codes:
"ValueAsString" Text-Inhalt des ersten Barcodes. Dies entspricht derzeit "Value".
"ValueAsInteger" numerischer Inhalt des ersten Barcodes.

TestFileName: Wenn dieser optionale Parameter angegeben ist, wird der Grafikausschnitt in der angegebenen Bilddatei gespeichert. Sie können überprüfen, ob der korrekte Ausschnitt definiert wurde. Der Parameter sollte nach erfolgreichen Tests wieder entfernt werden. Geben Sie den Dateinamen bitte ohne Endung an, z. B. "C:\Temp\Test". Wenn die Datei bereits vorhanden ist, wird automatisch eine Zahl angehängt.

Rückgabewert

Barcode-Inhalt

Beschreibung

Die Funktion gibt den Text zurück, der im angegebenen Barcode kodiert ist. Es werden diverse Grafikformate (bmp, jpeg, tiff und viele andere) unterstützt. Das Bild kann auch in einem PDF-Dokument eingebettet sein.

Die Funktion wird beispielsweise beim Scannen verwendet, um eine kodierte Belegnummer vom Papier zu lesen.

Hinweis: Bei PDF-Dokumenten wird die erste Grafik auf der Seite verwendet. Bei gescannten Belegen beinhaltet eine Seite i. d. R. genau eine Grafik.

Beispiele

Barcode-Inhalt (1D) auf einer auszuwählenden Datei zeigen:

{MessageDlg:{ImgReadBarcode:{ExecOpenDlg:Bilddateien|*.pdf;*.bmp;*.jpg;*.jpeg;*.png;*.tif;*.tiff},1,Unknown}}

Textwert eines PDF417 im markierten Dokument auf der unteren Seitenhälfte in eine Variable kopieren und die Variable im Messagedialog zeigen:

{SetPrivVar:MyBarCode={ImgReadBarcode:{CurrDocFileName},1,1,100,50,100,1,PDF417,Value}}

{MessageDlg:{GetPrivVar:MyBarCode}}

Siehe auch

Makro-Referenz

Automatische Dokumentenerkennung

ImgGetTextFromRect

Scan-Profile


ImgWriteProperty

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ImgWriteProperty

Makro-Prozedur ImgWriteProperty

Schreibt Text-Informationen in eine Bilddatei, derzeit nur IPTC.

Syntax

{ImgWriteProperty:FileName,ItemName,ItemValue}

Parameter

FileName: Dateiname des Bildes.

ItemName: Name der gewünschten Information. Mögliche Werte sind:

IPTC_OBJECTNAME

IPTC_EDITSTATUS

IPTC_URGENCY

IPTC_CATEGRORY

IPTC_SUPPCATEGORY

IPTC_FIXTUREID

IPTC_KEYWORDS

IPTC_RELEASEDATE

IPTC_RELEASETIME

IPTC_SPECIALINSTRU

IPTC_REFSERVICE

IPTC_REFDATE

IPTC_REFNUMBER

IPTC_DATECREATED

IPTC_TIMECREATED

IPTC_ORIGINATINGPROGRAM

IPTC_PROGRAMVERSION

IPTC_OBJECTCYCLE

IPTC_BYLINE

IPTC_BYLINETITLE

IPTC_CITY

IPTC_STATE

IPTC_LOCATIONCODE

IPTC_LOCATIONNAME

IPTC_TRANSMISSIONREF

IPTC_IMAGECREDIT

IPTC_SOURCE

IPTC_COPYRIGHT

IPTC_IMAGECAPTION

IPTC_IMAGECAPTIONWRITER

IPTC_IMAGETYPE

ItemValue: Wert der gewünschten Information.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

In Bilddateien (z. B. JPeg-Bilder von Adobe Photoshop) können zusätzliche Informationen im IPTC-Standard gespeichert werden. IPTC steht für "International Press Telecommunications Council" und definiert Informationen für eine Publizierung der Bilder. Die Makro-Funktion ImgWriteProperty schreibt gibt die in den Parameter angegebene Information in die Datei.

Beispiel

{ImgWriteProperty:C:\Temp\F0001.jpg,IPTC_Copyright,Softwarebüro Krekeler}

schreibt den Copyright-Vermerk "Softwarebüro Krekeler" in die Bilddatei.

Siehe auch

Makro-Referenz

ImgGetProperty


ImportAbort

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ImportAbort

Sonderfunktion ImportAbort

Dokumenten-Import abbrechen.

Syntax

{ImportAbort}

Parameter

Keine

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Diese Funktion wird vom Makrointerpreter ignoriert, sie wird nur in den Import-Profilen berücksichtigt: Seite Makro, optionaler Makrobefehl Vor Hinzufügen. Wenn Sie hier {ImportAbort} eingeben, dann wird der Dokumentenimport nicht ausgeführt. Die Prüfung erfolgt erst nach Auswertung des Makros und ermöglicht so auch einen bedingten Abbruch.

Beispiel

Sie möchten Dateien aus einem Verzeichnis als Versionen zu bestehenden Dokumenten hinzufügen. Dies soll automatisch durchgeführt werden, sobald eine Datei im entsprechenden Verzeichnis abgelegt wird:

1.Erstellen Sie ein Makro, welches der Archivtabelle "docvers" neue Datensätze hinzufügt und speichern Sie dieses als "NeueVersion.omac".

2.Definieren Sie ein Importprofil mit Modus "Dokumente automatisch importieren" und lassen Sie die Makrodatei vor dem Hinzufügen des Dokumente ausführen.

3.Office Manager schaut regelmäßig nach, ob eine neue Datei im Verzeichnis vorhanden ist und führt dann das Makro aus.

4.Um zu verhindern, dass die Datei als neues Dokument importiert wird, geben Sie {ImportAbort} an.

Im Eingabefeld Makro | Vor Hinzufügen des Importprofils würde dann zum Beispiel stehen:

{ExecuteMacroFile:NeueVersion.omac}{ImportAbort}

Siehe auch

Makro-Referenz

Definition von Importprofilen


ImportFile

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ImportFile

Makro-Prozedur ImportFile

Dokumentdatei in das Archiv importieren.

Syntax

{ImportFile:FileName[,FieldName=Value,FieldName2=Value,...]}

Parameter

FileName: Name der zu importierenden Datei.

FieldName: Optionale Angabe von Inhalten der Datenbankfelder (Dokumentattribute).

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die angegebene Dokumentdatei wird an die Importfunktion übergeben und, sobald möglich, in das geöffnete Archiv importiert.

Diese Funktion wird auch vom Hilfsprogramm "SendToOM.exe“ verwendet, wenn Dateien vom Explorer oder einem Dokumentenscanner an den Office Manager gesendet wurden.

Beispiel

{ImportFile:C:\Daten\Datei.pdf} importiert Datei.pdf mit den Einstellungen des entsprechenden Importprofiles.

{ImportFile:C:\Daten\Datei.pdf,DOCNO=AR8456,NAME=Rechnung 8456} wie oben, jedoch mit Vorgabewerten für die Felder Dokument-Nummer und -Name.

"c:\Programme\Krekeler\Office Manager\sendtoom.exe" "{ImportFile:C:\Daten\Datei.pdf,DOCNO=AR8456,NAME=Rechnung 8456}" obiges Beispiel als Kommandozeile für das Tool SendToOM.

Siehe auch

Makro-Referenz

Definition von Importprofilen

COM-Methode ImportFile


IncludeMacroFile

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

IncludeMacroFile

Verfügbar in diesen Editionen

Makro-Funktion IncludeMacroFile

Fügt Makro-Variablen und -Funktionen aus der angegebenen Textdatei in das DDE-Makro ein. Nur für Office Manager-Makrosprache.

Syntax

{IncludeMacroFile:FileName}

Parameter

FileName: kompletter Dateiname des Makros.

Rückgabewert

Rückgabe des eingefügten Makros.

Beschreibung

Mit IncludeMacroFile können Sie die Makro-Variablen und -Funktionen ausführen, die in der angegebenen Textdatei enthalten sind. Wenn Sie bei der benutzerdefinierte Steuerung von Anwendungen den Inhalt der Datei in ein DDE-Makro einfügen möchten, verwenden Sie bitte IncludeMacroFile. Die Datei wird dabei vor dem Aufbau der DDE-Verbindung in das Makro eingefügt.

Die Funktion muss im Makro in einer eigenen Zeilen stehen!

Siehe auch

Makro-Referenz

ExecuteMacroFile


InifileOperation

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

InifileOperation

Makro-Prozedur InifileOperation

Funktionen für INI-Dateien.

Syntax

{InifileOperation:FileName,Operation,Section[,Ident]}

Syntax für MoveNumberKeys

{InifileOperation:FileName,MoveNumberKeys,Section,Increment[,PrivVarMin,PrivVarMax]}

Parameter

FileName: Dateiname der INI. Falls kein Pfad angegeben ist, dann wird die Datei im Verzeichnis der gemeinsamen Dateien erwartet.

Operation: Auszuführende Funktion:
DeleteKey zum Löschen eines Schlüssels.
EraseSection löscht eine ganze Sektion.
EraseSectionIfEmpty löscht die Sektion nur, wenn diese leer ist.
MoveNumberKeys: Sonderfunktion für Sektionen, die ausschließlich Ganzzahlen als Schlüsselnamen enthalten, siehe Beispiel unten.

Section: Name der INI-Sektion. Die Sektionen sind in der Datei in "["-Klammern eingeschlossen, geben Sie die Sektion hier ohne die Klammern an.

Ident: Optionaler Name des Schlüssel.

Nur für Operation "MoveNumberKeys":

Increment: Wert, der auf die Schlüsselname addiert werden soll.

PrivVarMin: Optionale Variable, in die der neue Minimalwert geschrieben wird.

PrivVarMax: Optionale Variable, in die der neue Maximalwert geschrieben wird.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Einschränkung

Diese potenziell gefährliche Funktion ist standardmäßig gesperrt.

Beschreibung

Die Funktion ermöglicht das Löschen von Sektionen oder Schlüsseln in einer Konfigurationsdatei sowie das Nummerieren innerhalb einer Sektion.

Beispiele für Operation "MoveNumberKeys"

[Dateien]
1=C:\DateiA.txt
2=C:\DateiB.txt
3=C:\DateiC.txt

In der oben gezeigten Beispiel-Sektion [Dateien] soll eine neue Datei an erster Stelle eingefügt werden. Die bereits vorhandenen sollen "nach unten rutschen". Anschließend soll eine Message Box den höchsten Schlüssel nennen:

{InifileOperation:C:\inidatei.ini,MoveNumberKeys,Dateien,1,NewMin,NewMax}
{InifileWriteStr:C:\inidatei.ini,Dateien,1,C:\DateiNeu.txt}
{MessageDlg:Der höchste Schlüssel ist jetzt {GetPrivVar:NewMax}}

Die Sektion sieht anschließend wie folgt aus und die Nachricht "Der höchste Schlüssel ist jetzt 4" wird gezeigt:

[Dateien]
1=C:\DateiNeu.txt
2=C:\DateiA.txt
3=C:\DateiB.txt
4=C:\DateiC.txt

Siehe auch

Makro-Referenz

InifileWriteStr

ReadAdminIni


InifileReadSection

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

InifileReadSection

Makro-Funktion InifileReadSection

Liest eine Sektion aus einer Konfigurationsdatei (*.ini).

Syntax

{InifileReadSection:FileName,Section,Result[,Separator]}

Parameter

FileName: Dateiname der INI. Falls kein Pfad angegeben ist, dann wird die Datei im Verzeichnis der gemeinsamen Dateien erwartet.

Section: Name der INI-Sektion. Die Sektionen sind in der Datei in "["-Klammern eingeschlossen, geben Sie die Sektion hier ohne die Klammern an.

Result: "Keys" gibt nur die Schlüssel, "Values" nur die Werte und "Entire" beides zurück.

Separator: Optionales Trennzeichen für die einzelnen Zeilen. Standard-Trennzeichen, wenn nicht angegeben, ist ein Zeilenumbruch.

Rückgabewert

Sektionsdaten aus der INI-Datei, wie im Parameter Result angegeben.

Beschreibung

Mit dieser Funktion wird eine komplette INI-Sektion ausgelesen.

Siehe auch

Makro-Referenz

InifileReadStr

InifileOperation

ReadAdminIni

RegistryReadStr

ReadLnFile


InifileReadStr

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

InifileReadStr

Makro-Funktion InifileReadStr

Liest einen Zeichenwert aus einer Konfigurationsdatei (*.ini).

Syntax

{InifileReadStr:FileName,Section,Ident}

Parameter

FileName: Dateiname der INI. Falls kein Pfad angegeben ist, dann wird die Datei im Verzeichnis der gemeinsamen Dateien erwartet.

Section: Name der INI-Sektion. Die Sektionen sind in der Datei in "["-Klammern eingeschlossen, geben Sie die Sektion hier ohne die Klammern an.

Ident: Name des Schlüssel (Wert vor dem =).

Rückgabewert

Wert aus INI-Datei.

Beschreibung

Mit dieser Funktion können Sie einen Zeichenwert aus einer INI-Datei lesen.

Siehe auch

Makro-Referenz

InifileWriteStr

InifileReadSection

InifileOperation

ReadAdminIni

RegistryReadStr

ReadLnFile

Formatparameter Values

CSVGetCell


InifileWriteStr

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

InifileWriteStr

Makro-Prozedur InifileWriteStr

Schreibt einen Zeichenwert in eine Konfigurationsdatei (*.ini).

Syntax

{InifileWriteStr:FileName,Section,Ident,Value}

Parameter

FileName: Dateiname der INI. Falls kein Pfad angegeben ist, dann wird die Datei im Verzeichnis der gemeinsamen Dateien erwartet.

Section: Name der INI-Sektion. Die Sektionen sind in der Datei in "["-Klammern eingeschlossen, geben Sie die Sektion hier ohne die Klammern an.

Ident: Name des Schlüssel (Wert vor dem =).

Value: Zu schreibender Text.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Mit dieser Prozedur können Sie einen Zeichenwert in eine INI-Datei schreiben. Die Datei wird erstellt, falls sie noch nicht vorhanden war.

Siehe auch

Makro-Referenz

InifileReadStr

InifileOperation

RegistryWriteStr

WriteLnFile


LastAppendedDocID

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

LastAppendedDocID

Makro-Variable LastAppendedDocID

Schlüsselnummer des zuletzt von diesem Client hinzugefügten Dokuments.

Syntax

{LastAppendedDocID}

Parameter

Keine

Rückgabewert

Schlüsselnummer

Beschreibung

Die Variable beinhaltet die Schlüsselnummer (Feld DOCID) des Dokuments, welches zuletzt von dem Client hinzugefügt wurde, der das Makro ausführt. Beim Programmstart und dem Öffnen des Archivs wird die Variable mit -1 initialisiert.

Siehe auch

Makro-Referenz


LoadLanguageFile

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

LoadLanguageFile

Makro-Prozedur LoadLanguageFile

Lädt eine Sprachdatei.

Syntax

{LoadLanguageFile:FileName}

Parameter

FileName: Name der Sprachdatei.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Prozedur lädt eine Sprachdatei zur teilweisen Übersetzung der Programmoberfläche.

Siehe auch

Makro-Referenz

SaveLanguageFile

Sprachdateien


MailGetProperty

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

MailGetProperty

Verfügbar in diesen Editionen

Makro-Funktion MailGetProperty

Eigenschaft einer E-Mail ermitteln.

Syntax

{MailGetProperty:PropertyName[,FileName]}

Parameter

PropertyName: Name der Eigenschaft, gültige Werte sind "From", "To", "Subject", "Date", "Client", "XMailer", "AttachNames", "Message-ID" sowie "Header" für den gesamten Header als mehrzeiliger Text.
"ToMail" und "FromMail" geben aus der Empfänger- bzw. Absenderadresse nur die Mailadresse zurück.
"*PrivVar" kopiert alle Properties in gleichnamige private Variablen, "*PublVar" in globale Variablen.

FileName: Optionaler Dateiname. Wenn kein Dateiname angegeben ist, dann wird auf die aktuelle Dokumentdatei zugegriffen. Unterstützte Dateiformate sind .eml, .msg und .nws.

Rückgabewert

Angeforderte Eigenschaft der Mail.

Beschreibung

Die Funktion liest eine Eigenschaft, wie z. B. die Betreffzeile einer E-Mail, oder den gesamten Header-Text aus der angegebenen Mail-Datei.

Siehe auch

Makro-Referenz

ExtractAttachment

AutoCaptEInvoice

MapiCreateEMail


MapiCreateEMail

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

MapiCreateEMail

Verfügbar in diesen Editionen

Makro-Prozedur MapiCreateEMail

Sendet eine E-Mail.

Syntax

{MapiCreateEMail:Recipient,Subject[,Body,AllowZIP,Attachment1,Attachment2,...]}

Parameter

Recipient: EMail-Adresse des Empfängers. Mehrere Adressen bitte mit Semikolon trennen.

Subject: Betreff der Mail *).

Body: Optionaler Text der Mail *).

AllowZIP: Optional 0 oder 1. Bei 1 werden die Anlage komprimiert, sofern diese insgesamt mehr als 200 KB enthalten und die Komprimierung mehr als 10% Speicherplatz einspart.

AttachmentN: Optionale Dateianlage(n).

*) Wenn im Text ein Komma erforderlich ist, dann verwenden Sie bitte die Chr-Variable: z. B. "Sehr geehrter Herr Mustermann{Chr:44} vielen Dank" statt "Sehr geehrter Herr Mustermann, vielen Dank".

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Erstellt mit Hilfe der Windows MAPI-Schnittstelle eine neue E-Mail.

Siehe auch

Makro-Referenz

Senden an E-Mail-Empfänger

OmAPI:ActDocSendToEMail

MailGetProperty

Sonderzeichen


MegaCreateFrame

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

MegaCreateFrame

Verfügbar in diesen Editionen

Makro-Funktion MegaCreateFrame

Schriftkopf für neue MegaCAD-Zeichnung ausfüllen.

Syntax

{MegaCreateFrame:Template[,CharToOem]}

Parameter

Template: Dateiname der CDL-Schriftkopfvorlage mit komplettem Pfad oder ohne Pfad, wenn in "Gemeinsame Dateien\Template" abgelegt.

CharToOem: Wenn dieser optionale Parameter gesetzt ist, werden Texte in den OEM-Zeichensatz (ASCII) konvertiert. Setzten Sie diesen Parameter bitte, wenn deutsche Umlaute fehlerhaft im Schriftkopf eingetragen werden.

Rückgabewert

Name der erzeugte CDL-Datei mit Schriftkopf zum Import in die Zeichnung.

Beschreibung

Nur für MegaCAD: Erzeugt den Schriftkopf für eine neue Zeichnung. Ersetzen Sie Template bitte durch den Namen der CDL-Vorlagendatei. Die Variable wird durch den Dateinamen der ausgefüllten CDL-Schriftkopfdatei ersetzt.

Office Manager kopiert die Vorlagendatei in das temporäre Verzeichnis und füllt die enthaltenen Variablen (*DTM_) mit den im Zeichnungsarchiv eingegebenen Texten. Diese temporäre CDL wird anschließend in die Zeichnung importiert.

Hinweis: Für AutoCAD verwenden Sie bitte AcadComNewDwg und für andere CAD-Systeme DxfCreateFrame.

Beispiel

DDE-Befehl
CDLRead {MegaCreateFrame:c:\megacad\zngkopf.cdl}

Siehe auch

Makro-Referenz

Einrichtungsassistent für MegaCAD

Schriftkopf-Erzeugung für MegaCAD manuell einstellen

DxfCreateFrame


MessageBeep

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

MessageBeep

Makro-Prozedur MessageBeep

Gibt einen Signalton aus.

Syntax:

{MessageBeep:Parameter}

Parameter

Parameter: gültiger Parameter für Windows-Funktion "MessageBeep"
-1: Standardsignalton,
0 : MB_OK,
16: MB_ICONHAND ($00000010)
32: MB_ICONQUESTION ($00000020)
48: MB_ICONEXCLAMATION ($00000030)
64: MB_ICONASTERISK ($00000040)

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Ruft die Windows-Funktion "MessageBeep" auf und gibt den im Parameter definierten Signalton aus.

Siehe auch

Makro-Referenz

WinAPI:PlaySound


MessageDlg

MessageDlg, MessageDlgCB

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

MessageDlg, MessageDlgCB

Makro-Prozedur MessageDlg

Makro-Prozedur MessageDlgCB

Öffnet ein Dialogfenster zur Bestätigung durch den Anwender.

Syntax

{MessageDlg:Text}

{MessageDlgCB:Name,Text}

Parameter

Name: Nur bei MessageDlgCB: eindeutiger Name für die Option "Diesen Dialog erneut zeigen".

Text: Meldung, die im Dialogfenster ausgegeben wird. Bei MessageDlg wird der Text ggf. auf 10.000 Zeichen gekürzt.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Öffnet ein Windows-Dialogfenster mit dem im Parameter Text angegebenen Hinweisen oder Fragen. Sobald der Anwender auf OK klickt, wird mit dem Abarbeiten des Makros fortgefahren. Klickt er auf Abbrechen, so wird das Makro nicht weiter ausgeführt.

Vor Durchführung umfangreicher Änderungen im Dokumentenarchiv sollte der Anwender dies zum Beispiel bestätigen.

Bei der Funktion MessageDlgCB kann der Benutzer angeben, ob der Dialog erneut angezeigt werden soll.

Siehe auch

Makro-Referenz

WriteStatusbar

Bedingte Ausführung

ExecInputQuery

Wait


MinimizeApplication

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

MinimizeApplication

Makro-Prozedur MinimizeApplication

Minimiert und deaktiviert die Anwendung.

Syntax

{MinimizeApplication:Parameter}

Parameter

Parameter

Self: Minimiert den Office Manager

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Minimiert die Anwendung, so dass sie in der Taskleiste als Symbol dargestellt wird. Diese Funktion lässt sich derzeit nur mit dem Parameter Self aufrufen, sie wirkt sich also nur auf den Office Manager selbst aus. Verwenden Sie {WinAPI:ShowWindow:6} für andere Anwendungen.

Siehe auch

Makro-Referenz

WinAPI


MoveFile

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

MoveFile

Makro-Prozedur MoveFile

Datei oder Verzeichnis verschieben bzw. umbenennen.

Syntax

{MoveFile:SrcName,DstName}

Parameter

SrcName: Vollständiger Pfad der Quelldatei oder des Quellverzeichnisses.

DstName: Der neue Name inkl. Pfad.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Einschränkung

Diese potenziell gefährliche Funktion ist standardmäßig gesperrt.

Beschreibung

Verschiebt die Quelldatei oder das Verzeichnis SrcName nach DstName. Bei Fehlern, oder falls das Ziel bereits vorhanden ist, wird eine Fehlermeldung erzeugt und das Makro beendet. Falls Sie die Funktion auch ausführen möchten, wenn die Zieldatei bereits vorhanden ist, können Sie vor MoveFile die Funktion {DeleteFile:DstName,NoConfirm} aufrufen.

Siehe auch

Makro-Referenz

CopyFile

DeleteFile

IF-Bedingung


OleDocumentSummaryInformation

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

OleDocumentSummaryInformation

Makro-Variable OleDocumentSummaryInformation

Gibt erweiterte Dateieigenschaften (Größe, Zeichenanzahl u. a.) zurück.

Syntax

{OleDocumentSummaryInformation:PropertyName[,FileName]}

Parameter

PropertyName: Name der Eigenschaft. Gültige Werte: "PresentationTarget", "Bytes", "Lines", "Paragraphs", "Slides", "Notes", "HiddenSlides", "MMClips", "ScaleCrop", "HeadingPairs", "TitlesofParts", "Manager", "Company", "LinksUpTo Date", "Characters (with spaces)"
oder "(TotalList)" für eine Gesamtliste "Name=Wert".

FileName: Optionaler Dateiname. Wenn kein Dateiname angegeben ist, wird auf die aktuelle Dokumentdatei zugegriffen.

Rückgabewert

Angeforderte erweiterte Dateieigenschaft.

Beschreibung

Die Variable enthält Dateiinformationen des "OLE Property Set" von Office-Dokumenten. Siehe auch Eigenschaften im Popupmenü des Windows-Explorers. Die Variable ist leer, wenn die entsprechende Eigenschaft nicht vorhanden ist.

Beispiel

{OleDocumentSummaryInformation:Notes} enthält Notizen des aktuellen Dokuments.

Siehe auch

Makro-Referenz

Automatische Belegerkennung

OleSummaryInformation

OleUserDefinedProperties

OleSetDocumentSummaryInformation

FileAttr


OleMessageRegisterFilter

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

OleMessageRegisterFilter

Makro-Prozedur OleMessageRegisterFilter

Implementiert IOleMessageFilter.

Syntax

{OleMessageRegisterFilter}

Parameter

Keine

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Wenn Sie bei der COM-Automatisierung einer anderen Anwendung den Fehler "Aufruf wurde durch Augerufenen abgelehnt" erhalten, dann rufen Sie vor der Erzeugung des COM/OLE-Objektes bitte {OleMessageRegisterFilter} auf. Geben Sie den Filter am Ende des Skriptes mit {OleMessageRevokeFilter} wieder frei.

Englische Fehlermeldungen sind "Call was Rejected By Callee" oder "Application is Busy".

Diese Prozedur wurde mit Office Manager-Version 11.0.2.444 eingeführt. Die interne AutoCAD-Schnittstelle registriert den Filter automatisch.

Siehe auch

Makro-Referenz

OleMessageRevokeFilter für die anschließende Freigabe

How to: Fix 'Application is Busy' and 'Call was Rejected By Callee' Errors


OleMessageRevokeFilter

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

OleMessageRevokeFilter

Makro-Prozedur OleMessageRevokeFilter

Gibt den zuvor mit registrierten IOleMessageFilter wieder frei.

Syntax

{OleMessageRevokeFilter}

Parameter

Keine

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Siehe OleMessageRegisterFilter

Siehe auch

Makro-Referenz


OleSummaryInformation

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

OleSummaryInformation

Makro-Variable OleSummaryInformation

Gibt erweiterte Dateieigenschaften (Autor, Kommentar u. a.) zurück.

Syntax

{OleSummaryInformation:PropertyName[,FileName]}

Parameter

PropertyName: Name der Eigenschaft. Gültige Werte: "Title", "Subject", "Author", "Keywords", "Comments", "Template", "Last Saved By", "Revision Number", "Total Editing Time", "Last Printed", "Create Time/Date", "Last Saved Time/Date", "Number of Pages", "Number of Words", "Number of Characters", "Thumbnail", "Creating Application", "Security"
oder "(TotalList)" für eine Gesamtliste "Name=Wert".

FileName: Optionaler Dateiname. Wenn kein Dateiname angegeben ist, wird auf die aktuelle Dokumentdatei zugegriffen.

Rückgabewert

Angeforderte erweiterte Dateieigenschaft.

Beschreibung

Die Variable enthält Dateiinformationen des "OLE Property Set" von Office-Dokumenten. Die Variable ist leer, wenn die entsprechende Eigenschaft nicht vorhanden ist.

Beispiele

{OleSummaryInformation:Comments} enthält die Kommentare des aktuellen Dokuments.

{OleSummaryInformation:Title,{Source}} enthält den Titel einer zu importierenden Datei.

Siehe auch

Makro-Referenz

Automatische Belegerkennung

OleDocumentSummaryInformation

OleUserDefinedProperties

OleSetSummaryInformation

FileAttr


OleUserDefinedProperties

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

OleUserDefinedProperties

Makro-Variable OleUserDefinedProperties

Gibt benutzerdefinierte Dateieigenschaften zurück.

Syntax:

{OleUserDefinedProperties:PropertyName[,FileName]}

Parameter

PropertyName: Name der benutzerdefinierten Eigenschaft oder "(TotalList)" für eine Gesamtliste "Name=Wert".

FileName: Optionaler Dateiname. Wenn kein Dateiname angegeben ist, wird auf die aktuelle Dokumentdatei zugegriffen.

Rückgabewert

Angeforderte erweiterte Dateieigenschaft.

Beschreibung

Die Variable enthält Dateiinformationen des "OLE Property Set". Siehe beispielsweise im Explorer-PopupmenüEigenschaften auf der Seite Benutzerdefiniert. Die Variable ist leer, wenn die entsprechende Eigenschaft nicht vorhanden ist.

Siehe auch

Makro-Referenz

Automatische Belegerkennung

OleSummaryInformation

OleDocumentSummaryInformation

OleSetUserDefinedProperties

FileAttr


OleSetDocumentSummaryInformation

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

OleSetDocumentSummaryInformation

Makro-Prozedur OleSetDocumentSummaryInformation

Erweiterte Dateieigenschaften schreiben.

Syntax

{OleSetDocumentSummaryInformation:Property=Value[,Property2=Value,..,FileName]}

Parameter

Property: Name oder ID-Nummer der Eigenschaft, s. a. OleDocumentSummaryInformation

Value: Zu schreibender Eigenschaftswert.

FileName: Optionaler Dateiname. Wenn kein Dateiname angegeben ist, wird die aktuelle Dokumentdatei verwendet. Der optionale Dateiname darf kein Gleichheitszeichen enthalten.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Prozedur schreibt eine oder mehrere Dateieigenschaften des "OLE Property Set" von Office-Dokumenten.

Beispiel

{OleSetDocumentSummaryInformation:Notes=Meine Notiz,Company=Softwarebüro,C:\Temp\Testdatei.doc}

Siehe auch

Makro-Referenz

OleSetSummaryInformation

OleSetUserDefinedProperties

OleDocumentSummaryInformation

FileAttr


OleSetSummaryInformation

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

OleSetSummaryInformation

Makro-Prozedur OleSetSummaryInformation

Erweiterte Dateieigenschaften (Autor, Kommentar u. a.) schreiben.

Syntax

{OleSetSummaryInformation:Property=Value[,Property2=Value,FileName]}

Parameter

Property: Name oder ID-Nummer der Eigenschaft, s. a. OleSummaryInformation.

Value: Zu schreibender Eigenschaftswert.

FileName: Optionaler Dateiname. Wenn kein Dateiname angegeben ist, wird die aktuelle Dokumentdatei verwendet. Der optionale Dateiname darf kein Gleichheitszeichen enthalten.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Schreibt eine oder mehrere Dateieigenschaften des "OLE Property Set" von Office-Dokumenten.

Beispiel

{OleSetSummaryInformation:Comments=Mein Kommentar,2=Mein Titel}

Siehe auch

Makro-Referenz

OleDocumentSummaryInformation

OleUserDefinedProperties

OleSummaryInformation

FileAttr


OleSetUserDefinedProperties

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

OleSetUserDefinedProperties

Makro-Prozedur OleSetUserDefinedProperties

Benutzerdefinierte Dateieigenschaften schreiben.

Syntax

{OleSetUserDefinedProperties:PropertyName=Value[,PropertyName2=Value,FileName]}

Parameter

PropertyName: Name der benutzerdefinierten Eigenschaft.

Value: zu schreibender Eigenschaftswert.

FileName: optionaler Dateiname. Wenn kein Dateiname angegeben ist, wird die aktuelle Dokumentdatei verwendet. Der optionale Dateiname darf kein Gleichheitszeichen enthalten.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Schreibt eine oder mehrere benutzerdefinierte Dateieigenschaften.

Beispiel

{OleSetUserDefinedProperties:Abteilung=Softwareentwicklung}

Siehe auch

Makro-Referenz

OleSetSummaryInformation

OleSetDocumentSummaryInformation

OleUserDefinedProperties

FileAttr


OmApiCsvParams

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

OmApiCsvParams

Makro-Prozedur OmApiCsvParams

Lösung für das Komma-Problem

Syntax

{OmApiCsvParams:Actice}

Parameter

Active: 0 oder 1: 0 deaktiviert (Vorgabe), 1 aktiviert den Modus für CSV-Paratemer.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Das Komma-Problem

"OmAPI" diente anfangs nur als Platzhalter für Datenbankfelder mit der Syntax {Tabelle:Feldname}. Es kamen dann Formatparameter hinzu {Tabelle:Feldname,Format} und später entstand nach und nach eine umfangreiche Makrosprache.

Variablen, wie {Tabelle:Feldname,Format} funktionieren problemlos, weil der Feldname selbst kein Komma beinhalten kann. Nehmen wir aber beispielsweise {DBSetField:Tabelle,Feldname1=Wert1,Feldmame2=Wert2}, dann haben wir ein Problem, sobald Wert1 ein Komma enthält, wie bei "Mustermann, Max". Der Interpreter trennt dann die Parameter in {DBSetField:Tabelle,Feldname1=Mustermann, Max,Feldmame2=Wert2} bei jedem Komma und wird den Fehler melden, dass ein Datenfeld mit Namen " Max" nicht vorhanden ist.

Lösung

Wenn zu erwarten ist, dass Parameter Kommata beinhalten, sollte der CSV-Modus (Comma-separated values) aktiviert und die Textparameter mit Komma in Anführungszeichen eingeschlossen werden. Beispiel:

{OmApiCsvParams:1}{DBSetField:Tabelle,"Feldname1=Mustermann, Max",Feldmame2=Wert2}{OmApiCsvParams:0}

Nicht nur "Mustermann, Max" steht hier in doppelten Anführungszeichen, sondern der gesamte Parameter "Feldname1=Mustermann, Max". Es schadet nicht, wenn alle Textparameter in Anführungszeichen stehen, auch wenn sie kein Komma beinhalten, wie "Feldname2=Wert2".

Aus Kompatibilitätsgründen muss der Modus anschließend mit {OmApiCsvParams:0} deaktiviert werden. Die Einstellung gilt nicht nur für das jeweilige Makro, sondern für die gesamte Programmlaufzeit.

Beispiel

Im Layout des Eigenschaftendialogs wird ein Mausschalter platziert, mit dem der Anwender einen Kontakt aus einer umfangreichen Liste filtern und wählen kann. Die Kontaktnamen sind in einer Textdatei enthalten, teils als "Max Mustermann" und teils als "Mustermann, Max". Dem Mausschalter ist folgendes Makro (in einer Zeile) hinterlegt:

{RaiseError:In archivierten Dokumenten gesperrt,{Self:DocTable}=docarch}

{OmApiCsvParams:1}

{DBSetField:document,"contact={ExecStringDlg:C:\Kontakte.txt,0,0,0,Kontakt wählen}"}

{OmApiCsvParams:0}

Siehe auch

Makro-Referenz


OpenDatabase

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

OpenDatabase

Makro-Prozedur OpenDatabase

Öffnet ein Dokumentenarchiv, eine Kontakt- oder Anwendungsdatenbank.

Syntax

{OpenDatabase:FileName}

Parameter

FileName: Vollständiger Dateiname der zu öffnenden Datenbank.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Funktion öffnet die im Parameter angegebene Datenbank. Falls die Datei nicht vorhanden ist, wird die Funktion ohne Fehlermeldung ignoriert.

Siehe auch

Makro-Referenz

SendToOM.exe

IF-Anweisung

OmAPI


OpenDlg

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

OpenDlg

Makro-Variable OpenDlg

Beinhaltet den zuletzt im Dialog "Datei öffnen" gewählten Dateinamen.

Syntax

{OpenDlg[:FormatParameter]}

Parameter

FormatParameter: Mit dem optionalen Formatparameter können Sie Teile des Dateinamen übernehmen.

Rückgabewert

Dateiname

Beschreibung

Die Variable wird durch den Dateinamen ersetzt, der beim letzten Aufruf des Dialoges "Datei öffnen" eingegeben bzw. gewählt wurde.

Verwenden Sie die Variable ExecOpenDlg, um den Dialog erneut zu öffnen.

Siehe auch

Makro-Referenz

ExecOpenDlg

Source

SaveDlg

GetPrivVar


OpenDocument

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

OpenDocument

Makro-Prozedur OpenDocument

Öffnet eine Dokumentdatei.

Syntax

{OpenDocument[:ArchiveName,DocID/DocGUID,Mode,Info]}

Parameter

ArchiveName: Dateiname der Archivdatenbank ohne Pfad

DocID/DocGUID: Schlüsselnummer oder GUID des zu öffnenden Dokumentes

Mode: derzeit nur 1. Die Dokumentdatei wird mit dem Windows-Standardbefehl geöffnet, ohne zuvor in der Office Manager-Tabelle dargestellt zu werden.

Info: reserviert.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Funktion durchsucht die angegebene Archivdatenbank und öffnet, sofern vorhanden, das gewünschte Dokument.

Siehe auch

Makro-Referenz

ShellExecute

ExecuteDocuments


Ord

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

Ord

Makro-Funktion Ord

Ordinalwert eines Zeichens.

Syntax

{Ord:Zeichen}

Parameter

Zeichen: Einzelnes Zeichen

Rückgabewert

Ordinalwert des Zeichens.

Beschreibung

Mit Ord wird der Ordinalwert eines einzelnen Zeichens (Buchastabe oder anderes) ermittelt und zurückgegeben.

Beispiele

{Ord:A} ergibt 65
{Chr:a} ergibt 97
{Chr:1} ergibt 49
{Chr:+} ergibt 43

Siehe auch

Makro-Referenz

Chr


OS

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

OS

Makro-Variable OS

Zugriff auf Umgebungsvariablen des Betriebssystems.

Syntax

{OS:Variable[,CLSID]}

Parameter

Variable

OSDir: Stammverzeichnis des Betriebssystems, z. B.: "C:\Windows"

SysDir: Systemverzeichnis des Betriebssystems, z. B.: "C:\Windows\System"

TmpPath: Temporäre Dateien, entspricht Windows API-Funktion "GetTempPath"

MyFiles: Das Verzeichnis "Eigene Dateien" *)

Desktop: Verzeichnis in dem der Desktopinhalt gespeichert wird *)

Programs: Startmenüordner Programme *)

Program_Files: z. B. "C:\Program Files\" *)

Templates: Dokumentvorlagen, z. B. "C:\Windows\ShellNew\" oder "C:\Dokumente und Einstellungen\(UserName)\Vorlagen\" *)

UserName: Benutzername (der im Betriebssystem angemeldete Benutzer)

ComputerName: Name des Computers

DecimalSeparator: Eingestelltes Dezimaltrennzeichen

ThousandSeparator: Tausender-Trennzeichen

SpecialFolder,CLSID: Spezielle Windows-Verzeichnisse *). Das Verzeichnis wird mit der Windows API-Funktion SHGetSpecialFolderLocation aus shell32.dll ab Version 4.0 ermittelt. Mögliche CLSID-Werte (s. a. shlobj.h) z. B. "0x001a" für AppData oder "0x002e" für CommonDocuments.

Win32MajorVersion: Major-Version des Windows-Betriebssystems

Win32MinorVersion: Minor-Version des Windows-Betriebssystems

*) mit abschließendem Backslash

Rückgabewert

Umgebungsvariable, die im Parameter Variable angefordert wurde.

Beschreibung

Gibt eine Umgebungsvariable des Betriebssystems zurück.

Siehe auch

Makro-Referenz

Self


PackFiles

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

PackFiles

Makro-Prozedur PackFiles

Dateien komprimieren

Syntax

{PackFiles:FullPath,Encrypt,Password,res,DestFileName,FileName1[,Filename2,...]}

Parameter

FullPath: 0, 1 oder 2: Verzeichnisstruktur der Quelldateien übernehmen. 0=nie, 1=wenn wegen gleichnamigen Dateien nötig, 2=immer.

Encrypt: 0 oder 1, bei 1 wird die ZIP verschlüsselt

Password für die Verschlüsselung

res: reserviert, bitte 0 angeben

DestFileName: Dateiname der Zieldatei (*.zip o. a.)

FileName1, FileName2: Die zu komprimierenden Quelldateien

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Komprimiert die angegebenen Quelldateien und speichert diese in einem Archiv-Format: zip, gz,tgz, tar und jar sind möglich.

Wenn die Verschlüsselung aktiviert, aber kein Kennwort angegeben ist, dann wird der Anwender gefragt, ob und mit welchem Passwort verschlüsselt werden soll. Bitte beachten: Das Inhaltsverzeichnis verschlüsselter Dateien kann auch ohne Kennwort eingesehen werden, die Dateinamen und die Struktur dürfen also keine vertraulichen Informationen beinhalten. Nur die Dateien selbst sind passwortgeschützt.

Beachten Sie bei Tests mit der Verschlüsselung, dass sich die Windows Zip-Funktion das Kennwort der ZIP-Dateien vom letzten Entpacken merkt. Ändern Sie bei Tests in jedem Aufruf das Kennwort.

Beispiel

{OmApiCsvParams:1}{PackFiles:0,0,,0,C:\Daten\Versenden.zip,{CurrDocFileName}}{OmApiCsvParams:0}

Siehe auch

Makro-Referenz

ExtractAttachment

Dokumente senden


PasteFromClipboard

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

PasteFromClipboard

Makro-Variable PasteFromClipboard

Text aus der Zwischenablage kopieren.

Syntax

{PasteFromClipboard}

Parameter

Keine

Rückgabewert

Inhalt der Zwischenablage.

Beschreibung

Die Variable wird durch den Text-Inhalt der Windows-Zwischenablage ersetzt.

Siehe auch

Makro-Referenz

CopyToClipboard


PDFAddComment

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

PDFAddComment

Verfügbar in diesen Editionen

Makro-Prozedur PDFAddComment

Fügt Kommentare in PDF-Dokumente ein.

Syntax

{PdfAddComment:FileName,PageNum,Type,ALeft,ATop,PLeft,PRight,PTop,PBottom,Color,InfoEx,Expand,Title,Content}

Parameter

FileName: Dateiname der PDF-Datei, z. B. {Doc:FileName}.

PageNum: Nummer der Seite, auf welcher der Kommentar eingefügt werden soll. Sie können auch negative Werte eingeben, um von hinten zu zählen: -1 ist z. B. die letzte Seite.

Type: 0 bis 6 und 100 bis 106: 0=Textnotiz, 1=Kommentar, 2=Hilfe, 3=Text einfügen, 4=Schlüssel, 5=Neuer Absatz, 6=Absatz. Addieren Sie 100 zu den Werten, um das Datum in den Titel aufzunehmen (wird aber nicht von allen PDF-Viewern gezeigt).

ALeft, ATop: Gibt den Abstand des Ankers in Millimetern von links/oben an. Es sind nur ganze Zahlen erlaubt.

PLeft, PRight, PTop, PBottom: Definiert das Rechteck des Popupfenster in Millimetern. PLeft und PRight geben den Abstand vom linken Seitenrand, PTop und PBottom vom oberen Rand an. Es sind nur ganze Zahlen erlaubt.

Color: Farbkonstante, z. B.: clYellow, clRed, clBlue, clCreme.

InfoEx: 0 oder 1. Bei 1 wird eine zusätzliche Info mit Datum und Benutzernamen hinzugefügt.

Expand: 0 oder 1. Bei 1 ist der Kommentar geöffnet, wenn das Dokument geladen wird.

Title: Überschrift des Kommentars. Es sind keine Kommata erlaubt, verwenden Sie bei Bedarf {Chr:44}.

Content: Inhalt des Kommentars. Hier sind Kommata erlaubt.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Kommentar in ein Adobe Acrobat-Dokument einfügen. Das Makro wird mit einem Fehler beendet, falls das Dokument geschützt ist oder ein anderer Fehler auftritt. Falls Title und Content leer sind, wird der Kommentar nicht hinzugefügt

Beispiel

{PdfAddComment:{CurrDocFileName},1,2,10,30,30,100,30,80,clBlue,1,1,Mein Titel,Mein Kommentar}

Siehe auch

Makro-Referenz

PDFAddStamp

FilePageCount

PDFProtectDocument

CreateDocVers

TDebenuPDFLibrary


PDFAddStamp

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

PDFAddStamp

Makro-Prozedur PDFAddStamp

Fügt einen Stempel in ein PDF-Dokument ein.

Syntax

{PDFAddStamp:FileName,PageNum,TypeOrFile,Left,Top,Width,Height,Color,reserved,Title,Comment}

Parameter

FileName: Dateiname der PDF-Datei, z. B. {CurrDocFileName}.

PageNum: Nummer der Seite, auf welcher der Stempel eingefügt werden soll. Sie können auch negative Werte eingeben, um von hinten zu zählen: -1 ist z. B. die letzte Seite.

TypeOrFile: Für benutzerdefinierte Stempel geben Sie bitte den Dateinamen einer Grafik an.
Oder die Nummer (0 bis 13) eines Standard-Stempels: 0=Genehmigt, 1=In Versuchsphase, 2=Abgelehnt, 3=Wie gesehen, 4=Abgelaufen, 5=Nur für internen Gebrauch, 6=Vertraulich, 7=Endgültige Version, 8=Verkauft, 9=Abteilungsintern, 10=Zum Kommentar, 11=Geheimsache, 12=Entwurf, 13=Zur Veröffentlichung.

Left, Top, Width, Height: Definiert das Rechteck des Stempels in Millimetern. Es sind nur ganze Millimeter erlaubt.

Color: Farbkonstante, z. B.: clYellow, clRed, clBlue, clCreme.

reserved: Bitte 0 eingeben.

Title: Überschrift für Kommentar.

Comment: Beschreibung oder Kommentar.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Mit dieser Prozedur können Sie einen Stempel in Acrobat-Dokumente einfügen. Das Makro wird mit einem Fehler beendet, falls das Dokument geschützt ist oder ein anderer Fehler auftritt.

Farbe und Größenangaben haben auf die Standard-Stempel derzeit keinen Einfluss. Title und Comment fügen nur einen Kommentar hinzu und ändern nicht den Stempeltext.

Beispiel

{PDFAddStamp:{CurrDocFileName},1,6,10,20,40,30,clRed,0,,}

Siehe auch

Makro-Referenz

PDFAddComment

FilePageCount

PDFProtectDocument

CreateDocVers

TDebenuPDFLibrary


PDFProtectDocument

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

PDFProtectDocument

Verfügbar in diesen Editionen

Makro-Prozedur PDFProtectDocument

PDF-Dokument verschlüsseln und vor Änderungen schützen.

Syntax

{PDFProtectDocument[:FileName,MasterPW,UserPW,
AllowPrint,AllowCopy,AllowChange,AllowAddNotes,AllowFillFields,
AllowCopyAccess,AllowAssemble,AllowPrintFull]}

Optionale Parameter

FileName: Kompletter Dateiname des Dokuments. Standardwert -wenn kein Dateiname angegeben wurde- ist die aktuelle Dokumentdatei.

MasterPW: Passwort, welches für die Aufhebung des Schutzes nötig ist. Standardwert (wenn Sie den Parameter nicht angeben bzw. leer lassen) ist ein Zufallspasswort. Dies ist zusammen mit AllowChange=0 für die revisionssichere Archivierung empfohlen: Das Dokument kann nicht mehr geändert werden, das Passwort zur Aufhebung der Sperre ist nicht bekannt.

UserPW: Passwort zum Öffnen des Dokumentes. Der Standardwert ist leer, so dass kein Passwort zum Öffnen erforderlich ist.

AllowPrint: 0 oder 1, 1=Drucken erlaubt, 0=Drucken nicht zulässig. Standard ist 1.

AllowCopy: Kopieren von Inhalt. Standard ist 1.

AllowChange: Dokumentänderungen, Standard ist 0.

AllowAnnotations: Kommentare hinzufügen oder bearbeiten sowie interaktive Formularfelder ausfüllen, Standard ist 0.

AllowFillFields: Formularfelder ausfüllen, Standard ist 0.

AllowCopyAccess: Barrierefreiheitsfunktionen, Lesen durch Screenreader, Standard ist 1.

AllowAssemble: Zusammenstellen, Dokumentenstruktur ändern, Seiten hinzufügen, drehen, löschen. Standard ist 0.

AllowPrintFull: Drucken, sofern zulässig, auch in hoher Auflösung. Standard ist 1.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Prozedur verschlüsselt ein Acrobat-Dokument (*.pdf) und aktiviert den Passwortschutz, um beispielsweise Dokumentänderungen zu verhindern. Für die revisionssichere Archivierung können Sie die Funktion ohne Parameter bzw. nur mit FileName aufrufen. Die Funktion wird ohne Fehlermeldung abgebrochen, falls die Datei bereits verschlüsselt oder signiert ist.

Die Verschlüsselung erfolgt mit einem 128-Bit-Schlüssel des "Rivest Cipher 4 (RC4)"-Algorithmus.

Wenn Sie alle Dokumente automatisch schützen möchten, die aus einem bestimmten Verzeichnis importiert werden, dann definieren Sie bitte ein Importprofil. Geben Sie auf der Seite Makro bei Nach Speichern
{PDFProtectDocument:{Source}}{UpdateDocAttributesFromFile}
ein.

Siehe auch

Makro-Referenz

UpdateDocAttributesFromFile

Dokumente archivieren

Menü Bearbeiten | Dokument | Verschlüsseln

SignDocument

PDFAddStamp

PDFAddComment

TDebenuPDFLibrary


ProcessMessages

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ProcessMessages

Makro-Prozedur ProcessMessages

Windows-Botschaften abarbeiten.

Syntax

{ProcessMessages}

Parameter

Keine

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Der Office Manager arbeitet alle anstehenden Windows-Botschaften ab, bevor er mit dem Makro fortsetzt.

Siehe auch

Makro-Referenz

WaitForFile


RaiseError

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

RaiseError

Makro-Prozedur RaiseError

Laufzeitfehler auslösen.

Syntax

{RaiseError:Message,[Condition]}

Parameter

Message: Text der Fehlermeldung.

Condition: Optionale Angabe einer Bedingung, der Fehler wird nur ausgelöst, wenn die Bedingung erfüllt ist. Condition erlaubt die Operatoren =, <>, < und >. Zwischen Groß- und Kleinschreibung wird nicht unterschieden.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

RaiseError löst einen Laufzeitfehler mit dem in Message angegebenen Text aus. Die Fehlermeldung wird in einem Dialogfenster ausgegeben und in error.log eingetragen.

Die Verwendung der Funktion ohne Condition erfolgt normalerweise nur zusammen mit IF.

Beispiel

Wenn Sie das Makro beispielsweise durch einen Fehler abbrechen möchten, wenn das aktuelle Dokument keinem Projekt zugeordnet ist, sieht die Funktion folgendermaßen aus:

{RaiseError:Projektzuordnung fehlt,{Doc:PROJECT}=}

Hinter dem Gleichheitszeichen folgt direkt die abschließende runde Klammer. Die Bedingung ist also erfüllt, wenn das Projekt leer ist. In diesem Fall würde die Fehlermeldung "Projektzuordnung fehlt" erscheinen, das Makro und programminternen Funktionen abgebrochen.

Siehe auch

Makro-Referenz

Bedingte Ausführung

Exit

DBCheckFieldValue

IfThen


ReadAdminIni

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ReadAdminIni

Makro-Funktion ReadAdminIni

Liest eine Variable aus der Office Manager-Datei admin.ini und ersetzt ggf. den Wert durch NewValue.

Syntax

{ReadAdminIni:Variable[,NewValue]}

Parameter

Variable: Bezeichnung der Schlüssel-Variablen in Sektion [Macro_ReadAdminIni] der admin.ini.
Wenn der Schlüssel nicht vorhanden ist, wird ein leerer String zurückgegeben. Ist gleichzeitig der Parameter NewValue angegeben, wird der Schlüssel mit diesem neuen Wert erzeugt.

NewValue: Wenn der optionale Parameter angegeben ist, wird dieser neue Wert in die admin.ini zurückgeschrieben. Er dient gleichzeitig als Vorgabewert, falls der Schlüssel noch nicht in der INI enthalten war.

Rückgabewert

Wert aus admin.ini

Beschreibung

Liest den Wert der mit Variable angegebenen Schlüsselvariablen aus der Office Manager-Datei admin.ini, Sektion [Macro_ReadAdminIni]. Wenn der optionale Parameter NewValue angegeben ist, wird die Variable mit diesem neuen Wert in die Ini-Datei zurückgeschrieben. Wenn das erste Zeichen des Parameters NewValue ein "+" oder ein "-" ist, wird der Wert der Variablen berechnet (alter Wert +/- Parameter NewValue) und das Ergebnis in die Ini-Datei zurückgeschrieben.

Siehe auch

Makro-Referenz

Beispiel Dokumentenverzeichnis definieren

AdminINI

InifileReadStr

ReadIdentNo

ReadLnFile

RegistryReadStr


ReadIdentNo

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ReadIdentNo

Verfügbar in diesen Editionen

Makro-Funktion ReadIdentNo

Liest eine Schlüsselnummer und erhöht diese in der Tabelle um 1.

Syntax

{ReadIdentNo:IdentName[,FormatParameter]}

Parameter

IdentName: Name der Aufzählungsvariablen.

FormatParameter: optionaler Parameter für die Formatierung.

Rückgabewert

Angeforderte Schlüsselnummer.

Beschreibung

Die Funktion liest die Aufzählungsvariable mit dem Namen IdentName aus der Datenbanktabelle IDENTNO, erhöht den Wert der Variablen um 1 und schreibt ihn in die Tabelle zurück.

Hinweis: Diese Funktion ist z. B. für die automatische Erzeugung von Dokument-Nummern geeignet, wenn {Doc:DocID} nicht zum gewünschten Ergebnis führt. Geben Sie die Syntax der Dokumentennummer bitte bei den Feldwerten im Menü Datei | Datenbank | Anpassen | Felder definieren ein.

Beispiel

Dokumentnummer: Jedes Dokument hat im Archiv eine eindeutige Schlüsselnummer im Datenfeld "DocID". Diese wird in der Regel auch in die Nummer (Datenfeld DocNo) übernommen, um eindeutige Dokumentnummern zu generieren.

Wenn Sie diese unabhängig von der Schlüsselnummer erstellen möchten, dann können Sie dies mit der Funktion ReadIdentNo lösen.

Mit den Office Manager-Makrofunktionen haben Sie drei Möglichkeiten, Aufzählungsvariablen zu lesen: ReadLnFile liest die erste Zeile aus einer Textdatei, ReadAdminIni liest eine Variable aus der admin.ini und ReadIdentNo liest aus der Datenbanktabelle "identno".

Beispiel 1:

{ReadIdentNo:AktDokNr}

Wenn Sie ein neues Dokument anlegen, dann wird der aktuelle Wert des Datenfeldes AktDokNr aus der Tabelle gelesen (z. B. "3721") und das neue Dokument mit dieser Nummer "3721" gespeichert. Der Office Manager erhöht den Wert um eins und schreibt "3722" in die Tabelle zurück, das nächste Dokument erhält dann die Nummer "3722".

Beispiel 2:

Die Dokumente sollen innerhalb ihrer Projekte fortlaufend nummeriert werden:

{ReadIdentNo:{Doc:Project,Main}}

Siehe auch

Makro-Referenz

Aufzählungsvariable initialisieren

Tabelle IDENTNO

ReadAdminIni

ReadLnFile


ReadLnFile

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ReadLnFile

Makro-Funktion ReadLnFile

Text aus Datei lesen ggf. den Dateiinhalt ändern.

Syntax 1

{ReadLnFile:FileName[,NewValue]}

Parameter

FileName: Name der Textdatei. Wenn die Datei nicht vorhanden ist wird sie neu erstellt.

NewValue: Wenn dieser optionale Parameter angegeben ist, dann wird der neue Wert in die Datei zurückgeschrieben.
Oder "ReadAll", um die gesamte Datei einzulesen.

Rückgabewert

Erste Dateizeile oder gesamte Datei.

Beschreibung

Liest die erste Zeile aus der angegebenen Textdatei. Wenn der optionale Parameter NewValue angegeben ist, dann wird der neue Wert in die Datei zurückgeschrieben. Wenn das erste Zeichen des Parameters NewValue ein "+" oder ein "-" ist, wird der Wert berechnet (alter Wert +/- Parameter NewValue) und das Ergebnis in die Datei eingefügt.

Wenn die Textdatei nicht vorhanden, NewValue aber angegeben ist, dann wird die Datei erzeugt und der Rückgabewert mit NewValue initialisiert.

Syntax 2

{ReadLnFile:FileName,Row=RowNumber}

Parameter

FileName: Name der Textdatei. Wenn die Datei nicht vorhanden ist wird sie neu erstellt.

Row: Zeilennummer, die eingelesen werden soll, z. B. "Row=2" für die zweite Textzeile. "Row=0" steht für die gesamte Datei.

Rückgabewert

Angeforderte Dateizeile oder gesamte Datei.

Beschreibung

Liest eine oder alle Zeilen aus einer Textdatei.

Beispiele

Automatische Nummerierung. Die aktuelle Nummer wird aus ID.txt gelesen und die Nummer für den nächsten Aufruf um 1 erhöht:

{ReadLnFile:C:\Temp\ID.txt,+1}

Der kompletten Inhalt einer Textdatei in eine Variable einlesen:

{SetPrivVar:Dateiinhalt={ReadLnFile:C:\Temp\Test.txt,Row=0}}

Siehe auch

Makro-Referenz

ReadIdentNo

InifileReadStr

ReadAdminIni

WriteLnFile

CSVGetCell


ReadShortcutURL

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ReadShortcutURL

Makro-Variable ReadShortcutURL

Liest die Internetadresse (URL) aus der Internetverknüpfung (*.url).

Syntax

{ReadShortcutURL:FileName}

Parameter

FileName: Name der .url-Datei.

Rückgabewert

URL

Beschreibung

Liest die Internetadresse (URL) aus der im Parameter angegebenen Internetverknüpfung. Die Datei kann mit oder ohne Dateiendung (.url) angegeben werden. Internetverknüpfungen werden z. B. vom MS Internet-Explorer erstellt und beinhalten die Favoriten.

Die Makrovariable wird durch die enthaltene URL ersetzt.

Siehe auch

Makro-Referenz


RecordCount

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

RecordCount

Makro-Variable RecordCount

Gibt die Datensatzanzahl einer Tabelle zurück.

Syntax

{RecordCount:Table[,SQL-Where]}

Parameter

Table: Kennung der Datenbanktabelle.

SQL-Where: optionale Angabe des SQL Where-Statements.

Rückgabewert

Datensatzanzahl

Beschreibung

Die Variable gibt die Anzahl der Datensätze in Table zurück. Wenn der optionale Parameter SQL-Where nicht angegeben ist, dann wird die derzeitige Abfrage verwendet. Bei der Dokumenttabelle entspricht RecordCount in diesem Fall der Dokumentenanzahl der aktuellen Suche.

Alternativ können Sie den optionalen Parameter SQL-Where angeben. Die Datensatzanzahl wird dann mit einer temporären SQL-Abfrage ermittelt.

Beispiele

{RecordCount:Doc}: Dokumentanzahl der aktuellen Suche.

{RecordCount:Doc,}: Gesamte Dokumentenanzahl in der Tabelle "Aktive Dokumente". Durch das Komma am Ende wird der Parameter SQL-Where als leerer Text übergeben - also ein SELECT ohne WHERE ausgeführt.

{RecordCount:Doc,WHERE FILENAME={Self:DbQuoteChar}C:\Datei.txt{Self:DbQuoteChar}}: Anzahl Dokumente mit dem Dateinamen "C:\Datei.txt".

Siehe auch

Makro-Referenz

DBOperation

DBSerach


RecoverDocument

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

RecoverDocument

Verfügbar in diesen Editionen

Makro-Prozedur RecoverDocument

Stellt ein archiviertes Dokument wieder her.

Syntax

{RecoverDocument[:DocID,RaiseError]}

Optionale Parameter

DocID: Schlüsselnummer des archivierten Dokumentes, Standard ist das aktuelle Dokument.

RaiseError: Der Standardwert '1' löst bei Fehlern eine Exception aus und beendet das Makro. '0' unterdrückt den Fehler und gibt die Fehlermeldung als Variablenwert zurück.

Rückgabewert

Leerstring oder Fehlermeldung

Beschreibung

Dokument aus der Archivtabelle DOCARCH in die Tabelle der aktiven Dokumente DOCUMENT verschieben. Die externe Datei wird ev. entsprechend den Einstellungen verschoben.

Siehe auch

Makro-Referenz

ArchiveDocument

Dokumente archivieren


RegistryReadInt

RegistryReadInt, RegistryReadStr

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

RegistryReadInt, RegistryReadStr

Makro-Funktion RegistryReadInt
Makro-Funktion RegistryReadStr

Liest einen Wert aus der Windows-Registrierungsdatenbank.

Syntax

{RegistryReadInt:Root,Key,Name[,UseIni]}

{RegistryReadStr:Root,Key,Name[,UseIni]}

Parameter

Root: Hauptschlüssel der Registry: HKEY_CLASSES_ROOT (oder kurz HKCR), HKEY_LOCAL_MACHINE (HKLM) oder HKEY_CURRENT_USER (HKCU). Falls ein ungültiger Wert angegeben ist, wird HKEY_CURRENT_USER geöffnet.

Key: Name des Registry-Schlüssels, z. B. "Software\Krekeler\Office Manager".

Name: Name des Datenwertes. Lassen Sie dieses Feld leer, um den Standard-Wert zu lesen.

UseIni: Optionaler Parameter z. B. für Terminalserver. Geben Sie "UseIni" an wenn die Registryzugriffe in INI-Dateien umgeleitet werden sollen.

Rückgabewert

Angeforderter Wert aus Registry.

Beschreibung

Mit RegistryReadInt können Sie einen numerischen Wert und mit RegistryReadStr einen Zeichenwert aus der Registrierungsdatenbank lesen. Bei Erfolg wird die Variable durch den gelesenen Wert ersetzt. Bei Misserfolg wird sie ohne Laufzeitfehler ignoriert.

Beispiele

{RegistryReadStr:HKEY_LOCAL_MACHINE,{Self:RegistryPath},CurrentVersion}

{RegistryReadStr:HKEY_LOCAL_MACHINE,{Self:RegistryPath},CurrentVersion,UseIni}

Siehe auch

Makro-Referenz

RegistryWriteInt

RegistryWriteStr

Self:RegistryPath

InifileReadStr


RegistryWriteInt

RegistryWriteInt, RegistryWriteStr

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

RegistryWriteInt, RegistryWriteStr

Makro-Prozedur RegistryWriteInt
Makro-Prozedur RegistryWriteStr

Schreibt einen Wert in die Windows-Registrierungsdatenbank.

Syntax

{RegistryWriteInt:Root,Key,Name,Value[,UseIni]}

{RegistryWriteStr:Root,Key,Name,Value[,UseIni]}

Parameter

Root: Hauptschlüssel der Registry: HKEY_CLASSES_ROOT1) (oder kurz HKCR), HKEY_LOCAL_MACHINE1) (HKLM) oder HKEY_CURRENT_USER (HKCU). Falls ein ungültiger Wert angegeben ist, wird HKEY_CURRENT_USER geöffnet.

Key: Name des Registry-Schlüssels, z. B. "Software\Krekeler\Office Manager".

Name: Name des Datenwertes. Lassen Sie dieses Feld leer, um in den Standard-Wert zu schreiben.

Value: Der zu speichernde Datenwert.

UseIni: Optionaler Parameter z. B. für Terminalserver. Geben Sie "UseIni" an wenn die Registryzugriffe in INI-Dateien umgeleitet werden sollen.

1) Beachten Sie bitte, dass ein Schreiben in HKEY_CLASSES_ROOT und HKEY_LOCAL_MACHINE nur mit Windows-Administrationsrechten möglich ist.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Einschränkung

Diese potenziell gefährliche Funktion ist standardmäßig gesperrt.

Beschreibung

Mit der Funktion RegistryWriteInt können Sie einen numerischen Wert und mit RegistryWriteStr einen Zeichenwert in die Registrierungsdatenbank speichern. Wenn der Schlüssel nicht vorhanden ist, wird er angelegt.

Bei Misserfolg wird kein Laufzeitfehler erzeugt!

Siehe auch

Makro-Referenz

RegistryReadInt

RegistryReadStr

Self:RegistryPath

InifileReadStr


SaveAsPDF

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

SaveAsPDF

Verfügbar in diesen Editionen

Makro-Prozedur SaveAsPDF

Im Archiv vorhandenes Textdokument in ein PDF konvertieren und archivieren.

Syntax

{SaveAsPDF:4,ShowDlg,OpenFile[,ForceCOM]}

Parameter

4: Für Modus reserviert, bitte 4 eingeben.

ShowDlg: 0 oder 1, bei 1 wird der Eigenschaftendialog für die neue PDF geöffnet.

OpenFile: 0 oder 1, bei 1 wird die erzeugte PDF geöffnet.

ForceCOM: optional 0 oder 1, Vorgabewert ist 0. Bei 0 erfolgt die Konvertierung möglichst mit programminternen Funktionen. Wenn diese nicht möglich sind oder eine 1 angegeben ist, wird mittels Component Object Model eine geeignete Anwendung für die Konvertierung genutzt, beispielsweise Microsoft Office.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Erstellt eine PDF-Kopie des aktuell markierten Dokuments, übernimmt die Datenfelder und importiert dieses sofort in das Archiv. Nur für

·Word-Dokumente (docx und doc), Rich Text Format, Textdateien und HTML mit internen Funktionen oder COM.

·Excel-Dateien (xlsx und xls) mittels COM-Automatisierung, sofern MS Excel installiert ist.

Siehe auch

Makro-Referenz

Dokumente versenden


SaveAsWebarchive

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

SaveAsWebarchive

Verfügbar in diesen Editionen

Makro-Prozedur SaveAsWebarchive

Speichert den Seiteninhalt eines URL (Internet-Adresse) in eine Web-Archivdatei.

Syntax

{SaveAsWebarchive:URL,ArchiveFileName}

Parameter

URL: Dateiname der zu erstellenden Datei.

ArchiveFileName: Dateiname der zu erstellenden Datei.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Im Office Manager können Sie Internetadressen (URL) verwalten. Beim Öffnen wird die aktuelle Webseite im Browser geöffnet. In manchen Situationen ist es aber sinnvoll, den derzeitigen Stand einer Seite zu archivieren, beispielsweise wenn Sie Nutzungsbedingen o. ä. bestätigen und diese aufheben möchten.

Mit "SaveAsWebarchive" wird die mit dem URL angegebene Webseite in eine MHTML-Datei inklusive Bildern gespeichert.

Siehe auch

Makro-Referenz

White Paper Internet und E-Mail


SaveDlg

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

SaveDlg

Makro-Variable SaveDlg

Beinhaltet den zuletzt im Dialog "Datei speichern" gewählten Dateinamen.

Syntax

{SaveDlg[:FormatParameter]}

Parameter

FormatParameter: Mit dem optionalen Formatparameter können Sie Teile des Dateinamen übernehmen.

Rückgabewert

Dateiname

Beschreibung

Die Variable wird durch den Dateinamen ersetzt, der beim letzten Aufruf des Dialogs "Datei speichern" eingegeben bzw. gewählt wurde.

Verwenden Sie die Variable ExecSaveDlg, wenn der Dialog erneut angezeigt werden soll.

Siehe auch

Makro-Referenz

ExecSaveDlg

Dest

OpenDlg

GetPrivVar


SaveLanguageFile

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

SaveLanguageFile

Makro-Prozedur SaveLanguageFile

Erstellt eine Sprachdatei zur Übersetzung.

Syntax

{SaveLanguageFile:FileName}

Parameter

FileName: Dateiname der zu erstellenden Datei.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Prozedur erstellt eine Sprachdatei zur teilweisen Übersetzung der Programmoberfläche.

Siehe auch

Makro-Referenz

LoadLanguageFile

Sprachdateien


ScanSnap

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ScanSnap

Makro-Funktion ScanSnap

Zugriff auf den Treiber des Ricoh (eh. Fujitsu) ScanSnap.

Syntax

Syntax: {ScanSnap:Command}

Parameter

Command

ExitManager beendet den ScanSnap-Manager

IniFileName Name der Konfigurationsdatei "scansnap.(Rechnername).ini".

Installed gibt "1" zurück, wenn der Treiber installiert ist oder "0", wenn nicht.

LastScanResult gibt den Fehlercode des letzten Scans aus: 0=ok, 1=Manager geöffnet oder Scan läuft, 5=Paramaterfehler, 6=Scan derzeit nicht möglich.

ManagerRunning gibt "1" zurück, wenn der ScanSnap-Manager ausgeführt wird oder "0", wenn nicht.

ProfileName Name des zuletzt verwendeten und somit aktiven Office Manager-Scanprofiles

Scan: Dokumente scannen

Settings öffnet die Treibereinstellungen, entspricht Einstellungen der Scan Taste

StartManager startet den ScanSnap-Manager

Rückgabewert

Abhängig vom verwendeten Befehlsparameter.

Beschreibung

Der Dokumentenscanners "ScanSnap" von Ricoh bzw. Fujitsu verwendet keine TWAIN- oder WIA-Treiber. Office Manager beinhaltet eine spezielle Schnittstelle für diese Gerät. Mithilfe der Makrofunktion können Sie auf den Treiber, den ScanSnap-Manager, zugreifen, Informationen abfragen und Scans starten.

Siehe auch

Makro-Referenz


ScriptControl

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ScriptControl

Makro-Prozedur ScriptControl

Diese Funktion ist nur in der 32 Bit-Version verfügbar.

Führt "Windows Script Host" aus.

Syntax

Syntax 1: {ScriptControl:Language,Source}

Syntax 2: {ScriptControl:FileName}

Parameter

Language: Verwendete Skriptsprache, z. B. "VBScript" oder "JScript".

Source: Der auszuführene Quelltext.

FileName: Alternativ zu den Parametern Language und Source kann auch der Name einer Skriptdatei angegeben werden. Die Sprache wird anhand der Dateiendung festgelegt. Die Datei wird im Verzeichnis "Gemeinsame Dateien\Macro" gesucht, falls sie ohne Pfad angegeben wurde. "menu\Dateiname" ist ebenfalls möglich

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Einschränkung

Diese potenziell gefährliche Funktion ist standardmäßig gesperrt.

Beschreibung

Die Prozedur führt innerhalb eines Office Manager Makros ein Skript mit Hilfe des "Windows Script Host" aus. Es werden verschiedene Programmiersprachen unterstützt: z. B. VBScript und JScript. Weitere Sprachen können im Scriptcontrol installiert werden.

Internetlinks

Google nach MS Scriptcontrol durchsuchen

Windows Scripting Host

Siehe auch

Makro-Referenz

ScriptControlSetOption

ExecuteMacroFile

Makro-Editor


ScriptControlSetOption

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ScriptControlSetOption

Makro-Prozedur ScriptControlSetOption

Diese Funktion ist nur in der 32 Bit-Version verfügbar.

Optionen des "Windows Script Host" setzen.

Syntax

{ScriptControlSetOption:OptionName,Value}

Parameter

OptionName: Name der Einstellung:
TimeOut des ScriptControls in Millisekunden oder "-1" zum Deaktivieren des TimeOuts.
UseSafeSubset: Sicheren Modus aktivieren (Value 1) oder deaktivieren (Value 0).

Value: Der neue Wert der Einstellung.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Funktion ändert ScriptControl-Einstellungen für Visual Basic, JScript und andere Skriptsprachen. Die neue Einstellung gilt für die gesamte Laufzeit der Office Manager-Instanz.

Hinweis: Wenn Sie diese Funktion im Makro-Editor ausführen, dann werden die Einstellungen erst nach einem erneuten Start des Makros übernommen.

Beispiele

{ScriptControl:TimeOut,-1} deaktiviert den TimeOut.

{ScriptControl:UseSafeSubset,1} aktiviert den sicheren Modus.

Siehe auch

Makro-Referenz

admin.ini ScriptControl

ScriptControl


SearchField

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

SearchField

Makro-Funktion SearchField

Liest aus oder schreibt in ein primäres Suchfeld.

Syntax 1, lesen

{SearchField:FieldName[,FormatParameter]}

Parameter

FieldName: Name des Datenbankfeldes oder "*FTI" für das Suchfeld "Volltext" oder "*ProjectNavigator" für das im Navigator markierte Projekt.

FormatParameter: Optionaler Formatparameter.

Rückgabewert

Text im primären Suchfeld.

Syntax 2, schreiben

{SearchField:FieldName=Value}

Parameter

FieldName: Name des Datenbankfeldes oder "*FTI" für das Suchfeld "Volltext" oder "*ProjectNavigator" für den Navigator.

Value: Zu schreibender Wert.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Funktion gibt den Text zurück, der im entsprechenden primären Suchfeld enthalten ist. Falls der Parameter "FieldName" ein Gleichheitszeichen beinhaltet, wird nicht gelesen, sondern in das Suchfeld geschrieben.

Siehe auch

Makro-Referenz

Variablen für Datenfelder


SearchGridSelection

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

SearchGridSelection

Makro-Prozedur SearchGridSelection

Die markierten Datensätze suchen.

Syntax

{SearchGridSelection[:SelectAll]}

Parameter

SelectAll (optional): Wenn angegeben, dann werden die Datensätze nach der Suche erneut markiert.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Funktion sucht alle Datensätze (Dokumente oder Aufgaben), die derzeit in der Tabelle markiert sind. Nach dem Aufruf sind nur noch die zuvor markierten Datensätze in der Tabelle enthalten.

SearchGridSelection eignet sich beispielsweise für die Automatisierung von Programm-Funktionen, die sich auf alle Daten der aktuellen Suche beziehen, Sie aber nur die markierten verarbeiten möchten.

Beachten Sie bitte, dass die generierte SQL-Suche SELECT ... WHERE id IN (1,2,3,...) je nach verwendetem Datenbanksystem nur für eine begrenzte Anzahl an markierten Datensätzen funktioniert.

Beispiel

Folgendes Makro druckt eine Übersicht der markierten Dokumente:

{SearchGridSelection}

{OmAPI:ActFileDbExportHtml}

{OmAPI:ActSearchLastSearch}

Siehe auch

Makro-Referenz

DocumentSearch


SelectDocVersions

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

SelectDocVersions

Verfügbar in diesen Editionen

Makro-Funktion SelectDocVersions

Filtert die Tabelle der Dokumentversionen für das aktuelle Dokument.

Syntax

{SelectDocVersions}

Parameter

Keine

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Nach einem Aufruf von SelectDocVersions ist die Tabelle DOCVERS gefiltert und enthält nur die Versionen des aktuellen Dokumentes.

Siehe auch

Makro-Referenz

Makrovariablen für Datenfelder

CreateDocVers


SelectionListFindItem

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

SelectionListFindItem

Makro-Funktion SelectionListFindItem

Sucht einen passenden Eintrag in einer Auswahlliste.

Syntax

{SelectionListFindItem:FieldName,SearchFor,SearchMode[,SearchEx,Default,Property]}

Parameter

FieldName: Name des Datenbankfeldes, dessen Auswahlliste durchsucht werden soll.

SearchFor: Text, welcher zu einem Eintrag in der Liste passen soll.

SearchMode: Suchmodus 0 bis 3.
0: der gesuchte Text muss mit dem Listeneintrag übereinstimmen.
1: Listeneintrag muss mit dem Suchtext beginnen.
2: Suchtext muss im Listeneintrag enthalten sein.
3: Listeneintrag muss mit dem Suchtext enden.
Die Groß-, Kleinschreibweise wird in keinem Fall berücksichtigt.

SearchEx: Optional 0 oder 1, Standard ist 0. Bei 1 wird auch die Beschreibung durchsucht. Der entsprechende Listeneintrag wird zurückgegeben, wenn der gesuchte Text in der Bezeichnung oder Beschreibung gefunden wird.

Default: Optionaler Text, der zurückgegeben wird, wenn kein passender Eintrag gefunden wurde.

Property, optional: Alternativ zum gesamten Text des gefundenen Projektes können Sie auch die erweiterten Eigenschaften abfragen: "FullPath" entspricht dem Standard, "Text" ist die unterste Projektebene und "Description" die Beschreibung. Weitere Eigenschaften sind "Bold", "Italic" und "ImageIndex".

Rückgabewert

Gibt den entsprechenden Eintrag aus der Liste zurück oder einen Leerstring, falls kein passender Eintrag gefunden wurde.

Beschreibung

Einigen Datenfeldern sind Auswahllisten zugeordnet - beispielsweise dem Projekt und der Kategorie. Mit Hilfe dieser Makrovariable können Sie passende Einträge in den Listen suchen.

Hinweis: Verwenden Sie AutoCaptSelectionListFindItem, wenn Sie nach passenden Texten im gesamten Dokumenteninhalt suchen möchten.

Beispiele

{SelectionListFindItem:Category,{GetPrivVar:AusDokumentGelesen},1,0,Nicht definiert}
Die private Variable "AusDokumentGelesen" wurde beim Scannen von einer festen Position gelesen. Wenn der Text in einer Kategorie vorkommt, dann soll diese Kategorie zurückgegeben werden, anderenfalls "Nicht definiert".

{SelectionListFindItem:Project,Prinzenallee,2,1}
In den Projekthinweisen sind Straßennamen enthalten, die zum jeweiligen Projekt gehören. Es soll das Projekt ermittelt werden, welches die "Prinzenallee" beinhaltet.
Bei der automatisierten E-Mailarchiverung könnten beispielsweise auch die Mailadressen in den Projekthinweisen hinterlegt und die Mails dann automatisch dem Projekt zugeordnet werden.

{SelectionListFindItem:Project,{Doc:Project},0,0,{Doc:Project},Description}
Gibt die Beschreibung des Projektes zurück, welchem das aktuelle Dokument zugeordnet ist. Falls keine Beschreibung vorhanden ist, wird das Projekt zurückgegeben.

Siehe auch

Makro-Referenz

Übersicht Belegerkennung

AutoCaptSelectionListFindItem

FtiGetFirstCrspWord


Self

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

Self

Makro-Variable Self

Zugriff auf Variablen und -funktionen des DMS-Clients.

Syntax

{Self:Variable[,FormatParameter]}

Parameter

Variable

AdminLoggedIn: "1", wenn der Programm-Administrator angemeldet ist, anderenfalls "0".

AdminMessage: Der vom Administrator definierte Zusatztext für Fehlermeldungen

ApplDB: Dateiname der Anwendungsdatenbank

ArchDocPath: Verzeichnis für archivierte Dokumente 1)

ArchDocPathMain: Verzeichnis für archivierte Dokumente bis vor erster Makrovariablen 1)

ArchDocPathResult: Verzeichnis für archivierte Dokumente, enthaltene Variablen werden ausgewertet 1)

CommonFilesPath: Verzeichnis der gemeinsamen Dateien 1)

CreateOrAlterStoredProcedures: Gespeicherte Prozeduren in den geöffneten Datenbanken (derzeit nur Archiv) erstellen oder aktualisieren 2)

CrmDB: Dateiname der Kontaktdatenbank (CRM)

DBQuoteChar: Anführungszeichen, mit denen die Zeichenwerte bei SQL-Abfragen eingeschlossen sind (s. a.)

DocDB: Dateiname der geöffneten Archivdatenbank

DocPath: Standard-Dokumentenverzeichnis 1)

DocPathMain: Standard-Dokumentenverzeichnis bis vor erster Makrovariablen 1)

DocPathResult: Standard-Dokumentenverzeichnis, enthaltene Variablen werden ausgewertet 1)

DocTable: Name der aktiven Dokumententabelle, "document" oder "docarch"

ExeName: Die Programmdatei mit komplettem Pfad

ExePath: Der komplette Programm-Pfad 1)

ExeVersion: Die Office Manager-Versionsnummer, z. B. "23.1.0.580" (s. a. FileAttr:Version)

ExeVersionComp: Die Compilierungsnummer, z. B. "580"

PathApplDB: Verzeichnis der Anwendungsdatenbank 1)

PathCrmDB: Verzeichnis der Kontaktdatenbank 1)

PathDocDB: Verzeichnis der Archivdatenbank 1)

ProgramName: Kurzname des Programms

RegistryPath: Office Manager-Pfad in der Registrierdatenbank 1)

RegistryPathCfg: Pfad zu den Einstellungen in der Registrierdatenbank 1)

TmpPath: Pfad der temporären Dateien 1)

UserName: Benutzername (der in Office Manager DMS angemeldete Benutzer)

UserNameEx,FileName: Windows-Besitzer der Datei FileName oder (wenn der Besitzer nicht ermittelt werden konnte oder eine Gruppe ist) der Office Manager-Benutzername

WindowTitle: Titel des Programmfensters

FormatParameter: Mit dem optionalen Formatparameter können Sie einen Teil des Dateinamen übernehmen.

1) Alle Pfadangaben "Path" sind inkl. abschließendem Backslash "\".

2) Aufruf einer Prozedur ohne Rückgabewert.

Rückgabewert

Angeforderte Office Manager DMS-Variable.

Beschreibung

Ermöglicht den Zugriff auf Programmvariablen, wie z. B. die geöffneten Datenbanken und aktuelle Programmoptionen.

Siehe auch

Makro-Referenz

CurrDatabase

AdminINI

OS


SendKey

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

SendKey

Makro-Prozedur SendKey

Emuliert einen Tastendruck im aktiven Anwendungsprogramm.

Syntax

{SendKey:ASCII-Code}

Parameter

ASCII-Code: Der ASCII-Code des zu sendenden Tastendrucks.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Einschränkung

Diese potenziell gefährliche Funktion ist standardmäßig gesperrt.

Beschreibung

Emuliert einen Tastendruck im aktiven Anwendungsprogramm. Als Parameter wird der ASCII-Code der Taste übergeben.

Hinweis: Um einen ganzen Text zu senden verwenden Sie bitte SendKeyStr.

Beispiel

Mit {SendKey:121} können Sie die Taste F10 simulieren und im aktiven Anwendungsprogramm das Hauptmenü öffnen.

Siehe auch

Makro-Referenz

SendKeyStr

CreateKey

Chr

SetActiveApplication


SendKeyStr

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

SendKeyStr

Makro-Prozedur SendKeyStr

Emuliert Tastatureingaben für die Übermittlung des im Parameter angegebenen Textes an die Anwendung.

Syntax

{SendKeyStr:Text}

Parameter

Text: Der an die Anwendung zu sendende Text, z. B. {SendKeyStr:Ich bin der Text}

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

SendKeyStr sendet den im Parameter angegebenen Text an die aktive Anwendung. Für jedes Zeichen wird in der Anwendung ein Tastendruck simuliert.

Hinweis: Um nur ein einzelnes Zeichen zu senden verwenden Sie bitte SendKey.

Siehe auch

Makro-Referenz

ASCII-Code

SendKey

CreateKey

CreateKeyStr

SetActiveApplication


SendMouseClick

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

SendMouseClick

Makro-Prozedur SendMouseClick

Emuliert einen Mausklick.

Syntax

{SendMouseClick:Key[,Point]}

Parameter

Key:

L = linke

R = rechte

M = mittlere Maustaste

D = Doppelklick mit linker Maustaste. Dieser Klick wird immer mit PostMessage simuliert (erste Methode).

Point: XxY, bezogen auf die linke obere Ecke des Fensters. Dieser Parameter ist optional.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Prozedur emuliert einen Mausklick (drücken und lösen der Taste) in einer Anwendung.

Wenn der optionale Parameter Point angegeben ist, dann erfolgt der Klick mit der Windows-API-Funktion PostMessage an den gewünschten Koordinaten. Die Anwendung, in der die Maus emuliert werden soll, muss mit einem vorherigen Aufruf von {SetActiveApplication:Default} definiert werden.

Ist der Parameter nicht angegeben, erfolgt die Emulation mit der Windows-API-Funktion Mouse_Event an der aktuellen Position in der Anwendung, die derzeit im Vordergrund ist. Bringen Sie die gewünschte Anwendung mit einem Aufruf von{ShowApplication} in den Vordergrund. Diese Methode ohne Koordinaten-Angabe funktioniert oft auch mit älteren Anwendungen, bei denen die erste Methode versagt.

Beispiele:

{SetActiveApplication:Default} Das Fensterhandle der aktuellen Anwendung (mit der das Dokument gerade geöffnet wurde) für folgende Makrofunktionen festlegen.

{SendMouseClick:L,100x150} emuliert den Klick der linken Maustaste an den Koordinaten X=100 und Y=150.

Siehe auch

Makro-Referenz

ShowApplication

SetActiveApplication

WinAPI

SendKey

SendKeyStr


SetActiveApplication

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

SetActiveApplication

Makro-Prozedur SetActiveApplication

Definiert die aktive Anwendung für fensterorientierte Funktionen.

Syntax

{SetActiveApplication:Application}

Parameter

Application

Default: Aktiviert die Anwendung, mit dem das Dokument geöffnet wird.

GetForegroundWindow: Aktiviert das Fenster, das z.Zt. im Vordergrund ist.

GetDesktopWindow: Aktiviert den Windows-Desktop.

GetParent: Aktiviert das Fenster, welches der Eigentümer des z.Zt. aktiven Fensters ist. Wenn z. B. das Dialogfenster der Anwendung aktiv ist, wird durch GetParent das Hauptfenster aktiviert.

GetTopWindow: Aktiviert das für den Anwender sichtbare Fenster der aktiven Anwendung.

Self: Aktiviert das Hauptfenster des Office Managers.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Makro-Funktionen beziehen sich in der Regel auf die Anwendung, mit der das Dokument geöffnet wird. Wenn Sie jedoch Befehle an eine andere Anwendung senden möchten, dann können Sie mit SetActiveApplication eine andere Anwendung festlegen, auf die sich nachfolgende Makro-Funktionen beziehen sollen.

Siehe auch

Makro-Referenz

SetComApplName


SetComApplName

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

SetComApplName

Makro-Prozedur SetComApplName

Definiert die Anwendung für folgende COM-Funktionen.

Syntax

{SetComApplName:Application}

Parameter

Application: OLE-Name der Anwendung, z. B. "Word.Application" oder "AutoCAD.Application".

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Funktion definiert den Namen der Anwendung für folgende COM-Automatisierungen.

Siehe auch

Makro-Referenz

SetActiveApplication


SetControl

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

SetControl

Verfügbar in diesen Editionen

Makro-Prozedur SetControl

Eigenschaft eines Formular-Controls ändern.

Syntax

{SetControl:Path,Property=Value}

Parameter

Path: Kompletter Pfad und Name des Controls: FormName.Container.ControlName, z. B.
FormDBEdit.LayoutPanelMainFields.CoBoxApplName

Property: Name der Eigenschaft:
enabled: Bool (0 oder 1)
visible: Bool
left: Integer
top: Integer
width: Integer
height: Integer
hint: String

Value: Neuer Wert der Eigenschaft.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Einschränkung

Diese potenziell gefährliche Funktion ist standardmäßig gesperrt.

Beschreibung

Mit SetControl können Sie Eigenschaften eines Controls (Eingabefeld, Schalter u. ä.) aus einem Makro heraus ändern.

Die Funktion richtet sich an Applikations-Entwickler. Als Anwender verwenden Sie bitte den Layout-Designer.

Siehe auch

Makro-Referenz

GetControl

Layout-Designer


SetPrivVar

SetPrivVar, SetPublVar

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

SetPrivVar, SetPublVar

Makro-Prozedur SetPrivVar

Makro-Prozedur SetPublVar

Benutzer-Variable definieren.

Syntax

{SetPrivVar:Variable=Value}

{SetPrivVar:*TableName}

{SetPublVar:Variable=Value}

{SetPublVar:*TableName}

Parameter

Variable: Name der Variable oder * und Kennung der Datenbank-Tabelle. Verwenden Sie den Stern nur für Tabellen und nicht für Variablen-Namen, beispielsweise ist "*List" ein reservierter Name.

Value: Inhalt der Variable.

Alternativ

*Clear-List: löscht alle Variablen.

*TableName: * gefolgt von der Tabellenkennung.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Mit den Prozeduren werden Variablen definiert, auf die mit GetPrivVar und GetPublVar zugegriffen werden kann. Private Variablen (SetPrivVar) sind nur innerhalb des Makros gültig. Öffentliche (SetPublVar) gelten zur gesamten Laufzeit des Office Managers.

Alternativ zu einzelnen Variablen können auch die Spalten des aktuellen Datensatzes einer Tabelle als Variablen übernommen werden. Die Syntax ist dann {SetPrivVar:*Table}. Die Variablen können anschließend mit {GetPrivVar:FieldName} abgerufen werden.

Siehe auch

Makro-Referenz

GetPrivVar, GetPublVar

InifileWriteStr


SetStayOnTop

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

SetStayOnTop

Makro-Prozedur SetStayOnTop

Office Manager im Vordergrund.

Syntax

{SetStayOnTop:Self,Parameter}

Parameter

Self: Derzeit nur "Self", der Office Manager selbst.

Parameter: "true" = Office Manager im Vordergrund halten. "false" = wieder normalen Status setzen.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Legt fest, ob der Office Manager systemweit im Vordergrund gehalten werden soll.

Siehe auch

Makro-Referenz

WinAPI:ShowWindow


ShellExecute

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ShellExecute

Makro-Prozedur ShellExecute

Dateien öffnen.

Syntax

{ShellExecute[:FileName,Parameter,Show,Flag|ShellCmd]}

Parameter

FileName: Kompletter Dateiname einer Anwendung oder Dokumentdatei

Parameter: Optionale Befehlszeilenparameter

Show: 1=normale Fenstergröße (Vorgabe), 2=als Symbol starten, 3=maximiert starten

Der vierte Parameter ist entweder ein Flag oder der Windows-Befehlsname:

Flag: "WaitForInputIdle" wartet, bis die Anwendung gestartet ist, "WaitForSingleObject" wartet bis sie beendet ist (der intern verwendete Windows-Befehl ist dann CreateProcess statt ShellExecute). "RunAsAdmin" führt die Anwendung als Administrator aus, Sie müssen den Aufruf bei aktiver Benutzerkontensteuerung (UAC) bestätigen.

ShellCmd: Windows-Befehlsname, beispielsweise "open", "printto", "edit". Standard ist leer=Windows-Standardbefehl bzw. der vorgegebene Wert von OpenShellCommand.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Startet die mit FileName angegebene Anwendung oder Dokumentdatei. Wenn kein Dateiname angegeben ist wird die dem aktuellen Befehl zugeordnete Anwendung gestartet. Wenn in Dateiname keine Anwendung, sondern ein Dokument angegeben ist, dann wird das Dokument in der entsprechenden Windows-Standardanwendung geöffnet.

Hinweis: ShellExecute ändert nicht die aktive Anwendung für nachfolgende Makro-Funktionen. Verwenden Sie dafür SetActiveApplication.

Beispiele

{ShellExecute} startet die aktuelle Anwendung.

{ShellExecute:notepad.exe} startet den Windows-Editor.

{ShellExecute:{CurrApplExe},{CurrDocFileName}} startet die aktuelle Anwendung und übergibt ihr das aktuelle Dokument als Startparameter. Das Dokument wird dann in der Regel von der Anwendung geöffnet. Beachten Sie bei der zweiten Variante bitte das Komma hinter dem Doppelpunkt.

{ShellExecute:notepad.exe,C:\Eigene Dateien\test.txt} startet Notepad und öffnet die Datei "C:\Eigene Dateien\test.txt".

{ShellExecute:C:\Eigene Dateien\test.txt} öffnet die Datei "C:\Eigene Dateien\test.txt" in der Windows-Standardanwendung.

{ShellExecute:{CurrDocFileName}} öffnet das aktuelle Dokument in der Windows-Standardanwendung.

{ShellExecute:{Self:ExeName},/regserver,RunAsAdmin} Office Manager COM-Server registrieren.

Siehe auch

Makro-Referenz

WaitForApplication

ShowApplication

SetActiveApplication

ExecuteDocuments

OpenDocument

admin.ini OpenShellCommand


ShowApplication

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

ShowApplication

Makro-Prozedur ShowApplication

Zeigt die angegebene Anwendung.

Syntax

{ShowApplication[:FileName]}

Parameter

FileName: Kompletter Dateiname der Anwendung (*.exe)

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

ShowApplication zeigt die angegebene Anwendung an. Wenn die Anwendung gestartet ist wird sie in den Vordergrund gebracht. Ist sie noch nicht gestartet so wird sie jetzt gestartet. Wenn kein Dateiname angegeben ist bzw. die Datei nicht existiert, wird die aktuell Anwendung verwendet.

Hinweis: ShowApplication ändert nicht die aktive Anwendung für nachfolgende Makro-Funktionen. Verwenden Sie dafür SetActiveApplication.

Siehe auch

Makro-Referenz

ShellExecute

WinAPI:ShowWindow:x

SetStayOnTop


SignDocument

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

SignDocument

Verfügbar in diesen Editionen

Makro-Prozedur SignDocument

PDF-Dokument digital signieren.

Syntax

{SignDocument:DocFileName,PFXFileName,PFXPassword[,Location,ContactInfo,Reason,SignFieldName,OpenPassword]}

Parameter

DocFileName: Kompletter Dateiname des Dokuments, z. B. {Doc:FileName} oder {Source}.

PFXFileName: Kompletter Dateiname der *.pfx-Signaturdatei.

PFXPassword: Verschlüsseltes Passwort für die Signaturdatei.

Optionale Parameter

Location: Ort der Unterzeichnung. Standardwert -wenn nicht angegeben- ist der Ort und das Land der Office Manager-Registrierung.

ContactInfo: Informationen zum Unterzeichner, beispielsweise Vor- und Nachname. Standardwert ist der Windows-Benutzername.

Reason: Grund für die Signierung. Standard ist "Revisionssichere Archivierung" bzw. Übersetzung entsprechend der gewählten Programmsprache.

SignFieldName: Name des Signaturfeldes, Standard "OfficeManagerSignatureField". Dem Namen wird ein Zahl angefügt, falls er bereits vorhanden ist.

OpenPassword: In der Regel leer. Das Dokument könnte nur mit dem Passwort geöffnet werden, wenn es angegeben wird.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Funktion signiert ein Acrobat-Dokument mit Hilfe einer *.pfx-Signaturdatei (PKCS#12 certificate/private key file). Im Gegensatz zu PDFProtectDocument werden Dateiänderungen hiermit nicht verhindert, sondern erkannt. Der Unterzeichner bürgt für die Richtigkeit des Dokuments, es ist jederzeit zu erkennen, ob das Dokument nach der Unterzeichnung manipuliert wurde. Ein Dokument kann mehrmals und von mehreren Personen unterschrieben werden.

Signiertes PDF-Dokument
Signatur im Acrobat

Wenn Sie alle Dokumente automatisch signieren möchten, die aus einem bestimmten Verzeichnis importiert werden, dann definieren Sie bitte ein Importprofil. Geben Sie auf der Seite Makro bei Nach Speichern diese Prozedur ein.

Siehe auch

Makro-Referenz

UpdateDocAttributesFromFile

PDFProtectDocument

PDFAddComment

StoreHashesOnBlockchain

Adobe-Certified Document Services (CDS)

Passwort verschlüsseln


Source

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

Source

Makro-Variable Source

Dateiname einer Quelle, insbesondere beim Importieren und Scannen.

Syntax

{Source[:FormatParameter]}

Parameter

FormatParameter: Mit dem optionalen Formatparameter können Sie Teile des Dateinamen übernehmen.

Rückgabewert

Quelldateiname

Beschreibung

Enthält beispielsweise den Namen einer Datei, die per Drag&Drop vom Explorer importiert wird. Beim Scannen ist der temporäre Dokumentdateiname enthalten, den Sie im Makro der OCR-Software verwenden können.

Während der Programmierung eines Makros können Sie der Variable {Source} auch einen Wert per Code zuweisen, um nicht für jeden Testlauf einen Import ausführen zu müssen:

{Source:SetSource=G:\Dokumente\Mein Testdateiname.pdf}

Siehe auch

Makro-Referenz

Dest

CurrDocFileName

Source oder FileName


SplitDocument

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

SplitDocument

Makro-Funktion SplitDocument

PDF-Dokument nach fester Seitenzahl (Syntax 1) sowie mit Barcode oder Makro (Syntax 2) aufteilen.

Syntax 1

{SplitDocument:Mode,SrcFileName,PageCount,DeleteSrc}

Parameter

Mode: Für Syntax 1 bitte "1" angeben.

SrcFileName: Name der zu splittenden PDF-Datei.

PageCount: Anzahl der Seiten, nach welcher ein neues Dokument erstellt wird.

DeleteSrc: 0 oder 1: Bei 1 wird das Quelldokument gelöscht, sofern es aufgeteilt wurde.

Rückgabewert

Liste der erzeugten Dateien mit Zeilenumbruch (#13#10) getrennt.

Beschreibung

Zerlegt das Quelldokument in einzelne Dateien mit der angegebenen Seitenzahl.

Syntax 2 und 3

Verfügbar in diesen Editionen

{SplitDocument:Mode,SrcFileName,BarType/Macro,BarcodeText/MacroRes,DeleteSrc[,RenderDPI]}

Parameter

Mode: "2" für Barcode, "3" für Makro-Trennung.

SrcFileName: Name der zu splittenden PDF-Datei.

BarType/Macro: Bei Barcode-Trennung geben Sie "Unknown" für eine automatische Erkennung oder die Kurzbezeichnung des gewünschten 1D-Barcodes ein.
Bei Makrotrennung bitte das Makro.

BarcodeText/MacroRes: Text des Barcodes bzw. des Makroergebnisses, der eine Dokumenttrennung auslöst.

DeleteSrc: 0 oder 1: Bei 1 wird das Quelldokument gelöscht, sofern es aufgeteilt wurde.

RenderDPI (optional): Wenn der Parameter fehlt oder 0 ist, dann wird die erste Grafik auf den Seiten extrahiert und nach dem Barcode durchsucht. Wenn ein Wert ungleich 0 angegeben ist, dann werden die Seiten mit der angegebenen Auflösung in Grafikdateien gedruckt.

Rückgabewert

Liste der erzeugten Dateien mit Zeilenumbruch (#13#10) getrennt.

Beschreibung

Die Funktion dient der Dokumenttrennung, wie bei einem Stapelscan. Der gesamte Stapel (das Quelldokument) wird bei jedem passenden Barcode oder Makroergebnis getrennt und die einzelnen Dateien erstellt. Beim Barcodemodus werden die Trennblätter entfernt.

Das Quelldokument bleibt immer erhalten, falls keine Trennung erfolgt, der Quelldateiname steht dann im Rückgabewert.

Siehe auch

Makro-Referenz

CombineDocuments

MergeDocuments

ExtractPages


StoreHashesOnBlockchain

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

StoreHashesOnBlockchain

Makro-Funktion StoreHashesOnBlockchain

Dokumentenrevision mittels dezentraler Blockchain.

Syntax

{StoreHashesOnBlockchain:Blockchain,WebAPI,DocID}

Parameter

Blockchain: 1 für Documentchain oder 2 für das Documentchain-Testnet.

WebAPI: 1 für die Verwendung eines Web-Servers oder 0 für ein lokal installiertes Wallet.

DocID: Schlüsselnummer des Dokuments im Archiv.

Rückgabewert

Blockchain-Kennung und Transaktions-ID, beispielsweise
dms:2117313482d0cd51d34bb9a6037281dd4b58fe72cbfd978cd4118538f09300c2

Beschreibung

Speichert Dokument-Checksummen manipulationssicher auf einer öffentlichen Blockchain und gibt die Transaktions-ID oder bei Misserfolg einen Leerstring zurück. Die Funktion ist nur für Dokumente möglich und nicht für Internetlinks. Die Speicherung auf Documentchain ist kostenpflichtig, in der Vollversion von Office Manager sind aber bereits einige Transaktionen ohne Zusatzkosten erhalten.

Die Makro-Funktion setzt nicht das Schreibschutzattribut der Dateien. Dies kann im Makro aber mit FileSetAttr gemacht werden.

Siehe auch

Makro-Referenz

AddSysTask

SignDocument


StringReplace

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

StringReplace

Makro-Funktion StringReplace

Einen Teil im angegebenen Text ersetzen.

Syntax

{StringReplace:Text,OldPattern,NewPattern}

Parameter

Text: Text der geändert werden soll.

OldPattern: Ursprünglicher Wert, der ersetzt werden soll.

NewPattern: Wert, durch den OldPattern ersetzt wird.

Rückgabewert

Ersetzter Text.

Beschreibung

Ersetzt in Text alle Zeichen mit dem Wert OldPattern durch NewPattern. Groß- und Kleinschreibung wird unterschieden.

Beispiel

{StringReplace:{Doc:FileName},G:\,C:\} ändert den Dokument-Dateinamen von "G:\..." in "C:\...".

Siehe auch

Makro-Referenz

Format


UpdateDocAttributesFromFile

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

UpdateDocAttributesFromFile

Makro-Prozedur UpdateDocAttributesFromFile

Aktualisiert die dateiabhängigen Attribute des aktuellen Dokuments.

Syntax

{UpdateDocAttributesFromFile}

Parameter

Keine

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Funktion liest alle Dateiattribute aus der aktuellen Dokumentdatei und aktualisiert diese bei Bedarf im Archiv-Datensatz. Ein Aufruf dieser Funktion ist erforderlich, nachdem eine Datei mit Makrofunktionen bearbeitet wurde. Beispielsweise nach PDFProtectDocument, wenn das Datenfeld fileprotected im Archiv vorhanden ist.

Siehe auch

Makro-Referenz

FileAttr

Dateiabhängige Dokumentattribute

Datenbankpflege


UploadFile

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

UploadFile

Makro-Funktion UploadFile

Eine Datei auf einen FTP-Server hochladen.

Syntax

{UploadFile:Mode,LocalFileName,RemoteFileName,Host,Port,UserName,Password[,PublicKeyFile,PrivateKeyFile]}

Parameter

Mode
1: FTP mit Benutzername und Passwort im siebten Parameter.
2: wie 1, jedoch mit verschlüsseltem Passwort.
3: SFTP mit Benutzername und Passwort im siebten Parameter.
4: wie 3, jedoch mit verschlüsseltem Passwort.
5: SFTP mit Schlüsselpaar
6: : wie 5, jedoch mit verschlüsseltem Passwort.

LocalFileName: Dateiname oder URL der Quelldatei.

RemoteFileName: Dateiname der Zieldatei auf dem FTP-Server.

Host: Name oder IP des FTP-Servers.

Port: Server-Port, Standard ist 21 für FTP und 22 für SFTP.

UserName: Benutzername für die Server-Anmeldung.

Password: In Mode 1 bis 4 das Benutzer-Passwort im Klartext oder verschlüsselt. In Mode 5 und 6 leer oder das Passwort für PrivateKeyFile.

PublicKeyFile: Nur Mode 5 und 6, Dateiname des öffentlichen Schlüssels.

PrivateKeyFile: Nur Mode 5 und 6, Dateiname des privaten Schlüssels.

Rückgabewert

1 bei erfolgreichem Upload und 0 bei Misserfolg.

Beschreibung

Mit dieser Funktion können Sie eine Datei auf einen FTP-Server hochladen. Unterstützt wird das klassische File Transfer Protocol (FTP) sowie Secure File Transfer Protocol (SFTP) via SSH.

Damit das Passwort nicht im Klartext hinterlegt werden muss, kann es in den Modi 2, 4 und 6 verschlüsselt werden.

Voraussetzung für SFTP ist eine installierte Bibliothek libssh2.dll, beispielsweise im Programmverzeichnis. Für Modus 5 und 6 ist eine libssh2.dll erforderlich, die mit OpenSSL kompiliert wurde.

Siehe auch

Makro-Referenz

CopyFile zum lokalen Kopieren und Download


Wait

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

Wait

Makro-Prozedur Wait

Wartet die angegebene Zeit.

Syntax

{Wait:msec}

Parameter

msec: Zeit in Millisekunden.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Der Office Manager wartet vor dem Senden weiterer Makro-Befehle die angegebene Zeit in Millisekunden (1000=1 Sekunde).

Siehe auch

Makro-Referenz

WaitForFile

WaitForApplication

ProcessMessages


WaitForApplication

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

WaitForApplication

Makro-Funktion WaitForApplication

Auf den Start oder das Ende einer Anwendung warten.

Syntax

{WaitForApplication:ExeName[,TimeOut,StartOrEnd]}

Parameter

ExeName: Kompletter Dateiname der Anwendung.

TimeOut: Optionale Angabe der maximale Wartezeit in Sekunden. Wenn kein TimeOut oder der Wert 0 angegeben ist, kann dies zu einer Endlosschleife führen!

StartOrEnd: '0' wartet bis die Anwendung beendet ist, '1' bis sie gestartet ist. '1' ist der Vorgabewert, falls der Parameter nicht angegeben ist.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Office Manager prüft in einer Warteschleife, ob das Hauptfenster der angegebenen Anwendung vorhanden ist. Weitere Makro-Befehle werden erst gesendet, wenn das Fenster gefunden bzw. nicht gefunden wird. Falls die im optionalen Parameter TimeOut angegebene Zeit überschritten wurde, bricht das Makro mit einer Fehlermeldung ab. Die Warteschleife wird immer einmal durchlaufen, dadurch entsteht eine Wartezeit von mindestens 1 Sekunde.

Beispiel

Aktuelles Dokument öffnen, Menü Datei | Beenden durch Tastenemulation ausführen und max. 5 Sekunden warten bis die Anwendung wieder geschlossen ist.

{ShellExecute:{CurrApplExe},{CurrDocFileName},1,WaitForInputIdle}

{Wait:400}

{WinAPI:BringWindowToTop}

{CreateKey:121,Virtual}

{CreateKey:100}

{CreateKey:98}

{WaitForApplication:{CurrApplExe},5,0}

Siehe auch

Makro-Referenz

WaitForFile

Wait

MessageDlg


WaitForFile

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

WaitForFile

Makro-Prozedur WaitForFile

Auf eine Datei warten.

Syntax

{WaitForFile:FileName[,TimeOut,ExistsOrNot]}

Parameter

FileName: Kompletter Name der Datei.

TimeOut: Optionale Angabe der maximale Wartezeit in Sekunden. Wenn kein TimeOut oder 0 angegeben ist, kann dies zu einer Endlosschleife führen!

ExistsOrNot: '1' oder keine Angabe wartet bis die Datei vorhanden ist. '0' wartet bis sie nicht (mehr) vorhanden ist.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Der Office Manager prüft in einer Warteschleife, ob die genannte Datei vorhanden (oder nicht mehr vorhanden) ist. Weitere Makro-Befehle werden erst abgearbeitet, wenn die Bedingung eintritt. Falls die im optionalen Parameter TimeOut angegebene Zeit überschritten wurde, bricht das Makro mit einer Fehlermeldung ab. Die Warteschleife wird mindestens einmal durchlaufen, dadurch entsteht immer eine Wartezeit von 1 Sekunde.

Siehe auch

Makro-Referenz

WaitForApplication

Wait

Bedingte Ausführung

MessageDlg


WinAPI

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

WinAPI

Makro-Prozedur WinAPI

Führt die im Parameter angegebene Windows-API-Funktion aus.

Syntax

{WinAPI:Function[,Parameter]}

Parameter

Function:

SetForegroundWindow: Bringt das Fenster in den Vordergrund, wenn es im Hintergrund liegt.

BringWindowToTop: Bringt das Fenster in den Vordergrund, wenn es im Hintergrund liegt. Im Gegensatz zu SetForegroundWindow bringt es die Anwendung auch an den Anfang der Windows Z-Reihenfolge.

ShowWindow: Setzt den Status des Fensters auf Normal oder auf den im zweiten Parameter angegebenen Fensterstatus.

Parameter für ShowWindow:

2: (SW_SHOWMINIMIZED) aktiviert das Fenster und zeigt es minimiert an

3: (SW_MAXIMIZE) maximiert das Fenster

4: (SW_SHOWNOACTIVATE) zeigt das Fenster mit häufigst verwendeter Position und Größe ohne es zu aktivieren

5: (SW_SHOW) zeigt und aktiviert das Fenster. Dies ist auch der Vorgabewert, wenn der Parameter nicht angegeben wurde.

6: (SW_MINIMIZE) minimiert und deaktiviert das Fenster

7: (SW_SHOWMINNOACTIVE) zeigt das Fenster minimiert ohne es zu aktivieren

8: (SW_SHOWNA) zeigt das Fenster ohne es zu aktivieren

9: (SW_RESTORE) aktiviert und zeigt das Fenster in seiner originalen Größe und Position

0: (SW_HIDE) verbirgt das Fenster, rufen Sie ShowWindow nicht mit dem Parameter 0 auf, das Fenster ist dann nicht mehr sichtbar !

OpenIcon: Stellt die Anwendung wieder her, wenn sie minimiert ist.

PlaySound: Spielt die im Parameter angegebene Sounddatei ab.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Führt die im Parameter angegebene Windows-API-Funktion aus. Die Funktion bezieht sich immer auf das Hauptfenster der aktiven Anwendung.

Hinweis: Verwenden Sie ShowApplication, um die Anwendung unabhängig von ihrem Status in den Vordergrund zu bringen. Mit MinimizeApplication können Sie den Office Manager minimieren.

Beispiel

{WinAPI:ShowWindow:6} minimiert und deaktiviert das Programm-Fenster.

Siehe auch

Makro-Referenz

ShowApplication

SetActiveApplication

MessageBeep


WriteJournal

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

WriteJournal

Makro-Prozedur WriteJournal

Protokolleintrag zu einem Dokument oder Kontakt hinzufügen.

Syntax

{WriteJournal:DBID,RecordID,Text}

Parameter

DBID: DocDB oder CRMDB.

RecordID: Schlüsselnummer des Dokuments oder GUID des Kontakts, zu dem der Text protokolliert werden soll.

Text: der zu protokollierende Text.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Prozedur erstellt einen Protokolleintrag.

Das Protokoll wird auch erstellt, wenn "Dokumentbearbeitung protokollieren" deaktiviert ist.

Beispiel

{WriteJournal:DocDB,{Doc:DocID},Protokolltext für das aktuelle Dokument}

{WriteJournal:CRMDB,{Contact:contactguid},Protokolltext für den aktuellen Kontakt}

Siehe auch

Makro-Referenz

Einstellungen, Seite Datenbank, Dokumentbearbeitung protokollieren


WriteLnFile

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

WriteLnFile

Makro-Prozedur WriteLnFile

Fügt eine Textzeile an eine Datei an.

Syntax

{WriteLnFile:FileName,Text}

Parameter

FileName: Kompletter Dateiname der Textdatei.

Text: Der zu schreibende Text.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Die Funktion schreibt den angegebenen Text in die Datei. Der Text wird am Ende der Textdatei angefügt. Ist die Datei noch nicht vorhanden, dann wird sie erstellt.

Mehrzeiliger Text muss mit carriage return und line feed getrennt werden "{Chr:13}{Chr:10}".

Beispiele

Den Projektnamen des aktuellen Dokuments als neue Zeile am Ende einer Textdatei hinzufügen:

{WriteLnFile:c:\Projektliste.txt,{Doc:project}}

Die Projektliste in eine Datei schreiben:

# da WriteLnFile immer anfügt, zuvor löschen

{DeleteFile:c:\Projektliste.txt,NoConfirm}

{WriteLnFile:c:\Projektliste.txt,{Format:{FieldAttribute:DocDB,project,pickitems,{chr:13}{chr:10}},Trim}}

Siehe auch

Makro-Referenz

ReadLnFile


WriteStatusbar

Navigation: Entwicklerhilfe > Makro-Referenz OmAPI >

WriteStatusbar

Makro-Prozedur WriteStatusbar

Schreibt einen Text in die Statuszeile des Programm-Hauptfensters.

Syntax

{WriteStatusbar:Text}

Parameter

Text: Der zu schreibende Informationstext.

Rückgabewert

Keiner, die Anweisung wird nach Ausführung durch einen Leerstring ersetzt.

Beschreibung

Vor dem Aufruf von zeitaufwendigen Funktionen können Sie einen Text in die Statuszeile schreiben, um den Anwender über den aktuellen Ausführungsstand zu informieren.

Siehe auch

Makro-Referenz

MessageDlg


Pascal-Referenz

Navigation: Entwicklerhilfe >

Pascal-Referenz

Office Manager beinhaltet den "JCL Pascal Pre Processor". Die Skripte werden programmintern interpretiert.

Allgemeine Pascal-Referenz

Der Interpreter hat folgende Merkmale:

·Einfache Pascal-Syntax mit Prozeduren, Funktionen, lokalen und globalen Variablen.

·Einfache Datentypen, Varianten- und Array-Typen.

·Objektorientierte Programmierung

·OLE-Automatisierungen.

·Aufruf von DLLs

·Visuelle Komponentenbibliothek

Informationen und Dokumentationen:

·Beschreibung des Interpreters (englisch)

·Wikibooks GNU-Pascal in Beispielen

·Embarcadero VCL, der Interpreter unterstützt einen Teil der VCL

Spezielle Referenz

Objekte und Funktionen, die vom Office Manager-Programm zur Verfügung gestellt werden:

1. Globale Variablen

OfficeManager: TOfficeManager

2. Objekte

TOfficeManager

TArchive

TApplDB

TCRM

TCfg

TDebenuPDFLibrary

TFieldAttribute

TOmFormProgress

TPickItemEx

3. Units

Sie können units mittels "uses" einbinden. Die gleichnamige Pascal-Datei wird im Verzeichnis "macro\EventScripting" und danach in "macro" gesucht.

4. Ereignisse

Mit EventScriting[.Computername].pas können Sie auf programminterne Ereignisse reagieren.

5. Sonstiges

Hilfsfunktionen


TOfficeManager

Navigation: Entwicklerhilfe > Pascal-Referenz >

TOfficeManager

Pascal-Objekt TOfficeManager

Hauptobjekt des Office Manager-Clients für den Zugriff auf Programmfunktionen und -objekte.

Erzeugen Sie keine eigene Instanz dieses Objektes, greifen Sie vielmehr über die globale Variable "OfficeManager" auf das Anwendungsobjekt zu.

Syntax

OfficeManager.Anweisung

Typ

TOfficeManager

Eigenschaften

Archive | TArchive | Read | Zugriff auf das geöffnete Dokumentenarchiv
ApplDB | TApplDB | Read | Zugriff auf die geöffnete Anwendungsdatenbank
CRM | TCRM | Read | Zugriff auf die geöffnete Kontaktdatenbank
Cfg | TCfg | Read | Zugriff auf die Programm-Konfiguration
AdminLoggedIn | Boolean | Read | Status der Administratoranmeldung
ActiveGridView | TOMGridView | Read | omgvNone, omgvDocument, omgvDocArch, omgvTodo, omgvCont
ExeName | String | Read | Programm-Dateiname mit Pfad
ExeVersion | String | Read | Programmversion, wie "14.0.3.501"
ExeVersionComp | Word | Read | Kompilierungsnummer, z. B. 501
GridRecordCount(ASelected: boolean) | Integer | Read | Datensatzanzahl oder nur Anzahl der markierten in aktiver Tabelle
ProgramName | String | Read | Programmbezeichnung
SearchField[FieldName: string] | String | Read, Write | Text eines primären Suchfeldes. FieldName ist der datenbankinterne Feldname oder "*projectnavigator"
UserName | String | Read | Benutzername
WindowTitle | String | Read | Titel des Hauptfensters

Methoden

function ExecuteMacroFile(FileName: string): string | Makrodatei ausführen, beliebige Sprache
function ExecuteOmMacroLine(OmAPI: string): string | OmAPI-Befehle interpretieren
function FormByName(FormName: string: TForm | Programmfenster
procedure ImportFile(FileName: string; FieldValues: TStrings) | Datei an die Importfunktion geben
function LocateSelectedRecord(SelectionIndex: integer): boolean | Datenbankzeiger auf einen markierten Datensatz
procedure SearchSelectedRecords(SelectAll: boolean) | Die markierten Datensätze suchen. Bei SelectAll=true werden die gesuchten Datensätze anschließend markiert.
procedure SelectDocumentRecords(DocIDs: string; ClearOldSelection: boolean) | Dokumentdatensätze in der aktiven Ansicht markieren. DocIDs bitte komma-getrennt übergeben.
procedure SelectFocusedRecord(ClearSelection: boolean) | Aktuellen Datensatz markieren
function SelectionGetCSDocIDs: string | Schlüsselnummern der markierten Dokumente kommasepariert
procedure SelectionGetFieldValues(FieldName: string; sl: TStrings) | Kopiert die Feldwerte von FieldName der markierten Dokumente in sl
function SendEMail(Recipient, Subject, Body: string; Attachments: TStrings, AllowZIP: boolean) | Eine E-Mail erstellen und mit Standard-Mailprogramm senden
procedure ShowHintPopup(Hint: string) | Hinweis-Popup im Hauptfenster einblenden
procedure WriteErrorLog(Message: string) | In error.log schreiben
procedure WriteStatusBar(Message: string; WriteErrorLog, Bold, ProcessMessages: boolean | In die Statusbar des Hauptfensters und ev. in error.log schreiben

Beschreibung

Zugriff auf den Office Manager DMS-Client.

Beispiel 1

ShowMessage(OfficeManager.WindowTitle);

Beispiel 2

begin

OfficeManager.Archive.ActiveDatasetDocument.First;

ShowMessage(OfficeManager.Archive.ActiveDatasetDocument.FieldByName('docno').AsString);

end;

Beispiel 3

begin

for i:=0 to OfficeManager.GridRecordCount(true)-1 do begin

if OfficeManager.LocateSelectedRecord(i) then

ShowMessage(OfficeManager.Archive.ActiveDatasetDocument.FieldByName('name').AsString)

else

ShowMessage('Locate gescheitert');

end;

end;

Siehe auch

Pascal-Referenz


TArchive

Navigation: Entwicklerhilfe > Pascal-Referenz >

TArchive

Pascal-Objekt TArchive

Geöffnetes Dokumentenarchiv.

Erzeugen Sie keine eigene Instanz dieses Objektes, greifen Sie über die "OfficeManager.Archive" auf das Datenbankobjekt zu.

Syntax

OfficeManager.Archive.Anweisung

Typ

TArchive

Eigenschaften

ActiveDatasetDocument | TFDQuery | Read |
ActiveDocTableSource | TDocTableSource | Read, Write | dtsDocument, dtsDocArchive, dtsDocTrash
ActiveDocTableSourceName | String | Read | "document", "docarch", "doctrash"
Connection | TFDConnection | Read |
ConnectionString | String | Read |
DatabaseName | String | Read | Dateiname der Archivdatei s. a. function IsCurrArchive

Methoden

function AddDocumentVersion(EnsureDocID: integer; Name, Notes, SourceFileName: string; AsNewVersion, ShowDlg, ReadOnly, Compressed: boolean): boolean | Dokumentversion hinzufügen
procedure ArchiveDocument(DocID: Integer) | Dokument archivieren
function CopyCurrDocument(Clone, ShowEditDlg, OpenDoc, ForceCOM: boolean; NewFieldValue: TStrings): boolean | Dokument-Kopie oder -Klon erstellen
function CreateDataset: TFDQuery | Dataset-Komponente innerhalb des Archivs erzeugen
function DatasetByTableName (const TableName: string): TDataset | Dataset einer Tabelle
procedure DeleteCurrDocument(UseTrash, DeleteFiles: boolean); | Dokument löschen
function FieldAttributeByFieldName(FieldName: string): TFieldAttribute | Dokumentattribut-Objekt über Datenbank-Feldnamen
procedure EnsureDocTableSource (DocTableSource: TDocTableSource; Message: String) | Löst einen Fehler aus, wenn nicht die geforderte Tabelle geöffnet ist. TDocTableSource ist dtsDocument, dtsDocArch oder dtsDocTrash
procedure ExecSQL(Command: String) | SQL-Befehle im Archiv ausführen
function LocateDocByID(DocID: integer): boolean | Dokument mit der ID selektieren, wird bei Bedarf gesucht
procedure RecoverArchivedDocument(DocID: Integer) | Archiviertes Dokument wiederherstellen
function RenameCurrDocumentFile(NewFileName: string; ConfirmMultiFiles: boolean): boolean | Datei(en) des markierten Dokuments verschieben. Es werden auch alle weiteren Datensätze im geöffneten Archiv angepasst, die zur selben Datei verlinken.
procedure SearchDocuments(SqlWhere, InfoText: string; AddToCurrentSearch, StoreSearch: boolean) | Dokumentenrecherche
procedure SearchCombinedDocuments(DocID: integer; AddToCurrentSearch, ForceRecursive: boolean) | Verknüpfte Dokumente suchen
procedure WriteJournal(DocID, Type: Integer; Text1, Text2: String; Important: Boolean) | Protokolleintrag, siehe auch Blog

Beschreibung

Zugriff auf das geöffnete Dokumentenarchiv.

Beispiel

begin

OfficeManager.Archive.ActiveDatasetDocument.First;

ShowMessage(OfficeManager.Archive.ActiveDatasetDocument.FieldByName('docno').AsString);

end;

Siehe auch

Pascal-Referenz


TApplDB

Navigation: Entwicklerhilfe > Pascal-Referenz >

TApplDB

Pascal-Objekt TApplDB

Anwendungsdatenbank mit den Definitionen der Dokumenttypen und zentraler Aufgabenverwaltung.

Erzeugen Sie keine eigene Instanz dieses Objektes, greifen Sie über die "OfficeManager.ApplDB" auf das Datenbankobjekt zu.

Syntax

OfficeManager.ApplDB.Anweisung

Typ

TApplDB

Eigenschaften

Connection | TFDConnection | Read |
ConnectionString | String | Read |
DatabaseName | String | Read | Dateiname

Methoden

function CreateDataset: TFDQuery | Dataset-Komponente innerhalb der Datenbank erzeugen
function DatasetByTableName (const TableName: string): TDataset | Dataset einer Tabelle
procedure ExecSQL(Command: String) | SQL-Befehle ausführen

Beschreibung

Zugriff auf die geöffnete Anwendungsdatenbank.

Beispiel

ShowMessage(OfficeManager.ApplDB.DatabaseName);

Siehe auch

Pascal-Referenz


TCRM

Navigation: Entwicklerhilfe > Pascal-Referenz >

TCRM

Pascal-Objekt TCRM

Kontaktdatenbank (Customer-Relationship-Management)

Erzeugen Sie keine eigene Instanz dieses Objektes, greifen Sie über die "OfficeManager.CRM" auf das Datenbankobjekt zu.

Syntax

OfficeManager.CRM.Anweisung

Typ

TCRM

Eigenschaften

ActiveDatasetContact | TFDQuery | Read | Geöffnete Kontakt-Tabelle
Connection | TFDConnection | Read |
ConnectionString | String | Read |
DatabaseName | String | Read | Dateiname

Methoden

function CreateDataset: TFDQuery | Dataset-Komponente innerhalb der Datenbank erzeugen
function DatasetByTableName (const TableName: string): TDataset | Dataset einer Tabelle
AddContact(FieldValueList: TStrings): string; | Neuen Kontakt hinzufügen und GUID als String zurückgeben.
procedure ExecSQL(Command: String) | SQL-Befehle ausführen
function FieldAttributeByFieldName(FieldName: string): TFieldAttribute | Kontaktattribut-Objekt über Datenbank-Feldnamen

Beschreibung

Zugriff auf die geöffnete Kontaktdatenbank (Customer-Relationship-Management).

Beispiele

ShowMessage(OfficeManager.CRM.DatabaseName);

s := OfficeManager.CRM.Connection.ExecSQLScalar('SELECT email FROM contact WHERE matchcode="Softwarebüro Krekeler"');

i := OfficeManager.CRM.Connection.ExecSQLScalar('SELECT count(*) FROM contact WHERE company={s Musterfirma GmbH}');

// Kontakt anlegen

sl := TStringList.Create;

try

sl.Add('matchcode={s Mustermann, Paula, Architektin}');

sl.Add('company={s Mustermann Architektur}');

sl.Add('mydatefield={d 2024-12-24}');

sl.Add('myintfield=123');

sl.Add('recognition={s in.belegerkennung.alles.klein.ohne.leerzeichen}');

LGUID := OfficeManager.CRM.AddContact(sl);

finally

sl.Free;

end;

Siehe auch

Pascal-Referenz


TCfg

Navigation: Entwicklerhilfe > Pascal-Referenz >

TCfg

Pascal-Objekt TCfg

Programm-Einstellungen.

Erzeugen Sie keine eigene Instanz dieses Objekts, greifen Sie bitte über die "OfficeManager.Cfg" auf die Eigenschaften zu.

Syntax

OfficeManager.Cfg.Anweisung

Typ

TCfg

Eigenschaften

AdminMessage | String | Read, Write |
ArchDocPath | String | Read |
CommonFilesPath | String | Read |
DBQuoteChar | Char | Read, Write |
DocPath | String | Read |
RegistryPath | String | Read | Hauptpfad in Registry
RegistryPathCfg | String | Read | Pfad der Einstellungenin Registry
TmpPath | String | Read | Temporäres Verzeichnis
UserdefinedSetting(Name: string) | String | Read, Write | Eigene benannte Einstellungen

Beschreibung

Zugriff auf die Programmkonfiguration. Die vom Skript geänderten Einstellungen gelten nur für die Programmlaufzeit. Ausnahme: UserDefinedSettings werden in der "Settings.ini" des angemeldeten Benutzers gespeichert.

Beispiel 1

ShowMessage(OfficeManager.Cfg.RegistryPathCfg);

Beispiel 2

begin

OfficeManager.Cfg.UserDefinedSetting('Meine Einstellung') := 'Dies bitte merken';

ShowMessage(OfficeManager.Cfg.UserDefinedSetting('Meine Einstellung'));

end;

Siehe auch

Pascal-Referenz


TFieldAttribute

Navigation: Entwicklerhilfe > Pascal-Referenz >

TFieldAttribute

Pascal-Objekt TFieldAttribute

Veralteter Typname TDocumentAttribute.

Dokumentattribut des geöffneten Archivs und Kontaktattribut der geöffneten CRM-Datenbank.

Erzeugen Sie keine eigene Instanz dieses Objektes, greifen Sie bitte über "OfficeManager.Archive.FieldAttributeByFieldName" auf die vorhandenen Objekte zu.

Syntax

OfficeManager.Archive.FieldAttributeByFieldName(TheFieldName).Anweisung

OfficeManager.CRM.FieldAttributeByFieldName(TheFieldName).Anweisung

Typ

TFieldAttribute

Eigenschaften

AllowNull | Boolean | Read | false = Pflichtfeld
Caption | String | Read | Bezeichnung
DefaultNew | String | Read | Standardwert für neue Dokumente
DefaultOnPost | String | Read | Standardwert für neue und vorhandene
EditStyle | Integer | Read | Eingabestil
EditStyleDescription | String | Read | Beschreibung des Eingabestils
FieldName | String | Read | Feldname in Datenbank
ID | Integer | Read | Interne ID-Nummer
MultiSelect | Boolean | Read | Mehrfachauswahl
Name | String | Read | Interner Objektname
PickList | TStrings | Read | Auswahlliste
PickListAutoAdd | Boolean | Read | Liste automatisch erweitern
PickListExists | Boolean | Read | Attribut hat eine Auswahlliste
PickListHasObjects | Boolean | Read | Liste hat erweiterte Eigenschaften
PickListIsGlobal | Boolean | Read | Globale Liste
Syntax | String | Read | Format bei Datei- und Kontaktliste
StyleEx | String | Read | Erweiterter Eingabestil, Währung
Unique | Boolean | Read | Eindeutiger Wert

Methoden

function PickItemEx(Value: string): TPickItemEx | Erweitere Eigenschaften eines Listenelements
function PickListAdd(Item: string; UpdateChanges, ShowProblems: boolean): boolean | Der Auswahlliste einen Eintrag hinzufügen, sofern dieser noch nicht vorhanden ist. Die Liste wird gespeichert, alle Listen der Benutzeroberfläche aktualisiert.
procedure PickListClear | Die Auswahlliste leeren. Es werden auch die eventuell verbundenen Objekte (erweiterte Projekteigenschaften) freigegeben.
procedure PickListEdit(AbsoluteIndex: integer; NewText: string; UpdateChanges: boolean) | Einen Listeneintrag ändern.
function PickListFindItem(SearchFor: string; SearchMode: integer; SearchDescription: boolean; ReturnProperty: string): string | Passenden Listeneintrag suchen, s. a. OmAPI SelectionListFindItem.
procedure PickListLoad | Auswahlliste aus Datenbank oder Datei laden.
procedure PickListSave | Derzeitigen Inhalt der Auswahlliste speichern.

Beschreibung

Zugriff auf die Attributdefinitionen der geöffneten Kontaktdatenbank und des Dokumentenarchivs.

Siehe auch Datei | Datenbank | Anpassen | Felder definieren

Beispiel

procedure AddNewProject;

var LFieldDef: TFieldAttribute;

begin

LFieldDef := OfficeManager.Archive.FieldAttributeByFieldName('project');

if LFieldDef.PickListAdd('Mein neues Hauptprojekt\Mit Unterprojekt', true, false) then

ShowMessage(LFieldDef.Caption + ' wurde der Liste hinzugefügt und gespeichert');

end;

Siehe auch

Pascal-Referenz

Felder definieren


TPickItemEx

Navigation: Entwicklerhilfe > Pascal-Referenz >

TPickItemEx

Pascal-Objekt TPickItemEx

Erweiterte Eigenschaften eines Auswahllisten-Eintrages.

Erzeugen Sie keine eigene Instanz dieses Objektes, greifen Sie über "TFieldAttribute.PickItemEx(Value)" auf die vorhandenen Objekte zu.

Syntax

OfficeManager.Archive.FieldAttributeByFieldName(FieldName).PickItemEx(Value).Anweisung

Typ

TPickItemEx

Eigenschaften

FontStyle | TFontStyles | Read | Set of fsBold, fsItalic, fsStrikeOut
FullPath | String | Read | Text des Listenelements
Hint | String | Read, Write | Mehrzeilige Beschreibung
ImageIndex | Integer | Read, Write | Bildnummer
Status | Integer | Read, Write | 0=normal, 1=Warnung

Beschreibung

Die Elemente in Auswahllisten bieten zusätzliche Gestaltungsmöglichkeiten: Schriftformatierung, farbige Hervorhebung, Textbeschreibung und Grafik.

Beispiel

procedure ProjectAttributes;

var

LAttr: TFieldAttribute;

LItem: TPickItemEx;

begin

LAttr := OfficeManager.Archive.FieldAttributeByFieldName('project');

// Auswahlliste ohne erweiterte Eigenschaften

if not LAttr.PickListHasObjects then

exit;

LItem := LAttr.PickItemEx('ZUGFeRD');

// LItem ist nil, wenn das Element keine erweiterten Eigenschaften hat

if LItem = nil then

exit;

// Hint abfragen

ShowMessage(LItem.Hint);

// Attribute ändern

LItem.Hint := 'Die neue Beschreibung'#13#10'mit zwei Zeilen';

LItem.ImageIndex := 10;

LItem.Status := 1;

// dauerhaft in Datenbank speichern

LAttr.PickListSave;

end;

Siehe auch

Pascal-Referenz

TFieldAttribute.PickListHasObjects


TOmFormProgress

Navigation: Entwicklerhilfe > Pascal-Referenz >

TOmFormProgress

Pascal-Objekt TOmFormProgress

Formular mit Fortschrittsbalken

Syntax

MyProgressForm := TOmFormProgress.Create(Application.MainForm);

Vorfahre

TForm

Eigenschaften

BtnCancel | TButton | Read | Schalter "Abbrechen"
Canceled | Boolean | Read | Wird bei Benutzerabbruch true
LabelBottom | TLabel | Read |
LabelTop | TLabel | Read |
Max | Integer | Read, Write | Maximale Position
Pos | Integer | Read, Write | Position des Fortschritts

Methoden

constructor Create(Owner: TComponent) | Objektinstanz erzeugen
procedure Step(StepBy: integer) | Position im Fortschrittsbalken um StepBy bewegen

Beschreibung

Blendet ein Fenster mit Beschriftungen und einem Fortschrittsbalken ein. Der Fortschritt wird auch im Office Manager-Taskbar-Icon gezeigt.

Beispiel

unit MyProgressTest;

interface

implementation

procedure Main;

var LProgress: TOmFormProgress;

i: integer;

begin

LProgress := TOmFormProgress.Create(Application.MainForm);

try

LProgress.LabelTop.Caption := 'OM-Pascal-Test';

LProgress.LabelTop.Visible := true;

LProgress.BtnCancel.Visible := true;

LProgress.Show;

LProgress.Max := 100;

LProgress.Pos := 0;

for i:=1 to 50 do begin

LProgress.Step(2);

sleep(40);

if LProgress.Canceled then

break;

end;

LProgress.Close;

finally

LProgress.Free;

end;

end;

end.

Siehe auch

Pascal-Referenz


TDebenuPDFLibrary

Navigation: Entwicklerhilfe > Pascal-Referenz >

TDebenuPDFLibrary

Pascal-Objekt TDebenuPDFLibrary

Dieses Objekt ist veraltet. Bitte verwenden Sie es nicht mehr in neuen Skripten.

Umfangreiche PDF-Funktionsbibliothek

Methoden

Siehe Dokumentation der Bibliothek

Beschreibung

TDebenuPDFLibrary ist ein umfangreiches SDK für Arbeit mit PDF-Dokumenten.

Beispiel 1

PDF-Tag "Creator" mit Direct Access-Funktionen zeigen:

unit QuickPdfExample;

interface

implementation

procedure Main;

var LPDF: TDebenuPDFLibrary;

LFileName: string;

LFile: integer;

begin

// Aktuell im Archiv markiertes PDF-Dokument...

LFileName := OfficeManager.Archive.ActiveDatasetDocument.FieldByName('FILENAME').AsString;

if not SameText(ExtractFileExt(LFileName), '.pdf') then

raise Exception.Create('Im Archiv ist kein PDF-Dokument markiert.');

// PDF-Objekt erzeugen (wird mit der Office Manager-Lizenz freigeschaltet)...

LPDF := TDebenuPDFLibrary.Create;

try

LFile := LPDF.DAOpenFileReadOnly(LFileName, '');

if LFile = 0 then

raise Exception.Create(Format('Datei "%s" konnte nicht geöffnet werden.', [LFileName]));

ShowMessage(LPDF.DAGetInformation(LFile, 'Creator'));

LPDF.DACloseFile(LFile);

finally

LPDF.Free;

end;

end;

end.

Beispiel 2

QRCode in ein PDF zeichnen:

unit QuickPdfExample;

interface

implementation

function GetDesktopPath: string;

begin

result := OfficeManager.ExecuteOmMacroLine('{OS:Desktop}');

end;

procedure Main;

var LPDF: TDebenuPDFLibrary;

s, LFileName: string;

begin

// Aktuell im Archiv markiertes PDF-Dokument...

s := OfficeManager.Archive.ActiveDatasetDocument.FieldByName('FILENAME').AsString;

if not SameText(ExtractFileExt(s), '.pdf') then

raise Exception.Create('Im Archiv ist kein PDF-Dokument markiert.');

// Datei auf den Desktop kopieren...

LFileName := GetDesktopPath + 'Mein Test-PDF.pdf';

if FileExists(LFileName) then

if MessageDlg(Format('Zieldatei "%s" ist bereits vorhanden. Überschreiben?', [LFileName]),

mtConfirmation, [mbYes,mbNo], 0) <> mrYes

then exit;

if not CopyFile(s, LFileName, false) then

raise Exception.Create(Format('Datei konnte nicht nach "%s" kopiert werden.', [LFileName]));

// PDF-Objekt erzeugen (wird mit der Office Manager-Lizenz freigeschaltet)...

LPDF := TDebenuPDFLibrary.Create;

try

if LPDF.LoadFromFile(LFileName, '') <> 1 then

raise Exception.Create(Format('Datei "%s" konnte nicht geöffnet werden.', [LFileName]));

if LPDF.SelectPage(1) <> 1 then

raise Exception.Create('Seite 1 konnte nicht gewählt werden');

if LPDF.DrawQRCode(2, 800, 150, 'Mein QRCode', 0, 0) <> 1 then

raise Exception.Create('QR Code konnte nicht gezeichnet werden');

if LPDF.SaveToFile(LFileName) <> 1 then

raise Exception.Create(Format('Datei "%s" konnte nicht gespeichert werden.', [LFileName]));

exit;

finally

LPDF.Free;

end;

end;

end.

Siehe auch

Pascal-Referenz

Debenu Supportseiten


Hilfsfunktionen

Navigation: Entwicklerhilfe > Pascal-Referenz >

Hilfsfunktionen

Zusätzliche Pascal-Funktionen

Zusätzlich zu den Standard-Pascal-Funktionen können folgende verwendet werden:

function CopyFileOrDir(Source, Dest: string): boolean | Datei oder Verzeichnis mit SHFileOperation kopieren
function FileIsLocked(FileName: string; NeedWriteAccess: boolean): boolean | true, wenn die Datei gesperrt oder schreibgeschützt ist.
function GetCleanFileName(FileName: string; OnlyName: boolean): string | Bereinigt den String, so dass er als Dateiname verwendet werden kann. OnlyName=true, wenn nur der Name ohne Pfad und Endung angegeben ist.
function GetFileHashSum(FileName: string): string | MD5 Checksumme der Datei
function GetJournalPrefix: string | '[28.02.2001 10:45 Benutzer an Computername]'
function GetUniqueFileName(FileName: string): string | Eindeutigen (nicht vorhandenen) Dateinamen ermitteln. Wenn FileName bereits vorhanden ist, wird eine Zahl angefügt.
function IsCurrArchive(ArchivName: string): boolean | Schnellprüfung, ob das gewünschte Archiv geöffnet ist. Dateiname ohne Pfad, mit oder ohne Endung.
function IsNewerFile(const NewerFileName, OlderFileName: string): boolean | true, wenn NewerFile neuer als OlderFile ist
function IsSameFile(const ReferenceFileName, OtherFileName: string): boolean | true, wenn beide Dateien inhaltsgleich sind
procedure LogDebugInfo(Info: string) | Gibt den Text "Info" in einem Debug-Fenster aus.
function MoveFileOrDir(Source, Dest: string): boolean | Datei oder Verzeichnis mit SHFileOperation verschieben
function TokenizeString(Str: string; Delimn: Char; IgnoreEmpty: boolean): TStrings | Zerlegt einen String und gibt die Teile in einer Stringliste zurück. Die Liste wird von der Funktion erzeugt.
function TaskMessageDlg(Title, Msg, MsgEx, MsgFooter: string; DlgType: TMsgDlgType; Buttons: TMsgDlgButtons; BtnCaptions: array of string; DefaultBtn: TMsgDlgBtn; HelpCtx: integer; ExpandBtnCaption: string; ShowAgainCB = false): integer | Taskdialog für Hinweise und Rückfragen
function TaskMessageDlg(Title, Msg, MsgEx, NameForShowAgain: string; DlgType: TMsgDlgType; Buttons: TMsgDlgButtons; reserviert für BtnCaptions: array of string; Default_WennNichtMehrGezeigt: Word; HelpCtx: integer; reserviert ExpandBtnCaption: string; ShowAgainCB = true): integer | Taskdialog mit Option "Erneut zeigen"
function UploadFile(Mode: integer; LocalFileName, RemoteFileName, Host: string; Port: integer; UserName, Password, PublicKeyFile, PrivateKeyFile: string): boolean | Datei mittels FTP oder SFTP hochladen (s. a.)
function ViewDataset(Dataset: TDataset; Caption: string; ReadOnly: boolean): boolean; | Eine Datentabelle zeigen, result ist bei Änderungen true.
function WinApiGetSpecialDir(CLSID: integer): string | Windows-Verzeichnisse ermitteln, z. B. $0026 für Program Files.

Siehe auch

Pascal-Referenz


COM-Referenz

Navigation: Entwicklerhilfe >

COM-Referenz

Office Manager COM-Server

Sie können den Office Manager mit geeigneten Programmier- und Skriptsprachen automatisieren. Erzeugen Sie bitte das Automatisierungs-Objekt "om.OfficeManagerApp".

Beispiel mit Visual Basic Script:

set omapp = CreateObject("om.OfficeManagerApp")

omapp.ExecuteOmMacroLine("{OmAPI:ListMainMenuEntries}")

Objektstruktur

Office Manager COM-Objektstruktur

Klicken Sie im Bild auf die Komponenten, zu der Sie weitere Hilfe wünschen.

Siehe auch

Aufruf aus Fremdprogrammen

Makro-Referenz


Server registrieren

Navigation: Entwicklerhilfe > COM-Referenz >

Server registrieren

Office Manager COM-Server registrieren

Wenn Sie Probleme beim Erzeugen des Automatisierungs-Objekts haben, registrieren Sie diesen bitte manuell. Wählen Sie dazu im Makroeditor den Menübefehl Datei | Server registrieren. Alternativ können Sie die Makrofunktion {ShellExecute} verwenden oder die Programmdatei in der Windows-Eingabeaufforderung mit Parameter "/regserver" starten:

"C:\Programme\Krekeler\Office Manager\om.exe" /regserver

Achten Sie bitte auf die Anführungszeichen. Diese sind erforderlich, sofern Leerzeichen im Pfadnamen vorkommen.


om.OfficeManagerApp

Navigation: Entwicklerhilfe > COM-Referenz >

om.OfficeManagerApp

COM-Objekt om.OfficeManagerApp

Automatisierungsobjekt der Office Manager-Anwendung.

Das COM-Objekt ermöglicht die Automatisierung des Office Managers mit geeigneten Programmier- und Skriptsprachen, wie beispielsweise C, Delphi, Visual Basic, Javascript und anderen.

Syntax

Visual Basic Script: set omapp = CreateObject("om.OfficeManagerApp")

Pascal, Delphi: omapp := CreateOleObject('om.OfficeManagerApp');

Eigenschaften

Archive

ApplDBConnected

ArchiveConnected

Methoden

ExecuteAction

ExecuteOmMacroLine

ExecuteSelectedDocuments

ImportFile

OpenDatabase

Siehe auch

COM-Referenz

Aufruf aus Fremdprogrammen


Archive

Navigation: Entwicklerhilfe > COM-Referenz > om.OfficeManagerApp >

Archive

COM-Eigenschaft Archive

Eigenschaft des Automatisierungsobjekts om.OfficeManagerApp.

Gibt das geöffnete Archiv als Automatisierungsobjekt om.ComArchive zurück.

Siehe auch

COM-Referenz


ApplDBConnected

Navigation: Entwicklerhilfe > COM-Referenz > om.OfficeManagerApp >

ApplDBConnected

COM-Eigenschaft ApplDBConnected

Eigenschaft des Automatisierungsobjekts om.OfficeManagerApp

Gibt TRUE zurück, wenn eine Anwendungsdatenbank geöffnet ist, andernfalls FALSE.

Syntax

Visual Basic Script: set mybool = omapp.ApplDBConnected

Pascal, Delphi: mybool := omapp.ApplDBConnected;

Siehe auch

COM-Referenz

om.OfficeManagerApp

OpenDatabase

ArchiveConnected


ArchiveConnected

Navigation: Entwicklerhilfe > COM-Referenz > om.OfficeManagerApp >

ArchiveConnected

COM-Eigenschaft ArchiveConnected

Eigenschaft des Automatisierungsobjekts om.OfficeManagerApp

Gibt TRUE zurück, wenn eine Archivdatenbank geöffnet ist, andernfalls FALSE.

Syntax

Visual Basic Script: set mybool = omapp.ArchiveConnected

Pascal, Delphi: mybool := omapp.ArchiveConnected;

Siehe auch

COM-Referenz

om.OfficeManagerApp

OpenDatabase

ApplDBConnected


ExecuteAction

Navigation: Entwicklerhilfe > COM-Referenz > om.OfficeManagerApp >

ExecuteAction

COM-Methode ExecuteAction

Methode des Automatisierungsobjekts om.OfficeManagerApp

Die Funktion führt einen Menübefehl des Office Managers aus und kehrt erst zurück, nachdem die Anweisung ausgeführt wurde.
Um eine Liste aller Menübefehle zu erhalten, klicken Sie bitte auf den Menübefehl Start | Verwenden | Makro | Makro-Editor. Wählen Sie die Sprache "OmAPI", geben Sie "{OmAPI:ListMainMenuEntries}" ein und klicken Sie auf Start | Makro | Ausführen.

Syntax

Visual Basic Script: omapp.ExecuteAction("Actionname")

Pascal, Delphi: omapp.ExecuteAction('Actionname');

Siehe auch

COM-Referenz

om.OfficeManagerApp

Makro-Funktion OmAPI


ExecuteOmMacroLine

Navigation: Entwicklerhilfe > COM-Referenz > om.OfficeManagerApp >

ExecuteOmMacroLine

COM-Methode ExecuteOmMacroLine

Methode des Automatisierungsobjekts om.OfficeManagerApp

Die Funktion führt einen Befehl der Office Manager-Makrosprache aus und kehrt erst zurück, nachdem das Makro abgearbeitet ist.

Dies ist die derzeit umfangreichste Automatisierungsfunktion.

Syntax

Visual Basic Script: set ResultString = omapp.ExecuteOmMacroLine("Macro")

Pascal, Delphi: ResultString := omapp.ExecuteOmMacroLine('Macro');

Siehe auch

COM-Referenz

om.OfficeManagerApp

Makro-Referenz


ExecuteSelectedDocuments

Navigation: Entwicklerhilfe > COM-Referenz > om.OfficeManagerApp >

ExecuteSelectedDocuments

COM-Methode ExecuteSelectedDocuments

Methode des Automatisierungsobjekts om.OfficeManagerApp

Alle in der Dokumenttabelle markierten Dokumente ausführen.

Syntax

Visual Basic Script: omapp.ExecuteSelectedDocuments("open")

Pascal, Delphi: omapp.ExecuteSelectedDocuments('open');

Command-Parameter

open: Öffnen

print: Drucken

preview: Vorschau

(benutzerdefinierter Befehl)

Siehe auch

COM-Referenz

om.OfficeManagerApp

ExecuteAction


ImportFile

Navigation: Entwicklerhilfe > COM-Referenz > om.OfficeManagerApp >

ImportFile

COM-Methode ImportFile

Methode des Automatisierungsobjekts om.OfficeManagerApp

Eine Datei in den Office Manager importieren.

Syntax

Visual Basic Script: omapp.ImportFile("FileName[,FieldName=Value,...]")

Pascal, Delphi: omapp.ExecuteSelectedDocuments('FileName[,FieldName=Value,...]');

Siehe auch

COM-Referenz

om.OfficeManagerApp

Definition von Importprofilen

Makro-Funktion ImportFile

Aufruf aus Fremdprogrammen


OpenDatabase

Navigation: Entwicklerhilfe > COM-Referenz > om.OfficeManagerApp >

OpenDatabase

COM-Methode OpenDatabase

Methode des Automatisierungsobjekts om.OfficeManagerApp

Öffnet ein Dokumentenarchiv oder eine Anwendungsdatenbank.

Syntax

Visual Basic Script: omapp.OpenDatabase("Filename")

Pascal, Delphi: omapp.OpenDatabase('Filename');

Siehe auch

COM-Referenz

om.OfficeManagerApp


om.ComArchive

Navigation: Entwicklerhilfe > COM-Referenz >

om.ComArchive

COM-Objekt om.ComArchive

Automatisierungsobjekt der Office Manager-Archivdatenbank.

Eigenschaften

DatasetDocument

FileName

Methoden

Close

ExecSQL

Open

SelectFocusedDocument

SelectNextDocument

SelectPriorDocument

SetDocumentSource

WriteJournal

Zugriff über

OfficeManagerApp

Siehe auch

COM-Referenz

Aufruf aus Fremdprogrammen


Close

Navigation: Entwicklerhilfe > COM-Referenz > om.ComArchive >

Close

COM-Methode Close

Methode des Automatisierungsobjekts om.ComArchive

Schließt die aktuelle Archivdatenbank.

Siehe auch

COM-Referenz

om.ComArchive

Open


DatasetDocument

Navigation: Entwicklerhilfe > COM-Referenz > om.ComArchive >

DatasetDocument

COM-Eigenschaft DatasetDocument

Eigenschaft des Automatisierungsobjekts om.ComArchive

Zugriff auf die Datenbanktabelle der Dokumente im Archiv.

Siehe auch

COM-Referenz

om.ComArchive

SetDocumentSource

Struktur der Archivdatenbank


ExecSQL

Navigation: Entwicklerhilfe > COM-Referenz > om.ComArchive >

ExecSQL

COM-Methode ExecSQL

Methode des Automatisierungsobjekts om.ComArchive.

Führt eine SQL-Anweisung in der Archivdatenbank aus. Einige Funktionen sind aber aus Sicherheitsgründen gesperrt.

Syntax

Visual Basic Script: omarchive.ExecSQL("UPDATE DOCUMENT SET DOCNO = UPPER(DOCNO)")

Pascal, Delphi: omarchive.ExecSQL('UPDATE DOCUMENT SET DOCNO = UPPER(DOCNO)');

Siehe auch

COM-Referenz

om.ComArchive


FileName

Navigation: Entwicklerhilfe > COM-Referenz > om.ComArchive >

FileName

COM-Eigenschaft FileName

Eigenschaft des Automatisierungsobjekts om.ComArchive

Gibt den Dateinamen des geöffneten Archivs zurück.

Siehe auch

COM-Referenz

om.ComArchive


Open

Navigation: Entwicklerhilfe > COM-Referenz > om.ComArchive >

Open

COM-Methode Open

Methode des Automatisierungsobjekts om.ComArchive

Öffnet das aktuelle Dokumentenarchiv nachdem es geschlossen wurde.

Siehe auch

COM-Referenz

om.OfficeManagerApp

OpenDatabase

Close


SelectFocusedDocument

Navigation: Entwicklerhilfe > COM-Referenz > om.ComArchive >

SelectFocusedDocument

COM-Methode SelectFocusedDocument

Methode des Automatisierungsobjekts om.ComArchive

Markiert das in der Datenquelle aktuelle Dokument in der Tabellen-Komponente des Programmfensters. Diese Methode wird nach Aufrufen von ComDataset.Next, Prior, First und Last verwendet, um die Tabellen-Komponente mit der Datenquelle zu synchronisieren.

Beispiel

ComDataset.Next

ComArchive.SelectFocusedDocument

entspricht einem Aufruf von:

ComArchive.SelectNextDocument

Siehe auch

COM-Referenz

SelectNextDocument

SelectPriorDocument

ComDataset.Next


SelectNextDocument

Navigation: Entwicklerhilfe > COM-Referenz > om.ComArchive >

SelectNextDocument

COM-Methode SelectNextDocument

Methode des Automatisierungsobjekts om.ComArchive

Markiert das nächste Dokument im Archiv.

Siehe auch

COM-Referenz

ComDataset.Next

ComDataset.Last

ComDataset.EoF


SelectPriorDocument

Navigation: Entwicklerhilfe > COM-Referenz > om.ComArchive >

SelectPriorDocument

COM-Methode SelectPriorDocument

Methode des Automatisierungsobjekts om.ComArchive

Markiert das vorherige Dokument im Archiv.

Siehe auch

COM-Referenz

ComDataset.Prior

ComDataset.First

ComDataset.BoF


SetDocumentSource

Navigation: Entwicklerhilfe > COM-Referenz > om.ComArchive >

SetDocumentSource

Verfügbar in diesen Editionen

COM-Methode SetDocumentSource

Methode des Automatisierungsobjekts om.ComArchive

Aktiviert die aktuellen oder archivierten Dokumente im Archiv.

Der Parameter "document" steht für die aktuellen Dokumente. Ein Aufruf entspricht dem Menübefehl Ansicht | Anzeigen | Aktive Dokumente. Der Parameter "docarch" aktiviert die archivierten Dokumente.

Syntax

Visual Basic Script: omarchive.SetDocumentSource("document")

Pascal, Delphi: omarchive.SetDocumetnSource('document');

Siehe auch

COM-Referenz

om.ComArchive

DatasetDocument


WriteJournal

Navigation: Entwicklerhilfe > COM-Referenz > om.ComArchive >

WriteJournal

COM-Methode WriteJournal

Methode des Automatisierungsobjekts om.ComArchive

Erstellt einen Eintrag im Protokoll.

Syntax

Visual Basic Script: omarchive.WriteJournal DocID, Type, Important, Text, Text2

Pascal, Delphi: omarchive.WriteJournal(DocID, Type, Important, Text, Text2);

Parameter

DocID (Integer): Schlüsselnummer des Dokuments, auf das sich der Protokolleintrag bezieht. Oder -1 für das aktuelle Dokument oder 0 für Protokolleinträge, die sich auf das Archiv selbst beziehen.

Type (Integer): Protokolltyp
1 = Info
2 = Warning
3 = Error
4 = Comment
5 = Todo, erledigte Tätigkeit
6 = Created, wenn Dokument oder DocVersion erstellt wird
7 = FileExecute, Datei geöffnet oder anderer Befehl
8 = FileSendTo, Datei wurde kopiert, Text ist Kommentar oder Zieldateiname
9 = ImportFrom
10 = FileModified
11 = DataModified
12 = FileBackup, Dateiname einer erzeugten Sicherungskopie
13 = RenamedFrom, alter Dateiname bei verschieben
14 = RenamedTo, neuer Dateiname bei verschieben
15 = LinkChangedFrom, alter Dateiname bei neu verlinken
16 = LinkChangedTo, neuer Dateiname bei neu verlinken
17 = DocErased, Dokument oder Version wurde gelöscht, auch EditFields-Feld löschen

Important (Boolean): Bei true wird der Eintrag immer erstellt. Bei false nur, wenn die Option "Dokument-Bearbeitung protokollieren" aktiviert ist.

Text: Der zu protokollierende Text.

Text2: veraltet, nicht mehr verwenden.

Siehe auch

COM-Referenz

om.ComArchive


om.ComDataset

Navigation: Entwicklerhilfe > COM-Referenz >

om.ComDataset

COM-Objekt om.Dataset

Automatisierungsobjekt der Office Manager-Datenbanktabellen.

Eigenschaften

Active

BoF

EoF

FieldCount

RecordCount

SQL

Methoden

Append

Cancel

Close

Edit

FieldName

First

GetFieldValue

Last

Next

Open

Post

Prior

SetFieldValue

Zugriff über

ComArchive

Siehe auch

COM-Referenz

Aufruf aus Fremdprogrammen


Active

Navigation: Entwicklerhilfe > COM-Referenz > om.ComDataset >

Active

COM-Eigenschaft Active

Eigenschaft des Automatisierungsobjekts om.ComDataset

Gibt true zurück, wenn die Tabelle geöffnet ist, andernfalls false.

Siehe auch

COM-Referenz

om.ComArchive


Append

Navigation: Entwicklerhilfe > COM-Referenz > om.ComDataset >

Append

COM-Methode Append

Methode des Automatisierungsobjekts om.ComDataset.

Erstellt einen neuen Datensatz und aktiviert den Bearbeitungsmodus der Tabelle.

Siehe auch

COM-Referenz

Cancel

Edit

Post


BoF

Navigation: Entwicklerhilfe > COM-Referenz > om.ComDataset >

BoF

COM-Eigenschaft BoF

Eigenschaft des Automatisierungsobjekts om.ComDataset

Ist true, wenn der erste Datensatz der Datenmenge aktiv ist, andernfalls false.

Syntax

Visual Basic Script: BeginOfFile = omdataset.BoF

Pascal, Delphi: BeginOfFile := omdataset.BoF;

Siehe auch

COM-Referenz

om.ComArchive

EoF

Next

Prior


Cancel

Navigation: Entwicklerhilfe > COM-Referenz > om.ComDataset >

Cancel

COM-Methode Cancel

Methode des Automatisierungsobjekts om.ComDataset.

Verwirft die Änderungen am Datensatz und beendet den Bearbeitungsmodus.

Siehe auch

COM-Referenz

Append

Edit

Post


Close

Navigation: Entwicklerhilfe > COM-Referenz > om.ComDataset >

Close

COM-Methode Close

Methode des Automatisierungsobjekts om.ComDataset.

Schließt die Datenbanktabelle.

Siehe auch

COM-Referenz

Active

Open


Edit

Navigation: Entwicklerhilfe > COM-Referenz > om.ComDataset >

Edit

COM-Methode Edit

Methode des Automatisierungsobjekts om.ComDataset

Setzt die Tabelle in den Bearbeitungsmodus.

Siehe auch

COM-Referenz

Append

Cancel

Post

ComArchive.ExecSQL


EoF

Navigation: Entwicklerhilfe > COM-Referenz > om.ComDataset >

EoF

COM-Eigenschaft EoF

Eigenschaft des Automatisierungsobjekts om.ComDataset

Ist true, wenn der letzte Datensatz der Datenmenge aktiv ist, andernfalls false.

Syntax

Visual Basic Script: EndOfFile = omdataset.EoF

Pascal, Delphi: EndOfFile := omdataset.EoF;

Siehe auch

COM-Referenz

om.ComArchive

BoF

Next

Prior


FieldCount

Navigation: Entwicklerhilfe > COM-Referenz > om.ComDataset >

FieldCount

COM-Eigenschaft FieldCount

Eigenschaft des Automatisierungsobjekts om.ComDataset

Gibt die Feldanzahl der Datenbanktabelle zurück.

Siehe auch

COM-Referenz

om.ComDataset

FieldName

RecordCount

Struktur der Archivdatenbank


FieldName

Navigation: Entwicklerhilfe > COM-Referenz > om.ComDataset >

FieldName

COM-Methode FieldName

Methode des Automatisierungsobjekts om.ComDataset

Gibt den Namen des Datenfeldes zurück.

Syntax

Visual Basic Script: TheFieldName = omdataset.FieldName(FieldIndex)

Pascal, Delphi: TheFieldName := omdataset.FieldName(FieldIndex);

Siehe auch

COM-Referenz

om.ComDataset

FieldCount

Struktur der Archivdatenbank


First

Navigation: Entwicklerhilfe > COM-Referenz > om.ComDataset >

First

COM-Methode First

Methode des Automatisierungsobjekts om.ComDataset

Positioniert den Cursor auf den ersten Datensatz.

Syntax

Visual Basic Script: omdataset.First

Pascal, Delphi: omdataset.First;

Siehe auch

COM-Referenz

om.ComArchive

EoF

Next

Last

ComArchive.SelectFocusedDocument


GetFieldValue

Navigation: Entwicklerhilfe > COM-Referenz > om.ComDataset >

GetFieldValue

COM-Methode GetFieldValue

Methode des Automatisierungsobjekts om.ComDataset

Datenfelder der Tabelle lesen.

Syntax

Visual Basic Script: TheName = omdataset.GetFieldValue("NAME")

Pascal, Delphi: TheName := omdataset.GetFieldValue('NAME');

Siehe auch

COM-Referenz

om.ComArchive

SetFieldValue


Last

Navigation: Entwicklerhilfe > COM-Referenz > om.ComDataset >

Last

COM-Methode Last

Methode des Automatisierungsobjekts om.ComDataset

Positioniert den Cursor auf den letzten Datensatz.

Syntax

Visual Basic Script: omdataset.Last

Pascal, Delphi: omdataset.Last;

Siehe auch

COM-Referenz

om.ComArchive

EoF

First

Next

ComArchive.SelectFocusedDocument


Next

Navigation: Entwicklerhilfe > COM-Referenz > om.ComDataset >

Next

COM-Methode Next

Methode des Automatisierungsobjekts om.ComDataset.

Positioniert den Cursor auf den nächsten Datensatz.

Siehe auch

COM-Referenz

EoF

Prior

ComArchive.SelectNextDocument

ComArchive.SelectFocusedDocument


Open

Navigation: Entwicklerhilfe > COM-Referenz > om.ComDataset >

Open

COM-Methode Open

Methode des Automatisierungsobjekts om.ComDataset.

Öffnet die Datenbanktabelle.

Siehe auch

COM-Referenz

Active

Close


Post

Navigation: Entwicklerhilfe > COM-Referenz > om.ComDataset >

Post

COM-Methode Post

Methode des Automatisierungsobjekts om.ComDataset.

Speichert die Änderungen am Datensatz und beendet den Bearbeitungsmodus.

Siehe auch

COM-Referenz

Append

Cancel

Edit


Prior

Navigation: Entwicklerhilfe > COM-Referenz > om.ComDataset >

Prior

COM-Methode Prior

Methode des Automatisierungsobjekts om.ComDataset.

Positioniert den Cursor auf den vorherigen Datensatz.

Siehe auch

COM-Referenz

BoF

Next

ComArchive.SelectPriorDocument

ComArchive.SelectFocusedDocument


RecordCount

Navigation: Entwicklerhilfe > COM-Referenz > om.ComDataset >

RecordCount

COM-Eigenschaft RecordCount

Eigenschaft des Automatisierungsobjekts om.ComDataset

Gibt die aktuelle Datensatzanzahl der Tabelle zurück.

Siehe auch

COM-Referenz

om.ComDataset

FieldCount

Makro-Variable {RecordCount}


SetFieldValue

FieldValue

Navigation: Entwicklerhilfe > COM-Referenz > om.ComDataset >

FieldValue

COM-Methode SetFieldValue

Methode des Automatisierungsobjekts om.ComDataset

Datenfelder der Tabelle schreiben. Die Datenquelle muss sich im Bearbeitungs- oder Einfügemodus befinden. Rufen Sie ggf. vorher Edit auf.

Syntax

Visual Basic Script: omdataset.SetFieldValue "NAME", "Mein Dokumentenname"

Pascal, Delphi: omdataset.SetFieldValue('NAME', 'Mein Dokumentenname');

Siehe auch

COM-Referenz

om.ComArchive

GetFieldValue

Edit


SQL

Navigation: Entwicklerhilfe > COM-Referenz > om.ComDataset >

SQL

COM-Eigenschaft SQL

Eigenschaft des Automatisierungsobjekts om.ComDataset

Die aktuelle SQL-Abfrage der Tabelle lesen oder schreiben.

Syntax

Visual Basic Script:

omdataset.Close

omdataset.SQL = "SELECT * FROM DOCUMENT WHERE DOCID=123"

omdataset.Open

Pascal, Delphi:

omdataset.Close;

omdataset.SQL := 'SELECT * FROM DOCUMENT WHERE DOCID=123';

omdataset.Open;

Siehe auch

COM-Referenz

om.ComArchive


_Schnipsel-Edition-0001

Verfügbar in diesen Editionen


_Schnipsel-Edition-0011

Verfügbar in diesen Editionen


_Schnipsel-Edition-0111

Verfügbar in diesen Editionen


_Schnipsel-Edition-1011

Verfügbar in diesen Editionen


_Schnipsel-Edition-1111

In allen Editionen verfügbar


_Schnipsel-Tipps-Benutzerliste

Hinweise zur Benutzer- und Gruppenliste

In umfangreichen Netzwerkumgebungen kann das Laden der Windows-Benutzer und -Gruppen lange dauern. Beachten Sie in so einem Fall bitte folgende Tipps:

·Das Laden der Liste kann mit Esc abgebrochen werden, die Liste ist dann unvollständig.

·Die Liste wird nur einmal abgefragt. Wenn Sie diese aktualisieren möchten, schließen Sie bitte das Fenster der Programmeinstellungen und öffnen Sie es erneut.

·Wenn Sie den vollqualifizierten Namen des gewünschten Benutzers bzw. der Gruppe bereits kennen, können Sie diesen auch ohne Liste in einem einfachen Eingabedialog eingeben. Halten Sie hierzu bitte die Umschalt-Taste gedrückt, wenn Sie auf den Mausschalter Neu oder Bearbeiten klicken.


Tipps zu AcroExch

Verfügbar in diesen Editionen

Tipps zu AcroExch-Funktionen

Sie benötigen den Office Manager Enterprise und die Adobe Acrobat-Vollversion.

Makro-Variablen und -Funktionen, die mit "AcroExch" beginnen, führen eine COM-Automatisierung der Adobe Acrobat Vollversion aus. Wenn mehrere Funktionen aufgerufen werden, muss jedes Mal eine Adobe-Programminstanz gestartet werden. Sie können dies verhindern, indem Sie die Adobe Acrobat-Vollversion starten bevor Sie die Office Manager-Funktionen ausführen.

Sollte der Office Manager bei der Ausführung dieser Funktionen nicht mehr reagieren, stellen Sie bitte sicher, dass der Acrobat-Reader nicht gleichzeitig gestartet ist. Es gibt Probleme bei der COM-Automatisierung, wenn die Acrobat-Vollversion und der Reader gleichzeitig ausgeführt werden.


Adobe Acrobat

Adobe Acrobat Vollversion

Die Adobe Acrobat-Vollversion ist eine kostenpflichtige Software. Sie wird als Standard- und Professional-Version angeboten.

Für wenige Office Manager-Funktionen, wie beispielsweise die API-Variablen {AcroExch..}, ist diese Software erforderlich. Zum Öffnen und Drucken von PDF-Dokumenten genügt der kostenlose Acrobat-Reader oder eine alternative Software und eine Vorschau ist ohne zusätzliche Programme möglich


Alle importieren

Navigation: »Kein übergeordnetes Kapitel«

Alle importieren

Das Dialogfenster öffnet sich, wenn Sie beim Import mehrerer Dateien im Eigenschaftenfenster auf Alle OK klicken.

Änderungen übernehmen

Wenn Sie beim vorherigen Dokument Änderungen an der Dokumentbeschreibung vorgenommen hatten, dann können diese auch für die noch folgenden Dokumente übernommen werden:

·Aktivieren Sie die Option Änderungen auch für die noch zu importierenden Dokumente übernehmen, falls diese nicht markiert ist.

Darunter befindet sich eine Tabelle mit den Feldnamen und Werten.

·Standardmäßig sind alle Werte, die Sie zuvor geändert haben, markiert und werden übernommen. Wenn Sie einzelne Werte nicht übernehmen möchten, dann entfernen Sie die Markierung: klicken Sie auf das Optionsfeld vor der Zeile, sodass diese nicht mehr mit dem Haken markiert ist.

·Zusätzlich sind einige Datenfelder aufgelistet, dessen Werte automatisch ermittelt wurden. Markieren Sie die Felder, um dessen Werte für die folgenden Dokumente zu übernehmen.

Kataloginfos für folgende Dokumente

In diesem Beispiel erhalten auch die folgenden Dokumente die Kategorie "Anwender-Support"

Bestätigen

Klicken Sie auf den Mausschalter Ja, um alle noch zu importierenden Dokumente jetzt zu übernehmen. Mit Nein kehren Sie zum Eigenschaftendialog zurück und können die folgenden Dokumente einzeln übernehmen.


ASCII-Codes

Navigation: »Kein übergeordnetes Kapitel«

ASCII-Codes

Beispiele ASCII-Codes

9 | Tabulator
13 | Enter (Eingabetaste)
27 | Esc
32 | Space (Leerzeichen)
44 | , (s. a. Sonderzeichen)
49 | 1
65 | A
80 | P
90 | Z
97 | a
122 | z
123 | { (s. a. Sonderzeichen)
125 | }

Virtuelle Steuercodes

33 | PgUp (Seite hoch)
34 | PgDn (Seite runter}
35 | End (Ende)
36 | Home (Anfang)
37 | Cursor links
38 | Cursor hoch
39 | Cursor rechts
40 | Cursor runter
45 | Ins (Einfügen)
46 | Del (Entfernen)
112 | F1
113 | F2
121 | F10 (z. B. Hauptmenü öffnen)


Dynamische AutoCAD-Schnittstelle

Dynamische AutoCAD-Anbindung

Navigation: »Kein übergeordnetes Kapitel«

Dynamische AutoCAD-Anbindung

Verfügbar in diesen Editionen

Die dynamische CAD-Schnittstelle stellt die Aktualisierung der Schriftkopfdaten sicher, verzögert aber das System. Änderungen im Archiv werden automatisch in die Zeichnung übertragen und Änderungen an der Zeichnung werden in das Archiv und den Volltextindex übernommen.

Zu beachten

Sie müssen Sie die Konfigurationsdatei acad.ini an Ihre Zeichnungen anpassen.

Für jede Aktualisierung wird AutoCAD gestartet. Dies verzögert die Arbeit mit dem System. Alternativ können Sie die Aktualisierungen auch manuell mit den Menübefehlen CAD | AutoCAD | Attribute in Zeichnung speichern und Attribute aus Zeichnung lesen ausführen, ohne die dynamische Anbindung zu aktivieren.

Aktivieren

1.Wählen Sie im Hauptmenü bitte den Befehl Datei | Optionen | Dokumenttyp.

2.Im Dialogfenster "Registrierte Dokumenttypen" klicken Sie auf Neu | AutoCAD einrichten.

3.Markieren Sie die Option Dynamische AutoCAD-Anbindung einrichten und folgen Sie dem Assistenten mit Klick auf Weiter.

Deaktivieren

1.Wählen Sie im Hauptmenü den Befehl Datei | Optionen | Dokumenttyp und markieren Sie "AutoCAD Zeichnung".

2.Wechseln Sie zur Registerseite Befehle.

3.Markieren Sie den Befehl "AcadSetAttributes" und klicken Sie auf den Mausschalter Erweitert.

4.Bei Automatisch ausführen ist "AfterEditDBFields" gewählt. Entfernen Sie dieses, wählen Sie dazu den leeren Eintrag aus der Liste. Klicken Sie auf Schließen.

5.Markieren Sie den Befehl "AcadGetAttributes" und klicken Sie auf den Mausschalter Erweitert.

6.Bei Automatisch ausführen ist "OnFtiReadFile" gewählt. Entfernen Sie dieses, wählen Sie dazu den leeren Eintrag aus der Liste.

7.Schließen Sie beide Dialogfenster und bestätigen Sie die Rückfrage zum Speichern der Änderungen.

8.Zum Deaktivieren der automatischen Volltextindexierung wählen Sie im Hauptmenü den Befehl Datei | Optionen | Einstellungen.

9.Wechseln Sie zur Registerseite Volltextindex.

10.Hinter Liste der zu indexierenden Dateitypen auf Öffnen klicken und ".dwg" aus der Liste entfernen.


Filter für automatisierten Dateiimport

Navigation: »Kein übergeordnetes Kapitel«

Filter für automatisierten Dateiimport

Filter für automatisierten Datei-Import
(Menü Datei | Optionen | Einstellungen, Seite Importieren | Filter)

Geben Sie bitte die Syntax der Dateien ein, die beim automatisierten Import (Profil mit Modus "automatisch", Verzeichnisüberwachung, Massenimport) ignoriert werden sollen.

Zwischen Groß- und Kleinschreibung wird nicht unterschieden. Verwenden Sie den Stern "*" als Joker für mehrere Zeichen und "?" für ein einzelnes Zeichen. Geben Sie bitte jede Syntax in einer eigenen Zeile ein.

Beispiele:

"~*" alle Dateien ignorieren, die mit "~" beginnen

"*_vers*" vom Office Manager erzeugte Dokumentversionen (s. a. erweiterte Einstellung)

"*_copy*" vom Office Manager erzeugte Sicherungskopien

"backup*" alle Dateien, die mit "backup" beginnen

"Thumbs.db" genau diese Systemdatei

Siehe auch

Filter in den Importprofilen


Barcode

Navigation: »Kein übergeordnetes Kapitel«

Barcode

Verfügbar in diesen Editionen

Barcode-Scanner

Office Manager Enterprise kann Barcodes lesen, um Dokumenteigenschaften zu erfassen und Prozesse zu steuern.

Verwendungsmöglichkeiten

· Stapeltrennung in Scanprofilen

·Stapeltrennung in Importprofilen

·Makro SplitDocument zum Trennen von PDF-Dokumenten.

·Makro ImgReadBarcode in der Belegerkennung oder zur Weiterverarbeitung in Skripten.

Unterstützte Barcodes

1D-Barcodes

Bezeichnung | Kurzbezeichnung | Bemerkung
Code 39 | Code39 |
Code128 | Code128 |
Interleaved 2 of 5 | Code25Int | auch Deutsche Post Indentcode
EAN-8 | EAN8 |
EAN-13 | EAN13 |
ISBN-10 | ISBN10 | Unterart von EAN
ISBN-13 | ISBN13 | Sonderform von EAN-13
UPC-A | UPCA |
UPC-E | UPCE |

2D-Codes

Bezeichnung | Kurzbezeichnung | Bemerkung
QR-Code | QRCode |
PDF417 | PDF417 | "Unknown" im Makro nicht möglich


Beispiel: Befehlszeilensteuerung

Navigation: »Kein übergeordnetes Kapitel«

Beispiel: Befehlszeilensteuerung

Beispiel: Befehlszeilensteuerung der Anwendung

Sie möchten die Dokumentdateien bei Bedarf im Windows-Editor öffnen.

1.Wählen Sie bitte im Menü Datei | Optionen den Eintrag Dokumenttyp, markieren Sie den entsprechenden Dokumenttypund wechseln Sie auf die Registerseite "Befehle".

2.Klicken Sie auf die Schaltfläche Neuer Befehl und geben Sie folgende Daten ein:
Befehlsname: editor,
Beschreibung: Im Editor öffnen,
markieren Sie Benutzerdefinierte Steuerung der Anwendung,
Programmdatei des Editors, z. B. "C:\Windows\Notepad.exe".

3.Klicken Sie bitte auf den Schalter Erweitert.

4.Markieren Sie im Fenster "Befehlseigenschaften" die Optionen Befehlszeilen-Steuerung und Datei als Startparameter.

5.Klicken Sie auf Schließen und speichern Sie den neuen Befehl, schließen Sie das Fenster "Registrierte Dokumenttypen".

Sobald Sie jetzt in der Dokumenttabelle einen Eintrag des entsprechenden Dokumenttyps markieren, können Sie im Menü Verwenden | Befehle die neue Funktion Im Editor öffnen wählen, um die Dokumentdatei in Notepad.exe zu öffnen.


Beispiel ADO-Datenbank

Navigation: »Kein übergeordnetes Kapitel«

Beispiel ADO-Datenbank

Verfügbar in diesen Editionen

Beispiel für die Ado-Makrofunktionen:

# Verbindung zur (leeren) Access-Datenbank "G:\Daten\MeineDB.accdb" aufbauen

{AdoSetConnection:Provider=Microsoft.ACE.OLEDB.12.0;Data Source=G:\Daten\MeineDB.accdb}

# Tabelle "meinedaten" hinzufügen

{AdoOperation:Execute,CREATE TABLE meinedaten (id AUTOINCREMENT, Bezeichnung VARCHAR(30), Nummer INTEGER)}

# 3 Datensätze hinzufügen

{AdoOperation:Open,SELECT * FROM meinedaten}

{AdoOperation:Append}

{AdoSetField:Bezeichnung=Meine Bezeichnung,Nummer=25}

{AdoOperation:Post}

{AdoOperation:Append}

{AdoSetField:Bezeichnung=Ein Datensatz mit Nummer 70,Nummer=70}

{AdoOperation:Post}

{AdoOperation:Append}

{AdoSetField:Bezeichnung=Meine andere Bezeichnung,Nummer=100}

{AdoOperation:Post}

# Datensätze mit einer Nummer größer 50 abfragen (2 Stück)

{AdoOperation:Close}

{AdoOperation:Open,SELECT * FROM meinedaten WHERE Nummer > 50}

# Datenabfrage zeigen und Anwender einen Datensatz wählen lassen

# und die Auswahl im Message Dialog zeigen

{MessageDlg:{AdoViewTable:Zeigt meinedaten,1,res,res,-,Nummer,Bezeichnung}}

# Verbindung zur Datenbank beenden

{AdoDestroy}


Bildschirmlupe

Navigation: »Kein übergeordnetes Kapitel«

Bildschirmlupe

Die Dokumentenvorschau ist häufig zu klein, um Details zu erkennen. Neben den verschiedenen Zoomfunktionen können Sie auch schnell auf die Bildschirmlupe zurückgreifen:

Details im Dokument vergrößern

Halten Sie die Strg-Taste gedrückt und bewegen Sie den Mauszeiger über das Vorschaufenster. Der Bereich um den Cursor wird doppelt so groß dargestellt. Für eine dreifache Vergrößerung halten Sie bitte die Tasten Strg und Umsch. gleichzeitig gedrückt.

Die Lupe können Sie in folgenden Fensters nutzen:

1.Dokumenten- Kontakt- und Kalender-Vorschau im Hauptfenster und dem Eigenschaftendialog. Die Lupe ist für die meisten Dokumentenviewer verfügbar, außer für die Windows-Miniaturansichten, Webseiten und den CAD-Viewer.

2.In der Bildvorschau des Scandialogs und der Seitendarstellung (Doppelklick auf gescanntes Bild).

3.In der Seitenvorschau der manuellen Stapeltrennung.


Blockchain-Einstellungen

Navigation: »Kein übergeordnetes Kapitel«

Blockchain-Einstellungen

Einstellungen für Blockchain-Revisionen

Programmeinstellungen für die erweiterte Revisionssicherheit konfigurieren:

1.Klicken Sie im Office Manager-Hauptmenü bitte auf Datei | Optionen | Einstellungen und wechseln Sie zur Seite Dokument | Blockchain.

2.Wählen Sie "Documentchain" für das produktive Netzwerk oder das Testnet für kostenlose Tests.

3.Mit der Option Web-Wallet verwenden können Sie Funktionen nutzen, ohne zusätzliche Software installieren zu müssen.

4.Geben Sie Ihren Namen oder die Firmenbezeichnung ein. Der Hash dieser Bezeichnung wird dann zusammen mit den Dokumentinformationen auf der Blockchain hinterlegt. Hinweis: Es werden immer nur Hashwerte (Checksummen) gespeichert und nicht die Daten selbst.

Um unbeabsichtigte Änderungen an den Dateien zu vermeiden, sollte das Schreibschutz-Attribut aktiviert sein.

Automatisch speichern

Die Hinterlegung der Daten erfolgt normalerweise manuell über den Menübefehl Bearbeiten | Blockchain. Sie können hier aber auch die Option Neue Dokumente automatisch hinterlegen aktivieren.

Es stehen auch erweiterte Optionen zu Verfügung, um beispielsweise Archive aus dem Automatismus auszuschließen und die Funktion auf einem bestimmten Computer auszuführen.


Blockchain Fehlerbehebung

Navigation: »Kein übergeordnetes Kapitel«

Blockchain Fehlerbehebung

FAQ - Fehlermeldungen von DMS Core

Wenn Sie die lokale Wallet-Software "DMS Core" und nicht den Webserver verwenden.

Internal Server Error

HTTP/1.0 500 Internal Server Error

Bedeutung: DMS Core hat eine Anweisung erhalten, bei der Ausführung ist aber ein Fehler aufgetreten.

Häufigste Ursache: Das Wallet ist verschlüsselt und somit für die gebührenpflichtige Anweisung nicht freigegeben.

Lösung: Wechseln Sie zur Wallet-Software und entschlüsseln Sie diese im Menü Einstellungen. Bei unerwarteten Problemen kann ein Wallet- oder Rechnerneustart helfen.

Weitere mögliche Ursache bei der Datenabfrage (Revision):

Die Transaktion wurde in der Blockchain nicht gefunden

Bedeutung: Dokumentinformationen werden in Transaktionen gespeichert und die ID im Archiv hinterlegt. Bei einer späteren Prüfung sucht die Software nach dieser Transaktion und vergleicht die hinterlegten Informationen mit den aktuellen Werten. Die Transaktion mit der gespeicherten ID wurde in der Blockchain aber nicht gefunden.

Häufigste Ursache: Die Transaktion ist neu und noch nicht bestätigt.

Lösung: Warten Sie bitte einige Minuten, bis diese vom Netzwerk bestätigt (geschürft) ist.

Weitere Überlegungen: Wenn Sie die Wallet-Software gerade erst gestartet haben, dann warten Sie bitte, bis diese mit dem Netzwerk synchronisiert ist.

Socket-Fehler
Die Serververbindung konnte nicht hergestellt werden

Bedeutung: Office Manager konnte sich nicht mit dem Wallet verbinden.

Häufigste Ursache: Das Wallet ist nicht (im richtigen Modus) gestartet, der Port stimmt nicht oder die Firewall verhindert eine Verbindung.

Lösung: Stellen Sie sicher, dass DMS Core ausgeführt wird und die richtige Blockchain (Standard oder Testumgebung) gewählt ist. Prüfen Sie die dms.conf: haben Sie ev. falsche Werte manuell eingetragen?

Kein passendes Guthaben

Bedeutung: Für die Speicherung der Dokumentinformationen muss eine Transaktionsgebühr in DMS-Coin bezahlt werden.

Ursache: Es ist kein passender Input im genannten Guthabenbereich verfügbar.

Lösung: Wechseln Sie im Wallet bitte zur Registerseite Überweisen und klicken Sie auf den Mausschalter Inputs. Falls dieser nicht vorhanden ist, bitte im Menü Einstellungen | Konfiguration auf Seite Wallet die Option Coin Control aktivieren. Wenn kein Input mit dem Mindestguthaben vorhanden ist, müssen Sie Coins erzeugen oder beziehen. Wenn höhere Guthaben vorhanden sind, können Sie den entsprechenden Betrag an sich selbst (an eine eigene Empfangsadresse) überweisen. Höhere Inputs werden derzeit aus Sicherheitsgründen nicht verwendet.

Keine Daten von Wallet-Software erhalten

Häufigste Ursache: Vermutlich durch einen beendeten Systemdienst verursacht.

Lösung: Starten Sie bitte den Computer neu.


CommandTimeout

Mit CommandTimeout können Sie die Zeitspanne in Sekunden angeben, nach der eine Befehlsausführung in einer Datenbank als nicht erfolgreich angesehen wird. Der Standardwert ist -1 für automatisch bzw. für keine Wartezeit. Wenn der Befehl vor Ablauf dieser Periode ausgeführt werden kann, wird der Wert ignoriert. Andernfalls wird die Ausführung abgebrochen.

Diese Option ist für Firebird SQL-Server nicht geeignet, Fehler "Feature not supported" möglich.

Allgemein

Mit folgendem Eintrag in der admin.ini legen Sie den gewünschten Wert in Sekunden fest:

[Database]

CommandTimeout=120

Datenbankspezifisch

Bei Datenbanken auf SQL-Servern kann die Wartezeit auch in der Datenbankverbindungsdatei (*.omcs) speziell für die Datenbank angegeben werden:

[ConnectionOptions]

CommandTimeout=120


.topic 200
Die Dokumentennummer sollte den firmenspezifischen Vorgaben für Zeichnungs- oder Dokumentwnnummerierung entsprechen. Die Nummer kann aber auch leer bleiben.
.topic 201
Der Dokumentenname wird beim Anlegen eines Dokumentes vom Anwender vergeben. Der Name kann frei gewählt werden und sollte das Dokument sinnvoll beschreiben.
Der Dokumentenname kann, muss aber nicht dem Dateinamen entsprechen.
.topic 202
Zuordnung des Dokuments zu einem Projekt.
Projekte werden im Menü Datei | Optionen | Auswahllisten definiert.
.topic 203
Zuordnung des Dokumentes zu einer Kategorie.
Kategorien und andere Listen werden im Menü Datei | Optionen | Auswahllisten definiert.
.topic 204
Status eines Dokumentes, wie z. B.: Wichtig, Erledigt, Rücksprache, usw. zugeordnet werden.
Status-Eigenschaften werden im Menü Datei | Optionen | Auswahllisten definiert.
.topic 205
Der Dokumenttyp legt das Anwendungsprogramm fest, mit dem die Dokumente bearbeitet werden, wie z. B. MS Word Dokument, Excel Tabelle, CAD Zeichnung.
Im Menü Datei | Optionen | Dokumenttyp können Sie festlegen, welche Anwendungen aktiviert werden.
.topic 206
Das Feld Besitzer enthält den Namen des Anwenders, der das Dokument erstellt hat.
Der Benutzername wird aus der Windowsanmeldung übernommen
.topic 207
Der Schlüssel ist eine automatische EDV-Nummer, die für alle Dokumente erstellt wird.
Die Schlüsselnummer. ist innerhalb eines Archivs eindeutig, sie wird also immer nur einmal vergeben.
.topic 208
Datei auf dem Datenträger, in der das Dokument gespeichert ist. Der Dateiname enthält die komplette Pfadangabe. Der Dateiname wird automatisch aus dem zugeordneten Projekt und dem Dokumentennamen erzeugt.
Bei Webseiten enthält das Attribut die Internetadresse.
.topic 210
Endung der Dokument-Dateien, z. B. "TXT", "DOC", "XLS" usw.
.topic 212
Bevorzugte Dokumente können als Favoriten gekennzeichnet werden. Die Suche nach diesen Dokumente ist einfacher, da Sie die Suche auch auf die Favoriten begrenzen können.
.topic 213
Eine Datei, die als Vorlage für neue Dokumente verwendet wird.
.topic 216
Das Archiv (Dokumentdatenbank) beinhaltet alle Attribute, den Volltextindex und die Dateiverknüpfungen der verwalteten Dokumente.
.topic 217
Datenfeld für den Volltextindex. Es übernimmt das Dateidatum, wenn die Dokumentdatei indexiert wird
.topic 218
Letzte Ereignisse: Datenfeld für Hinweise und besondere Ereignisse.
Im Eigenschaftenfenster auf der Registerseite Protokoll können Sie einen beliebigen Text in diese Feld eingeben. Nach Klick auf OK wird Ihre Eingabe mit aktuellen Datum dem Protokoll hinzugefügt.
Beispiel: "Rechnung per Post verschickt".
.topic 219
Beliebige Notizen und Hinweise zum Dokument.
Tipp: Sie können hier auch Schlüsselwörter für die Volltextsuche eingeben.
.topic 220
Wenn Sie eine E-Mail oder andere Datei mit mindestens einer Anlage importieren, wird das Dokument in der Tabelle mit einer Büroklammer gekennzeichnet.
Hinweis: Das Datenfeld "mailattachico" (Type Grafik) muss vorhanden sein.
.topic 264
Die Anwendungsdatenbank beinhaltet alle Informationen zu den registrierten Dokumenttypen, die bekannten Benutzernamen und alle Aufgaben der Terminplanung.
.topic 4557
Optical Character Recognition-Software wandelt die vom Scanner eingelesen Bilder in Texte um. Der Office Manager kann die Dokumente anschließend indexieren, so dass eine Suche im Volltextindex möglich ist.
.topic 10001
Zur nächsten Seite des Assistenten.
.topic 10002
Zur vorherigen Seite des Assistenten.
.topic 10004
Klicken Sie auf Fertigstellen, um die Einrichtung des Office Managers abzuschließen.
.topic 100
Klicken Sie auf OK, um die Eingaben / Änderungen zu übernehmen und dieses Dialogfenster zu schließen.
.topic 1013
Dateinamen werden vom Office Manager automatisch vergeben. Klicken Sie bitte auf die Schaltfläche [Durchsuchen], um einen eigenen Dateiname zu vergeben.
Die Syntax der Dateinamen können Sie Ihren Anforderungen anpassen (Menü Datei | Optionen | Einstellungen).
.topic 1014
Protokoll des Dokuments oder Kontakts. Die automatische Protokollierung der Dokumentenverwendung kann im Menü Datei | Optionen | Einstellungen, Seite Datenbank ein- und ausgeschaltet werden.
Der Administrator kann einzelne Protokolldatensätze löschen, beispielsweise aus Datenschutzgründen.
.topic 1015
Spezielle Angaben für CAD-Zeichnungen. Der Office Manager kann den Schriftkopf einer neuen CAD-Zeichnung automatisch mit den hier eingegebenen Daten ausfüllen.
.topic 1016
Geben Sie die Adresse eines Dokumentes oder Computers im Internet ein, das bzw. der geöffnet werden soll. Internetadressen beginnen häufig mit "https://www".
Wenn Sie ein lokales Dokument (HTML-Datei) zuordnen möchten, beachten Sie bitte, dass die Datei vorhanden sein muss. Sie können keine neue Datei erzeugen.
.topic 1018
Geben Sie bitte aussagekräftige Bezeichnungen in den Dokumentattributen ein.
.topic 1019
Text, der im Protokoll des Dokuments hinterlegt wird.
Siehe auch: Bearbeiten | Dokument | Eigenschaften, Seite Protokoll.
.topic 101
Klicken Sie auf Abbrechen, um die Eingaben / Änderungen zu verwerfen und dieses Dialogfenster zu schließen.
.topic 1027
Detail-Dokumente: zeigt eine Liste mit abhängigen Dokumenten. Diese Sonderfunktion wird vom Inventor-Einrichtungsassistenten aktiviert. Sie können damit z. B. auf Baugruppen zugreifen.
.topic 102
Klicken Sie auf diese Schaltfläche um eine Hilfeübersicht für das aktive Programmfenster zu öffnen, oder wählen Sie die Direkthilfe [?] für spezielle Informationen zu einer Komponente.
.topic 1030
Elektronische Rechnungen beinhalten Datensätze für die einzelnen Rechnungspositionen. Diese können hier aus der E-Rechnung gelesen, dargestellt sowie um Kostenstelle und Notizen erweitert werden.
Ein Klick auf Importieren liest die Posten aus der E-Rechnung in die Tabelle ein. Mit Editieren können Notizen hinzugefügt und eine Kostenstelle hinterlegt werden.
.topic 1031
Importieren
Liest die Rechnungspositionen aus der Elektronischen Rechnung ein, sofern es sich bei diesem Dokument um eine E-Rechnung handelt.
.topic 1032
Editieren
Aktivieren Sie diese Schaltfläche, um die Rechnungspositionen direkt in der Tabelle zu bearbeiten. Nur Spalten mit einem Bearbeitungssymbol (Stift) können geändert werden, wie Notizen und die firmeninterne Kostenstelle.
.topic 103
Klicken Sie auf Schließen um dieses Dialogfenster zu schließen.
.topic 104
Klicken Sie auf Übernehmen um die Eingaben / Änderungen zu speichern, ohne dieses Dialogfenster zu schließen.
.topic 105
Öffnet einen Dialog um die Datenträger nach Dateien oder Verzeichnissen zu durchsuchen.
.topic 1051
Markieren Sie die Option Datei(en) löschen, um auch die Dokumentdateien vom Datenträger zu löschen. Wenn die Option nicht markiert ist, werden nur die Dokumentdatensätze aus dem Archiv entfernt.
Diese Option ist nur sichtbar, wenn Endgültig löschen markiert ist.
.topic 1052
Wenn die Option Endgültig bestätigen markiert ist, werden die Dokumente nicht in den Papierkorb verschoben. Sie können diese dann nicht wiederherstellen.
Hinweis: Diese Option kann vom Administrator gesperrt werden.
.topic 1053
Klicken Sie auf Nein, um das Dialogfenster zu schließen ohne die markierten Dokumente zu löschen.
.topic 1054
Klicken Sie auf Ja, um die Dokumente aus der Datenbank zu entfernen. Wenn die Option Datei(en) löschen markiert ist, wird auch die Dokumentdatei vom Datenträger entfernt.
.topic 106
Direkthilfe
Wählen Sie bitte im Menü Hilfe den Befehl Direkthilfe oder klicken Sie auf [?] rechts in der Titelleiste des Fenster. Klicken Sie anschließend auf die Komponente, zu der Sie weitere Informationen suchen.
Oder markieren Sie die Komponente (z. B. ein Eingabefeld) und drücken Sie die Taste F1.
.topic 107
Der Statusbalken zeigt den Fortschritt der aktuellen Bearbeitung.
.topic 109
Öffnet ein Menü mit weiteren Befehlen und Optionen.
.topic 1101
Tabelle der registrierten Dokumenttypen.
.topic 1105
Sicherheitsrichtlinie: legt die Berechtigungen der Benutzer und Benutzergruppen für neue Dokument fest. Neue Dokumente erhalten die hier eingestellte Richtlinie als Vorgabe. Wenn die Option Benutzer dürfen Richtlinien ändern markiert ist, können die berechtigten Benutzer die Richtlinie für jedes einzelne Dokument anpassen. Ist die Option nicht markiert ist, werden auch eventuelle Vorgabewerte der Importeinstellungen ignoriert.
.topic 1106
Klicken Sie bitte auf Eigenschaften, um die Sicherheitsrichtlinien zu bearbeiten.
.topic 1107
Bezeichnung des Dokumententypen, wie "Word-Dokument", "Excel-Tabelle", "AutoCAD-Zeichnung", "Brief", "Fax".
Zum Ändern der Bezeichnung wählen Sie bitte im Menü Start | Dokumenttyp den Befehl Umbenennen.
.topic 1108
Typ der Anwendung
Für "normale" Dokumenttypen (Dokumente, die mit anderen Anwendungen erstellt werden) wählen Sie die Option Standarddokument.
Für die spezielle Internet-Funktion markieren Sie die Option Internetadresse. Es werden dann keine Dokumentdateien sondern Internetadressen verwaltet.
Mit dem Typ E-Mail können E-Mails aus Outlook, Thunderbird und vielen anderen Mail-Programmen verwaltet werden.
Für die Office Manager Textverarbeitung markieren Sie die Option Dokument der Office Manager-Textverarbeitung. Es werden dann keine externen Dokumentdateien verwaltet, die Texte werden mit in der Dokumentendatenbank gespeichert.
.topic 1110
Benutzerdefinierte Steuerung der Anwendung
Wenn diese Option markiert ist, können Sie detailliert festlegen, wie der Befehl ausgeführt wird. Klicken Sie bitte auf Erweitert, um die Parameter zu definieren
Ist die Option nicht markiert, wird der Befehl direkt von Windows ausgeführt. Der Befehl "Öffnen" (open) entspricht dann beispielsweise einem Doppelklick auf die Dokumentdatei im Explorer.
.topic 11101
Aktiviert die Online-Hilfe für den Einrichtungs-Assistenten. Zu jedem Arbeitsschritt wird die jeweilige Hilfe automatisch geöffnet.
.topic 11102
Eingabe der Seriennummer für die Vollversion und Möglichkeit der Online-Registrierung.
Wenn diese Option nicht markiert ist, wird die entsprechende Seite im Assistenten übersprungen.
.topic 11103
Festlegen der Verzeichnisstruktur und automatische Erzeugung von Dateinamen.
Wenn diese Option nicht markiert ist, wird die entsprechende Seite im Assistenten übersprungen.
.topic 11104
Registrierung der Anwendungsprogramme, die mit dem Office Manager zusammenarbeiten sollen.
Wenn diese Option nicht markiert ist, wird die entsprechende Seite im Assistenten übersprungen.
.topic 11105
Einstellungen für die Netzwerkzugriffe und Systemoptimierung.
Wenn diese Option nicht markiert ist, wird die entsprechende Seite im Assistenten übersprungen.
.topic 11106
Administrator-Grundeinstellungen
Wenn diese Option nicht markiert ist, wird die entsprechende Seite im Assistenten übersprungen.
.topic 11107
Registrierung des Office Managers in der Windowsumgebung.
Wenn diese Option nicht markiert ist, wird die entsprechende Seite im Assistenten übersprungen.
.topic 1111
Fenstergröße der Anwendung
Wählen Sie Vollbild, wenn das Anwendungsprogramm immer maximiert geöffnet werden soll oder Normal, um die aktuelle Programmeinstellung zu verwenden. Symbol minimiert das Programm zum Symbol in der Taskleiste. Diese Option ist nur sinnvoll, wenn das Programm z. B. eine Konvertierung im Hintergrund durchführen soll.
.topic 1114
Programmdatei
Ausführbare Programmdatei (*.exe) der Anwendung mit kompletter Pfadangabe. Klicken Sie auf die Schaltfläche [...] hinter dem Eingabefeld und wählen Sie:
Durchsuchen: um die Anwendung im Dateidialog auszuwählen.
Standardanwendung: die zuständige Windows-Standardanwendung verwenden.
Tipp: Sie können auch mehrere Programmdateien angeben. Dies ist im Netzwerkbetrieb sinnvoll, wenn die Anwendung auf den verschiedenen Rechner in unterschiedlichen Verzeichnissen liegen. Geben Sie mehrere Programmdateien im SDF-Format (Komma getrennt) ein.
.topic 1115
Geben Sie eine sinnvolle Bezeichnung für die Vorlagendatei ein. Beispielsweise Brief, Angebot, Rechnung, Entwurfsplan, Prospekt, usw.
Anhand dieser Bezeichnung wird beim Erstellen neuer Dokumente die Vorlage ausgewählt.
.topic 1116
Geben Sie den Dateinamen der Vorlage ein. Klicken Sie auf die Schaltfläche [Durchsuchen], um den Dateidialog zu öffnen.
.topic 1118
Geben Sie eine Bezeichnung für die Dateiendung ein. Diese Bezeichnung wird z. B. in Dateidialogen verwendet.
Beispiel: Für Dateien mit der Endung "txt" wäre die Bezeichnung "Textdatei" sinnvoll.
.topic 1119
Endung der Dokumentdateien (File-Extension): z. B. "txt", "docx", "xlsx", "dwg" usw.
.topic 111
Datenbank-Navigation: Springt zum ersten Datensatz in der Tabelle.
.topic 11201
Geben Sie den Freischaltcode ein und klicken Sie auf Weiter. Der Office Manager arbeitet nun im neuen Betriebsmodus (registrierte Testversion oder Vollversion).
.topic 11202
Klicken Sie auf Registrieren, um die Testversion zu registrieren oder eine Vollversion zu bestellen.
.topic 1122
Aktivieren Sie diese Option, wenn das Verzeichnis des Anwendungsprogramms zum aktuellen Verzeichnis gemacht werden soll, sobald die Anwendung startet. Diese Option ist nur erforderlich, wenn es zuvor zu Problemen kam.
.topic 1124
Liste der Vorlagendateien.
Vorlagendateien werden als Grundlage für neue Dokumente verwendet. Für den Dokumenttyp "Word" können Sie beispielsweise eine Vorlage "Brief" erstellen, in der bereits Ihr Firmen-Schriftkopf und der Grundaufbau des Briefes enthalten ist. Wenn Sie ein neues Dokument für "Word" erstellen und die Vorlage auswählen, ist die Grundstruktur des neuen Briefes bereits fertig.
.topic 1125
Löscht den markierten Dokumenttyp.
Achtung: Wenn Sie einen Dokumententyp löschen, für den bereits Dokumente vorhanden sind, können Sie auf diese Dokumente nicht mehr zugreifen.
.topic 112
Datenbank-Navigation: Springt zum vorherigen Datensatz in der Tabelle.
.topic 1131
Klicken Sie auf Neuer Dokumenttyp, um manuell einen neuen Dokumenttypen einzurichten.
.topic 1132
Klicken Sie bitte auf Neu für Dateiendung, um den Dokumenttypen für bestimmte Dateien (*.txt u. a.) automatisiert einzurichten.
.topic 1133
Wählen Sie den Befehl Umbenennen, um die Bezeichnung des Dokumenttypen zu ändern.
.topic 113
Datenbank-Navigation: Springt zum nächsten Datensatz in der Tabelle.
.topic 1140
Standardvorlagendatei
Wenn beim Erstellen eines neuen Dokumentes keine Vorlagendatei gewählt ist, wird die Standardvorlage (soweit vorhanden) verwendet. Beachten Sie bitte auch, dass manche Windows-Programme immer eine Vorlagendatei benötigen, wenn ein neues Dokument erstellt werden soll. In diesem Fall müssen Sie eine Standardvorlage definieren, auch wenn diese nur ein leeres Dokument ist.
.topic 11401
Liste der Anwendungsprogramme aus der Windows-Registrierdatenbank. Markieren Sie die Anwendungen, mit denen der Office Manager zusammenarbeiten soll.
Wenn Sie die Einstellungen der Anwendungsprogramme ändern möchten, wählen Sie bitte im Menü Datei | Optionen den Eintrag Dokumenttyp.
.topic 11402
Markieren Sie diese Option, um sicherzustellen, dass ein Dokumenttyp für die Verwaltung von Internetadressen eingerichtet wird.
Die Option ist nur wählbar, wenn noch kein entsprechender Dokumenttyp registriert wurde.
.topic 11403
Markieren Sie diese Option, um sicherzustellen, dass ein Dokumenttyp für die Verwaltung von E-Mails eingerichtet wird.
Sie können dann Ihre Mails beispielsweise per Drag&Drop in den Office Manager importieren und komfortabel verwalten.
Die Option ist nur wählbar, wenn noch kein entsprechender Dokumenttyp registriert wurde.
.topic 11404
Markieren Sie diese Option, um einen Dokumententyp für Notizen zu erstellen.
Notizen werden mit der integrierten Textverarbeitung erstellt und ohne externe Datei in der Archivdatenbank gespeichert.
Die Option ist nur wählbar, wenn noch kein entsprechender Dokumententyp registriert wurde.
.topic 1141
Klicken Sie auf die Schaltfläche Neu, um eine neue Vorlagendatei zu definieren.
.topic 1142
Klicken Sie auf die Schaltfläche Bearbeiten, um die markierte Vorlagendatei zu ändern.
.topic 1143
Klicken Sie auf die Schaltfläche Löschen, um die markierte Vorlagendatei zu entfernen.
.topic 1144
Liste mit weiteren Dateitypen, die mit dieser Anwendung bearbeitet werden können.
.topic 1145
Klicken Sie auf die Schaltfläche Neu, um einen neuen Dateityp zu definieren, der mit dieser Anwendung bearbeitet werden kann.
.topic 11450
Klicken Sie auf die Schaltfläche Tabelle, um ein Menü mit weiteren Funktionen zu öffnen:
Eigenschaften: Informationen der Anwendung aus der Registrierdatenbank anzeigen
Datei-Eigenschaften der Programmdatei anzeigen
Symbole anzeigen: Icons der Anwendungen darstellen oder ausblenden
Nur Standardanwendungen: Alle Anwendungen oder nur die Standardanwendungen zeigen
Alles markieren: Alle Anwendungen markieren
Markierung aufnehmen: Keine Anwendung markieren
.topic 1146
Klicken Sie auf die Schaltfläche Bearbeiten, um den markierten Dateitypen zu ändern.
.topic 1147
Klicken Sie auf die Schaltfläche Löschen, um den markierten Dateitypen aus der Liste zu entfernen.
.topic 114
Datenbank-Navigation: Springt zum letzten Datensatz in der Tabelle.
.topic 1150
Befehlsliste
Markieren Sie bitte den Befehl für den Sie die Parameter einstellen möchten.
.topic 11504
Die Abbildung zeigt den PDF-Scanner "Ricoh ScanSnap".
.topic 11510
Richtet die Schnittstelle zum PDF-Scanner "ScanSnap" von Ricoh oder Fujitsu automatisch ein und legt einige Scanprofile an. Die Scanner-Software muss bereits auf diesem Computer installiert sein.
.topic 1152
Datei als Startparameter
Die Dokumentdatei wird beim Starten der Anwendung als Parameter übergeben.
.topic 1153
Startparameter
Sie können hier weitere Startparameter definieren (auch Makrovariablen), die beim Start an die Anwendung übergeben werden. Um beispielsweise die Dokumentdatei als Parameter zu übergeben, können Sie hier die Variable "{CurrDocFileName}" angeben oder Option Datei als Startparameter markieren.
.topic 1154
Befehlszeilen-Steuerung
Das Anwendungsprogramm wird mit den angegebenen Parametern gestartet. Markieren Sie Datei als Startparameter und/oder geben Sie weitere Startparameter an.
.topic 1155
Makro-Steuerung
Der Befehl wird mit einem Office Manager-Makro ausgeführt. Geben Sie bitte die Variablen und Funktionen ein.
.topic 1157
Makro
Liste der Befehle zur Steuerung des Anwendungsprogramms. Geben Sie hier den Quelltext des Skriptes ein.
.topic 115
Datenbank: Speichert die Änderungen am aktuellen Datensatz.
.topic 1160
Befehlsname
Systeminterner Name des Befehles, wie beispielsweise "open" oder "print".
.topic 11601
Klicken Sie auf Einzelarbeitsplatz, um die Datenbankoptionen für einen nicht vernetzten Arbeitsplatz voreinzustellen.
Dokument-Bearbeitung protokollieren wird deaktiviert
Anzeige der Dokumentanzahl wird aktiviert
Beim Start alle Datensätze abrufen wird aktiviert
Programmsymbole darstellen wird aktiviert
Diese Voreinstellungen beruhen auf allgemeinen Erfahrungswerten. Die einzelnen Optionen können Sie Ihren individuellen Vorstellungen anpassen.
.topic 11602
Klicken Sie auf Kleines Netzwerk, um die Datenbankoptionen für Netzwerke bis ca. 5 Arbeitsplätze voreinzustellen.
Dokument-Bearbeitung protokollieren wird deaktiviert
Anzeige der Dokumentanzahl wird aktiviert
Beim Start alle Datensätze abrufen wird deaktiviert
Programmsymbole darstellen wird aktiviert
Diese Voreinstellungen beruhen auf allgemeinen Erfahrungswerten. Die einzelnen Optionen können Sie Ihren individuellen Vorstellungen anpassen.
.topic 11603
Klicken Sie auf Großes Netzwerk, um die Datenbankoptionen für Netzwerke mit mehr als fünf Arbeitsplätzen und hohen Dokumentvorkommen voreinzustellen.
Dokument-Bearbeitung protokollieren wird deaktiviert
Anzeige der Dokumentanzahl wird deaktiviert
Beim Start alle Datensätze abrufen wird deaktiviert
Programmsymbole darstellen wird aktiviert
Diese Voreinstellungen beruhen auf allgemeinen Erfahrungswerten. Die einzelnen Optionen können Sie Ihren individuellen Vorstellungen anpassen.
.topic 1161
Sichtbare Beschreibung des Befehles. Die Bezeichnung der Standardbefehle (Neu, Öffnen, Drucken) kann nicht geändert werden. Bei zusätzlichen Befehlen geben Sie bitte eine sinnvolle Bezeichnung für die Auswahl des Befehls im Menü Verwenden | Befehle ein.
.topic 1162
Befehl verbergen
Markieren Sie diese Option, wenn der Befehl nicht im Menü Dokument sichtbar sein soll und somit nicht vom Anwender gewählt werden kann. Hiermit können Sie Befehle vorübergehend deaktivieren. Darüber hinaus werden einige Systembefehle, beispielsweise aus die CAD-Anbindung, vom Programm automatisch ausgeführt und sind daher für den Anwender verborgen.
.topic 1163
Wenn die Option Warten bis Anwendung beendet markiert ist, wartet der Office Manager, bis die aufgerufene Anwendung wieder beendet wurde. Diese Option ist nur in Ausnahmefällen sinnvoll, wenn beispielsweise eine Konvertierung im Hintergrund ausgeführt wird.
Der Office Manager reagiert nicht, solange die aufgerufene Anwendung läuft!
.topic 1164
Neuer Befehl
Erstellt einen neuen Befehl.
.topic 1165
Befehl kopieren
Erstellt einen neuen Befehl als Kopie des markierten Befehls.
.topic 1166
Befehl löschen
Löscht den markierten Befehl. Beachten Sie bitte, dass die Standardbefehle "new", "open" und "print" nicht gelöscht werden können.
.topic 116
Datenbank: Verwirft die Änderungen am aktuellen Datensatz.
.topic 117
Datenbank: Aktualisiert die gepufferten Daten und lädt sie erneut aus der Datenbank.
.topic 11801
Markieren Sie die Option Nur Benutzer mit Windowsanmeldung zulassen, um sicherzustellen, dass sich die Anwender ordnungsgemäß anmelden. Wenn die Option Alle Benutzer zulassen markiert ist, werden auch Anwender akzeptiert, die sich am Betriebssystem nicht angemeldet haben.
.topic 11910
Wenn die Option Dateitypen mit Office Manager verknüpfen markiert ist, werden alle Dateien mit der Endung .omp, .omsl,.omen und .omcs mit dem Office Manager verknüpft. Sie können dann Archiv-Datenbank mit einem Doppelklick im Explorer öffnen.
.topic 11911
Bei aktiviertem Autostart wird Office Manager nach dem Hochfahren von Windows automatisch ausgeführt
.topic 120
Exportieren
Exportiert die Datensätze der Tabelle in eine Datei.
.topic 12050
Dokumentenarchiv: erstellt ein neues Archiv. Die Einstellungen und Datenfelder des geöffneten Archivs werden übernommen.
Synchrones Dokumentarchiv: erstellt eine synchrone Datenbank mit den Dokumenten der aktuellen Suche. Mit diesem Typ können Sie z. B. ausgewählte Dokumente auf ein Notebook auslagern und später wieder mit dem Netzwerk synchronisieren.
Archiv zur Prüfungsvorlage für einen Steuer- oder Wirtschaftsprüfer nur mit den relevanten Daten des Prüfungszeitraumes erstellen. Diese Option ist nur in GoBD-Archiven möglich.
Anwendungsdatenbank: erstellt eine neue Anwendungsdatenbank.
Kontaktdatenbank: erstellt eine neue CRM-Datenbank.
.topic 12053
Server (Menü Datei | Neues Archiv)
Name oder IP des SQL-Datenbankservers. Wenn eine benannte Instanz verwendet wird, dann geben Sie diese bitte mit Backslash vom Servernamen getrennt an "Servername\Instanzname".
Bei MS SQL können Sie auch auf den Pfeil des Kombinationsfeldes klicken, um alle sichtbaren Serverinstanzen anzuzeigen. Beim ersten Öffnen sehen Sie die Information "<dicovering...>, es wird jetzt nach Servern gesucht. Die Liste wird nach einiger Zeit aktualisiert, sofern die Server abgefragt werden können.
.topic 12054
Datenbank (Menü Datei | Neues Archiv)
Name der Datenbank auf dem SQL-Server. Wenn die Datenbank noch nicht vorhanden ist, dann wird diese mit Abschluss des Assistenten erstellt. Alternativ können Sie auch zuvor eine leere Datenbank erstellen.
Bei Firebird müssen Sie den Datenbank-Dateinamen mit vollständigem Pfad aus Sicht des Servers angeben.
.topic 12055
Anmeldedaten für SQL-Server (Menü Datei | Neues Archiv)
Integrierte Sicherheit verwenden: Markieren Sie bevorzugt diese Option, um die Windows-Anmeldedaten des jeweiligen Benutzers auch für den SQL-Server zu verwenden.
Die folgenden Felder sind nur sichtbar, wenn keine integrierte Sicherheit verwendet wird:
Benutzer: Fester Benutzername mit dem sich alle Anwender anmelden.
Kennwort: Das Passwort zum Benutzer.
.topic 12056
Verbindung testen (Menü Datei | Neues Archiv)
Testet die Verbindung zum angegebenen Server. Führen Sie den Test aus, wenn der Server angegeben ist, die Datenbank aber noch nicht.
.topic 12057
Port (Menü Datei | Neues Archiv)
Vom SQL-Server verwendeter Port. Standardwert für MySQL und MariaDB ist 3306 oder oft auch 3307, für Firebird 3050.
.topic 121
Funktion suchen "Was möchten Sie tun?"
Ermöglicht den Zugriff auf Menübefehle durch die Eingabe von Schlagwörtern. Beachten Sie auch die Fußzeile des Hauptfenstern mit einer Kurzinformation zum jeweiligen Befehl, wenn Sie die Maus über diesen bewegen.
Hinweise
Das Eingabefeld befindet im Ribbon-Menüband neben den Karteireitern (Tabs). Um dieses ein- oder auszublenden, wählen Sie bitte den Menübefehl Datei | Optionen | Einstellungen und wechseln zur Registerseite Ansicht.
Die maximale Anzahl wird mit der Einstellung "Kombinationsfelder sichtbare Zeilen" festgelegt.
Einige Funktionen werden nur im Administratormodus eingeblendet.
.topic 12102
Login beim Öffnen der Datenbank
(Menü Datei | Datenbank | Anpassen | Eigenschaften)
Wenn diese Option aktiviert ist, muss sich der Anwender beim Öffnen der Datenbank mit Benutzernamen und Passwort anmelden. Voraussetzung hierfür ist eine SQL Server-Authentifizierung. Wenn Sie MS SQL mit der Windows-Authentifizierung nutzen, werden diese Login-Daten ignoriert.
Für Anwendungsdatenbanken ist die Option i. d. R. nicht sinnvoll. Sie ist nur in der Enterprise-Version enthalten und kann nicht für den Standard-Treiber gewählt werden.
.topic 1211
Grafik
Wählen Sie bitte eine Grafik aus, die in der Dokumententabelle vor den jeweiligen Dokumenten dargestellt werden soll.
Eigene Bilder
Wählen Sie in der Liste den Eintrag "Andere Grafik laden".
Sie können eigene Grafiken aber auch der Auswahlbox hinzufügen: Speichern Sie die Bilder bitte im Verzeichnis "(Gemeinsame Dateien)\DocImages\" als Bitmap (*.bmp) in der Größe 16x16 Pixel oder als skalierbare Vektorgrafik (*.svg) ab. Das Programm liest die Bilder nach einem Neustart ein
.topic 12151
Geben Sie bitte die Dateinamen für die neue Datenbank ein und klicken Sie anschließend auf Weiter.
Archivname (nur Dokumentenarchiv) wird im Titel des Hauptfensters gezeigt.
Dateiname: Pfad und Name der Datenbankdatei.
.topic 12152
Bezeichnung des Archivs
Geben Sie eine aussagekräftige Bezeichnung ein, wie z. B. "Zeichnungen", "Office-Dokumente" oder "Personaldaten".
.topic 12153
Dateiname der neuen Datenbank.
Klicken Sie auf die Schaltfläche [Durchsuchen], um den Dateidialog zu öffnen.
.topic 12156
Datenbank-Parameter bearbeiten (nur Enterprise-Edition)
Markieren Sie diese Option, wenn Sie die erweiterten Einstellungen des Datenbanktreibers manuell bearbeiten möchten.
.topic 12201
Datenbank-Parameter (nur Enterprise-Edition)
Sie können die Datenbankverbindungsparameter überprüfen und bei Bedarf ändern. Die Parameter sind vom gewählten Treiber abhängig, Informationen finden Sie ggf. in der Dokumentation Ihres SQL-Servers. Zu den Parametern gehören z. B. der Datenbank-Dateiname, die Größe des Struktur-Cache, der Sprachtreiber, der Benutzername und das Kennwort.
Gehen Sie bei Änderungen der Verbindungsparameter sorgfältig vor!
.topic 12202
Klicken Sie auf den Schalter Rückgängig, um die Änderungen an den Datenbankparametern zu widerrufen. Wenn Sie die Parameter auf die Vorgaben zurücksetzen möchten, können Sie auch auf den Schalter Zurück und anschließend wieder auf Weiter klicken.
.topic 12251
Datenbank erstellen (nur Enterprise-Edition)
Der Office Manager hat alle Informationen für die neue Datenbank erhalten. Sie müssen jetzt mit Hilfe Ihrer Datenbanksoftware eine leere Datenbank erstellen und die entsprechenden Benutzerkonten einrichten. Wenden Sie sich ggf. an Ihren Administrator..
Die Datenbanktabellen werden im nächsten Schritt vom Office Manager erstellt.
.topic 12301
Klicken Sie auf Fertigstellen, um die neue Datenbank zu erzeugen. Der Office Manager erstellt die erforderlichen Tabellen und Daten. Wenn die Option Datensätze kopieren markiert ist, werden alle Daten aus der momentan geöffneten Datenbank kopiert.
Hinweis zur Enterprise-Version: Wenn Sie die Einstellungen einer Server-Datenbank später ändern möchten, wählen Sie bitte im Menü Datei | Datenbank | Anpassen | Eigenschaften.
.topic 12302
Datensätze kopieren
Markieren Sie diese Option, wenn Sie die derzeit geöffnete Datenbank in die neu erstellte kopieren möchten.
Die neue Datenbank wird die derzeit geöffnete ersetzen
Alle Datenbanken sind mit einer eindeutigen Kennung (GUID) registriert. Diese ist insbesondere für die Zuordnungen der zentral verwalteten Tätigkeiten wichtig. Wenn diese Option markiert ist, übernimmt die neue Datenbank diese Kennung aus der alten. Die bereits vorhandenen Tätigkeiten der Aufgabenverwaltung beziehen sich dann auf die neue Archiv- oder Kontaktdatenbank.

Tipp: Wenn Sie die Daten auf ein neues Datenbankformat umstellen möchten, beispielsweise von SQLite oder Access auf einen professionellen SQL-Datenbankserver umsteigen, dann
markieren Sie bitte beide Optionen und erstellen Sie die neue Datenbank.
Passen Sie anschließend die Einstellungen an: Datei | Optionen | Einstellungen, Seite Datenbank.
Beenden Sie das Programm.
Verschieben Sie die alte Datenbank in ein Backupverzeichnis, damit die Anwender nicht mehr auf diese zugreifen.
Starten Sie Office Manager DMS neu und öffnen Sie die neue Datenbank.
.topic 12303
Markieren Sie diese Option, wenn Sie sich zum Erstellen der Datenbank-Tabellen mit dem Logindialog anmelden möchten (nur Enterprise-Edition). Dies ist nur erforderlich, wenn die derzeitigen Datenbank-Benutzerrechte keine Änderungen an der Datenbankstruktur erlauben und nur möglich, wenn SQL-Server-Authentifizierung aktiviert ist.
.topic 12304
Desktop-Verknüpfung
Legt eine Verknüpfung auf dem Desktop an, mit der das erstellte Prüfungsarchiv geöffnet werden kann.
Falls die Prüfung mit einem anderen Windows-Benutzer ausgeführt wird, kopieren Sie diese bitte noch auf den entsprechenden Desktop.
.topic 13101
Im Darstellungsmodus Automatisch wird das Vorschaubild in Originalgröße dargestellt, wenn es komplett in das Vorschaufenster passt. Ist das Bild zu groß, wird es auf Fenstergröße verkleinert. Dieser Modus ist gut geeignet, um durch mehrere Dokumente zu blättern.
.topic 131
Klicken Sie auf Starten, um die Funktion auszuführen.
.topic 132
Klicken Sie auf Stopp, um die Ausführung abzubrechen.
.topic 135
Blendet die Symbolleiste mit Mausschaltflächen ein oder verbirgt sie.
.topic 150
Klicken Sie auf Neu um einen neuen Eintrag in die Liste einzufügen.
.topic 151
Markieren Sie einen Eintrag in der Liste und klicken Sie dann auf Ändern, um den markierten Eintrag zu ändern.
.topic 152
Markieren Sie einen oder mehrere Einträge in der Liste und klicken Sie dann auf Löschen, um alle markierten Einträge aus der Liste zu entfernen.
.topic 15210
Zugriff von mobiler App zulassen
Markieren Sie diese Option und folgen Sie der Anleitung, um mit Ihrem Smartphone oder Tablet auf die Dokumentenarchive zugreifen zu können.
.topic 15211
Login-Daten
Vergeben Sie bitte einen Benutzernamen und ein Passwort für die Kommunikation. Die gleichen Daten müssen auch in der mobilen App auf Seite Einstellungen hinterlegt werden.
Verwenden Sie ein sicheres Passwort - beispielsweise eine Kombination aus Buchstaben, Zahlen und Sonderzeichen.
.topic 15212
Menü Datei | Mobile Server
Geben Sie bitte einen freien Port an: beispielsweise 211 oder 8080. Der gleiche Wert wird auch in der mobilen App auf Seite Einstellungen hinterlegt und Ihr Router muss diesen Port an den PC weiterleiten.
Mit Klick auf den Mausschalter Testen können Sie prüfen, ob der Port frei ist.
.topic 15213
Maximale Listeneinträge
Beim Öffnen der Rechercheseite in der mobilen App werden die Listeneinträge für Projekte und Kategorien übertragen. Bei tief strukturierten Projekten können sehr viele Einträge vorhanden sein. Dies würde die App verlangsamen und solch lange Listen sind auf dem kleinen Display wenig sinnvoll.
Mit dieser Einstellung wird die Anzahl der zu übertragenden Listeneinträge begrenzt. Geben Sie möglichst nicht mehr als 100 ein.
.topic 15214
Einstellungen speichern
Klicken Sie auf diesen Schalter, wenn Sie alle Einstellungen vorgenommen haben. Sie benötigen Windows-Administrationsrechte.
Wenn der Zugriff zugelassen wird, installiert und startet Office Manager das Dienstprogramm "DMSService". Dieses ist für die Kommunikation mit dem Mobilgerät zuständig. Der Windows-Firewall wird eine eingehende Regel für das Dienstprogramm hinzugefügt.
.topic 15216
Server verwalten
Wenn diese Schalfläche sichtbar ist, können Sie Ihren Computer nicht als mobilen Server einsetzen. In Ihrem Firmennetzwerk ist das optionale Serverprogramm lizenziert, welches die Daten zentral zur Verfügung stellt. Wenden Sie sich bitte an Ihren Administrator.
Ein Klick auf den Mausschalter öffnet, sofern zugelassen, die Benutzeroberfläche der Server-Software.
.topic 153
Dupliziert den markierten Listeneintrag. Es wird ein neuer Eintrag als Kopie des markierten erstellt.
.topic 154
Liste durchsuchen
Klicken Sie bitte auf  Suchen und geben Sie den gesuchten Begriff oder einen Teil davon ein. Nach Klick auf OK wird die Liste durchsucht und der erste passende Eintrag markiert.
Bei der Projektsuche wird auch die Projektbeschreibung berücksichtigt.
.topic 1557
Automatisch Suchen
Rastet den Schalter Suchen ein. Die Suche nach Dokumenten wird automatisch gestartet, sobald Sie Änderungen in den primären Suchfeldern eingeben.
.topic 1558
Kopierte Dokumente und Kontakte suchen (Start | Suchen | Zwischenablage)
Zeigt in der Tabelle nur die Dokumente bzw. Kontakte, welche zuvor mit dem Menübefehl Bearbeiten | Kopieren in die Zwischenablage kopiert wurden.
Tipp: Sie können beispielsweise auch eine Datei im Explorer kopieren und im Archiv suchen. Es werden dann alle identischen Dateien gefunden, auch wenn diese nicht im selben Verzeichnis abgelegt sind.
.topic 1560
Genaue Suche
Standardmäßig sucht Office Manager entsprechend dem Prinzip "beginnt mit". Wenn Sie beispielsweise ein Projekt im Navigator markieren, dann werden alle Dokumente gefunden, dessen Projekt mit dem markierten beginnt.
Wenn Genau Suche markiert ist, dann werden nur Dokumente gefunden, die in genau dem markierten Projekt abgelegt sind.
Die Option gilt für alle Attribute, das Jokerzeichen $ wird dem Suchtext am Ende hinzugefügt.
.topic 1561
Aktualisieren
Lädt die Auswahlliste neu. Sie können hiermit die Liste aktualisieren, wenn beispielsweise Änderungen auf einem anderen Netzwerkarbeitsplatz durchgeführt wurden.
.topic 1566
Autovervollständigung
Das Eingabefeld merkt sich die zuletzt eingegebenen Suchbegriffe und schlägt diese bei einer erneuten Eingabe vor.
Um diese Funktion zu (de-)aktivieren, klicken Sie bitte mit der sekundären Maustaste auf das Eingabefeld und wählen Sie im lokalen Menü den entsprechenden Befehl.
Hinweise
Die Suchbegriffe werden individuell für jeden Anwender und jedes Archiv gespeichert.
Die maximale Anzahl der Begriffe entspricht der Programmeinstellung Kombinationsfelder auf der Einstellungsseite Ansicht.
.topic 1571
Markierte (Start | Suchen | Markierte)
Die markierten Datensätze suchen. Markieren Sie die gewünschten Dokumente oder Aufgaben und klicken Sie anschließend auf diesen Schalter. Die Tabelle zeigt dann nur noch die zuvor markierten Datensätze.
.topic 16101
Die Tabelle enthält alle Menü-Befehle des Programm-Hauptfensters. Sie können zu jedem Menüeintrag individuelle Benutzerrechte definieren.
.topic 16102
Der Schalter Info zeigt weitere Informationen über den markierten Menüeintrag.
.topic 16103
Sichtbarkeit
Markieren Sie bitte einen Menüeintrag in der Tabelle und klicken Sie auf die Schaltfläche Sichtbarkeit, um die Benutzerrechte für den Menüeintrag festzulegen.
.topic 16104
Sichtbarkeit kopieren
Kopiert die Sichtbarkeit des markierten Menüeintrags in die Zwischenablage. Sie können anschließend einen anderen Menüeintrag markieren und die Sichtbarkeit mit der zuvor kopierten überschreiben.
.topic 16105
Einfügen/Ersetzen
Ersetzt die Sichtbarkeit des markierten Menüeintrags mit der zuvor kopierten Sichtbarkeit (s. Sichtbarkeit kopieren).
.topic 16111
Öffnet die Hilfe zum ausgewählten Befehl
.topic 16112
Sichtbar für jeden
Die Programmfunktion kann uneingeschränkt von allen Benutzern verwendet werden.
.topic 16113
Sichtbar nur in der Administrator-Ebene
Die Programmfunktion ist geschützt und für den normalen Anwender unsichtbar. Die Funktion kann nur vom Office Manager-Administrator verwendet werden. Zur Anmeldung als Administrator wählen Sie bitte im Menü Datei | Optionen den Befehl Administrator.
Diese Sichtbarkeit sollte für administrative Funktionen, wie beispielsweise Einstellungen, Felder definieren und Dokumenttyp gewählt werden.
.topic 16114
Sichtbar nur für Benutzer oder Gruppen
(nur Enterprise-Edition)
Die Programmfunktion ist nur für ausgewählte Benutzer und Gruppen sichtbar. Geben Sie in der Liste bitte alle Benutzer und Benutzergruppen an, die auf diese Funktion zugreifen dürfen. Verwenden Sie die Benutzer- und Gruppennamen des Windows NT-Betriebssystems.
Die Funktion ist immer auch in der Administrator-Ebene sichtbar.
.topic 16115
Liste der Benutzer und Gruppen, für die der ausgewählte Menüeintrag sichtbar ist.
Die Funktion ist immer auch in der Administrator-Ebene sichtbar.
.topic 16131
Die Berechtigung Attribute ändern bezieht sich auf alle Dokumente. Wenn Sie diese Sichtbarkeit einschränken, können unberechtigte Anwender die Attribute zu keinem Dokument ändern.
Siehe auch Sicherheitsgrundregel Dokumente ändern auf der Seite Sicherheit | Regeln.
.topic 16132
Die Berechtigung Dateien ändern bezieht sich auf alle Dokumente. Wenn Sie diese Sichtbarkeit einschränken, können unberechtigte Anwender die Dokumente nur schreibgeschützt öffnen.
Siehe auch Sicherheitsgrundregel Dokumente ändern auf der Seite Sicherheit | Regeln.
.topic 16201
Sicherheitsregel "Dokumente ändern"
Wenn die Option Benutzer darf alle Dokumente ändern markiert ist, kann jeder Benutzer alle Dokumentattribute und -dateien uneingeschränkt bearbeiten. (Datei-Zugriffsrechte des Betriebssystems bleiben aber erhalten.)
Ist die Option Benutzer darf nur die eigenen Dokumente ändern markiert, kann der Benutzer nur die Attribute seiner eigenen Dokumente bearbeiten. Dokumentdateien anderer Benutzer werden nur als schreibgeschützte Kopie geöffnet.
Hinweis: Der Administrator darf alle Dokumente ändern.
.topic 16202
Sicherheitsregel "Dokumente löschen"
Wenn die Option Benutzer darf alle Dokumente löschen markiert ist, kann jeder Benutzer alle Dokumentverknüpfungen aus dem Office Manager-Archiv löschen.
Ist die Option Benutzer darf nur die eigenen Dokumente löschen markiert, kann der Benutzer nur seine eigenen Dokumente aus dem Archiv löschen
Hinweis: Der Administrator darf alle Dokumente löschen.
.topic 16203
Sicherheitsregel "Papierkorb"
Ist die Option Benutzer darf auch endgültig löschen markiert, kann der Benutzer die Dokumente unwiderruflich aus dem Archiv entfernen und auch die Dokumentdatei löschen.
Wenn Benutzer darf nur in den Papierkorb verschieben markiert ist, können Dokumente nur vom Administrator endgültig gelöscht werden. Hiermit wird auch verhindert, dass Benutzer die Dokumentdatei löschen.
Hinweis: In Archiven mit GoBD-Modus kann grundsätzlich nur in den Papierkorb verschoben werden.
.topic 16301
Datei-Zugriffsrechte
Legt die Berechtigungen der Benutzer und Benutzergruppen für die verknüpfte Dokumentdatei fest.
Zugriffsrechte definieren: Menü Datei | Optionen | Einstellungen, Seite Sicherheit | Dokument
.topic 16311
Beschreibung
Geben Sie bitte eine passende Bezeichnung für die vordefinierten Zugriffsrechte ein. Beispielsweise
"Normal" mit Vollzugriff für jeden Benutzer
"Office" mit Vollzugriff für die Benutzergruppe Office und Nur-Lesen für alle anderen
.topic 16312
Liste der vordefinierten Dateizugriffsrechte.
.topic 16313
Zeigt Informationen über die Verwendung der Sicherheitsrichtlinie. Prüfen Sie dies bitte vor dem Löschen oder Umbenennen einer Richtlinie in jedem Archiv.
.topic 16320
Vollzugriff: Kombination aus allen Zugriffsrechten, der Anwender hat uneingeschränkte Rechte an der Dokumentdatei.
.topic 16321
Lesen und ausführen (nur lesen): das Dokument kann geöffnet, betrachtet, kopiert und gedruckt werden. Die Datei kann weder geändert noch vom Datenträger gelöscht werden.
.topic 16323
Schreiben: das Dokument kann bearbeitet und die Änderungen in der Datei gespeichert werden. Löschen ist nicht möglich.
Hinweis: Das Attribut Lesen und ausführen wird automatisch hinzugefügt, sobald Schreiben gesetzt wird.
.topic 16324
Löschen: die Dokumentdatei kann vom Datenträger entfernt werden.
.topic 16325
Attribute ändern: die Attribute (auch die Sicherheitsattribute) der Dokumentdatei können geändert werden.
Der Datei-Eigentümer sollte immer die Rechte zum Ändern der Sicherheitsattribute haben.
.topic 16326
Besitzrechte übernehmen: der Anwender kann die Besitzrechte an der Datei übernehmen, er kann also Eigentümer der Datei werden.
.topic 17001
Liste der Dokumentvorlagen in diesem Archiv.
.topic 17002
Die Dokumentvorlagen werden in der Archivdatenbank gespeichert, jedes Archiv hat somit unterschiedliche Vorlagen. Wenn Sie die Dokumentvorlagen aus einem anderen Archiv übernehmen möchten,
klicken Sie bitte auf Importieren und
wählen Sie das Archiv, aus dem die Vorlagen kopiert werden sollen.
Markieren Sie anschließend alle Einträge die Sie übernehmen möchten
und klicken Sie auf OK.
.topic 17011
Bezeichnung der Dokumentvorlage, wie sie im Menü Erstellen | Neu | Vorlagen | (Vorlage) gelistet wird.
Die Bezeichnung darf nicht mit Punkten enden.
.topic 17013
Wenn diese Option markiert ist, wird der Eigenschaftendialog für die Eingabe von Dokumentattribute geöffnet, bevor das neue Dokument erstellt wird. Ist sie nicht markiert, werden die Dokumente sofort erstellt.
In der Regel sollte diese Option markiert sein.
.topic 17014
Klicken Sie bitte auf die Schaltfläche [Ändern], um festzulegen, für welche Anwender diese Vorlage verwendet können.
.topic 17015
Auf der Seite Feldwerte werden die Attributvorlagen für neuen Dokumente eingegeben. Wenn Sie beispielsweise für Category den Feldwert "Angebot " eingeben, wird das neue Dokument der Kategorie "Angebot" zugeordnet. Im Eigenschaftendialog des neuen Dokuments können Sie die Attribute aber noch ändern.
In den Feldwerten können Sie auch die Makrovariablen verwenden.
.topic 17016
Makrobefehle, die vor Hinzufügen des Dokumentdatensatzes und vor Öffnen des Eigenschaftendialoges ausgeführt werden.
.topic 18105
Drucker
Wählen Sie bitte den Drucker, auf dem Sie das Dokument ausgeben möchten.
.topic 18107
Klicken Sie auf Drucker-Eigenschaften, um die Einstellungen des ausgewählten Druckers zu ändern.
.topic 1900
Liste der Kategorien. Wählen Sie eine Kategorie, um die entsprechenden Einstellungen anzuzeigen.
.topic 19001
Liste der Scanprofile.
.topic 19002
Bezeichnung des Profils, wie es im Scanner-Menü gelistet wird.
.topic 19003
Aktiviert, sofern vom Gerät unterstützt, das gleichzeitige Scannen der Vorder- und Rückseite des Dokuments.
.topic 19004
Automatische Bilddrehung
Wenn aktiviert, dann wird Dokument automatisch gedreht, sofern es seitlich oder verkehrt gescannt wurde. Da hierfür die Textausrichtung analysiert wird, kann es bei ungeeigneten Dokumenten zu einem fehlerhaften Verdrehen kommen. Insbesondere bei Grafiken, Handschriften und zu kleinen oder zu großen Zeichen.
.topic 19005
Wenn diese Option markiert ist, wird der Dokumenten-Eigenschaftendialog nach dem Scannen geöffnet. Sie können dann die Attribute, wie Name und Projekt eingeben.
.topic 19007
Legt den Dokumenttyp fest, in dem die gescannten Dokumente gespeichert werden. Üblich sind beispielsweise "Adobe Acrobat" und Grafik-Dokumenttypen für TIFF und JPeg. Mehrseitige Dokumente können nur im Adobe Acrobat PDF-Format oder als TIFF gespeichert werden.
.topic 19008
Kurztasten dienen dem schnellen Zugriff auf Befehle. Wählen Sie bitte eine Tastenkombination aus der Liste oder markieren Sie das Eingabefeld und drücken Sie die gewünschte Kurztaste (z. B. Strg festhalten und 1 drücken).
Achten Sie bitte darauf, dass Sie keine Standard-Tastenkombinationen, wie beispielsweise Strg-C verwenden. Ebenfalls nicht empfohlen werden Kombinationen aus Alt und einem Buchstaben, weil diese als Kurztasten für Menübefehle und andere Komponenten dienen.
.topic 19009
Der Kurzhinweis erscheint in der Statusleiste, wenn sich die Maus im Menü über dem Scanprofil befindet. Wenn Sie nichts eingeben, dann wird ein Standardhinweis aus den Einstellungen erzeugt.
.topic 19010
Das Symbol wird im Menü vor dem Profil gezeichnet. Verwenden Sie beispielsweise ein einzelnes Blatt für ein Profil, welches für jede Seite ein neues Dokument erzeugt.
.topic 19013
Makrobefehle, die vor dem Scannen des Dokuments und vor dem Hinzufügen des Dokumentdatensatzes ausgeführt werden.
.topic 19014
Öffnet den ScanSnap Manager bzw. ScanSnap Home - die Treibersoftware Ihres Ricoh/Fujitsu ScanSnap.
.topic 19020
Stapel mit mehreren Dokumenten.
Markieren Sie diese Option, wenn der eingelegte Papierstapel aus mehreren Dokumenten besteht.
.topic 19021
Die Dokumente im Stapel haben eine feste Seitenzahl. Der Office Manager erstellt ein neues Dokument, sobald die Seitenanzahl erreicht.
.topic 19022
Für einen Stapel mit unterschiedlicher Seitenzahl (nur Enterprise-Edition). Legen Sie bitte ein Trennblatt hinter die letzte Seite der jeweiligen Dokumente.
.topic 19023
Typ und Text des verwendeten Barcodes, wenn die Option Standard-Barcode nicht markiert ist.
Syntax: "Typ,Text[,Auflösung]". Vorschläge sind in der Auswahlliste enthalten.
.topic 19024
Scanvorgang fortsetzen (nur ScanSnap)
Verarbeitung großer Papierstapel, Sie können Papier nachlegen: Sobald der Einzelblatteinzug abgearbeitet ist, wartet die Software auf Ihre Bestätigung: Sie können dann weitere Seiten in den Einzug legen und mit Scan fortsetzen zum Stapel hinzufügen oder mit Scan beenden den Vorgang abschließen.
Wenn diese Option nicht markiert ist, wird der Scanvorgang abgeschlossen, sobald das letzte Blatt eingezogen ist.
.topic 19025
Markieren Sie diese Option, um den empfohlenen Barcode zu verwenden.
.topic 19026
Barcode-Trennblatt drucken.
.topic 19027
Vorschaubilder der Dokumentseiten
Markieren Sie die Checkbox oben links an einer Seite, wenn mit dieser ein neues Dokument beginnen soll..
Sie können die Vorschaugröße mit dem Regler einstellen.
Öffnen Sie das lokale Menü mit der sekundären Maustaste (Rechtsklick), um weitere Funktionen zu nutzen.
Per Drag&Drop können Sie die Seiten verschieben und zusätzliche Seite aus Bilddateien importieren.
.topic 19028
Zoom
Zum Vergrößern oder Verkleinern der Vorschaubilder können Sie
den Zoom-Regler verschieben,
die + und - Tasten am Zehner-Block mit gehaltener Strg-Taste verwenden oder
das lokale Menü (Rechtsklick) nutzen.
.topic 19029
Manuell trennen
Für einen Stapel mit unterschiedlicher Seitenzahl. Sie können nach dem Scan mit der Maus markieren, wo ein neues Dokument beginnt. Das Vorschaufenster bietet auch Funktionen für das Umsortieren und Löschen von Seiten sowie das Hinzufügen von Bilddateien.
Ab n Seiten
Gibt an, ab wie vielen Seiten das Vorschaufenster mit der Trennmöglichkeit eingeblendet wird. In der Regel ist dies ab 2 Seiten. Ein einseitiger "Stapel" muss nicht getrennt werden, außer Sie möchten Bilddateien per Drag&Drop als zusätzliche Seiten hinzufügen.
.topic 1905
Auswahlliste wählen
Wählen Sie die Auswahlliste, dessen Daten Sie bearbeiten möchten. Wenn Sie z. B. neue Gruppen hinzufügen möchten, dann markieren Sie bitte den Eintrag "Kategorie". In der rechten Liste werden nun alle vorhandenen Gruppen aufgelistet. Mit den Schaltern Neu, Ändern und Löschen können Sie die Liste bearbeiten.
.topic 1906
Liste der Projekte, Gruppen, usw.
Mit den Schaltern Neu, Ändern und Löschen können Sie die ausgewählte Liste bearbeiten.
Sie können auch Einträge aus einer Datei einfügen, um beispielsweise die Projekte einer anderen Datenbank einzulesen. Klicken Sie dazu bitte mit der rechten Maustaste auf die Liste und wählen Sie im lokalen Menü den Befehl Einfügen.
.topic 1909
Einstellungen finden
Geben Sie einen Suchbegriff ein und drücken Sie die Eingabetaste oder klicken Sie auf die Lupe.
Alle passenden Optionen werden in einer Liste gezeigt - klicken Sie doppelt auf den gewünschten Eintrag, um direkt zur entsprechenden Kategorie-Seite zu springen.
.topic 1910
Markieren Sie dieses Feld, um alle Bearbeitungen und Aufrufe der Dokumente zu protokollieren. Wenn die Option nicht aktiviert ist, werden nur wichtige Ereignisse protokolliert.
Siehe auch Menü Datei | Optionen | Einstellungen, Seite Datenbank
.topic 1911
Standard-Dokumentenarchiv
Geben Sie hier das Standard-Dokumentenarchiv an, das beim Start des Office Managers geladen werden soll, z. B. C:\Office Manager\Datenbank\Archiv.omp
Klicken Sie auf die Schaltfläche [Durchsuchen], um das Datei-Dialogfenster zu öffnen.
.topic 1912
Standard-Anwendungsdatenbank
Menü Datei | Optionen | Dokumenttyp
Eine Anwendungsdatenbank beinhaltet die Informationen zu den Windows-Programmen, bekannte Benutzernamen sowie die Daten der Aufgabenverwaltung.
Klicken Sie auf die Schaltfläche [Durchsuchen], um das Datei-Dialogfenster zu öffnen.
.topic 1913
Zählt die Anzahl der gefundenen Dokumente
(Menü Datei | Optionen | Einstellungen, Seite Optimieren).
Wenn Sie diese Option markieren, wird die Anzahl der gefundenen Dokumente angezeigt. Das Zählen der Dokumente benötigt zusätzliche Zeit bei der Suche. Verzichten Sie bei großen Datenbanken auf diese Option, um die Suchzeiten zu optimieren.
Wenn zusätzlich die Option Anzahl beider Tabellen markiert ist, wird die Anzahl der aktiven und archivierten Dokumente gezeigt.
.topic 1914
Standard-Kontaktdatenbank
Menü Datei | Optionen | Dokumenttyp
Die Datenbank beinhaltet Ihre Kontakte und Adressen.
Klicken Sie auf die Schaltfläche [Durchsuchen], um das Datei-Dialogfenster zu öffnen.
.topic 1915
Wenn diese Option markiert ist öffnet der Office Manager beim Start die Datenbanken, die der Benutzer zuletzt geöffnet hatte.
.topic 1924
Beim Start alle Datensätze abrufen
Wenn diese Option markiert ist, werden beim Programmstart bzw. nach dem Öffnen einer Datenbank alle Dokumente, Kontakte und Aufgaben aus der Datenbank abgerufen. Ist die Option nicht markiert, wird nur der jeweils zuletzt markierte Datensatz geladen.
Bei großen Datenbeständen -vor allem bei SQL-Servern- sollte die Option nicht markiert sein, weil dies unnötige Ressourcen verbraucht und den Programmstart verlangsamt.
Auf Terminalservern werden die Daten nicht automatisch abgefragt.
.topic 1931
Zeilenanzahl in Auswahllisten
Menü Datei | Optionen | Einstellungen
Anzahl sichtbarer Zeilen der Auswahllisten von Kombinationsfelder (Eingabefeld mit Liste). Der Standardwert ist 20.
Auch das Suchfeld "Was möchten Sie tun?" im Hauptmenü zeigt eine entsprechende Anzahl an Befehlen und die Autovervollständigung in Eingabefeldern merkt sich diese Anzahl an Einträgen.
.topic 1932
Baumknoten automatisch erweitern
Menü Datei | Optionen | Einstellungen
Menü Navigator
In strukturierten Listen, wie beispielsweise dem Projektnavigator, wird ein Knoten erweitert, um die Unterpunkte sichtbar zu machen.
Wenn das automatische Erweitern aktiviert ist, öffnen sich die Baumkonten, sobald sie markiert sind. Andere Knoten, die zuvor automatisch geöffnet wurden, schließen dann. Ist  diese Option nicht aktiviert, kann der Knoten mit einem Klick auf das Symbol vor dem Text oder mit einem Doppelklick auf den Text erweitert werden.
Tipp: Im Dialogfenster der Programmeinstellungen können Sie das Verhalten testen, indem Sie die Option umschalten und dann links die strukturierte Liste der Optionskategorien bedienen.
.topic 1935
Stil (Menü Ansicht | Anpassen | Stil)
Legt das Farschema der Benutzeroberfläche fest.
.topic 1943
Archiv-Schnellzugriff
Wenn der Schnellzugriff aktiviert ist, können Sie das zu öffnende Dokumentenarchiv sehr schnell aus der Liste über dem Projektnavigator wählen. Die Option ist sinnvoll, wenn Sie sehr oft zwischen verschiedenen Archiven wechseln.
Klicken Sie bitte mit der rechten Maustaste auf den Projektnavigator, und wählen Sie Archiv-Schnellzugriff, um die Einstellung zu ändern.
Der Schnellzugriff ist nicht möglich, wenn der Menübefehl Datei | Archiv öffnen vom Administrator gesperrt wurde.
.topic 1945
Hinweise zeigen
Menü Hilfe | Kurzhilfe | Hinweise
Zeigt auf dem Bildschirm Erläuterungen (Quickinfo) zu den Schaltflächen und Komponenten an, sobald der Mauszeiger darauf ruht.
.topic 1946
Zeilenanzahl der Dokumenttabelle
Menü Datei | Optionen | Einstellungen, Seite Ansicht | Tabellen
Maximale Anzahl sichtbarer Textzeilen in einer Tabellenzeile. Wenn der Text breiter aus die Spalte ist, wird er umgebrochen und in der nächsten Textzeile dargestellt. Standardwert ist 1.
.topic 1947
Filtern im Tabellenkopf (Menü Datei | Optionen | Einstellungen)
Wenn die Option markiert ist, können Sie in der Dokumenten- und Aufgabentabelle zusätzliche Filterkriterien setzen.
.topic 1948
Datensatzanzahl in Gruppierung
Hiermit können Sie in der gruppierten Dokumenten- und Aufgabentabelle die Anzahl der Datensätze im Gruppenknoten einblenden.
.topic 1950
Zebra-Tabelle
Die Tabellenzeilen können für eine bessere Lesbarkeit als s.g. Zebra-Tabelle mit abwechselnden Hintergrundfarben dargestellt werden. Die Option finden Sie im Menü Datei | Optionen | Einstellungen auf Seite Ansicht | Tabellen. Beachten Sie aber, dass dies nicht von allen Stilen unterstützt wird.
.topic 1951
Erweiterte Eigenschaften darstellen
Menü Datei | Optionen | Einstellungen, Seite Ansicht | Tabellen
In Dokument- und Kontakt-Tabellen werden auch die erweiterten Eigenschaften dargestellt: Schriftformatierungen, Hintergrundfarbe und Bilder, welche in den Auswahllisten definiert sind.
.topic 1952
Wenn die Option Programmsymbole darstellen markiert ist, wird oberhalb der Dokumententabelle das Symbol (Icon) des zugeordneten Windows-Programms dargestellt. Das Symbol wird bei jedem Wechsel des Dokumentdatensatzes gelesen. Entfernen Sie die Markierung, um die Geschwindigkeit beim Wechsel der Datensätze zu beschleunigen.
.topic 1953
Scrollleisten werden schmal dargestellt und wechseln zur normalen Breite, sobald sich der Mauszeiger darüber befindet.
Diese Darstellung ist modern, bringt aber keinen Vorteil. Es ist Geschmackssache.
.topic 1956
Benutzername im Titel des Hauptfensters zeigen
(Menü Datei | Optionen | Einstellungen, Seite Ansicht)
Wenn markiert, dann steht "Benutzername @ Archivname, Kontakte" im Titel des Hauptfensters.
Deaktivieren Sie diese Option, wenn Sie regelmäßig mehrere Office Manager-Programmfenster öffnen: Sie können dann in der Taskleiste besser erkennen, welches Archiv im jeweiligen Fenster geöffnet ist.
.topic 1958
Jetzt speichern
Wenn der Speichermodus "Global für alle Benutzer im Layout hinterlegt" gewählt ist, dann speichern Sie die aktuellen Tabelleneinstellungen mit Klick auf diesen Schalter.
.topic 1959
Rechtschreibprüfung
(Menü Datei | Optionen | Einstellungen, Seite Ansicht)
Aktiviert die Rechtsschreibprüfung in der programminternen Textverarbeitung für Notizen sowie in einigen Eingabefeldern.
.topic 1970
Eingabe eines neuen Passwortes für den Zugriff auf die Administrator-Ebene.
.topic 1971
Potenziell gefährliche Makrofunktionen in OmAPI zulassen
Einige Funktionen der Office Manager-Makrosprache "OmAPI" sind standardmäßig gesperrt. Beispielsweise das Löschen von Dateien und SQL-Datenbankoperationen.
Falls Sie auch diese zulassen möchten, dann markieren Sie die Option im Menü Datei | Optionen | Einstellungen auf der Seite Sicherheit.
.topic 1982
Zusatztext für Fehlermeldungen
Der Administrator kann einen zusätzlichen Text für Informations-Dialoge definieren (Menü Datei | Optionen | Einstellungen).
Der hier eingegebene Text wird bei Warnungen und Fehlermeldungen mit angezeigt. Geben Sie z. B. "Bei Fragen wenden Sie sich bitte an den Systemadministrator Werner Müller, Apparat 26" ein.
.topic 1983
Der Office Manager schreibt alle wichtigen internen Meldungen in die Logdatei "error.log". Wählen Sie Logdatei, um den Inhalt einzusehen.
Der Befehl ist nur aktiviert, wenn eine solche Datei vorhanden ist.
.topic 1987
Ausführung der Importfunktionen
Wenn dieser Optionsschalter nicht gedrückt ist, werden die Importfunktionen pausiert.
Die Funktion dient der Entwickler-Unterstützung und ist nicht für den normalen Betrieb vorgesehen.
.topic 1991
Syntax der Dateinamen
(Menü Datei | Optionen | Einstellungen, Seite Dokument)
Sie können hier festlegen, wie die Dateien im Hintergrund benannt werden. Beispielsweise können diese dem Datenfeld "name" entsprechen oder einfach mit der Schlüsselnummer durchnummeriert werden.
Verwenden Sie Makro-Variablen, um den automatisch erzeugten Dateinamen zu definieren, z. B.
{Doc:DocID} für die eindeutige Schlüsselnummer),
{Doc:Name} für den Dokumentennamen
{Doc:Name,Validate3} für den Namen nur mit einfachen Zeichen.
.topic 1993
Datenschutzbeauftragter
(Menü Datei | Optionen | Einstellungen, Seite Dokument | Revision)
Wenn in Ihrem Unternehmen ein Datenschutzbeauftragten bestellt ist, dann geben Sie hier bitte dessen Namen und die nötigen Daten für eine Kontaktaufnahme an. Diese Daten werden im Programm in datenschutzrelevanten Dialogen eingeblendet.
.topic 1994
Änderungen der Dateinamen zulassen
(Einstellungen, Seite Dokument)
1. In revisionssicheren Archiven mit GoBD-Modus können Dateinamen unabhängig von dieser Einstellung nicht geändert werden.
2. Deaktivieren Sie die Option "Änderungen der Dateinamen zulassen", wenn Sie auch in Standardarchiven verhindern möchten, dass der Anwender die Dateinamen ändert. Unabhängig von dieser Einstellung können Dateinamen dann aber noch vom Administrator geändert werden und vom Benutzer, falls die angegebene Datei nicht vorhanden ist.
.topic 1996
Löschen nach Ablauf der Aufbewahrungspflicht zulassen
(Menü Datei | Optionen | Einstellungen, Seite Dokument | Revision)
Mit dieser Option aktivieren Sie die Verwendung von Aufbewahrungsfristen für alle Archive. Nach dem Ablauf der Frist können Dokumente gelöscht werden, auch im GoBD-Modus und auch in der Ansicht "Archivierte Dokumente". Der Datenschutz hat dann Vorrang.
Die Fristen werden über die Dokumenten-Kategorie definiert. Zum Löschen ist eine Internetverbindung zu einem Zeitserver erforderlich.
Wenden Sie sich ggf. an Ihren Administrator.
.topic 1998
Vorgabe gilt auch für bestehende Dateien
Menü Datei | Optionen | Einstellungen auf Seite Dokument
Markieren Sie diese Option, um den automatisch erzeugten Dateinamen auch für bestehende Dateien zu erzwingen. Sobald der Anwender ein für den Dateinamen relevantes Attribut (Projekt usw.) ändert, wird die Dokumentdatei umbenannt bzw. in das neue Verzeichnis verschoben.
Beachten Sie bitte, dass diese Option den Datenverkehr im Netzwerk stark belasten kann. Die Datei wird nicht verschoben, wenn der neu ermittelte und der alte Dateiname auf dasselbe Verzeichnis verweist - egal ob UNC-Pfad oder Laufwerksbuchstabe.
Diese Option kann nur aktiviert werden, wenn Änderungen der Dateinamen zulassen nicht markiert ist. Sie hat keine Auswirkung auf geklonte Dokumente.
.topic 20704
Quelltexteditor
Geben Sie hier bitte den Skriptquelltext ein. Beachten Sie die gewählte Skriptsprache im Menü Start | Makro.
.topic 20705
Funktionsliste der gewählten Skriptsprache. Mit einem Doppelklick können Sie Funktionen an die Cursorposition im Editor einfügen.
.topic 20706
Liste der Interpreter-Meldungen.
.topic 20707
Statusbar
.topic 20709
Nach einer Funktion in der Liste suchen.
Bei der Sprache "OmAPI" wird auch in der Kurzbeschreibung und in Schlüsselwörtern gesucht. Bei anderen Skriptsprachen nur im Funktionsnamen.
.topic 20710
Neu
Ein neues Makro oder Skript erstellen. Wenn derzeit ein Makro geladen ist, dann wird dieses geschlossen.
.topic 20711
Öffnen
Eine vorhandene Makrodatei in den Editor laden. Die Skriptsprache wird -sofern bekannt- nach dem Öffnen automatisch eingestellt.
.topic 20712
Speichern
Änderungen des geöffneten Makros in Datei oder Datenbanktabelle speichern.
Siehe auch: Speichern unter
.topic 20713
Speichern unter...
Die geöffnete Makrodatei unter einem neuen Namen speichern.
.topic 20714
Speichern unter...
Dieses Makro ist in einer Datenbanktabelle gespeichert. Wählen Sie bitte im Menü Datei den Befehl
Speichern, um die Änderungen in die Tabelle zu schreiben oder
Speichern und Senden | Speichern unter, um eine Dateikopie des Makros zu erstellen.
.topic 20715
Hilfe zur Funktion
Nur für Office Manager Makrosprache: markieren Sie bitte eine Funktion in der rechten Liste und klicken Sie anschließend auf diesen Befehl, um die Hilfeseite zur markierten Funktion zu öffnen.
.topic 20716
Ausführen [F9]
Führt das Makro bzw. Skript aus. Diese Funktion ist vor allem für Testzwecke vorgesehen. Meldungen des Interpreters werden in der unteren Liste aufgeführt.
Debuggen [F8]
Nur OmAPI-Makrosprache: Führt das Makro Schritt-für-Schritt zur Fehlersuche aus. Alternativ zum Menübefehl Debuggen können Sie auch mit gedrückter Umschalt-Taste auf Ausführen klicken oder die Taste F8 drücken.
Kompilieren [Strg+F9]
Nur Pascal: Ermöglicht eine Syntaxprüfung, ohne das Skript auszuführen.
.topic 20717
Funktion in den Editor kopieren
Bewegen Sie den Cursor bitte an die gewünschte Stelle im Editor und doppelklicken Sie auf eine Funktion in der rechten Liste. Die markierte Funktion wird an der Cursorposition im Editor eingefügt.
Statt einem Doppelklick können Sie auch eine Funktion markieren und anschließend im Menü Start | Makro den Befehl Funktion einfügen wählen.
.topic 20718
Sprache
Wählen Sie bitte die Programmiersprache des Makros (z. B. VBScript, JScript oder OmAPI).
.topic 20719
Ergebnis zeigen
Debugger-Funktion: Wenn diese Option markiert ist, dann wird das Ergebnis des Makros nach dem Ausführen im Editor gezeigt.
Wenn im Makro zum Beispiel nur die Variable {Doc:FileName} enthalten ist, dann wird der Dateinamen des aktuellen Dokuments gezeigt.
.topic 21001
Liste der Importprofile.
.topic 21003
Für die unterschiedlichen Verzeichnisse können individuelle Importeinstellungen festgelegt werden (s. a. Hilfe).
Um zu ermitteln, welche der obigen Importeinstellungen für eine bestimmte Datei verwendet würde, können Sie die Datei per Drag and Drop vom Explorer auf diese Fläche ablegen.
.topic 21010
Geben Sie bitte eine aussagekräftige Beschreibung ein.
.topic 21011
Deaktiviert: diese Definition wird ignoriert, als wäre sie nicht vorhanden
Manuell oder von außen gesteuert: beispielsweise Drag&Drop
Dokumente automatisch importieren: das Verzeichnis wird regelmäßig nach neuen Dokumenten durchsucht
.topic 21012
Geben Sie einen Computernamen an, wenn das Profil nur an diesem gültig sein soll.
Tipp zu Importprofilen: Beim automatischen Import können Sie hier den zuständigen Computer angeben. Dies verhindert z. B. beim Import von Netzwerkressourcen, dass der Import einer Datei gleichzeitig von mehreren Rechnern ausgeführt wird.
.topic 21016
Markieren Sie ein oder mehrere Verzeichnisse, für welche die Importoptionen gelten.
.topic 21017
Geben Sie einen Benutzer an, wenn das Profil nur für diesen gelten soll.
Tipp zu Importprofilen: Beim automatischen Import können Sie hier den zuständigen Benutzer wählen. Dies verhindert z. B. beim Import von Netzwerkressourcen, dass der Import einer Datei gleichzeitig von mehreren Rechnern ausgeführt wird.
.topic 21018
Wählen Sie bitte eine Archivdatenbank, wenn das Profil nur für ein bestimmtes Archiv gelten soll.
.topic 21019
Titel des Dokumenten-Eigenschaftendialogs, zum Beispiel "Dokumentdatei importieren".
.topic 21020
Eine Datei, die im Eigenschaftenfenster beim Klick auf den Schalter Hilfe geöffnet wird.
Oder:
Die Nummer der Office Manager-Hilfe. Klicken Sie auf [...] und wählen Sie ein Thema aus.
.topic 21021
Typ der Importquelle: ein oder mehrere gewählte Verzeichnisse oder alle Wechsellaufwerke (CD, USB u. a.) die an dem Computer angeschlossen sind.
.topic 21023
Liste mit Import-Quellverzeichnissen, welche als Makrovariable definiert werden. Jede Zeile beinhaltet ein Verzeichnis.
Beispiele für geeignete Makrovariablen:
{OS:TmpPath} z. B. für DnD von E-Mails und deren Anlagen
{OS:SpecialFolder,0x002e}
{Self:DocPath}
.topic 2120
Klicken Sie auf Verwerfen, wenn Sie diese Datei nicht in das Archiv importieren möchten.
.topic 2125
Klicken Sie auf Alle OK, um dieses und alle weiteren anstehenden Dateien ohne weitere Bearbeitung in das Archiv zu importieren.
Tipp: Klicken Sie mit der rechten Maustaste auf diesen Schalten und wählen Sie Import-Dateiliste im lokalen Menü.
.topic 2130
Klicken Sie auf Abbrechen, um den Import aller anstehenden Dateien abzubrechen.
.topic 2148
Importstapel
Die in dieser Liste markierten Dateien werden nach Klick auf Importieren archiviert.
.topic 2149
Markieren Sie diese Option und kopieren Sie anschließend Dateien in die Zwischenablage. Diese werden dann automatisch in den Importstapel übernommen.
.topic 2151
Im unteren Bereich des Dialogfensters finden Sie Informationen über den derzeitigen Bearbeitungsstatus.
.topic 2152
Datenträgerverzeichnis (Ordner), in dem die Suche nach Dokumenten beginnen soll.
Klicken Sie auf die Schaltfläche [Durchsuchen], um das Verzeichnis auszuwählen. Um mehrere Verzeichnissen zu markieren, halten Sie bitte die Strg- oder Umschalt-Taste gedrückt.
.topic 2153
Markieren Sie diese Option, um auch die Unterverzeichnisse nach Dokumentdateien zu durchsuchen.
.topic 2154
Nur neue Dokumentdateien importieren
(Einstellung der Import-Profile und Option beim Massen-Import)
Wenn diese Option markiert ist, werden nur Dokumentdateien importiert, die im geöffneten Archiv noch nicht vorhanden sind. Beachten Sie bitte, dass alle identischen Dateien ignoriert werden.
Hierzu wird die Datenbank nach der Datei-Checksumme durchsucht und bei identischer Summe zusätzlich der Dateiinhalt verglichen.
Bei der Verzeichnisüberwachung ist diese Option immer aktiviert.
Siehe auch erweiterte Einstellungen FindDuplicateByFileName und ConfirmDuplicate
.topic 2155
Klicken Sie bitte auf Importieren, um die Dateien in der rechten Liste in das Dokumentenarchiv zu importieren.
.topic 2156
Klicken Sie auf die Schaltfläche Optionen und legen Sie die Optionen für das Importverzeichnis fest. Auf der Seite Feldwerte können Sie definieren, wie die Dokumentattribute aus der Verzeichnisstruktur ermittelt werden.
.topic 2157
Klicken Sie auf Suchen, um die Suche nach Dokumentdateien im angegeben Verzeichnis zu starten.
.topic 2158
Klicken Sie auf Abbrechen, um die Suche nach Dokumentdateien abzubrechen.
Es kann einige Sekunden dauern, bis die Software reagiert und die Sicherheitsabfrage "Möchten Sie abbrechen" erscheint.
.topic 2159
Für den Import werden i. d. R. alle Dokumenttypen berücksichtigt, die in Office Manager DMS registriert sind. Wenn Sie nur nach bestimmten Dateien suchen möchten, können Sie eine Dateimaske vorgeben. Mehrere Masken bitte mit Semikolon trennen.
Beispiele:
*.pdf
*.txt;*.doc
Me?er.*
Datei[0-9].txt
.topic 221
Die Aufbewahrungsfrist gibt an, wie lange das Dokument archiviert werden muss.
.topic 2210
Eigenschaften der Dokumentversion bearbeiten
Sie können die Beschreibung und den Dateinamen der Version ändern.
.topic 2211
Dokumentversion öffnen
Öffnet die markierte Dokumentversion im zugeordneten Anwendungsprogramm. Beachten Sie bitte, dass die archivierten Versionen oft schreibgeschützt sind und nicht geändert werden können.
.topic 2221
Geben Sie eine sinnvolle Beschreibung der Dokumentversion ein. Auf der Seite Details können Sie weitere Notizen erfassen.
.topic 2222
Dateiname der zu archivierenden Dokumentversion. Der Dateiname wird vom Office Manager automatisch festgelegt. Alternativ können Sie aber auch einen Namen vorgeben, klicken Sie dazu bitte auf die Schaltfläche neben dem Eingabefeld.
.topic 2223
Wenn die Option Schreibschutz markiert ist, kann die Dokumentdatei nicht geändert werden. Archivierte Dokumentversionen sollten mit einem Schreibschutz versehen werden, um eine unbeabsichtigte Änderung zu vermeiden.
.topic 2224
Versionsnummer des archivierten Dokumentes. Die Nummer wird automatisch vom Programm vergeben.
.topic 2225
Datum und Uhrzeit der Archivierung.
.topic 2226
Name des Anwenders, der die Dokumentversion archiviert hat.
.topic 2227
Details
Sie können hier die Details der Dokument-Version beschreiben und beliebige Notizen erstellen.
.topic 2228
Diese Datei wird als Versionsstand für das Dokument importiert.
Je nach Einstellung (Menü Datei | Optionen | Einstellungen, Seite Importieren | Profile) wird die Datei in das Dokumentenverzeichnis kopiert, verschoben oder sie verbleibt am ursprünglichen Speicherort.
.topic 23050
Wählen Sie bitte den zu verwendenen CD-Rekorder aus.
.topic 23051
Klicken Sie auf Brennen, um mit dem Beschreiben der CD zu beginnen.
.topic 23052
Laufwerksschublade öffnen.
.topic 23053
Eingelegten Datenträger schnell löschen. Diese Funktion ist nur für wiederbeschreibbare CDRW möglich.
.topic 23054
Bezeichnung des Datenträgers.
.topic 23055
Markieren Sie diese Option, um die CD nach dem Brennen automatisch auszuwerfen.
.topic 23056
Text, der im Protokoll des Dokuments hinterlegt wird.
Ein Protokolleintrag ist zwingend erforderlich, falls die Option "Dokumentbearbeitung protokollieren" aktiviert ist.
Siehe auch: Datei | Optionen | Einstellungen, Seite Datenbank.
.topic 23057
Liste der Meldungen.
.topic 23058
Legt ein HTML-Inhaltsverzeichnis auf der CD ab.
.topic 23070
Server
IP-Nummer oder Name des Servers (Host).
Die Verbindungseinstellungen werden für jeden Benutzer gespeichert und können nach einem Neustart in diesem Kombinationsfeld ausgewählt werden.
.topic 23071
Port
Server-Port für den FTP-Zugriff. Der Standardport für FTP ist 21 und für SFTP 22.
.topic 23072
Protokoll
FTP und SFTP sind Protokolle zur Dateiübertragung, SFTP ist sicherer.
FTP ist unverschlüsselt und kann abgehört werden, während SFTP die Daten über eine verschlüsselte SSH-Verbindung überträgt.
.topic 23073
FTP-Zielverzeichnis
Optionales Unterverzeichnis auf dem FTP-Server, in welches die Dateien hochgeladen werden.
.topic 23074
Benutzername und Passwort für die Authentifizierung auf dem FTP-Server.
.topic 23075
Die Verbindungseinstellungen werden benutzerabhängig gespeichert und nach einem Neustart wiederhergestellt.
Klicken Sie auf Löschen, wenn Sie die Einstellungen des gewählten FTP-Servers entfernen möchten.
.topic 2313
Startet die Revision der Dokumente, die derzeit gesucht sind. Im Anschluss erhalten Sie eine Zusammenfassung der Tests und die Möglichkeit, Details zu den einzelnen Dokumenten einzusehen.
.topic 2314
Klicken Sie auf Abbrechen, um die laufende Revision zu unterbrechen. Das Prüfungsergebnis der bereits durchlaufenden Dokumente geht dabei nicht verloren.
.topic 2315
Zusammenfassung der Dokumentenrevision aller beim Test durchlaufenden Dokumente.
Um Details zu den einzelnen Dokumenten einzusehen, klicken Sie bitte auf den entsprechenden als Links dargestellten Text. Beispielsweise n nachvollziehbare Bearbeitungen.
.topic 2316
Kehrt zur Revisions-Startseite zurück. Dieser Schalter ist nur auf der Seite mit den Dokumentendetails sichtbar.
.topic 2317
Zusammenfassung der Revision eines einzelnen Dokuments.
.topic 2318
Log des Prüfungsdurchlaufs.
Hier können Sie nachvollziehen, wie die Software ein einzelnes Dokument überprüft.
.topic 2411
Die in der Dokumententabelle markierten Dokumente werden kombiniert. Geben Sie bitte einen beliebigen Verknüpfungsnamen ein und klicken Sie auf OK.
Ein aussagekräftiger Name, z. B. die Auftragsnummer, hat Vorteile, wenn Sie später weitere Dokumente mit diesen kombinieren möchten.
.topic 2412
Die Dokumente werden einer bereits vorhandenen Verknüpfung hinzugefügt. Markieren die gewünschte Verknüpfung bitte in der unteren Liste und klicken Sie auf OK.
.topic 2413
Markieren Sie die Verknüpfung, aus welcher die Dokumente entfernt werden sollen und klicken Sie auf OK.
.topic 2414
Liste mit vorhandenen Verknüpfungen, zu denen die Dokumente hinzugefügt werden können. Zur besseren Identifikation der Verknüpfungen können Sie durch Klick auf [+] die bereits enthaltenen Dokumente einblenden.
.topic 2503
Auswahl der Datentabelle
Markieren Sie bitte im Menü Ansicht den Eintrag:
Aktive Dokumente, um nach normalen, im täglichen Zugriff befindlichen Dokumenten zu suchen, oder
Archivierte Dokumente für eine Suche in den langzeitarchivierten Dokumenten (nur Enterprise-Edition).
Kontakte wechselt zur Adressverwaltung und
Aufgaben zum Terminplaner.
Papierkorb beinhaltet die (noch nicht endgültig) gelöschten Dokumente.
.topic 25101
Drucken
Ausgabe des Reports auf einem Drucker.
.topic 25102
Als PDF-Datei speichern
Ausgabe des Reports in ein PDF-Dokument. Wählen Sie bitte den Namen der zu erstellenden PDF-Datei, indem Sie auf den Schalter Durchsuchen klicken. Die Datei wird anschließend geöffnet, wenn die Option "Datei öffnen" markiert ist.
.topic 25110
Zu druckende Felder
Markieren Sie bitte alle Felder, die im Report mit ausgedruckt werden sollen.
Die Positionierung auf dem Report entspricht der Sortierung in dieser Liste. Zum Sortieren können Sie die Felder mit der Maus verschieben (Drag&Drop).
.topic 25111
Wenn diese Option nicht markiert ist, werden leere Felder im Report ignoriert.
.topic 25120
Grafikformat
Gibt an, in welchem Format die Vorschaugrafik in der PDF-Datei eingebunden wird. Für Farbbilder sollte JPeg verwendet werden, um Speicherplatz zu sparen.
.topic 25121
Auflösung der Vorschaugrafik
Eine hohe Auflösung verbessert die Qualität, benötigt aber mehr Speicherplatz für das erstellte PDF-Dokument. Empfohlen sind 300 dpi.
.topic 25122
Größe der Vorschaugrafik
Bei "Automatisch" wird der zur Verfügung stehende Platz ausgenutzt.
.topic 25123
Vorschau umrahmen
Wenn die Option markiert ist, wird ein Rahmen um die Vorschaugrafik gezeichnet.
.topic 25124
Überschrift
Text der über den Datenfeldern ausgegeben wird. Lassen Sie dies leer, wird automatisch "Dokument" oder "Kontakt" ausgegeben.
.topic 25125
Logo
Dateiname einer Grafik die rechts oben in der Kopfzeile des Reports platziert wird.
.topic 25126
Schriftgröße
Standardschriftgröße der Texte, beispielsweise "10".
.topic 25127
Optionen zwischenspeichern
Sie können verschiedene Einstellungen in Dateien speichern und später wieder laden.
.topic 25128
Feldnamen-Breite
Im Report werden die ausgewählten Felder mit ihren Daten in zwei Spalten gedruckt. Dieser Wert legt die maximale Breite des Texte für die Feldnamen in mm fest. Der Standardwert ist 25 mm.
.topic 25129
Ausgeben
Markieren Sie im Dropdown-Listenfeld bitte die zu druckenden Bereiche. Datenfelder sind immer aktiv und lassen sich nicht abschalten.
Vorschau, Versionen und Dokumentdatei sind für Kontakt-Reporte nicht relevant.,
.topic 25130
Seitenumbruch nach jedem Dokument
Wenn diese Option markiert ist, wird der Report für jedes Dokument bzw. jeden Kontakt auf einer eigenen Seite gedruckt.
.topic 25131
Ausrichtung korrigieren
Markieren Sie diese Option bitte nur, falls einige Bilder im Report auf dem Kopf stehen. Die Einstellung dreht Bilder, welche mit der Windows-Miniaturansicht erzeugt wurden, um 180°.
Diese Einstellung ist Benutzer- und Computerabhängig.
.topic 2601
Archivverzeichnis
Mit der Archivierungsfunktion werden alte Dokumente aus dem normalen Speicherbereich ausgelagert. Geben Sie bitte das Verzeichnis an, in welches die archivierten Dokumente verschoben werden sollen.
Falls die Dokumentdateien bei der Archivierung nicht verschoben werden sollen, lassen Sie das Eingabefeld bitte leer.
.topic 26010
Zeigt Informationen und das Protokoll der Datenübergabe.
.topic 26012
Ausgabeverzeichnis
In dieses Verzeichnis werden die Dokumentdateien kopiert.
Sie können auch Makrovariablen verwenden, um eine Verzeichnisstruktur zu erzeugen. Beispielsweise legt "C:\Export\Steuerberater\{doc:project}\{doc:category}\" Unterverzeichnisse für die Jahre und Kategorien an.
.topic 26013
Syntax der Dateinamen
Falls der Steuerberater besondere Dateinamen benötigt, können Sie diese mit Makrovariablen formatieren. Beispielsweise "{StringReplace:{doc:category},\,-}-{doc:docno}-{doc:name}" für "Kategorie-Nummer-Name".
.topic 26014
Warnen, wenn das Zielverzeichnis nicht leer ist
Warnt den Anwender vor dem Versenden, falls das Ausgabeverzeichnis bereits Dateien oder Unterverzeichnisse beinhaltet.
.topic 26015
Tabellen
Markieren Sie, welche Dokumententabellen berücksichtigt werden sollen. Der Bereich "Archivierte Dokumente" ist nur in der Enterprise-Edition verfügbar.
.topic 26016
Nur markierte Buchungsjahre bzw. Projekte
Sendet nur Dokumente der im Programmhauptfenster markierten Projekte bzw. Buchungsjahre.
Der Anwender markiert dazu die gewünschten Einträge im Projektnavigator, bevor er die Funktion "An Steuerberater senden" aufruft.
.topic 26017
Kategorien
Markieren Sie die Dokumentenkategorien, die für den Steuerberater relevant sind. Beispielsweise Rechnungen und Kontoauszüge.
Beachten Sie bitte, dass auch Unterpunkte markiert werden müssen: "Buchhaltung" beinhaltet nicht automatisch den Unterpunkt "Buchhaltung\Ausgangsrechnung".
.topic 26018
Zusätzlicher Filter
Falls Sie nach weiteren Datenfeldern filtern möchten, können Sie diese hier angeben.
Beispiele
meinfeld = 'Steuerberater' AND janeinfeld = 'T'
Nur Belege vom Februar 2025 (Belegdatum ab 1. Februar und vor 1. März):
receiptdate >= {d 2025-02-01} AND receiptdate < {d 2025-03-01}
.topic 26019
Standard-Unterverzeichnisse für DATEV-Belegtransfer
Wenn markiert, dann werden die Belege anhand ihrer Kategorie in Unterordner des Ausgabeverzeichnisses kopiert:
Kategorie im Office Manager-Archiv => Unterordner
Buchhaltung\Ausgangsrechnung => Rechnungsausgang
Buchhaltung\Eingangsrechnung => Rechnungseingang
Buchhaltung\Kasse => Kasse
(ohne Kategorie) => ohne Belegtyp
(alle anderen) => Sonstige
.topic 2602
Wenn die Option Dokumentdateien komprimieren markiert ist, werden die Dokumentdateien beim Archivieren komprimiert. Die Dateien belegen dann weniger Speicherplatz.
.topic 26020
Nur Belege bis zum Vormonat
Diese Option ist empfohlen, wenn Sie die Dokumente monatlich zum Steuerberater geben. Es werden dann nur Belege bis zum Ende des vergangenen Monats über das Belegdatum (Datenfeld receiptdate) gefiltert. Belege des aktuellen Monats sind nicht enthalten.
Beispiel
Wenn Sie am 6. März die Daten an den Berater senden, werden alle Belege aus dem Vormonat Februar gewählt. Falls seit der letzten Übertragung (z. B. am 6. Februar) aber noch neue Belege aus dem Januar oder früher hinzugekommen sind, werden auch diese nachgereicht. Sie wurden ja noch nicht gesendet.
.topic 2603
Aktiviert den Passwortschutz eines Acrobat-Dokuments, um Dokumentänderungen zu verhindern. Der Schutz kann nicht mehr aufgehoben werden (revisionssichere Archivierung).
.topic 2604
Legen Sie fest, ob die Dokumentdateien bei der Archivierung in einen besonderen Speicherbereich kopiert oder verschoben werden sollen.
.topic 262
Ausführbare Programmdatei (*.exe) der Anwendung mit kompletter Pfadangabe.
.topic 2711
Neue Dokumente automatisch hinterlegen
Menü Datei | Optionen | Einstellungen, Seite Dokument | Blockchain
Wenn diese Option markiert ist, werden die Hashwerte neu hinzugefügter Dokumente automatisch nach 10 Minuten auf der eingestellten Blockchain hinterlegt.
Beachten Sie auch die erweiterte Einstellung "AutoStoreTaskOwner" in der admin.ini.
.topic 2712
Verwendete Blockchain
Um die Einstellungen anzupassen, klicken Sie rechts im Eingabefeld bitte auf die Schaltfläche.
[automatisch]: die Office Manager-Vollversion verwendet das Mainnet "Documentchain", die Testversion speichert im Testnet.
Documentchain: das verteilte Mainnet der Blockchain für echte Revisionen.
Documentchain Testnet: nur für Tests.
Wenn Sie das Web-Wallet verwenden, benötigen Sie keine zusätzliche Software.
.topic 2713
RPC-Port
Über diesen Computer-Port erfolgt die Kommunikation mit der Wallet-Software "DMS Core".
.topic 2714
Rohdaten zeigen
Vor dem Senden an die Blockchain wird eine Vorschau der Daten eingeblendet. Wenn diese Option markiert ist, beinhaltet die Vorschau auch den rohen Datenstream.
.topic 2715
Vorschau
Vor dem Hinterlegen können Sie auf diesen Schalter klicken. Die zur Speichern vorgesehenen Informationen werden im mehrzeiligen Textfeld als Vorschau eingeblendet. Dies ermöglicht Ihnen eine Überprüfung, bevor Sie die Daten senden.
.topic 2716
Ausgabefeld für die Vorschau und Dokumentenrevision.
.topic 2717
Hinterlegen
Speichert nach einer Rückfrage die Dokumentinformationen (Hash, Dateichecksumme) in der ausgewählten Blockchain und zieht die Transaktionsgebühr vom Wallet-Guthaben ab. Die Transaktions-ID wird Im Archiv hinterlegt, sodass später eine Dokumentenrevision durchgeführt werden kann.
Im Anschluss wird auch das Schreibschutz-Attribut der Datei gesetzt, um unbeabsichtigte Änderungen zu verhindern. Sie können dies aber mit Start | Eigenschaften wieder deaktivieren.
Ein Dokument kann nur einmal in der Documentchain hinterlegt werden, ein Überschreiben der bestehenden Information ist nicht möglich. Ausnahmen:
Wenn das Dokument nur in einer Testumgebung hinterlegt ist, kann es trotzdem an die öffentliche Blockchain gesendet werden.
Sie können die Revisionsinformationen löschen (Klick auf den Pfeil des Schalters "Dokument prüfen") und anschließend neu hinterlegen. Selbstverständlich wird dann aber nur die Unveränderbarkeit seit dem erneuten Hinterlegen (also ab jetzt) bestätigt.

Socket-Fehler
Die Meldung "Verbindung abgelehnt" erhalten Sie, wenn keine Verbindung zum Wallet aufgebaut werden konnte. Prüfen Sie dann bitte, ob die "DMS Core" ausgeführt wird und die richtige Blockchain (normal oder Testumgebung) gewählt ist.
Internal server error weist auf ein verschlüsseltes Wallet zu, bitte zuerst mit Eingabe des Passwortes entschlüsseln.
.topic 2718
Dokument prüfen
Führt eine Dokumentenrevision durch. Die aktuellen Daten werden mit den in der Blockchain gespeicherten verglichen. Wenn das Dokument unverändert ist, wird dieses bestätigt.
Die Prüfung ist nach einer Hinterlegung nicht sofort möglich. Die Transaktion muss zuvor bestätigt (gemined) werden. Warten Sie bitte einige Minuten ab. Falls Sie die lokale Testumgebung verwenden, dann erzeugen Sie den Block bitte mit "generate 1" im Menü Werkzeuge | Debug-Konsole.

Revisionsinformationen löschen
Klicken Sie hierzu bitte auf den Pfeil des Mausschalters "Dokument prüfen". Das Blockchain-Datenfeld mit der Transaktions-ID aller markierten Dokumente wird nach einer Rückfrage geleert. Anschließend können Sie keine Revision mehr durchführen (bzw. nur noch, wenn Sie die Transaktions-ID kennen).
Dies ist in der Regel nur sinnvoll, wenn Sie eine Dokumentdatei nachträglich geändert haben und das Dokument erneut auf der Blockchain absichern möchten. Selbstverständlich wird dann aber nur die Unveränderbarkeit seit dem erneuten Hinterlegen (also ab jetzt) bestätigt.
Für das Löschen sind administrative Rechte erforderlich.

Fehlgeschlagene Dokumente suchen
Wenn bei einer Revision Dokumente mit geänderter Datei gefunden wurden, können Sie die betroffenen Dokumente filtern. Klicken Sie hierzu bitte auf den Pfeil des Mausschalters "Dokument prüfen". Die Dokumentenhaupttabelle zeigt anschließend nur noch die fehlerhaften Dokumente und nur noch diese sind für die Bearbeitung im Blockchain-Dialogfenster gewählt.
.topic 2724
Besitzer/Firma
Optional. Geben Sie hier Ihren Firmennamen o. ä. an. Der Hashwert dieser Information wird zusammen mit den Dokumentinformationen in der Blockchain gespeichert.
Datenschutz
Es wird nur der Hash hinterlegt. Da es sich um einen kurzen Text handelt, könnte der Name aber erraten werden (Berechnung der Hashwerte für verschiedene Firmennanem). Jemand, der diesen Hash kennt, kann ermitteln, wie viele Dokumente mit diesem Firmenhash hinterlegt sind.
.topic 2725
Datei-Hash
Für die Revisionssicherheit wird die Checksumme (MD5 Hash) des Dokuments in der Documentchain gespeichert. Bei der späteren Überprüfung, ob das Dokument unverändert ist, wird diese mit der aktuellen Checksumme verglichen.
Dokumentdateien und interne Textverarbeitung: Der Hash wird aus dem Dokumenteninhalt gebildet.
Internet-URL: Wenn Sie eine Internetadresse (ohne lokale Dateikopie) verwalten, dann wird nur die Adresse (URL) überprüft. Es wird also nur bestätigt, dass der URL unverändert ist.
.topic 2728
DMS Coin-Einheiten
1 DMS = 1 DMS
1 mDMS = 0,001 DMS, gesprochen "Milli-DMS"
1 uDMS oder µDMS = 0,000001 DMS, gesprochen "Micro-DMS"
1 docz = 0,00000001 DMS, gesprochen "Docoshi"
Test-DMS
Im Testnetz wird der Einheit jeweils ein kleines "t" vorangestellt, um diese von den echten Coins zu unterscheiden, besipielsweise tDMS und tuDMS.
.topic 28031
Modell
Öffnen Sie das Kombinationsfeld mit Klick auf den Pfeil am rechten Rand, um alle verfügbaren Chat-Modelle des gewählten GPT-Dienstes aufzulisten.
Die Ergebnisse der KI hängen von der richtigen Wahl eines passenden Modells ab. Sie können mit verschiedenen Modellen für die jeweilige KI-Aufgabe experimentieren.
.topic 28032
Rollen
Die Anfrage an den Chat-Dienst kann in System- und Benutzerrolle aufgeteilt werden, um die Ergebnisse zu optimieren. Die Systemrolle beinhaltet dabei die Regeln und die Benutzerrolle die eigentliche Anfrage.
System-Rolle
Legt den Kontext und das Verhalten des KI-Assistenten fest. Beispiele sind
"Du bist ein Assistent, der mich bei der Übersetzung von fremdsprachigen Texte unterstützt. Übersetze in deutsche Sprache."
"Die Regeln für die Dokumentenerkennung sind ...".
"Du bist ein Assistent, der mir Fragen zur Computer-Technik beantwortet. Antworte in deutscher Sprache und vermeide Fachbegriffe."
Benutzer-Rolle
Beinhaltet die Frage an die KI, beispielsweise
"Übersetze folgenden Text in deutsche Sprache: [the text]"
"Erkenne das Dokument mit folgendem Inhalt: [Text]"
"Was ist ein WORM-Datenträger?"
.topic 28033
Maximale Tokens
Legt eine Obergrenze für die Eingabe plus Ausgabe bei der Kommunikation mit dem GPT fest. Tokens entsprechen ungefähr der Anzahl von Wörtern und Satzzeichen. Cloud-Dienste werden i. d. R. für die Anzahl der genutzten Tokens bezahlt. Der Standardwert ist 1024.
.topic 28034
Dokumente kürzen (Tokens)
Für die Dokumentenerkennung und die Übersetzung von Dokumenten wird der Text aus der markierten Datei extrahiert und an die KI übergeben. Sehr lange Texte sind meist nicht sinnvoll, sie würden unnötige Tokens sowie Zeit und Rechenleistung verbrauchen.
Office Manager DMS kürzt den Text auf die angegebene Anzahl von Tokens, bevor dieser gesendet wird.
Tokens entsprechen ungefähr der Anzahl von Wörtern und Satzzeichen. Der GPT-Dienst verwendet ggf. eine abweichende Berechnungsmethode.

.topic 28035
Bilder verkleinern (Pixel)
Für die Bilderkennung wird nicht die Originaldatei in voller Größe genutzt. Dies ist in der Regel nicht nötig und würde zu viele Tokens und Rechenleistung verbrauchen.
Geben Sie die maximale Pixelbreite oder -höhe an. Das Bild wird so verkleinert dass Breite und Höhe nicht größer als der Maximalwert sind.
Empfohlene Werte
224 Pixel ist die Mindestgröße für grundlegende Erkennungen.
300 bis 512 ein guter Kompromiss für die meisten Anwendungen.
640 ist der Maximalwert für detaillierte Analysen.
.topic 28036
Zurücksetzen
Die ausgewählte GPT-Funktion auf Standard-Einstellungen setzen.
.topic 28101
API-Adresse
URL der REST API für den Zugriff auf die Cloud-Funktionen und lokale GPT.
Beispiele
GPT4All (lokal)
http://localhost:4891/v1
OpenAI ChatGPT
https://api.openai.com/v1
Google Gemini
https://generativelanguage.googleapis.com/v1beta/openai
Azure GPT
https://(meine-subdomain).openai.azure.com/
Azure OCR
https://germanywestcentral.api.cognitive.microsoft.com/vision/v3.2/read/analyze
Azure Formularerkennung
https://myendpoint.cognitiveservices.azure.com/formrecognizer/documentModels/prebuilt-invoice:analyze?api-version=2022-08-31
.topic 28102
Schlüssel
Ihren API-Key finden Sie im Dashboard des jeweiligen Anbieters.. Bei lokalen GPT-Diensten können Sie i. d. R. einen beliebigen Text eingeben, wie "mykey".
.topic 28103
Erkannte Rohdaten zeigen
Blendet nach der Erkennung die vom Cloud-Server erhaltenen Daten ein. Hier finden Sie beispielsweise die Pfade für die Makrovariable AutoCaptAzureAI.
.topic 28104
Timeout für KI-Antwort
Menü Datei | Optionen | Einstellungen, Seite Künstliche Intelleigenz
Die Antwortzeit der Künstliche Intelligenz hängt von der Leistungsfähigkeit des Computers und der Komplexität der Anfrage ab. Bei umfangreichen Antworten, wie der Übersetzung langer Texte, kann die Verarbeitung auch einige Minuten dauern.
Nach Ablauf des eingestellten Timeouts bricht Office Manager DMS die Verbindung ab und gibt eine entsprechende Fehlermeldung aus.
Stellen Sie hier ein, wie viele Sekunden auf eine Antwort der KI gewartet werden soll, der Standardwert ist 120 = 2 Minuten. Ein sehr hoher Wert hat den Nachteil, dass Sie bei Verbindungsproblemen lange warten müssen, bis die Verbindung abgebrochen wird.
Weitere Timeouts
In der Konfigurationsdatei können auch die Timeouts für den Verbindungsaufbau und das Senden der Frage eingestellt werden. Dies ist i. d. R. aber nicht nötig, der Standard-Timeout beträgt hier 60 Sekunden. Beachten Sie, dass die Werte in der INI-Datei in Millisekunden angegeben werden.
.topic 28105
Ermöglicht die Übertragung der Einstellungen zwischen verschiedenen Funktionen.
Kopieren legt die aktuellen Einstellung in der Zwischenablage ab.
Klicken Sie auf Einfügen, um diese aus der Zwischenablage in das Dialogfenster zu übernehmen.
.topic 3001
Erstellt eine neue CAD-Zeichnung.
.topic 3002
Erstellt ein neues CAD-Zeichnungsbauteil.
.topic 3003
Importiert Dateien im DWG- oder DXF-Format und konvertiert diese in das MegaCAD-Zeichnungsformat PRT. Ziehen Sie die Dateien per Drag&Drop vom Explorer auf die Office Manager-Dokumententabelle.
.topic 3004
Konvertiert die markierte MegaCAD-Datei in das DWG- oder DXF-Format und speichert diese unter dem angegebenen Dateinamen.
.topic 3005
CAD-Programme ausführen. Startet das CAD- oder Zusatzprogramm.
.topic 3007
Fügt das markierte Bauteil in die geöffnete CAD-Zeichnung ein.
.topic 301
Fügt den Inhalt der Zwischenablage in das aktivierte Eingabefeld ein.
Wenn die Dokumententabelle markiert ist, werden die Dokumente aus der Zwischenablage importiert.
.topic 302
Kopiert den markierten Text in die Zwischenablage.
Oder,
wenn die Dokumententabelle markiert ist, die ausgewählten Dokumente in die Zwischenablage. Diese können im Programm, aber z. B. auch im Windows-Explorer wieder eingefügt werden.
.topic 303
Löscht den markierten Text und legt ihn in der Zwischenablage ab.
.topic 304
Löscht die markierten Einträge bzw. den markierten Text ohne ihn in der Zwischenablage abzulegen.
Wenn ein Dokument markiert ist, wird nach Rückfrage der Dokumentdatensatz und, wenn gewünscht, die entsprechende Datei vom Datenträger gelöscht.
.topic 305
Markiert den gesamten Text des aktiven Eingabefeldes.
Oder,
wenn die Dokumententabelle markiert ist, alle Dokumente in der Tabelle.
Tipp: Wenn alle Dokumente in der Tabelle markiert sind und Sie die Markierung entfernen möchten, dann halten Sie bitte die Strg-Taste fest und klicken auf einen markierten Datensatz.
.topic 3050
Markieren Sie diese Option, um den MegaCAD-Eintrag in der Windows-Registrierdatenbank zu aktualisieren. Dieser Eintrag hat für die Arbeit mit dem Office Manager keine Bedeutung, er ermöglicht Ihnen aber z. B., MegaCAD-Zeichnungen auch aus dem Windows-Explorer zu öffnen.
.topic 3051
Markieren Sie diese Option, um einen Dokumenttypen für CAD-Zeichnungen einzurichten.
.topic 3052
Bezeichnung des Dokumenttypen für CAD-Zeichnungen:
Geben Sie eine beliebige Bezeichnung (z. B. AutoCAD-Zeichnung, MegaCAD Zeichnung) ein, um einen neuen Dokumenttyp für das CAD-Programm zu erstellen.
Wenn Sie einen bereits vorhandenen Dokumenttypen ändern möchten, dann wählen Sie diesen aus der Liste aus.
Hinweis:
Die Bezeichnung des Zeichnungs-Dokumenttypen soll alphabetisch vor dem Bauteil-Dokumenttypen kommen. Dadurch werden beispielsweise bei AutoCAD die per Drag&Drop importierten DWG-Dateien dem Zeichnungs-Dokumenttypen zugeordnet.
.topic 3053
Markieren Sie diese Option, um einen Dokumenttypen für CAD-Zeichnungsbauteile einzurichten.
.topic 3054
Bezeichnung des Dokumententypen für CAD-Bauteile:
Geben Sie eine beliebige Bezeichnung (z. B. CAD-Zeichnungsbauteil) ein, um einen neuen Dokumententyp für CAD-Bauteile zu erstellen. Wenn Sie einen bereits vorhandenen Dokumententypen ändern möchten, dann wählen Sie diesen aus der Liste aus.
.topic 3055
Dateiname der CAD-Programmdatei (z. B. C:\Programme\acad\acad.exe oder C:\MegaCAD\ntmega3d.exe).
Klicken Sie auf [Durchsuchen], um nach der Programmdatei zu suchen.
.topic 3056
Dateiname des CAD-Plot-Programms (z. B. C:\MEGAWIN\PLOT\WPLOT32.EXE).
Klicken Sie auf [Durchsuchen], um nach der Programmdatei zu suchen.
.topic 3061
Schriftkopf erstellen
Wenn diese Option markiert ist, fügt der Office Manager einen Schriftkopf in neue Zeichnungen ein. Attribute wie der Zeichnungsname werden dabei automatisch ausgefüllt.
.topic 3062
Neues Fenster öffnen
wenn diese Option markiert ist, wird beim Öffnen von Zeichnungen immer eine neue CAD-Instanz gestartet. Ist die Option nicht markiert, werden Zeichnungen in ein bereits geöffnetes CAD-Fenster geladen.
.topic 3064
Schriftkopfverzeichnis
Geben Sie bitte das Verzeichnis an, in dem die Schriftkopf-Dateien gespeichert sind.
.topic 4400
Markieren Sie diese Option, um die Verzeichnis-Überwachung zu aktivieren. Der Office Manager übernimmt dann die Dokumente, die im überwachten Verzeichnis gespeichert werden.
.topic 4401
Überwachtes Verzeichnis
Markieren Sie Verzeichnis "Eigene Dateien", um das persönliche Systemverzeichnis "Eigene Dateien" zu überwachen.
Oder markieren Sie die Option Verzeichnis und geben Sie das zu überwachende Verzeichnis im Eingabefeld ein. Klicken Sie auf [Durchsuchen], um das Verzeichnis im Dialogfenster auszuwählen.
Hinweis
Das überwachte Verzeichnis sollte nicht dem Standard-Dokumentenverzeichnis entsprechen. Dies würde zu Problemen führen, wenn Sie ein neues Dokument mit dem Office Manager erstellen. Sie können die Makro-Variablen im Verzeichnis verwenden.
.topic 4403
Markieren Sie diese Option, um auch die Unterverzeichnisse zu überwachen, beispielsweise ein komplettes Laufwerk.
Mit dieser Funktion kann die Dokumentenverwaltung auf Wunsch komplett automatisiert werden: Die Anwender speichern ihre Dokumente einfach in der gewohnten Verzeichnisstruktur. Der Office Manager überwacht die Verzeichnisse und übernimmt neue Dokumente automatisch in das Archiv. Die Attribute (Dokumenttyp, Projekt usw.) werden dabei aus der Verzeichnisstruktur übernommen oder für jedes Dokument manuell bearbeitet.
.topic 4404
Markieren Sie bitte die Verzeichnisse, die vom Office Manager überwacht werden sollen.
Diese Auswahl steht nur zur Verfügung, wenn die Option Unterverzeichnisse überwachen aktiviert ist.
.topic 4405
Dateioperation
Legen Sie fest, ob die importierten Dateien aus dem Quell-Verzeichnis in das Dokumentenverzeichnis kopiert werden sollen.
In das Dokumentenverzeichnis kopieren: Die importierte Dokumentdatei wird in das Standard-Dokumentverzeichnis kopiert und anhand der Vorgaben umbenannt. (s. a. Einstellungen | Dokument).
In das Dokumentenverzeichnis verschieben: Die Dokumentdatei wird in das Dokumentverzeichnis verschoben und anhand der Vorgaben umbenannt. (s. a.  Einstellungen| Dokument).
Im Quell-Verzeichnis belassen: Die Dokumentdatei verbleibt ohne Änderung in dem Verzeichnis, aus dem sie importiert wurde.
Die Dateioperation wird im Importprofil definiert, kann beim Import einer Datei aber auch individuell angepasst werden. Klicken Sie dazu im Eigenschaftendialog auf Durchsuchen hinter Dateiname.
Hinweis:
Wenn die Dokumentendatei nicht im Quell-Verzeichnis verbleibt (der Normalfall), dann kann bei der Verzeichnisüberwachung folgendes Problem entstehen: Sie arbeiten z. B. mit der Textverarbeitung und speichern eine Datei in das überwachte Verzeichnis. Office Manager DMS kommt in den Vordergrund und Sie geben die Attribute ein. Wenn auf OK klicken, kann die Datei nicht verschoben werden, weil sie noch in der Textverarbeitung geöffnet ist. Schließen Sie Dokumentdateien also, bevor Sie den Import in das Archiv durchführen.
.topic 4407
Der Administrator hat den Abbruch der automatischen Dokumentübernahme verboten. Die Schalter Verwerfen und  Abbrechen sind deaktiviert.
Klicken Sie bitte auf OK, um das Dokument zu übernehmen.
Siehe auch: Erweiterte Einstellungen - AllowCancel
.topic 4408
Nur Dateien des angemeldeten Benutzers übernehmen
(Menü Datei | Optionen | Einstellungen)
Markieren Sie diese Option, wenn mehrere Computer ein gemeinsames Server-Verzeichnis überwachen. Sonst würden alle angeschlossenen Computer, auf denen der Office Manager läuft, versuchen, die neue Datei zu importieren.
Voraussetzung für diese Option ist ein Windows NT-System und die korrekte Sicherheitseinstellung auf dem Dateiserver: der Ersteller neuer Dateien muss auch der Eigentümer der Datei sein. Sie können die Einstellung überprüfen, indem Sie im Windows-Explorer die Spalte "Eigentümer" einblenden: hier sollte jeweils der Loginname des Anwenders stehen, der die Datei erstellt hat.
.topic 4501
Primäres Suchfeld Volltext
Der Office Manager ermöglicht neben der Suche in den einzelnen Attributen auch eine sehr schnelle Abfrage über den Gesamtindex. Hier sind die Wörter aus allen Attributen (Projekt, Name, usw.) und den Notizfeldern enthalten. Geben Sie Wörter ein und drücken Sie die Eingabetaste. Die Dokumententabelle enthält jetzt nur noch die Dokumente, die alle gesuchten Wörter enthalten.
Das Suchfeld ist nur sichtbar, wenn der Gesamtindex aktiviert ist (Menü Datei | Optionen | Einstellungen, Seite Volltextindex)
.topic 4510
Aktualisierung des Gesamtindex
Der Statusbalken zeigt den Fortschritt der Volltextindexierung.
.topic 4520
Volltextindex erzeugen
Mit dieser Option legen Sie fest, ob ein Volltextindex erzeugt werden soll.
Kein Index: es wird kein Volltextindex erzeugt.
Index über alle Datenfelder: nur die Inhalte der Datenbankfelder werden indexiert.
Index über alle Datenfelder und Dateiattribute: die Datenbankfelder und erweiterten Dateiattribute (Titel, Autor u. a.) werden indexiert.
Index über alle Datenfelder und Dokumentinhalte: die Datenbankfelder, die erweiterten Dateiattribute und die Dokumentinhalte werden indexiert. Beachten Sie bitte, dass die Indexierung der Dokumente sehr zeitaufwendig sein kann.
.topic 4521
Zahlen ignorieren
Wenn Sie diese Option markieren, dann ist eine Volltextsuche nach Zahlen nicht möglich.
.topic 4522
Mindestanzahl der Zeichen je Wort
Geben Sie bitte die Mindestlänge der Wörter ein, die in den Gesamtindex übernommen werden sollen. Wenn Sie z. B. eine Mindestlänge von 4 eingeben, werden Wörter wie "er", "Sie" und "pro" nicht in den Index übernommen.
.topic 4523
Liste der zu ignorierenden Wörter
Häufig gebrauchte Wörter (z. B. will, sollen, er, aber, deshalb, ...), nach denen nicht gesucht wird, sollten auch nicht in den Gesamtindex übernommen werden. Sie würden den Index unnötig belasten. Klicken Sie auf Öffnen, um die Liste Ihren eigenen Anforderungen anzupassen.
Siehe auch: Erweiterte Einstellungen - Suchwortliste
.topic 4526
Liste der zu indexierenden Dateitypen
Enthält die Dateiendungen aller Dokumenttypen, die indexiert werden sollen. Klicken Sie auf Öffnen, um die Liste Ihren eigenen Anforderungen anzupassen. Geben Sie die Dateiendungen bitte mit dem führenden Punkt an (z. B. ".txt"), es sind keine Jokerzeichen erlaubt!
Beachten Sie auch die erweiterte Einstellung "IndexAttachments" in der admin.ini
.topic 4527
Nur die ersten MB indexieren
Oft ist es nicht sinnvoll, die gesamten Dokumentinhalte zu indexieren. Stellen Sie sich z. B. ein eher unwichtiges PDF-Dokument mit mehreren hundert Seiten oder eine Excel-Tabelle mit zigtausend Zeilen vor. Es würde den Index mit einer Vielzahl Wörter belasten, die nie abgefragt werden.
Wir empfehlen, hier einen Wert von 2 MB anzugeben, um nur die ersten 2 MB der externen Dokumentdateien zu indexieren. Das ist ein guter Kompromiss zwischen Geschwindigkeit und vollständiger Indexierung.
Geben Sie 0 MB ein, um immer die gesamte Datei zu indexieren.
.topic 4542
Suchoption
Wählen Sie bitte, ob die Dokumente alle gesuchten Wörter oder nur mindestens ein gesuchtes Wort beinhalten müssen, um angezeigt zu werden.
.topic 4552
Dateiname der OCR-Software bei Parametersteuerung
oder des Makros bei Makrosteuerung.
OLE-Kennung bei automatisierter OCR.
.topic 4553
Führt einen kurzen Test der gewählten OCR-Software aus.
.topic 4554
Öffnet die Makrodatei im Skripteditor.
.topic 4556
Markieren Sie bitte die Grafikformate, welche von der OCR-Software unterstützt werden (z. B. Tiff).
Wenn Sie Adobe Acrobat (PDF) auswählen, müssen Sie zusätzlich mindestens ein Grafikformat markieren. Der Office Manager bettet die Grafiken dann in diesem Format in das PDF-Dokument ein.
.topic 4565
OCR ausführen auf
Optionale Vorgabe des Computers, auf dem die OCR-Texterkennungssoftware ausgeführt wird. Wenn Sie keinen Computer angeben, dann wird die OCR auf dem Computer ausgeführt, auf dem das Dokument gescannt wurde. Dies ist das Standardverhalten.
Syntax: Computername oder Benutzername@Computername bzw. Domäne\Benutzername@Computername.
Mit Hilfe dieser Option können Sie die Texterkennung zentralisieren, die OCR-Software muss nur auf einem Computer installiert sein.
.topic 4610
Wenn diese Option markiert ist, wird für jedes importierte Dokument der Eigenschaftendialog geöffnet. Sie können dann die Attribute eingeben und das neue Dokument übernehmen, aber auch ablehnen.
Ist die Option nicht markiert, werden neue Dokumente automatisch übernommen, ohne dass der Eigenschaftendialog geöffnet wird.
.topic 4621
Tabelle mit den Feldstandardwerten für importierte Dokumente. Die linke Seite zeigt die Datenfelder der geöffneten Dokument-Datenbank, die rechte Seite die Feldwerte.
Sie können die Makro-Variablen verwenden, um die Dokumentattribute beispielsweise aus dem Dateinamen zu generieren. Die Auswahllisten in der Spalte Feldwerte beinhalten Beispiele für den Verwendung der Makro-Variablen.
Klicken Sie für weitere Informationen auf den Schalter Hilfe.
.topic 4622
Wenn diese Option markiert ist, werden die Dokumentattribute von der Auswahl im Projektnavigator und der Gruppierung übernommen.
Die Option ist nur in Importprofilen sichtbar, wenn die Dokumente automatisch importiert werden. Beim manuellen Import per Drag&Drop werden die Attribute immer berücksichtigt.
Beispiel:
Die Tabelle ist nach dem Feld "Status" gruppiert und ein Dokument mit dem Status "Normal" ist in der Tabelle markiert. Das neue Dokument erhält auch den Status "Normal", wenn diese Option markiert ist.
.topic 4711
Deaktiviert: kein Faximport.
Manuell auf neue Faxe prüfen: neue Faxe werden mit dem Menübefehl Dokument | Neu | Faxe importieren eingelesen.
Neue Faxe automatisch importieren: es wird regelmäßig nach neuen Faxen gesucht.
Vollautomatisch: neue Faxe werden automatisch importiert, ohne dass der Eigenschaftendialog geöffnet wird.
.topic 4712
Verzeichnis, in welchem die Faxsoftware eingehende Faxe abspeichert.
Sie können eine Dateimaske angeben, beispielsweise "G:\Faxeingang\*.*" für alle Dateien oder "G:\Faxeingang\*.tif" nur für Tiff-Dateien.
.topic 4713
Dokumenttyp für Faxe.
Wählen Sie im Menü Datei | Optionen den Befehl Dokumenttyp, wenn Sie einen Typen für Faxe definieren möchten.
.topic 4714
Projekt, welchem die neuen Faxe zugeordnet werden.
Beim manuellen Faximport wird diese Vorgabe aber durch ein eventuell markiertes Projekt im Navigator überschrieben.
.topic 4715
Status für die neuen Faxe. Beispielsweise können Sie den Status "zu bearbeiten" vorgeben.
.topic 4716
Bei automatischen Faximport wird dieser Benutzer zur Bearbeitung neuer Faxe aufgefordert.
Alternativ können Sie hier auch den Namen eines zuständigen Computers angeben. Markieren Sie in diesem Fall auch die Option Eigenschaftendialog für Fax öffnen auf der Seite Importieren.
Die Änderung dieser Option wirkt sich erst nach einem Programmneustart aus.
.topic 4717
Wenn diese Option markiert ist, wird nach dem vollautomatischen Faximport für den zuständigen Benutzer eine Tätigkeit erstellt, die ihn zum Bearbeiten des Dokumentes auffordert.
.topic 4718
Import-Abbruch zulassen
Deaktivieren Sie diese Option, um zu vermeiden, dass der Import durch den Anwender abgebrochen wird. In der Regel wird der Abbruch aber zugelassen - der Anwender kann dann im Eigenschaften-Dialog auf Abbrechen klicken und das Fax verwerfen oder später importieren.
.topic 5002
Quelldatei, aus der die Datensätze importiert werden sollen. Klicken Sie bitte auf die Schaltfläche [Durchsuchen] und wählen Sie den Dateinamen im Dialogfenster aus.
.topic 5003
Tabelle mit den Feldzuordnungen. Die linke Spalte zeigt alle Datenfelder der Quelldatei, die rechte Spalte die Felder des Office Manager-Archivs, in welche die Daten kopiert werden.
.topic 5004
Startet den Import. Alle Datensätze aus der Quelldatei werden in das geöffnete Office Manager-Archiv kopiert.
.topic 5005
Liest die Feldzuordnungen aus einer Map-Datei.
Beachten Sie, dass die Zuordnungen in der Tabelle überschrieben werden. Wenn Sie bereits Zuordnungen gemacht haben, können Sie diese zuvor in einer anderen Map-Datei speichern.
.topic 5006
Speichert die Feldzuordnungen in einer Map-Datei.
Nutzen Sie diese Funktion, wenn Sie die Feldzuordnungen in der Tabelle öfters verwenden möchten.
.topic 506
Dateiexistenz prüfen (Menü Datei | Datenbank)
Es wird überprüft, ob die in den Datensätzen zugeordneten Dokumentdateien vorhanden sind.
Im Anschluss an die Prüfung wird eine Suche nach allen Dokumenten erstellt, die ungültige Dateiverknüpfungen enthalten. Beachten Sie bitte, dass auch die Dokumentversionen überprüft werden. Die Suche kann also Datensätze enthalten, bei denen nur die Datei einer Dokumentversion nicht mehr vorhanden ist.
.topic 5063
Layout wählen
Mit Auswahl der Layoutdatei legen Sie das aktuelle Design der Programmoberfläche fest.
Klicken Sie für eine umfangreiche Hilfe bitte auf den letzten Listeneintrag [Hilfe].
.topic 5071
Raster
Einstellung der Rasterweite, an der die Komponenten ausgerichtet werden. Bei einer Einstellung von beispielsweise "4", werden die Komponenten beim Verschieben um jeweils 4 Bildpunkte versetzt.
.topic 5072
Auswahlmodus
Klicken Sie auf diese Schaltfläche, um bestehende Komponenten mit der Maus auszuwählen.
.topic 5073
Freien Text hinzufügen
Klicken Sie bitte auf diese Schaltfläche und positionieren Sie anschließend das Textfeld im Layout.
.topic 5074
Linie hinzufügen
Mit diesem Befehl können Sie das Layout gestalten und Linien hinzufügen.
.topic 5075
Gruppierungsbox hinzufügen
Fügt dem Layout eine beschriftete Box hinzu, in der andere Komponenten gruppiert dargestellt werden.
.topic 5076
Hintergrundgrafik hinzufügen
Sie können eine Grafik einfügen und das Layout ansprechend gestalten.
Tipp: Fügen Sie nur dezente Bilder ein.
.topic 5077
Feldbeschriftung hinzufügen
Feldbeschriftungen sind Textfelder, welche die Bezeichnung von Datenbankfeldern zeigen. Sie werden im Layout normalerweise links neben oder über einem Datenbankfeld positioniert.
Siehe auch: Menü Datei | Datenbank | Anpassen | Felder definieren.
.topic 5078
Datenfeld hinzufügen
Fügt ein Eingabefeld für Dokumentattribute (Datenbankfelder) ein.
.topic 5079
Komponente löschen
Um eine Komponente aus dem Layout zu löschen, markieren Sie die Komponente bitte zuerst mit der Maus und klicken Sie anschließend auf diese Schaltfläche.
.topic 508
Gruppierter CSV-Export
Auch der Datenbankexport in CSV verwendet die Einstellungen der sichtbaren Dokumententabelle inklusive der Gruppierung. In der Regel sind CSV-Daten aber ohne Gruppierung erforderlich.
Klicken Sie auf Nein, um eine CSV-Datei ohne Gruppierung für den Datenaustausch mit anderen Programme zu erzeugen. Oder auf Ja, falls die Gruppierung erwünscht ist.
.topic 5080
Mausschaltfläche hinzufügen
Fügt einen Schalter zum Aufruf von Makros ein.
.topic 5081
Text
Hier geben Sie die Beschriftung für freie Textfelder und Gruppierungsboxen, bzw. den Dateinamen für Grafiken ein.
.topic 5082
Datenfeld
Wählen Sie bitte das Datenbankfeld aus der Liste, welches der markierten Datenfeld-Komponente zugeordnet werden soll.
.topic 5083
X (links)
Gibt den Abstand der Komponente vom linken Rand an. Sie können die Komponente mit der Maus verschieben oder den gewünschten Abstand hier eingeben.
Der Abstand wird in Bildpunkten (Pixel) angegeben.
.topic 5084
Y (oben)
Gibt den Abstand der Komponente vom oberen Rand an. Sie können die Komponente mit der Maus verschieben oder den gewünschten Abstand hier eingeben.
Der Abstand wird in Bildpunkten (Pixel) angegeben.
.topic 5085
Breite
Gibt die Breite der Komponente in Bildpunkten (Pixel) an. Sie können die Größe der Komponente mit der Maus ändern oder die gewünschte Breite hier eingeben.
Die Größe von Textfeldern kann nicht geändert werden, wenn die Option Größe der Textfelder anpassen markiert ist.
.topic 5086
Höhe
Gibt die Höhe der Komponente in Bildpunkten (Pixel) an. Sie können die Größe der Komponente mit der Maus ändern oder die gewünschte Höhe hier eingeben.
Die Größe von Textfeldern kann nicht geändert werden, wenn die Option Größe der Textfelder anpassen markiert ist.
.topic 5087
Umriss
Gibt an, ob die Linien-Komponente ein Rechteck oder eine einfache Linie darstellt.
.topic 5088
Transparent (Menü Ansicht | Anpassen | Layout einwerfen)
Markieren Sie diese Option, wenn die markierte Grafik transparent dargestellt werden soll.

Flach
Mausschaltfläche ohne 3D-Rand zeichnen.

Überschrift
Großes Textfeld: gemäß den Windows Design-Richtlinien wird der Text in blauer Farbe mit einer Schriftgröße von 11 Pixeln dargestellt.

Zeilenumbruch
Bricht lange Textzeilen automatisch um, damit sie vollständig sichtbar sind.
.topic 5089
Makro
Enthält das Makro, welches beim Klick auf den Schalter ausgeführt wird.
Beispiel: {ExecuteMacroFile:filename.omac}
.topic 509
Beendet das Programm.
.topic 5111
Klicken Sie bitte auf Online-Registrierung, um das Web-Formular für die Registrierung in Ihrem Browser zu öffnen. Den Freigabecode erhalten Sie anschließend per E-Mail.
.topic 5112
Geben Sie den Freigabecode ein und klicken Sie auf Freischalten. Das Programm arbeitet anschließend als Vollversion.
.topic 5114
Adressdaten für die Online-Registrierung.
Mit diesen Daten werden die Felder in unseren Web-Formularen ausgefüllt - spart doppelte Tipparbeit.
.topic 5115
Ihre gültige E-Mail-Adresse. Der Freigabecode wird per Mail an diese Adresse gesendet.
.topic 5116
Klicken Sie bitte auf Enterprise-Edition, Jetzt testen, wenn Sie jetzt noch keine Vollversion bestellen und die Software als Enterprise-Edition testen möchten. Diese Option steht nur für einen begrenzten Zeitraum zur Verfügung.
.topic 5117
Zeigt an, wie viele Tage die Software noch als Demoversion gestartet werden kann.
.topic 5118
Klicken Sie bitte auf Pro-Edition, Jetzt testen, wenn Sie jetzt noch keine Vollversion bestellen und die Software als Pro-Edition testen möchten. Diese Option steht nur für einen begrenzten Zeitraum zur Verfügung.
.topic 512
Dokument erneut öffnen (Menü Dokument | Erneut öffnen)
Das Untermenü enthält eine Liste mit den zuletzt geöffneten Dokumenten. Klicken Sie auf einen Eintrag, um das Dokument erneut im zuständigen Anwendungsprogramm zu öffnen.
.topic 515
Übersicht drucken
Erstellt eine HTML-Datei mit den Dokumentdatensätzen der aktuellen Suche und öffnet die Datei im Browser. Nutzen Sie diese Funktion, wenn Sie eine Übersicht der Dokumente ausdrucken möchten.
Sicherheitshinweis
Wenn Sie ein verschlüsseltes Archiv drucken, wird die temporäre HTML-Datei anschließend gelöscht. Hierzu öffnet sich ein Dialogfenster mit dem Hinweis, bestätigen Sie dieses bitte nach dem Ausdruck.
.topic 516
Dokumente mit einer anderen Anwendung öffnen
(Menü Dokument)
Wählen Sie bitte eine Anwendung aus dem Untermenü, um die markierten Dokumente in dieser Anwendung zu öffnen.
Hinweise:
Sie können mehrere Dokumente markieren und gleichzeitig öffnen. Achten Sie darauf, dass Sie nur Dokumente markieren, die mit der gewählten Anwendung kompatibel sind.
Wenn Sie den Eintrag Programm auswählen verwendet, wird der Befehl nur für das aktuelle Dokument und nicht für alle markierten ausgeführt.
.topic 524
Suche zurücksetzen (Menü Suchen | Zurücksetzen)
Die eingegebenen Suchkriterien werden gelöscht, die Tabelle zeigt wieder alle Dokumente an.
Wenn die Umschalttaste gedrückt ist, dann wird die Markierung im Projektnavigator nicht zurückgesetzt.
.topic 526
Felder leeren (Menü Suchen)
Löscht alle eingegebenen Suchbegriffe.
Wenn die Umschalttaste gedrückt ist, dann wird die Markierung im Projektnavigator nicht gelöscht.
.topic 528
Befehl Systemmenü im lokalen Popupmenü der Tabelle.
Öffnet das lokale Menü des Windows-Explorers. Sie können das Dokument mit Systemfunktionen öffnen und bearbeiten.
Diese Funktion ist in GoBD-Archiven gesperrt.
.topic 530
Anmeldung für die Administratorebene
(Menü Datei | Optionen | Administrator)
Aktiviert den Zugriff auf die Administratorebene. Um das System im Netzwerkbetrieb zu schützen, sollten Sie ein Passwort für die Administratorebene definieren.
.topic 538
Menüband zurücksetzen (Menü Ansicht | Anpassen | Menüs zurücksetzen)
Setzt die Menüs und Symbolleisten auf den Auslieferungszustand zurück.
.topic 540
Übersicht der Office Manager-Hilfethemen, Hilfe-Index und -Suche.
Für eine Übersicht wählen Sie bitte Hilfethemen.
Wählen Sie Direkthilfe und klicken Sie anschließend auf ein Element, um weitere Informationen zu diesem Element zu erhalten.
Benutzerhandbuch öffnet das PDF-Handbuch.
Im Menü Kurzanleitungen finden Sie PDF-Dokumente zu ausgewählten Themen.
Der Eintrag Info zeigt eine Infobox zum Programm.
.topic 541
Benutzerhandbuch (Menü Hilfe)
Öffnet das PDF-Benutzerhandbuch.
.topic 5410
Klicken Sie auf Starten, um die Änderungen durchzuführen.
Sie benötigen Administrator-Rechte zum Ausführen dieser Funktion. Überprüfen Sie Ihre Eingaben sehr sorgfältig, die Änderungen können nicht rückgängig gemacht werden.
.topic 5411
Geben Sie den zu ändernden Pfad ein. Es werden alle Dokumente angepasst, deren Dateinamen mit diesem Pfad beginnen.
Beispiel: Bestehender Pfadeintrag = "C:\Eigene Dateien" und in Ändern in = "G:\Daten". Die Datei "C:\Eigene Dateien\Projektname\Dokument.txt" wird in "G:\Daten\Projektname\Dokument.txt" geändert.
.topic 5412
Geben Sie den neuen Pfad ein.
Beispiel: Bestehender Pfadeintrag = "C:\Eigene Dateien" und in Ändern in = "G:\Daten". Die Datei "C:\Eigene Dateien\Projektname\Dokument.txt" wird in "G:\Daten\Projektname\Dokument.txt" geändert.
.topic 5413
Legt fest, ob nur die Datenbank aktualisiert oder auch die Dokumentdateien kopiert werden sollen.
nicht kopieren: Der Datenbankeintrag wird aktualisiert, wenn die Datei bereits im neuen Verzeichnis vorhanden ist.
in das neue Verzeichnis kopieren: Der Datenbankeintrag wird aktualisiert und die Datei kopiert.
in das neue Verzeichnis verschieben: Der Datenbankeintrag wird aktualisiert und die Datei verschoben.
.topic 545
Info über den Office Manager, Ansprechpartner für weitere Informationen.
.topic 546
Kurzanleitungen
Enthält eine Liste mit Kurzanleitungen zu den wichtigsten Programmfunktionen.
.topic 5510
Datenbank komprimieren
Markieren Sie diese Option, um die geöffneten Datenbanken zu überprüfen und den nicht mehr genutzten Speicherplatz freizugeben. Diese Funktion sollte z. B. ausgeführt werden, nachdem viele Datensätze in der Dokumententabelle gelöscht wurden. Bei Firebird ist diese Funktion nur für defekte Datenbanken erforderlich.
Diese Option gilt nur für Datenbanken im MS Access- und SQLite-Format.
.topic 5511
Volltextindex und Dateiattribute aktualisieren
Synchronisiert die Archivdatenbank mit dem Dateninhalt und den Attributen.
Der Index wird bei Änderungen der Dokumente automatisch aktualisiert. Wenn Sie ein Dokument aber ohne Office Manager öffnen, werden eventuelle Änderungen nicht berücksichtigt.
Aktivieren Sie bitte bei der Datenbankpflege diese Option, um alle Dokumentdateien, die seit der letzten Indexierung geändert wurden, erneut einzulesen.
.topic 5512
Daten-Integrität sicherstellen
Überprüft die Datenintegrität (Schlüsselnummern, verbundene Tabellen) und führt bei Bedarf erforderliche Korrekturen durch.
Bereinigt die Liste der bekannten Datenbanken, welche beispielsweise für die Spalte "Datenbank" in der Aufgabenverwaltung relevant ist.
.topic 5513
Index für Kontakterkennung
Neue Dokumente werden, sofern möglich und gewünscht, automatisch einem Kontakt zugeordnet. Beispielweise über die eindeutige E-Mail-Adresse, IBAN oder Kundennummer. Der Index mit den eindeutigen Phrasen wird automatisch gepflegt.
Markieren Sie diese Optionen, falls Sie den Index vollständig neu erstellen möchten.
.topic 5604
Klicken Sie auf Starten, um den Datenabgleich auszuführen.
.topic 5621
Dateiname des geöffneten Dokumentenarchivs. Dies ist die ursprüngliche (originale) Datenbank, die z. B. im Firmennetzwerk gespeichert ist.
Es wird nur die aktuelle Suche der Datenbank synchronisiert.
.topic 5622
Wählen Sie den Dateinamen der synchronen Dokumentendatenbank. Dies ist das ausgelagerte Archiv, das beispielsweise auf einem Notebook gespeichert wurde.
.topic 5623
Datenpriorität
Legt fest, welche Datenbank die gültigen Dokumentattribute enthält. Wählen Sie:
Daten des geöffneten Archivs, wenn die Attribute der geöffneten Datenbank gültig sind. Die synchrone Datenbank wird aktualisiert.
Daten des Synchronarchivs, wenn die Attribute der synchronen Datenbank gültig sind. Die geöffnete Datenbank wird aktualisiert.
.topic 5625
Sicherungskopien
Wenn diese Option markiert ist werden alle Dateien, die durch die Synchronisierung ersetzt werden, vor dem Überschreiben gesichert. Die Sicherungen befinden sich im selben Verzeichnis, der Dateiendung wird eine Tilde ~ vorangestellt. Es wird max. eine Sicherung erstellt, ältere werden also überschrieben.
Das Aktivieren dieser Option vermeidet Datenverlust und ist für die Datensicherheit empfohlen.
.topic 5626
Wenn die Option markiert ist werden auch die Tätigkeiten synchronisiert. Falls Sie die Aufgabenverwaltung des Office Managers nicht nutzen, können Sie die Markierung entfernen, um den Datenabgleich zu beschleunigen.
.topic 5630
Wenn die Option markiert ist wird eine Logdatei mit den durchgeführten Änderungen erstellt. Die Datei beinhaltet Informationen über die geänderten Attribute und ersetzen Dateien.
.topic 5681
Klicken Sie auf OK, um die markiere Datei zu übernehmen. Die Zieldatei wird überschrieben!
.topic 5682
Klicken Sie auf Alle, um die Auswahl für alle zu synchronisierenden Dateien zu übernehmen. Es erfolgt keine weitere Rückfrage mehr.
.topic 5683
Klicken Sie auf Abbrechen, um die Synchronisierung abzubrechen.
.topic 5685
Die ursprüngliche Datei (z. B. im Firmennetzwerk) bleibt erhalten. Die synchrone Datei (z. B. auf dem Notebook) wird mit der ursprünglichen überschrieben.
.topic 5686
Die synchrone Datei (z. B. auf dem Notebook) bleibt erhalten. Die ursprüngliche Datei (z. B. im Firmennetzwerk) wird mit der synchronen überschrieben.
.topic 5687
Die jeweils neuere Datei (die zuletzt bearbeitete) bleibt erhalten. Die ältere wird mit der neueren überschrieben.
.topic 5688
Keine Synchronisierung, beide Dateien bleiben erhalten.
.topic 5801
Datenbank | Eigenschaften
(nur Enterprise-Edition)
Einstellungen und Verbindungsparameter der geöffneten Server-Datenbanken bearbeiten.
Dieser Befehl ist nur aktiviert, wenn eine .omcs-Dokument-, .crmcs-Kontakt- und/oder .aplcs-Anwendungsdatenbank geöffnet ist.
.topic 5802
Verbindungsparameter der geöffneten Server-Datenbanken. Klicken Sie für ausführliche Informationen bitte auf Hilfe.
ACHTUNG: Gehen Sie bei Änderungen der Verbindungsparameter sehr sorgfältig vor.
.topic 5803
Bezeichnung des Datenbanktreibers.
Um einen anderen Treiber zu wählen, markieren Sie bitte die Spalte Verbindung und klicken Sie auf die Schaltfläche [...].
.topic 5804
Kompletter Dateiname der .omcs-, .crmcs oder .aplcs-Datei. In dieser Textdatei sind die Verbindungsparameter für die Server-Datenbank gespeichert.
.topic 5908
Zurücksetzen
Die Schrifteinstellungen auf Standardwerte zurücksetzen und die Grafik entfernen.
.topic 5909
Bezeichnung
Der Name des Projektes. Gleichheitszeichen und Backslash sind nicht erlaubt.
.topic 5910
Schriftfarbe
Farbe der Projektnamen im Navigator.
.topic 5911
Hintergrundfarbe
Der Projektname wird im Navigator mit dieser Farbe hinterlegt.
.topic 5912
Wählen Sie bitte eine Grafik aus, die im Projektnavigator vor dem Projektnamen dargestellt werden soll.
.topic 5913
Beschreibung
Geben Sie einen kurzen Hinweis oder eine längere Projektbeschreibung ein.
Beachten Sie auch die automatische Projekterkennung mit {AutoCaptSelectionListFindItem} und {SelectionListFindItem}
.topic 5914
Formatiert den Projektnamen fett und hebt ihn somit hervor.
.topic 5915
Formatiert den Projektnamen kursiv.
.topic 5918
Stellt den Projektnamen druchgestrichen dar.
.topic 5919
Warnung
Hervorhebung von Dokumenten und Kontakten im Eigenschaften-Dialog.
Beispiel: Sie verwalten Kontakte mit einem Statusfeld. Wenn der Status "Gesperrt" ist, möchten Sie verhindern, dass dies übersehen wird. Hierzu fügen Sie der Auswahlliste den Wert "Gesperrt" hinzu, markieren die Option Warnung und geben eine auffällige Hintergrundfarbe an. Die Farbmarkierung sehen Sie dann bei gesperrten Kontakten im Eigenschaftendialog am untere Rand.
.topic 6001
Übersicht der Office Manager-Hilfethemen, Hilfe-Index und Suche. Für eine Übersicht der gesamten Online-Dokumentation wählen Sie Hilfethemen.
Für die Dokumentation der Textverarbeitung klicken Sie auf Hilfe.
Der Eintrag Info zeigt eine Infobox zum Programm.
.topic 6002
Speichert das interne Dokument als Text-Datei.
.topic 6003
Druckt das Dokument.
.topic 6004
Hilfe- und Supportseiten im Internet. Siehe auch Menü Datei | Hilfe.
.topic 6010
Macht den letzten Befehl rückgängig oder löscht die letzte Eingabe.
.topic 6011
Macht nach einer Rückfrage sämtliche Änderungen seit dem Öffnen des Dokumentes rückgängig.
.topic 6012
Löscht den markierten Text ohne ihn in der Zwischenablage abzulegen.
.topic 6013
Fügt den Inhalt der Zwischenablage an der Einfügemarke ein und ersetzt den markierten Text.
.topic 6014
Wiederholt einen Befehl, der zuvor rückgängig gemacht wurde.
.topic 6030
Öffnet das Dialogfenster "Schriftart". Sie können hiermit die Schriftart, Größe, Farbe usw. des markierten Textes ändern.
.topic 6031
Ändert die Schriftart des markierten Textes. Wählen Sie eine Schriftart aus der Liste.
.topic 6032
Ändert den Schriftgrad (Größe) des markierten Textes.
.topic 6033
Speichert die aktuelle Schriftart als Standard-Vorgabe für den Editor. Wenn Sie ein neues Dokument erstellen, dann ist diese Schriftart voreingestellt.
.topic 6035
Formatiert den markierten Text fett, bzw. entfernt die Formatierung fett.
.topic 6036
Formatiert den markierten Text kursiv, bzw. entfernt die Formatierung kursiv.
.topic 6037
Unterstreicht den markierten Text, bzw. entfernt die Formatierung unterstrichen.
.topic 6038
Zwischenablage überwachen
Wenn dieser Schalter gedrückt ist, wird der Text aus der Zwischenablage automatisch eingefügt:
In einer anderen Anwendung Text markieren und in die Zwischenablage kopieren (z. B. Strg+C). Der Text wird dann hier in den Editor eingefügt.
.topic 604
Tabelle editieren
Aktivieren Sie die Funktion, um die Daten direkt in der Tabelle zu bearbeiten.
.topic 6041
Richtet den markierten Text linksbündig aus.
.topic 6042
Zentriert den markierten Text.
.topic 6043
Richtet den markierten Text rechtsbündig aus.
.topic 6045
Fügt den markierten Absätzen Aufzählungszeichen hinzu.
.topic 606
Datentabelle sortieren
Klicken Sie mit der linken Maustaste auf die Spaltenüberschrift, um die Tabelle anhand der Spalte zu sortieren. Ein erneuter Klick ändert die Sortierreihenfolge (auf- oder absteigend).
Oder:
Klicken Sie mit der rechten Maustaste auf die Überschrift und wählen Sie im Kontextmenü den Eintrag Aufsteigend sortieren bzw. Absteigend sortieren. Halten Sie um Umschalttaste gedrückt, um nach mehreren Feldern zu sortieren.
.topic 607
Feld ausblenden (lokales Menü der Dokumententabelle)
Entfernt die ausgewählte Spalte aus der sichtbaren Dokumenttabelle. Die Daten sind weiterhin vorhanden, werden aber in der Tabelle nicht mehr angezeigt. Um Spalten wieder hinzuzufügen wählen Sie bitte Ansicht | Anpassen | Feldauswahl.
.topic 608
Spalten ausrichten
Klicken Sie mit der rechten Maustaste auf die Spaltenüberschrift und wählen Sie im Kontextmenü den Eintrag Ausrichten (Links, Rechts oder Zentriert), um die Daten in dieser Spalte entsprechend auszurichten
.topic 609
Spaltenbreite anpassen
Sie können die Breite der einzelnen Tabellenspalten einfach mit der Maus ändern. Ziehen Sie dazu die Linie rechts neben dem Spaltenkopf auf die gewünschte Breite.
Oder:
Klicken Sie mit der rechten Maustaste auf den Spaltenkopf. Wählen Sie im Kontextmenü den Eintrag Optimale Breite, um die Breite der ausgewählten Spalte, bzw. Optimale Breite aller Spalten, um die Breite aller Spalten zu optimieren. Die Breite wird dann automatisch an die Breite der enthaltenen Daten angepasst.
.topic 611
Baumknoten öffnen
Öffnet alle Baumknoten.
.topic 612
Baumknoten schließen
Schließt alle Baumknoten.
.topic 614
Wenn die Option Immer im Vordergrund aktiviert ist wird das Fenster vor allen anderen Fenster im Vordergrund dargestellt.
Wenn die Option deaktiviert ist, kann das Fenster von anderen verdeckt werden.
.topic 615
Immer geöffnet
Die Baumknoten werden automatisch expandiert und immer geöffnet dargestellt.
.topic 616
Dokumente gruppieren
Sie können die Dokumente gruppieren, indem Sie einen Tabellenkopf per Drag&Drop auf diese Fläche ziehen.
Beispiel: Klicken Sie mit der linken Maustaste auf den Tabellenkopf Dokumenttyp, halten Sie die Maustaste fest, schieben Sie die Maus auf diese Fläche und lassen Sie die Maustaste wieder los. Die Dokumente werden nun anhand des Dokumententyps gruppiert.
.topic 617
Baumknoten öffnen oder schließen
[+] öffnet den Baumknoten,
[-] schließt ihn.
.topic 618
Sie können die Spaltenbreite und Zeilenhöhe mit der Maus vergrößern und verkleinern, indem Sie die Trennlinie zwischen zwei Spalten bzw. Zeilen verschieben.
.topic 619
Die linke schmale Spalte enthält die Markierung für den aktuellen Datensatz.
.topic 620
Dokumente nach Datum gruppieren
Wählen Sie bitte aus, wie genau nach Datum gruppiert werden soll.
Beispielsweise nach Tagen, um alle Dokumente eines Tages unter einem Konten zusammen zu fassen.
.topic 630
Oberhalb der Dokumententabelle finden Sie eine kurze Information über die aktuelle Suche nach Dokumenten.
.topic 631
Symbol der Anwendung, mit der das markierte Dokument geöffnet wird.
.topic 7002
Eigenschaften der markierte Tätigkeit ändern.
.topic 7003
Suchen (in der Aufgabenverwaltung)
Fragt die Daten des Terminplaners neu aus der Datenbank ab und öffnet das Erinnerungsfenster erneut, falls dieses geschlossen wurde. Nutzen Sie dies im Netzwerkbetrieb bitte regelmäßig, um die Änderungen anderer Anwendenden zu sehen.
.topic 7004
Felder leeren (in der Aufgabenverwaltung)
Springt zum heutigen Datum und schaltet zur Monatsansicht.
.topic 7005
Terminplaner
Das Haupt-Steuerelement der Aufgabenverwaltung.
Die verschiedenen Ansichten, wie Tages- oder Monatskalender, werden im Menü Aufgabe | Anordnen gewählt. Den Bereich können Sie auch mit der Zeitleiste und dem Datumsnavigator einstellen.
Doppelklick öffnet eine Aufgabe zur Ansicht und Bearbeitung.
Drag&Drop: Aufgaben können beispielsweise auch mit der Maus in andere Tage verschoben werden.
.topic 7007
Suchen | Dokumente
Sucht die mit der Aufgabe oder dem Kontakt verknüpften Dokumente. Die Ansicht wechselt automatisch zur Dokumententabelle.
.topic 7009
Bereits erledigte Aufgaben werden nicht gezeigt, wenn dieses Optionsfeld markiert ist.
.topic 7010
Suchen | Kontakte
Sucht die mit dem Dokument bzw. der Aufgabe verknüpften Kontakt. Die Ansicht wechselt automatisch zur Kontakttabelle.
.topic 7011
Die Tabelle enthält eine Liste der geplanten Tätigkeiten für dieses Dokument bzw. diesen Kontakt.
.topic 7021
Menü Aufgabe | Navigieren
Heute springt im Kalender zum heutigen Tag.
Datum: Dialogauswahl zur Anordnung und Markierung eines Datums.
Nächste 7 Tage springt zum heutigen Tag und ordnet die nächsten sieben Tage in einer Wochenansicht an.
.topic 7022
Menü Aufgabe | Anordnen
Tag stellt einen einzelnen Tag im Terminplaner dar.
Mo.-Fr. stellt eine Arbeitswoche ohne Samstag und Sonntag dar..
Woche: Gesamte Woche mit Samstag und Sonntag.
Monat: Ansicht eines Monats.
Zeitleiste ordnet die Aufgaben entlang einer Zeitskala von links nach rechts chronologisch an.
Jahr: Kalenderansicht über ein komplettes Jahr.
Balken zeigt die Aufgaben als horizontale Balken entlang der Zeitachse an.
Agenda zeigt die Aufgaben untereinander in einer tabellarischen Ansicht.
.topic 7023
Menü Aufgabe | Ansicht | Anpassen
Zeitskalierung setzt die Größe der Zeitauswahlleiste auf die angegebenen Minutenblöcke.
Datumsnavigator legt fest, ob und wo der kleine Monatskalender dargestellt wird.
Wochenende komprimieren: Samstag und Sonntag teilen sich in der Wochenansicht eine Tageszelle.
Arbeitsstunden schaltet in der Zeitleiste die Sichtbarkeit von Nicht-Arbeitszeiten um (s. a. Programmeinstellungen | Terminplaner).
An Zeitschlitzen fangen verbindet Benutzeraufgaben visuell mit den Zeitblöcken im Planungsbereich.
.topic 7024
Menü Aufgabe | Ansicht | Ressourcen
Ressourcen: Aufgaben können verschiedenen Ressourcen, beispielsweise Mitarbeitenden, Teams und Abteilungen zugewiesen sein. Mit Klick auf den oberen Bereich des Mausschalters im Menü öffnen Sie das Dialogfenster zum Ein- oder Ausblenden von Aufgaben dieser Ressourcen.
Auch beim Datumsnavigator finden Sie ein Eingabefeld mit den gewählten Ressourcen und einem Mausschalter zum Öffnen des Dialogs.

Aufgaben filtern:
Markieren Sie die Mitarbeitenden, dessen Aufgaben im Kalender sichtbar sein sollen. Wenn keine Ressource markiert ist, dann werden alle Aufgaben eingeblendet.
Ressourcen | Gruppierung zurücksetzen stellt die Aufgaben aller Ressourcen in einer gemeinsamen Ansicht dar.
Ressourcen | Nach Datum gruppieren: Eigener Terminplaner für jeder gewählte Ressource mit Gruppierung nach Datum.
Ressourcen | Nach Ressource gruppieren: Eigener Terminplaner für jeder gewählte Ressource mit Gruppierung nach Ressourcen.
.topic 7025
Datumsnavigator
Markieren Sie einen oder mehrere Tage, um den Terminplaner auf den gewünschten Zeitabschnitt einzustellen.
Der Navigator kann mit Aufgabe | Ansicht | Anpassen | Datumsnavigator positioniert werden.
.topic 7026
Zeitauswahlleiste
Auswahl des im Terminplaner gezeigten Zeitintervalls. Sie können den Bereich mit der Maus verschieben und in der Breite ändern.
.topic 8002
Liste der Datenbankfelder. Die in Klammern geschriebenen Felder (z. B. "[DocID]") werden vom Programm benötigt und können nicht gelöscht oder umbenannt werden. Sie können aber die im Programm sichtbare Beschreibung und die Feldgröße anpassen.
Zum Suchen nach Feldern klicken Sie bitte auf die Lupe oberhalb der Liste.
.topic 8005
Feld suchen
Klicken Sie bitte auf diesen Mausschalter und geben Sie einen Teil des Feldnamen oder der Bezeichnung ein, um ein Datenfeld zu finden.
Oder: Klicken Sie auf die Feldliste und geben Sie die ersten Buchstaben des Feldnamen ein. Es wird zum passenden Feld gesprungen.
.topic 8011
Klicken Sie auf den Schalter Neu, um ein neues Datenbankfeld zu erstellen. Geben Sie anschließend die Daten ein und speichern Sie das Feld mit einem Klick auf Übernehmen.
Klicken Sie bitte auf den Pfeil, um eine Liste mit vordefinierten Felder zu öffnen.
.topic 8012
Klicken Sie auf den Schalter Löschen, um das markierte Datenbankfeld endgültig zu entfernen. Alle Daten in diesem Feld gehen verloren!
In SQLite-Datenbanken können keine Felder gelöscht oder umbenannt werden.
.topic 8013
Klicken Sie auf den Schalter Übernehmen, um das neue Feld anzulegen oder die Änderungen am Feld zu speichern.
.topic 8014
Klicken Sie auf den Schalter Abbrechen, um die Änderungen zu verwerfen.
.topic 8015
Klicken Sie auf den Schalter DB-Login, wenn Sie sich mit dem Logindialog an der Datenbank anmelden möchten. Dies ist nur erforderlich, wenn die derzeitigen Datenbank-Benutzerrechte keine Änderungen an der Datenbank erlauben.
Der Befehl steht nur für SQL-Datenbanken zur Verfügung und wird bei Windows-Authentifizierung vom Datenbanksystem ignoriert.
.topic 8101
Geben Sie die maximale Zeichenanzahl für den Datentyp Zeichenkette ein. Mögliche Werte liegen zwischen 2 und 254.
Unnötig große Felder gehen zu Lasten der Performance.
Das System verweigert eine Kürzung des Datenfeldes, wenn dies zu einem Datenverlust führen würde.
.topic 8102
Geben Sie den Namen des Datenbankfeldes ein. Erlaubt sind nur Buchstaben, Zahlen und der Unterstrich "_", verwenden Sie keine Umlaute (ä, ö, ü). Feldnamen dürfen nicht mit "OM" beginnen oder den reservierten SQL-Begriffen entsprechen.
Beachten Sie beim Ändern des Namen eines bestehenden Feldes, dass dieser Name z. B. von der Makroverarbeitung, den Layouts und der Schriftkopferzeugung verwendet wird.
Dieser interne Name ist für den Anwender nicht sichtbar. Die sichtbare Bezeichnung können Sie auf der Seite Ansicht im Eingabefeld Beschreibung ändern.
.topic 8103
Kommentar
Sie können hier beliebige Hinweise und Kommentare eingeben oder das Feld beispielsweise als Zwischenablage für den Test von Makrovariablen nutzen. Programmintern werden diese Daten nicht verwendet.
.topic 8104
Bei geschützten Datenfelder (Namen in eckigen Klammern) können Sie nur die Feldgröße ändern.
.topic 8106
Änderungen protokollieren

Änderungen an den Attributen (Inhalt der Datenfelder) werden im Protokoll erfasst und sind somit nachvollziehbar.
.topic 8107
Schreibweise
Texte unverändert oder in Groß- bzw. Kleinschreibung in die Datenbank speichern.
.topic 8201
Geben Sie die Bezeichnung des Datenbankfeldes ein. Diese Bezeichnung ist für den Anwender in den Programm-Layouts und der Dokumententabelle sichtbar.
Bezeichnungen wie z. B. "{resstr:rsdfcName}" sind Variablen, die in der Mehrsprachversion das dynamische Umschalten zwischen den Sprachen ermöglichen.
.topic 8203
Wenn Globale Liste für alle Datenbanken markiert ist, greifen alle Dokumentenarchive und Kontaktdatenbanken auf dieselbe Auswahlliste zu. Neue Einträge (z. B. Projekte) stehen dann in allen Datenbanken zur Verfügung, in denen dieses Datenfeld mit globaler Liste definiert ist.
Ist die Option nicht markiert, dann verwendet diese Datenbank seine eigene Liste.
Globale Listen werden als itm-Dateien, private Listen in der Datenbank gespeichert.
.topic 8205
Liste automatisch erweitern
Wenn diese Option markiert ist, wird die Auswahlliste automatisch um neue Einträge erweitert.
.topic 8206
Eingabe erforderlich (Pflichtfeld)
Menü Datei | Datenbank | Anpassen | Felder definieren
Mit den Pflichtfeldern wird festgelegt, welche Daten für ein Dokument zwingend erforderlich sind. Ein Dokument kann nur angelegt werden, wenn alle als Pflichtfeld definierte Daten eingegeben wurden. Markieren Sie diese Option beispielsweise beim Feld "Name", um zu verhindern, dass ein Dokument ohne Namen angelegt wird.
.topic 8213
Erweiterter Stil
Zusätzliche Stil-Eigenschaft je nach Datentyp.
Währung
Beispielweise können Fließkommazahlen als Währung dargestellt werden: "1.234,50 €" statt "1234,5". Hierfür wird die im Windows-System hinterlegt Währungseinstellung verwendet.
.topic 8221
Wählen Sie den gewünschten Eingabestil für das Datenfeld aus. Für den Datentyp Zeichenkette stehen folgende Eingabestile zur Auswahl:
Eingabefeld: Die Daten werden frei eingegeben.
Eingabefeld mit Liste: Die Daten können aus einer Auswahlliste gewählt und frei eingegeben werden.
Nur Auswahl aus Liste: Die Daten können nur aus einer Auswahlliste gewählt werden, eine freie Eingabe ist nicht möglich. Verwenden Sie diesen Stil, wenn Sie Schreibfehler verhindern möchten, z. B. für das Feld Projekt.
Eingabefeld mit strukturierter Liste: Die Daten können aus einer strukturierten Auswahlliste gewählt und frei eingegeben werden. Die Einträge der Liste können untergliedert werden (Baumdarstellung).
Nur Auswahl aus strukturierter Liste: Die Daten können nur aus einer strukturierten Liste gewählt werden, eine freie Eingabe ist nicht möglich.
Mehrzeiliges Eingabefeld für mehrzeiligen Text, wie z. B. die Notizen.
Dateiliste oder Makro: Die Daten können nur aus der Liste gewählt werden. Welche Dateien die Liste enthält, legen Sie im Feld Format fest.
Outlook-Kontaktliste: Liest die Adressdatenbank von Microsoft Outlook ein und ermöglicht ein einfache Zuordnung der Dokumente zu Ihren Kontakten.
Kontaktliste: Integrierte CRM-Datenbank für Datenfeld "contactguid".
Besondere Datenfelder bieten zusätzlich den Eintrag Optionsfeld an (ein Kontrollfeld, dass nur markiert oder nicht markiert sein kann). Beispiel username: wenn der Stil Optionsfeld gewählt wurde, können Sie Ihre eigenen Dokumente suchen, indem Sie das Optionsfeld Private Suche markieren.
.topic 8222
Wählen Sie den gewünschten Eingabestil für das Datenfeld aus. Für den lange Textfelder steht nur ein Eingabestil zur Auswahl:
Mehrzeiliges Eingabefeld für mehrzeiligen Text, wie z. B. die Notizen.
.topic 8223
Wählen Sie den gewünschten Eingabestil für das Datenfeld aus. Für die Datentypen Ganzzahl und Fließkommazahl stehen folgende Eingabestile zur Auswahl:
Eingabefeld: Die Daten werden frei eingegeben.
Eingabefeld mit Liste: Die Daten können aus einer Auswahlliste gewählt und frei eingegeben werden.
Nur Auswahl aus Liste: Die Daten können nur aus einer Auswahlliste gewählt werden, eine freie Eingabe ist nicht möglich. Verwenden Sie diesen Stil, wenn Sie Schreibfehler verhindern möchten, z. B. für das Feld Projekt.
Eingabefeld mit strukturierter Liste: Die Daten können aus einer strukturierten Auswahlliste gewählt und frei eingegeben werden. Die Einträge der Liste können untergliedert werden (Baumdarstellung).
Nur Auswahl aus strukturierter Liste: Die Daten können nur aus einer strukturierten Liste gewählt werden, eine freie Eingabe ist nicht möglich.
.topic 8224
Für den Datentyp Logisch (Boolean) steht nur der Eingabestil Optionsfeld zur Verfügung. Dies ist ein Kontrollfeld, dass nur markiert oder nicht markiert sein kann.
.topic 8225
Wählen Sie den gewünschten Eingabestil für das Datenfeld aus. Für binäre Felder stehen folgende Eingabestile zur Auswahl:
Mehrzeiliges Eingabefeld für mehrzeiligen Text, wie z. B. die Notizen.
Grafik: Feld mit Grafikdaten. Im Eigenschaftendialog öffnen Sie bitte das lokale Menü mit Rechtsklick auf das Grafikfeld, um Bilder einzufügen oder aus einer Datei zu laden.
.topic 8226
Wählen Sie den gewünschten Eingabestil für das Datenfeld aus. Für den Datentyp Datum/Zeit stehen folgende Eingabestile zur Auswahl:
Datum: Eingabefeld und Auswahldialog für ein Datum
Zeit: Eingabefeld für Uhrzeit.
Datum und Zeit: Die Daten werden frei eingegeben.
.topic 8301
Dieser Vorgabewert wird für neue Dokumente verwendet, wenn der Anwender das Feld leer gelassen hat. Beachten Sie, dass dies ebenfalls nur dann ausgewertet wird, wenn Vorgabewert für neue und vorhandene Datensätze leer ist.
Falls Sie verhindern möchten, dass der Anwender einen Wert eingibt, können Sie die Eingabe sperren (s. Seite Sicherheit, Berechtigung zum Ändern). In dem Falls wird immer der Vorgabewert verwendet.
Sie können Makrovariablen als Vorgabewert verwenden. Die Variablen werden erst ausgewertet, wenn der Dokumentdatensatz gespeichert wird.
.topic 8302
Dieser Vorgabewert wird für neue und bereits vorhandene Dokumente verwendet, sobald der Datensatz gespeichert wird. Der Vorgabewert wird somit erzwungen, Eingaben des Anwenders überschrieben!
Sie können Makrovariablen als Vorgabewert verwenden. Die Variablen werden beim Speichern des Datensatzes ausgewertet.
.topic 8401
Klicken Sie bitte auf die Schaltfläche [Ändern], um festzulegen, für welche Anwender dieses Datenfeld sichtbar ist. Für unberechtigte Anwender wird das Feld verborgen, sie können es weder sehen noch bearbeiten.
Die Sicherheitseinstellungen können mit Strg-C kopiert und mit Strg-V eingefügt werden.
.topic 8402
Klicken Sie bitte auf die Schaltfläche [Ändern], um festzulegen, welche Anwender dieses Datenfeld bearbeiten dürfen. Unberechtigte Anwender können die Felder sehen, aber nicht ändern (readonly).
Die Sicherheitseinstellungen können mit Strg+C kopiert und mit Strg+V eingefügt werden.
.topic 9025
Gibt an, ob diese Datei schreibgeschützt ist. Solange die Option markiert ist, kann die Dokumentdatei nicht geändert werden.
Im GoBD-Modus kann ein gesetzter Schreibschutz nicht mehr aufgehoben werden.
.topic 9027
Der Dokumenttyp legt das Anwendungsprogramm fest, mit dem die Dokumente bearbeitet werden. Wählen Sie bitte die Anwendung für dieses Dokument aus der Liste.
Die Liste ist eventuell gefiltert und zeigt nur die geeigneten Dokumententypen zur Auswahl.
Klicken Sie mit der rechten Maustaste auf das Kombinationsfeld, wenn Sie aus allen Dokumententypen wählen möchten.
Im Menü Datei | Optionen | Dokumenttyp werden die Anwendungen registriert.
.topic 9028
Öffnet den Windows-Dialog Datei-Eigenschaften. Dieser Befehl ist nur aktiviert, wenn die angegebene Datei vorhanden ist. Diese Funktion ist in GoBD-Archiven gesperrt.
.topic 9029
Klicken Sie auf SQL-Abfrage, um Ihre Eingaben in eine SQL-Abfrage umzuwandeln. Sie können den erzeugten SQL-Code dann weiter bearbeiten.
.topic 9030
Legt fest, in welchem Grafikformat das gescannte Dokument gespeichert wird.
.topic 9031
Klicken Sie auf Löschen, um die Inhalte aller Eingabefelder zu leeren.
.topic 9101
Wählen Sie bitte die Bildquelle: Twain- oder WIA kompatible Scanner, Digitalkamera oder Ricoh ScanSnap.
Ist Ihr Scanner nicht enthalten?
Beachten Sie bei TWAIN-Treibern bitte, dass diese zur Bit-Ausgabe von Office Manager DMS passen müssen: Für einen 32 Bit Office Manager benötigen Sie einen 32 Bit-Treiber, für einen 64 Bit Office Manager einen 64 Bit-Treiber. Diese Regel gilt auch für andere Windows-Programme.
Installieren Sie bitte einen entsprechenden Treiber oder den Office Manager passend zum Treiber. Sie können auch beide Office Manager-Ausgaben parallel installieren.
.topic 9102
Öffnet das lokale Menü:
Scanner-Information: zeigt Eigenschaften der gewählten Bildquelle
Liste aktualisieren: lädt die Liste der verfügbaren Scanner neu ein
.topic 9103
Wenn die Option markiert ist, wird zum Scannen die Benutzeroberfläche der Quelle geöffnet. Dies ist sinnvoll, wenn Sie geräteabhängige Einstellungen vorgeben möchten.
.topic 9104
Gibt die Auflösung in Punkten pro Zoll an, wenn diese Einstellung von der Bildquelle unterstützt wird. Große Werte verbessern die Bildqualität, benötigen aber mehr Speicherplatz. Für Dokumente ist ein Wert von ca. 150 dpi empfehlenswert.
.topic 9105
Gibt den Farbmodus an, wenn diese Einstellung von der Bildquelle unterstützt wird.
Beispielsweise Schwarz/Weiß, Graustufen oder Farbe.
.topic 9110
Aktiviert, sofern vorhanden, den automatischen Dokumenteneinzug (ADF) des Scanners.
.topic 9111
Alle Dokumente im Dokumenteneinzug (ADF) werden automatisch eingezogen, bis der ADF leer ist.
.topic 9112
Legt die Größe des Scanbereichs und das Seitenformat der PDF-Datei fest.
Siehe auch: Datei | Optionen | Einstellungen, Seite Papierformate.
.topic 9120
Klicken Sie bitte auf Scannen oder drücken Sie die Taste F6, um den Scan zu starten bzw. das Bild von der Quelle zu importieren.
.topic 9121
Klicken Sie bitte auf Stapelscan, um das Fenster für produktives Scannen zu öffnen.
.topic 9130
Wenn diese Option markiert ist, wird der enthaltene Text mit einer OCR-Software erkannt. Die Texterkennung wird gestartet, sobald Sie das Dokument mit Klick auf OK übernehmen.
Siehe auch Menü Datei | Optionen | Einstellungen, Seite Volltextindex | OCR
.topic 9131
Geraderücken
Rückt schief eingezogene Seiten gerade. Verwenden Sie diese Option nur für gescannte Seiten mit Text.
Schnell
Wertet nur einen Teil des Dokumentenabbildes aus und arbeitet mit einem schnell Algorithmus.
Sie sollten diese Option bevorzugt verwenden und nur bei falschen Ergebnissen deaktivieren: zum Beispiel bei Dokumenten, die im oberen Seitenbereich eine Grafik oder eine farbige Fläche haben.
.topic 9221
JPeg-Qualität
Qualität der farbigen Grafiken: 100% gibt die beste Qualität, 10% die höchste Komprimierung an. Hohe Werte erfordern mehr Speicherplatz.
.topic 9222
Optimierung des Scanergebnisses
Textfilter: starke Hervorhebung von Kanten und Farbübergängen für dedizierte OCR-Optimierung, Grafiken werden zerstört.
Kontrastanhebung: Hervorhebung von Kanten und Farbübergängen für OCR unter Beibehaltung von Grafiken.
Weichzeichner: harte Kontrastübergänge werden angeglichen.
Beachten Sie aber auch Vorschriften der GoBD zur Archivierung steuerlich relevanter Daten. Scannen Sie ohne Optimierung, wenn eine derartige Datenaufbereitung unzulässig ist.
.topic 9223
Dynamischer Weißabgleich
Korrigiert verfälschende Kunstlichteinwirkungen und erweitert den Kontrast des Bildes. Diese Option ist für alle Vorlagen geeignet, die weiße Bereiche enthalten
.topic 9225
Die Abbildung zeigt den Status der Sceye-Dokumentenkamera: geschlossen, geöffnet oder geöffnet mit aktiviertem Laser.
.topic 9226
Sceye-Livebild
Zeigt eine stark verkleinerte Ansicht des Erfassungsbereichs als Livebild in niedriger Qualität.
.topic 9160
Zeigt die Vorschau der eingelesenen Bilder.
.topic 9161
Mit dieser Bildlaufleiste können Sie zwischen den gescannten Bildern blättern.
.topic 9162
Dreht das aktuelle Bild um 90° gegen den Uhrzeigersinn.
.topic 9163
Dreht das aktuelle Bild um 90° im den Uhrzeigersinn.
.topic 9164
Dreht das aktuelle Bild um einen beliebigen Winkel. Geben Sie bitte einen Drehwinkel größer 0 ein, um im Uhrzeigersinn, oder einen Winkel kleiner 0 ein, um gegen den Uhrzeigersinn zu drehen.
.topic 9165
Importiert eine Grafik aus einer Datei.
.topic 9166
Importiert eine Grafik aus der Zwischenablage.
Sie können auch die Zwischenablage überwachen und neue Bilder automatisch übernehmen. Aktivieren Sie dazu die Schaltfläche "Clipboard mit Pluszeichen".
.topic 1967
Löscht die aktuelle Grafik.
.topic 9168
Legt fest, ob der neue Stapel vor der aktuellen Grafik, nach der aktuellen Grafik oder am Ende hinzugefügt werden. Sie können auch die aktuelle Grafik durch einen neuen Scan ersetzen.
Die Option wird bei jedem Öffnen des Scandialoges auf "Als letzte Grafik anhängen" zurückgesetzt.
.topic 9169
Startet die OCR-Software und zeigt Ihnen, welcher Text von der aktuellen Grafik gelesen wurde. Diese Funktion dient nur Testzwecken.
.topic 9170
Kopiert die aktuelle Grafik in die Zwischenablage.
.topic 9171
Öffnet die aktuelle Grafik zur Bearbeitung in einem externen Programm.
Führen Sie die gewünschten Änderung bitte im gestarteten Grafikprogramm durch und speichern Sie die Änderungen. Wenn Sie zum Office Manager zurückkehren, wird die Änderung nach Rückfrage übernommen.
.topic 9172
Der Speicher-Transfer vermeidet Pausen zwischen den einzelnen Seiten beim Stapelscan. Einige Scanner unterstützen diese Option aber nicht. Prüfen Sie bitte das Scanergebnis, wenn Sie diese Option aktivieren.
.topic 9224
Schaltet den Laser der Dokumentenkamera ein oder aus.
.topic 9227
Schaltet die LED-Beleuchtung der Kamera ein oder aus.
.topic 9228
Schaltet den Laser und die LED automatisch aus, sobald das Scan-Fenster geschossen wird.
Aktivieren Sie diese Option, wenn Sie nur gelegentlich scannen.
Falls Sie viel scannen - dieses Dialogfenster also in kurzen Abständen immer wieder öffnen, dann sollten Sie die Option deaktivieren. Dies vermeidet ein häufiges Schalten der Beleuchtungselemente.
.topic 9281
Scanintervall
Zeitspanne für das Wechseln der Papiervorlage. Verwenden Sie für erste Versuche 4-6 Sekunden.
.topic 9282
Signalton
Das Erfassen der Vorlage wird mit einem kurzen Ton signalisiert. Diese Option ist vor allem bei ersten Versuchen sinnvoll.
.topic 9283
Scannen
Klicken Sie auf diesen Schalten, um mit der Vorlagenerfassung zu beginnen. Ein erneutes Anklicken beendet den Scanvorgang.


Datei kopieren?

Datei konnte nicht verschoben werden. Kopieren?

Office Manager passt die Dateinamen- und Pfade automatisch an neue Attribute (insbesondere die Projektzuordnung) an, wenn die Option Vorgabe gilt auch für bestehende Dateien aktiviert ist.

Tipp: Der häufigste Grund für diese Meldung ist eine geöffnete und somit gesperrte Dokumentdatei. Schließen Sie diese und klicken Sie auf Wiederholen.

Auswahlmöglichkeiten im Rückfragedialog:

Ja: Die Datei wird kopiert und diese Kopie mit dem Office Manager-Datensatz verknüpft. Die ursprüngliche Datei bleibt ebenfalls auf dem Datenträger erhalten. Dies ist nur empfohlen, wenn sich die Datei beispielsweise auf einer CD befindet und in das Dokumentenverzeichnis verschoben werden soll.

Nein: Die Änderung am Dateinamen wird nicht durchgeführt, der alte Dateiname bleibt erhalten.

Wiederholen: Falls Sie die Dokumentdatei gerade geöffnet haben, dann schließen Sie diese bitte und wiederholen Sie das Verschieben.


Dateianlagen in Vorschau

Zugriff auf Dateianlagen in der Vorschau

Navigation: »Kein übergeordnetes Kapitel«

Zugriff auf Dateianlagen in der Vorschau

Wird ein Dokument, beispielsweise eine E-Mail, PDF oder ZIP mit enthaltenen Dateianlagen in der Vorschau gezeigt, finden Sie die Anlagen unterhalb des Vorschaubildes aufgelistet. Bei Kontakten und Kalender-Terminen sehen Sie hier die Visitenkarte (vCard) bzw. den Termin als iCalendar-Datei.

Screenshot der E-Mail-Vorschau mit Dateianlage

Sie können hier direkt auf die anliegenden Dateien zugreifen:

·Ein Klick mit der primären (i. d. R. linken Maustaste) lädt die Datei in die Vorschau.

·Ein Mausklick bei gleichzeitig gehaltener Umschalt-Taste öffnet die Datei.

·Das lokale Menü (Rechtsklick) bietet weitere Möglichkeiten.

·Das Kopieren in den Windows-Explorer u. a. Anwendungen ist mit Drag&Drop möglich.

Siehe auch


Feldtypen

Datentypen der Datenbankfelder:

@ Datum/Zeit
A Text, Länge in Klammern
M Langer Text (Memofeld)
N Numerisch, Ganzzahl
L Logisch (ja/nein = "T"/"F"), wird als Text(1) gespeichert
G Grafik
U GUID, Uniqueidentifier
* Primär-Index


Datenbanktreiber fehlen

Navigation: »Kein übergeordnetes Kapitel«

Datenbanktreiber fehlen

Verfügbar in diesen Editionen

Fehler beim Öffnen der Archiv- oder Anwendungsdatenbank

Auf Standarddatenbanken im SQLite-Format greift Office Manager direkt zu. Für SQL-Server und ev. auch für Access-Datenbanken sind Treiber erforderlich. Falls Sie beim Programmstart eine entsprechende Fehlermeldung erhalten, dann installieren Sie bitte den genannten Treiber.

Downloadmöglichkeiten finden Sie im Supportbereich


Verschlüsseln

Navigation: »Kein übergeordnetes Kapitel«

Verschlüsseln

Geschützte SQLite-Datenbanken
Menü Datei | Neues Archiv, nur in der 32-Bit-Version

Markieren Sie beim Datenbanktreiber "SQLite" die Option Verschlüsseln, wenn Sie die Archiv- bzw. Kontaktdatenbank schützen möchten. Diese ist dann mit dem eingegebenen Kennwort gesichert.

Passwortsafe?

Falls Sie ein Archiv für die Verwaltung von Kennwörtern oder anderen vertraulichen Informationen anlegen möchten, dann ist ein geschütztes SQLite-Archiv eventuell eine einfache Möglichkeit für Sie. Die Datenbankdatei wird verschlüsselt und kann nur mit dem Kennwort geöffnet werden. Die Sicherheit ist dabei so gut, wie das gewählte Kennwort. Die Verschlüsselung führt zu einer Leistungsminderung und die Archive werden nicht in der mobilen App geöffnet.

Vorteil gegenüber passwortgeschützten Datenbanken auf SQL-Servern: Die Datenbankdatei (*.omen steht für Office Manager Encryted) ist einfach handzuhaben. Als zusätzliche Sicherungsmaßnahme könnte die Datei auf einem externen Medium gespeichert und nur bei Bedarf an den Rechner angeschlossen werden (dann aber unbedingt weitere Sicherungskopien aufheben).

Wichtig!

·Kennwortverlust = Datenverlust. Ohne das Kennwort können Sie nicht mehr zugreifen.

·Nur die Datenbank wird verschlüsselt. Geben Sie die geheimen Informationen nur in den Datenfeldern und nicht in der Dokumentendatei ein.

Internetlinks

Hotline-Blog: Verschlüsselung entfernen
SQLite Encryption Extension
Wikipedia zu SQLite
Für welche Datenbank ist die Passwortabfrage?


Beispiel DDE-Makro

Im folgenden Beispiel wird eine Zeichnung per DDE-Befehl in AutoCAD geöffnet. Falls AutoCAD noch nicht gestartet ist, wird es mit der Mechanicaldesktop-Umgebung (MDT) ausgeführt.

{DDESetExeParam:/p "C:\Programme\Autodesk\MDT 2004\Desktop\mdtpp.arg"}

{DDEOpenLink:AutoCAD.r15.DDE,System}

{DDESendLine:[open("{CurrDocFileName}")]}

{DDECloseLink}


DDE-Kennungen

Navigation: »Kein übergeordnetes Kapitel«

DDE-Kennungen

DDE-Kennung:

Kennung des Anwendungsprogramms für die Übermittlung von DDE-Befehlen und das Thema der DDE-Kommunikation. Die DDE-Kennung (Service) ist oft der Programmdateiname ohne Endung, für Thema (Topic) kann in den meisten Fällen "System" eingegeben werden. Lesen Sie auch in der Dokumentation des Anwendungsprogramms nach.

Beispiele:

Anwendung

Kennung
(Service)

Thema
(Topic)

Microsoft Excel

Excel

System

Microsoft Word

WinWord

System

AutoCAD 14

AutoCAD.r14.DDE

System

AutoCAD 2000

AutoCAD.r15.DDE

System

AutoCAD 2002

AutoCAD.r15.DDE

System

MegaCAD 2D

MegaCAD

System

MegaCAD 3D

MegaCAD_3D

System


DDE synchronisieren

Wenn die DDE-Verbindung synchronisiert geöffnet wird, wartet der Office Manager vor dem Senden weiterer Befehle, bis das Anwendungsprogramm den vorherigen Befehl abgearbeitet hat.

Eine Synchronisierung ist in den meisten Fällen nicht erforderlich.
Diese Option wirkt sich nur aus, wenn mehrere DDE-Befehle (mehrere Zeilen) gesendet werden.


DDE Hintergrundinformation

Der Office Manager kann die Anwendungsprogramme grundsätzlich auf zwei Arten steuern:

1.Das Programm wird vom Office Manager gestartet, der Dateiname des Dokumentes als Startparameter übergeben.

2.Das Programm wird nur gestartet, wenn es noch nicht geöffnet ist. Der Office Manager nimmt eine DDE-Verbindung zum Programm auf und sendet DDE-Befehle um das Dokument zu öffnen.

Anwendung mit DDE steuern

Office Manager versucht eine DDE-Verbindung herzustellen. Gelingt dies nicht, startet er zunächst die Anwendung und baut die DDE-Verbindung auf. Die Befehle des DDE-Makros werden gesendet. Ein Vorteil der DDE-Steuerung ist bei MDI-Anwendungen, dass die Anwendung nicht für jedes Dokument neu gestartet werden muss.

Eine Mischung beider Arten kann in Ausnahmefällen sinnvoll sein.

Siehe auch

DDE-Beispiel

Makro-IF-Bedingung


Drag & Drop von Internet-Links

Wenn Sie einen Link aus dem Browser per Drag&Drop auf den Office Manager schieben oder eine URL aus der Zwischenablage importieren, erscheint folgendes Popupmenü:

Sie können jetzt wählen, ob das Dokument archiviert oder mit der URL verknüpft werden soll:

Internetlink verwalten: der Office Manager verwaltet direkt die URL. Wenn Sie später die Webseite oder das Dokument öffnen, wird diese Internetadresse (i. d. R. im Browser) geöffnet.

Lokale Kopie speichern: die Dokumentdatei wird von der URL geladen und im Dokumentenverzeichnis gespeichert. Wenn die URL auf eine downloadbare Datei verweist, dann wird diese geladen. Webseiten (HTML) werden als Webarchiv (MIME HTML, *.mhtml) gespeichert.

Abbrechen: der Import wird abgebrochen.

Dieses Popupmenü wird eingeblendet, wenn Sie eine URL importieren, dessen Dokumenttyp als "Standard-Dokument in externer Datei" oder als "E-Mail" registriert ist oder wenn eine Webseite als MHTML gespeichert werden kann. In allen anderen Fällen wird ohne Rückfrage der Link verwaltet.

MIME HTML-Webarchive werden mit Windows API-Funktionen, dem IMessage Interface, erstellt. Die Darstellung kann vom Original abweichen. Es werden nicht alle Linkquellen unterstützt.


Drag&Drop mit Verzeichnissen

Wenn Sie Verzeichnisse per Drag&Drop oder aus der Zwischenablage importieren, müssen Sie angeben, wie die Dateien aus den Verzeichnissen gehandhabt werden.

Dateien aus Verzeichnissen importieren: Alle Dokumentdateien des Verzeichnisses einzeln in das Archiv übernehmen.

Dateien auch aus Unterverzeichnissen importieren: Alle Dateien des Verzeichnisses und allen Unterverzeichnissen einzeln in das Archiv übernehmen.

Verzeichnisse als ZIP-Archiv importieren: Alle Dateien im Verzeichnis und allen Unterverzeichnissen in eine ZIP-Datei packen und diese in das Dokumentenarchiv importieren.

Verzeichnisse ignorieren: Die Dateien aus den importierten Verzeichnissen werden nicht übernommen.

Abbrechen: Der Import wird abgebrochen.


Neue Dokumentdatei zuordnen

Navigation: »Kein übergeordnetes Kapitel«

Neue Dokumentdatei zuordnen

Neue Dokumentdatei zuordnen

Wählen Sie im Menü Bearbeiten | Dokument | Eigenschaften und klicken Sie auf die Schaltfläche Durchsuchen neben dem Eingabefeld Dateiname.

Wenn Sie im Dateidialog eine vorhandene Datei auswählen, wird diese dem Dokument zugeordnet.

Diese Funktion ist in GoBD-Archiven gesperrt.

Siehe auch: Erweiterter Import

Dokumentdatei verschieben oder umbenennen

Wenn Sie jedoch einen noch nicht vorhandenen Dateinamen eingeben, werden Sie gefragt, ob das Dokument unter dem neuen Dateinamen gespeichert werden soll. Klicken Sie auf Ja, um die Dokumentdatei umzubenennen.

Wenn Sie nach Klick auf Durchsuchen den Menübefehl Automatisch wählen, dann wird der Dateiname neu aus den Vorgaben ermittelt und die Dokumentdatei ggf. nach Rückfrage verschoben. Siehe auch Option "Vorgabe gilt auch für bestehende Dateien".

Das Archiv wird nach weiteren Datensätzen durchsucht, die auf diese Datei verweisen (z. B. Klone). Es werden alle Datensätze aktualisiert.


Dokumenttypen automatisch registrieren

Automatische Registrierung eines Dokumenttypen

Die verschiedenen Windows-Anwendungen werden im Office Manager als Dokumenttypen registriert. Wenn für ein Dokument, welches Sie importieren oder öffnen möchten, noch kein Dokumenttyp registriert ist, sucht der Office Manager nach einer geeigneten Windows-Anwendung. Wenn eine Anwendung vorhanden ist, kann diese automatisch registriert werden.

Klicken Sie auf Ja, damit die Anwendung registriert und die Dokumentdatei übernommen werden kann.

Wenn Sie auf Nein klicken, kann die Datei nicht übernommen werden. In dem Fall können Sie den Dokumenttyp manuell registrieren (Menü Datei | Optionen | Dokumenttyp).

Tipp

Falls die Registrierung neuer Dokumenttypen nicht gewünscht ist, kann der Administrator dies sperren: Menü Datei | Optionen | Einstellungen, Seite Sicherheit | Befehle, die Sichtbarkeit für den Befehl "Optionen | Dokumenttyp" entsprechend beschränken.


Dokumenttyp umbenennen

Sie haben die Bezeichnung eines bestehenden Dokumenttypen geändert. Die abhängigen Daten (Befehle, Dateiendungen und die Dokumentdatensätze) sind über die Bezeichnung mit den Dokumenttypen verknüpft und müssen jetzt entsprechend angepasst werden. Dieser Vorgang kann einige Minuten Zeit in Anspruch nehmen.

Klicken Sie bitte auf Ja, um den Dokumenttypen umzubenennen und alle erforderlichen Änderungen durchzuführen oder auf Nein, um die ursprüngliche Bezeichnung beizubehalten.

Im Netzwerkbetrieb sollten Sie die Änderung nur durchführen, wenn keine anderen Benutzer an der Datenbank angemeldet sind.
Beachten Sie bitte auch, dass die Änderungen an der Anwendungsdatenbank Einfluss auf alle Dokumentenarchive hat. Sie müssen das Attribut "Dokumenttyp" ggf. in anderen Archive manuell ändern.


Anwendung ungültig für Datei

Sie haben eine Dokumentdatei per Drag&Drop auf die gruppierte Dokumenttabelle gezogen. Anhand der Gruppierung soll das Dokument der genannten Anwendung zugeordnet werden. Für die Anwendung sind Dokumente von diesem Typ allerdings nicht registriert.

Klicken Sie auf:

Ja, um das Dokument der gewünschten Anwendung zuzuordnen und Dokumente mit dieser Dateiendung automatisch zu registrieren.

Nein, um das Dokument der Standardanwendung zuzuordnen.

Ignorieren, um das Dokument der gewünschten Anwendung zuzuordnen ohne Dokumente mit dieser Dateiendung zu registrieren. Diese Option ist nicht empfohlen!


Zu importierende Dateien vorhanden

Die Liste der zu importierenden Dateien enthält noch Einträge (z. B. aus der Verzeichnisüberwachung oder einem Dokumentenscanner). Klicken Sie auf:

Ja, um die Dateien jetzt zu importieren, auf

Nein, um das Programm zu beenden ohne die Dateien zu importieren, oder auf

Abbrechen, um das Programm jetzt nicht zu beenden.

Diese Meldung erhalten Sie beim Programmende, wenn noch nicht alle Dateien importiert wurden.


Volltextindexierung läuft

Navigation: »Kein übergeordnetes Kapitel«

Volltextindexierung läuft

Aktualisierung des Volltextindex

Wenn Sie ein Dokument erstellen oder ändern, wird der Index im Hintergrund überarbeitet. Bei Aktivierung der Standard-Volltextsuche (nicht bei SQLite und MS SQL-Suche) finden Sie links unten in der Statusleiste einen Fortschrittsbalken:

Ausführung von Systemaufgaben

Systemaufgaben, wie beispielsweise die nachträgliche OCR-Texterkennung, werden im Hintergrund ausgeführt:

Die Datenbank kann erst geschlossen werden, wenn die Indexierung und die Systemaufgaben abgeschlossen sind.

Wenn umfangreiche Dokumentdateien indexiert werden, dann kann der Vorgang einige Minuten erfordern.

Ein anderes Archiv öffnen

Wenn Sie ein anderes Dokumentenarchiv öffnen möchten ohne auf die Fertigstellung der o. g. Funktionen zu warten, dann starten Sie das Archivierungsprogramm eine weiteres Mal mit dem gewünschten Archiv.

Aktualisierung abbrechen

Beim Versuch, Office Manager während der Aktualisierung zu beenden, erscheint ein Hinweisfenster. Falls Sie in diesem Dialog auf Ignorieren klicken, wird die Aktualisierung abgebrochen und das Programm beendet. Sie sollten dies nur tun, falls die Aktualisierung nicht mehr reagiert. Beachten Sie, dass durch den Abbruch Wörter im Volltextindex fehlen werden.


Eingehendes Fax verwerfen

Sie haben sich entschlossen, das eingegangene Fax zu verwerfen. Möchten Sie die Datei später importieren? Klicken Sie bitte auf:

Ja, um die Datei später zu importieren. Die erneute Aufforderung erfolgt erst, wenn Sie Programm das nächste Mal starten.

Nein, um die Datei endgültig zu verwerfen. Sie wird in das Verzeichnis "Verworfen" unterhalb des Faxeingangsverzeichnisses verschoben.

Abbrechen, um das Fax doch nicht zu verwerfen.

Siehe auch

Faxe importieren


Formular zurücksetzen

Fenstergröße zurücksetzen

Sie können die Größe des Programmfensters (Hauptfenster und Eigenschaftendialog) mit der Maus ändern und in der Layoutdatei speichern. Wählen Sie den Befehl Fenstergröße zurücksetzen, um die Größe wieder auf Standard zu setzen. Die Werte werden dann aus der Layoutdatei gelöscht.

Mit dieser Funktion setzen Sie auch die Höhe des oberen Bereichs im Eigenschaftendialog zurück, wenn der Designer mit dem Befehl Ansicht | Anpassen | Layout entwerfen | Dokument-Eigenschaften (Hauptfenster) geöffnet wurde.


Aufgabe erledigen

Wenn Sie eine Aufgabe erledigt haben, dann löschen Sie diese bitte auch im Terminplaner. Markieren Sie dazu eine oder auch mehrere Tätigkeiten und klicken Sie auf den Mausschalter Aufgabe | Bearbeiten | Erledigen:

Bestimmen Sie, ob die Aufgabe erledigt ist oder nur gelöscht wird. Diese Information wird in der Historie des verknüpften Dokuments oder Kontaktes protokolliert. Bestätigen Sie mit Klick auf Ja.

Mausschalter im Dialogfenster

·Ja: Die Aufgabe löschen oder erledigen.

·Nein: Diese nicht erledigen.

·Abbrechen: Keine Aufgaben erledigen, Vorgang beenden.

·Hilfe: Öffnet diese Dokumentation.

Warnung "Datenbank öffnen"

Für die Protokollierung am Dokument oder Kontakt muss die entsprechende Datenbank geöffnet sein. Im Bestätigungsdialog sehen Sie bei Bedarf eine Aufforderung zum Öffnen der Datenbank:

Warnung bei "Aufgabe erledigen"

Öffnen Sie bitte das genannte Dokumentenarchiv bzw. die Kontakte. Falls dies nicht möglich ist, weil die Datenbank beispielsweise nicht mehr verfügbar ist, können Sie die Aufgabe trotzdem erledigen. Es wird dann aber kein Protokoll erstellt. Markieren Sie hierzu die Option Trotzdem erledigen und klicken Sie auf Ja.


Eingabe erforderlich

Eingabe erforderlich (Pflichtfeld)

Sie versuchen ein Dokument zu erstellen, haben aber nicht alle Pflichtfelder ausgefüllt. Geben Sie bitte Daten in das Pflichtfeld ein, bevor Sie fortfahren.

Bei einem automatisierten und bei einem Massenimport können Sie auch auf Ignorieren klicken, um dieses Feld jetzt nicht auszufüllen.

Pflichtfeld-Option einstellen

Wenn Sie zukünftig Dokumente archivieren möchten, ohne dieses Feld auszufüllen, dann können Sie die Pflichtfeld-Option deaktivieren:

1.Wenden Sie sich ggf. an Ihren Administrator..

2.Wählen Sie bitte den Menübefehl Datei | Datenbank | Anpassen | Felder definieren.

3.Markieren Sie links das entsprechende Datenfeld. Sie können auch zum Suchen auf die Lupe klicken.

4.Deaktivieren Sie die Option Eingabe erforderlich (Pflichtfeld).

5.Klicken Sie auf Übernehmen und Schließen.


Datei verknüpfen

Geben Sie bitte den Namen der Datei an, die mit diesem Dokument verknüpft werden soll.

Siehe auch

Einstellung des Dokumentenverzeichnisses

Einstellung der Dateinamenvorgabe


Keine Berechtigung zum Ändern

Navigation: »Kein übergeordnetes Kapitel«

Keine Berechtigung zum Ändern

Dokument darf nicht bearbeitet werden

A. Fehlende Zugriffsrechte

Das Dokument kann nicht geändert werden, weil Ihnen die erforderlichen Berechtigungen fehlen. Wenden Sie sich bitte an Ihren Administrator, wenn Sie das Dokument bearbeiten möchten.

Das Dokument ist schreibgeschützt, weil die Sicherheitsregel Benutzer darf nur die eigenen Dokumente ändern aktiviert oder der Befehl Grundfunktionen | Attribute bearbeiten gesperrt ist.

Wenn Sie administrative Rechte haben, melden Sie sich bitte als Administrator an, um das Dokument zu bearbeiten.

B. Archiviertes Dokument

Dokumente in der Ansicht "Archivierte Dokumente" sind schreibgeschützt und können nicht bearbeitet werden. Sie müssen das Dokument zuerst wiederherstellen.

C. Gelöschtes Dokument

In der Papierkorb-Ansicht können Sie keine Dokumenteigenschaften ändern. Sie müssen das Dokument zuerst wiederherstellen.


Buchungsdaten löschen

Beim Synchronisieren mit der Buchhaltung werden unter anderem die Buchungstexte in das Datenfeld POSTINGTXT übernommen. Dieses Feld wird zu Beginn der Synchronisierung in allen Belegen gelöscht, welche in der importierten Synchronisierungsdatei enthalten sind.


Anwendung ungültig für Datei

Sie versuchen, dem Dokument eine Anwendung zuzuordnen, die anscheinend nicht geeignet ist.

Klicken Sie bitte nur auf Ja, wenn Sie sicher sind, dass die genannte Dokumentdatei mit dieser Anwendung geöffnet werden kann.

Siehe auch Dokumenttyp. Um diese Meldung zukünftig zu verhindern, können Sie dem Dokumenttypen die Dateiendung (wie ".txt" u. ä.) zuordnen.


Sehr viele Dokumente zu öffnen

Das gleichzeitige Öffnen mehrerer Dokumente kann eventuell viel Zeit beanspruchen. Um zu verhindern, dass Sie ungewollt sehr viele Dokumente gleichzeitig öffnen, müssen Sie dies besonders bestätigen:

Klicken Sie bitte auf Ja, um alle markierten Dokumente zu öffnen oder auf Nein, wenn Sie die Dokumente jetzt nicht öffnen möchten.

Der Grenzwert kann geändert werden. Siehe auch Erweiterte Einstellungen - WarningExecuteCount


DOCARCH in Pro-Version nicht möglich

Ansicht "Archivierte Dokumente" in Pro-Version nicht enthalten

Die Funktion "Dokumente archivieren" ist in der Office Manager Pro-Version nicht enthalten.

Beim Erstellen des neuen Archivs wurde festgestellt, dass die zu kopierende Quelldatenbank archivierte Dokumente beinhaltet. Diese wurden mit einer Enterprise-Version (auch Testversion) erstellt, können in der Pro-Edition aber nicht eingesehen werden.

Sie sollten den Vorgang abbrechen, das Quellarchiv in der Enterprise-Version öffnen und alle archivierten Dokumente wiederherstellen. Anschließend können Sie mit der Pro-Edition das Archiv in eine neue Datenbank übernehmen.


Systemaufgabe in Warteschleife

Mit Hilfe der Systemaufgaben wird zum Beispiel eine nachträgliche OCR-Texterkennung durchgeführt. Einige Funktionen - wie die Langzeitarchivierung und Blockchain-Revision - sind erst möglich, wenn alle Systemaufgaben des Dokuments erledigt sind.

In der Regel bedeutet dies, dass die Texterkennung eines gescannten Dokumente noch nicht fertiggestellt ist, warten Sie diese bitte ab. Siehe auch Blogartikel.


Nicht leere Projekte löschen

Wenn Sie Projekte aus dem Navigator löschen, dann prüft der Office Manager, ob dem Projekt noch Dokumente zugeordnet sind. Sie müssen das Löschen bestätigen, falls entsprechende Dokumente vorhanden sind.

Wenn Sie das Projekt mit allen zugeordneten Dokumenten löschen möchten:

·Klicken Sie bitte auf Nein.

·Erstellen Sie eine Suche nach allen Dokumenten des Projekts.

·Markieren Sie alle Dokumente des Projekte und wählen Sie anschließend den Menübefehl Löschen.

Wenn Sie nur das Projekt aus der Liste löschen möchten:

·Klicken Sie auf Ja.

Die Dokumente sind anschließend noch vorhanden, aber nicht mehr über den Navigator zu finden. Sie müssen den gesuchten Projektnamen dann im Suchfeld eingeben oder die Dokumente über andere Eigenschaften und den Volltext suchen.


Synchrone Daten verwenden

Office Manager verwendet die synchronen Daten, wenn das Verzeichnis der gemeinsamen Dateien nicht vorhanden ist oder wenn der Startparameter /UseLocalFiles gesetzt ist.

Diese Meldung erhalten Sie in der Regel beim Programmstart, wenn das Notebook bzw. der Rechner vom Netzwerk getrennt wurde. Nach Klick auf OK werden die lokalen Daten verwendet, die zuvor mit der Synchronisierung erstellt wurden.

Falls Sie sich jetzt doch mit dem Netzwerk verbinden möchten, dann klicken Sie bitte in dieser Benachrichtigung und im folgenden Verzeichnisdialog auf Abbrechen und beenden Sie das Programm. Stellen Sie die Netzwerkverbindung her und starten Sie den Office Manager erneut.


Dienst-Steuerung

Navigation: »Kein übergeordnetes Kapitel«

Dienst-Steuerung

Verfügbar in diesen Editionen

Menü Datei | Mobile Server

Die Kommunikation mit den mobilen Endgeräten erfolgt nicht mit dem Office Manager-Hauptprogramm, sondern mit dem Dienst "DMSService.exe". Dieses Dienstprogramm wird automatisch installiert und gestartet oder beendet, wenn Sie den Zugriff zugelassen oder untersagt haben und dann auf Einstellungen speichern klicken.

Mit dem Mausschalter Dienst-Steuerung können Sie auf weitere Funktionen zugreifen:

·Dienst-Steuerung: Ein Klick auf den Schalter meldet den derzeitigen Status des Dienstes.

Klicken Sie für weitere Funktionen auf den Pfeil des Schalter:

·Dienst starten

·Dienst beenden

·Dienst installieren: Im Servicemanager von Windows registrieren.

·Dienst deinstallieren können Sie wählen, wenn Sie die mobilen Verbindungen dauerhaft deaktivieren möchten.

·Firewall-Regel hinzufügen: Erstellt oder aktualisiert die eingehende Regel der Windows-Firewall für den mobilen Zugriff.

·Logdatei öffnen: Öffnet eine Logdatei, die vom Dienstprogramm geschrieben wird.

Hinweis: Die Dienst-Steuerung ist deaktiviert, falls das zentrale Server-Programm für den mobilen Zugriff aktiviert ist.


DMS Core

Navigation: »Kein übergeordnetes Kapitel«

DMS Core

Blockchain-Software "DMS Core"

DMS Core ist das Standard-Wallet der Kryptowährung "DMS". Sie benötigen die Software, wenn Sie mit dieser Währung bezahlen, Coins schürfen, Masternodes betreiben oder die Blockchain-Dokumentenfunktionen ohne Web-Dienst nutzen. Sie finden DMS Core als Open-Source-Software auf der Plattform GitHub.

Installation

Hinweis: Einige Antivirenprogramme warnen grundsätzlich vor Blockchain-Software als potentiell unerwünschte Software.

1.Laden Sie bitte das neueste Release für Ihr Betriebssystem. Wir gehen hier von einer Windows-Installation aus.

2.Führen Sie das Installationsprogramm (z. B. dmscore-version-win64-setup.exe) aus. Alternativ können Sie auch ohne Setup die entsprechende *.zip-Datei im gewünschten Verzeichnis entpacken.

3.Starten Sie DMS Core.

4.Für das Datenverzeichnis können Sie den Standard-Pfad übernehmen oder beispielsweise ein Verzeichnis wählen, welches regelmäßig gesichert wird. In diesem Verzeichnis wird neben der Blockchain auch die wallet.dat gespeichert, die Ihr Guthaben an DMS-Coins beinhaltet.

Screenshot der Wallet-Software DMS Core

Vorbereitungen

1.Warten Sie bitte, bis das Wallet synchronisiert ist. Dies nimmt einige Zeit in Anspruch - es werden alle Blöcke seit dem Start der Blockchain am 26.08.2018 geladen und geprüft.

2.Verschlüsseln Sie das Wallet, um unberechtigte Zugriffe zu verhindern. Wählen Sie hierzu den entsprechenden Befehl im Menü Einstellungen.

3.Stellen Sie sicher, dass die im Datenverzeichnis enthaltene Datei wallet.dat regelmäßig gesichert wird. Ein Verlust dieser Datei oder des für die Verschlüsselung genutzten Kennwortes bedeutet den Verlust des Guthabens!

Einstellungen

Wählen Sie im Office Manager-Hauptmenü bitte Datei | Optionen | Einstellungen und wechseln Sie zur Seite Dokument | Blockchain. Wählen Sie "Documentchain" aus und deaktivieren Sie die Option Web-Wallet verwenden. Sie können hier Ihren Namen oder Ihre Firmenbezeichnung hinterlegen.

RPC-Einstellungen für die Kommunikation werden automatisch konfiguriert, wenn die Programme auf demselben Computer installiert sind.

DMS-Coins erwerben

Als Kunde der aktuellen Office Manager DMS-Software können Sie auf Rückfrage einen kleinen Betrag an DMS kostenlos erhalten. Wenden Sie sich hierfür und für Fragen zu Bezugsquellen bitte an mail@krekeler.de. Informationen zum Coin und zu Handelsbörsen finden Sie auch auf der Projekt-Webseite documentchain.org

Selbst erzeugen: Mining

Der Coin "DMS" kann, wie viele andere Kryptowährungen, durch Mining geschürft werden. Bei diesem Vorgang werden aktuelle Transaktionen zu neuen Blöcken zusammengeführt und der Blockchain hinzugefügt. Mit den neuen Blöcken werden neue Coins erzeugt und zusammen mit Transaktionsgebühren an die Miner und Masternodes ausgezahlt. DMS verwendet einen für CPU optimierten Algorithmus, um das Mining mit Standard-Computern und Servern zu ermöglichen.

Wählen Sie den Menübefehl Werkzeuge | Mining und geben Sie die Anzahl der zu nutzenden logischen Prozessoren an. Die Software versucht anschließend, neue Blöcke zu generieren. Ob dies gelingt, hängt vor allem vom aktuellen Schwierigkeitsgrad ab. Je mehr Miner (Konkurrenten) beteiligt sind, desto geringer die Erfolgschance.

Siehe auch Anleitung auf documentchain.org

Selbst erzeugen: Masternode

Masternodes speichern eine Kopie der gesamten Blockchain, sind möglichst durchgehend verfügbar und sichern so das Netzwerk. Zusätzlich zu einfachen Full-Nodes managen Sie private Zahlungsvorgänge. Betreiber von Masternodes erhalten einen Teil der geschürften Coins.

Siehe auch Anleitung auf documentchain.org


DMS-Wallet-Einstellungen

Einstellungen DMS Core

Navigation: »Kein übergeordnetes Kapitel«

Einstellungen DMS Core

Einstellungen des Wallets "DMS Core"

Alternativ zum Web-Wallet können Sie auch eine eigene Wallet-Software verwenden. Dies ist sinnvoll, wenn Sie sehr viele Dokumente hinterlegen möchten.

1.Installieren Sie DMS Core.

2.Klicken Sie im Office Manager-Hauptmenü bitte auf Datei | Optionen | Einstellungen und wechseln Sie zur Seite Dokument | Blockchain.

3.Wählen Sie "Documentchain" für das echte Netzwerk oder das Testnet für kostenlose Tests.

4.Deaktivieren Sie die Option Web-Wallet verwenden.

5.Geben Sie Ihren Namen oder Firmenbezeichnung ein. Der Hash dieser Bezeichnung wird dann zusammen mit den Dokumentinformationen in der Blockchain hinterlegt.

Kommunikations-Daten

Office Manager kommuniziert über RPC mit dem Wallet "DMS Core" und muss hierfür die Zugangsdaten kennen. Wenn beide Programme auf demselben Computer installiert sind, werden die erforderlichen Daten bei Bedarf automatisch in die Wallet-Konfigurationsdatei "dms.conf" eingetragen. Sie müssen das Wallet neu starten, falls Sie dazu aufgefordert werden.

Sie können die Optionen "rpcuser" und "rpcpassword" auch beliebig anpassen, beide Programme lesen diese aus derselben Datei "dms.conf". Achten Sie bei Änderungen bitte darauf, dass die Option "server=1" in der Konfiguration enthalten ist.

Wallet im lokalen Netzwerk

Falls die Programme auf unterschiedlichen Computern laufen, müssen Sie Office Manager die Verbindungsdaten mitteilen. Diese werden in der admin.ini hinterlegt:

[Blockchain]

DMS.Publisher=Ihre Firma

DMS.EncryptKeyEn=xyz

DMS.URL=http://192.168.0.123

DMS.User=DmsRpcUser

DMS.Publisher ist eine Standardeinstellung, die in den Einstellungen eingegeben wird (siehe oben). Die anderen Optionen sind nur für eine Remoteverbindung zur Walletsoftware nötig:

·DMS.URL: Die Adresse des Computers, auf dem DMS Core läuft.

·DMS.User: Option "rpcuser" aus "dms.conf" im Klartext.

·DMS.PasswordEn: verschlüsseltes RPC-Kennwort. Kopieren Sie bitte den Wert von "rpcpassword" aus "dms.conf" in den Office Manager-Makroeditor. Markieren Sie das Passwort im Editor und klicken Sie im Hauptmenü auf Text verschlüsseln. Das nun verschlüsselte Kennwort tragen Sie hinter "DMS.PasswordEn=" ein.

Zum Einlesen der geänderten admin.ini ist ein Programmneustart erforderlich.

Siehe auch

Lösungen für häufige Fehler


Dokumentvorlagen importieren

Dokumentenvorlagen importieren

Navigation: »Kein übergeordnetes Kapitel«

Dokumentenvorlagen importieren

Dokumentenvorlagen aus anderem Archiv importieren

Die Dokumentenvorlagen werden in der Archivdatenbank gespeichert, jedes Archiv hat somit unterschiedliche Vorlagen. Wenn Sie die Dokumentenvorlagen aus einem anderen Archiv übernehmen möchten,

·wählen Sie bitte den Menübefehl Erstellen | Neu | Vorlagen | Dokumentvorlagen bearbeiten,

·klicken Sie auf Importieren und

·wählen Sie das Archiv, aus dem die Vorlagen kopiert werden sollen.

·Markieren Sie anschließend alle Einträge die Sie übernehmen möchten

·und klicken Sie auf OK.


Unterschiedliche Dokumentenverzeichnisse

Navigation: »Kein übergeordnetes Kapitel«

Unterschiedliche Dokumentenverzeichnisse

Beispiel zu den Makrofunktionen ReadAdminIni und GetFirstNotEmpty
zur Definition unterschiedlicher Dokumentenverzeichnisse.

Die Einstellung des Dokumentenverzeichnisses gilt für alle Archivdatenbanken. In der Regel wird ein gemeinsames Stammverzeichnis (z. B. G:\Office Manager DMS\Dokumente\) vorgegeben und die Dokumente in Archiv- und Projekt-Unterverzeichnissen gespeichert: "G:\Office Manager DMS\Dokumente\{Self:DocDB,Name}\{Doc:Project}\".

In seltenen Fällen kann es aber erforderlich sein, für unterschiedliche Archive komplett andere Verzeichnisse vorzugeben. Wenn Sie Office Manager Enterprise verwenden, dann können Sie dies bequem mit den archivspezifischen Einstellungen realisieren.

In älteren Versionen und der Pro-Edition wird ein benutzerdefinierter Wert in der admin.ini definiert und dieser mit ReadAdminiIni ausgelesen.

Beispiel 1

Die Dokumente des Archivs "Office.omcs" sollen in "G:\Dokumente\..." und die des Archivs "Privat.omp" in "N:\Daten\Privat\..." gespeichert werden. Für die Projekte werden Unterverzeichnisse angelegt.

Der admin.ini werden folgende Zeilen hinzugefügt:

[Macro_ReadAdminIni]

PathOffice=G:\Dokumente\{Doc:Project}\

PathPrivat=N:\Daten\Privat\{Doc:Project}\

Gelesen werden die Werte mit:

{ReadAdminIni:Path{Self:DocDB,Name}}

Um sicher zu gehen, dass für alle Archive ein Dokumentenverzeichnis definiert ist, wird die Funktion GetFirstNotEmpty verwendet. Die Einstellung des Dokumentenverzeichnisses lautet vollständig:

{GetFirstNotEmpty:{ReadAdminIni:Path{Self:DocDB,Name}},G:\Daten\{Doc:Project}\}

Zur Erklärung: Der gelb markierte Ausdruck wird verwendet, wenn für das Archiv ein Wert in der admin.ini vorhanden ist. Der grün markierte Wert ist eine Vorgabe, falls kein Wert vorhanden oder dieser leer ist.

Beispiel 2

Dokumente mit dem Status "Steuerrelevant" sollen auf dem WORM-Datenträger X, alle anderen unter "G:\Dokumente\..." gespeichert werden. Für die Projekte werden Unterverzeichnisse angelegt.
Hinweis: Das Attribut Status hat den internen Feldnamen STATE.

Der admin.ini werden folgende Zeilen hinzugefügt:

[Macro_ReadAdminIni]

PathStateSteuerRelevant=X:\{Doc:Project}\

Die Einstellung des Dokumentenverzeichnisses lautet:

{GetFirstNotEmpty:{ReadAdminIni:PathState{Doc:State}},G:\Daten\{Doc:Project}\}

Siehe auch

Office Manager Developer Network


Beispiel-Report

Navigation: »Kein übergeordnetes Kapitel«

Beispiel-Report
Beispielblatt eines gedruckten Archivreports

Siehe auch

Report drucken


Dokument löschen (DSGVO)

Navigation: »Kein übergeordnetes Kapitel«

Dokument löschen (DSGVO)

Verfügbar in diesen Editionen

Administratives Löschen eines gesperrten Dokuments aus Datenschutzgründen. Diese Funktion darf nur in Ausnahmefällen genutzt werden.

Die Datenschutz-Grundverordnung beinhaltet ein Recht auf Vergessenwerden. Dies kann dazu führen, dass Sie Dokumente löschen müssen, sobald keine Gründe mehr für die Speicherung vorliegen.

Der Normalfall

Office Manager steuert, sofern aktiviert, den Dokumenten-Lebenszyklus über die Kategorie: ein Dokument kann nach Ablauf der Aufbewahrungsfristen mit der normalen Funktion vollständig entfernt werden. Prüfen Sie zuerst, ob ein normales Löschen möglich ist.

Ausnahmesituation

Es sind aber Situationen denkbar, in denen der Datenschutz Vorrang hat und Sie personenbezogene Daten entfernen müssen, obwohl die Archivierungssoftware diese sperrt. Beispielsweise durch eine falsche Kategoriezuordnung oder eine neue gesetzliche Vorgabe. In so einem Fall können Sie diese administrative Funktion verwenden.

Entscheidung treffen

Halten Sie Rücksprache mit Ihrem Datenschutzbeauftragten und prüfen Sie, ob das Dokument gelöscht werden muss. Überlegen Sie auch, ob alternativ eine Zugriffseinschränkung der Dokumentdatei mit den Windows-Dateiberechtigungen infrage kommt. Beachten Sie die gesetzlichen Vorgaben, unter anderem

Art. 17 DSGVO - Recht auf Löschung ("Recht auf Vergessenwerden")
Die betroffene Person hat das Recht [...] dass sie betreffende personenbezogene Daten unverzüglich gelöscht werden [...] sofern einer der folgenden Gründe zutrifft:
a) Die personenbezogenen Daten sind für die Zwecke, für die sie erhoben oder auf sonstige Weise verarbeitet wurden, nicht mehr notwendig. [...]

Siehe auch Wikipedia und bfdi.bund.de

Dokument löschen (DSGVO)

Sie benötigen administrative Berechtigungen, wenden Sie sich bei Bedarf an Ihren Administrator. Die Dokumentdatei und alle Versionen sowie die OCR-Sicherheitskopie werden vom Datenträger gelöscht. Der Archivdatensatz wird bis auf die Belegnummer, Datum und einige Systemfelder geleert, bleibt aber mit Ihrer Begründung als Dokumentenname im Papierkorb erhalten. Bei einer späteren Dokumentenrevision wird auf diesen Vorgang hingewiesen.

1.Lassen Sie sich von Ihrem Datenschutzbeauftragten bestätigen, dass ein Löschen erforderlich ist.

2.Melden Sie sich als Office Manager-Administrator an: Menü Datei | Optionen | Administrator.

3.Falls sich das Dokument bereits im Papierkorb befindet, müssen Sie es zuerst wiederherstellen.

4.Markieren Sie das zu löschende Dokument in der Tabelle. Es können nur einzelne Dokumente entfernt werden.

5.Wechseln Sie zur Menüseite Administrator, öffnen Sie das Untermenü Administrator und klicken Sie auf Dokument löschen (DSGVO).

6.Bestätigen Sie, wenn Sie sicher sind, die Rückfrage mit Ja bzw. Löschen.

7.Geben Sie im Dialog eine Begründung ein.


Datei verschieben

Datei konnte nicht verschoben werden

Office Manager passt die Dateinamen- und Pfade automatisch an neue Attribute (insbesondere die Projektzuordnung) an, wenn die Option Vorgabe gilt auch für bestehende Dateien aktiviert ist.

Der häufigste Grund für diese Meldung ist eine geöffnete und somit gesperrte Dokumentdatei. Schließen Sie diese und klicken Sie auf Wiederholen.

Wenn Sie Abbrechen wählen, dann bleibt die Datei am ursprünglichen Speicherort und wird nicht umbenannt.


Dokumente komprimieren

Navigation: »Kein übergeordnetes Kapitel«

Dokumente komprimieren

Verfügbar in diesen Editionen

Dokumente komprimieren

Markieren Sie bitte das Dokument in der Tabelle und wählen Sie den Menübefehl Bearbeiten | Dokument | Eigenschaften Eigenschaften.

Option: Dokumentdatei komprimieren

Markieren Sie die Option Dokumentdatei komprimieren und klicken Sie auf OK. Die Dokumentdatei wird jetzt mit Windows-Funktionen komprimiert und belegt weniger Speicherplatz auf dem Datenträger.

Diese Option nutzt Windows NTFS-Funktionen und ist nicht auf allen Datenträgern möglich.

Siehe auch

Dokumente an ZIP-Archiv senden


Fenster Dokumentverknüpfungen

Navigation: »Kein übergeordnetes Kapitel«

Fenster Dokumentverknüpfungen

Das Dialogfenster "Interne Dokumentverknüpfungen"

Menü Bearbeiten | Dokument | Verknüpfen, nur Enterprise-Edition

Mit Hilfe der Verknüpfungsfunktion werden Dokumente innerhalb eines Archivs kombiniert. Zum Verständnis beachten Sie bitte das Kapitel Dokumente kombinieren, dort wird die Funktion anhand eines Beispieles beschrieben.

Klicken Sie im Bild auf die Komponenten, zu der Sie weitere Hilfe wünschen.

Markierte Dokumente miteinander verknüpfen

Die in der Dokumententabelle markierten Dokumente werden kombiniert. Geben Sie bitte einen beliebigen Verknüpfungsnamen ein und klicken Sie auf OK.

Dokumente zu bestehender Verknüpfung hinzufügen

Die Dokumente werden einer bereits vorhandenen Verknüpfung hinzugefügt. Markieren die gewünschte Verknüpfung bitte in der unteren Liste und klicken Sie auf OK.

Dokumente aus Verknüpfung entfernen

Markieren Sie die Verknüpfung, aus welcher die Dokumente entfernt werden sollen und klicken Sie auf OK.

Siehe auch

Dokumente kombinieren


Dateimaske und Kontakte

Dateimaske, Makro und Kontaktliste

Navigation: »Kein übergeordnetes Kapitel«

Dateimaske, Makro und Kontaktliste

Syntax für erweiterte Eingabestile

Menü Datei | Datenbank | Anpassen | Felder definieren

1. Dateiliste oder Makro

1a. Dateiliste

Datenfelder mit diesem Eingabestil werden beispielsweise in der CAD-Zeichnungsverwaltung für die Auswahl von Schriftkopf-Vorlagendateien verwendet. Das Kombinationsfeld erhält eine Auswahlliste mit den entsprechenden Dateinamen.

Geben Sie im Feld Format bitte an, welche Dateien zur Auswahl stehen sollen. Syntax: "Verzeichnis,Dateimaske,Formatierung":

Verzeichnis gibt den Pfad an, in dem die Dateien gespeichert sind.

Dateimaske ist ein Filterkriterium für Dateien, beispielsweise "*.dwg". Mehrere Filter werden durch Semikolon getrennt.

Formatierung: "Name" gibt den Dateinamen ohne Endung, "File" gibt ihn mit Endung an. "FileName" gibt die Datei mit Endung und Pfad an.

Geben Sie die Parameter bitte im SDF-Format (Komma getrennt) ein.

Beispiel

G:\Office Manager DMS\Gemeinsame Dateien\Template\CadFrame\CadFrame,*.dwg,Name

1b. Makro

Wenn das eingegebene Format mit einer geschweiften Klammer "{" beginnt, dann wird es also Makro interpretiert. Sie können hiermit beispielsweise den Inhalt einer Textdatei oder die Spalte einer beliebigen Datentabelle als Auswahlliste bereitstellen. Verwenden Sie die üblichen Zeilen-Trennzeichen mit ASCII-Code 13 und/oder 10. Das Makro wird beim Öffnen des Archivs interpretiert, die Liste ist sortiert, doppelte Einträge entfernt.

Beispiel Textdatei

{ReadLnFile:C:\Daten\Auswahlliste.txt,Row=0}

Beispiel Datenbank-Spalte

{ExecuteMacroFile:AdoSelectList.omac}

Als Format können maximal 200 Zeichen eingegeben werden, größere Makros müssen also in einer Datei gespeichert werden. "AdoSelectList.omac" liegt im Standard-Verzeichnis und hat folgenden Inhalt:

{AdoSetConnection:Provider=SQLOLEDB.1;Integrated Security=SSPI;Initial Catalog=Datenbankname;Data Source=Servername}

{AdoOperation:Open,SELECT DISTINCT feldname FROM tabellenname}

{AdoGetFieldValues:feldname,{Chr:10}}

{AdoOperation:Close}

{AdoDestroy}

2. Interne Kontaktliste

Feldliste für den Eingabestil "Kontaktliste"(speziell für Datenfeld contactguid), zum Beispiel "matchcode;company;firstname;lastname". Hiermit werden die Kontakte der Office Manager-Adressdatenbank in den Dokumentbeschreibungen eingebunden. Geben Sie die gewünschten Datenfelder der Kontaktdatenbank (Tabelle contact) mit einem Semikolon getrennt an.

Wichtig: Geben Sie an der ersten Stelle "matchcode" oder ein anderes Feld an, welches immer Daten beinhaltet. Anderenfalls zeigt das Eingabefeld keine Daten, wenn ein Kontakt gewählt ist.

Das Eingabefeld der Kontaktauswahl kann mit Entf. geleert werden.

3. Externe Kontaktliste

Format für den Eingabestil "Outlook-Kontaktliste", zum Beispiel "CompanyName, FirstName LastName".

Folgende Strings werden als Variablen interpretiert: CompanyName, LastName, FirstName, FullName, CustomerID, EntryID, OrganizationalIDNumber, ComputerNetworkName und Email1Address (bei Email ev. Sicherheitswarnung von Outlook).

Leer- und einige Sonderzeichen am Anfang und Ende werden automatisch entfernt.

Wählen Sie den Eingabestil "Outlook-Kontaktliste" und geben Sie im Feld Format bitte die Syntax der Kontakte ein. Folgende Variablen sind möglich:

Variable

Beschreibung

EntryID

Datensatz-ID

FullName

Vollständiger Kontaktname

Email1Address

E-Mail-Adresse

CompanyName

Firma

FirstName

Vorname

OrganizationalIDNumber

Datensatz-ID der Firma

LastName

Nachname

ComputerNetworkName

Computername

CustomerID

Kundennummer

{FileName=..}

Gibt den Kontaktordner an, falls nicht der Standardordner
verwendet werden soll.
{FileName=Folder} Angabe des Ordnernamens, wie im Outlook.
{FileName=#1} Angabe der Ordnernummer hinter #.
{FileName=#Select} Der Ordner wird beim Öffnen des
Archivs manuell gewählt.
{FileName=#ID..} Angabe der Outlook-EntryID hinter #ID

{unsorted}

Keine Sortierung der Liste.


Editionen

Navigation: »Kein übergeordnetes Kapitel«

Editionen

Programm-Edition

Office Manager DMS wird in mehreren Editionen mit unterschiedlichem Funktionsumfang herausgegeben:

1.Gonz@les DMS - Document Runner
Dokumentenverwaltung "Small" für Privatanwender.

2.Office Manager for ScanSnap
Sonderedition, die im Paket mit dem Ricoh ScanSnap erhältlich ist.

3.Office Manager Pro
Professionelle Dokumentenmanagement- und Archivierungssoftware mit Funktionen für die Dokumentenrevision.

4.Office Manager Enterprise
Höchste Ausbaustufe für das Unternehmens-Netzwerk mit Unterstützung von SQL-Datenbankservern, umfangreichen Automatisierungsmöglichkeiten und Sicherheitsoptionen.

Upgrademöglichkeit

Wenn Sie eine Funktion benötigen, die in Ihrer Edition fehlt, dann können Sie auf eine höhere Edition upgraden. Wenden Sie sich bitte an Ihren Händler oder wählen Sie im Menü Hilfe | Internet | Version registrieren.

Kennzeichnung in der Dokumentation

In einigen Hilfethemen finden den Hinweis auf die Verfügbarkeit der beschriebenen Programmfunktion:

Abbildung

Bedeutung
Enterprise

Nur im Office Manager Enterprise verfügbar
Pro, Enterprise

Nur in Pro und Enterprise
ScanSnap, Pro, Enterprise

Nur in ScanSnap, Pro und Enterprise
Small, Pro, Enterprise

Nur in Gonz@les, Pro und Enterprise

Dies bedeutet, dass die entsprechende Funktion vorhanden und die Dokumentation für die Edition relevant ist. Der Funktionsumfang kann sich in den verschiedenen Editionen aber unterscheiden.

Internet-Links

Funktionsübersicht

Preisliste


Übersicht Eingabestile

Navigation: »Kein übergeordnetes Kapitel«

Übersicht Eingabestile

Eingabestil
Menü Datei | Datenbank | Anpassen | Felder definieren

Wählen Sie den gewünschten Eingabestil für das Datenfeld aus. Je nach Datentyp stehen unterschiedliche Eingabestile zur Verfügung:

Eingabefeld: die Daten werden frei eingegeben.

Eingabefeld mit Liste: die Daten können aus einer Auswahlliste gewählt und frei eingegeben werden.

Nur Auswahl aus Liste: die Daten können nur aus einer Liste gewählt werden, eine freie Eingabe ist nicht möglich. Dies verhindert u. a. Schreibfehler. Bei diesem Eingabestil werden die erweiterten Eigenschaften auch im Editor dargestellt.

Eingabefeld mit strukturierter Liste: die Daten können aus einer strukturierten Auswahlliste gewählt und frei eingegeben werden. Die Einträge der Liste können untergliedert werden (Baumdarstellung).

Nur Auswahl aus strukturierter Liste: die Daten können nur aus einer strukturierten Liste gewählt werden, eine freie Eingabe ist nicht möglich.

Dateiliste oder Makro: die Daten können nur aus der Liste gewählt werden. Welche Daten die Liste enthält, legen Sie im Feld Format fest.

Outlook-Kontaktliste: liest die Adressdatenbank von Microsoft Outlook ein und ermöglicht eine einfache Zuordnung der Dokumente zu Ihren Kontakten (s. a. Format).

Kontaktliste: listet die Kontakte des integrierten CRM auf, speziell für Datenfeld "contactguid".

Optionsfeld: ein Kontrollfeld, das nur markiert oder nicht markiert sein kann.

Mehrzeiliges Eingabefeld für mehrzeiligen Text, wie z. B. die Notizen.

Datum: Eingabefeld und Auswahldialog für ein Datum

Zeit: Eingabefeld für Uhrzeit.

Datum und Zeit: kombiniertes Feld.

Eingabefeld mit Rechner: Eingabefeld für numerische Datenfelder mit einblendbarem Rechner.

Grafik: Feld mit Grafikdaten.


Einschränkungen in der Ansicht "Archivierte Dokumente"

Navigation: »Kein übergeordnetes Kapitel«

Einschränkungen in der Ansicht "Archivierte Dokumente"

Verfügbar in diesen Editionen

In der Ansicht "Archivierte Dokumente" sind einige Programmfunktionen deaktiviert:

·Eigenschaften: Sie können die Dokumentattribute nicht ändern.

·Die Dokumentdateien sind schreibgeschützt.

·Dokumente können nicht gelöscht werden.

·Es können keine neuen Dokumente erstellt oder Dokumentversionen archiviert werden.

·Die automatischen Importfunktionen sind pausiert, neue Dokumente werden erst übernommen, wenn Sie zur Ansicht "Aktive Dokumente" zurückkehren.

·Die Archiv-Synchronisierung ist deaktiviert.

·Und anderes.


ABBYY Hot Folder & Scheduling

Navigation: »Kein übergeordnetes Kapitel«

ABBYY Hot Folder & Scheduling

2. Einstellungen OCR-Software

2a. Einstellungen der OCR-Software "ABBYY Hot Folder & Scheduling"

"Hot Folder & Scheduling" ist in den FineReader Corporate- und Site Licence- Editionen enthalten.

·Starten Sie bitte "Hot Folder & Scheduling" und klicken Sie auf den Schalter Neu.

·Auf der ersten Seite geben Sie bei Ordner das Importverzeichnis an, beispielsweise "\\Server\Freigabe\OCR\Import". Als Dateityp wählen Sie bitte "PDF-Dateien" und die Zeiteinstellung "Ordner regelmäßig überprüfen". Die verarbeiteten Bilder sollten aus dem Ordner entfernt werden.

·Klicken Sie auf Weiter.

·Bei Schritt 2 können Sie die Standardeinstellungen beibehalten.

·Klicken Sie auf Weiter, um die Seite "Schritt 3" zu öffnen.

·Der Ausgabeordner ist das Exportverzeichnis, z. B. "\\Server\Freigabe\OCR\Export". Wählen Sie als Dateityp bitte "PDF-Dokument" und klicken Sie auf den Schalter Formateinstellungen. Wichtig: Auf Seite PDF geben Sie bei Speichermodus bitte "Text unter dem Seitenbild" an. Dies stellt sicher, dass die gescannte Grafik für die Dokumentenarchivierung erhalten bleibt. Für die Qualität ist "Hoch" empfohlen.

·Klicken Sie bitte auf Fertigstellen.

Hinweise zur FineReader-Version 11.0

Bei "Datei aus Ordner öffnen, Dokumente" wählen Sie bitte die Option "Erstellen Sie ein separates Dokument für jede Datei". Dokument speichern, Dateiname: Bitte Eingabedateinamen verwenden.
Siehe auch Blog-Artikel

3. Einstellungen Office Manager


Parametergesteuerte OCR-Software

Navigation: »Kein übergeordnetes Kapitel«

Parametergesteuerte OCR-Software

Parametergesteuerte OCR-Software
(Menü Datei | Optionen | Einstellungen, Seite Volltextindex | OCR)

Diese Option ist flexibel und arbeitet mit OCR-Programmen zusammen, die den Text in einer Grafikdatei erkennen und dieses selbständig in der Grafik- oder PDF-Datei hinterlegen können.

Funktionsablauf:

1.Der Office Manager liest Papierdokumente über einen Twain-kompatiblen Scanner ein und speichert die Bilder beispielsweise in einer Tiff-Datei oder bettet sie in einem PDF-Dokument ein.

2.Anschließend startet er das angegebene OCR-Programm und übergibt diesem den Namen der Dokumentdatei als Parameter.

3.Die OCR-Software extrahiert den Text und speichert ihn entweder direkt im Dokument (in den Metadaten der Tiff- oder JPeg-Datei oder als hinterlegten Text im PDF-Dokument) oder in einer separaten Textdatei.

4.Der Office Manager liest den extrahierten Text ein und erstellt den Volltextindex für eine spätere Suche.

Erforderliche Einstellungen:

OCR-Software: Wählen Sie bitte "Andere, Parametergesteuert".

Dateiname: Geben Sie den Dateinamen (*.exe) der OCR-Software mit komplettem Pfad ein.

Grafikformate: Markieren Sie die von der OCR-Software unterstützten Grafikformate, beispielsweise Tiff.

Siehe auch

Einstellungen OCR-Software

Makrogesteuert OCR-Software


Makrogesteuerte OCR-Software

Navigation: »Kein übergeordnetes Kapitel«

Makrogesteuerte OCR-Software

Makrogesteuerte OCR-Software
(Menü Datei | Optionen | Einstellungen, Seite Volltextindex | OCR)

Diese Option ist äußert flexibel, erfordert aber Programmierkenntnisse. Sie dient in erster Linie der Anbindung weiterer OCR-Programme durch das Softwarebüro Krekeler.

Funktionsablauf:

1.Der Office Manager liest Papierdokumente über einen Twain-kompatiblen Scanner ein und speichert die Bilder beispielsweise in einer Grafik-Datei oder bettet sie in einem PDF-Dokument ein.

2.Anschließend führt er das angegebene Makro aus, um die OCR-Software zu steuern.
Wenn die OCR während dem Scannen ausgeführt wird, dann ist das Dokument noch in einer temporären Datei gespeichert. Verwenden Sie im Skript bitte "{GetPublVar:OcrCurrFileName}", um den Dateinamen zu ermitteln. Die Variable kann auch bei einer nachträglichen Texterkennung verwendet werden.

3.Die OCR-Software extrahiert den Text und speichert ihn entweder direkt im Dokument (in den Metadaten der Tiff- oder JPeg-Datei oder als hinterlegten Text im PDF-Dokument) oder in einer separaten Textdatei.

4.Der Office Manager liest den extrahierten Text ein und erstellt den Volltextindex für eine spätere Suche.

Erforderliche Einstellungen:

OCR-Software: Wählen Sie bitte "Andere, Makrogesteuert".

Dateiname: Geben Sie den Namen der Makrodatei (*.mac, *.js, *.vbs) mit komplettem Pfad ein. Klicken Sie auf den Schalter Makro, und geben Sie den Skriptquelltext ein.

Grafikformate: Markieren Sie die von der OCR-Software unterstützten Grafikformate, beispielsweise PDF und TIFF.

Siehe auch

Einstellungen OCR-Software

Parametergesteuerte OCR-Software

Makro-Referenz


OmniPage OCR-Software

Navigation: »Kein übergeordnetes Kapitel«

OmniPage OCR-Software

OCR-Software "Kofax/Nuance OmniPage"
(Menü Datei | Optionen | Einstellungen, Seite Volltextindex | OCR)

OmniPage kann von der Archivierungssoftware direkt gesteuert werden und bietet sehr gute Ergebnisse.

Office Manager verwendet für PDF-Dokumente den Textkonverter "Converters.Text.PDFImageOnText". Wenn Sie die Einstellungen anpassen möchten, dann wählen Sie bitte im OmniPage-Menü Extras | Speichereinstellungen. Markieren Sie den Textkonverter "Durchsuchbares PDF-Bild" und klicken Sie auf Optionen. Vermeiden Sie eine Änderung des Grafikmodus. Die Konvertierung eines Farbbildes in Schwarzweiß kann z. B. bei schwachen Farben zu einer vollständig weißen Grafik führen. Die PDF-Kompatibilität "Auf Größe optimieren" führt insbesondere bei Farbscans zu einer schlechten Qualität der digitalisierten Dokumente.

Hinweise für fortgeschrittene OmniPage-Anwender

Relevant sind die Einstellungen in der Konfigurationsdatei "Automation.sts". Falls im Office Manager-Programmverzeichnis die Datei "omnipage.sts" vorhanden ist, dann werden die Einstellungen aus dieser eingelesen.

Für PDF-Dateien wird das Export Text Format "Converters.Text.PDFImageOnText" verwendet. Wenn Sie ein anderes Format wählen möchten, können Sie dies in der Windows-Registrierdatenbank vorgeben:
HKLM\Krekeler\Office Manager (Version)\OCR: OmniPage.PDFExportTextFormat = "Formatname"

Siehe auch

Einstellungen OCR-Software

OmniPage Agent verwenden


OmniPage Agent

Navigation: »Kein übergeordnetes Kapitel«

OmniPage Agent

2. Einstellungen OCR-Software

2b. Einstellungen der OCR-Software "OmniPage Agent"

Die Funktion ist in OmniPage Professional enthalten. Eine ausführliche Anleitung mit Screenshots finden Sie auch im Supportartikel zum OmniPage Agent.

·Starten Sie bitte "OmniPage Batch Manager" wählen Sie im Menü Datei den Befehl Aufgabe erstellen. Markieren Sie "Ordnerüberwachungsauftrag" und geben Sie als Auftragsname z. B. "Office Manager" ein.

·Klicken Sie auf Weiter.

·Wählen Sie bei Zu überwachende Ordner bitte das Importverzeichnis (z. B. "\\Server\Freigabe\OCR\Import") und markieren Sie dieses. Klicken Sie auf Weiter.

·Geben Sie bitte bei Beginn "Jetzt beginnen" und bei Ende "Kein Zeitlimit" ein. Markieren Sie die Optionen Eingabedateien löschen und Auftrag ohne Eingabeaufforderung ausführen.

·Klicken Sie zweimal auf Weiter.

·Geben Sie bitte die gewünschten Vorverarbeitungs-Optionen ein, markieren Sie Neues Dokument erstellen für jede Bilddatei und klicken Sie auf Weiter.

·Markieren Sie bitte Bearbeitung erkannter Seiten ohne Erkennungsprüfung zulassen und klicken Sie auf Weiter bis zum Schritt 5 "Speichern".

·Wählen Sie Speichern als "Text", Dateioperation "Eine Datei für alle Seiten", Dateityp "Durchsuchbares PDF-Bild" und als Speicherort das Exportverzeichnis, z. B. "\\Server\Freigabe\OCR\Export". Hinter dem Speicherort sollte jetzt "<Original-Dateiname.pdf>" stehen.
OmniPage Agent Einstellungen

·Klicken Sie bitte auf Fertigstellen (mit dem Schalter Weiter würden zusätzliche Arbeitsschritte erstellt).

·Wählen Sie im Menü Extras den Befehl Optionen und markieren Sie auf Seite Allgemeines bitte OmniPage Agent im Infobereich anzeigen. Klicken Sie auf OK.

·Sie können den OmniPage Batch Manager jetzt beenden.

2c. OmniPage-Auftrag bearbeiten

Falls Sie später Änderungen am oben definierten OCR-Auftrag vornehmen möchten, dann markieren Sie diesen bitte links in der Auftragsliste und klicken Sie zuerst auf den Menübefehl Datei | Auftrag deaktivieren. Erst danach können Sie mit Bearbeiten | Ändern die gewünschten Änderungen vornehmen.

3. Einstellungen Office Manager


ReadIRIS überwachter Ordner

Navigation: »Kein übergeordnetes Kapitel«

ReadIRIS überwachter Ordner

2. Einstellungen OCR-Software

2c. Einstellungen der OCR-Software "ReadIRIS überwachter Ordner"

Die Funktion ist in der ReadIRIS Corporate-Edition enthalten.

·Starten Sie ReadIRIS und wählen Sie im Menü Datei den Befehl Überwachter Ordner.

·Geben Sie bei Bildordner auswählen das Importverzeichnis (z. B. "\\Server\Freigabe\OCR\Import") und bei Textordner auswählen bitte das Exportverzeichnis (z. B. "\\Server\Freigabe\OCR\Export") an.

·Klicken Sie auf den Schalter Textformat und wählen Sie bei Externe Datei das Format "Adobe Acrobat PDF Bild-Text". Dies stellt sicher, dass die gescannte Grafik für die Dokumentenarchivierung erhalten bleibt. Klicken Sie bitte auf OK.
ReadIRIS OCR

·Klicken Sie im Fenster "Überwachter Ordner" bitte auf OK, um die Überwachung zu starten.

3. Einstellungen Office Manager


Hot Folder OCR-Software

Navigation: »Kein übergeordnetes Kapitel«

Hot Folder OCR-Software

OCR-Software "ABBYY Hot Folder, OmniPage Agent, ReadIRIS u. ä."
(Menü Datei | Optionen | Einstellungen, Seite Volltextindex | OCR)

Für OCR-Programme, die ein Verzeichnis überwachen und neue Dokumente automatisch verarbeiten.

1. Funktionsablauf

·Die OCR-Software überwacht ein Verzeichnis "Import".

·Office Manager kopiert das gescannte PDF-Dokument in dieses Verzeichnis.

·OCR startet die Texterkennung, schreibt den Text in das PDF-Dokument und verschiebt es in ein Verzeichnis "Export".

·Office Manager prüft, ob das Dokument im Exportverzeichnis vorhanden ist. Wenn ja, dann ersetzt er das ursprüngliche Dokument mit diesem und indexiert den Text für die Volltextsuche. Wenn nein, dann wird die Prüfung später erneut durchgeführt.

2. Einstellungen OCR-Software

·Legen Sie bitte ein temporäres Verzeichnis für die Texterkennung fest, beispielsweise "\\Server\Freigabe\OCR". Erstellen Sie diese Verzeichnis und darin die Unterverzeichnisse "Import" und "Export".

·Stellen Sie die Software bitte so ein, dass der Unterordner "Import" des zuvor festgelegten temporären Verzeichnisses überwacht wird. Die verarbeiteten Dokumente müssen anschließend im Unterordner "Export" gespeichert werden.
Siehe Beschreibungen für:
ABBYY Hot Folder & Scheduling
OmniPage Agent
ReadIRIS überwachter Ordner

3. Einstellungen Office Manager

·Öffnen Sie bitte im Menü Datei | Optionen | Einstellungen die Seite Volltextindex | OCR.

·Wählen Sie bei OCR-Software "ABBYY Hot Folder, OmniPage Agent, ReadIRIS u. ä." und geben Sie als Verzeichnis das zuvor festgelegte temporäre Verzeichnis, z. B. "\\Server\Freigabe\OCR" an. Die Unterverzeichnisse werden bei Bedarf automatisch erstellt. Die Ausführungszeit ist "Im Hintergrund".

·Klicken Sie bitte auf OK.

4. Hinweise

Stellen Sie bitte sicher, dass die OCR-Software gestartet ist, wenn Sie Dokumente scannen. OCR kann auch auf einem andere Rechner, z. B. einem Server, ausgeführt werden.
Bis zur fertigen Indexierung des Dokuments vergehen mindestens 2 Minuten.

Siehe auch

Einstellungen OCR-Software


Einstellungen zum Senden an Steuerberater

Navigation: »Kein übergeordnetes Kapitel«

Einstellungen zum Senden an Steuerberater

Verfügbar in diesen Editionen

Bevor Sie die Funktion verwenden können, müssen einige Einstellungen vorgenommen werden.

1.Hierfür sind eventuell administrative Rechte erforderlich, siehe Menü Datei | Optionen | Administrator.

2.Öffnen Sie das Dialogfenster Datei | Datenbank | Datenaustausch | An Steuerberater senden.

3.Geben Sie die gewünschten Einstellungen auf den Registerseiten Optionen und Filter an.

Nutzen Sie die Direkthilfe bei Fragen zu den einzelnen Optionen.

Grundsätzliche Funktionsweise

ZIP-Datei erstellen

Packt die Dokumentdateien in eine ZIP-Datei. Dieses kann dann beispielsweise per E-Mail an den Steuerberater gegeben werden.

In das Ausgabeverzeichnis kopieren

Die Dokumentdateien werden in das angegebene Ausgabeverzeichnis kopiert.

DATEV Unternehmen online

Die Dokumentdateien werden in das Ausgabeverzeichnis kopiert. Im Gegensatz zur Option "In das Verzeichnis kopieren" werden für DATEV möglichst keine E-Mails weitergegeben, sondern nur die anliegenden PDF-Dokumente und XRechnungen.

Geben Sie bitte das Verzeichnis an, welches die Daten mit DATEV synchronisiert und legen Sie fest, ob die Standard-Unterordner verwendet werden sollen.

Archiv-Austauschdatei

Für Empfänger, die ebenfalls Office Manager DMS verwenden. Die Austauschdatei beinhaltet die Dokumente mit den Beschreibungen aus der Archivdatenbank. In der Enterprise-Edition wird für aktive und archivierte Dokumente jeweils eine eigene .omexc-Austauschdatei erstellt.

Der Import beim Empfänger erfolgt über den Menübefehl Datei | Datenbank | Datenaustausch | Importieren.


Volltextsuche mit MS SQL-Server

Navigation: »Kein übergeordnetes Kapitel«

Volltextsuche mit MS SQL Server

Volltextsuche des MS SQL Servers aktivieren
Nur Enterprise-Edition

Alternativ zur Standard-Volltextsuche können Sie auch den Index des MS SQL Servers verwenden. Die Vorteile liegen in einer schnelleren Verarbeitung großer Datenbestände, der Indexierung durch den Server mit Entlastung der Clients und den erweiterten Abfragemöglichkeiten mit Fuzzylogik.

Eine ausführliche Anleitung finden Sie im Supportbereich von officemanager.de.

Voraussetzungen

Office Manager Enterprise und Speicherung des Archivs auf einem MS SQL Server. Die automatische Aktivierung wurde mit Versionen ab 2008 R2 getestet. Wenn Sie die Express-Edition verwenden möchten, dann installieren Sie bitte Express with Advanced Services. Nehmen Sie im Zweifel das größtmögliche Paket.

Aktivieren

Beim Anlegen eines neuen Archivs markieren Sie bitte die Option SQL Server-Index aktivieren.
(Hinweis: Wenn das als Vorlage geöffnete Archiv den Index von SQLite oder MS SQL verwendet, dann können Sie diese Option für das neu zu erstellende Archiv nicht deaktivieren.)

Alternativ können dies auch nachträglich in den Programmeinstellungen durchführen:

1.Wählen Sie bitte den Menübefehl Datei | Optionen | Einstellungen und wechseln Sie zur Seite Volltextindex. Klicken Sie auf den Schalter SQL Server-Index aktivieren. Der Datenbank wird das Datenfeld contenttext hinzugefügt und die Volltextkomponente auf dem Server aktiviert.

2.Schließen Sie die Archivdatenbank und öffnen Sie dieser erneut oder starten Sie Office Manager neu.

3.Wählen Sie erneut den Menübefehl Datei | Optionen | Einstellungen. Klicken Sie auf der Seite Volltextindex bitte auf den Schalter Index neu erstellen. Alle Dokumententexte werden aus den Dateien extrahiert und in das Datenfeld contenttext geschrieben. Der SQL-Server indiziert anschließend den Text.


Einstellungen Volltextindex

Navigation: »Kein übergeordnetes Kapitel«

Einstellungen Volltextindex

Einstellungen für den Volltextindex
Menü Datei | Optionen | Einstellungen

Optionen

Um eine Suche im Index zu ermöglichen, muss die Option Volltextindex entsprechend ausgewählt sein. Sie können die Mindestlänge der Wörter einstellen, Zahlen ignorieren und die Liste der Stopp-Wörter bearbeiten. Wenn der Index auch über die Dokumentinhalte erstellt wird, können Sie die zu indexierenden Dateitypen und die maximale Dateigröße festlegen.

Index neu erstellen

Wenn Sie die Einstellungen geändert haben und die Änderungen auch für die bereits im Archiv vorhandenen Dokumente durchgeführt werden soll, dann muss der Index neu erstellt werden. Klicken Sie dazu auf den Schalter Index neu erstellen. Beachten Sie bitte, dass diese Funktion sehr zeitaufwändig ist. Bei großen Datenbanken sollte der Index z. B. nachts neu erstellt werden.

SQL Server-Index

Die Enterprise-Edition ermöglicht neben der Standard-Volltextsuche auch die Volltextkataloge des MS SQL-Servers. Klicken Sie bitte auf den Schalter SQL Server-Index aktiveren, um die erforderlichen Änderungen in der Archivdatenbank durchzuführen. Der Index muss hierfür vollständig neu aufgebaut werden.

Unterstützte Dateitypen

Für die Volltextindexierung wird der in den Dokumenten enthaltene Text extrahiert und in den Datenbankindex geschrieben. Das Programm beinhaltet Konvertierungsroutinen, um den Text aus folgenden Dateitypen zu lesen. Die Dokumente werden auch indexiert, wenn sie in einem ZIP-Archiv oder einer E-Mail enthalten sind (s. a. erweiterte Einstellung IndexAttachments).

Intern unterstützt

Adobe Acrobat: .pdf

XML Paper Specification: .xps, .oxps

Microsoft Office: .doc, .docx, .docm, .dotx, .xls, .xlsx, .xlsm, .pptx, .ppsx

Apache OpenOffice: .odf, .odg, .odp, .ods, .odt, .sxc, .sxd, .sxi, .sxw

e-Book: .epub

Rich Text Format: .rtf

Word Perfect: .wpd

Textdateien: .txt und alle Dateien, die reinen Text beinhalten

Drawing Interchange Format: .dxf

E-Mails: .eml, .msg, .nws

HTML- und XML-Formate: .htm, .html, .xml, .enex

Webarchive: .mht, .mhtml

Metadateien: .emf, .wmf, .qrp (QuickReport)

Unterstützt mit Fremdprogrammen

Grafikformate, wenn eine OCR-Texterkennung ausgeführt wird

Zeichnungen, sofern AutoCAD installiert ist: .dwg

Andere

Sie können die Volltextsuche auch für andere Dateitypen aktivieren, indem Sie diese in die Liste der zu indexierenden Dateitypen eintragen. Die Datei wird dann einfach als Textdatei betrachtet und die enthaltenen Wörter indexiert. Hierbei kann sehr viel unbrauchbarer "Text" den Index belasten. Prüfen Sie bitte die Ergebnisse einer Indexierung und entscheiden Sie, ob diese sinnvoll ist.

Unterstützte Komprimierungs-Archive

Dateien werden auch indiziert, wenn sie in folgenden Archivformaten komprimiert sind: .cab, .jar, .tar, .gz, .tgz, .zip

Siehe auch

Datenbankpflege, Option Volltextindex aktualisieren

Suche im Volltextindex

Erweiterte Einstellungen

Einstellungen OCR-Software


Fehler DDE-Befehl

DDE-Befehl konnte nicht übermittelt werden

Diese Fehlermeldung erhalten Sie, wenn ein DDE-Befehl nicht an die Anwendung gesendet werden konnte. Warten Sie ggf. bis die Anwendung gestartet ist und klicken Sie dann auf Wiederholen, um den Befehl erneut zu senden.

Oder klicken Sie auf OK, um den nächsten DDE-Befehl zu senden oder auf Abbrechen, um das Makro zu beenden.

Tipp: Wenn das Problem bei diesem Anwendungsprogramm öfters auftritt, sollten Sie die Makrofunktion DDEOpenLink mit dem Parameter Synchron aufrufen.


Ereignisgesteuerter Befehl

Verfügbar in diesen Editionen

Ereignis

Menü Datei | Optionen | Dokumenttyp, Seite Befehle | Erweitert

Der Befehl wird automatisch ausgeführt, wenn das gewählte Ereignis eintritt. Die dynamische CAD-Schnittstelle nutzt beispielsweise das Ereignis "OnFtiReadFile", um geänderte Schriftkopfattribute aus der Zeichnung zu übernehmen.

·(kein Ereignis): der Befehl wird nicht automatisch ausgeführt. Dies ist der Normalfall.

·AfterEditDBFields: der Befehl wird ausgeführt, nachdem die Dokumentattribute geändert wurden (Menü Bearbeiten | Dokument | Eigenschaften).

·AfterPostNewDoc: nach der Speicherung eines neuen Datensatzes im Archiv.

·AfterPostChangedDoc: nach der Speicherung eines geänderten Datensatzes im Archiv.

·AfterPostDoc: nach der Speicherung eines neuen oder geänderten Datensatzes im Archiv.
Wenn ein Befehl für das Ereignis AfterPostDoc und zusätzlich ein Befehl für AfterPostNewDoc/AfterPostChangedDoc definiert ist, dann wird zuerst AfterPostDoc ausgeführt.

·AfterCreateDocFile: nachdem die Datei eines neuen Dokumentdatensatzes angelegt wurde, beispielsweise Erzeugung einer neuen Datei oder Kopieren/Verschieben einer Vorlage, einer gescannten oder importierten Datei.

·OnFileChange: beim Aktivieren des Office Managers, wenn die aktuelle Dokumentdatei geändert wurde.

·OnFtiReadFile: direkt bevor eine Dokumentdatei für die Volltextindexierung gelesen wird. Dieses Ereignis tritt nur ein, wenn die Indexierung der Dokumentdatei aktiviert ist (s. a. Einstellungen | Volltextindex).


Attribute können nicht übernommen werden

Sie haben ein Dokument auf der gruppierten Office Manager-Dokumenttabelle abgelegt. Die Gruppierung beinhaltet ein Attribut, dessen Wert nicht automatisch dem neuen Dokument zugeordnet werden kann.

Folgende Attribute können nie übernommen werden:

·Dateiname

·Name des Bearbeiters

·Datum/Zeit der Bearbeitung oder Erstellung

Sie sollten die Tabelle nicht nach diesen Feldern gruppieren, wenn Sie Dateien per Drag&Drop übernehmen.

Die Dokumentdateien werden jetzt übernommen, das entsprechende Datenfeld aber nicht angepasst.


Meldung: Lizenzen verbraucht

Navigation: »Kein übergeordnetes Kapitel«

Meldung: Lizenzen verbraucht

"Sie können nicht angemeldet werden, weil n von m Lizenzen bereits verwendet werden."

Diese Meldung erhalten Sie beim Start von Office Manager DMS, wenn alle verfügbaren Lizenzen in Verwendung sind. Sie müssen, je nach Lizenzmodell, entweder warten bis eine Lizenz frei wird oder zusätzliche Lizenzen erwerben.

Klicken Sie bitte auf:

·OK, um das Programm zu beenden.

·Wiederholen, um zu prüfen, ob zwischenzeitlich eine Lizenz frei geworden ist.

·Ignorieren: Es ist möglich, dass eine Lizenz nicht ordnungsgemäß freigegeben wurde. Gründe hierfür sind beispielsweise Netzwerkprobleme, ein Systemabsturz, Cloud-Synchronisierungen, fehlende Berechtigungen oder das Einspielen einer Datensicherung. Mit dem Ignorieren werden verwaiste Einträge aus der Lizenzüberwachung entfernt. Dieser Vorgang kann mehrere Minuten erfordern.


Ist kein Synchronarchiv

Fehler "ist kein Synchronarchiv von"

Die im Eingabefeld synchronisieren mit ausgewählte Datei ist kein Synchronarchiv des geöffneten Dokumentenarchivs. Sie sollten ein Archiv nur mit einem zuvor erstellten Synchronarchiv abgleichen.

Sie haben wahrscheinlich das synchrone Archiv geöffnet und versuchen dieses mit dem ursprünglichen abzugleichen.

Sie müssen aber das ursprüngliche Archiv (z. B. im Firmennetzwerk) öffnen und diese mit dem synchronen (z. B. auf dem Notebook) abgleichen.

Siehe auch

Daten synchronisieren


Fehler beim Synchronisieren

Fehler beim Synchronisieren von Dokument ...

Das Dokument konnte nicht synchronisiert werden. Klicken Sie bitte auf:

Abbrechen, um die Synchronisierung zu beenden.

Wiederholen, um es erneut zu versuchen.

Ignorieren, um den Datensatz zu überspringen.


Fehler: Neues Dokument

Navigation: »Kein übergeordnetes Kapitel«

Fehler: Neues Dokument

Fehler beim Anlegen neuer Dokumente

Sie finden hier eine Liste der möglichen Fehlerursachen und erhalten Hinweise zu deren Behebung.

Anwendung wird nicht gestartet: Überprüfen Sie bitte, ob das Anwendungsprogramm für den gewählten Dokumenttyp verfügbar ist (siehe auch).

Fehler: Überprüfen Sie die Datei...: Die Vorlagendatei für dieses Dokument wurde nicht gefunden. Überprüfen Sie bitte die Vorlagendateien im entsprechenden Dokumenttyp (Menü Datei | Optionen | Dokumenttyp). Im Netzwerkbetrieb tritt dieser Fehler z. B. auf, wenn bestimmte Anwendungsprogramme lokal auf den einzelnen Computern installiert sind und die Pfade auf den Computern unterschiedlich sind.

Fehler: Das Verzeichnis konnte nicht erstellt werden: Überprüfen Sie bitte die Einstellungen für die automatische Erzeugung der Dokument-Dateinamen (Datei | Optionen | Einstellungen, Seite Dokument).

Der Schlüsselwert für "DOCID" konnte nicht ermittelt werden. Bei MS SQL und MySQL/MariaDB kann dies an den gespeicherten Prozeduren liegen, falls Sie diese geändert haben.

Fehler: Ein an das System angeschlossene Gerät funktioniert nicht: Vermutlich ist die Windows-Zuordnung der Dateiendung mit der entsprechenden Anwendung nicht richtig konfiguriert (siehe Blog-Artikel) oder es gibt ein Problem mit dem Laufwerk, auf dem die Dokumentdatei gespeichert werden soll.


Fehler: Dokumenttyp "..." ist nicht definiert.

Der diesem Dokument zugeordnete Dokumenttyp ist nicht (mehr) definiert.

Dieser Fehler tritt auf, wenn:

1.Ein Dokumenttyp gelöscht oder umbenannt wurde obwohl bereits Dokumente zugeordnet sind. Sie können entweder den Dokumenttyp korrigieren oder den Datensatz des Dokumentes anpassen. Wählen Sie dazu im Menü Bearbeiten | Dokument | Eigenschaften und korrigieren Sie den Dokumenttyp.

2.Im Netzwerkbetrieb ein Dokumenttyp nur auf einem anderen Arbeitsplatz definiert ist. Wenn z. B. zwei Arbeitsplätze auf eine gemeinsame Dokumentendatenbank zugreifen, die Dokumenttypen aber jeweils in einer eigenen Datenbank definiert sind, kann der erste Arbeitsplatz ggf. nicht auf die Daten des zweiten zugreifen. Es ist ja auch möglich, dass auf beiden Computern unterschiedlich Anwendungsprogramme installiert sind.


Schriftkopf-Vorlage nicht gefunden

Fehler: Schriftkopf-Vorlage nicht gefunden

Die Vorlage-Datei wird benötigt, um den Schriftkopf für eine neue CAD-Zeichnung zu erstellen. Mögliche Ursache: Die Datei (z. B. ..\template\zngkopf.dxf) wurde entweder gelöscht oder bei der Einrichtung des CAD-Dokumenttypen falsch definiert.

Siehe auch

Einrichtungsassistent für AutoCAD und MegaCAD

Benutzerdefinierte Steuerung von Anwendungen

DxfCreateFrame

MegaCreateFrame

Schriftkopf-Erzeugung für MegaCAD manuell einstellen


Mit dem Dokumenttyp können keine neuen Dokumente erstellt werden

Der gewählte Dokumenttyp kann keine neuen Dokumente erstellen. Wählen Sie einen anderen Dokumenttyp aus der Liste oder ändern Sie die Einstellungen des Typs (Menü Datei | Optionen | Dokumenttyp).


Fehler: Der Schlüsselwert konnte nicht ermittelt werden

Fehler: Der Schlüsselwert für "(Feld)" konnte nicht ermittelt werden.

Der Fehler tritt beim Hinzufügen neuer Datensätze auf, wenn der Wert für das Schlüsselfeld nicht ermittelt werden konnte. In großen Netzwerken kann dies gelegentlich auftreten, wenn viele Anwender gleichzeitig neue Datensätze erstellen. Klicken Sie in diesem Fall auf Wiederholen.

Sollte der Fehler immer wieder auftreten, klicken Sie bitte auf Abbrechen. Beenden Sie den Office Manager und starten Sie ihn erneut. Falls der Fehler weiterhin auftritt, informieren Sie bitte Ihren Datenbank-Administrator. Die Ursache liegt in der Dokumentendatenbank in Tabelle IDENTNO. Der Datensatz "(Feld)" kann nicht geändert werden, weil er vermutlich von einem anderen Benutzer gesperrt ist.


Fehler: Aktualisierbare Abfrage erforderlich

Archiv-Schreibschutz

Fehlermeldung "ERROR: attempt to write a readonly database" oder "Operation muss eine aktualisierbare Abfrage verwenden".

Die Daten konnten nicht gespeichert werden, weil Sie vermutlich keine Schreibrechte in der Archivdatenbank besitzen. Sie benötigen Lese- und Schreibrechte auf die Datenbank und im Verzeichnis der gemeinsamen Dateien.

Fehlerbehebung

Schreibschutzattribut der Datei entfernen oder Zugriffsrechte ändern, Details finden Sie im Supportartikel im Internet.

Eine weitere Ursache kann in den Sicherheitseinstellungen des SQL-Servers liegen, wenn Sie mit der DMS-Edition Enterprise arbeiten.


Anmeldefehler

Fehler beim Login

Beim Zugriff auf die Lizenz-Sperrdatei ist ein Fehler aufgetreten, Sie können nicht angemeldet werden.

Klicken Sie auf bitte Wiederholen, falls der Fehler gelegentlich auftritt ("Datei von anderem Prozess gesperrt").

Falls keine Anmeldung möglich ist (z. B. "Zugriff verweigert"), dann fehlen Ihnen die erforderlichen Berechtigungen im Verzeichnis der Gemeinsamen Dateien. Korrigieren Sie bitte die Windows-Berechtigungen, wenden Sie sich ggf. an Ihren Administrator.

Siehe auch

Lizenzmodelle


omAdmin registrieren

COM-Server omadmin.exe registrieren

Unter Windows sind einige Systembereiche durch die Benutzerkontensteuerung (UAC) geschützt. Office Manager DMS verwendet ein eigenes Hilfsprogramm, welches für geschützte Einstellungen die Administrationsrechte anfordert.

Dieses Hilfsprogramm scheint nicht korrekt registriert zu sein. Klicken Sie bitte auf Ja, um die Registrierung durchzuführen.

Bei aktivierter Benutzerkontensteuerung müssen Sie anschließend die Windows-Sicherheitsabfrage "Möchten Sie zulassen, dass ... Änderungen vorgenommen werden" bestätigen. Sie benötigen hierfür eventuell das Windows-Administratorkennwort. Die Abfrage ist zweimal nötig: einmal für die Registrierung des Tools und nach erfolgreicher Registrierung für die Ausführung der ursprünglichen Funktion.


Dokumentdatensätze konnten nicht kopiert werden

Navigation: »Kein übergeordnetes Kapitel«

Dokumentdatensätze konnten nicht kopiert werden

Beim Datenbankimport in ein Archiv konnten die genannten Dokument-Datensätze nicht kopiert werden.

Mögliche Ursachen können in den Zugriffsrechten liegen oder beispielsweise an inkompatiblen Datentypen, wenn zwischen verschiedenen Datenbankformaten kopiert wird.

In der Fehlermeldung werden die Schlüsselnummern aller Dokumente aufgeführt, die nicht kopiert wurden.

Tipp: Sie können den Text der Meldung in die Zwischenablage kopieren. Klicken Sie das Dialogfenster an und drücken Sie Strg+C.

Betroffene Dokumente suchen

Öffnen Sie das Quellarchiv in einem weiteren Office Manager-Programmfenster und suchen Sie mit dem Menübefehl Start | Weitere | Schlüssel einzeln nach den aufgeführten Nummern. Prüfen Sie insbesondere die Datum-Felder (Belegdatum u. a.) und korrigieren falschen Daten.

Wenn nur wenige Dokumente nicht kopiert wurden, dann können Sie diese einzeln per Drag&Drop vom Quellarchiv in das Zielarchiv kopieren. Wenn ein grundsätzlicher Fehler vorlag, ist es ev. einfacher, den gesamten Vorgang zu wiederholen.


fehler-90024-pdf-dll

Fehler beim Initialisieren von DebenuPDF

Navigation: »Kein übergeordnetes Kapitel«

Fehler beim Initialisieren von DebenuPDF

Office Manager DMS nutzt ab Version 23.0.1.580 zum Erstellen und Verarbeiten von PDF-Dokumenten auch Funktionen aus einer Programmbibliothek. Diese Dynamic Link Library wird im Programmverzeichnis erwartet und heißt

·"DebenuPDF32.dll" bei einem 32 Bit-DMS

·oder "DebenuPDF64.dll" bei 64 Bit.

Die Bibliothek ist wichtig und muss korrekt eingebunden sein. Wenn Sie diese Fehlermeldung erhalten, dann beheben Sie den Fehler, bevor Sie weiter mit dem DMS arbeiten. Beispielsweise können sonst beim Scannen keine PDF-Dokumente erzeugt werden.

Wenn die Datei nicht vorhanden ist, dann laden Sie diese bitte mit Hilfe der Softwareaktualisierung. Eine weitere Ursache kann an mangelnden Dateizugriffsrechten liegen.


Feldauswahl

Navigation: »Kein übergeordnetes Kapitel«

Feldauswahl

Tabellenspalten ein- und ausblenden
Menü Ansicht | Anpassen | Feldauswahl

Mit dieser Funktion können Sie die sichtbaren Spalten (Datenfelder) in der Tabelle auswählen. Ziehen Sie ein Datenfeld aus der Liste der verfügbaren Felder per Drag&Drop auf die Tabelle, um dieses in die Tabelle einzufügen.

Ziehen Sie ein Feld von der Tabelle auf die Liste der verfügbaren Felder, um dieses aus der Tabelle zu entfernen.

Um eine einzelne Spalten auszublenden, können Sie auch mit der rechten Maustaste auf die Spaltenüberschrift klicken und im Kontextmenü den Eintrag Feld ausblenden wählen.

Felder bearbeiten und neue erstellen

Mit oben genannter Funktion können bestehende Spalten ein- und ausgeblendet werden. Wenn Sie eigene Spalten erstellen möchten, dann wählen Sie bitte den Menübefehl Datei | Datenbank | Anpassen | Felder definieren.


Felder für SQL-Server definieren

Navigation: »Kein übergeordnetes Kapitel«

Felder für SQL-Server definieren

Verfügbar in diesen Editionen

Felder definieren
Besonderheiten bei SQL-Servern

Bei Access-Datenbanken kann das Programm die Datenbankstrukturen direkt ändern. Bei SQL-Servern ist dies aber nur über SQL-Befehle (Data Definition Language, Alter Table) möglich.

Folgende Punkte sollten Sie beachten, wenn Sie Felder einer SQL-Server-Datenbank anpassen möchten:

1.Benutzerrechte: Klicken Sie auf den Schalter DB-Login, wenn Sie sich mit erweiterten Benutzerrechten an der Datenbank anzumelden müssen.

2.Bestehende Felder ändern: Die Feldeigenschaften Feldname und ggf. der Datentyp und die Feldgröße können mit SQL nicht direkt geändert werden. Wenn Sie eine Feldeigenschaft ändern, erstellt das Programm ein neues Feld mit den gewünschten Eigenschaften, kopiert die Daten aus dem ursprünglichen Feld und löscht anschließend das ursprüngliche Feld. Dies hat zur Folge, dass ein geändertes Feld immer an das Ende der Feldliste verschoben wird.
Tipp: wenn Sie nur die Feldgröße oder den Datentyp ändern möchten, so können Sie dies auch direkt mit der Datenbanksoftware (SQL Management Studio, HeidiSQL für MySQL und MariaDB) vornehmen. Im Office Manager sind dafür keine Anpassungen nötig.
Für die Eigenschaften auf den Registerseiten "Ansicht", "Feldwerte" und "Sicherheit", sowie für das Hinzufügen neuer Felder gelten diese Einschränkungen nicht.

3.Manche SQL-Server erlauben kein Löschen von Feldern, dadurch ist auch die unter 2 beschriebene Änderung bestehender Felder nicht möglich. Halten Sie in solchen Fällen bitte Rücksprache mit dem Datenbank-Administrator. Sie müssen ein neues Feld erstellen, die Daten mit dem SQL-Befehl "Update" kopieren und das alte Feld mit Hilfe der Datenbanksoftware löschen.

4.Logische Datentypen werden von einem Feldtyp Zeichenkette mit einer Länge 1 und dem Eingabestil Optionsfeld repräsentiert. Ihr Datenbanksystem muss also keine logischen Datentypen unterstützen.

Siehe auch

Felder definieren


Eindeutiger Wert

Navigation: »Kein übergeordnetes Kapitel«

Eindeutiger Wert

Verfügbar in diesen Editionen

Menü Datei | Datenbank | Anpassen | Felder definieren

Kann verhindern, dass ein Wert mehrmals in der Datenbank bzw. im Buchungsjahr vorkommt. Die Option dient ausschließlich der Benutzerinformation, wenn beispielsweise eine Belegnummer mehrfach vergeben wurde.

Sonderfall Belegnummer und Buchungsjahr

In der Buchhaltung ist es üblich, dass die Belegnummern nur innerhalb eines Jahres eindeutig sind. Office Manager behandelt diesen Sonderfall automatisch:

Wenn beim Datenfeld DOCNO eindeutige Werte aktiviert sind und der Beleg einem Projekt (Buchungsjahr) zugeordnet wird, welches aus vier Ziffern besteht, dann muss die Nummer nur innerhalb des Projektes eindeutig sein.

Wichtige Informationen

Die Eindeutigkeit wird nicht auf Datenbankebene festgelegt, sondern nur vor dem Speichern eines Datensatzes geprüft. Die Option hat keinen Einfluss auf bereits vorhandene Dokumente oder Kontakte.

Wird beim manuellen Speichern eines Datensatzes ein Verstoß gegen die Eindeutigkeit festgestellt, wird der Anwender zur Korrektur aufgefordert.

Bei automatisierten Funktionen greift diese Prüfung nicht. Beispielsweise auch nicht, wenn ein Dokument nachträglich in ein anderes Buchungsjahr verschoben wird.

Leere Werte sind zulässig, außer auf Seite Ansicht ist Eingabe erforderlich markiert.

Nach doppelten Werten suchen

Klicken Sie in der Datentabelle bitte mit der rechten Maustaste auf den gewünschten Wert und wählen Sie im lokalen Menü den obersten Befehl unterhalb von Suchen.


Seitenzahl ermitteln

Navigation: »Kein übergeordnetes Kapitel«

Seitenzahl ermitteln

Das dateiabhängige Attribut FILEPAGECOUNT und die Makro-Funktion FilePageCount unterstützen folgende Dokumente:

PDF, TIFF, GIF, QRP

Die Seitenzahl wird mit internen Funktionen ermittelt. Bei TIFF- und GIF-Grafiken entspricht die Seitenzahl der Anzahl an Einzelbildern.

Textdateien (TXT)

Es wird mit 68 Zeilen je Seite gerechnet, dies entspricht ungefähr der Seitenzahl bei Ausdruck mit dem Windows-Editor.

BMP, JPG, PNG, EMF, WMF

Die Seitenzahl ist immer 1.

Office Dokumente und alle anderen Dateien

Die Seitenzahl wird, sofern vorhanden, aus dem erweiterten Dateiattribut "Number of Pages" gelesen.


Einrichtungsassistent: Überblick

Navigation: »Kein übergeordnetes Kapitel«

Einrichtungsassistent: Überblick

Einrichtungs-Assistent
(Menü Datei | Optionen | Assistent)

Der Assistent hilft Ihnen bei der Einrichtung Ihres Office Managers. Sie können sehr einfach die Anwendungsprogramme registrieren und die wichtigsten Programmeinstellungen festlegen:

Lizenzierung: Freischalten der Vollversion oder kostenlose Registrierung

Dokumenteinstellungen: Verzeichnisse und Optionen

Anwendungsprogramme einrichten: Programme im Office Manager registrieren

Datenbankeinstellungen: Systemoptimierung

Sicherheit und Administration: Sicherheits-Grundeinstellungen

Verknüpfungen: Office Manager-Dateien im Windows registrieren und Autostart-Option

Hilfe: Aktiviert die Online-Hilfe automatisch


Einrichtungsassistent: Dokumenttypen

Navigation: »Kein übergeordnetes Kapitel«

Einrichtungsassistent: Dokumenttypen

Einrichtungs-Assistent

Seite 1: Lizenzierung

Seite 2: Dokumenteinstellungen

Seite 3: Anwendungsprogramme einrichten. Wählen Sie die Anwendungsprogramme aus, mit denen der Office Managerzusammenarbeiten soll. Die Dokumente der ausgewählten Anwendungen können dann mit dem Office Manager verwaltet werden.
Sie sollten vorerst nur die wichtigsten Anwendungen auswählen, weitere Programme können Sie jederzeit hinzufügen.

Kicken Sie auf Weiter, um die markierten Anwendungen zu registrieren und zur nächsten Seite des Assistenten zu gelangen.

Seite 4: Datenbankeinstellungen

Seite 5: Sicherheit und Administration: Voreinstellungen der Sicherheitsoptionen

Seite 6: Verknüpfungen: Office Manager-Dateien im Windows registrieren und Autostart-Option


Einrichtungsassistent: Datenbanken

Navigation: »Kein übergeordnetes Kapitel«

Einrichtungsassistent: Datenbanken

Einrichtungs-Assistent

Seite 1: Lizenzierung

Seite 2: Dokumenteinstellungen

Seite 3: Anwendungsprogramme einrichten

Seite 4: Datenbankeinstellungen. Optimierungen für die Datenbankzugriffe.
Mit den drei Schaltflächen im oberen Bereich können Sie die Optionen voreinstellen. Wählen Sie Einzelarbeitsplatz, wenn Sie nur lokal arbeiten. Kleines Netzwerk für bis zu ca. fünf Arbeitsplätze oder Großes Netzwerk für viele Arbeitsplätze und hohes Dokumentenaufkommen. Bei moderner Hardware und schnellem SQL-Server können aber auch im Netzwerk alle Optionen aktiviert sein.

Die einzelnen Optionen können Sie auch später in den Einstellungen anpassen:
Dokument-Bearbeitung protokollieren
Anzeige der Dokumentenanzahl
Beim Start alle Datensätze abrufen
Programmsymbole darstellen

Kicken Sie auf Weiter, um zur nächsten Seite des Assistenten zu gelangen.

Seite 5: Sicherheit und Administration. Voreinstellungen der Sicherheitsoptionen.

Seite 6: Verknüpfungen: Office Manager-Dateien im Windows registrieren und Autostart-Option.


Einrichtungsassistent: Dokumenteinstellungen

Navigation: »Kein übergeordnetes Kapitel«

Einrichtungsassistent: Dokumenteinstellungen

Einrichtungs-Assistent

Seite 1: Lizenzierung

Seite 2: Dokumenteinstellungen. Sie können die Verzeichnisstruktur und Dateinamen festlegen, in denen neue Dokumente gespeichert werden.

Kicken Sie auf Weiter, um zur nächsten Seite des Assistenten zu gelangen.

Seite 3: Anwendungsprogramme einrichten

Seite 4: Datenbankeinstellungen

Seite 5: Sicherheit und Administration: Voreinstellungen der Sicherheitsoptionen

Seite 6: Verknüpfungen: Office Manager-Dateien im Windows registrieren und Autostart-Option

Tipp: Nutzen Sie auch die Direkthilfe. Klicken Sie auf das Fragezeichen rechts im Fenstertitel und anschließend auf die Komponente, zu der Sie weitere Informationen benötigen.


Einrichtungsassistent: Lizenzierung

Navigation: »Kein übergeordnetes Kapitel«

Einrichtungsassistent: Lizenzierung

Einrichtungs-Assistent

Seite 1: Lizenzierung. Wenn Sie die Vollversion des Office Managers erworben haben, dann geben Sie bitte hier den Aktivierungscode ein. Sie finden die Nummer entweder auf der CD oder Sie wurde Ihnen per E-Mail übermittelt.

Für die Testversion benötigen Sie keinen Code. Sie können die Software dann an 30 Tagen kostenlos testen, um sich von ihrem Nutzen zu überzeugen. Hierbei zählen nur die Tage, an denen das Programm verwendet wird.

Kicken Sie auf Weiter, um zur nächsten Seite des Assistenten zu gelangen.

Seite 2: Dokumenteinstellungen

Seite 3: Anwendungsprogramme einrichten

Seite 4: Datenbankeinstellungen

Seite 5: Sicherheit und Administration: Voreinstellungen der Sicherheitsoptionen

Seite 6: Verknüpfungen: Office Manager-Dateien im Windows registrieren und Autostart-Option


Einrichtungsassistent: Verknüpfungen

Navigation: »Kein übergeordnetes Kapitel«

Einrichtungsassistent: Verknüpfungen

Einrichtungs-Assistent

Seite 1: Lizenzierung

Seite 2: Dokumenteinstellungen

Seite 3: Anwendungsprogramme einrichten

Seite 4: Datenbankeinstellungen

Seite 5: Sicherheit und Administration: Voreinstellungen der Sicherheitsoptionen

Seite 6: Verknüpfungen: Office Manager-Dateien im Windows registrieren und Autostart-Option
Dateitypen mit Office Manager verknüpfen
Office Manager automatisch ausführen

Klicken Sie auf Fertigstellen um die Einrichtung des Office Manager abzuschließen. Sie können die Einstellungen jederzeit im Menü Datei | Optionen ändern oder erweitern. Um den Einrichtungs-Assistenten erneut zu starten, wählen Sie bitte den Eintrag Assistent.

Interessante Hilfethemen für die ersten Schritte:

- Grundlagen

- Dokumente erstellen

- Dokumente suchen

- Der Administrator


Einstellungen Ricoh/Fujitsu ScanSnap-Manager

Navigation: »Kein übergeordnetes Kapitel«

Einstellungen Ricoh/Fujitsu ScanSnap-Manager

ScanSnap: manuelle Konfiguration

Die Anbindung an den ScanSnap wird vom Office Manager durchgeführt (s. a. Menü Datei | Optionen | Einstellungen, Seite Scannen | ScanSnap). Voraussetzung ist ein ScanSnap Manager Version 6.0 oder neuer bzw. ScanSnap Home.

Alternativ können Sie auch eine vereinfachte Anbindung manuell konfigurieren. Office Manager wird dabei als Zielanwendung für den Scanner angegeben:

A. Ricoh ScanSnap ix1500, iX1600 sowie Fujitsu ScanSnap iX500, S1500, S1100, S1300
oder älterer Scanner mit Treiber-Version des iX500/S1500

1.Klicken Sie bitte mit der rechten Maustaste auf das Symbol ScanSnap-Icon in der Windows-Taskleiste und wählen Sie den Menüpunkt Einstellungen der Scantaste.

2.Deaktivieren Sie die Option Quick-Menü verwenden.

3.Wechseln Sie zur Seite Anwendung. (Falls im unteren Bereich des Dialogfensters keine Registerseiten sichtbar sind, dann klicken Sie bitte auf den Schalter Detail, um diese einzublenden.)

4.Klicken Sie auf Installieren/Deinstallieren und anschließend auf Hinzufügen.

5.Im Eingabefeld Name der Anwendung bitte "Office Manager" eingeben und auf den Schalter Durchsuchen klicken.

6.Wählen Sie bitte die Datei "SendToOM.exe" (z. B. im Pfad C:\Programme\Krekeler\Office Manager DMS) aus.

7.Klicken Sie auf die Schalter Öffnen, OK und Schließen, Sie befinden sich wieder auf der Registerseite Anwendung des Hauptfensters.

8.Wählen Sie im Listenfeld Anwendung den neuen Eintrag "Office Manager". Dieser wird dadurch zu Zielanwendung für die gescannten Dokumente definiert.

9.Wechseln Sie zur Registerseite Speichern und deaktivieren die Option Datei nach Scan umbenennen.

10.Wechseln Sie bitte zur Seite Dateiart und wählen Sie das Dateiformat "PDF (*.pdf)".

11.Wenn Sie die Volltextsuche des Office Managers verwenden möchten, markieren Sie bitte die Option In durchsuchbare PDF konvertieren und stellen Sie die weiteren OCR-Optionen ein.

12. Klicken Sie bitte auf OK.

B. Fujitsu ScanSnap S510, S500, S300
oder älterer ScanSnap mit Treiber-Version des S510

1.Klicken Sie bitte mit der rechten Maustaste auf das Symbol ScanSnap-Icon in der Windows-Taskleiste. Deaktivieren Sie ggf. die Option Quick-Menü verwenden und wählen Sie den Menüpunkt Einstellungen.

2.Auf der Seite "Anwendung" klicken Sie auf Installieren/Deinstallieren und anschließend auf Hinzufügen.

3.Geben Sie im Eingabefeld Anwendungsname bitte "Office Manager" ein und wählen Sie die Datei "SendToOM.exe" (z. B. im Pfad C:\Programme\Krekeler\Office Manager) als Programm aus. Klicken Sie auf Schließen.

4.Auf der Seite "Anwendung" wählen Sie jetzt den neuen Eintrag "Office Manager" als Zielanwendung für die gescannten Dokumente aus.

5.Deaktivieren Sie auf der Seite Speichern unter die Option Datei nach Scan umbenennen.

6.Wechseln Sie bitte zur Seite Dateiart und wählen Sie das Dateiformat "PDF". Wenn Sie die Volltextsuche des Office Managers verwenden möchten, markieren Sie bitte die Option Suchbare PDF und stellen Sie die weiteren OCR-Optionen ein.

7. Klicken Sie bitte auf OK.

C. Fujitsu ScanSnap I, II und II plus

1.Klicken Sie bitte mit der rechten Maustaste auf das Symbol ScanSnap-Icon in der Windows-Taskleiste und wählen Sie den Menüpunkt Einstellungen.

2.Auf der Seite "Anwendung" klicken Sie auf Installieren/Deinstallieren und anschließend auf Hinzufügen.

3.Geben Sie im Eingabefeld Anwendungsname "Office Manager" ein und wählen Sie die Datei "SendToOM.exe" (z. B. im Pfad C:\Programme\Krekeler\Office Manager) als Programm aus. Klicken Sie auf Schließen.

4.Auf der Seite "Anwendung" wählen Sie jetzt bitte den neuen Eintrag "Office Manager" als Zielanwendung für die gescannten Dokumente aus.

5.Deaktivieren Sie auf der Seite Speichern unter die Option Datei nach Scan umbenennen.

6.Stellen Sie sicher, dass auf der Seite Dateiart das Format "PDF" gewählt ist und klicken Sie auf OK.

7.Starten Sie die Software "ABBYY FineReader for Fujitsu ScanSnap" und ändern Sie die Einstellungen für Scan2Pdf:
PDF-Datei nach der Erkennung öffnen sollte deaktiviert sein,
Dateiname vor dem Speichern ändern sollte deaktiviert sein.
Klicken Sie bitte auf OK.

Siehe auch

Fujitsu ScanSnap

OCR im Hintergrund ausführen

Stapel in Einzeldokumente teilen

ScanSnap-FAQ für Office Manager

PDF-Kurzanleitung


Einrichtungsassistent: Sicherheit

Navigation: »Kein übergeordnetes Kapitel«

Einrichtungsassistent: Sicherheit

Einrichtungs-Assistent

Seite 1: Lizenzierung

Seite 2: Dokumenteinstellungen

Seite 3: Anwendungsprogramme einrichten

Seite 4: Datenbankeinstellungen

Seite 5: Sicherheit und Administration.
Wird das Dokumentenmanagement von mehreren Personen oder im Firmennetzwerk genutzt, sollte der Administrator ein Passwort für den Schutz kritischer Funktionen vergeben. Die Zusatzinformation für Fehlermeldungen kann beispielsweise den administrativen Ansprechpartner beinhalten..

Kicken Sie auf Weiter, um zur nächsten Seite des Assistenten zu gelangen

Seite 6: Verknüpfungen: Office Manager-Dateien im Windows registrieren und Autostart-Option


Vordefinierte Datei-Zugriffsrechte

Verfügbar in diesen Editionen

Datei-Zugriffsrechte definieren

Geben Sie bitte zuerst eine passende Beschreibung für die Sicherheitsrichtlinie ein. Klicken Sie anschließend auf den Schalter Neu und wählen Sie ein Benutzer- oder Gruppenkonto aus. Markieren Sie die Zugriffsrechte, die der markierte Benutzer oder die Benutzergruppe erhalten soll.

Beispiele:

Beschreibung = "Normal" mit Vollzugriff für jeden Benutzer

"Office" mit Vollzugriff für die Benutzergruppe Office und Nur-Lesen für alle anderen

"Personal" mit Vollzugriff für die Personalabteilung und Geschäftsführung, aber keinerlei Rechte für andere Benutzer

Hinweise zur Benutzer- und Gruppenliste

In umfangreichen Netzwerkumgebungen kann das Laden der Windows-Benutzer und -Gruppen lange dauern. Beachten Sie in so einem Fall bitte folgende Tipps:

·Das Laden der Liste kann mit Esc abgebrochen werden, die Liste ist dann unvollständig.

·Die Liste wird nur einmal abgefragt. Wenn Sie diese aktualisieren möchten, schließen Sie bitte das Fenster der Programmeinstellungen und öffnen Sie es erneut.

·Wenn Sie den vollqualifizierten Namen des gewünschten Benutzers bzw. der Gruppe bereits kennen, können Sie diesen auch ohne Liste in einem einfachen Eingabedialog eingeben. Halten Sie hierzu bitte die Umschalt-Taste gedrückt, wenn Sie auf den Mausschalter Neu oder Bearbeiten klicken.

Siehe auch

Übersicht Datei-Zugriffsrechte


Begriff: Nummer

Die Dokumentennummer sollte den firmenspezifischen Vorgaben für Zeichnungs- oder Dokumentwnnummerierung entsprechen. Die Nummer kann aber auch leer bleiben.


Begriff: Dokumentenname

Der Dokumentenname wird beim Anlegen eines Dokumentes vom Anwender vergeben. Der Name kann frei gewählt werden und sollte das Dokument sinnvoll beschreiben.

Der Dokumentenname kann, muss aber nicht dem Dateinamen entsprechen.


Begriff: Projekt

Zuordnung des Dokuments zu einem Projekt.

Projekte werden im Menü Datei | Optionen | Auswahllisten definiert.


Begriff: Gruppe

Zuordnung des Dokumentes zu einer Kategorie.

Kategorien und andere Listen werden im Menü Datei | Optionen | Auswahllisten definiert.


Begriff: Status

Status eines Dokumentes, wie z. B.: Wichtig, Erledigt, Rücksprache, usw. zugeordnet werden.

Status-Eigenschaften werden im Menü Datei | Optionen | Auswahllisten definiert.


Begriff: Dokumenttyp

Der Dokumenttyp legt das Anwendungsprogramm fest, mit dem die Dokumente bearbeitet werden, wie z. B. MS Word Dokument, Excel Tabelle, CAD Zeichnung.

Im Menü Datei | Optionen | Dokumenttyp können Sie festlegen, welche Anwendungen aktiviert werden.


Begriff: Besitzer

Das Feld Besitzer enthält den Namen des Anwenders, der das Dokument erstellt hat.

Der Benutzername wird aus der Windowsanmeldung übernommen


Begriff: Schlüsselnummer

Der Schlüssel ist eine automatische EDV-Nummer, die für alle Dokumente erstellt wird.

Die Schlüsselnummer. ist innerhalb eines Archivs eindeutig, sie wird also immer nur einmal vergeben.


Begriff: Dateiname

Datei auf dem Datenträger, in der das Dokument gespeichert ist. Der Dateiname enthält die komplette Pfadangabe. Der Dateiname wird automatisch aus dem zugeordneten Projekt und dem Dokumentennamen erzeugt.

Bei Webseiten enthält das Attribut die Internetadresse.


Begriff: Dateiendung

Endung der Dokument-Dateien, z. B. "TXT", "DOC", "XLS" usw.


Begriff: Favorit

Bevorzugte Dokumente können als Favoriten gekennzeichnet werden. Die Suche nach diesen Dokumente ist einfacher, da Sie die Suche auch auf die Favoriten begrenzen können.


Begriff: Vorlagedatei

Eine Datei, die als Vorlage für neue Dokumente verwendet wird.


Begriff: Dokumentarchiv

Das Archiv (Dokumentdatenbank) beinhaltet alle Attribute, den Volltextindex und die Dateiverknüpfungen der verwalteten Dokumente.


Datum der Indexierung

Datenfeld für den Volltextindex. Es übernimmt das Dateidatum, wenn die Dokumentdatei indexiert wird


Begriff: Letzte Ereignisse

Letzte Ereignisse: Datenfeld für Hinweise und besondere Ereignisse.

Im Eigenschaftenfenster auf der Registerseite Protokoll können Sie einen beliebigen Text in diese Feld eingeben. Nach Klick auf OK wird Ihre Eingabe mit aktuellen Datum dem Protokoll hinzugefügt.

Beispiel: "Rechnung per Post verschickt".


Begriff: Notizen

Beliebige Notizen und Hinweise zum Dokument.

Tipp: Sie können hier auch Schlüsselwörter für die Volltextsuche eingeben.


Begriff: E-Mail Anlage

Wenn Sie eine E-Mail oder andere Datei mit mindestens einer Anlage importieren, wird das Dokument in der Tabelle mit einer Büroklammer gekennzeichnet.

Hinweis: Das Datenfeld "mailattachico" (Type Grafik) muss vorhanden sein.


Begriff: Anwendungsdatenbank

Die Anwendungsdatenbank beinhaltet alle Informationen zu den registrierten Dokumenttypen, die bekannten Benutzernamen und alle Aufgaben der Terminplanung.


OCR-Software

Optical Character Recognition-Software wandelt die vom Scanner eingelesen Bilder in Texte um. Der Office Manager kann die Dokumente anschließend indexieren, so dass eine Suche im Volltextindex möglich ist.


Begriff: Aktuelle Suche

Der Begriff "aktuelle Suche" bezeichnet die Datensätze, die derzeit aus dem Archiv abgerufen sind, also alle Einträge, die in der Dokumententabelle vorhanden sind.


Begriff: Dokumentattribut

Dokumentattribute sind Eigenschaften und Zugehörigkeiten der Dokumente, die in der Archivdatenbank gespeichert werden. Beispielsweise: Name, Nummer, Projekt, Status, Besitzer, Bearbeitungsdatum, Dokumenttyp und andere benutzerdefinierte Attribute.


Besonderheiten im GoBD-Archiv

Besonderheiten in GoBD-Archiven

Navigation: »Kein übergeordnetes Kapitel«

Besonderheiten in GoBD-Archiven

Verfügbar in diesen Editionen

Dokumentenarchive mit aktiviertem GoBD-Modus weisen folgende Abweichungen zu normalen Archiven auf:

Gesperrte Funktionen

·Dokumente können in den Papierkorb verschoben, aber nicht endgültig gelöscht werden. Ausnahmen sind abgelaufene Aufbewahrungsfristen und administratives Löschen aus Datenschutzgründen sowie kürzlich hinzugefügte Dokumente (siehe unten).

·Dokumentversionen können nicht gelöscht werden.

·Befehl Systemmenü im lokalen Popupmenü der Dokumententabelle sowie der Windows-Eigenschaftendialog.

·Einige Optionen des erweiterten Imports und Änderungen der Dateinamen.

·Das Wiederherstellen aus dem Langzeitarchiv ist nur für kürzlich archivierte Dokumente zulässig. Sobald das Archiv geschlossen wird, ist dies nicht mehr möglich.

·Datenbankimport und Archivsynchronisierung.

·Bildbearbeitung im Scandialog.

Besonderheiten

·Vor dem Öffnen wird das Schreibschutzattribut der Datei gesetzt.

·Einige Funktionen werden verweigert, wenn die Datei zwischenzeitlich verändert wurde. Beispielsweise OCR, Signierung und Archivierung.

·Einschränkungen bei der Verwendung von Vorlagen. Grundsätzlich sollten Dokumente gescannt oder importiert und nicht mit dem Befehl "Neu" erstellt werden.

·Die Änderung relevanter Dokumentattribute wird protokolliert, außer das Dokument wurde erst kürzlich hinzugefügt. Diese Attribute können nicht direkt in der Tabelle editiert werden.

·Texte der programmeigenen Textverarbeitung (Dokumenttyp "Notiz") können nachträglich nicht geändert, sondern nur mit Kommentaren erweitert werden.

Ausnahmen für neue Dokumente

Die einem Archiv neu hinzugefügten Dokumente werden in einer Speicherliste vermerkt, beim Schließen des Archivs wird diese Liste geleert. Alle Dokumente, die seit dem Öffnen des Archivs neu hinzu kamen, werden somit als "kürzlich hinzugefügt" betrachtet. Für diese gelten Erleichterungen bei der Revisionssicherheit:

·Änderungen an relevanten Dokumentattributen werden nicht protokolliert.

·Die Dokumente können noch endgültig gelöscht werden.

Dieses Verhalten ist mit den aus Buchführungssoftware bekannten Stapelbuchungen vergleichbar. Solange sich die Daten im Eingangsstapel befinden, dürfen diese noch ohne weitere Konsequenzen korrigiert oder entfernt werden. Beispielsweise eine gerade erfasste Rechnung, bei der ein falsches Datum oder eine andere Kategorie angegeben war. Hierdurch werden bei der Revision unnötige Warnungen vermieden.

Zusätzliche Funktionen

·Erstellung eines Archivauszuges für die Prüfung

·Prüferfunktion im Menü Datei | Datenbank | Pflege | GoBD-Prüfung


GoBD-Prüfung vorbereiten

Navigation: »Kein übergeordnetes Kapitel«

GoBD-Prüfung vorbereiten

Verfügbar in diesen Editionen

Datenzugriff durch Steuerprüfer

Nach den GoBD hat die Finanzbehörde im Rahmen einer Außenprüfung das Recht, die aufbewahrungspflichtigen Unterlagen durch Datenzugriff zu prüfen. Im Absatz "11.1. Unmittelbarer Datenzugriff (Z1)" der GoBD heißt es:

Die Finanzbehörde hat das Recht, selbst unmittelbar auf das DV-System dergestalt zuzugreifen, dass sie in Form des Nur-Lesezugriffs Einsicht in die aufzeichnungs- und aufbewahrungspflichtigen Daten nimmt und die vom Steuerpflichtigen oder von einem beauftragten Dritten eingesetzte Hard- und Software zur Prüfung der gespeicherten Daten einschließlich der jeweiligen Meta-, Stamm- und Bewegungsdaten sowie der entsprechenden Verknüpfungen (z. B. zwischen den Tabellen einer relationalen Datenbank) nutzt.
Dabei darf sie nur mit Hilfe dieser Hard- und Software auf die elektronisch gespeicherten Daten zugreifen. Dies schließt eine Fernabfrage (Online-Zugriff) der Finanzbehörde auf das DV-System des Steuerpflichtigen durch die Finanzbehörde aus. Der Nur-Lesezugriff umfasst das Lesen und Analysieren der Daten unter Nutzung der im DV-System vorhandenen Auswertungsmöglichkeiten (z. B. Filtern und Sortieren).

Unmittelbarer Datenzugriff (Z1)

Der Steuerprüfer nutzt Office Manager DMS, um die archivierten steuerrelevanten Belege und Dokumente einzusehen. Neben dem normalen Benutzerzugriff auf das Gesamtsystem haben Sie auch die Möglichkeit, dem Prüfer einen Archivauszug zur Verfügung zu stellen. Dabei werden die relevanten Daten des Prüfungszeitraumes auf die lokale Festplatte des Computers kopiert, ein Zugriff auf das Firmennetzwerk ist dann für die Prüfung nicht erforderlich.

Archiv zur Prüfungsvorlage erstellen

Archiv zur Prüfungsvorlage

1.Bestimmen Sie einen Computer, den Sie dem Prüfer zur Verfügung stellen möchten. Melden Sie sich hier zunächst mit einem Benutzerkonto an, welches Zugriff auf Office Manager DMS hat.

2.Stellen Sie sicher, dass Sie die aktuelle Office Manager-Version nutzen, siehe Menü Hilfe | Internet | Internet | Software aktualisieren.

3. Öffnen Sie das Dokumentenarchiv, welches die archivierten Buchungsbelege beinhaltet.

4. Suchen Sie alle relevanten Daten des Prüfungszeitraums. In einem Standard-Buchhaltungsarchiv markieren Sie dazu links im Navigator die entsprechenden Jahre (Strg-Taste festhalten und die Jahre mit der Maus anklicken). Sie können auch weitere Filter, wie beispielsweise die Kategorie verwenden. Achten Sie darauf, dass alle steuerrelevanten Dokumente im Suchergebnis enthalten sind.

5.Wählen Sie den Menübefehl Datei | Neues Archiv.

6.Markieren Sie Archiv zur Prüfungsvorlage und klicken Sie auf Weiter.
Hinweis: Falls diese Auswahl nicht enthalten ist, dann haben Sie kein revisionssicheres GoBD-Archiv geöffnet oder verwenden eine veraltete Softwareversion.

7.Auf den folgenden Dialogseiten werden in der Regel die vorgeschlagenen Werte übernommen. Klicken Sie auf der letzten Seite bitte auf Fertigstellen. Das Prüfungsarchiv und eine Desktopverknüpfung zu diesem werden erstellt, die Dokumentdateien kopiert.

8.Beenden Sie den Office Manager.

9.Wenn Ihre EDV-Umgebung dies grundsätzlich zulässt, können Sie den Rechner vom Netzwerk trennen. Am besten vorher herunterfahren. Wenn der Prüfer ein anderes Benutzerkonto verwenden soll, dann kopieren Sie die vom Assistenten erstellte Desktopverknüpfung (z. B. "Buchhaltung (Lokal)") bitte auf den Desktop des entsprechenden Benutzers.

10.Öffnen Sie das Archiv mit der angelegten Desktop-Verknüpfung. Stellen Sie sicher, dass alle relevanten Daten enthalten sind.

11.Führen Sie eine GoBD-Prüfung durch: Menü Start | Felder leeren und Suchen, um alle Dokumente des Archivs abzufragen. Die Revision mit dem Menübefehl Datei | Datenbank | Pflege | GoBD-Prüfung ausführen.

Siehe auch

Supportseiten zur Archivierung von Buchungsbelegen und zur GoBD-Prüfung


GoBD-Test

Navigation: »Kein übergeordnetes Kapitel«

GoBD-Test

Verfügbar in diesen Editionen

Unveränderbarkeit prüfen

In revisionssicheren Dokumentenarchiven kann die Einhaltung von Aufbewahrungsvorschriften jederzeit überprüft werden. Folgendes Vorgehen ist empfohlen:

Systemprüfung der Dokumente

1. Suchen Sie alle Dokumente des Prüfungszeitraums.
Beispiel Buchhaltungsarchiv: Wählen Sie zuerst den Menübefehl Start | Suchen | Felder leeren, markieren Sie links im Navigator das erste zu prüfende Jahr, halten Sie die Strg-Taste gedrückt und markieren Sie alle weiteren Jahre. Klicken Sie auf den Start | Suchen | Suchen.

2.Wählen Sie den Menübefehl Datei | Datenbank | Pflege | GoBD-Prüfung und klicken Sie auf den Mausschalter GoBD-Prüfung ausführen. Das System überprüft die Dokumente und zeigt eine Zusammenfassung der Prüfungsergebnisse.
Hinweis: Falls das Suchergebnis nur ein einzelnes Dokument beinhaltet, zeigt das Dialogfenster automatisch die Details zu diesem Dokument.

Revisionsdialog nach Testdurchlauf

Ergebnisse

Im unteren Bereich finden Sie nach dem Prüfungslauf klickbare (als Link dargestellte) Ergebnisse: Die Anzahl der gesamt geprüften Dokumente sowie die einzelnen Hinweise:

n Dokumente überprüft: Anzahl der durchlaufenen Dokumente.

n nachvollziehbare Bearbeitungen: Dokumente, die nachträglich verändert wurden. Der ursprüngliche Beleg ist aber als Dokumentversion vorhanden. Dies kann beispielsweise eine Rechnung sein, bei der die Anschrift korrigiert wurde.

n Hinweise: Dokumente mit nachträglichen Änderungen bzw. Korrekturen der Eigenschaften (Datum, Kategorie u. ä.) sowie Dokumente ohne Revisionssicherheit. Internetlinks werden beispielsweise nicht auf Unveränderbarkeit geprüft, weil nur der Link und nicht das Dokument selbst archiviert ist.

n Verstöße: Das Dokument oder das Audit-Protokoll wurde verändert.

Der Archiv-Papierkorb beinhaltet insgesamt n Dokumente: Dies ist ein Hinweis auf gelöschte Dokumente. Um zu überprüfen, ob relevante Belege gelöscht wurden, wechseln Sie bitte in den Papierkorb und suchen Sie alle Dokumente des Prüfungszeitraums.

Details einsehen

Klicken Sie auf einen der Ergebnislinks, beispielsweise auf n nachvollziehbare Bearbeitungen. Das Programm sucht jetzt die betroffenen Dokumente und wechselt zur Dialogansicht der einzelnen Dokumente:

Revisionsdialog eines einzelnen Dokuments

Sie finden hier das Prüfungsergebnis im Detail sowie die einzelnen Logeinträge.

Schaltflächen in der unteren Fensterzeile:

Übersicht: zum Hauptseite der Prüfung zurückkehren.

Zurück: zum vorherigen Dokument wechseln.

Weiter: zum nächsten Dokument wechseln.

Schließen: das Fenster schließen.

Hilfe öffnet dieses Hilfethema.

Blockchain-Revision ist nur sichtbar, wenn Dokumentinformationen zusätzlich in einer Blockchain hinterlegt sind.

Dokumente einsehen

1.Klicken Sie, wie beim Einsehen der Details, auf einen Link. Das Programm sucht die entsprechenden Dokumente und zeigt diese in der Tabelle.

2.Schließen Sie das Dialogfenster und öffnen Sie die Dokumente mit einem Doppelklick in der Tabelle.

Beim erneuten Aufruf des Menübefehls Datei | Datenbank | Pflege | GoBD-Prüfung ist das letzte Prüfungsergebnis noch vorhanden.

Versionen überprüfen

Wenn Belege nachvollziehbare Bearbeitungen beinhalten, können Sie diese in den Dokumentversionen nachverfolgen:

1.Falls die Detailseite der Dokumente gezeigt wird, kehren mit Klick auf Überblick zur Hauptseite.

2.Klicken Sie auf den Link n nachvollziehbare Bearbeitungen - das Programm stellt die betroffenen Dokumente in der Tabelle zusammen.

3.Schließen Sie das Prüfungsfenster.

4.Zurück im Programmhauptfenster markieren Sie das erste gewünschte Dokument in der Tabelle und öffnen dieses mit Doppelklick.

5.Wählen den Menübefehl Bearbeiten | Dokument | Eigenschaften und wechseln Sie im Eigenschaftenfenster zur Registerseite Versionen.

6.Öffnen Sie die gewünschte Version mit Doppelklick.

7.Sie können die geöffneten Dokumentdateien jetzt vergleichen und die Änderungen nachvollziehen.


Gonz@les Web-Runner Archiv importieren

Navigation: »Kein übergeordnetes Kapitel«

Gonz@les Web-Runner Archiv importieren

Der Gonz@les Web-Runner 6.0 wurde Anfang 2019 durch das Nachfolgeprogramm "Gonz@les DMS", einer Edition von Office Manager DMS, ersetzt. Die alten Datenbanken können Sie in das neue Programm importieren.

Begriff-Abgrenzung: "Web-Runner" ist die alte Software mit dem zu importierenden Archiv. "Office Manager" ist das Zielprogramm, auch wenn es als "Gonz@les DMS" ausgeführt wird.

Vorbereitungen

1.Web-Runner Archive (*.gwr) sind Datenbanken im MS Access-Format. Für den Import benötigen Sie wahrscheinlich eine 32 Bit-Ausgabe von Office Manager, weil auch auf einem 64 Bit Windows standardmäßig nur der 32 Bit Access-Treiber installiert ist. Sie können die 32 und 64 Bit-Ausgabe parallel installieren.

2.Öffnen Sie im Office Manager das Archiv, in welches Sie die Daten importieren möchten.

3.Wenn Sie im Web-Runner eigene Datenfelder erstellt haben, dann fügen Sie diese auch dem Zielarchiv hinzu. Verwenden Sie den gleichen Feldnamen, auf Groß- und Kleinschreibung brauchen Sie dabei nicht achten.

Archivimport

4.Wählen Sie den Menübefehl Datei | Datenbank | Datenaustausch | Importieren.

5.Wählen Sie die Quelldatei *.gwr (z. B. in "C:\ProgramData\Gonz@les Web-Runner\Archive\") aus und klicken Sie auf Importieren.

Nacharbeiten

6.Falls unbekannte Dokumenttypen vorhanden sind, dann beachten Sie bitte diesen Blogartikel.

7.Die Dokumentdateien befinden sich noch im alten Verzeichnis. Kopieren Sie diese bitte in das Standard-Dokumentenverzeichnis. Verwenden Sie hierfür den Menübefehl Datei | Datenbank | Anpassen | Dateipfade ändern:
Dateipfade anpassen

8.Prüfen Sie, ob alle Dateiverknüpfungen gültig sind: Datei | Datenbank | Pflege | Dateiexistenz prüfen.

9.Für die Volltextsuche müssen die Dokumentinhalte neu eingelesen werden: Datei | Datenbank | Pflege | Datenbankpflege wählen, Volltextindex und Dateiattribute aktualisieren markieren und starten.


OK

Klicken Sie auf OK, um die Eingaben / Änderungen zu übernehmen und dieses Dialogfenster zu schließen.


Abbrechen

Klicken Sie auf Abbrechen, um die Eingaben / Änderungen zu verwerfen und dieses Dialogfenster zu schließen.


Hilfeüberblick

Klicken Sie auf diese Schaltfläche um eine Hilfeübersicht für das aktive Programmfenster zu öffnen, oder wählen Sie die Direkthilfe [?] für spezielle Informationen zu einer Komponente.


Schließen

Klicken Sie auf Schließen um dieses Dialogfenster zu schließen.


Übernehmen

Klicken Sie auf Übernehmen um die Eingaben / Änderungen zu speichern, ohne dieses Dialogfenster zu schließen.


Durchsuchen

Öffnet einen Dialog um die Datenträger nach Dateien oder Verzeichnissen zu durchsuchen.


Direkthilfe

Wählen Sie bitte im Menü Hilfe den Befehl Direkthilfe oder klicken Sie auf [?] rechts in der Titelleiste des Fenster. Klicken Sie anschließend auf die Komponente, zu der Sie weitere Informationen suchen.

Oder markieren Sie die Komponente (z. B. ein Eingabefeld) und drücken Sie die Taste F1.


Fortschrittsbalken

Der Statusbalken zeigt den Fortschritt der aktuellen Bearbeitung.


Optionsmenü

Öffnet ein Menü mit weiteren Befehlen und Optionen.


Erster Datensatz

Datenbank-Navigation: Springt zum ersten Datensatz in der Tabelle.


Vorheriger Datensatz

Datenbank-Navigation: Springt zum vorherigen Datensatz in der Tabelle.


Nächster Datensatz

Datenbank-Navigation: Springt zum nächsten Datensatz in der Tabelle.


Letzter Datensatz

Datenbank-Navigation: Springt zum letzten Datensatz in der Tabelle.


Datensatz speichern

Datenbank: Speichert die Änderungen am aktuellen Datensatz.


Datensatzänderungen verwerfen

Datenbank: Verwirft die Änderungen am aktuellen Datensatz.


Datensatz neu laden

Datenbank: Aktualisiert die gepufferten Daten und lädt sie erneut aus der Datenbank.


Tabelle exportieren

Exportieren

Exportiert die Datensätze der Tabelle in eine Datei.


Ribbon-Funktion suchen

Funktion suchen "Was möchten Sie tun?"

Ermöglicht den Zugriff auf Menübefehle durch die Eingabe von Schlagwörtern. Beachten Sie auch die Fußzeile des Hauptfenstern mit einer Kurzinformation zum jeweiligen Befehl, wenn Sie die Maus über diesen bewegen.

Hinweise

Das Eingabefeld befindet im Ribbon-Menüband neben den Karteireitern (Tabs). Um dieses ein- oder auszublenden, wählen Sie bitte den Menübefehl Datei | Optionen | Einstellungen und wechseln zur Registerseite Ansicht.

Die maximale Anzahl wird mit der Einstellung "Kombinationsfelder sichtbare Zeilen" festgelegt.

Einige Funktionen werden nur im Administratormodus eingeblendet.


Starten

Klicken Sie auf Starten, um die Funktion auszuführen.


Stopp

Klicken Sie auf Stopp, um die Ausführung abzubrechen.


Symbolleiste einblenden

Blendet die Symbolleiste mit Mausschaltflächen ein oder verbirgt sie.


Neuer Listeneintrag

Klicken Sie auf Neu um einen neuen Eintrag in die Liste einzufügen.


Listeneintrag ändern

Markieren Sie einen Eintrag in der Liste und klicken Sie dann auf Ändern, um den markierten Eintrag zu ändern.


Listeneintrag löschen

Markieren Sie einen oder mehrere Einträge in der Liste und klicken Sie dann auf Löschen, um alle markierten Einträge aus der Liste zu entfernen.


Listeneintrag duplizieren

Dupliziert den markierten Listeneintrag. Es wird ein neuer Eintrag als Kopie des markierten erstellt.


Listeneintrag suchen

Liste durchsuchen

Klicken Sie bitte auf Suchen und geben Sie den gesuchten Begriff oder einen Teil davon ein. Nach Klick auf OK wird die Liste durchsucht und der erste passende Eintrag markiert.

Bei der Projektsuche wird auch die Projektbeschreibung berücksichtigt.


Aufbewahrungsfrist

Die Aufbewahrungsfrist gibt an, wie lange das Dokument archiviert werden muss.


Programmdateiname

Ausführbare Programmdatei (*.exe) der Anwendung mit kompletter Pfadangabe.


Einfügen

Fügt den Inhalt der Zwischenablage in das aktivierte Eingabefeld ein.

Wenn die Dokumententabelle markiert ist, werden die Dokumente aus der Zwischenablage importiert.


Kopieren

Kopiert den markierten Text in die Zwischenablage.

Oder,

wenn die Dokumententabelle markiert ist, die ausgewählten Dokumente in die Zwischenablage. Diese können im Programm, aber z. B. auch im Windows-Explorer wieder eingefügt werden.


Ausschneiden

Löscht den markierten Text und legt ihn in der Zwischenablage ab.


Löschen

Löscht die markierten Einträge bzw. den markierten Text ohne ihn in der Zwischenablage abzulegen.

Wenn ein Dokument markiert ist, wird nach Rückfrage der Dokumentdatensatz und, wenn gewünscht, die entsprechende Datei vom Datenträger gelöscht.


Alles markieren

Markiert den gesamten Text des aktiven Eingabefeldes.

Oder,

wenn die Dokumententabelle markiert ist, alle Dokumente in der Tabelle.

Tipp: Wenn alle Dokumente in der Tabelle markiert sind und Sie die Markierung entfernen möchten, dann halten Sie bitte die Strg-Taste fest und klicken auf einen markierten Datensatz.


Verknüpfungen prüfen

Dateiexistenz prüfen (Menü Datei | Datenbank)

Es wird überprüft, ob die in den Datensätzen zugeordneten Dokumentdateien vorhanden sind.

Im Anschluss an die Prüfung wird eine Suche nach allen Dokumenten erstellt, die ungültige Dateiverknüpfungen enthalten. Beachten Sie bitte, dass auch die Dokumentversionen überprüft werden. Die Suche kann also Datensätze enthalten, bei denen nur die Datei einer Dokumentversion nicht mehr vorhanden ist.


CSV-Export gruppiert

Gruppierter CSV-Export

Auch der Datenbankexport in CSV verwendet die Einstellungen der sichtbaren Dokumententabelle inklusive der Gruppierung. In der Regel sind CSV-Daten aber ohne Gruppierung erforderlich.

Klicken Sie auf Nein, um eine CSV-Datei ohne Gruppierung für den Datenaustausch mit anderen Programme zu erzeugen. Oder auf Ja, falls die Gruppierung erwünscht ist.


Beenden

Beendet das Programm.


Dokument erneut öffnen

Dokument erneut öffnen (Menü Dokument | Erneut öffnen)

Das Untermenü enthält eine Liste mit den zuletzt geöffneten Dokumenten. Klicken Sie auf einen Eintrag, um das Dokument erneut im zuständigen Anwendungsprogramm zu öffnen.


Übersicht drucken

Erstellt eine HTML-Datei mit den Dokumentdatensätzen der aktuellen Suche und öffnet die Datei im Browser. Nutzen Sie diese Funktion, wenn Sie eine Übersicht der Dokumente ausdrucken möchten.

Sicherheitshinweis

Wenn Sie ein verschlüsseltes Archiv drucken, wird die temporäre HTML-Datei anschließend gelöscht. Hierzu öffnet sich ein Dialogfenster mit dem Hinweis, bestätigen Sie dieses bitte nach dem Ausdruck.


Öffnen mit

Dokumente mit einer anderen Anwendung öffnen
(Menü Dokument)

Wählen Sie bitte eine Anwendung aus dem Untermenü, um die markierten Dokumente in dieser Anwendung zu öffnen.

Hinweise:
Sie können mehrere Dokumente markieren und gleichzeitig öffnen. Achten Sie darauf, dass Sie nur Dokumente markieren, die mit der gewählten Anwendung kompatibel sind.

Wenn Sie den Eintrag Programm auswählen verwendet, wird der Befehl nur für das aktuelle Dokument und nicht für alle markierten ausgeführt.


Suche zurücksetzen

Suche zurücksetzen (Menü Suchen | Zurücksetzen)

Die eingegebenen Suchkriterien werden gelöscht, die Tabelle zeigt wieder alle Dokumente an.

Wenn die Umschalttaste gedrückt ist, dann wird die Markierung im Projektnavigator nicht zurückgesetzt.


Felder leeren

Felder leeren (Menü Suchen)

Löscht alle eingegebenen Suchbegriffe.

Wenn die Umschalttaste gedrückt ist, dann wird die Markierung im Projektnavigator nicht gelöscht.


Systemmenü

Befehl Systemmenü im lokalen Popupmenü der Tabelle.

Öffnet das lokale Menü des Windows-Explorers. Sie können das Dokument mit Systemfunktionen öffnen und bearbeiten.

Diese Funktion ist in GoBD-Archiven gesperrt.


Administrator-Anmeldung

Anmeldung für die Administratorebene
(Menü Datei | Optionen | Administrator)

Aktiviert den Zugriff auf die Administratorebene. Um das System im Netzwerkbetrieb zu schützen, sollten Sie ein Passwort für die Administratorebene definieren.


Menüs zurücksetzen

Menüband zurücksetzen (Menü Ansicht | Anpassen | Menüs zurücksetzen)

Setzt die Menüs und Symbolleisten auf den Auslieferungszustand zurück.


Online-Hilfe

Übersicht der Office Manager-Hilfethemen, Hilfe-Index und -Suche.

·Für eine Übersicht wählen Sie bitte Hilfethemen.

·Wählen Sie Direkthilfe und klicken Sie anschließend auf ein Element, um weitere Informationen zu diesem Element zu erhalten.

·Benutzerhandbuch öffnet das PDF-Handbuch.

·Im Menü Kurzanleitungen finden Sie PDF-Dokumente zu ausgewählten Themen.

·Der Eintrag Info zeigt eine Infobox zum Programm.


Benutzerhandbuch

Benutzerhandbuch (Menü Hilfe)

Öffnet das PDF-Benutzerhandbuch.


Info

Info über den Office Manager, Ansprechpartner für weitere Informationen.


Kurzanleitungen

Enthält eine Liste mit Kurzanleitungen zu den wichtigsten Programmfunktionen.


Tabelle editieren

Aktivieren Sie die Funktion, um die Daten direkt in der Tabelle zu bearbeiten.


Sortieren

Datentabelle sortieren

Klicken Sie mit der linken Maustaste auf die Spaltenüberschrift, um die Tabelle anhand der Spalte zu sortieren. Ein erneuter Klick ändert die Sortierreihenfolge (auf- oder absteigend).

Oder:

Klicken Sie mit der rechten Maustaste auf die Überschrift und wählen Sie im Kontextmenü den Eintrag Aufsteigend sortieren bzw. Absteigend sortieren. Halten Sie um Umschalttaste gedrückt, um nach mehreren Feldern zu sortieren.


Feld ausblenden

Feld ausblenden (lokales Menü der Dokumententabelle)

Entfernt die ausgewählte Spalte aus der sichtbaren Dokumenttabelle. Die Daten sind weiterhin vorhanden, werden aber in der Tabelle nicht mehr angezeigt. Um Spalten wieder hinzuzufügen wählen Sie bitte Ansicht | Anpassen | Feldauswahl.


Spalten ausrichten

Klicken Sie mit der rechten Maustaste auf die Spaltenüberschrift und wählen Sie im Kontextmenü den Eintrag Ausrichten (Links, Rechts oder Zentriert), um die Daten in dieser Spalte entsprechend auszurichten


Spaltenbreite ändern

Spaltenbreite anpassen

Sie können die Breite der einzelnen Tabellenspalten einfach mit der Maus ändern. Ziehen Sie dazu die Linie rechts neben dem Spaltenkopf auf die gewünschte Breite.

Oder:

Klicken Sie mit der rechten Maustaste auf den Spaltenkopf. Wählen Sie im Kontextmenü den Eintrag Optimale Breite, um die Breite der ausgewählten Spalte, bzw. Optimale Breite aller Spalten, um die Breite aller Spalten zu optimieren. Die Breite wird dann automatisch an die Breite der enthaltenen Daten angepasst.


Baumknoten öffnen

Öffnet alle Baumknoten.


Baumknoten schließen

Schließt alle Baumknoten.


Immer im Vordergrund

Wenn die Option Immer im Vordergrund aktiviert ist wird das Fenster vor allen anderen Fenster im Vordergrund dargestellt.

Wenn die Option deaktiviert ist, kann das Fenster von anderen verdeckt werden.


helpcontext-615

Immer geöffnet

Die Baumknoten werden automatisch expandiert und immer geöffnet dargestellt.


Gruppieren

Dokumente gruppieren

Sie können die Dokumente gruppieren, indem Sie einen Tabellenkopf per Drag&Drop auf diese Fläche ziehen.

Beispiel: Klicken Sie mit der linken Maustaste auf den Tabellenkopf Dokumenttyp, halten Sie die Maustaste fest, schieben Sie die Maus auf diese Fläche und lassen Sie die Maustaste wieder los. Die Dokumente werden nun anhand des Dokumententyps gruppiert.


Knoten öffnen

Baumknoten öffnen oder schließen

[+] öffnet den Baumknoten,

[-] schließt ihn.


Spalten anpassen

Sie können die Spaltenbreite und Zeilenhöhe mit der Maus vergrößern und verkleinern, indem Sie die Trennlinie zwischen zwei Spalten bzw. Zeilen verschieben.


Indicator

Die linke schmale Spalte enthält die Markierung für den aktuellen Datensatz.


Datum gruppieren

Dokumente nach Datum gruppieren

Wählen Sie bitte aus, wie genau nach Datum gruppiert werden soll.

Beispielsweise nach Tagen, um alle Dokumente eines Tages unter einem Konten zusammen zu fassen.


Info zur Suche

Oberhalb der Dokumententabelle finden Sie eine kurze Information über die aktuelle Suche nach Dokumenten.


Anwendungssymbol

Symbol der Anwendung, mit der das markierte Dokument geöffnet wird.


Dateiname

Dateinamen werden vom Office Manager automatisch vergeben. Klicken Sie bitte auf die Schaltfläche [Durchsuchen], um einen eigenen Dateiname zu vergeben.

Die Syntax der Dateinamen können Sie Ihren Anforderungen anpassen (Menü Datei | Optionen | Einstellungen).


Protokoll

Protokoll des Dokuments oder Kontakts. Die automatische Protokollierung der Dokumentenverwendung kann im Menü Datei | Optionen | Einstellungen, Seite Datenbank ein- und ausgeschaltet werden.

Der Administrator kann einzelne Protokolldatensätze löschen, beispielsweise aus Datenschutzgründen.


Seite Zeichnung

Spezielle Angaben für CAD-Zeichnungen. Der Office Manager kann den Schriftkopf einer neuen CAD-Zeichnung automatisch mit den hier eingegebenen Daten ausfüllen.


Adresse

Geben Sie die Adresse eines Dokumentes oder Computers im Internet ein, das bzw. der geöffnet werden soll. Internetadressen beginnen häufig mit "https://www".

Wenn Sie ein lokales Dokument (HTML-Datei) zuordnen möchten, beachten Sie bitte, dass die Datei vorhanden sein muss. Sie können keine neue Datei erzeugen.


Dokumentattribute

Geben Sie bitte aussagekräftige Bezeichnungen in den Dokumentattributen ein.


Protokolleintrag

Text, der im Protokoll des Dokuments hinterlegt wird.

Siehe auch: Bearbeiten | Dokument | Eigenschaften, Seite Protokoll.


Detaildokumente

Detail-Dokumente: zeigt eine Liste mit abhängigen Dokumenten. Diese Sonderfunktion wird vom Inventor-Einrichtungsassistenten aktiviert. Sie können damit z. B. auf Baugruppen zugreifen.


helpcontext-1030

Elektronische Rechnungen beinhalten Datensätze für die einzelnen Rechnungspositionen. Diese können hier aus der E-Rechnung gelesen, dargestellt sowie um Kostenstelle und Notizen erweitert werden.

Ein Klick auf Importieren liest die Posten aus der E-Rechnung in die Tabelle ein. Mit Editieren können Notizen hinzugefügt und eine Kostenstelle hinterlegt werden.


helpcontext-1031

Importieren

Liest die Rechnungspositionen aus der Elektronischen Rechnung ein, sofern es sich bei diesem Dokument um eine E-Rechnung handelt.


helpcontext-1032

Editieren

Aktivieren Sie diese Schaltfläche, um die Rechnungspositionen direkt in der Tabelle zu bearbeiten. Nur Spalten mit einem Bearbeitungssymbol (Stift) können geändert werden, wie Notizen und die firmeninterne Kostenstelle.


Datei löschen

Markieren Sie die Option Datei(en) löschen, um auch die Dokumentdateien vom Datenträger zu löschen. Wenn die Option nicht markiert ist, werden nur die Dokumentdatensätze aus dem Archiv entfernt.

Diese Option ist nur sichtbar, wenn Endgültig löschen markiert ist.


Endgültig löschen

Wenn die Option Endgültig bestätigen markiert ist, werden die Dokumente nicht in den Papierkorb verschoben. Sie können diese dann nicht wiederherstellen.

Hinweis: Diese Option kann vom Administrator gesperrt werden.


Nein

Klicken Sie auf Nein, um das Dialogfenster zu schließen ohne die markierten Dokumente zu löschen.


Ja

Klicken Sie auf Ja, um die Dokumente aus der Datenbank zu entfernen. Wenn die Option Datei(en) löschen markiert ist, wird auch die Dokumentdatei vom Datenträger entfernt.


Dokumenttypen

Tabelle der registrierten Dokumenttypen.


Sicherheitsrichtlinie

Sicherheitsrichtlinie: legt die Berechtigungen der Benutzer und Benutzergruppen für neue Dokument fest. Neue Dokumente erhalten die hier eingestellte Richtlinie als Vorgabe. Wenn die Option Benutzer dürfen Richtlinien ändern markiert ist, können die berechtigten Benutzer die Richtlinie für jedes einzelne Dokument anpassen. Ist die Option nicht markiert ist, werden auch eventuelle Vorgabewerte der Importeinstellungen ignoriert.


Eigenschaften

Klicken Sie bitte auf Eigenschaften, um die Sicherheitsrichtlinien zu bearbeiten.


Bezeichnung

Bezeichnung des Dokumententypen, wie "Word-Dokument", "Excel-Tabelle", "AutoCAD-Zeichnung", "Brief", "Fax".

Zum Ändern der Bezeichnung wählen Sie bitte im Menü Start | Dokumenttyp den Befehl Umbenennen.


Typ

Typ der Anwendung

Für "normale" Dokumenttypen (Dokumente, die mit anderen Anwendungen erstellt werden) wählen Sie die Option Standarddokument.

Für die spezielle Internet-Funktion markieren Sie die Option Internetadresse. Es werden dann keine Dokumentdateien sondern Internetadressen verwaltet.

Mit dem Typ E-Mail können E-Mails aus Outlook, Thunderbird und vielen anderen Mail-Programmen verwaltet werden.

Für die Office Manager Textverarbeitung markieren Sie die Option Dokument der Office Manager-Textverarbeitung. Es werden dann keine externen Dokumentdateien verwaltet, die Texte werden mit in der Dokumentendatenbank gespeichert.


Benutzerdefinierte Steuerung von Programmen

Benutzerdefinierte Steuerung der Anwendung

Wenn diese Option markiert ist, können Sie detailliert festlegen, wie der Befehl ausgeführt wird. Klicken Sie bitte auf Erweitert, um die Parameter zu definieren

Ist die Option nicht markiert, wird der Befehl direkt von Windows ausgeführt. Der Befehl "Öffnen" (open) entspricht dann beispielsweise einem Doppelklick auf die Dokumentdatei im Explorer.


Fenstergröße

Fenstergröße der Anwendung

Wählen Sie Vollbild, wenn das Anwendungsprogramm immer maximiert geöffnet werden soll oder Normal, um die aktuelle Programmeinstellung zu verwenden. Symbol minimiert das Programm zum Symbol in der Taskleiste. Diese Option ist nur sinnvoll, wenn das Programm z. B. eine Konvertierung im Hintergrund durchführen soll.


Programmdateiname

Programmdatei

Ausführbare Programmdatei (*.exe) der Anwendung mit kompletter Pfadangabe. Klicken Sie auf die Schaltfläche [...] hinter dem Eingabefeld und wählen Sie:

Durchsuchen: um die Anwendung im Dateidialog auszuwählen.

Standardanwendung: die zuständige Windows-Standardanwendung verwenden.

Tipp: Sie können auch mehrere Programmdateien angeben. Dies ist im Netzwerkbetrieb sinnvoll, wenn die Anwendung auf den verschiedenen Rechner in unterschiedlichen Verzeichnissen liegen. Geben Sie mehrere Programmdateien im SDF-Format (Komma getrennt) ein.


Vorlagenname

Geben Sie eine sinnvolle Bezeichnung für die Vorlagendatei ein. Beispielsweise Brief, Angebot, Rechnung, Entwurfsplan, Prospekt, usw.

Anhand dieser Bezeichnung wird beim Erstellen neuer Dokumente die Vorlage ausgewählt.


Vorlagedateiname

Geben Sie den Dateinamen der Vorlage ein. Klicken Sie auf die Schaltfläche [Durchsuchen], um den Dateidialog zu öffnen.


Filtername

Geben Sie eine Bezeichnung für die Dateiendung ein. Diese Bezeichnung wird z. B. in Dateidialogen verwendet.

Beispiel: Für Dateien mit der Endung "txt" wäre die Bezeichnung "Textdatei" sinnvoll.


Dateiendung

Endung der Dokumentdateien (File-Extension): z. B. "txt", "docx", "xlsx", "dwg" usw.


Verzeichnis wechseln

Aktivieren Sie diese Option, wenn das Verzeichnis des Anwendungsprogramms zum aktuellen Verzeichnis gemacht werden soll, sobald die Anwendung startet. Diese Option ist nur erforderlich, wenn es zuvor zu Problemen kam.


Vorlagedateien

Liste der Vorlagendateien.

Vorlagendateien werden als Grundlage für neue Dokumente verwendet. Für den Dokumenttyp "Word" können Sie beispielsweise eine Vorlage "Brief" erstellen, in der bereits Ihr Firmen-Schriftkopf und der Grundaufbau des Briefes enthalten ist. Wenn Sie ein neues Dokument für "Word" erstellen und die Vorlage auswählen, ist die Grundstruktur des neuen Briefes bereits fertig.


Löschen

Löscht den markierten Dokumenttyp.

Achtung: Wenn Sie einen Dokumententyp löschen, für den bereits Dokumente vorhanden sind, können Sie auf diese Dokumente nicht mehr zugreifen.


Neuer Dokumenttyp

Klicken Sie auf Neuer Dokumenttyp, um manuell einen neuen Dokumenttypen einzurichten.


Neu für Dateiendung

Klicken Sie bitte auf Neu für Dateiendung, um den Dokumenttypen für bestimmte Dateien (*.txt u. a.) automatisiert einzurichten.


Umbenennen

Wählen Sie den Befehl Umbenennen, um die Bezeichnung des Dokumenttypen zu ändern.


Standardvorlagendatei

Wenn beim Erstellen eines neuen Dokumentes keine Vorlagendatei gewählt ist, wird die Standardvorlage (soweit vorhanden) verwendet. Beachten Sie bitte auch, dass manche Windows-Programme immer eine Vorlagendatei benötigen, wenn ein neues Dokument erstellt werden soll. In diesem Fall müssen Sie eine Standardvorlage definieren, auch wenn diese nur ein leeres Dokument ist.


Neue Vorlagendatei

Klicken Sie auf die Schaltfläche Neu, um eine neue Vorlagendatei zu definieren.


Bearbeiten

Klicken Sie auf die Schaltfläche Bearbeiten, um die markierte Vorlagendatei zu ändern.


Löschen

Klicken Sie auf die Schaltfläche Löschen, um die markierte Vorlagendatei zu entfernen.


Weitere Dateitypen

Liste mit weiteren Dateitypen, die mit dieser Anwendung bearbeitet werden können.


Neuer Dateityp

Klicken Sie auf die Schaltfläche Neu, um einen neuen Dateityp zu definieren, der mit dieser Anwendung bearbeitet werden kann.


Bearbeiten

Klicken Sie auf die Schaltfläche Bearbeiten, um den markierten Dateitypen zu ändern.


Löschen

Klicken Sie auf die Schaltfläche Löschen, um den markierten Dateitypen aus der Liste zu entfernen.


Befehlsliste

Markieren Sie bitte den Befehl für den Sie die Parameter einstellen möchten.


Datei als Startparameter

Die Dokumentdatei wird beim Starten der Anwendung als Parameter übergeben.


Startparameter

Sie können hier weitere Startparameter definieren (auch Makrovariablen), die beim Start an die Anwendung übergeben werden. Um beispielsweise die Dokumentdatei als Parameter zu übergeben, können Sie hier die Variable "{CurrDocFileName}" angeben oder Option Datei als Startparameter markieren.


Befehlszeilen-Steuerung

Das Anwendungsprogramm wird mit den angegebenen Parametern gestartet. Markieren Sie Datei als Startparameter und/oder geben Sie weitere Startparameter an.


Makro-Steuerung

Der Befehl wird mit einem Office Manager-Makro ausgeführt. Geben Sie bitte die Variablen und Funktionen ein.


Makro

Liste der Befehle zur Steuerung des Anwendungsprogramms. Geben Sie hier den Quelltext des Skriptes ein.


Befehlsname

Systeminterner Name des Befehles, wie beispielsweise "open" oder "print".


Befehlsbezeichnung

Sichtbare Beschreibung des Befehles. Die Bezeichnung der Standardbefehle (Neu, Öffnen, Drucken) kann nicht geändert werden. Bei zusätzlichen Befehlen geben Sie bitte eine sinnvolle Bezeichnung für die Auswahl des Befehls im Menü Verwenden | Befehle ein.


Befehl verbergen

Markieren Sie diese Option, wenn der Befehl nicht im Menü Dokument sichtbar sein soll und somit nicht vom Anwender gewählt werden kann. Hiermit können Sie Befehle vorübergehend deaktivieren. Darüber hinaus werden einige Systembefehle, beispielsweise aus die CAD-Anbindung, vom Programm automatisch ausgeführt und sind daher für den Anwender verborgen.


Warten bis Anwendung beendet

Wenn die Option Warten bis Anwendung beendet markiert ist, wartet der Office Manager, bis die aufgerufene Anwendung wieder beendet wurde. Diese Option ist nur in Ausnahmefällen sinnvoll, wenn beispielsweise eine Konvertierung im Hintergrund ausgeführt wird.

Der Office Manager reagiert nicht, solange die aufgerufene Anwendung läuft!


Neuer Befehl

Erstellt einen neuen Befehl.


Befehl kopieren

Erstellt einen neuen Befehl als Kopie des markierten Befehls.


Befehl löschen

Löscht den markierten Befehl. Beachten Sie bitte, dass die Standardbefehle "new", "open" und "print" nicht gelöscht werden können.


Grafik

Wählen Sie bitte eine Grafik aus, die in der Dokumententabelle vor den jeweiligen Dokumenten dargestellt werden soll.

Eigene Bilder

Wählen Sie in der Liste den Eintrag "Andere Grafik laden".

Sie können eigene Grafiken aber auch der Auswahlbox hinzufügen: Speichern Sie die Bilder bitte im Verzeichnis "(Gemeinsame Dateien)\DocImages\" als Bitmap (*.bmp) in der Größe 16x16 Pixel oder als skalierbare Vektorgrafik (*.svg) ab. Das Programm liest die Bilder nach einem Neustart ein


Permanent

Automatisch Suchen

Rastet den Schalter Suchen ein. Die Suche nach Dokumenten wird automatisch gestartet, sobald Sie Änderungen in den primären Suchfeldern eingeben.


Kopierte Dokumente

Kopierte Dokumente und Kontakte suchen (Start | Suchen | Zwischenablage)

Zeigt in der Tabelle nur die Dokumente bzw. Kontakte, welche zuvor mit dem Menübefehl Bearbeiten | Kopieren in die Zwischenablage kopiert wurden.

Tipp: Sie können beispielsweise auch eine Datei im Explorer kopieren und im Archiv suchen. Es werden dann alle identischen Dateien gefunden, auch wenn diese nicht im selben Verzeichnis abgelegt sind.


Genaue Suche

Standardmäßig sucht Office Manager entsprechend dem Prinzip "beginnt mit". Wenn Sie beispielsweise ein Projekt im Navigator markieren, dann werden alle Dokumente gefunden, dessen Projekt mit dem markierten beginnt.

Wenn Genau Suche markiert ist, dann werden nur Dokumente gefunden, die in genau dem markierten Projekt abgelegt sind.

Die Option gilt für alle Attribute, das Jokerzeichen $ wird dem Suchtext am Ende hinzugefügt.


Auswahlliste aktualisieren

Aktualisieren

Lädt die Auswahlliste neu. Sie können hiermit die Liste aktualisieren, wenn beispielsweise Änderungen auf einem anderen Netzwerkarbeitsplatz durchgeführt wurden.


Autovervollständigung

Das Eingabefeld merkt sich die zuletzt eingegebenen Suchbegriffe und schlägt diese bei einer erneuten Eingabe vor.

Um diese Funktion zu (de-)aktivieren, klicken Sie bitte mit der sekundären Maustaste auf das Eingabefeld und wählen Sie im lokalen Menü den entsprechenden Befehl.

Hinweise

Die Suchbegriffe werden individuell für jeden Anwender und jedes Archiv gespeichert.

Die maximale Anzahl der Begriffe entspricht der Programmeinstellung Kombinationsfelder auf der Einstellungsseite Ansicht.


Markierte Datensätze

Markierte (Start | Suchen | Markierte)

Die markierten Datensätze suchen. Markieren Sie die gewünschten Dokumente oder Aufgaben und klicken Sie anschließend auf diesen Schalter. Die Tabelle zeigt dann nur noch die zuvor markierten Datensätze.


Optionskategorien

Liste der Kategorien. Wählen Sie eine Kategorie, um die entsprechenden Einstellungen anzuzeigen.


Auswahllisten

Auswahlliste wählen

Wählen Sie die Auswahlliste, dessen Daten Sie bearbeiten möchten. Wenn Sie z. B. neue Gruppen hinzufügen möchten, dann markieren Sie bitte den Eintrag "Kategorie". In der rechten Liste werden nun alle vorhandenen Gruppen aufgelistet. Mit den Schaltern Neu, Ändern und Löschen können Sie die Liste bearbeiten.


Auswahlliste

Liste der Projekte, Gruppen, usw.

Mit den Schaltern Neu, Ändern und Löschen können Sie die ausgewählte Liste bearbeiten.

Sie können auch Einträge aus einer Datei einfügen, um beispielsweise die Projekte einer anderen Datenbank einzulesen. Klicken Sie dazu bitte mit der rechten Maustaste auf die Liste und wählen Sie im lokalen Menü den Befehl Einfügen.


Einstellung suchen

Einstellungen finden

Geben Sie einen Suchbegriff ein und drücken Sie die Eingabetaste oder klicken Sie auf die Lupe.

Alle passenden Optionen werden in einer Liste gezeigt - klicken Sie doppelt auf den gewünschten Eintrag, um direkt zur entsprechenden Kategorie-Seite zu springen.


Protokollieren

Markieren Sie dieses Feld, um alle Bearbeitungen und Aufrufe der Dokumente zu protokollieren. Wenn die Option nicht aktiviert ist, werden nur wichtige Ereignisse protokolliert.

Siehe auch Menü Datei | Optionen | Einstellungen, Seite Datenbank


Standardarchiv

Standard-Dokumentenarchiv

Geben Sie hier das Standard-Dokumentenarchiv an, das beim Start des Office Managers geladen werden soll, z. B. C:\Office Manager\Datenbank\Archiv.omp

Klicken Sie auf die Schaltfläche [Durchsuchen], um das Datei-Dialogfenster zu öffnen.


Anwendungsdatenbank

Standard-Anwendungsdatenbank

Menü Datei | Optionen | Dokumenttyp

Eine Anwendungsdatenbank beinhaltet die Informationen zu den Windows-Programmen, bekannte Benutzernamen sowie die Daten der Aufgabenverwaltung.

Klicken Sie auf die Schaltfläche [Durchsuchen], um das Datei-Dialogfenster zu öffnen.


Dokumente zählen

Zählt die Anzahl der gefundenen Dokumente
(Menü Datei | Optionen | Einstellungen, Seite Optimieren).

Wenn Sie diese Option markieren, wird die Anzahl der gefundenen Dokumente angezeigt. Das Zählen der Dokumente benötigt zusätzliche Zeit bei der Suche. Verzichten Sie bei großen Datenbanken auf diese Option, um die Suchzeiten zu optimieren.

Wenn zusätzlich die Option Anzahl beider Tabellen markiert ist, wird die Anzahl der aktiven und archivierten Dokumente gezeigt.


helpcontext-1914

Standard-Kontaktdatenbank

Menü Datei | Optionen | Dokumenttyp

Die Datenbank beinhaltet Ihre Kontakte und Adressen.

Klicken Sie auf die Schaltfläche [Durchsuchen], um das Datei-Dialogfenster zu öffnen.


Zuletzt geöffnete Datenbank

Wenn diese Option markiert ist öffnet der Office Manager beim Start die Datenbanken, die der Benutzer zuletzt geöffnet hatte.


Dokumente abfragen

Beim Start alle Datensätze abrufen

Wenn diese Option markiert ist, werden beim Programmstart bzw. nach dem Öffnen einer Datenbank alle Dokumente, Kontakte und Aufgaben aus der Datenbank abgerufen. Ist die Option nicht markiert, wird nur der jeweils zuletzt markierte Datensatz geladen.

Bei großen Datenbeständen -vor allem bei SQL-Servern- sollte die Option nicht markiert sein, weil dies unnötige Ressourcen verbraucht und den Programmstart verlangsamt.

Auf Terminalservern werden die Daten nicht automatisch abgefragt.


Zeilenanzahl in Auswahllisten
Menü Datei | Optionen | Einstellungen

Anzahl sichtbarer Zeilen der Auswahllisten von Kombinationsfelder (Eingabefeld mit Liste). Der Standardwert ist 20.

Auch das Suchfeld "Was möchten Sie tun?" im Hauptmenü zeigt eine entsprechende Anzahl an Befehlen und die Autovervollständigung in Eingabefeldern merkt sich diese Anzahl an Einträgen.


Baumknoten erweitern

Baumknoten automatisch erweitern

Menü Datei | Optionen | Einstellungen

Menü Navigator

In strukturierten Listen, wie beispielsweise dem Projektnavigator, wird ein Knoten erweitert, um die Unterpunkte sichtbar zu machen.

Wenn das automatische Erweitern aktiviert ist, öffnen sich die Baumkonten, sobald sie markiert sind. Andere Knoten, die zuvor automatisch geöffnet wurden, schließen dann. Ist diese Option nicht aktiviert, kann der Knoten mit einem Klick auf das Symbol vor dem Text oder mit einem Doppelklick auf den Text erweitert werden.

Tipp: Im Dialogfenster der Programmeinstellungen können Sie das Verhalten testen, indem Sie die Option umschalten und dann links die strukturierte Liste der Optionskategorien bedienen.


Menü-Stil

Stil (Menü Ansicht | Anpassen | Stil)

Legt das Farschema der Benutzeroberfläche fest.


Archiv-Schnellzugriff

Wenn der Schnellzugriff aktiviert ist, können Sie das zu öffnende Dokumentenarchiv sehr schnell aus der Liste über dem Projektnavigator wählen. Die Option ist sinnvoll, wenn Sie sehr oft zwischen verschiedenen Archiven wechseln.

Klicken Sie bitte mit der rechten Maustaste auf den Projektnavigator, und wählen Sie Archiv-Schnellzugriff, um die Einstellung zu ändern.

Der Schnellzugriff ist nicht möglich, wenn der Menübefehl Datei | Archiv öffnen vom Administrator gesperrt wurde.


Kurzhilfe

Hinweise zeigen
Menü Hilfe | Kurzhilfe | Hinweise

Zeigt auf dem Bildschirm Erläuterungen (Quickinfo) zu den Schaltflächen und Komponenten an, sobald der Mauszeiger darauf ruht.


Zeilenanzahl in Tabelle

Zeilenanzahl der Dokumenttabelle
Menü Datei | Optionen | Einstellungen, Seite Ansicht | Tabellen

Maximale Anzahl sichtbarer Textzeilen in einer Tabellenzeile. Wenn der Text breiter aus die Spalte ist, wird er umgebrochen und in der nächsten Textzeile dargestellt. Standardwert ist 1.


Filtern im Tabellenkopf

Filtern im Tabellenkopf (Menü Datei | Optionen | Einstellungen)

Wenn die Option markiert ist, können Sie in der Dokumenten- und Aufgabentabelle zusätzliche Filterkriterien setzen.


Datensatzanzahl

Datensatzanzahl in Gruppierung

Hiermit können Sie in der gruppierten Dokumenten- und Aufgabentabelle die Anzahl der Datensätze im Gruppenknoten einblenden.


helpcontext-1950

Zebra-Tabelle

Die Tabellenzeilen können für eine bessere Lesbarkeit als s.g. Zebra-Tabelle mit abwechselnden Hintergrundfarben dargestellt werden. Die Option finden Sie im Menü Datei | Optionen | Einstellungen auf Seite Ansicht | Tabellen. Beachten Sie aber, dass dies nicht von allen Stilen unterstützt wird.


helpcontext-1951

Erweiterte Eigenschaften darstellen

Menü Datei | Optionen | Einstellungen, Seite Ansicht | Tabellen

In Dokument- und Kontakt-Tabellen werden auch die erweiterten Eigenschaften dargestellt: Schriftformatierungen, Hintergrundfarbe und Bilder, welche in den Auswahllisten definiert sind.


Symbole darstellen

Wenn die Option Programmsymbole darstellen markiert ist, wird oberhalb der Dokumententabelle das Symbol (Icon) des zugeordneten Windows-Programms dargestellt. Das Symbol wird bei jedem Wechsel des Dokumentdatensatzes gelesen. Entfernen Sie die Markierung, um die Geschwindigkeit beim Wechsel der Datensätze zu beschleunigen.


Smooth Scroll

Scrollleisten werden schmal dargestellt und wechseln zur normalen Breite, sobald sich der Mauszeiger darüber befindet.

Diese Darstellung ist modern, bringt aber keinen Vorteil. Es ist Geschmackssache.


Benutzername im Titel

Benutzername im Titel des Hauptfensters zeigen
(Menü Datei | Optionen | Einstellungen, Seite Ansicht)

Wenn markiert, dann steht "Benutzername @ Archivname, Kontakte" im Titel des Hauptfensters.

Deaktivieren Sie diese Option, wenn Sie regelmäßig mehrere Office Manager-Programmfenster öffnen: Sie können dann in der Taskleiste besser erkennen, welches Archiv im jeweiligen Fenster geöffnet ist.


Tabelle jetzt speichern

Jetzt speichern

Wenn der Speichermodus "Global für alle Benutzer im Layout hinterlegt" gewählt ist, dann speichern Sie die aktuellen Tabelleneinstellungen mit Klick auf diesen Schalter.


helpcontext-1959

Rechtschreibprüfung
(Menü Datei | Optionen | Einstellungen, Seite Ansicht)

Aktiviert die Rechtsschreibprüfung in der programminternen Textverarbeitung für Notizen sowie in einigen Eingabefeldern.


Administrator-Passwort

Eingabe eines neuen Passwortes für den Zugriff auf die Administrator-Ebene.


Gefährliche Makros zulassen

Potenziell gefährliche Makrofunktionen in OmAPI zulassen

Einige Funktionen der Office Manager-Makrosprache "OmAPI" sind standardmäßig gesperrt. Beispielsweise das Löschen von Dateien und SQL-Datenbankoperationen.

Falls Sie auch diese zulassen möchten, dann markieren Sie die Option im Menü Datei | Optionen | Einstellungen auf der Seite Sicherheit.


Administratormeldung

Zusatztext für Fehlermeldungen

Der Administrator kann einen zusätzlichen Text für Informations-Dialoge definieren (Menü Datei | Optionen | Einstellungen).

Der hier eingegebene Text wird bei Warnungen und Fehlermeldungen mit angezeigt. Geben Sie z. B. "Bei Fragen wenden Sie sich bitte an den Systemadministrator Werner Müller, Apparat 26" ein.


Logdatei öffnen

Der Office Manager schreibt alle wichtigen internen Meldungen in die Logdatei "error.log". Wählen Sie Logdatei, um den Inhalt einzusehen.

Der Befehl ist nur aktiviert, wenn eine solche Datei vorhanden ist.


Importpause

Ausführung der Importfunktionen

Wenn dieser Optionsschalter nicht gedrückt ist, werden die Importfunktionen pausiert.

Die Funktion dient der Entwickler-Unterstützung und ist nicht für den normalen Betrieb vorgesehen.


Dateinamensyntax

Syntax der Dateinamen
(Menü Datei | Optionen | Einstellungen, Seite Dokument)

Sie können hier festlegen, wie die Dateien im Hintergrund benannt werden. Beispielsweise können diese dem Datenfeld "name" entsprechen oder einfach mit der Schlüsselnummer durchnummeriert werden.

Verwenden Sie Makro-Variablen, um den automatisch erzeugten Dateinamen zu definieren, z. B.

{Doc:DocID} für die eindeutige Schlüsselnummer),

{Doc:Name} für den Dokumentennamen

{Doc:Name,Validate3} für den Namen nur mit einfachen Zeichen.


Datenschutzbeauftragter

(Menü Datei | Optionen | Einstellungen, Seite Dokument | Revision)

Wenn in Ihrem Unternehmen ein Datenschutzbeauftragten bestellt ist, dann geben Sie hier bitte dessen Namen und die nötigen Daten für eine Kontaktaufnahme an. Diese Daten werden im Programm in datenschutzrelevanten Dialogen eingeblendet.


Änderungen zulassen

Änderungen der Dateinamen zulassen
(Einstellungen, Seite Dokument)

1. In revisionssicheren Archiven mit GoBD-Modus können Dateinamen unabhängig von dieser Einstellung nicht geändert werden.

2. Deaktivieren Sie die Option "Änderungen der Dateinamen zulassen", wenn Sie auch in Standardarchiven verhindern möchten, dass der Anwender die Dateinamen ändert. Unabhängig von dieser Einstellung können Dateinamen dann aber noch vom Administrator geändert werden und vom Benutzer, falls die angegebene Datei nicht vorhanden ist.


Dateiumbennung verweigert

Dateiumbenennung verweigert

Sie dürfen den Dateinamen nicht ändern oder das Dokument mit einer anderen Datei verknüpfen.

Dies ist in revisionssicheren Archiven grundsätzlich untersagt und der Administrator kann die Funktion auch für alle Archive sperren.

Hinweis für den Administrator:

Die Einstellung finden Sie im Menü Datei | Optionen | Einstellungen auf der Seite Dokument. Wenn Sie das Umbenennen in Archiven ohne GoBD-Modus erlauben möchten, dann markieren Sie bitte die Option Änderungen der Dateinamen durch den Benutzer zulassen. In der Regel ist dies aber nicht empfohlen, der hinterlegte Speicherpfad ist für den normalen Anwender nicht relevant.


Löschen nach Aufbewahrungsfrist

Löschen nach Ablauf der Aufbewahrungspflicht zulassen

(Menü Datei | Optionen | Einstellungen, Seite Dokument | Revision)

Mit dieser Option aktivieren Sie die Verwendung von Aufbewahrungsfristen für alle Archive. Nach dem Ablauf der Frist können Dokumente gelöscht werden, auch im GoBD-Modus und auch in der Ansicht "Archivierte Dokumente". Der Datenschutz hat dann Vorrang.

Die Fristen werden über die Dokumenten-Kategorie definiert. Zum Löschen ist eine Internetverbindung zu einem Zeitserver erforderlich.

Wenden Sie sich ggf. an Ihren Administrator.


Vorgabedateinamen beibehalten

Vorgabe gilt auch für bestehende Dateien

Menü Datei | Optionen | Einstellungen auf Seite Dokument

Markieren Sie diese Option, um den automatisch erzeugten Dateinamen auch für bestehende Dateien zu erzwingen. Sobald der Anwender ein für den Dateinamen relevantes Attribut (Projekt usw.) ändert, wird die Dokumentdatei umbenannt bzw. in das neue Verzeichnis verschoben.

Beachten Sie bitte, dass diese Option den Datenverkehr im Netzwerk stark belasten kann. Die Datei wird nicht verschoben, wenn der neu ermittelte und der alte Dateiname auf dasselbe Verzeichnis verweist - egal ob UNC-Pfad oder Laufwerksbuchstabe.

Diese Option kann nur aktiviert werden, wenn Änderungen der Dateinamen zulassen nicht markiert ist. Sie hat keine Auswirkung auf geklonte Dokumente.


Verwerfen

Klicken Sie auf Verwerfen, wenn Sie diese Datei nicht in das Archiv importieren möchten.


Alle OK

Klicken Sie auf Alle OK, um dieses und alle weiteren anstehenden Dateien ohne weitere Bearbeitung in das Archiv zu importieren.

Tipp: Klicken Sie mit der rechten Maustaste auf diesen Schalten und wählen Sie Import-Dateiliste im lokalen Menü.


Abbrechen

Klicken Sie auf Abbrechen, um den Import aller anstehenden Dateien abzubrechen.


Dateiliste

Importstapel

Die in dieser Liste markierten Dateien werden nach Klick auf Importieren archiviert.


Zwischenablage überwachen

Markieren Sie diese Option und kopieren Sie anschließend Dateien in die Zwischenablage. Diese werden dann automatisch in den Importstapel übernommen.


Meldungen

Im unteren Bereich des Dialogfensters finden Sie Informationen über den derzeitigen Bearbeitungsstatus.


Startverzeichnis

Datenträgerverzeichnis (Ordner), in dem die Suche nach Dokumenten beginnen soll.

Klicken Sie auf die Schaltfläche [Durchsuchen], um das Verzeichnis auszuwählen. Um mehrere Verzeichnissen zu markieren, halten Sie bitte die Strg- oder Umschalt-Taste gedrückt.


Unterverzeichniss

Markieren Sie diese Option, um auch die Unterverzeichnisse nach Dokumentdateien zu durchsuchen.


Nur neue Dateien

Nur neue Dokumentdateien importieren
(Einstellung der Import-Profile und Option beim Massen-Import)

Wenn diese Option markiert ist, werden nur Dokumentdateien importiert, die im geöffneten Archiv noch nicht vorhanden sind. Beachten Sie bitte, dass alle identischen Dateien ignoriert werden.

Hierzu wird die Datenbank nach der Datei-Checksumme durchsucht und bei identischer Summe zusätzlich der Dateiinhalt verglichen.

Bei der Verzeichnisüberwachung ist diese Option immer aktiviert.

Siehe auch erweiterte Einstellungen FindDuplicateByFileName und ConfirmDuplicate


Importieren

Klicken Sie bitte auf Importieren, um die Dateien in der rechten Liste in das Dokumentenarchiv zu importieren.


Optionen

Klicken Sie auf die Schaltfläche Optionen und legen Sie die Optionen für das Importverzeichnis fest. Auf der Seite Feldwerte können Sie definieren, wie die Dokumentattribute aus der Verzeichnisstruktur ermittelt werden.


Suchen

Klicken Sie auf Suchen, um die Suche nach Dokumentdateien im angegeben Verzeichnis zu starten.


Abbrechen

Klicken Sie auf Abbrechen, um die Suche nach Dokumentdateien abzubrechen.

Es kann einige Sekunden dauern, bis die Software reagiert und die Sicherheitsabfrage "Möchten Sie abbrechen" erscheint.


Dateimaske

Für den Import werden i. d. R. alle Dokumenttypen berücksichtigt, die in Office Manager DMS registriert sind. Wenn Sie nur nach bestimmten Dateien suchen möchten, können Sie eine Dateimaske vorgeben. Mehrere Masken bitte mit Semikolon trennen.

Beispiele:
*.pdf
*.txt;*.doc
Me?er.*
Datei[0-9].txt


Eigenschaften

Eigenschaften der Dokumentversion bearbeiten

Sie können die Beschreibung und den Dateinamen der Version ändern.


Öffnen

Dokumentversion öffnen

Öffnet die markierte Dokumentversion im zugeordneten Anwendungsprogramm. Beachten Sie bitte, dass die archivierten Versionen oft schreibgeschützt sind und nicht geändert werden können.


Name

Geben Sie eine sinnvolle Beschreibung der Dokumentversion ein. Auf der Seite Details können Sie weitere Notizen erfassen.


Dateiname

Dateiname der zu archivierenden Dokumentversion. Der Dateiname wird vom Office Manager automatisch festgelegt. Alternativ können Sie aber auch einen Namen vorgeben, klicken Sie dazu bitte auf die Schaltfläche neben dem Eingabefeld.


Schreibschutz

Wenn die Option Schreibschutz markiert ist, kann die Dokumentdatei nicht geändert werden. Archivierte Dokumentversionen sollten mit einem Schreibschutz versehen werden, um eine unbeabsichtigte Änderung zu vermeiden.


Versionsnummer

Versionsnummer des archivierten Dokumentes. Die Nummer wird automatisch vom Programm vergeben.


Erstellt am

Datum und Uhrzeit der Archivierung.


Benutzername

Name des Anwenders, der die Dokumentversion archiviert hat.


Details

Sie können hier die Details der Dokument-Version beschreiben und beliebige Notizen erstellen.


Importdateiname

Diese Datei wird als Versionsstand für das Dokument importiert.

Je nach Einstellung (Menü Datei | Optionen | Einstellungen, Seite Importieren | Profile) wird die Datei in das Dokumentenverzeichnis kopiert, verschoben oder sie verbleibt am ursprünglichen Speicherort.


Start

Startet die Revision der Dokumente, die derzeit gesucht sind. Im Anschluss erhalten Sie eine Zusammenfassung der Tests und die Möglichkeit, Details zu den einzelnen Dokumenten einzusehen.


Abbrechen

Klicken Sie auf Abbrechen, um die laufende Revision zu unterbrechen. Das Prüfungsergebnis der bereits durchlaufenden Dokumente geht dabei nicht verloren.


Zusammenfassung

Zusammenfassung der Dokumentenrevision aller beim Test durchlaufenden Dokumente.

Um Details zu den einzelnen Dokumenten einzusehen, klicken Sie bitte auf den entsprechenden als Links dargestellten Text. Beispielsweise n nachvollziehbare Bearbeitungen.


Überblick

Kehrt zur Revisions-Startseite zurück. Dieser Schalter ist nur auf der Seite mit den Dokumentendetails sichtbar.


Dokumentergebnis

Zusammenfassung der Revision eines einzelnen Dokuments.


Prüfung

Log des Prüfungsdurchlaufs.

Hier können Sie nachvollziehen, wie die Software ein einzelnes Dokument überprüft.


Neu verknüpfen

Die in der Dokumententabelle markierten Dokumente werden kombiniert. Geben Sie bitte einen beliebigen Verknüpfungsnamen ein und klicken Sie auf OK.

Ein aussagekräftiger Name, z. B. die Auftragsnummer, hat Vorteile, wenn Sie später weitere Dokumente mit diesen kombinieren möchten.


Zu Verknüpfung hinzufügen

Die Dokumente werden einer bereits vorhandenen Verknüpfung hinzugefügt. Markieren die gewünschte Verknüpfung bitte in der unteren Liste und klicken Sie auf OK.


Verknüpfung entfernen

Markieren Sie die Verknüpfung, aus welcher die Dokumente entfernt werden sollen und klicken Sie auf OK.


Verknüpfungslisten

Liste mit vorhandenen Verknüpfungen, zu denen die Dokumente hinzugefügt werden können. Zur besseren Identifikation der Verknüpfungen können Sie durch Klick auf [+] die bereits enthaltenen Dokumente einblenden.


Auswahl der Datentabelle

Markieren Sie bitte im Menü Ansicht den Eintrag:

Aktive Dokumente, um nach normalen, im täglichen Zugriff befindlichen Dokumenten zu suchen, oder

Archivierte Dokumente für eine Suche in den langzeitarchivierten Dokumenten (nur Enterprise-Edition).

Kontakte wechselt zur Adressverwaltung und

Aufgaben zum Terminplaner.

Papierkorb beinhaltet die (noch nicht endgültig) gelöschten Dokumente.


Archivverzeichnis

Mit der Archivierungsfunktion werden alte Dokumente aus dem normalen Speicherbereich ausgelagert. Geben Sie bitte das Verzeichnis an, in welches die archivierten Dokumente verschoben werden sollen.

Falls die Dokumentdateien bei der Archivierung nicht verschoben werden sollen, lassen Sie das Eingabefeld bitte leer.


Dokumentdateien komprimieren

Wenn die Option Dokumentdateien komprimieren markiert ist, werden die Dokumentdateien beim Archivieren komprimiert. Die Dateien belegen dann weniger Speicherplatz.


PDF-Dokumente schützen

Aktiviert den Passwortschutz eines Acrobat-Dokuments, um Dokumentänderungen zu verhindern. Der Schutz kann nicht mehr aufgehoben werden (revisionssichere Archivierung).


Dateioperation

Legen Sie fest, ob die Dokumentdateien bei der Archivierung in einen besonderen Speicherbereich kopiert oder verschoben werden sollen.


helpcontext-2711

Neue Dokumente automatisch hinterlegen

Menü Datei | Optionen | Einstellungen, Seite Dokument | Blockchain

Wenn diese Option markiert ist, werden die Hashwerte neu hinzugefügter Dokumente automatisch nach 10 Minuten auf der eingestellten Blockchain hinterlegt.

Beachten Sie auch die erweiterte Einstellung "AutoStoreTaskOwner" in der admin.ini.


Blockchain-Auswahl

Verwendete Blockchain

Um die Einstellungen anzupassen, klicken Sie rechts im Eingabefeld bitte auf die Schaltfläche.

[automatisch]: die Office Manager-Vollversion verwendet das Mainnet "Documentchain", die Testversion speichert im Testnet.

Documentchain: das verteilte Mainnet der Blockchain für echte Revisionen.

Documentchain Testnet: nur für Tests.

Wenn Sie das Web-Wallet verwenden, benötigen Sie keine zusätzliche Software.


RPC-Port

Über diesen Computer-Port erfolgt die Kommunikation mit der Wallet-Software "DMS Core".


helpcontext-2714

Rohdaten zeigen

Vor dem Senden an die Blockchain wird eine Vorschau der Daten eingeblendet. Wenn diese Option markiert ist, beinhaltet die Vorschau auch den rohen Datenstream.


Vorschau

Vor dem Hinterlegen können Sie auf diesen Schalter klicken. Die zur Speichern vorgesehenen Informationen werden im mehrzeiligen Textfeld als Vorschau eingeblendet. Dies ermöglicht Ihnen eine Überprüfung, bevor Sie die Daten senden.


Ausgabe

Ausgabefeld für die Vorschau und Dokumentenrevision.


Veröffentlichen

Hinterlegen

Speichert nach einer Rückfrage die Dokumentinformationen (Hash, Dateichecksumme) in der ausgewählten Blockchain und zieht die Transaktionsgebühr vom Wallet-Guthaben ab. Die Transaktions-ID wird Im Archiv hinterlegt, sodass später eine Dokumentenrevision durchgeführt werden kann.

Im Anschluss wird auch das Schreibschutz-Attribut der Datei gesetzt, um unbeabsichtigte Änderungen zu verhindern. Sie können dies aber mit Start | Eigenschaften wieder deaktivieren.

Ein Dokument kann nur einmal in der Documentchain hinterlegt werden, ein Überschreiben der bestehenden Information ist nicht möglich. Ausnahmen:

·Wenn das Dokument nur in einer Testumgebung hinterlegt ist, kann es trotzdem an die öffentliche Blockchain gesendet werden.

·Sie können die Revisionsinformationen löschen (Klick auf den Pfeil des Schalters "Dokument prüfen") und anschließend neu hinterlegen. Selbstverständlich wird dann aber nur die Unveränderbarkeit seit dem erneuten Hinterlegen (also ab jetzt) bestätigt.

Socket-Fehler

Die Meldung "Verbindung abgelehnt" erhalten Sie, wenn keine Verbindung zum Wallet aufgebaut werden konnte. Prüfen Sie dann bitte, ob die "DMS Core" ausgeführt wird und die richtige Blockchain (normal oder Testumgebung) gewählt ist.

Internal server error weist auf ein verschlüsseltes Wallet zu, bitte zuerst mit Eingabe des Passwortes entschlüsseln.


Dokument prüfen

Führt eine Dokumentenrevision durch. Die aktuellen Daten werden mit den in der Blockchain gespeicherten verglichen. Wenn das Dokument unverändert ist, wird dieses bestätigt.

Die Prüfung ist nach einer Hinterlegung nicht sofort möglich. Die Transaktion muss zuvor bestätigt (gemined) werden. Warten Sie bitte einige Minuten ab. Falls Sie die lokale Testumgebung verwenden, dann erzeugen Sie den Block bitte mit "generate 1" im Menü Werkzeuge | Debug-Konsole.

Revisionsinformationen löschen

Klicken Sie hierzu bitte auf den Pfeil des Mausschalters "Dokument prüfen". Das Blockchain-Datenfeld mit der Transaktions-ID aller markierten Dokumente wird nach einer Rückfrage geleert. Anschließend können Sie keine Revision mehr durchführen (bzw. nur noch, wenn Sie die Transaktions-ID kennen).

Dies ist in der Regel nur sinnvoll, wenn Sie eine Dokumentdatei nachträglich geändert haben und das Dokument erneut auf der Blockchain absichern möchten. Selbstverständlich wird dann aber nur die Unveränderbarkeit seit dem erneuten Hinterlegen (also ab jetzt) bestätigt.

Für das Löschen sind administrative Rechte erforderlich.

Fehlgeschlagene Dokumente suchen

Wenn bei einer Revision Dokumente mit geänderter Datei gefunden wurden, können Sie die betroffenen Dokumente filtern. Klicken Sie hierzu bitte auf den Pfeil des Mausschalters "Dokument prüfen". Die Dokumentenhaupttabelle zeigt anschließend nur noch die fehlerhaften Dokumente und nur noch diese sind für die Bearbeitung im Blockchain-Dialogfenster gewählt.


Besitzer

Besitzer/Firma

Optional. Geben Sie hier Ihren Firmennamen o. ä. an. Der Hashwert dieser Information wird zusammen mit den Dokumentinformationen in der Blockchain gespeichert.

Datenschutz

Es wird nur der Hash hinterlegt. Da es sich um einen kurzen Text handelt, könnte der Name aber erraten werden (Berechnung der Hashwerte für verschiedene Firmennanem). Jemand, der diesen Hash kennt, kann ermitteln, wie viele Dokumente mit diesem Firmenhash hinterlegt sind.


Datei-Hash

Für die Revisionssicherheit wird die Checksumme (MD5 Hash) des Dokuments in der Documentchain gespeichert. Bei der späteren Überprüfung, ob das Dokument unverändert ist, wird diese mit der aktuellen Checksumme verglichen.

Dokumentdateien und interne Textverarbeitung: Der Hash wird aus dem Dokumenteninhalt gebildet.

Internet-URL: Wenn Sie eine Internetadresse (ohne lokale Dateikopie) verwalten, dann wird nur die Adresse (URL) überprüft. Es wird also nur bestätigt, dass der URL unverändert ist.


DMS Coin-Einheiten

1 DMS = 1 DMS

1 mDMS = 0,001 DMS, gesprochen "Milli-DMS"

1 uDMS oder µDMS = 0,000001 DMS, gesprochen "Micro-DMS"

1 docz = 0,00000001 DMS, gesprochen "Docoshi"

Test-DMS

Im Testnetz wird der Einheit jeweils ein kleines "t" vorangestellt, um diese von den echten Coins zu unterscheiden, besipielsweise tDMS und tuDMS.


helpcontext-2731

Datei-Schreibschutz setzen

Menü Datei | Optionen | Einstellungen, Seite Dokument | Blockchain

Wenn diese Option markiert ist, wird nach dem Hinterlegen des Hashes das Schreibschutz-Attribut der Dokumentdatei gesetzt. Dies ist eine einfache Möglichkeit, unbeabsichtigte Änderungen an den Dateien zu verhindern.


Neue Zeichnung

Erstellt eine neue CAD-Zeichnung.


Neues Bauteil

Erstellt ein neues CAD-Zeichnungsbauteil.


DXF,DWG konvertieren

Importiert Dateien im DWG- oder DXF-Format und konvertiert diese in das MegaCAD-Zeichnungsformat PRT. Ziehen Sie die Dateien per Drag&Drop vom Explorer auf die Office Manager-Dokumententabelle.


DXF,DWG exportieren

Konvertiert die markierte MegaCAD-Datei in das DWG- oder DXF-Format und speichert diese unter dem angegebenen Dateinamen.


CAD starten

CAD-Programme ausführen. Startet das CAD- oder Zusatzprogramm.


Bauteil einfügen

Fügt das markierte Bauteil in die geöffnete CAD-Zeichnung ein.


Registrierdatenbank aktualisieren

Markieren Sie diese Option, um den MegaCAD-Eintrag in der Windows-Registrierdatenbank zu aktualisieren. Dieser Eintrag hat für die Arbeit mit dem Office Manager keine Bedeutung, er ermöglicht Ihnen aber z. B., MegaCAD-Zeichnungen auch aus dem Windows-Explorer zu öffnen.


CAD einrichten

Markieren Sie diese Option, um einen Dokumenttypen für CAD-Zeichnungen einzurichten.


Bezeichnung

Bezeichnung des Dokumenttypen für CAD-Zeichnungen:

Geben Sie eine beliebige Bezeichnung (z. B. AutoCAD-Zeichnung, MegaCAD Zeichnung) ein, um einen neuen Dokumenttyp für das CAD-Programm zu erstellen.

Wenn Sie einen bereits vorhandenen Dokumenttypen ändern möchten, dann wählen Sie diesen aus der Liste aus.

Hinweis:
Die Bezeichnung des Zeichnungs-Dokumenttypen soll alphabetisch vor dem Bauteil-Dokumenttypen kommen. Dadurch werden beispielsweise bei AutoCAD die per Drag&Drop importierten DWG-Dateien dem Zeichnungs-Dokumenttypen zugeordnet.


Bauteile-Dokumenttyp

Markieren Sie diese Option, um einen Dokumenttypen für CAD-Zeichnungsbauteile einzurichten.


Bezeichnung

Bezeichnung des Dokumententypen für CAD-Bauteile:

Geben Sie eine beliebige Bezeichnung (z. B. CAD-Zeichnungsbauteil) ein, um einen neuen Dokumententyp für CAD-Bauteile zu erstellen. Wenn Sie einen bereits vorhandenen Dokumententypen ändern möchten, dann wählen Sie diesen aus der Liste aus.


CAD-Programmdatei

Dateiname der CAD-Programmdatei (z. B. C:\Programme\acad\acad.exe oder C:\MegaCAD\ntmega3d.exe).

Klicken Sie auf [Durchsuchen], um nach der Programmdatei zu suchen.


Plot-Programmdatei

Dateiname des CAD-Plot-Programms (z. B. C:\MEGAWIN\PLOT\WPLOT32.EXE).

Klicken Sie auf [Durchsuchen], um nach der Programmdatei zu suchen.


Schriftkopf erstellen

Wenn diese Option markiert ist, fügt der Office Manager einen Schriftkopf in neue Zeichnungen ein. Attribute wie der Zeichnungsname werden dabei automatisch ausgefüllt.


Neues Fenster öffnen

wenn diese Option markiert ist, wird beim Öffnen von Zeichnungen immer eine neue CAD-Instanz gestartet. Ist die Option nicht markiert, werden Zeichnungen in ein bereits geöffnetes CAD-Fenster geladen.


Schriftkopfverzeichnis

Geben Sie bitte das Verzeichnis an, in dem die Schriftkopf-Dateien gespeichert sind.


Verzeichnis überwachen

Markieren Sie diese Option, um die Verzeichnis-Überwachung zu aktivieren. Der Office Manager übernimmt dann die Dokumente, die im überwachten Verzeichnis gespeichert werden.


Verzeichnis

Überwachtes Verzeichnis

Markieren Sie Verzeichnis "Eigene Dateien", um das persönliche Systemverzeichnis "Eigene Dateien" zu überwachen.

Oder markieren Sie die Option Verzeichnis und geben Sie das zu überwachende Verzeichnis im Eingabefeld ein. Klicken Sie auf [Durchsuchen], um das Verzeichnis im Dialogfenster auszuwählen.

Hinweis
Das überwachte Verzeichnis sollte nicht dem Standard-Dokumentenverzeichnis entsprechen. Dies würde zu Problemen führen, wenn Sie ein neues Dokument mit dem Office Manager erstellen. Sie können die Makro-Variablen im Verzeichnis verwenden.


Unterverzeichnisse

Markieren Sie diese Option, um auch die Unterverzeichnisse zu überwachen, beispielsweise ein komplettes Laufwerk.

Mit dieser Funktion kann die Dokumentenverwaltung auf Wunsch komplett automatisiert werden: Die Anwender speichern ihre Dokumente einfach in der gewohnten Verzeichnisstruktur. Der Office Manager überwacht die Verzeichnisse und übernimmt neue Dokumente automatisch in das Archiv. Die Attribute (Dokumenttyp, Projekt usw.) werden dabei aus der Verzeichnisstruktur übernommen oder für jedes Dokument manuell bearbeitet.


Verzeichnisauswahl

Markieren Sie bitte die Verzeichnisse, die vom Office Manager überwacht werden sollen.

Diese Auswahl steht nur zur Verfügung, wenn die Option Unterverzeichnisse überwachen aktiviert ist.


Dateioperation

Legen Sie fest, ob die importierten Dateien aus dem Quell-Verzeichnis in das Dokumentenverzeichnis kopiert werden sollen.

·In das Dokumentenverzeichnis kopieren: Die importierte Dokumentdatei wird in das Standard-Dokumentverzeichnis kopiert und anhand der Vorgaben umbenannt. (s. a. Einstellungen | Dokument).

·In das Dokumentenverzeichnis verschieben: Die Dokumentdatei wird in das Dokumentverzeichnis verschoben und anhand der Vorgaben umbenannt. (s. a. Einstellungen| Dokument).

·Im Quell-Verzeichnis belassen: Die Dokumentdatei verbleibt ohne Änderung in dem Verzeichnis, aus dem sie importiert wurde.

Die Dateioperation wird im Importprofil definiert, kann beim Import einer Datei aber auch individuell angepasst werden. Klicken Sie dazu im Eigenschaftendialog auf Durchsuchen hinter Dateiname.

Hinweis:

Wenn die Dokumentendatei nicht im Quell-Verzeichnis verbleibt (der Normalfall), dann kann bei der Verzeichnisüberwachung folgendes Problem entstehen: Sie arbeiten z. B. mit der Textverarbeitung und speichern eine Datei in das überwachte Verzeichnis. Office Manager DMS kommt in den Vordergrund und Sie geben die Attribute ein. Wenn auf OK klicken, kann die Datei nicht verschoben werden, weil sie noch in der Textverarbeitung geöffnet ist. Schließen Sie Dokumentdateien also, bevor Sie den Import in das Archiv durchführen.


Abbruch verweigert

Der Administrator hat den Abbruch der automatischen Dokumentübernahme verboten. Die Schalter Verwerfen und Abbrechen sind deaktiviert.

Klicken Sie bitte auf OK, um das Dokument zu übernehmen.

Siehe auch: Erweiterte Einstellungen - AllowCancel


Nur eigene Dateien übernehmen

Nur Dateien des angemeldeten Benutzers übernehmen
(Menü Datei | Optionen | Einstellungen)

Markieren Sie diese Option, wenn mehrere Computer ein gemeinsames Server-Verzeichnis überwachen. Sonst würden alle angeschlossenen Computer, auf denen der Office Manager läuft, versuchen, die neue Datei zu importieren.

Voraussetzung für diese Option ist ein Windows NT-System und die korrekte Sicherheitseinstellung auf dem Dateiserver: der Ersteller neuer Dateien muss auch der Eigentümer der Datei sein. Sie können die Einstellung überprüfen, indem Sie im Windows-Explorer die Spalte "Eigentümer" einblenden: hier sollte jeweils der Loginname des Anwenders stehen, der die Datei erstellt hat.


Volltext

Primäres Suchfeld Volltext

Der Office Manager ermöglicht neben der Suche in den einzelnen Attributen auch eine sehr schnelle Abfrage über den Gesamtindex. Hier sind die Wörter aus allen Attributen (Projekt, Name, usw.) und den Notizfeldern enthalten. Geben Sie Wörter ein und drücken Sie die Eingabetaste. Die Dokumententabelle enthält jetzt nur noch die Dokumente, die alle gesuchten Wörter enthalten.

Das Suchfeld ist nur sichtbar, wenn der Gesamtindex aktiviert ist (Menü Datei | Optionen | Einstellungen, Seite Volltextindex)


Indexierungs-Fortschritt

Aktualisierung des Gesamtindex

Der Statusbalken zeigt den Fortschritt der Volltextindexierung.


Volltextindex erzeugen

Mit dieser Option legen Sie fest, ob ein Volltextindex erzeugt werden soll.

Kein Index: es wird kein Volltextindex erzeugt.

Index über alle Datenfelder: nur die Inhalte der Datenbankfelder werden indexiert.

Index über alle Datenfelder und Dateiattribute: die Datenbankfelder und erweiterten Dateiattribute (Titel, Autor u. a.) werden indexiert.

Index über alle Datenfelder und Dokumentinhalte: die Datenbankfelder, die erweiterten Dateiattribute und die Dokumentinhalte werden indexiert. Beachten Sie bitte, dass die Indexierung der Dokumente sehr zeitaufwendig sein kann.


Zahlen ignorieren

Wenn Sie diese Option markieren, dann ist eine Volltextsuche nach Zahlen nicht möglich.


Mindest-Zeichenanzahl

Mindestanzahl der Zeichen je Wort

Geben Sie bitte die Mindestlänge der Wörter ein, die in den Gesamtindex übernommen werden sollen. Wenn Sie z. B. eine Mindestlänge von 4 eingeben, werden Wörter wie "er", "Sie" und "pro" nicht in den Index übernommen.


Ignorierte Wörter

Liste der zu ignorierenden Wörter

Häufig gebrauchte Wörter (z. B. will, sollen, er, aber, deshalb, ...), nach denen nicht gesucht wird, sollten auch nicht in den Gesamtindex übernommen werden. Sie würden den Index unnötig belasten. Klicken Sie auf Öffnen, um die Liste Ihren eigenen Anforderungen anzupassen.

Siehe auch: Erweiterte Einstellungen - Suchwortliste


Dateitypen

Liste der zu indexierenden Dateitypen

Enthält die Dateiendungen aller Dokumenttypen, die indexiert werden sollen. Klicken Sie auf Öffnen, um die Liste Ihren eigenen Anforderungen anzupassen. Geben Sie die Dateiendungen bitte mit dem führenden Punkt an (z. B. ".txt"), es sind keine Jokerzeichen erlaubt!

Beachten Sie auch die erweiterte Einstellung "IndexAttachments" in der admin.ini


Nur Teil indexieren

Nur die ersten MB indexieren

Oft ist es nicht sinnvoll, die gesamten Dokumentinhalte zu indexieren. Stellen Sie sich z. B. ein eher unwichtiges PDF-Dokument mit mehreren hundert Seiten oder eine Excel-Tabelle mit zigtausend Zeilen vor. Es würde den Index mit einer Vielzahl Wörter belasten, die nie abgefragt werden.

Wir empfehlen, hier einen Wert von 2 MB anzugeben, um nur die ersten 2 MB der externen Dokumentdateien zu indexieren. Das ist ein guter Kompromiss zwischen Geschwindigkeit und vollständiger Indexierung.

Geben Sie 0 MB ein, um immer die gesamte Datei zu indexieren.


Optionen der Volltextsuche

Suchoption

Wählen Sie bitte, ob die Dokumente alle gesuchten Wörter oder nur mindestens ein gesuchtes Wort beinhalten müssen, um angezeigt zu werden.


Dateiname

Dateiname der OCR-Software bei Parametersteuerung
oder des Makros bei Makrosteuerung.

OLE-Kennung bei automatisierter OCR.


OCR-Test

Führt einen kurzen Test der gewählten OCR-Software aus.


Makro öffnen

Öffnet die Makrodatei im Skripteditor.


Grafikformate

Markieren Sie bitte die Grafikformate, welche von der OCR-Software unterstützt werden (z. B. Tiff).

Wenn Sie Adobe Acrobat (PDF) auswählen, müssen Sie zusätzlich mindestens ein Grafikformat markieren. Der Office Manager bettet die Grafiken dann in diesem Format in das PDF-Dokument ein.


Nur OCR

Nur OCR (empfohlen)

Navigation: »Kein übergeordnetes Kapitel«

Nur OCR (empfohlen)

(Menü Datei | Optionen | Einstellungen, Seite Volltextindex | OCR)

Wenn diese Option markiert ist, wird das PDF-Dokument nicht von der OCR, sondern von Office Manager DMS generiert. Das gescannte Bild bleibt unverändert erhalten.

Deaktivieren Sie diese Option nur, wenn Sie OmniPage bzw. Tesseract genau an Ihre Anforderungen angepasst und Tests mit allen eingesetzten Scannern durchgeführt haben. Achten Sie insbesondere darauf, dass durch die OCR keine unerwünschten Bildverarbeitungen oder ungeeignete Bildkompressionen vorgenommen werden.

Siehe auch

Übersicht OCR-Software
Supportseiten OCR-Software
Aktivieren Sie die Schräglagenkorrektur des Scanners oder im DMS.


Ausführungszeit

OCR-Ausführungszeit

Navigation: »Kein übergeordnetes Kapitel«

OCR-Ausführungszeit

Menü Datei | Optionen | Einstellungen, Seite Volltextindex | OCR

Der Text auf gescannten Papierdokumenten wird mittels OCR erkannt. Dieser zeitaufwendige Vorgang kann im Hintergrund erfolgen, sodass Sie während der Texterkennung ungestört weiterarbeiten können.

Auswahlmöglichkeiten

·Während dem Scannen: Der Text wird sofort erkannt. Nach dem Scan mit einem Profil müssen Sie einen Moment warten, bis sich das Eigenschaftenfenster öffnet. Beim Dialogscan erfolgt die Erkennung direkt nach Klick auf OK.
Beim Ricoh ScanSnap wird die OCR bereits von der ScanSnap-Software ausgeführt, wenn diese Option gewählt ist.

·Im Hintergrund: Startet den Vorgang kurz nach dem Abspeichern des Dokuments, Sie müssen nicht darauf warten.

·Ab hh:00 Uhr: Definiert eine Uhrzeit (z. B. nachts) für die Hintergrund-Ausführung.

Hinweise

Eine Volltextsuche im gescannten Dokument ist erst nach der OCR und der Indexierung möglich. Sie finden das neue Dokument also nicht sofort nach dem Abspeichern im Archiv. Siehe auch Blog-Artikel für ausführliche Informationen.

Wenn Sie ein Scanprofil mit automatischer Dokumentenerkennung nutzen, wird die Texterkennung unabhängig von dieser Einstellung sofort ausgeführt. Der Text ist für die Dokumentenanalyse zur Erkennung der Metadaten im Dokument erforderlich.

Moderne Computer mit Parallelverarbeitung sind so schnell, dass die Verzögerung bei wenigen Dokumentseiten kaum zu bemerken ist. Die sofortige OCR-Ausführung ist also meistens problemlos.


Ausführen auf

OCR ausführen auf

Optionale Vorgabe des Computers, auf dem die OCR-Texterkennungssoftware ausgeführt wird. Wenn Sie keinen Computer angeben, dann wird die OCR auf dem Computer ausgeführt, auf dem das Dokument gescannt wurde. Dies ist das Standardverhalten.

Syntax: Computername oder Benutzername@Computername bzw. Domäne\Benutzername@Computername.

Mit Hilfe dieser Option können Sie die Texterkennung zentralisieren, die OCR-Software muss nur auf einem Computer installiert sein.


Eigenschaftendialog öffnen

Wenn diese Option markiert ist, wird für jedes importierte Dokument der Eigenschaftendialog geöffnet. Sie können dann die Attribute eingeben und das neue Dokument übernehmen, aber auch ablehnen.

Ist die Option nicht markiert, werden neue Dokumente automatisch übernommen, ohne dass der Eigenschaftendialog geöffnet wird.


Feldwerte

Tabelle mit den Feldstandardwerten für importierte Dokumente. Die linke Seite zeigt die Datenfelder der geöffneten Dokument-Datenbank, die rechte Seite die Feldwerte.

Sie können die Makro-Variablen verwenden, um die Dokumentattribute beispielsweise aus dem Dateinamen zu generieren. Die Auswahllisten in der Spalte Feldwerte beinhalten Beispiele für den Verwendung der Makro-Variablen.

Klicken Sie für weitere Informationen auf den Schalter Hilfe.


Gruppierung übernehmen

Wenn diese Option markiert ist, werden die Dokumentattribute von der Auswahl im Projektnavigator und der Gruppierung übernommen.

Die Option ist nur in Importprofilen sichtbar, wenn die Dokumente automatisch importiert werden. Beim manuellen Import per Drag&Drop werden die Attribute immer berücksichtigt.

Beispiel:

Die Tabelle ist nach dem Feld "Status" gruppiert und ein Dokument mit dem Status "Normal" ist in der Tabelle markiert. Das neue Dokument erhält auch den Status "Normal", wenn diese Option markiert ist.


Faximport

Deaktiviert: kein Faximport.

Manuell auf neue Faxe prüfen: neue Faxe werden mit dem Menübefehl Dokument | Neu | Faxe importieren eingelesen.

Neue Faxe automatisch importieren: es wird regelmäßig nach neuen Faxen gesucht.

Vollautomatisch: neue Faxe werden automatisch importiert, ohne dass der Eigenschaftendialog geöffnet wird.


Faxverzeichnis

Verzeichnis, in welchem die Faxsoftware eingehende Faxe abspeichert.

Sie können eine Dateimaske angeben, beispielsweise "G:\Faxeingang\*.*" für alle Dateien oder "G:\Faxeingang\*.tif" nur für Tiff-Dateien.


Fax-Dokumenttyp

Dokumenttyp für Faxe.

Wählen Sie im Menü Datei | Optionen den Befehl Dokumenttyp, wenn Sie einen Typen für Faxe definieren möchten.


Fax-Projekt

Projekt, welchem die neuen Faxe zugeordnet werden.

Beim manuellen Faximport wird diese Vorgabe aber durch ein eventuell markiertes Projekt im Navigator überschrieben.


Fax-Status

Status für die neuen Faxe. Beispielsweise können Sie den Status "zu bearbeiten" vorgeben.


Fax-Benutzer

Bei automatischen Faximport wird dieser Benutzer zur Bearbeitung neuer Faxe aufgefordert.

Alternativ können Sie hier auch den Namen eines zuständigen Computers angeben. Markieren Sie in diesem Fall auch die Option Eigenschaftendialog für Fax öffnen auf der Seite Importieren.

Die Änderung dieser Option wirkt sich erst nach einem Programmneustart aus.


Aufgabe erstellen

Wenn diese Option markiert ist, wird nach dem vollautomatischen Faximport für den zuständigen Benutzer eine Tätigkeit erstellt, die ihn zum Bearbeiten des Dokumentes auffordert.


Import-Abbruch zulassen

Deaktivieren Sie diese Option, um zu vermeiden, dass der Import durch den Anwender abgebrochen wird. In der Regel wird der Abbruch aber zugelassen - der Anwender kann dann im Eigenschaften-Dialog auf Abbrechen klicken und das Fax verwerfen oder später importieren.


Quelldatei

Quelldatei, aus der die Datensätze importiert werden sollen. Klicken Sie bitte auf die Schaltfläche [Durchsuchen] und wählen Sie den Dateinamen im Dialogfenster aus.


Feldzuordnungen

Tabelle mit den Feldzuordnungen. Die linke Spalte zeigt alle Datenfelder der Quelldatei, die rechte Spalte die Felder des Office Manager-Archivs, in welche die Daten kopiert werden.


Import starten

Startet den Import. Alle Datensätze aus der Quelldatei werden in das geöffnete Office Manager-Archiv kopiert.


Map-Datei öffnen

Liest die Feldzuordnungen aus einer Map-Datei.

Beachten Sie, dass die Zuordnungen in der Tabelle überschrieben werden. Wenn Sie bereits Zuordnungen gemacht haben, können Sie diese zuvor in einer anderen Map-Datei speichern.


Map-Datei speichern

Speichert die Feldzuordnungen in einer Map-Datei.

Nutzen Sie diese Funktion, wenn Sie die Feldzuordnungen in der Tabelle öfters verwenden möchten.


Layout wählen

Mit Auswahl der Layoutdatei legen Sie das aktuelle Design der Programmoberfläche fest.

Klicken Sie für eine umfangreiche Hilfe bitte auf den letzten Listeneintrag [Hilfe].


Raster

Einstellung der Rasterweite, an der die Komponenten ausgerichtet werden. Bei einer Einstellung von beispielsweise "4", werden die Komponenten beim Verschieben um jeweils 4 Bildpunkte versetzt.


Auswahlmodus

Klicken Sie auf diese Schaltfläche, um bestehende Komponenten mit der Maus auszuwählen.


Freier Text

Freien Text hinzufügen

Klicken Sie bitte auf diese Schaltfläche und positionieren Sie anschließend das Textfeld im Layout.


Linie

Linie hinzufügen

Mit diesem Befehl können Sie das Layout gestalten und Linien hinzufügen.


Gruppierungsbox

Gruppierungsbox hinzufügen

Fügt dem Layout eine beschriftete Box hinzu, in der andere Komponenten gruppiert dargestellt werden.


Hintergrundgrafik

Hintergrundgrafik hinzufügen

Sie können eine Grafik einfügen und das Layout ansprechend gestalten.

Tipp: Fügen Sie nur dezente Bilder ein.


Feldbeschriftung

Feldbeschriftung hinzufügen

Feldbeschriftungen sind Textfelder, welche die Bezeichnung von Datenbankfeldern zeigen. Sie werden im Layout normalerweise links neben oder über einem Datenbankfeld positioniert.

Siehe auch: Menü Datei | Datenbank | Anpassen | Felder definieren.


Datenfeld

Datenfeld hinzufügen

Fügt ein Eingabefeld für Dokumentattribute (Datenbankfelder) ein.


Komponente löschen

Um eine Komponente aus dem Layout zu löschen, markieren Sie die Komponente bitte zuerst mit der Maus und klicken Sie anschließend auf diese Schaltfläche.


Schalter

Mausschaltfläche hinzufügen

Fügt einen Schalter zum Aufruf von Makros ein.


Text

Hier geben Sie die Beschriftung für freie Textfelder und Gruppierungsboxen, bzw. den Dateinamen für Grafiken ein.


Datenfeld

Wählen Sie bitte das Datenbankfeld aus der Liste, welches der markierten Datenfeld-Komponente zugeordnet werden soll.


X (links)

Gibt den Abstand der Komponente vom linken Rand an. Sie können die Komponente mit der Maus verschieben oder den gewünschten Abstand hier eingeben.

Der Abstand wird in Bildpunkten (Pixel) angegeben.


Y (oben)

Gibt den Abstand der Komponente vom oberen Rand an. Sie können die Komponente mit der Maus verschieben oder den gewünschten Abstand hier eingeben.

Der Abstand wird in Bildpunkten (Pixel) angegeben.


Breite

Gibt die Breite der Komponente in Bildpunkten (Pixel) an. Sie können die Größe der Komponente mit der Maus ändern oder die gewünschte Breite hier eingeben.

Die Größe von Textfeldern kann nicht geändert werden, wenn die Option Größe der Textfelder anpassen markiert ist.


Höhe

Gibt die Höhe der Komponente in Bildpunkten (Pixel) an. Sie können die Größe der Komponente mit der Maus ändern oder die gewünschte Höhe hier eingeben.

Die Größe von Textfeldern kann nicht geändert werden, wenn die Option Größe der Textfelder anpassen markiert ist.


Umriss

Gibt an, ob die Linien-Komponente ein Rechteck oder eine einfache Linie darstellt.


Transparent u.a:

Transparent (Menü Ansicht | Anpassen | Layout einwerfen)

Markieren Sie diese Option, wenn die markierte Grafik transparent dargestellt werden soll.

Flach

Mausschaltfläche ohne 3D-Rand zeichnen.

Überschrift

Großes Textfeld: gemäß den Windows Design-Richtlinien wird der Text in blauer Farbe mit einer Schriftgröße von 11 Pixeln dargestellt.

Zeilenumbruch

Bricht lange Textzeilen automatisch um, damit sie vollständig sichtbar sind.


Makro

Enthält das Makro, welches beim Klick auf den Schalter ausgeführt wird.

Beispiel: {ExecuteMacroFile:filename.omac}


Online-Registrierung

Klicken Sie bitte auf Online-Registrierung, um das Web-Formular für die Registrierung in Ihrem Browser zu öffnen. Den Freigabecode erhalten Sie anschließend per E-Mail.


Freischalten

Geben Sie den Freigabecode ein und klicken Sie auf Freischalten. Das Programm arbeitet anschließend als Vollversion.


Adressdaten für Registrierung

Adressdaten für die Online-Registrierung.

Mit diesen Daten werden die Felder in unseren Web-Formularen ausgefüllt - spart doppelte Tipparbeit.


E-Mail-Adresse

Ihre gültige E-Mail-Adresse. Der Freigabecode wird per Mail an diese Adresse gesendet.


Testen Enterprise

Klicken Sie bitte auf Enterprise-Edition, Jetzt testen, wenn Sie jetzt noch keine Vollversion bestellen und die Software als Enterprise-Edition testen möchten. Diese Option steht nur für einen begrenzten Zeitraum zur Verfügung.


Testablauf

Zeigt an, wie viele Tage die Software noch als Demoversion gestartet werden kann.


Testen Pro

Klicken Sie bitte auf Pro-Edition, Jetzt testen, wenn Sie jetzt noch keine Vollversion bestellen und die Software als Pro-Edition testen möchten. Diese Option steht nur für einen begrenzten Zeitraum zur Verfügung.


Dateiname ändern

Bestätigung "Dateiname ändern".

Klicken Sie bitte auf:

Ja, um die Änderung für diese Datei durchzuführen.

Nein, um diese Datei nicht zu ändern.

Abbrechen, um diese Datei nicht zu ändern und die Funktion abzubrechen.

Alle, um die Änderungen für alle Dateien durchzuführen.


Starten

Klicken Sie auf Starten, um die Änderungen durchzuführen.

Sie benötigen Administrator-Rechte zum Ausführen dieser Funktion. Überprüfen Sie Ihre Eingaben sehr sorgfältig, die Änderungen können nicht rückgängig gemacht werden.


Bestehender Pfadeintrag

Geben Sie den zu ändernden Pfad ein. Es werden alle Dokumente angepasst, deren Dateinamen mit diesem Pfad beginnen.

Beispiel: Bestehender Pfadeintrag = "C:\Eigene Dateien" und in Ändern in = "G:\Daten". Die Datei "C:\Eigene Dateien\Projektname\Dokument.txt" wird in "G:\Daten\Projektname\Dokument.txt" geändert.


Ändern in

Geben Sie den neuen Pfad ein.

Beispiel: Bestehender Pfadeintrag = "C:\Eigene Dateien" und in Ändern in = "G:\Daten". Die Datei "C:\Eigene Dateien\Projektname\Dokument.txt" wird in "G:\Daten\Projektname\Dokument.txt" geändert.


Dateien kopieren

Legt fest, ob nur die Datenbank aktualisiert oder auch die Dokumentdateien kopiert werden sollen.

nicht kopieren: Der Datenbankeintrag wird aktualisiert, wenn die Datei bereits im neuen Verzeichnis vorhanden ist.

in das neue Verzeichnis kopieren: Der Datenbankeintrag wird aktualisiert und die Datei kopiert.

in das neue Verzeichnis verschieben: Der Datenbankeintrag wird aktualisiert und die Datei verschoben.


Datenbank komprimieren

Markieren Sie diese Option, um die geöffneten Datenbanken zu überprüfen und den nicht mehr genutzten Speicherplatz freizugeben. Diese Funktion sollte z. B. ausgeführt werden, nachdem viele Datensätze in der Dokumententabelle gelöscht wurden. Bei Firebird ist diese Funktion nur für defekte Datenbanken erforderlich.

Diese Option gilt nur für Datenbanken im MS Access- und SQLite-Format.


Volltextindex aktualisieren

Volltextindex und Dateiattribute aktualisieren

Synchronisiert die Archivdatenbank mit dem Dateninhalt und den Attributen.

Der Index wird bei Änderungen der Dokumente automatisch aktualisiert. Wenn Sie ein Dokument aber ohne Office Manager öffnen, werden eventuelle Änderungen nicht berücksichtigt.

Aktivieren Sie bitte bei der Datenbankpflege diese Option, um alle Dokumentdateien, die seit der letzten Indexierung geändert wurden, erneut einzulesen.


Daten-Integrität sicherstellen

Überprüft die Datenintegrität (Schlüsselnummern, verbundene Tabellen) und führt bei Bedarf erforderliche Korrekturen durch.

Bereinigt die Liste der bekannten Datenbanken, welche beispielsweise für die Spalte "Datenbank" in der Aufgabenverwaltung relevant ist.


Index für Kontakterkennung

Neue Dokumente werden, sofern möglich und gewünscht, automatisch einem Kontakt zugeordnet. Beispielweise über die eindeutige E-Mail-Adresse, IBAN oder Kundennummer. Der Index mit den eindeutigen Phrasen wird automatisch gepflegt.

Markieren Sie diese Optionen, falls Sie den Index vollständig neu erstellen möchten.


Starten

Klicken Sie auf Starten, um den Datenabgleich auszuführen.


Quellarchiv

Dateiname des geöffneten Dokumentenarchivs. Dies ist die ursprüngliche (originale) Datenbank, die z. B. im Firmennetzwerk gespeichert ist.

Es wird nur die aktuelle Suche der Datenbank synchronisiert.


Synchrones Archiv

Wählen Sie den Dateinamen der synchronen Dokumentendatenbank. Dies ist das ausgelagerte Archiv, das beispielsweise auf einem Notebook gespeichert wurde.


Datenpriorität

Legt fest, welche Datenbank die gültigen Dokumentattribute enthält. Wählen Sie:

Daten des geöffneten Archivs, wenn die Attribute der geöffneten Datenbank gültig sind. Die synchrone Datenbank wird aktualisiert.

Daten des Synchronarchivs, wenn die Attribute der synchronen Datenbank gültig sind. Die geöffnete Datenbank wird aktualisiert.


Sicherungskopien

Wenn diese Option markiert ist werden alle Dateien, die durch die Synchronisierung ersetzt werden, vor dem Überschreiben gesichert. Die Sicherungen befinden sich im selben Verzeichnis, der Dateiendung wird eine Tilde ~ vorangestellt. Es wird max. eine Sicherung erstellt, ältere werden also überschrieben.

Das Aktivieren dieser Option vermeidet Datenverlust und ist für die Datensicherheit empfohlen.


Tätigkeiten synchronisieren

Wenn die Option markiert ist werden auch die Tätigkeiten synchronisiert. Falls Sie die Aufgabenverwaltung des Office Managers nicht nutzen, können Sie die Markierung entfernen, um den Datenabgleich zu beschleunigen.


Logdatei erstellen

Wenn die Option markiert ist wird eine Logdatei mit den durchgeführten Änderungen erstellt. Die Datei beinhaltet Informationen über die geänderten Attribute und ersetzen Dateien.


OK

Klicken Sie auf OK, um die markiere Datei zu übernehmen. Die Zieldatei wird überschrieben!


Alle

Klicken Sie auf Alle, um die Auswahl für alle zu synchronisierenden Dateien zu übernehmen. Es erfolgt keine weitere Rückfrage mehr.


Abbrechen

Klicken Sie auf Abbrechen, um die Synchronisierung abzubrechen.


Ursprüngliche Datei

Die ursprüngliche Datei (z. B. im Firmennetzwerk) bleibt erhalten. Die synchrone Datei (z. B. auf dem Notebook) wird mit der ursprünglichen überschrieben.


Synchrone Datei

Die synchrone Datei (z. B. auf dem Notebook) bleibt erhalten. Die ursprüngliche Datei (z. B. im Firmennetzwerk) wird mit der synchronen überschrieben.


Neuere Datei

Die jeweils neuere Datei (die zuletzt bearbeitete) bleibt erhalten. Die ältere wird mit der neueren überschrieben.


Keine Synchronisierung

Keine Synchronisierung, beide Dateien bleiben erhalten.


Datenbank-Eigenschaften

Datenbank | Eigenschaften
(nur Enterprise-Edition)

Einstellungen und Verbindungsparameter der geöffneten Server-Datenbanken bearbeiten.

Dieser Befehl ist nur aktiviert, wenn eine .omcs-Dokument-, .crmcs-Kontakt- und/oder .aplcs-Anwendungsdatenbank geöffnet ist.


Parameter

Verbindungsparameter der geöffneten Server-Datenbanken. Klicken Sie für ausführliche Informationen bitte auf Hilfe.

ACHTUNG: Gehen Sie bei Änderungen der Verbindungsparameter sehr sorgfältig vor.


Datenbanktreiber

Bezeichnung des Datenbanktreibers.

Um einen anderen Treiber zu wählen, markieren Sie bitte die Spalte Verbindung und klicken Sie auf die Schaltfläche [...].


Dateiname

Kompletter Dateiname der .omcs-, .crmcs oder .aplcs-Datei. In dieser Textdatei sind die Verbindungsparameter für die Server-Datenbank gespeichert.


Zurücksetzen

Die Schrifteinstellungen auf Standardwerte zurücksetzen und die Grafik entfernen.


Bezeichnung

Der Name des Projektes. Gleichheitszeichen und Backslash sind nicht erlaubt.


Schriftfarbe

Farbe der Projektnamen im Navigator.


Hintergrundfarbe

Der Projektname wird im Navigator mit dieser Farbe hinterlegt.


Grafik

Wählen Sie bitte eine Grafik aus, die im Projektnavigator vor dem Projektnamen dargestellt werden soll.


Beschreibung

Geben Sie einen kurzen Hinweis oder eine längere Projektbeschreibung ein.

Beachten Sie auch die automatische Projekterkennung mit {AutoCaptSelectionListFindItem} und {SelectionListFindItem}


Fett

Formatiert den Projektnamen fett und hebt ihn somit hervor.


Kursiv

Formatiert den Projektnamen kursiv.


Durchgestrichen

Stellt den Projektnamen druchgestrichen dar.


Warnung

Hervorhebung von Dokumenten und Kontakten im Eigenschaften-Dialog.

Beispiel: Sie verwalten Kontakte mit einem Statusfeld. Wenn der Status "Gesperrt" ist, möchten Sie verhindern, dass dies übersehen wird. Hierzu fügen Sie der Auswahlliste den Wert "Gesperrt" hinzu, markieren die Option Warnung und geben eine auffällige Hintergrundfarbe an. Die Farbmarkierung sehen Sie dann bei gesperrten Kontakten im Eigenschaftendialog am untere Rand.


Hilfe

Übersicht der Office Manager-Hilfethemen, Hilfe-Index und Suche. Für eine Übersicht der gesamten Online-Dokumentation wählen Sie Hilfethemen.

Für die Dokumentation der Textverarbeitung klicken Sie auf Hilfe.

Der Eintrag Info zeigt eine Infobox zum Programm.


Speichern

Speichert das interne Dokument als Text-Datei.


Drucken

Druckt das Dokument.


Hilfe-Internet

Hilfe- und Supportseiten im Internet. Siehe auch Menü Datei | Hilfe.


Rückgängig

Macht den letzten Befehl rückgängig oder löscht die letzte Eingabe.


Alles rückgängig

Macht nach einer Rückfrage sämtliche Änderungen seit dem Öffnen des Dokumentes rückgängig.


Löschen

Löscht den markierten Text ohne ihn in der Zwischenablage abzulegen.


Einfügen

Fügt den Inhalt der Zwischenablage an der Einfügemarke ein und ersetzt den markierten Text.


Wiederholen

Wiederholt einen Befehl, der zuvor rückgängig gemacht wurde.


Schrift formatieren

Öffnet das Dialogfenster "Schriftart". Sie können hiermit die Schriftart, Größe, Farbe usw. des markierten Textes ändern.


Schriftart

Ändert die Schriftart des markierten Textes. Wählen Sie eine Schriftart aus der Liste.


Schriftgrad

Ändert den Schriftgrad (Größe) des markierten Textes.


Schriftart speichern

Speichert die aktuelle Schriftart als Standard-Vorgabe für den Editor. Wenn Sie ein neues Dokument erstellen, dann ist diese Schriftart voreingestellt.


Fett

Formatiert den markierten Text fett, bzw. entfernt die Formatierung fett.


Kursiv

Formatiert den markierten Text kursiv, bzw. entfernt die Formatierung kursiv.


Unterstrichen

Unterstreicht den markierten Text, bzw. entfernt die Formatierung unterstrichen.


Zwischanablage überwachen

Zwischenablage überwachen

Wenn dieser Schalter gedrückt ist, wird der Text aus der Zwischenablage automatisch eingefügt:

In einer anderen Anwendung Text markieren und in die Zwischenablage kopieren (z. B. Strg+C). Der Text wird dann hier in den Editor eingefügt.


Linksbündig

Richtet den markierten Text linksbündig aus.


Zentriert

Zentriert den markierten Text.


Rechtsbündig

Richtet den markierten Text rechtsbündig aus.


Aufzählung

Fügt den markierten Absätzen Aufzählungszeichen hinzu.


Aufgabe bearbeiten

Eigenschaften der markierte Tätigkeit ändern.


helpcontext-7003

Suchen (in der Aufgabenverwaltung)

Fragt die Daten des Terminplaners neu aus der Datenbank ab und öffnet das Erinnerungsfenster erneut, falls dieses geschlossen wurde. Nutzen Sie dies im Netzwerkbetrieb bitte regelmäßig, um die Änderungen anderer Anwendenden zu sehen.


helpcontext-7004

Felder leeren (in der Aufgabenverwaltung)

Springt zum heutigen Datum und schaltet zur Monatsansicht.


helpcontext-7005

Terminplaner

Das Haupt-Steuerelement der Aufgabenverwaltung.

Die verschiedenen Ansichten, wie Tages- oder Monatskalender, werden im Menü Aufgabe | Anordnen gewählt. Den Bereich können Sie auch mit der Zeitleiste und dem Datumsnavigator einstellen.

Doppelklick öffnet eine Aufgabe zur Ansicht und Bearbeitung.

Drag&Drop: Aufgaben können beispielsweise auch mit der Maus in andere Tage verschoben werden.


Dokument markieren

Suchen | Dokumente

Sucht die mit der Aufgabe oder dem Kontakt verknüpften Dokumente. Die Ansicht wechselt automatisch zur Dokumententabelle.


Nur aktive Aufgaben

Bereits erledigte Aufgaben werden nicht gezeigt, wenn dieses Optionsfeld markiert ist.


helpcontext-7010

Suchen | Kontakte

Sucht die mit dem Dokument bzw. der Aufgabe verknüpften Kontakt. Die Ansicht wechselt automatisch zur Kontakttabelle.


Aufgabeliste

Die Tabelle enthält eine Liste der geplanten Tätigkeiten für dieses Dokument bzw. diesen Kontakt.


helpcontext-7021

Menü Aufgabe | Navigieren

Heute springt im Kalender zum heutigen Tag.

Datum: Dialogauswahl zur Anordnung und Markierung eines Datums.

Nächste 7 Tage springt zum heutigen Tag und ordnet die nächsten sieben Tage in einer Wochenansicht an.


helpcontext-7022

Menü Aufgabe | Anordnen

Tag stellt einen einzelnen Tag im Terminplaner dar.

Mo.-Fr. stellt eine Arbeitswoche ohne Samstag und Sonntag dar..

Woche: Gesamte Woche mit Samstag und Sonntag.

Monat: Ansicht eines Monats.

Zeitleiste ordnet die Aufgaben entlang einer Zeitskala von links nach rechts chronologisch an.

Jahr: Kalenderansicht über ein komplettes Jahr.

Balken zeigt die Aufgaben als horizontale Balken entlang der Zeitachse an.

Agenda zeigt die Aufgaben untereinander in einer tabellarischen Ansicht.


helpcontext-7023

Menü Aufgabe | Ansicht | Anpassen

Zeitskalierung setzt die Größe der Zeitauswahlleiste auf die angegebenen Minutenblöcke.

Datumsnavigator legt fest, ob und wo der kleine Monatskalender dargestellt wird.

Wochenende komprimieren: Samstag und Sonntag teilen sich in der Wochenansicht eine Tageszelle.

Arbeitsstunden schaltet in der Zeitleiste die Sichtbarkeit von Nicht-Arbeitszeiten um (s. a. Programmeinstellungen | Terminplaner).

An Zeitschlitzen fangen verbindet Benutzeraufgaben visuell mit den Zeitblöcken im Planungsbereich.


helpcontext-7024

Menü Aufgabe | Ansicht | Ressourcen

Ressourcen: Aufgaben können verschiedenen Ressourcen, beispielsweise Mitarbeitenden, Teams und Abteilungen zugewiesen sein. Mit Klick auf den oberen Bereich des Mausschalters im Menü öffnen Sie das Dialogfenster zum Ein- oder Ausblenden von Aufgaben dieser Ressourcen.
Auch beim Datumsnavigator finden Sie ein Eingabefeld mit den gewählten Ressourcen und einem Mausschalter zum Öffnen des Dialogs.

Aufgaben filtern:
Markieren Sie die Mitarbeitenden, dessen Aufgaben im Kalender sichtbar sein sollen. Wenn keine Ressource markiert ist, dann werden alle Aufgaben eingeblendet.

Ressourcen | Gruppierung zurücksetzen stellt die Aufgaben aller Ressourcen in einer gemeinsamen Ansicht dar.

Ressourcen | Nach Datum gruppieren: Eigener Terminplaner für jeder gewählte Ressource mit Gruppierung nach Datum.

Ressourcen | Nach Ressource gruppieren: Eigener Terminplaner für jeder gewählte Ressource mit Gruppierung nach Ressourcen.


helpcontext-7025

Datumsnavigator

Markieren Sie einen oder mehrere Tage, um den Terminplaner auf den gewünschten Zeitabschnitt einzustellen.

Der Navigator kann mit Aufgabe | Ansicht | Anpassen | Datumsnavigator positioniert werden.


helpcontext-7026

Zeitauswahlleiste

Auswahl des im Terminplaner gezeigten Zeitintervalls. Sie können den Bereich mit der Maus verschieben und in der Breite ändern.


Datenbankfelder

Liste der Datenbankfelder. Die in Klammern geschriebenen Felder (z. B. "[DocID]") werden vom Programm benötigt und können nicht gelöscht oder umbenannt werden. Sie können aber die im Programm sichtbare Beschreibung und die Feldgröße anpassen.

Zum Suchen nach Feldern klicken Sie bitte auf die Lupe oberhalb der Liste.


Suchen

Feld suchen

Klicken Sie bitte auf diesen Mausschalter und geben Sie einen Teil des Feldnamen oder der Bezeichnung ein, um ein Datenfeld zu finden.

Oder: Klicken Sie auf die Feldliste und geben Sie die ersten Buchstaben des Feldnamen ein. Es wird zum passenden Feld gesprungen.


Neu

Klicken Sie auf den Schalter Neu, um ein neues Datenbankfeld zu erstellen. Geben Sie anschließend die Daten ein und speichern Sie das Feld mit einem Klick auf Übernehmen.

Klicken Sie bitte auf den Pfeil, um eine Liste mit vordefinierten Felder zu öffnen.


Löschen

Klicken Sie auf den Schalter Löschen, um das markierte Datenbankfeld endgültig zu entfernen. Alle Daten in diesem Feld gehen verloren!

In SQLite-Datenbanken können keine Felder gelöscht oder umbenannt werden.


Übernehmen

Klicken Sie auf den Schalter Übernehmen, um das neue Feld anzulegen oder die Änderungen am Feld zu speichern.


Abbrechen

Klicken Sie auf den Schalter Abbrechen, um die Änderungen zu verwerfen.


Datenbank-Login

Klicken Sie auf den Schalter DB-Login, wenn Sie sich mit dem Logindialog an der Datenbank anmelden möchten. Dies ist nur erforderlich, wenn die derzeitigen Datenbank-Benutzerrechte keine Änderungen an der Datenbank erlauben.

Der Befehl steht nur für SQL-Datenbanken zur Verfügung und wird bei Windows-Authentifizierung vom Datenbanksystem ignoriert.


Datentyp

Navigation: »Kein übergeordnetes Kapitel«

Datentyp

Menü Datei | Datenbank | Anpassen | Felder definieren

Wählen Sie den Datentyp des Feldes aus der Liste:

Zeichenkette: Einzeiliges, alphanumerisches Feld. Geben Sie die maximale Zeichenanzahl im Eingabefeld Feldgröße ein.

Mehrzeiliger Text: Langes, alphanumerisches Feld.

Ganzzahl: Eine Zahl zwischen -2147483648 und 2147483647, die möglichen Werte können aber je nach Datenbanksystem abweichen.

Fließkommazahl: Eine Fließkommazahl mit 15 signifikanten Stellen, die Genauigkeit können aber je nach Datenbanksystem abweichen.

Logisch (Ja, Nein): Wahr oder Falsch, bzw. Ja oder Nein. Logische Datentypen werden intern als Feld vom Typ Zeichenkette mit einer Länge 1 und dem Eingabestil Optionsfeld gespeichert. Der Wert "T" entspricht Wahr und "F" Falsch.

Grafik: Spezielles Binärfeld für Grafikdaten. Im Eigenschaftendialog öffnen Sie bitte das lokale Menü mit Rechtsklick auf das Grafikfeld, um Bilder einzufügen oder aus einer Datei zu laden.

Datum und Zeit: Datum und Zeit (Timestamp)

Beim Ändern des Datentyps eines bestehenden Feldes erlaubt das System nur kompatible Datentypen.


Feldgröße

Geben Sie die maximale Zeichenanzahl für den Datentyp Zeichenkette ein. Mögliche Werte liegen zwischen 2 und 254.

Unnötig große Felder gehen zu Lasten der Performance.

Das System verweigert eine Kürzung des Datenfeldes, wenn dies zu einem Datenverlust führen würde.


Interner Name

Geben Sie den Namen des Datenbankfeldes ein. Erlaubt sind nur Buchstaben, Zahlen und der Unterstrich "_", verwenden Sie keine Umlaute (ä, ö, ü). Feldnamen dürfen nicht mit "OM" beginnen oder den reservierten SQL-Begriffen entsprechen.

Beachten Sie beim Ändern des Namen eines bestehenden Feldes, dass dieser Name z. B. von der Makroverarbeitung, den Layouts und der Schriftkopferzeugung verwendet wird.

Dieser interne Name ist für den Anwender nicht sichtbar. Die sichtbare Bezeichnung können Sie auf der Seite Ansicht im Eingabefeld Beschreibung ändern.


Kommentar

Sie können hier beliebige Hinweise und Kommentare eingeben oder das Feld beispielsweise als Zwischenablage für den Test von Makrovariablen nutzen. Programmintern werden diese Daten nicht verwendet.


Geschützte Felder

Bei geschützten Datenfelder (Namen in eckigen Klammern) können Sie nur die Feldgröße ändern.


helpcontext-8106

Änderungen protokollieren

Verfügbar in diesen Editionen

Änderungen an den Attributen (Inhalt der Datenfelder) werden im Protokoll erfasst und sind somit nachvollziehbar.


helpcontext-8107

Schreibweise

Texte unverändert oder in Groß- bzw. Kleinschreibung in die Datenbank speichern.


Bezeichnung

Geben Sie die Bezeichnung des Datenbankfeldes ein. Diese Bezeichnung ist für den Anwender in den Programm-Layouts und der Dokumententabelle sichtbar.

Bezeichnungen wie z. B. "{resstr:rsdfcName}" sind Variablen, die in der Mehrsprachversion das dynamische Umschalten zwischen den Sprachen ermöglichen.


Globale Liste für alle Datenbanken

Wenn Globale Liste für alle Datenbanken markiert ist, greifen alle Dokumentenarchive und Kontaktdatenbanken auf dieselbe Auswahlliste zu. Neue Einträge (z. B. Projekte) stehen dann in allen Datenbanken zur Verfügung, in denen dieses Datenfeld mit globaler Liste definiert ist.

Ist die Option nicht markiert, dann verwendet diese Datenbank seine eigene Liste.

Globale Listen werden als itm-Dateien, private Listen in der Datenbank gespeichert.


Liste automatisch erweitern

Wenn diese Option markiert ist, wird die Auswahlliste automatisch um neue Einträge erweitert.


Eingabe erforderlich

Eingabe erforderlich (Pflichtfeld)
Menü Datei | Datenbank | Anpassen | Felder definieren

Mit den Pflichtfeldern wird festgelegt, welche Daten für ein Dokument zwingend erforderlich sind. Ein Dokument kann nur angelegt werden, wenn alle als Pflichtfeld definierte Daten eingegeben wurden. Markieren Sie diese Option beispielsweise beim Feld "Name", um zu verhindern, dass ein Dokument ohne Namen angelegt wird.


Erweiterter Stil

Zusätzliche Stil-Eigenschaft je nach Datentyp.

Währung

Beispielweise können Fließkommazahlen als Währung dargestellt werden: "1.234,50 €" statt "1234,5". Hierfür wird die im Windows-System hinterlegt Währungseinstellung verwendet.


Eingabestile für Zeichenkette

Wählen Sie den gewünschten Eingabestil für das Datenfeld aus. Für den Datentyp Zeichenkette stehen folgende Eingabestile zur Auswahl:

Eingabefeld: Die Daten werden frei eingegeben.

Eingabefeld mit Liste: Die Daten können aus einer Auswahlliste gewählt und frei eingegeben werden.

Nur Auswahl aus Liste: Die Daten können nur aus einer Auswahlliste gewählt werden, eine freie Eingabe ist nicht möglich. Verwenden Sie diesen Stil, wenn Sie Schreibfehler verhindern möchten, z. B. für das Feld Projekt.

Eingabefeld mit strukturierter Liste: Die Daten können aus einer strukturierten Auswahlliste gewählt und frei eingegeben werden. Die Einträge der Liste können untergliedert werden (Baumdarstellung).

Nur Auswahl aus strukturierter Liste: Die Daten können nur aus einer strukturierten Liste gewählt werden, eine freie Eingabe ist nicht möglich.

Mehrzeiliges Eingabefeld für mehrzeiligen Text, wie z. B. die Notizen.

Dateiliste oder Makro: Die Daten können nur aus der Liste gewählt werden. Welche Dateien die Liste enthält, legen Sie im Feld Format fest.

Outlook-Kontaktliste: Liest die Adressdatenbank von Microsoft Outlook ein und ermöglicht ein einfache Zuordnung der Dokumente zu Ihren Kontakten.

Kontaktliste: Integrierte CRM-Datenbank für Datenfeld "contactguid".

Besondere Datenfelder bieten zusätzlich den Eintrag Optionsfeld an (ein Kontrollfeld, dass nur markiert oder nicht markiert sein kann). Beispiel username: wenn der Stil Optionsfeld gewählt wurde, können Sie Ihre eigenen Dokumente suchen, indem Sie das Optionsfeld Private Suche markieren.


Eingabestile für Text

Wählen Sie den gewünschten Eingabestil für das Datenfeld aus. Für den lange Textfelder steht nur ein Eingabestil zur Auswahl:

Mehrzeiliges Eingabefeld für mehrzeiligen Text, wie z. B. die Notizen.


Eingabestile für Zahlen

Wählen Sie den gewünschten Eingabestil für das Datenfeld aus. Für die Datentypen Ganzzahl und Fließkommazahl stehen folgende Eingabestile zur Auswahl:

Eingabefeld: Die Daten werden frei eingegeben.

Eingabefeld mit Liste: Die Daten können aus einer Auswahlliste gewählt und frei eingegeben werden.

Nur Auswahl aus Liste: Die Daten können nur aus einer Auswahlliste gewählt werden, eine freie Eingabe ist nicht möglich. Verwenden Sie diesen Stil, wenn Sie Schreibfehler verhindern möchten, z. B. für das Feld Projekt.

Eingabefeld mit strukturierter Liste: Die Daten können aus einer strukturierten Auswahlliste gewählt und frei eingegeben werden. Die Einträge der Liste können untergliedert werden (Baumdarstellung).

Nur Auswahl aus strukturierter Liste: Die Daten können nur aus einer strukturierten Liste gewählt werden, eine freie Eingabe ist nicht möglich.


Eingabestile für logische Felder

Für den Datentyp Logisch (Boolean) steht nur der Eingabestil Optionsfeld zur Verfügung. Dies ist ein Kontrollfeld, dass nur markiert oder nicht markiert sein kann.


Eingabestile für binäre Felder

Wählen Sie den gewünschten Eingabestil für das Datenfeld aus. Für binäre Felder stehen folgende Eingabestile zur Auswahl:

Mehrzeiliges Eingabefeld für mehrzeiligen Text, wie z. B. die Notizen.

Grafik: Feld mit Grafikdaten. Im Eigenschaftendialog öffnen Sie bitte das lokale Menü mit Rechtsklick auf das Grafikfeld, um Bilder einzufügen oder aus einer Datei zu laden.


Eingabestile für Datum/Zeit

Wählen Sie den gewünschten Eingabestil für das Datenfeld aus. Für den Datentyp Datum/Zeit stehen folgende Eingabestile zur Auswahl:

Datum: Eingabefeld und Auswahldialog für ein Datum

Zeit: Eingabefeld für Uhrzeit.

Datum und Zeit: Die Daten werden frei eingegeben.


Vorgabe für neue Dokumente

Dieser Vorgabewert wird für neue Dokumente verwendet, wenn der Anwender das Feld leer gelassen hat. Beachten Sie, dass dies ebenfalls nur dann ausgewertet wird, wenn Vorgabewert für neue und vorhandene Datensätze leer ist.

Falls Sie verhindern möchten, dass der Anwender einen Wert eingibt, können Sie die Eingabe sperren (s. Seite Sicherheit, Berechtigung zum Ändern). In dem Falls wird immer der Vorgabewert verwendet.

Sie können Makrovariablen als Vorgabewert verwenden. Die Variablen werden erst ausgewertet, wenn der Dokumentdatensatz gespeichert wird.


Vorgabe für bestehende Dokumente

Dieser Vorgabewert wird für neue und bereits vorhandene Dokumente verwendet, sobald der Datensatz gespeichert wird. Der Vorgabewert wird somit erzwungen, Eingaben des Anwenders überschrieben!

Sie können Makrovariablen als Vorgabewert verwenden. Die Variablen werden beim Speichern des Datensatzes ausgewertet.


Sichtbarkeit ändern

Klicken Sie bitte auf die Schaltfläche [Ändern], um festzulegen, für welche Anwender dieses Datenfeld sichtbar ist. Für unberechtigte Anwender wird das Feld verborgen, sie können es weder sehen noch bearbeiten.

Die Sicherheitseinstellungen können mit Strg-C kopiert und mit Strg-V eingefügt werden.


Schreibrechte ändern

Klicken Sie bitte auf die Schaltfläche [Ändern], um festzulegen, welche Anwender dieses Datenfeld bearbeiten dürfen. Unberechtigte Anwender können die Felder sehen, aber nicht ändern (readonly).

Die Sicherheitseinstellungen können mit Strg+C kopiert und mit Strg+V eingefügt werden.


Schreibschutz

Gibt an, ob diese Datei schreibgeschützt ist. Solange die Option markiert ist, kann die Dokumentdatei nicht geändert werden.

Im GoBD-Modus kann ein gesetzter Schreibschutz nicht mehr aufgehoben werden.


Dokumententyp

Der Dokumenttyp legt das Anwendungsprogramm fest, mit dem die Dokumente bearbeitet werden. Wählen Sie bitte die Anwendung für dieses Dokument aus der Liste.

Die Liste ist eventuell gefiltert und zeigt nur die geeigneten Dokumententypen zur Auswahl.

Klicken Sie mit der rechten Maustaste auf das Kombinationsfeld, wenn Sie aus allen Dokumententypen wählen möchten.
Im Menü Datei | Optionen | Dokumenttyp werden die Anwendungen registriert.


Datei-Eigenschaften

Öffnet den Windows-Dialog Datei-Eigenschaften. Dieser Befehl ist nur aktiviert, wenn die angegebene Datei vorhanden ist. Diese Funktion ist in GoBD-Archiven gesperrt.


SQL-Abfrage erzeugen

Klicken Sie auf SQL-Abfrage, um Ihre Eingaben in eine SQL-Abfrage umzuwandeln. Sie können den erzeugten SQL-Code dann weiter bearbeiten.


Grafikformat

Legt fest, in welchem Grafikformat das gescannte Dokument gespeichert wird.


Rücksetzen

Klicken Sie auf Löschen, um die Inhalte aller Eingabefelder zu leeren.


Bildquelle

Wählen Sie bitte die Bildquelle: Twain- oder WIA kompatible Scanner, Digitalkamera oder Ricoh ScanSnap.

Ist Ihr Scanner nicht enthalten?

Beachten Sie bei TWAIN-Treibern bitte, dass diese zur Bit-Ausgabe von Office Manager DMS passen müssen: Für einen 32 Bit Office Manager benötigen Sie einen 32 Bit-Treiber, für einen 64 Bit Office Manager einen 64 Bit-Treiber. Diese Regel gilt auch für andere Windows-Programme.

Installieren Sie bitte einen entsprechenden Treiber oder den Office Manager passend zum Treiber. Sie können auch beide Office Manager-Ausgaben parallel installieren.


Menü öffnen

Öffnet das lokale Menü:

Scanner-Information: zeigt Eigenschaften der gewählten Bildquelle

Liste aktualisieren: lädt die Liste der verfügbaren Scanner neu ein


Benutzeroberfläche

Wenn die Option markiert ist, wird zum Scannen die Benutzeroberfläche der Quelle geöffnet. Dies ist sinnvoll, wenn Sie geräteabhängige Einstellungen vorgeben möchten.


Auflösung

Gibt die Auflösung in Punkten pro Zoll an, wenn diese Einstellung von der Bildquelle unterstützt wird. Große Werte verbessern die Bildqualität, benötigen aber mehr Speicherplatz. Für Dokumente ist ein Wert von ca. 150 dpi empfehlenswert.


Farbmodus

Gibt den Farbmodus an, wenn diese Einstellung von der Bildquelle unterstützt wird.

Beispielsweise Schwarz/Weiß, Graustufen oder Farbe.


Einzelblatteinzug

Aktiviert, sofern vorhanden, den automatischen Dokumenteneinzug (ADF) des Scanners.


Automatisch einziehen

Alle Dokumente im Dokumenteneinzug (ADF) werden automatisch eingezogen, bis der ADF leer ist.


Seitenformat

Legt die Größe des Scanbereichs und das Seitenformat der PDF-Datei fest.

Siehe auch: Datei | Optionen | Einstellungen, Seite Papierformate.


Scannen

Klicken Sie bitte auf Scannen oder drücken Sie die Taste F6, um den Scan zu starten bzw. das Bild von der Quelle zu importieren.


Stapelscan

Klicken Sie bitte auf Stapelscan, um das Fenster für produktives Scannen zu öffnen.


OCR ausführen

Wenn diese Option markiert ist, wird der enthaltene Text mit einer OCR-Software erkannt. Die Texterkennung wird gestartet, sobald Sie das Dokument mit Klick auf OK übernehmen.

Siehe auch Menü Datei | Optionen | Einstellungen, Seite Volltextindex | OCR


Geraderücken

Rückt schief eingezogene Seiten gerade. Verwenden Sie diese Option nur für gescannte Seiten mit Text.

Schnell

Wertet nur einen Teil des Dokumentenabbildes aus und arbeitet mit einem schnell Algorithmus.

Sie sollten diese Option bevorzugt verwenden und nur bei falschen Ergebnissen deaktivieren: zum Beispiel bei Dokumenten, die im oberen Seitenbereich eine Grafik oder eine farbige Fläche haben.


Sceye JPeg-Qualität

JPeg-Qualität

Qualität der farbigen Grafiken: 100% gibt die beste Qualität, 10% die höchste Komprimierung an. Hohe Werte erfordern mehr Speicherplatz.


Sceye Filter

Optimierung des Scanergebnisses

Textfilter: starke Hervorhebung von Kanten und Farbübergängen für dedizierte OCR-Optimierung, Grafiken werden zerstört.

Kontrastanhebung: Hervorhebung von Kanten und Farbübergängen für OCR unter Beibehaltung von Grafiken.

Weichzeichner: harte Kontrastübergänge werden angeglichen.

Beachten Sie aber auch Vorschriften der GoBD zur Archivierung steuerlich relevanter Daten. Scannen Sie ohne Optimierung, wenn eine derartige Datenaufbereitung unzulässig ist.


Sceye Weißabgleich

Dynamischer Weißabgleich

Korrigiert verfälschende Kunstlichteinwirkungen und erweitert den Kontrast des Bildes. Diese Option ist für alle Vorlagen geeignet, die weiße Bereiche enthalten


Sceye Status

Die Abbildung zeigt den Status der Sceye-Dokumentenkamera: geschlossen, geöffnet oder geöffnet mit aktiviertem Laser.


Sceye-Livebild

Zeigt eine stark verkleinerte Ansicht des Erfassungsbereichs als Livebild in niedriger Qualität.


Scanergebnis

Zeigt die Vorschau der eingelesenen Bilder.


Bildlaufleiste

Mit dieser Bildlaufleiste können Sie zwischen den gescannten Bildern blättern.


Links drehen

Dreht das aktuelle Bild um 90° gegen den Uhrzeigersinn.


Rechts drehen

Dreht das aktuelle Bild um 90° im den Uhrzeigersinn.


Drehen

Dreht das aktuelle Bild um einen beliebigen Winkel. Geben Sie bitte einen Drehwinkel größer 0 ein, um im Uhrzeigersinn, oder einen Winkel kleiner 0 ein, um gegen den Uhrzeigersinn zu drehen.


Grafikdatei importieren

Importiert eine Grafik aus einer Datei.


Grafik einfügen

Importiert eine Grafik aus der Zwischenablage.

Sie können auch die Zwischenablage überwachen und neue Bilder automatisch übernehmen. Aktivieren Sie dazu die Schaltfläche "Clipboard mit Pluszeichen".


Grafik löschen

Löscht die aktuelle Grafik.


Einfügeposition

Legt fest, ob der neue Stapel vor der aktuellen Grafik, nach der aktuellen Grafik oder am Ende hinzugefügt werden. Sie können auch die aktuelle Grafik durch einen neuen Scan ersetzen.

Die Option wird bei jedem Öffnen des Scandialoges auf "Als letzte Grafik anhängen" zurückgesetzt.


OCR-Test

Startet die OCR-Software und zeigt Ihnen, welcher Text von der aktuellen Grafik gelesen wurde. Diese Funktion dient nur Testzwecken.


Grafik kopieren

Kopiert die aktuelle Grafik in die Zwischenablage.


Grafik bearbeiten

Öffnet die aktuelle Grafik zur Bearbeitung in einem externen Programm.

Führen Sie die gewünschten Änderung bitte im gestarteten Grafikprogramm durch und speichern Sie die Änderungen. Wenn Sie zum Office Manager zurückkehren, wird die Änderung nach Rückfrage übernommen.


Speicher-Transfer

Der Speicher-Transfer vermeidet Pausen zwischen den einzelnen Seiten beim Stapelscan. Einige Scanner unterstützen diese Option aber nicht. Prüfen Sie bitte das Scanergebnis, wenn Sie diese Option aktivieren.


Sceye Laser

Schaltet den Laser der Dokumentenkamera ein oder aus.


Sceye LED

Schaltet die LED-Beleuchtung der Kamera ein oder aus.


Sceye Laser LED auto off

Schaltet den Laser und die LED automatisch aus, sobald das Scan-Fenster geschossen wird.

Aktivieren Sie diese Option, wenn Sie nur gelegentlich scannen.

Falls Sie viel scannen - dieses Dialogfenster also in kurzen Abständen immer wieder öffnen, dann sollten Sie die Option deaktivieren. Dies vermeidet ein häufiges Schalten der Beleuchtungselemente.


Scanintervall

Zeitspanne für das Wechseln der Papiervorlage. Verwenden Sie für erste Versuche 4-6 Sekunden.


Signalton

Das Erfassen der Vorlage wird mit einem kurzen Ton signalisiert. Diese Option ist vor allem bei ersten Versuchen sinnvoll.


Scannen

Klicken Sie auf diesen Schalten, um mit der Vorlagenerfassung zu beginnen. Ein erneutes Anklicken beendet den Scanvorgang.


Nächste Seite

Zur nächsten Seite des Assistenten.


Vorherige Seite

Zur vorherigen Seite des Assistenten.


Fertigstellen

Klicken Sie auf Fertigstellen, um die Einrichtung des Office Managers abzuschließen.


Automatische Hilfe

Aktiviert die Online-Hilfe für den Einrichtungs-Assistenten. Zu jedem Arbeitsschritt wird die jeweilige Hilfe automatisch geöffnet.


Registrierung

Eingabe der Seriennummer für die Vollversion und Möglichkeit der Online-Registrierung.

Wenn diese Option nicht markiert ist, wird die entsprechende Seite im Assistenten übersprungen.


Verzeichnisstruktur

Festlegen der Verzeichnisstruktur und automatische Erzeugung von Dateinamen.

Wenn diese Option nicht markiert ist, wird die entsprechende Seite im Assistenten übersprungen.


Anwendungsprogramme

Registrierung der Anwendungsprogramme, die mit dem Office Manager zusammenarbeiten sollen.

Wenn diese Option nicht markiert ist, wird die entsprechende Seite im Assistenten übersprungen.


Netzwerkzugriffe

Einstellungen für die Netzwerkzugriffe und Systemoptimierung.

Wenn diese Option nicht markiert ist, wird die entsprechende Seite im Assistenten übersprungen.


Administrator

Administrator-Grundeinstellungen

Wenn diese Option nicht markiert ist, wird die entsprechende Seite im Assistenten übersprungen.


Verknüpfungen

Registrierung des Office Managers in der Windowsumgebung.

Wenn diese Option nicht markiert ist, wird die entsprechende Seite im Assistenten übersprungen.


Weiter

Geben Sie den Freischaltcode ein und klicken Sie auf Weiter. Der Office Manager arbeitet nun im neuen Betriebsmodus (registrierte Testversion oder Vollversion).


Registrieren

Klicken Sie auf Registrieren, um die Testversion zu registrieren oder eine Vollversion zu bestellen.


Anwendungsprogramme

Liste der Anwendungsprogramme aus der Windows-Registrierdatenbank. Markieren Sie die Anwendungen, mit denen der Office Manager zusammenarbeiten soll.

Wenn Sie die Einstellungen der Anwendungsprogramme ändern möchten, wählen Sie bitte im Menü Datei | Optionen den Eintrag Dokumenttyp.


Internet-Browser

Markieren Sie diese Option, um sicherzustellen, dass ein Dokumenttyp für die Verwaltung von Internetadressen eingerichtet wird.

Die Option ist nur wählbar, wenn noch kein entsprechender Dokumenttyp registriert wurde.


E-Mail

Markieren Sie diese Option, um sicherzustellen, dass ein Dokumenttyp für die Verwaltung von E-Mails eingerichtet wird.

Sie können dann Ihre Mails beispielsweise per Drag&Drop in den Office Manager importieren und komfortabel verwalten.

Die Option ist nur wählbar, wenn noch kein entsprechender Dokumenttyp registriert wurde.


Notiz

Markieren Sie diese Option, um einen Dokumententyp für Notizen zu erstellen.

Notizen werden mit der integrierten Textverarbeitung erstellt und ohne externe Datei in der Archivdatenbank gespeichert.

Die Option ist nur wählbar, wenn noch kein entsprechender Dokumententyp registriert wurde.


Tabelle

Klicken Sie auf die Schaltfläche Tabelle, um ein Menü mit weiteren Funktionen zu öffnen:

Eigenschaften: Informationen der Anwendung aus der Registrierdatenbank anzeigen

Datei-Eigenschaften der Programmdatei anzeigen

Symbole anzeigen: Icons der Anwendungen darstellen oder ausblenden

Nur Standardanwendungen: Alle Anwendungen oder nur die Standardanwendungen zeigen

Alles markieren: Alle Anwendungen markieren

Markierung aufnehmen: Keine Anwendung markieren


Ricoh ScanSnap

Die Abbildung zeigt den PDF-Scanner "Ricoh ScanSnap".


Ricoh ScanSnap

Richtet die Schnittstelle zum PDF-Scanner "ScanSnap" von Ricoh oder Fujitsu automatisch ein und legt einige Scanprofile an. Die Scanner-Software muss bereits auf diesem Computer installiert sein.


Einzelarbeitsplatz

Klicken Sie auf Einzelarbeitsplatz, um die Datenbankoptionen für einen nicht vernetzten Arbeitsplatz voreinzustellen.

·Dokument-Bearbeitung protokollieren wird deaktiviert

·Anzeige der Dokumentanzahl wird aktiviert

·Beim Start alle Datensätze abrufen wird aktiviert

·Programmsymbole darstellen wird aktiviert

Diese Voreinstellungen beruhen auf allgemeinen Erfahrungswerten. Die einzelnen Optionen können Sie Ihren individuellen Vorstellungen anpassen.


Kleines Netzwerk

Klicken Sie auf Kleines Netzwerk, um die Datenbankoptionen für Netzwerke bis ca. 5 Arbeitsplätze voreinzustellen.

·Dokument-Bearbeitung protokollieren wird deaktiviert

·Anzeige der Dokumentanzahl wird aktiviert

·Beim Start alle Datensätze abrufen wird deaktiviert

·Programmsymbole darstellen wird aktiviert

Diese Voreinstellungen beruhen auf allgemeinen Erfahrungswerten. Die einzelnen Optionen können Sie Ihren individuellen Vorstellungen anpassen.


Großes Netzwerk

Klicken Sie auf Großes Netzwerk, um die Datenbankoptionen für Netzwerke mit mehr als fünf Arbeitsplätzen und hohen Dokumentvorkommen voreinzustellen.

·Dokument-Bearbeitung protokollieren wird deaktiviert

·Anzeige der Dokumentanzahl wird deaktiviert

·Beim Start alle Datensätze abrufen wird deaktiviert

·Programmsymbole darstellen wird aktiviert

Diese Voreinstellungen beruhen auf allgemeinen Erfahrungswerten. Die einzelnen Optionen können Sie Ihren individuellen Vorstellungen anpassen.


Benutzer

Markieren Sie die Option Nur Benutzer mit Windowsanmeldung zulassen, um sicherzustellen, dass sich die Anwender ordnungsgemäß anmelden. Wenn die Option Alle Benutzer zulassen markiert ist, werden auch Anwender akzeptiert, die sich am Betriebssystem nicht angemeldet haben.


Dateitypen verknüpfen

Wenn die Option Dateitypen mit Office Manager verknüpfen markiert ist, werden alle Dateien mit der Endung .omp, .omsl,.omen und .omcs mit dem Office Manager verknüpft. Sie können dann Archiv-Datenbank mit einem Doppelklick im Explorer öffnen.


Automatisch ausführen

Bei aktiviertem Autostart wird Office Manager nach dem Hochfahren von Windows automatisch ausgeführt


Datenbanktyp

Dokumentenarchiv: erstellt ein neues Archiv. Die Einstellungen und Datenfelder des geöffneten Archivs werden übernommen.

Synchrones Dokumentarchiv: erstellt eine synchrone Datenbank mit den Dokumenten der aktuellen Suche. Mit diesem Typ können Sie z. B. ausgewählte Dokumente auf ein Notebook auslagern und später wieder mit dem Netzwerk synchronisieren.

Archiv zur Prüfungsvorlage für einen Steuer- oder Wirtschaftsprüfer nur mit den relevanten Daten des Prüfungszeitraumes erstellen. Diese Option ist nur in GoBD-Archiven möglich.

Anwendungsdatenbank: erstellt eine neue Anwendungsdatenbank.

Kontaktdatenbank: erstellt eine neue CRM-Datenbank.


Datenbanktreiber

Navigation: »Kein übergeordnetes Kapitel«

Datenbanktreiber

Format der Datenbank wählen
Menü Datei | Neues Archiv

Office Manager kann die Archive in verschiedenen Datenbankformaten speichern. Wählen Sie bitte den gewünschten Treiber aus.

Pro- und Enterprise-Editionen

SQLite ist ein modernes und stark verbreitetes Datenbankformat mit leistungsfähiger Volltextsuche. Es sind keine externen Treiber erforderlich. SQLite ist für den Einzelbenutzerbetrieb optimiert, die Performance nimmt spürbar ab, wenn mehrere Benutzer auf die Daten zugreifen. Datenbanken können lokal oder im Netzwerk gespeichert werden.
In der 32 Bit-Version kann ein SQLite-Archiv mit einem Passwort verschlüsselt werden.

Microsoft Access ist auch für die gleichzeitige Verwendung durch wenige Benutzer im Netzwerk geeignet. Beachten Sie bitte die Hinweise zum Access-Datenbanktreiber.

Firebird Server erfordert die Installation einer Datenbank-Software auf dem Server. Firebird ist das empfohlene Format, wenn mehrere Benutzer gleichzeitig mit der Pro-Edition arbeiten.

SQL-Server nur in Enterprise-Edition

Microsoft SQL Server: Leistungsstarker SQL-Datenbankserver für umfangreiche Archive und den gleichzeitigen Zugriff vieler Anwender. Sie können zwischen der Standard-Volltextsuche und der erweiterten Server-gestützten Suche wählen. Alle erforderlichen Treiber sind unter Windows standardmäßig installiert.

MySQL oder MariaDB: Office Manager beinhaltet einen nativen Treiber für MySQL und kompatible SQL-Server, wie MariaDB. Es müssen aber Bibliotheken (LIBMYSQL.DLL oder LIBMYSQLD.DLL) auf dem PC vorhanden sein.

Hinweise und Kurzanleitungen für die verschiedenen SQL-Server finden Sie unter: https://www.officemanager.de/support/sql/

Beachten Sie auch den Blogartikel zu den Vor- und Nachteilen der Datenbankformate.


Server

Server (Menü Datei | Neues Archiv)

Name oder IP des SQL-Datenbankservers. Wenn eine benannte Instanz verwendet wird, dann geben Sie diese bitte mit Backslash vom Servernamen getrennt an "Servername\Instanzname".

Bei MS SQL können Sie auch auf den Pfeil des Kombinationsfeldes klicken, um alle sichtbaren Serverinstanzen anzuzeigen. Beim ersten Öffnen sehen Sie die Information "<dicovering...>, es wird jetzt nach Servern gesucht. Die Liste wird nach einiger Zeit aktualisiert, sofern die Server abgefragt werden können.


Datenbank

Datenbank (Menü Datei | Neues Archiv)

Name der Datenbank auf dem SQL-Server. Wenn die Datenbank noch nicht vorhanden ist, dann wird diese mit Abschluss des Assistenten erstellt. Alternativ können Sie auch zuvor eine leere Datenbank erstellen.

Bei Firebird müssen Sie den Datenbank-Dateinamen mit vollständigem Pfad aus Sicht des Servers angeben.


DB-Logindaten

Anmeldedaten für SQL-Server (Menü Datei | Neues Archiv)

Integrierte Sicherheit verwenden: Markieren Sie bevorzugt diese Option, um die Windows-Anmeldedaten des jeweiligen Benutzers auch für den SQL-Server zu verwenden.

Die folgenden Felder sind nur sichtbar, wenn keine integrierte Sicherheit verwendet wird:

Benutzer: Fester Benutzername mit dem sich alle Anwender anmelden.

Kennwort: Das Passwort zum Benutzer.


Verbindung testen

Verbindung testen (Menü Datei | Neues Archiv)

Testet die Verbindung zum angegebenen Server. Führen Sie den Test aus, wenn der Server angegeben ist, die Datenbank aber noch nicht.


Port

Port (Menü Datei | Neues Archiv)

Vom SQL-Server verwendeter Port. Standardwert für MySQL und MariaDB ist 3306 oder oft auch 3307, für Firebird 3050.


Datenbank-Login

Login beim Öffnen der Datenbank
(Menü Datei | Datenbank | Anpassen | Eigenschaften)

Wenn diese Option aktiviert ist, muss sich der Anwender beim Öffnen der Datenbank mit Benutzernamen und Passwort anmelden. Voraussetzung hierfür ist eine SQL Server-Authentifizierung. Wenn Sie MS SQL mit der Windows-Authentifizierung nutzen, werden diese Login-Daten ignoriert.

Für Anwendungsdatenbanken ist die Option i. d. R. nicht sinnvoll. Sie ist nur in der Enterprise-Version enthalten und kann nicht für den Standard-Treiber gewählt werden.


Datenbankdateiname

Geben Sie bitte die Dateinamen für die neue Datenbank ein und klicken Sie anschließend auf Weiter.

Archivname (nur Dokumentenarchiv) wird im Titel des Hauptfensters gezeigt.

Dateiname: Pfad und Name der Datenbankdatei.


Bezeichnung

Bezeichnung des Archivs

Geben Sie eine aussagekräftige Bezeichnung ein, wie z. B. "Zeichnungen", "Office-Dokumente" oder "Personaldaten".


Dateiname

Dateiname der neuen Datenbank.

Klicken Sie auf die Schaltfläche [Durchsuchen], um den Dateidialog zu öffnen.


Parameter bearbeiten

Datenbank-Parameter bearbeiten (nur Enterprise-Edition)

Markieren Sie diese Option, wenn Sie die erweiterten Einstellungen des Datenbanktreibers manuell bearbeiten möchten.


Parameter

Datenbank-Parameter (nur Enterprise-Edition)

Sie können die Datenbankverbindungsparameter überprüfen und bei Bedarf ändern. Die Parameter sind vom gewählten Treiber abhängig, Informationen finden Sie ggf. in der Dokumentation Ihres SQL-Servers. Zu den Parametern gehören z. B. der Datenbank-Dateiname, die Größe des Struktur-Cache, der Sprachtreiber, der Benutzername und das Kennwort.

Gehen Sie bei Änderungen der Verbindungsparameter sorgfältig vor!


Rückgängig

Klicken Sie auf den Schalter Rückgängig, um die Änderungen an den Datenbankparametern zu widerrufen. Wenn Sie die Parameter auf die Vorgaben zurücksetzen möchten, können Sie auch auf den Schalter Zurück und anschließend wieder auf Weiter klicken.


Datenbank erstellen

Datenbank erstellen (nur Enterprise-Edition)

Der Office Manager hat alle Informationen für die neue Datenbank erhalten. Sie müssen jetzt mit Hilfe Ihrer Datenbanksoftware eine leere Datenbank erstellen und die entsprechenden Benutzerkonten einrichten. Wenden Sie sich ggf. an Ihren Administrator..

Die Datenbanktabellen werden im nächsten Schritt vom Office Manager erstellt.


Fertigstellen

Klicken Sie auf Fertigstellen, um die neue Datenbank zu erzeugen. Der Office Manager erstellt die erforderlichen Tabellen und Daten. Wenn die Option Datensätze kopieren markiert ist, werden alle Daten aus der momentan geöffneten Datenbank kopiert.

Hinweis zur Enterprise-Version: Wenn Sie die Einstellungen einer Server-Datenbank später ändern möchten, wählen Sie bitte im Menü Datei | Datenbank | Anpassen | Eigenschaften.


Datensätze kopieren

Markieren Sie diese Option, wenn Sie die derzeit geöffnete Datenbank in die neu erstellte kopieren möchten.

Die neue Datenbank wird die derzeit geöffnete ersetzen

Alle Datenbanken sind mit einer eindeutigen Kennung (GUID) registriert. Diese ist insbesondere für die Zuordnungen der zentral verwalteten Tätigkeiten wichtig. Wenn diese Option markiert ist, übernimmt die neue Datenbank diese Kennung aus der alten. Die bereits vorhandenen Tätigkeiten der Aufgabenverwaltung beziehen sich dann auf die neue Archiv- oder Kontaktdatenbank.

Tipp: Wenn Sie die Daten auf ein neues Datenbankformat umstellen möchten, beispielsweise von SQLite oder Access auf einen professionellen SQL-Datenbankserver umsteigen, dann

·markieren Sie bitte beide Optionen und erstellen Sie die neue Datenbank.

·Passen Sie anschließend die Einstellungen an: Datei | Optionen | Einstellungen, Seite Datenbank.

·Beenden Sie das Programm.

·Verschieben Sie die alte Datenbank in ein Backupverzeichnis, damit die Anwender nicht mehr auf diese zugreifen.

·Starten Sie Office Manager DMS neu und öffnen Sie die neue Datenbank.


Datenbank-Login

Markieren Sie diese Option, wenn Sie sich zum Erstellen der Datenbank-Tabellen mit dem Logindialog anmelden möchten (nur Enterprise-Edition). Dies ist nur erforderlich, wenn die derzeitigen Datenbank-Benutzerrechte keine Änderungen an der Datenbankstruktur erlauben und nur möglich, wenn SQL-Server-Authentifizierung aktiviert ist.


Desktop-Verknüpfung

Legt eine Verknüpfung auf dem Desktop an, mit der das erstellte Prüfungsarchiv geöffnet werden kann.

Falls die Prüfung mit einem anderen Windows-Benutzer ausgeführt wird, kopieren Sie diese bitte noch auf den entsprechenden Desktop.


Automatisch

Im Darstellungsmodus Automatisch wird das Vorschaubild in Originalgröße dargestellt, wenn es komplett in das Vorschaufenster passt. Ist das Bild zu groß, wird es auf Fenstergröße verkleinert. Dieser Modus ist gut geeignet, um durch mehrere Dokumente zu blättern.


Mobile Server Zugriff zulassen

Zugriff von mobiler App zulassen

Markieren Sie diese Option und folgen Sie der Anleitung, um mit Ihrem Smartphone oder Tablet auf die Dokumentenarchive zugreifen zu können.


Login-Daten

Vergeben Sie bitte einen Benutzernamen und ein Passwort für die Kommunikation. Die gleichen Daten müssen auch in der mobilen App auf Seite Einstellungen hinterlegt werden.

Verwenden Sie ein sicheres Passwort - beispielsweise eine Kombination aus Buchstaben, Zahlen und Sonderzeichen.


Computer-Port

Menü Datei | Mobile Server

Geben Sie bitte einen freien Port an: beispielsweise 211 oder 8080. Der gleiche Wert wird auch in der mobilen App auf Seite Einstellungen hinterlegt und Ihr Router muss diesen Port an den PC weiterleiten.

Mit Klick auf den Mausschalter Testen können Sie prüfen, ob der Port frei ist.


Listeneinträge

Maximale Listeneinträge

Beim Öffnen der Rechercheseite in der mobilen App werden die Listeneinträge für Projekte und Kategorien übertragen. Bei tief strukturierten Projekten können sehr viele Einträge vorhanden sein. Dies würde die App verlangsamen und solch lange Listen sind auf dem kleinen Display wenig sinnvoll.

Mit dieser Einstellung wird die Anzahl der zu übertragenden Listeneinträge begrenzt. Geben Sie möglichst nicht mehr als 100 ein.


Einstellungen speichern

Klicken Sie auf diesen Schalter, wenn Sie alle Einstellungen vorgenommen haben. Sie benötigen Windows-Administrationsrechte.

Wenn der Zugriff zugelassen wird, installiert und startet Office Manager das Dienstprogramm "DMSService". Dieses ist für die Kommunikation mit dem Mobilgerät zuständig. Der Windows-Firewall wird eine eingehende Regel für das Dienstprogramm hinzugefügt.


Server verwalten

Wenn diese Schalfläche sichtbar ist, können Sie Ihren Computer nicht als mobilen Server einsetzen. In Ihrem Firmennetzwerk ist das optionale Serverprogramm lizenziert, welches die Daten zentral zur Verfügung stellt. Wenden Sie sich bitte an Ihren Administrator.

Ein Klick auf den Mausschalter öffnet, sofern zugelassen, die Benutzeroberfläche der Server-Software.


Menü-Befehle

Die Tabelle enthält alle Menü-Befehle des Programm-Hauptfensters. Sie können zu jedem Menüeintrag individuelle Benutzerrechte definieren.


Befehlsinfo

Der Schalter Info zeigt weitere Informationen über den markierten Menüeintrag.


Sichtbarkeit

Markieren Sie bitte einen Menüeintrag in der Tabelle und klicken Sie auf die Schaltfläche Sichtbarkeit, um die Benutzerrechte für den Menüeintrag festzulegen.


Sichtbarkeit kopieren

Kopiert die Sichtbarkeit des markierten Menüeintrags in die Zwischenablage. Sie können anschließend einen anderen Menüeintrag markieren und die Sichtbarkeit mit der zuvor kopierten überschreiben.


Einfügen/Ersetzen

Ersetzt die Sichtbarkeit des markierten Menüeintrags mit der zuvor kopierten Sichtbarkeit (s. Sichtbarkeit kopieren).


Befehlshilfe

Öffnet die Hilfe zum ausgewählten Befehl


Sichtbar für jeden

Die Programmfunktion kann uneingeschränkt von allen Benutzern verwendet werden.


Sichtbar für Administrator

Sichtbar nur in der Administrator-Ebene

Die Programmfunktion ist geschützt und für den normalen Anwender unsichtbar. Die Funktion kann nur vom Office Manager-Administrator verwendet werden. Zur Anmeldung als Administrator wählen Sie bitte im Menü Datei | Optionen den Befehl Administrator.

Diese Sichtbarkeit sollte für administrative Funktionen, wie beispielsweise Einstellungen, Felder definieren und Dokumenttyp gewählt werden.


Sichtbar nur für Benutzer oder Gruppen
(nur Enterprise-Edition)

Die Programmfunktion ist nur für ausgewählte Benutzer und Gruppen sichtbar. Geben Sie in der Liste bitte alle Benutzer und Benutzergruppen an, die auf diese Funktion zugreifen dürfen. Verwenden Sie die Benutzer- und Gruppennamen des Windows NT-Betriebssystems.

Die Funktion ist immer auch in der Administrator-Ebene sichtbar.


Benutzerliste

Liste der Benutzer und Gruppen, für die der ausgewählte Menüeintrag sichtbar ist.

Die Funktion ist immer auch in der Administrator-Ebene sichtbar.


Attribute ändern

Die Berechtigung Attribute ändern bezieht sich auf alle Dokumente. Wenn Sie diese Sichtbarkeit einschränken, können unberechtigte Anwender die Attribute zu keinem Dokument ändern.

Siehe auch Sicherheitsgrundregel Dokumente ändern auf der Seite Sicherheit | Regeln.


Dateien ändern

Die Berechtigung Dateien ändern bezieht sich auf alle Dokumente. Wenn Sie diese Sichtbarkeit einschränken, können unberechtigte Anwender die Dokumente nur schreibgeschützt öffnen.

Siehe auch Sicherheitsgrundregel Dokumente ändern auf der Seite Sicherheit | Regeln.


Dokumente ändern

Sicherheitsregel "Dokumente ändern"

Wenn die Option Benutzer darf alle Dokumente ändern markiert ist, kann jeder Benutzer alle Dokumentattribute und -dateien uneingeschränkt bearbeiten. (Datei-Zugriffsrechte des Betriebssystems bleiben aber erhalten.)

Ist die Option Benutzer darf nur die eigenen Dokumente ändern markiert, kann der Benutzer nur die Attribute seiner eigenen Dokumente bearbeiten. Dokumentdateien anderer Benutzer werden nur als schreibgeschützte Kopie geöffnet.

Hinweis: Der Administrator darf alle Dokumente ändern.


Dokumente löschen

Sicherheitsregel "Dokumente löschen"

Wenn die Option Benutzer darf alle Dokumente löschen markiert ist, kann jeder Benutzer alle Dokumentverknüpfungen aus dem Office Manager-Archiv löschen.

Ist die Option Benutzer darf nur die eigenen Dokumente löschen markiert, kann der Benutzer nur seine eigenen Dokumente aus dem Archiv löschen

Hinweis: Der Administrator darf alle Dokumente löschen.


Dateien löschen

Sicherheitsregel "Papierkorb"

Ist die Option Benutzer darf auch endgültig löschen markiert, kann der Benutzer die Dokumente unwiderruflich aus dem Archiv entfernen und auch die Dokumentdatei löschen.

Wenn Benutzer darf nur in den Papierkorb verschieben markiert ist, können Dokumente nur vom Administrator endgültig gelöscht werden. Hiermit wird auch verhindert, dass Benutzer die Dokumentdatei löschen.

Hinweis: In Archiven mit GoBD-Modus kann grundsätzlich nur in den Papierkorb verschoben werden.


Zugriffsrechte

Datei-Zugriffsrechte

Legt die Berechtigungen der Benutzer und Benutzergruppen für die verknüpfte Dokumentdatei fest.

Zugriffsrechte definieren: Menü Datei | Optionen | Einstellungen, Seite Sicherheit | Dokument


Bezeichnung

Beschreibung

Geben Sie bitte eine passende Bezeichnung für die vordefinierten Zugriffsrechte ein. Beispielsweise

"Normal" mit Vollzugriff für jeden Benutzer

"Office" mit Vollzugriff für die Benutzergruppe Office und Nur-Lesen für alle anderen


Vordefinierte Datei-Zugriffsrechte

Liste der vordefinierten Dateizugriffsrechte.


Verwendung

Zeigt Informationen über die Verwendung der Sicherheitsrichtlinie. Prüfen Sie dies bitte vor dem Löschen oder Umbenennen einer Richtlinie in jedem Archiv.


Vollzugriff

Vollzugriff: Kombination aus allen Zugriffsrechten, der Anwender hat uneingeschränkte Rechte an der Dokumentdatei.


Lesen und ausführen

Lesen und ausführen (nur lesen): das Dokument kann geöffnet, betrachtet, kopiert und gedruckt werden. Die Datei kann weder geändert noch vom Datenträger gelöscht werden.


Schreiben

Schreiben: das Dokument kann bearbeitet und die Änderungen in der Datei gespeichert werden. Löschen ist nicht möglich.

Hinweis: Das Attribut Lesen und ausführen wird automatisch hinzugefügt, sobald Schreiben gesetzt wird.


Löschen

Löschen: die Dokumentdatei kann vom Datenträger entfernt werden.


Attribute ändern

Attribute ändern: die Attribute (auch die Sicherheitsattribute) der Dokumentdatei können geändert werden.

Der Datei-Eigentümer sollte immer die Rechte zum Ändern der Sicherheitsattribute haben.


Besitzrechte übernehmen

Besitzrechte übernehmen: der Anwender kann die Besitzrechte an der Datei übernehmen, er kann also Eigentümer der Datei werden.


Vorlagenliste

Liste der Dokumentvorlagen in diesem Archiv.


Importieren Context

Die Dokumentvorlagen werden in der Archivdatenbank gespeichert, jedes Archiv hat somit unterschiedliche Vorlagen. Wenn Sie die Dokumentvorlagen aus einem anderen Archiv übernehmen möchten,

·klicken Sie bitte auf Importieren und

·wählen Sie das Archiv, aus dem die Vorlagen kopiert werden sollen.

·Markieren Sie anschließend alle Einträge die Sie übernehmen möchten

·und klicken Sie auf OK.


Bezeichnung

Bezeichnung der Dokumentvorlage, wie sie im Menü Erstellen | Neu | Vorlagen | (Vorlage) gelistet wird.

Die Bezeichnung darf nicht mit Punkten enden.


Dialog öffnen

Wenn diese Option markiert ist, wird der Eigenschaftendialog für die Eingabe von Dokumentattribute geöffnet, bevor das neue Dokument erstellt wird. Ist sie nicht markiert, werden die Dokumente sofort erstellt.

In der Regel sollte diese Option markiert sein.


Sichtbarkeit

Klicken Sie bitte auf die Schaltfläche [Ändern], um festzulegen, für welche Anwender diese Vorlage verwendet können.


Feldwerte

Auf der Seite Feldwerte werden die Attributvorlagen für neuen Dokumente eingegeben. Wenn Sie beispielsweise für Category den Feldwert "Angebot " eingeben, wird das neue Dokument der Kategorie "Angebot" zugeordnet. Im Eigenschaftendialog des neuen Dokuments können Sie die Attribute aber noch ändern.

In den Feldwerten können Sie auch die Makrovariablen verwenden.


Makro vor Hinzufügen

Makrobefehle, die vor Hinzufügen des Dokumentdatensatzes und vor Öffnen des Eigenschaftendialoges ausgeführt werden.


Drucker

Wählen Sie bitte den Drucker, auf dem Sie das Dokument ausgeben möchten.


Drucker-Eigenschaften

Klicken Sie auf Drucker-Eigenschaften, um die Einstellungen des ausgewählten Druckers zu ändern.


Profil-Liste

Liste der Scanprofile.


Bezeichnung

Bezeichnung des Profils, wie es im Scanner-Menü gelistet wird.


Duplex

Aktiviert, sofern vom Gerät unterstützt, das gleichzeitige Scannen der Vorder- und Rückseite des Dokuments.


Automatische Bilddrehung

Wenn aktiviert, dann wird Dokument automatisch gedreht, sofern es seitlich oder verkehrt gescannt wurde. Da hierfür die Textausrichtung analysiert wird, kann es bei ungeeigneten Dokumenten zu einem fehlerhaften Verdrehen kommen. Insbesondere bei Grafiken, Handschriften und zu kleinen oder zu großen Zeichen.


Dialog öffnen

Wenn diese Option markiert ist, wird der Dokumenten-Eigenschaftendialog nach dem Scannen geöffnet. Sie können dann die Attribute, wie Name und Projekt eingeben.


Dokumenttyp

Legt den Dokumenttyp fest, in dem die gescannten Dokumente gespeichert werden. Üblich sind beispielsweise "Adobe Acrobat" und Grafik-Dokumenttypen für TIFF und JPeg. Mehrseitige Dokumente können nur im Adobe Acrobat PDF-Format oder als TIFF gespeichert werden.


Kurztaste definieren

Kurztasten dienen dem schnellen Zugriff auf Befehle. Wählen Sie bitte eine Tastenkombination aus der Liste oder markieren Sie das Eingabefeld und drücken Sie die gewünschte Kurztaste (z. B. Strg festhalten und 1 drücken).

Achten Sie bitte darauf, dass Sie keine Standard-Tastenkombinationen, wie beispielsweise Strg-C verwenden. Ebenfalls nicht empfohlen werden Kombinationen aus Alt und einem Buchstaben, weil diese als Kurztasten für Menübefehle und andere Komponenten dienen.


Hinweis

Der Kurzhinweis erscheint in der Statusleiste, wenn sich die Maus im Menü über dem Scanprofil befindet. Wenn Sie nichts eingeben, dann wird ein Standardhinweis aus den Einstellungen erzeugt.


Menüsymbol

Das Symbol wird im Menü vor dem Profil gezeichnet. Verwenden Sie beispielsweise ein einzelnes Blatt für ein Profil, welches für jede Seite ein neues Dokument erzeugt.


Makro vor Hinzufügen

Makrobefehle, die vor dem Scannen des Dokuments und vor dem Hinzufügen des Dokumentdatensatzes ausgeführt werden.


ScanSnap Manager

Öffnet den ScanSnap Manager bzw. ScanSnap Home - die Treibersoftware Ihres Ricoh/Fujitsu ScanSnap.


Stapel

Stapel mit mehreren Dokumenten.

Markieren Sie diese Option, wenn der eingelegte Papierstapel aus mehreren Dokumenten besteht.


Stapel Seitenzahl

Die Dokumente im Stapel haben eine feste Seitenzahl. Der Office Manager erstellt ein neues Dokument, sobald die Seitenanzahl erreicht.


Barcodetrennung

Für einen Stapel mit unterschiedlicher Seitenzahl (nur Enterprise-Edition). Legen Sie bitte ein Trennblatt hinter die letzte Seite der jeweiligen Dokumente.


Barcode

Typ und Text des verwendeten Barcodes, wenn die Option Standard-Barcode nicht markiert ist.

Syntax: "Typ,Text[,Auflösung]". Vorschläge sind in der Auswahlliste enthalten.


Scan fortsetzen

Scanvorgang fortsetzen (nur ScanSnap)

Verarbeitung großer Papierstapel, Sie können Papier nachlegen: Sobald der Einzelblatteinzug abgearbeitet ist, wartet die Software auf Ihre Bestätigung: Sie können dann weitere Seiten in den Einzug legen und mit Scan fortsetzen zum Stapel hinzufügen oder mit Scan beenden den Vorgang abschließen.

Wenn diese Option nicht markiert ist, wird der Scanvorgang abgeschlossen, sobald das letzte Blatt eingezogen ist.


Standard-Barcode

Markieren Sie diese Option, um den empfohlenen Barcode zu verwenden.


Barcode drucken

Barcode-Trennblatt drucken.


helpcontext-19027

Vorschaubilder der Dokumentseiten

Markieren Sie die Checkbox oben links an einer Seite, wenn mit dieser ein neues Dokument beginnen soll..

Sie können die Vorschaugröße mit dem Regler einstellen.

Öffnen Sie das lokale Menü mit der sekundären Maustaste (Rechtsklick), um weitere Funktionen zu nutzen.

Per Drag&Drop können Sie die Seiten verschieben und zusätzliche Seite aus Bilddateien importieren.


helpcontext-19028

Zoom

Zum Vergrößern oder Verkleinern der Vorschaubilder können Sie

·den Zoom-Regler verschieben,

·die + und - Tasten am Zehner-Block mit gehaltener Strg-Taste verwenden oder

·das lokale Menü (Rechtsklick) nutzen.


Manuelle Trennung

Manuell trennen

Für einen Stapel mit unterschiedlicher Seitenzahl. Sie können nach dem Scan mit der Maus markieren, wo ein neues Dokument beginnt. Das Vorschaufenster bietet auch Funktionen für das Umsortieren und Löschen von Seiten sowie das Hinzufügen von Bilddateien.

Ab n Seiten

Gibt an, ab wie vielen Seiten das Vorschaufenster mit der Trennmöglichkeit eingeblendet wird. In der Regel ist dies ab 2 Seiten. Ein einseitiger "Stapel" muss nicht getrennt werden, außer Sie möchten Bilddateien per Drag&Drop als zusätzliche Seiten hinzufügen.


Quelltexteditor

Geben Sie hier bitte den Skriptquelltext ein. Beachten Sie die gewählte Skriptsprache im Menü Start | Makro.


Funktionsliste

Funktionsliste der gewählten Skriptsprache. Mit einem Doppelklick können Sie Funktionen an die Cursorposition im Editor einfügen.


Meldungen

Liste der Interpreter-Meldungen.


Statusbar


Text verschlüsseln

Navigation: »Kein übergeordnetes Kapitel«

Text verschlüsseln

Makroeditor-Menü Start | Zwischenablage | Text verschlüsseln.

Die Funktion verschlüsselt den im Editor markierten Text.

Für einige Makrofunktionen ist die Angabe eines Passwortes erforderlich. Damit dieses nicht im Quelltext erkennbar ist, wird es verschlüsselt eingegeben.

Beispiel Makro-Funktion SignDocument

Öffnen Sie bitte den Makroeditor, wählen Sie die Skriptsprache OmAPI, geben Sie Folgendes ein und markieren Sie das Passwort:

{SignDocument:{Doc:FileName},G:\Archiv\MeinZertifikat.pfx,MeinPasswort,Ort,Mein Name}

Wählen Sie anschließend im Menü Start | Zwischenablage | Text verschlüsseln. Das Kennwort wird verschlüsselt:

{SignDocument:{Doc:FileName},G:\Archiv\MeinZertifikat.pfx,nvwA20txu0vB4Yn5R+JuVOJTqHigi7RGMgDw/cepeL0=,Ort,Mein Name}

Speichern Sie das Makro oder kopieren Sie es über die Zwischenablage. Das Kennwort wird vom Interpreter automatisch entschlüsselt.


Funktion suchen

Nach einer Funktion in der Liste suchen.

Bei der Sprache "OmAPI" wird auch in der Kurzbeschreibung und in Schlüsselwörtern gesucht. Bei anderen Skriptsprachen nur im Funktionsnamen.


Neu

Ein neues Makro oder Skript erstellen. Wenn derzeit ein Makro geladen ist, dann wird dieses geschlossen.


Öffnen

Eine vorhandene Makrodatei in den Editor laden. Die Skriptsprache wird -sofern bekannt- nach dem Öffnen automatisch eingestellt.


Speichern

Änderungen des geöffneten Makros in Datei oder Datenbanktabelle speichern.

Siehe auch: Speichern unter


Speichern unter...

Die geöffnete Makrodatei unter einem neuen Namen speichern.


Speichern unter (Export)

Speichern unter...

Dieses Makro ist in einer Datenbanktabelle gespeichert. Wählen Sie bitte im Menü Datei den Befehl
Speichern, um die Änderungen in die Tabelle zu schreiben oder
Speichern und Senden | Speichern unter, um eine Dateikopie des Makros zu erstellen.


Hilfe zur Funktion

Nur für Office Manager Makrosprache: markieren Sie bitte eine Funktion in der rechten Liste und klicken Sie anschließend auf diesen Befehl, um die Hilfeseite zur markierten Funktion zu öffnen.


Ausführen

Ausführen [F9]

Führt das Makro bzw. Skript aus. Diese Funktion ist vor allem für Testzwecke vorgesehen. Meldungen des Interpreters werden in der unteren Liste aufgeführt.

Debuggen [F8]

Nur OmAPI-Makrosprache: Führt das Makro Schritt-für-Schritt zur Fehlersuche aus. Alternativ zum Menübefehl Debuggen können Sie auch mit gedrückter Umschalt-Taste auf Ausführen klicken oder die Taste F8 drücken.

Kompilieren [Strg+F9]

Nur Pascal: Ermöglicht eine Syntaxprüfung, ohne das Skript auszuführen.


Funktion einfügen

Funktion in den Editor kopieren

Bewegen Sie den Cursor bitte an die gewünschte Stelle im Editor und doppelklicken Sie auf eine Funktion in der rechten Liste. Die markierte Funktion wird an der Cursorposition im Editor eingefügt.

Statt einem Doppelklick können Sie auch eine Funktion markieren und anschließend im Menü Start | Makro den Befehl Funktion einfügen wählen.


Sprache

Wählen Sie bitte die Programmiersprache des Makros (z. B. VBScript, JScript oder OmAPI).


Ergebnis zeigen

Debugger-Funktion: Wenn diese Option markiert ist, dann wird das Ergebnis des Makros nach dem Ausführen im Editor gezeigt.

Wenn im Makro zum Beispiel nur die Variable {Doc:FileName} enthalten ist, dann wird der Dateinamen des aktuellen Dokuments gezeigt.


Importprofile

Liste der Importprofile.


Drag and Drop Testfeld

Für die unterschiedlichen Verzeichnisse können individuelle Importeinstellungen festgelegt werden (s. a. Hilfe).

Um zu ermitteln, welche der obigen Importeinstellungen für eine bestimmte Datei verwendet würde, können Sie die Datei per Drag and Drop vom Explorer auf diese Fläche ablegen.


Bezeichnung

Geben Sie bitte eine aussagekräftige Beschreibung ein.


Modus

Deaktiviert: diese Definition wird ignoriert, als wäre sie nicht vorhanden

Manuell oder von außen gesteuert: beispielsweise Drag&Drop

Dokumente automatisch importieren: das Verzeichnis wird regelmäßig nach neuen Dokumenten durchsucht


Computer

Geben Sie einen Computernamen an, wenn das Profil nur an diesem gültig sein soll.

Tipp zu Importprofilen: Beim automatischen Import können Sie hier den zuständigen Computer angeben. Dies verhindert z. B. beim Import von Netzwerkressourcen, dass der Import einer Datei gleichzeitig von mehreren Rechnern ausgeführt wird.


Verzeichnisse

Markieren Sie ein oder mehrere Verzeichnisse, für welche die Importoptionen gelten.


Benutzer

Geben Sie einen Benutzer an, wenn das Profil nur für diesen gelten soll.

Tipp zu Importprofilen: Beim automatischen Import können Sie hier den zuständigen Benutzer wählen. Dies verhindert z. B. beim Import von Netzwerkressourcen, dass der Import einer Datei gleichzeitig von mehreren Rechnern ausgeführt wird.


Archiv

Wählen Sie bitte eine Archivdatenbank, wenn das Profil nur für ein bestimmtes Archiv gelten soll.


Fenstertitel

Titel des Dokumenten-Eigenschaftendialogs, zum Beispiel "Dokumentdatei importieren".


Benutzerhilfe

Eine Datei, die im Eigenschaftenfenster beim Klick auf den Schalter Hilfe geöffnet wird.

Oder:

Die Nummer der Office Manager-Hilfe. Klicken Sie auf [...] und wählen Sie ein Thema aus.


Quellentyp

Typ der Importquelle: ein oder mehrere gewählte Verzeichnisse oder alle Wechsellaufwerke (CD, USB u. a.) die an dem Computer angeschlossen sind.


Variable Verzeichnisse

Liste mit Import-Quellverzeichnissen, welche als Makrovariable definiert werden. Jede Zeile beinhaltet ein Verzeichnis.

Beispiele für geeignete Makrovariablen:

{OS:TmpPath} z. B. für DnD von E-Mails und deren Anlagen

{OS:SpecialFolder,0x002e}

{Self:DocPath}


Rekorder

Wählen Sie bitte den zu verwendenen CD-Rekorder aus.


Brennen

Klicken Sie auf Brennen, um mit dem Beschreiben der CD zu beginnen.


Auswerfen

Laufwerksschublade öffnen.


CDRW löschen

Eingelegten Datenträger schnell löschen. Diese Funktion ist nur für wiederbeschreibbare CDRW möglich.


Bezeichnung

Bezeichnung des Datenträgers.


Autom. auswerfen

Markieren Sie diese Option, um die CD nach dem Brennen automatisch auszuwerfen.


Protokoll

Text, der im Protokoll des Dokuments hinterlegt wird.

Ein Protokolleintrag ist zwingend erforderlich, falls die Option "Dokumentbearbeitung protokollieren" aktiviert ist.

Siehe auch: Datei | Optionen | Einstellungen, Seite Datenbank.


Meldungen

Liste der Meldungen.


Dokumentenindex

Legt ein HTML-Inhaltsverzeichnis auf der CD ab.


FTP-Server

Server

IP-Nummer oder Name des Servers (Host).

Die Verbindungseinstellungen werden für jeden Benutzer gespeichert und können nach einem Neustart in diesem Kombinationsfeld ausgewählt werden.


Server-Port

Port

Server-Port für den FTP-Zugriff. Der Standardport für FTP ist 21 und für SFTP 22.


FTP-Protokoll

Protokoll

FTP und SFTP sind Protokolle zur Dateiübertragung, SFTP ist sicherer.

FTP ist unverschlüsselt und kann abgehört werden, während SFTP die Daten über eine verschlüsselte SSH-Verbindung überträgt.


FTP-Zielverzeichnis

Optionales Unterverzeichnis auf dem FTP-Server, in welches die Dateien hochgeladen werden.


Benutzername

Benutzername und Passwort für die Authentifizierung auf dem FTP-Server.


Löschen

Die Verbindungseinstellungen werden benutzerabhängig gespeichert und nach einem Neustart wiederhergestellt.

Klicken Sie auf Löschen, wenn Sie die Einstellungen des gewählten FTP-Servers entfernen möchten.


Drucken

Ausgabe des Reports auf einem Drucker.


Als PDF speichern

Als PDF-Datei speichern

Ausgabe des Reports in ein PDF-Dokument. Wählen Sie bitte den Namen der zu erstellenden PDF-Datei, indem Sie auf den Schalter Durchsuchen klicken. Die Datei wird anschließend geöffnet, wenn die Option "Datei öffnen" markiert ist.


Feldliste

Zu druckende Felder

Markieren Sie bitte alle Felder, die im Report mit ausgedruckt werden sollen.

Die Positionierung auf dem Report entspricht der Sortierung in dieser Liste. Zum Sortieren können Sie die Felder mit der Maus verschieben (Drag&Drop).


Leere Felder

Wenn diese Option nicht markiert ist, werden leere Felder im Report ignoriert.


Grafikformat

Gibt an, in welchem Format die Vorschaugrafik in der PDF-Datei eingebunden wird. Für Farbbilder sollte JPeg verwendet werden, um Speicherplatz zu sparen.


Auflösung

Auflösung der Vorschaugrafik

Eine hohe Auflösung verbessert die Qualität, benötigt aber mehr Speicherplatz für das erstellte PDF-Dokument. Empfohlen sind 300 dpi.


Größe

Größe der Vorschaugrafik

Bei "Automatisch" wird der zur Verfügung stehende Platz ausgenutzt.


Grafikrahmen

Vorschau umrahmen

Wenn die Option markiert ist, wird ein Rahmen um die Vorschaugrafik gezeichnet.


Überschrift

Text der über den Datenfeldern ausgegeben wird. Lassen Sie dies leer, wird automatisch "Dokument" oder "Kontakt" ausgegeben.


Logo

Dateiname einer Grafik die rechts oben in der Kopfzeile des Reports platziert wird.


Schriftgröße

Standardschriftgröße der Texte, beispielsweise "10".


Optionen speichern

Optionen zwischenspeichern

Sie können verschiedene Einstellungen in Dateien speichern und später wieder laden.


Feldnamen-Breite

Im Report werden die ausgewählten Felder mit ihren Daten in zwei Spalten gedruckt. Dieser Wert legt die maximale Breite des Texte für die Feldnamen in mm fest. Der Standardwert ist 25 mm.


Ausgeben

Markieren Sie im Dropdown-Listenfeld bitte die zu druckenden Bereiche. Datenfelder sind immer aktiv und lassen sich nicht abschalten.

Vorschau, Versionen und Dokumentdatei sind für Kontakt-Reporte nicht relevant.,


Seitenumbruch

Seitenumbruch nach jedem Dokument

Wenn diese Option markiert ist, wird der Report für jedes Dokument bzw. jeden Kontakt auf einer eigenen Seite gedruckt.


Ausrichtung korrigieren

Markieren Sie diese Option bitte nur, falls einige Bilder im Report auf dem Kopf stehen. Die Einstellung dreht Bilder, welche mit der Windows-Miniaturansicht erzeugt wurden, um 180°.

Diese Einstellung ist Benutzer- und Computerabhängig.


helpcontext-26010

Zeigt Informationen und das Protokoll der Datenübergabe.


helpcontext-26012

Ausgabeverzeichnis

In dieses Verzeichnis werden die Dokumentdateien kopiert.

Sie können auch Makrovariablen verwenden, um eine Verzeichnisstruktur zu erzeugen. Beispielsweise legt "C:\Export\Steuerberater\{doc:project}\{doc:category}\" Unterverzeichnisse für die Jahre und Kategorien an.


helpcontext-26013

Syntax der Dateinamen

Falls der Steuerberater besondere Dateinamen benötigt, können Sie diese mit Makrovariablen formatieren. Beispielsweise "{StringReplace:{doc:category},\,-}-{doc:docno}-{doc:name}" für "Kategorie-Nummer-Name".


helpcontext-26014

Warnen, wenn das Zielverzeichnis nicht leer ist

Warnt den Anwender vor dem Versenden, falls das Ausgabeverzeichnis bereits Dateien oder Unterverzeichnisse beinhaltet.


helpcontext-26015

Tabellen

Markieren Sie, welche Dokumententabellen berücksichtigt werden sollen. Der Bereich "Archivierte Dokumente" ist nur in der Enterprise-Edition verfügbar.


helpcontext-26016

Nur markierte Buchungsjahre bzw. Projekte

Sendet nur Dokumente der im Programmhauptfenster markierten Projekte bzw. Buchungsjahre.

Der Anwender markiert dazu die gewünschten Einträge im Projektnavigator, bevor er die Funktion "An Steuerberater senden" aufruft.


helpcontext-26017

Kategorien

Markieren Sie die Dokumentenkategorien, die für den Steuerberater relevant sind. Beispielsweise Rechnungen und Kontoauszüge.

Beachten Sie bitte, dass auch Unterpunkte markiert werden müssen: "Buchhaltung" beinhaltet nicht automatisch den Unterpunkt "Buchhaltung\Ausgangsrechnung".


helpcontext-26018

Zusätzlicher Filter

Falls Sie nach weiteren Datenfeldern filtern möchten, können Sie diese hier angeben.

Beispiele

meinfeld = 'Steuerberater' AND janeinfeld = 'T'

Nur Belege vom Februar 2025 (Belegdatum ab 1. Februar und vor 1. März):

receiptdate >= {d 2025-02-01} AND receiptdate < {d 2025-03-01}


helpcontext-26019

Standard-Unterverzeichnisse für DATEV-Belegtransfer

Wenn markiert, dann werden die Belege anhand ihrer Kategorie in Unterordner des Ausgabeverzeichnisses kopiert:

Kategorie im Office Manager-Archiv => Unterordner

Buchhaltung\Ausgangsrechnung => Rechnungsausgang

Buchhaltung\Eingangsrechnung => Rechnungseingang

Buchhaltung\Kasse => Kasse

(ohne Kategorie) => ohne Belegtyp

(alle anderen) => Sonstige


helpcontext-26020

Nur Belege bis zum Vormonat

Diese Option ist empfohlen, wenn Sie die Dokumente monatlich zum Steuerberater geben. Es werden dann nur Belege bis zum Ende des vergangenen Monats über das Belegdatum (Datenfeld receiptdate) gefiltert. Belege des aktuellen Monats sind nicht enthalten.

Beispiel

Wenn Sie am 6. März die Daten an den Berater senden, werden alle Belege aus dem Vormonat Februar gewählt. Falls seit der letzten Übertragung (z. B. am 6. Februar) aber noch neue Belege aus dem Januar oder früher hinzugekommen sind, werden auch diese nachgereicht. Sie wurden ja noch nicht gesendet.


helpcontext-28031

Modell

Öffnen Sie das Kombinationsfeld mit Klick auf den Pfeil am rechten Rand, um alle verfügbaren Chat-Modelle des gewählten GPT-Dienstes aufzulisten.

Die Ergebnisse der KI hängen von der richtigen Wahl eines passenden Modells ab. Sie können mit verschiedenen Modellen für die jeweilige KI-Aufgabe experimentieren.


helpcontext-28032

Rollen

Die Anfrage an den Chat-Dienst kann in System- und Benutzerrolle aufgeteilt werden, um die Ergebnisse zu optimieren. Die Systemrolle beinhaltet dabei die Regeln und die Benutzerrolle die eigentliche Anfrage.

System-Rolle

Legt den Kontext und das Verhalten des KI-Assistenten fest. Beispiele sind

·"Du bist ein Assistent, der mich bei der Übersetzung von fremdsprachigen Texte unterstützt. Übersetze in deutsche Sprache."

·"Die Regeln für die Dokumentenerkennung sind ...".

·"Du bist ein Assistent, der mir Fragen zur Computer-Technik beantwortet. Antworte in deutscher Sprache und vermeide Fachbegriffe."

Benutzer-Rolle

Beinhaltet die Frage an die KI, beispielsweise

·"Übersetze folgenden Text in deutsche Sprache: [the text]"

·"Erkenne das Dokument mit folgendem Inhalt: [Text]"

·"Was ist ein WORM-Datenträger?"


helpcontext-28033

Maximale Tokens

Legt eine Obergrenze für die Eingabe plus Ausgabe bei der Kommunikation mit dem GPT fest. Tokens entsprechen ungefähr der Anzahl von Wörtern und Satzzeichen. Cloud-Dienste werden i. d. R. für die Anzahl der genutzten Tokens bezahlt. Der Standardwert ist 1024.


helpcontext-28034

Dokumente kürzen (Tokens)

Für die Dokumentenerkennung und die Übersetzung von Dokumenten wird der Text aus der markierten Datei extrahiert und an die KI übergeben. Sehr lange Texte sind meist nicht sinnvoll, sie würden unnötige Tokens sowie Zeit und Rechenleistung verbrauchen.

Office Manager DMS kürzt den Text auf die angegebene Anzahl von Tokens, bevor dieser gesendet wird.

Tokens entsprechen ungefähr der Anzahl von Wörtern und Satzzeichen. Der GPT-Dienst verwendet ggf. eine abweichende Berechnungsmethode.


helpcontext-28035

Bilder verkleinern (Pixel)

Für die Bilderkennung wird nicht die Originaldatei in voller Größe genutzt. Dies ist in der Regel nicht nötig und würde zu viele Tokens und Rechenleistung verbrauchen.

Geben Sie die maximale Pixelbreite oder -höhe an. Das Bild wird so verkleinert dass Breite und Höhe nicht größer als der Maximalwert sind.

Empfohlene Werte

224 Pixel ist die Mindestgröße für grundlegende Erkennungen.

300 bis 512 ein guter Kompromiss für die meisten Anwendungen.

640 ist der Maximalwert für detaillierte Analysen.


helpcontext-28036

Zurücksetzen

Die ausgewählte GPT-Funktion auf Standard-Einstellungen setzen.


helpcontext-28101

API-Adresse

URL der REST API für den Zugriff auf die Cloud-Funktionen und lokale GPT.

Beispiele

GPT4All (lokal)
http://localhost:4891/v1

OpenAI ChatGPT
https://api.openai.com/v1

Google Gemini
https://generativelanguage.googleapis.com/v1beta/openai

Azure GPT
https://(meine-subdomain).openai.azure.com/

Azure OCR
https://germanywestcentral.api.cognitive.microsoft.com/vision/v3.2/read/analyze

Azure Formularerkennung
https://myendpoint.cognitiveservices.azure.com/formrecognizer/documentModels/prebuilt-invoice:analyze?api-version=2022-08-31


helpcontext-28102

Schlüssel

Ihren API-Key finden Sie im Dashboard des jeweiligen Anbieters.. Bei lokalen GPT-Diensten können Sie i. d. R. einen beliebigen Text eingeben, wie "mykey".


helpcontext-28103

Erkannte Rohdaten zeigen

Blendet nach der Erkennung die vom Cloud-Server erhaltenen Daten ein. Hier finden Sie beispielsweise die Pfade für die Makrovariable AutoCaptAzureAI.


GPT Timeout

Timeout für KI-Antwort

Menü Datei | Optionen | Einstellungen, Seite Künstliche Intelleigenz

Die Antwortzeit der Künstliche Intelligenz hängt von der Leistungsfähigkeit des Computers und der Komplexität der Anfrage ab. Bei umfangreichen Antworten, wie der Übersetzung langer Texte, kann die Verarbeitung auch einige Minuten dauern.

Nach Ablauf des eingestellten Timeouts bricht Office Manager DMS die Verbindung ab und gibt eine entsprechende Fehlermeldung aus.

Stellen Sie hier ein, wie viele Sekunden auf eine Antwort der KI gewartet werden soll, der Standardwert ist 120 = 2 Minuten. Ein sehr hoher Wert hat den Nachteil, dass Sie bei Verbindungsproblemen lange warten müssen, bis die Verbindung abgebrochen wird.

Weitere Timeouts

In der Konfigurationsdatei können auch die Timeouts für den Verbindungsaufbau und das Senden der Frage eingestellt werden. Dies ist i. d. R. aber nicht nötig, der Standard-Timeout beträgt hier 60 Sekunden. Beachten Sie, dass die Werte in der INI-Datei in Millisekunden angegeben werden.


Kopieren und Einfügen

Ermöglicht die Übertragung der Einstellungen zwischen verschiedenen Funktionen.

Kopieren legt die aktuellen Einstellung in der Zwischenablage ab.

Klicken Sie auf Einfügen, um diese aus der Zwischenablage in das Dialogfenster zu übernehmen.


Dateifilter für Importprofile

Navigation: »Kein übergeordnetes Kapitel«

Dateifilter für Importprofile

Dateifilter für Importprofile
(Menü Datei | Optionen | Einstellungen, Seite Importieren | Profile)

Legen Sie bitte zuerst die Filtermethode fest:

·Kein Filter: alle Dateien werden berücksichtigt

·Nur Dateien mit folgender Syntax berücksichtigen: Dateien, die der eingegebenen Syntax entsprechen, werden berücksichtigt. Für alle anderen Dateien gilt diese Verzeichnisdefinition nicht, es wird ggf. die Standarddefinition verwendet.

·Dateien mit folgender Syntax ignorieren: Die Verzeichnisdefinition gilt nicht für Dateien, die der eingegebenen Syntax entsprechen.

Geben Sie anschließend bitte die Syntax der Dateien ein, die berücksichtigt oder ignoriert werden sollen. Zwischen Groß- und Kleinschreibung wird nicht unterschieden. Verwenden Sie den Stern "*" als Joker für mehrere Zeichen und "?" für ein einzelnes Zeichen. Geben Sie bitte jede Syntax in einer eigenen Zeile ein.

Beispiele:

"*.doc" Alle Word-Dokumente

"*_vers*" Vom Office Manager erzeugte Dokumentversionen (s. a. erweiterte Einstellung)

Siehe auch

Importprofile mit Modus "Dokumente automatisch importieren" und die Verzeichnisüberwachung verwenden zusätzlich den Filter für automatischen Dateiimport: Menü Datei | Optionen | Einstellungen, Seite Importieren | Filter.


Importprofile mit Makrovariablen

Navigation: »Kein übergeordnetes Kapitel«

Importprofile mit Makrovariablen

Mit Hilfe der Importprofile wird festgelegt, wie der Office Manager die Dateien beim Import aus unterschiedlichen Verzeichnissen behandeln soll.

Die Verzeichnisse können mit Makrovariablen definiert werden. Dies ist beispielsweise bei den Systemordnern für temporäre Dateien, "Eigene Dateien" u. ä. sinnvoll.

Wählen Sie dazu bitte auf der Seite Verzeichnis die Option "Makrovariablen für Verzeichnisse":

Importprofil definieren: Verzeichnis als Makro

Geben Sie die entsprechenden Makrovariablen in der Liste ein, jede Zeile beinhaltet ein Verzeichnis. Im obigen Bild wurden die Variablen {OS:TmpPath} und {Self:TmpPath} verwendet. Die Verzeichnisdefinition gilt somit für die temporären Verzeichnisse von Windows und vom Office Manager.

Beispiele für geeignete Makrovariablen:

{OS:TmpPath} z. B. für DnD von E-Mails und deren Anlagen

{OS:SpecialFolder,0x002e}

{Self:DocPath}

Siehe auch

Makro-Referenz

Makro-Editor

Verzeichnis-Definitionen

Vorgabewerte beim Import


Beispiel Importverzeichnis für Scanner

Beispiel-Importprofil für Scanner

Navigation: »Kein übergeordnetes Kapitel«

Beispiel-Importprofil für Scanner

Importprofile

Eine häufige Aufgabe des Dokumentenmanagements ist der Import von Dateien aus verschiedenen Quellen. Office Manager DMS bietet hierfür mehrere Importfunktionen, wie beispielsweise Drag&Drop, Einfügen aus der Zwischenablage und die Verzeichnisüberwachung. Sie können Import-Optionen für verschiedene Verzeichnisse definieren.

Beispiel: Import-Verzeichnisprofil für Dokumentenscanner

Ein Scanner, der nicht über Twain angesteuert wird, liest die Papierdokumente selbständig ein und legt die Dateien auf der Festplatte ab (s. u. Funktionsweise). In diesem Beispiel wird der Office Manager nach dem Scannen nicht vom Gerät informiert. Er überwacht vielmehr das Verzeichnis, in welchem die gescannten Dokumente abgelegt werden.

1.In der Scannersoftware wird festgelegt, in welchem Verzeichnis die Dokumente vom Gerät gespeichert werden, z. B. "C:\Scanner\".

2.Wählen Sie im Office Manager-Menü Datei | Optionen | Einstellungen und wechseln Sie auf die Seite Importieren | Profile.

3.Klicken Sie bitte auf den Schalter [image], um ein neues Profil zu erstellen:

4.Geben Sie als Beschreibung beispielsweise "Dokumentenscanner" ein und wählen Sie den Modus "Dokumente automatisch importieren". Der Office Manager importiert in diesem Modus alle Dateien aus dem Verzeichnis und verschiebt sie in das voreingestellte Dokumentenverzeichnis.

5.Die Option Eigenschaftendialog für neue Dokumente öffnen sollte aktiviert sein, damit Sie die Attribute für gescannte Dokumente eingeben können.

6.Fenstertitel ist z. B. "Dokument vom Scanner importieren". Dieser Text erscheint im Titel des Eigenschaftendialogs.

7.Als Benutzerhilfe empfiehlt sich "1000". Sie können aber auch ein eigenes Hilfedokument, z. B. im PDF-Format, mit Anweisungen für Ihre Mitarbeiter erstellen und den Dateinamen hier eingeben. Das Hilfedokument wird geöffnet, wenn der Anwender im Eigenschaftendialog auf Hilfe klickt.

8.Wechseln Sie bitte auf die Seite Verzeichnis und markieren Sie die Checkbox des Scanner-Verzeichnisses:

Importprofil definieren: Verzeichnis

9.Wechseln Sie auf die Seite Gültigkeit.

10.Wenn der Scanner - wie in unserem Beispiel - nur an einem Arbeitsplatzcomputer angeschlossen ist, wählen Sie den Computer bitte bei "Die Verzeichnisdefinition gilt nur auf folgendem Computer" aus. Bei einem Netzwerkscanner können Sie alternativ den Mitarbeiter festlegen, der für den Import der gescannten Dokumente verantwortlich ist, siehe "Die Verzeichnisdefinition gilt nur für folgende Benutzer".

11.Wenn Sie sicherstellen möchten, dass die Dokumente immer in dasselbe Archiv importiert werden, können Sie das Zielarchiv bei "Die Verzeichnisdefinition gilt nur für folgendes Archiv" vorgeben.

12.Auf der Seite Filter können Sie die zu importierenden Dateien einschränken: beispielsweise nur *.pdf und *.tif.

13.Wenn Sie Dokumentenstapel nachträglich in einzelne Dokumente trennen möchten, dann wählen Sie eine entsprechende Option auf Seite Stapel.

14.Wechseln Sie auf die Seite Feldwerte. Hier sind Vorgabewerte für Dokumentattribute möglich. Besonders interessant für gescannte Dokumente sind die Makrofunktionen ImgGetTextFromRect, AcroExchGetTextFromRect und FtiGetFirstCrspWord.

15.Auf der Seite Makros können Sie bei Nach Speichern die "OCR-Texterkennung" aus der Auswahlliste wählen. Dies ist aber nur erforderlich, wenn der Scanner keine durchsuchbaren PDF-Dokumente erstellt.

16.Klicken Sie bitte auf OK, um die Verzeichnisdefinition zu speichern.

17.Scannen Sie ein Dokument ein oder legen Sie zum Test eine entsprechende Datei im Verzeichnis "C:\Scanner" ab. Der Office Manager sucht in regelmäßigen Abständen nach Dateien in diesem Verzeichnis, importiert diese und verschiebt sie in das Dokumentenverzeichnis.


Importieren aus K7 AllScan

Navigation: »Kein übergeordnetes Kapitel«

Importieren aus K7 AllScan

Dokumente aus K7-AllScan importieren

AllScan ist eine Scan-Software mit direkter Schnittstelle zu verschiedenen Dokumentenscannern. Durch die direkte Anbindung ist der Scanvorgang i. d. R. schneller als die TWAIN-Schnittstelle.

Sie können den hier beschriebenen Import aber auch für andere Scan-Programme verwenden, wenn diese in ein vorgegebenes Verzeichnis speichern und anschließend eine Anwendung starten kann.

Profil in AllScan erstellen

1.Wählen Sie bitte im AllScan-Menü Extras bitte den Befehl Einstellungen und erstellen Sie ein neues Profil.

2.Fügen Sie anschließend ein neues Verfahren hinzu und wählen dafür das neue Profil aus. Wählen Sie die Schnittstelle "Standard Export Library" und klicken Sie auf Konfigurieren:

3.Geben Sie bitte ein Zielverzeichnis an (z. B. "Eigene Dateien\AllScan") und wählen Sie als Programm, das nach dem Export ausgeführt werden soll, die Datei "SendToOM.exe" im Office Manager-Programmverzeichnis aus.

4.Klicken Sie auf OK, um die Einstellungen zu speichern.

Einstellungen im Office Manager

1.Wählen Sie bitte den Befehl Datei | Optionen | Einstellungen.

2.Markieren Sie die Kategorie Importieren | Profile und klicken Sie auf den Schalter [image].

3.Geben Sie folgende Einstellungen ein:
Beschreibung "AllScan"
Aktivierung "Manuell oder von außen gesteuert"
Als Verzeichnis das AllScan-Zielverzeichnis (z. B. "Eigene Dateien\AllScan")
Dateioperation "In das Dokumentenverzeichnis verschieben"

4.Klicken Sie zweimal auf OK, um die Änderungen zu speichern.


Import-Optionen

Navigation: »Kein übergeordnetes Kapitel«

Import-Optionen

Import-Optionen
(Menü Datei | Optionen | Einstellungen, Seite Importieren)

Der Office Manager kann bestehende Dokumentdateien beispielsweise per Drag&Drop und mit Hilfe der Import-Funktion übernehmen.

Einstellungen auf Seite "Importieren"

Sounddatei: Sie können hier eine Datei angeben, die abgespielt wird, sobald ein Dokument automatisch übernommen wurde. Der Sound dient zu Ihrer Information.

Eigenschaftendialog öffnen: Beim Import der Internetadresse vom Browser wird das Fenster für die Eingabe der Dokumentbeschreibung geöffnet.

Import-Intervall: Gibt das Intervall für den automatischen Faximport und die automatischen Import-Profile an. Standard ist 30 Sekunden.

Verzeichnis-Optionen

Auf der Seite Profile können Sie die Importoptionen für verschiedene Verzeichnisse definieren und festlegen, wie die Dokumentattribute aus der Verzeichnisstruktur ermittelt werden.

Siehe auch

Dokumente importieren

Importprofile


Softwarebüro Krekeler

Navigation: »Kein übergeordnetes Kapitel«

Softwarebüro Krekeler

Impressum

Logo Softwarebüro Krekeler

Softwarebüro Krekeler

Dipl.-Wi.-Ing. Harald Krekeler

Friedrich-Engels-Straße 45

15712 Königs Wusterhausen

Deutschland

USt-ID: DE136377489

ILN: 40 29833 00000 7

Telefon +49 3375 203620

Fax +49 3375 203622

E-Mail mail@krekeler.de

Internet: https://www.krekeler.de/

Datenschutzerklärung: https://www.officemanager.de/impressum/datenschutz.php

Verantwortlicher im Sinne von § 18 Abs. 2 MStV: Harald Krekeler (Anschrift s. o.)

Office Manager DMS-Support

Unterstützung erhalten Sie bei Ihrem Fachhändler, im Internet unter https://dms.support/, im Hotline-Blog https://blog.officemanager.de/ oder per E-Mail vom Softwarebüro Krekeler.


Info Volltextindex

Navigation: »Kein übergeordnetes Kapitel«

Info Volltextindex

Index-Informationen abfragen
Menü Administrator | Info Volltextindex

Sie können sich anzeigen lassen, welche Wörter zu einem Dokument indexiert wurden.

Melden Sie sich bitte als Administrator an (Menü Datei | Optionen | Administrator). Markieren Sie das gewünschte Dokument in der Tabelle und wählen Sie im Menü Administrator den Befehl Info Volltextindex.

Die Wörter werden nicht gezeigt, falls gerade eine Index-Aktualisierung läuft.

Wenn Sie diesen Befehl öfter verwenden möchten, können Sie ihn auch in ein anderes Menü kopieren, um sich nicht jedes Mal als Administrator anmelden zu müssen. Siehe auch Menüband anpassen.


Blockchain AutoStore

Navigation: »Kein übergeordnetes Kapitel«

Blockchain AutoStore

Blockchain AutoStore

Neue Dokumente können automatisch mit der Blockchain-Revision abgesichert werden, siehe Einstellungen.

Folgende optionale Einstellungen in der admin.ini sind zusätzlich möglich:

AutoStoreTaskOwner

Legt einen anderen Computer und/oder das Benutzerkonto für die Blockchaintransaktion fest.

[Blockchain]

AutoStoreTaskOwner=MeinComputer

Syntax: Computername oder Benutzername@Computername bzw. Domäne\Benutzername@Computername

AutoStoreInclude

Wenn angegeben, dann gilt das automatische Hinterlegen nur für die Dokumentenarchive, dessen Dateiname (ohne Pfad und Endung) in der punktgetrennten Liste enthalten sind.

[Blockchain]

AutoStoreInclude=.archiv.buchhaltung.

AutoStoreExclude

Wenn AutoStoreInclude nicht angegeben ist, AutoStoreExclude aber schon, dann gilt das automatische Hinterlegen für alle Archive, außer für die in AutoStoreExclude angegebenen.

[Blockchain]

AutoStoreExclude=.archiv.


ConfirmDuplicate

Navigation: »Kein übergeordnetes Kapitel«

ConfirmDuplicate

ConfirmDuplicate

In den Importprofilen ist festgelegt, ob nur neue Dokumentdateien importiert werden. Ist eine identische Datei bereits im Archiv enthalten wird dann beim manuellen Import gefragt, ob diese trotzdem archiviert werden soll. Bei automatisierten Importfunktionen erscheint standardmäßig keine Rückfrage und kein Hinweis auf die Dublette.

Sie können aber mit einer erweiterten Option in der admin.ini bestimmen, wann die Rückfrage "Datei ist bereits im Archiv vorhanden, möchten Sie diese trotzdem importieren?" eingeblendet wird. Hinterlegen Sie hierzu eine punktgetrennte Liste mit den Importmethoden, bei denen die Rückfrage gewünscht ist:

[Import]

ConfirmDuplicate=.1.2.3.4.5.7.8.11.12.13.

1: Zwischenablage und Drag&Drop einer Datei
2: File Contents, z. B. Drag&Drop einer Dateianlage aus einer E-Mail
3: Zwischenablage und Drag&Drop aus E-Mail-Client
4: Zwischenablage und Drag&Drop eines Links
5: Makro, auch "Senden an Office Manager"
6: Scanprofil
7: Importprofil im Modus "automatisch importieren"
8: Fax
9: Verzeichnisüberwachung
10: Massenimport
11: Datenbankimport "Austauschdatei mit Dokumenten"
12: Datenbankimport ELOoffice
13: Programmintern, z. B. Serienbrief

Unabhängig von dieser Einstellung erfolgt im stillen Modus keine Rückfrage, beispielsweise beim Massenimport "Ohne Rückfrage importieren". Nicht alle Methoden sind für eine Rückfrage sinnvoll, beispielsweise erzeugt jeder Scan derselben Papiervorlage unterschiedliche Dokumentdateien.

ConfirmDuplicate=. deaktiviert alle Rückfragen.


DocGroupByField

Navigation: »Kein übergeordnetes Kapitel«

DocGroupByField

DocGroupByField

In der mobilen App werden die abgefragten Dokumente standardmäßig nach den Dokumenttypen sortiert und gruppiert. Das für die Gruppierung verwendete Datenfeld kann aber auch in der admin.ini angepasst werden:

[MobileServer]

DocGroupByField=category

Sinnvoll sind Datenfelder mit Auswahllisten, wie beispielsweise category, state oder project.


FindDuplicateByFileName

Navigation: »Kein übergeordnetes Kapitel«

FindDuplicateByFileName

FindDuplicateByFileName

In den Importprofilen kann eingestellt werden, dass nur neue Dateien importiert und Dubletten somit verhindert werden.

Die Funktion sucht dabei standardmäßig über den Hashwert nach inhaltsgleichen Dateien, die bereits im Archiv enthalten sind.

Es gibt aber eine Situation, in der die Dublettenprüfung besser über die Dateinamen erfolgt: bei der Synchronisierung des Archivs mit dem Dokumentenverzeichnis. Wenn beispielsweise von einer anderen Anwendung neue Dateien in das Office Manager-Dokumentenverzeichnis kopiert wurden und Sie diese in das Archiv importieren möchten, dann gehen Sie bitte wie folgt vor:

1.Stellen Sie sicher, dass die Dateien beim Import nicht kopiert oder verschoben werden. Legen Sie dazu ein Importprofil für das Dokumentenverzeichnis an und stellen Sie die Dateioperation auf "Dateien im Quell-Verzeichnis belassen". Aktivieren Sie "Nur neue Dokumentdateien importieren".

2.Fügen Sie folgende erweiterte Einstellung in die admin.ini ein:
[Import]
FindDuplicateByFileName=1

3.Starten Sie das Programm neu und wählen Sie den Import-Befehl auf der Erstellen-Menüseite. Aktivieren Sie "Nur neue Dokumentdateien importieren".

Hinweise

Die Option wirkt sich nur auf den Import aus und nicht auf die nachträgliche Dublettensuche.

Die Dublettenprüfung erfolgt normalerweise zweimal: beim Zusammenstellen der Dateiliste und direkt vor dem Import. Dies ist beim Dateinamenvergleich nicht nötig.


IndexAttachments

Navigation: »Kein übergeordnetes Kapitel«

IndexAttachments

IndexAttachments

Bei der Volltextindexierung von E-Mails und komprimierten Dateiarchiven (*.zip u. a.) werden auch die Dateianlagen indexiert, sodass eine Volltextsuche in diesen Anlagen möglich ist.

Mit folgendem Eintrag in der admin.ini können Sie die Indexierung der Anlagen deaktivieren:

[FullTextIndex]

IndexAttachments=0

Siehe auch

OCR für Dateianlagen


LockMode

Navigation: »Kein übergeordnetes Kapitel«

LockMode

LockMode

Mit LockType können Sie festlegen, welche Art von Sperre beim Bearbeiten von Datensätzen verwendet wird: pessimistisch, optimistisch oder keine.

Mit folgendem Eintrag in der Datenbankverbindungsdatei legen Sie die Sperre fest. Die .omcs, .crmcs bzw. .aplcs-Datei können Sie mit einem Texteditor.

[ConnectionOptions]

LockMode=3

Mögliche Werte:

0: keine Sperrung
1: Pessimistic, pessimistische Sperre, soweit vom Datenbanksystem unterstützt. Anderenfalls wird das optimistische Sperren verwendet.
2: Optimistic, optimistische Sperre auf Datensatzbasis. Ein Datensatz wird nur gesperrt, wenn Aktualisierungen eingetragen werden und er davon betroffen ist.


RegApplInAutoImp

Navigation: »Kein übergeordnetes Kapitel«

RegApplInAutoImp

Verfügbar in diesen Editionen

RegApplInAutoImp

Der Verzeichnisüberwachung und der Massenimport berücksichtigen standardmäßig nur Dateien, für die eine Anwendung registriert ist. Dies ist in der Regel gewollt, um das Archiv vor unerwünschten Dateien zu schützen. Falls Sie alle Dateien importieren möchten, können Sie eine automatische Registrierung von Dokumenttypen erzwingen.

"RegApplInAutoImp=1" aktiviert die automatische Registrierung von noch unbekannten Dateiendungen.

"DefaultAppl" legt einen bereits vorhandenen Dokumenttypen für alle Importvorgänge fest, der verwendet wird, wenn die Dateiendung auch unter Windows nicht registriert ist.

Änderungen geben Sie bitte in der admin.ini ein:

[Import]

RegApplInAutoImp=1

DefaultAppl=Sonstige


SendToMailAllowZIP

Navigation: »Kein übergeordnetes Kapitel«

SendToMailAllowZIP

SendToMailAllowZIP

Beim Senden von Dokumenten an E-Mail-Empfänger werden Dateianlagen eventuell gezippt. Im Prinzip werden die Dateien in ZIP-Archive gepackt, wenn "es sich lohnt".

Falls Sie dies nicht wünschen, können Sie das automatische Zippen deaktivieren. Tragen Sie dazu bitte folgenden Eintrag in die admin.ini ein:

[Document]

SendToMailAllowZIP=0

Tipp, wenn Sie nur gelegentlich ungezippt mailen möchten: Sie können auch eine E-Mail in Ihrem Mail-Client erstellen und die Anlagen vom Office Manager per Drag&Drop oder über die Zwischenablage in die E-Mail kopieren.


SpeedUp

Navigation: »Kein übergeordnetes Kapitel«

SpeedUp

SpeedUp

Wenn beim Dokumenten-Import beispielsweise das Projekt aus der Verzeichnisstruktur ermittelt wird und dieses noch nicht vorhanden ist, kann es vom Programm automatisch der Auswahlliste hinzugefügt werden. Bei sehr umfangreichen Liste ist dies zeitaufwendig. Mit aktiver SpeedUp-Option werden die Listen während des Importvorgange nicht aktualisiert, sondern nur einmal nach Anschluss des Imports. Wenn Sie, wie empfohlen, Auswahllisten mit flacher Struktur und wenigen Einträgen nutzen, dann ist die Beschleunigung kaum zu merken. Falls Sie aber z. B. tausende Einträge im Projektnavigator haben, dann kann ein Unterschied von einer Sekunde zu einer Minute je Dokument entstehen.

Beachten Sie in einer Netzwerkumgebung, dass andere Benutzer die Erweiterungen dann erst nach Importende sehen können.

Sie können die Beschleunigung in der admin.ini aktivieren:

[Import]

SpeedUp=1


TodoLabelColor

Navigation: »Kein übergeordnetes Kapitel«

TodoLabelColor

TodoLabelColor

In der mobilen App können Anwendende von unterwegs Aufgaben zu den Dokumenten hinzufügen. Die erweiterte Einstellung "TodoLabelColor" in der admin.ini legt fest, ob und wie diese Aufgaben im Terminplaner hervorgehoben werden:

[MobileServer]

TodoLabelColor=8689404

Mögliche Werte

Geben Sie den Farbwert der Hervorhebung an:

6610596: Persönlich
7649020: Teilnahmepflicht
7661308: Anruf
8689404: Wichtig
8703700: Vorbereitung
12897956: Jubiläum
13952740: Urlaub
14982788: Business
16033476: Geburtstag
16051844: Reise erforderlich


UseDebenuPDF

Navigation: »Kein übergeordnetes Kapitel«

UseDebenuPDF

UseDebenuPDF

Für die Volltextsuche wird der Text aus dem Dokument extrahiert und in den Index der Archivdatenbank geschrieben. Die Konvertierung von PDF-Dokumenten in Textdaten erfolgt seit Version 23.1 standardmäßig mit programminternen Funktionen.

Dokumentenlayout beibehalten

In seltenen Fällen ist neben der Textinformation aber auch das Dokumentenlayout interessant. Beispielsweise muss bei der Dokumentenerkennung mit AutoCaptFindMask der gesuchte Wert neben dem Schlüsselwort stehen:

Rechnungsnr. 12345

Lieferdatum: 29.01.2025

Kundennr. 5678

Bei einem tabellarischen PDF-Layout wird der Text aber ev. folgendermaßen extrahiert:

Rechnungsnr.

Lieferdatum:

Kundennr.

12345

29.01.2025

5678

In so einem Fall kann auf eine alternative Funktion mit der Debenu-DLL zum Lesen des Textes umgestellt werden. Fügen Sie dazu folgenden Eintrag in die admin.ini ein:

[FullTextIndex]

UseDebenuPDF=1


AcceptorMachines

Navigation: »Kein übergeordnetes Kapitel«

AcceptorMachines

Verfügbar in diesen Editionen

AcceptorMachines

Die erweiterte Einstellung AcceptorMachines enthält eine punktgetrennte Liste mit den Namen der Computer, die das Verzeichnis überwachen. Wenn diese Einstellung in der admin.ini vorgenommen wurde, ist die Überwachung auf allen nicht genannten Computern deaktiviert.

[DirWatch]

AcceptorMachines=.rechner1.rechner2.


AllowCancel

Navigation: »Kein übergeordnetes Kapitel«

AllowCancel

AllowCancel

Mit der erweiterten Einstellung "AllowCancel=0" können sie verhindern, dass der Anwender die Übernahme einer Datei aus der Verzeichnisüberwachung oder dem Faximport abbricht. Die Schalter Verwerfen und Abbrechen werden dann im Fenster "Eigenschaften" deaktiviert.

Hinweis: Diese Option ist nur sinnvoll, wenn die Einstellung Eigenschaftendialog öffnen aktiviert ist (Einstellungen, Seite Importieren).
Der Administrator kann die Übernahme immer abbrechen.

Nehmen Sie die Einstellung bitte in der admin.ini vor.

Für die Verzeichnisüberwachung

Verfügbar in diesen Editionen

[DirWatch]

AllowCancel=0

Für den Faximport

Verfügbar in diesen Editionen

[ImportFax]

AllowCancel=0


AllowOwnerToUnlock

Navigation: »Kein übergeordnetes Kapitel«

AllowOwnerToUnlock

Verfügbar in diesen Editionen

AllowOwnerToUnlock

Mit der erweiterten Einstellung "AllowOwnerToUnlock=0" wird auch dem Besitzer das Einchecken eines Dokuments untersagt. Die Freigabe kann dann nur noch vom DMS-Administrator vorgenommen werden.

Nehmen Sie die Einstellung bitte in der admin.ini vor:

[Secure]

AllowOwnerToUnlock=0

Das Ein- und Auschecken sind erweiterte Funktionen der Enterprise-Edition. Hierzu werden DMS-Funktionen über das Status-Attribut gesperrt.

Siehe auch

Office Manager Developer Network


AutoSearchDelay

Navigation: »Kein übergeordnetes Kapitel«

AutoSearchDelay

AutoSearchDelay

Gibt die Verzögerung der automatischen Suche an. Mit folgendem Eintrag in der admin.ini können Sie die Zeitverzögerung in Millisekunden angeben, Standard ist 700 = 0,7 Sekunden:

[Optimize]

AutoSearchDelay=1000


CharsetAdd

Navigation: »Kein übergeordnetes Kapitel«

CharsetAdd

CharsetAdd

Bei der Standard-Volltextindexierung werden alle Zeichen akzeptiert, die gemäß Unicode-Spezifikation als Buchstabe und ggf. als Zahl definiert sind.
Alle anderen Zeichen werden als Worttrennung interpretiert.

Mit folgendem Eintrag in der admin.ini können Sie beispielsweise das Pluszeichen als gültiges Zeichen definieren:

[FullTextIndex]

CharsetAdd=+

Gültigkeit

Diese Einstellung wirkt sich nur auf die Standardvolltextsuche aus. Sie wird in SQLite-Archiven (.omsl, .omen) immer ignoriert sowie in MS SQL-Archiven, wenn die Server-Volltextsuche aktiviert ist.

Einschränkungen

Es sind nicht alle Zeichen möglich, Punkt und Ausrufezeichen sind z. B. immer Trennzeichen. Der Bytewert muss innerhalb 1 und 127 liegen. Folgende Zeichen sind z. B. im deutschen Gebietsschema möglich: "#$%&'()*+,-/:;<=>?@[\]^_`{|}~

Wenn Sie den Bindestrich als gültiges Zeichen definieren, dann kann dieser nicht mehr als Joker für die NOT-Suche verwendet werden.

Siehe auch

Eine Auflistung der aktuell akzeptierten Zeichen finden Sie im Menü Datei | Information auf Seite Datenbanken | Volltextindex.


CompareAccessRights

Navigation: »Kein übergeordnetes Kapitel«

CompareAccessRights

Verfügbar in diesen Editionen

CompareAccessRights

Nach dem Setzen der Dokument-Zugriffsrechte überprüfen, ob diese erfolgreich übernommen wurden.

0: Überprüfung deaktivieren (Standardeinstellung)

1: Überprüfung aktivieren

Sie können den Modus mit einem Eintrag in der admin.ini ändern:

[Secure]

CompareAccessRights=1


ConvBWMode

Navigation: »Kein übergeordnetes Kapitel«

ConvBWMode

ConvBWMode

Erweiterte Einstellung für die Bild-Konvertierung in schwarz/weiß. Eine Änderung hat Auswirkung auf die erweiterte Scan-Funktion In schwarz/weiß konvertieren und die Scanprofil-Option In schwarz/weiß konvertieren.

Sie können die Einstellungen in der admin.ini ändern:

[Image]

ConvBWMode=-2

Mögliche Werte:

0 bis 255: manueller Grenzwert für weiß oder schwarz (Threshold-Methode). 1)
-1: automatischer Grenzwert für weiß oder schwarz (Threshold-Methode).
-2: automatischer Grenzwert mit Maximum-Entropie-Methode. Dies ist der Standardwert.

-10: Floyd-Steinberg Algorithmus. 2)

-11: Dithering Ordered-Methode. 2)

-20: Lokale Threshold-Methode für einzelne Bildausschnitte, Modus gering. 3)

-21: Lokale Threshold-Methode, Modus Mittelwert. 3)

-22: Lokale Threshold-Methode, Modus Min/Max. 3)

1) größere Werte ergeben ein dunkleres Bild, für sehr helle Vorlagen sind Werte zwischen 180 und 220 geeignet

2) das Ergebnis ist einem Graustufenbild ähnlich, für OCR und Barcode nicht geeignet

3) sehr langsam, ergibt eher dunkle Bilder


DefaultSearchMode

Navigation: »Kein übergeordnetes Kapitel«

DefaultSearchMode

DefaultSearchMode

Legt den Vergleichsmodus für die Dokumenten-Suche in einzeiligen Textfeldern fest.

0: exakte Übereinstimmung

1: beginnt mit (Standardeinstellung)

2: enthält

Sie können den Modus mit einem Eintrag in der admin.ini ändern:

[Database]

DefaultSearchMode=2

Die Einstellung bezieht sich nur auf die Suche in Textfeldern.

Siehe auch

Dokumente suchen

Primäre Suchfelder

Oder-verknüpfte Suche

Steuerzeichen "$"


DeleteOmftiFile

Navigation: »Kein übergeordnetes Kapitel«

DeleteOmftiFile

DeleteOmftiFile

Die Volltextindexierung erstellt für einige Dateiformate eine temporäre Textdatei mit der Endung .omfti (z. B. "Datei.doc.omfti" im Verzeichnis des Dokuments). Diese Datei wird nach der Indexierung wieder gelöscht. Während einer Testphase kann es sinnvoll sein, die Dateien nicht zu löschen. Geben Sie dazu bitte folgenden Eintrag in der admin.ini ein:

[FullTextIndex]

DeleteOmftiFile=0

Siehe auch

OmftiPath


DeleteOrphanedFolder

Navigation: »Kein übergeordnetes Kapitel«

DeleteOrphanedFolder

DeleteOrphanedFolder

Diese erweiterte Einstellung verhindert verwaiste Unterverzeichnisse im Dokumentenordner. Sobald eine Dokumentdatei gelöscht oder verschoben wird, prüft das Programm, ob das Verzeichnis anschließend noch Daten beinhaltet.

Ein Ordner wird gelöscht, wenn er leer ist oder nur noch folgende Dateien beinhaltet:

·*.~pdf: Sicherungskopien der OCR-Texterkennung,

·Thumbs.db: Chache-Datei der Windows-Miniaturansichten,

·desktop.ini: Darstellungsoptionen eines Verzeichnisses.

Beachten Sie bitte, dass ein Löschen nicht immer möglich ist. Beispielsweise kann dies durch Zugriffsberechtigungen des Verzeichnisses verhindert werden oder durch noch vorhandene Dateien, die mit dem aktuellen Benutzerkonto nicht sichtbar sind.

Tragen Sie folgende Zeile in der admin.ini ein, um die Funktion zu aktivieren:

[Document]

DeleteOrphanedFolder=1

Der Wert 1 steht für aktiv. Bei 0 oder, wenn die Option nicht vorhanden ist, dann wird die Funktion deaktiviert.

Siehe auch

Freeware-Programm zum Aufspüren und Löschen leerer Windows-Verzeichnisse.


DocCombinDefLinkName

Navigation: »Kein übergeordnetes Kapitel«

DocCombinDefLinkName

Verfügbar in diesen Editionen

DocCombinDefLinkName

Vorgabe-Verknüpfungsname für neue Dokument-Kombinationen. Wenn Sie Dokumente miteinander verknüpfen, dann wird für neue Verknüpfungen ein Name vorgeschlagen (z. B. "20093101 123011123"). Sie können den Vorgabenamen aber auch in der admin.ini festlegen. Sinnvoll ist beispielsweise die Belegnummer des aktuellen Dokuments.

Im Buchhaltungsarchiv empfehlen wir das Buchungsjahr gefolgt von der Belegnummer oder der Schlüsselnummer, falls die Belegnummer leer ist.

[Document]

DocCombinDefLinkName={Doc:Project}-{GetFirstNotEmpty:{Doc:DocNo},{Doc:DocID}}

Oder für eine Suche ohne Rekursion mit schlankerem Suchergebnis

DocCombinDefLinkName=#{Doc:DocID}}-{Doc:Project}-{Doc:DocNo}


DocTypeIgnoreDFEF

Navigation: »Kein übergeordnetes Kapitel«

DocTypeIgnoreDFEF

DocTypeIgnoreDFEF

Wenn die Option Vorgabe gilt auch für bestehende Dateien aktiviert ist, können einzelne Dokumenttypen von dieser Option ausgeschlossen werden. Tragen Sie dazu die Bezeichnung der Dokumenttypen als punktgetrennte Liste in der admin.ini ein:

[Document]

DocTypeIgnoreDFEF=.Internet.AutoCAD.


Syntax der Versions-Dateinamen

Navigation: »Kein übergeordnetes Kapitel«

Syntax der Versions-Dateinamen

Verfügbar in diesen Editionen

DocVersFileName

Diese erweiterte Einstellung legt die Syntax der Dateinamen von Dokumentversionen fest. Tragen Sie bitte die gewünschte Syntax mithilfe der Makrovariablen in der admin.ini ein:

[Document]

DocVersFileName={Doc:FileName,NoExt}_Vers{DocVers:DocVers}.{Doc:FileName,FileExt}

Sie sollten anschließend den Datei-Importfilter entsprechend anpassen, damit die Dateiversionen beim Import ignoriert werden.


FileNameAllowChar

Navigation: »Kein übergeordnetes Kapitel«

FileNameAllowChar

FileNameAllowChar

Mit dieser erweiterten Einstellung können mehrfache Leerzeichen und folgende Sonderzeichen in Dateinamen zulassen:

[];.=

Der Punkt ist normalerweise nur einmal als Trennung zwischen Dateiname und -Endung erlaubt. Tragen Sie ein oder mehrere Zeichen in der admin.ini ein:

[Document]

FileNameAllowChar=;.

Mehrfache Leerzeichen

Ab Version 15.0 werden mehrfache Leerzeichen durch ein einfaches ersetzt. Falls Sie aus Kompatibilitäts- oder anderen Gründen, im Dateinamen mehrere Leerzeichen hintereinander zulassen möchten, können Sie "ms" für "multiple spaces" hinzufügen. Achten Sie auf die Kleinschreibung. Folgender Beispieleintrag in der INI erlaubt Semikolon, Punkt und mehrfache Leerzeichen:

[Document]

FileNameAllowChar=;.ms

Ändern Sie diese Einstellung bitte nicht willkürlich und halten Sie Rücksprache mit dem Support.


HandledEvents

Navigation: »Kein übergeordnetes Kapitel«

HandledEvents

Verfügbar in diesen Editionen

HandledEvents

Die Verzeichnisüberwachung reagiert, wenn Dateien neu erstellt oder umbenannt wurden. Umbenennen, weil manche Anwendungsprogramme beim Erstellen neuer Dokumente zuerst in eine temporäre Datei schreiben und diese anschließend in die Dokumentdatei umbenennen.

Sie können in der admin.ini eine punktgetrennte Liste mit den zu behandelnden Ereignissen angeben:

[DirWatch]

HandledEvents=.1.2.3.4.5.

1: neue Datei
2: gelöschte Datei (reserviert)
3: geänderte Datei (reserviert)
4: umbenennen von
5: umbenennen in

Um nur auf neue Dateien zu reagieren, geben Sie bitte "HandledEvents=.1." an, um nur auf umbenannte zu reagieren "HandledEvents=.4.". Achten Sie bitte auf die Punkte vor und nach der Zahl. Um wieder auf alle Ereignisse zu reagieren, löschen Sie bitte den Eintrag aus der INI oder schreiben Sie ein Semikolon davor.


HttpProxy

Navigation: »Kein übergeordnetes Kapitel«

HttpProxy

HttpProxy

Mit dieser erweiterten Einstellung können Sie einen Proxy-Server für den Internetzugriff des Update-Programmes (webupdate.exe) definieren. Das Hauptprogramm om.exe nutzt diese Einstellung seit Version 15.0.1.508 nicht mehr.

Standardmäßig wird die Einstellung des Internet-Explorers (Registry HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings) verwendet. Mit einem Eintrag in der admin.ini kann dieses überschrieben werden. Syntax "Adresse:Port" oder "Adresse:Port:User:Password".

[Admin]

HttpProxy=123.123.123.123:80:User:Password


IgnoreOmExt

Navigation: »Kein übergeordnetes Kapitel«

IgnoreOmExt

Verfügbar in diesen Editionen

IgnoreOmExt

Die erweiterte Einstellung IgnoreOmExt enthält eine punktgetrennte Liste mit Office Manager-Dateiendungen, die beim Import als normale Dokumentdatei behandelt und ohne Rückfrage importiert werden sollen. Dies ist sinnvoll, wenn Sie regelmäßig Dokumente importieren, welche die gleiche Endung wie ein Office Manager-Dateityp haben.

Änderungen geben Sie bitte in der admin.ini ein:

[Import]

IgnoreOmExt=.lay.itm.


SkewDetect

Navigation: »Kein übergeordnetes Kapitel«

SkewDetect

SkewDetectAngle
SkewDetectWidth

Erweiterte Einstellung der Schräglagenkorrektur gescannter Seiten.

ImgSkewDetectWidth gibt an, ob die gesamte Seitenbreite ausgewertet werden soll: 1=gesamte Breite, 2=halbe Breite, 3=drittel Breite usw. Der Standardwert ist 2. Beim erweiterten Algorithmus ("Schnell" ist im Scanprofil nicht markiert) wird unabhängig von dieser Einstellung immer die gesamte Seite ausgewertet.

ImgSkewDetectAngle definiert den zu berücksichtigen Winkel: 5 korrigiert bis zu +/- 2,5° Schräglage, 10 korrigiert bis zu +/- 5° usw. Der Standardwert ist 5.

Sie können die Einstellung in der admin.ini ändern:

[Image]

SkewDetectAngle=5

SkewDetectWidth=1

Je kleiner die Werte sind, desto schneller ist die Funktion.


FileListEx

MaxFileListCount und FileListEx

Navigation: »Kein übergeordnetes Kapitel«

MaxFileListCount und FileListEx

Verfügbar in diesen Editionen

MaxFileListCount

Die Verzeichnisüberwachung muss Dateien ignorieren, die vom Office Manager selbst erstellt oder verschoben wurden. Hierzu werden die Namen aller vom Programm erzeugten Dateien in einer internen Liste gespeichert. Die Liste enthält standardmäßig maximal 40 Einträge, Sie können die Anzahl mit folgendem Eintrag in der admin.ini ändern:

[DirWatch]

MaxFileListCount=150

Eine Erhöhung des Wertes ist sinnvoll, wenn die Verzeichnisüberwachung Dateien importieren möchte, die vom Office Manager selbst erstellt oder verschoben wurden. Dies könnte beispielsweise durch die Attribut-Änderung vieler Dokumente ausgelöst werden, wenn die Option Vorgabe gilt auch für bestehende Dateien aktiviert ist.

Beachten Sie aber bitte auch, dass ein sehr hoher Wert zu Lasten der Performance geht.

FileListEx

Wenn aktiviert, werden die Dateien auch beim Öffnen der Liste hinzugefügt:

[DirWatch]

FileListEx=1


OcrCreateBackup

Navigation: »Kein übergeordnetes Kapitel«

OcrCreateBackup

OcrCreateBackup

Vor Ausführung einer OCR-Texterkennung wird vom PDF-Dokument eine Sicherungskopie (*.~pdf) erstellt.

Sie können dies mit folgendem Eintrag in der admin.ini deaktivieren:

[FullTextIndex]

OcrCreateBackup=0

Siehe auch

Hotline-Blog OCR-Sicherungskopien


OcrTransymOpt

Navigation: »Kein übergeordnetes Kapitel«

OcrTransymOpt

OcrTransymOpt

Erweiterte Optionen für die Transym OCR-Software.

Sie können die Einstellungen mit folgendem Eintrag in der admin.ini ändern:

[FullTextIndex]

OcrTransymOpt=1

Mögliche Werte:

·1 verhindert das Drehen der Grafik in die Textausrichtung,


OleToTxt

Navigation: »Kein übergeordnetes Kapitel«

OleToTxt

OleToTxt

Sofern möglich, werden die Dokumentdateien vor der Volltextindexierung in eine temporäre Textdatei gespeichert. Hierdurch wird die Indexierung enorm beschleunigt. Die Konvertierung erfolgt mittels OLE-Automatisierung.

Sollte die Konvertierung zu Problemen führen, kann sie mit folgendem Eintrag in der admin.ini deaktiviert werden:

[FullTextIndex]

OleToTxt=0


OmftiPath

Navigation: »Kein übergeordnetes Kapitel«

OmftiPath

OmftiPath

Die Volltextindexierung erstellt für einige Dateiformate eine temporäre Textdatei mit der Endung .omfti (z. B. "Datei.doc.omfti" im Verzeichnis des Dokuments). Diese Datei wird nach der Indexierung wieder gelöscht.

Voraussetzung hierfür sind Schreibrechte der Anwender im Verzeichnis der Dokumente, da die .omfti erstellt und geändert wird. Falls die Schreibrechte fehlen bzw. die Dokumente auf einem schreibgeschützten Laufwerk gespeichert sind, können Sie in der admin.ini einen alternativen Pfad definieren:

[FullTextIndex]

OmftiPath=T:\OmFti\

Beim Indexieren des Dokuments "G:\Daten\Projekt\Kategorie\Brief.doc" würde dann die temporäre Datei "T:\OmFti\G\Daten\Projekt\Kategorie\Brief.doc" erstellt.

Alternativ kann auch ein UNC-Pfad verwendet werden. Geben Sie den Pfad immer mit abschließendem Backslash an.

Siehe auch

DeleteOmftiFile


OpenNewDocuments

Navigation: »Kein übergeordnetes Kapitel«

OpenNewDocuments

OpenNewDocuments

Wenn Sie innerhalb des DMS-Programms ein neues Dokument erstellen, dann wird es anschließend automatisch geöffnet. Falls dies nicht gewünscht ist, dann können Sie das automatische Öffnen deaktivieren.

Tragen Sie dazu bitte folgende erweiterte Einstellung in die globale Konfigurationsdatei admin.ini ein:

[Document]

OpenNewDocuments=0


OpenShellCommand

Navigation: »Kein übergeordnetes Kapitel«

OpenShellCommand

OpenShellCommand

Bis Office Manager Version 9.0 wurde zum Öffnen von Dokumenten der Befehl "open" an die Windows Shell-Funktion übergeben. Ab Version 10.0 wird der Parameter NULL (leerer String) verwendet. Dadurch wird der in Windows als Standard definierte Befehl aufgerufen, was dem Verhalten des Windows-Explorers bei Doppelklick auf eine Datei entspricht.

Sie können die Einstellung in der admin.ini ändern. Sinnvoll ist i. d. R. nur "open":

[Document]

OpenShellCommand=open

Siehe auch

Dokumenttypen

Makro-Funktion ShellExecute


PdfPageMode

Navigation: »Kein übergeordnetes Kapitel«

PdfPageMode

PdfPageMode

PageMode der vom Office Manager erstellten Acrobat-Dokumente (z. B. vom Scannen).

Mögliche Werte:

0 = Normal view (Vorgabewert)

1 = Show the outlines pane

2 = Show the thumbnails pane

3 = Show the document in full screen mode

Nehmen Sie die Einstellung bitte in der admin.ini vor:

[Document]

PdfPageMode=2


QuickPdfDpi

Navigation: »Kein übergeordnetes Kapitel«

QuickPdfDpi

QuickPdfDpi

Auflösung des internen PDF-Viewers in DPI. Der Standardwert ist 72, geben Sie bitte einen höheren Wert ein, um die Auflösung zu verbessern. Geben Sie bitte nicht mehr als nötig ein. Ab 300dpi wird sehr viel Speicher verbraucht!

Nehmen Sie die Einstellung bitte in der admin.ini vor:

[Document]

QuickPdfDpi=100


QuoteChar

Navigation: »Kein übergeordnetes Kapitel«

QuoteChar

QuoteChar

Anführungszeichen, mit denen die Zeichenwerte bei SQL-Abfragen eingeschlossen sind.

' Einfache Anführungszeichen. Dies ist der Standardwert, wenn keine Angabe für QuotedChar in der admin.ini vorhanden ist. Dieser Wert ist nach dem SQL-Standard vorgesehen. Beispiel:
SELECT * FROM DOCUMENT WHERE PROJECT = 'Prinzenallee'
" Doppelte Anführungszeichen. Beispiel:
SELECT * FROM DOCUMENT WHERE PROJECT = "Prinzenallee"

Achtung:

Fügen Sie diesen Eintrag nur in die admin.ini ein, wenn das verwendete Datenbanksystem nicht mit dem Standardwert arbeitet.

Wenn Sie ein Zeichen angeben, das von der Datenbank nicht als Anführungszeichen interpretiert wird, werden keine Datenabfragen mehr korrekt durchgeführt. Eine Vielzahl von Fehlermeldungen wäre die Folge.

Die Angabe QuoteChar= ohne eine Zeichen führt zu einer Fehlermeldung beim Programmstart! Löschen Sie in diesem Fall den Eintrag aus der admin.ini.


ScriptControl

Navigation: »Kein übergeordnetes Kapitel«

ScriptControl

TimeOut

TimeOut des Microsoft-ScriptControls in Millisekunden oder "-1", um den TimeOut zu deaktivieren. Der Standardwert ist 10000 = 10 Sekunden.

UseSaveSubset

Sicheren Modus aktivieren (=1) oder deaktivieren (=0). Der sichere Modus ist standardmäßig deaktiviert, aber ggf. von der Windows-Version abhängig.

Nehmen Sie die Einstellungen bitte in admin.ini vor:

[ScriptControl]

TimeOut=-1

UseSafeSubset=1

Siehe auch

Entwicklerhilfe

Makro-Funktion ScriptControlSetOption


SearchOperatorOR

Navigation: »Kein übergeordnetes Kapitel«

SearchOperatorOR

SearchOperatorOR

Operator für die Oder-verknüpfte Suche, Standardwert "OR". Die Eingabe von "prinzenalle OR office manager" im Suchfeld Projekt gibt beispielsweise alle Dokumente zurück, die dem Projekt "prinzenallee" oder "office manager" zugeordnet sind.

Sie können den Operator mit einem Eintrag in der admin.ini ändern:

[Database]

SearchOperatorOR=<<OR>>

Siehe auch

DefaultSearchMode


SysChar2WildCard

Navigation: »Kein übergeordnetes Kapitel«

SysChar2WildCard

SysChar2WildCard

Bei inkompatiblen Zeichensätzen eines SQL-Datenbankservers kann es vorkommen, dass Abfragen mit deutschen Umlauten und anderen Sonderzeichen keine Dokumente finden. In diesem Fall können alle Sonderzeichen für die Abfrage in den SQL-Joker "_" umgewandelt werden. Geben Sie folgenden Eintrag in der admin.ini ein:

[Database]

SysChar2WildCard=1

Beachten Sie bitte, dass durch die Nutzung der Jokerzeichen die Abfragen langsamer werden.


SysThreadInterval

Navigation: »Kein übergeordnetes Kapitel«

SysThreadInterval

SysThreadInterval

Das Programm prüft in regelmäßigen Abständen, ob Systemaufgaben zu erledigen sind. Mit folgendem Eintrag in der admin.ini können Sie das Prüfungsintervall einstellen:

[Database]

SysThreadInterval=60000

Die Einheit ist 1000tel Sekunde, der Standardwert 60000 entspricht einer Minute.


TiffOcrTag

Navigation: »Kein übergeordnetes Kapitel«

TiffOcrTag

TiffOcrTag

Gibt den Speicherort des OCR-Textes in einer TIFF-Datei in.

Werte 1 bis 19: der erkannte Text wird vom Office Manager in der TIFF-Datei gespeichert. Wert -1: der Text wird nur für die Indexierung temporär in einer *.omfti gespeichert.

Nehmen Sie den Eintrag bitte in der admin.ini vor:

[FullTextIndex]

TiffOcrTag=10


UpdateOnActivate

Navigation: »Kein übergeordnetes Kapitel«

UpdateOnActivate

UpdateOnActivate

Im Volltextindex-Modus Index über alle Datenfelder und Dokumente prüft der Office Manager, ob sich das Dokument geändert hat und neu indexiert werden muss. Die Prüfung wird durchgeführt, sobald das Programm wieder aktiviert (in den Vordergrund gebracht) wurde. Sie können diese Prüfung mit folgendem Eintrag in der admin.ini deaktivieren:

[FullTextIndex]

UpdateOnActivate=0

Die Index-Aktualisierung müssen Sie dann manuell starten.


UseAutoInc

Navigation: »Kein übergeordnetes Kapitel«

UseAutoInc

UseAutoInc

Das Datenfeld WORDID in der Tabelle FTIWORD kann als Aufzählungsfeld (AutoInc) oder normales numerisches Feld definiert werden.

Mit AutoInc: die Word-Schlüsselnummern werden direkt von der Datenbank hoch gezählt.

Ohne AutoInc: die Word-Schlüsselnummern werden vom Programm mit Hilfe der Tabelle IDENTNO hoch gezählt.

Sie können die Option mit folgendem Eintrag in der admin.ini einstellen (1=mit AutoInc, 0=ohne AutoInc):

[FullTextIndex]

UseAutoInc=1

Die Änderung wirkt sich nur für neue Archivdatenbanken aus.


UseSearchWords

Navigation: »Kein übergeordnetes Kapitel«

UseSearchWords

UseSearchWords

Bei der Suche im Volltextindex werden alle Wörter ignoriert, die in der Stopwords-Liste enthalten sind. In seltenen Fällen kann es aber auch sinnvoll sein, mit einer "Suchwortliste" zu arbeiten: es werden dann alle Wörter ignoriert, die nicht in der Liste enthalten sind. Genauer ausgedrückt: es werden nur die Wörter indexiert, die mit einem Wort der Suchliste beginnen!

Sie können die Suchwortliste mit folgendem Eintrag in der admin.ini aktivieren:

[FullTextIndex]

UseSearchWords=1

Das Programm muss neu gestartet und der Index neu erstellt werden, wenn Sie diese Option ändern.

Die Liste wird in der Datei "searchword.lst" gespeichert.

Beispiel für die Suche mit Suchwortliste:

Wenn sich das Wort "schreib" in der Suchwortliste befindet, werden alle Wörter indexiert, die mit "schreib" beginnen. Beispielsweise: Schreibtisch, schreiben und schreibfaul.


WarningExecuteCount

Navigation: »Kein übergeordnetes Kapitel«

WarningExecuteCount

WarningExecuteCount

Das gleichzeitige Öffnen mehrerer Dokumente kann eventuell viel Zeit beanspruchen. Um zu verhindern, dass der Anwender ungewollt (durch unbeabsichtigten Klick auf eine Schaltfläche o.ä.) 15 oder mehr Dokumente gleichzeitig öffnet, muss dies besonders bestätigt werden.

Sie können den Vorgabewert von 15 ändern. Tragen Sie dazu bitte den gewünschten Grenzwert in der admin.ini ein:

[Document]

WarningExecuteCount=20


JBIG2-Komprimierung

Navigation: »Kein übergeordnetes Kapitel«

JBIG2-Komprimierung

Ungeeignete Bildkompression

Bild-Komprimierungsverfahren (z. B. JBIG2) mit "Symbol Coding" bzw. "Pattern Matching & Substitution" sind für die Dokumentenarchivierung nicht geeignet.

Bei dieser Komprimierung werden wiederkehrende Muster im Bild nur einmal gespeichert und mehrfach verwendet. Identische Bereiche, beispielsweise einzelne Buchstaben oder Zahlen, die mehrfach vorkommen, sind nach einem Scan aber nicht mehr pixelgenau identisch. Der Komprimierungsalgorithmus muss also eine gewisse Abweichung zulassen und ähnliche Pixelmuster als gleich betrachten. Im Ergebnis kann dies dazu führen, dass grafisch ähnliche Buchstaben und Zahlen untereinander ausgetauscht werden, aus einer 8 kann dann beispielsweise eine 6 werden:

Ein möglicher (hier nachgestellter) Kompressionsfehler

Wichtig: Der Fehler entsteht nicht bei der Texterkennung, sondern tatsächlich im Pixelbild.

Eine gute Beschreibung und Hintergrundinformationen finden Sie im Blog dkriesel.com

Für ersetzendes Scannen verboten

Das Bundesamt für Sicherheit in der Informationstechnik (BSI) hat diese Bildkompression am 16.03.2015 in der Technische Richtlinie 03138 Ersetzendes Scannen untersagt. Zitat:

"Beim Scannen MUSS auf die Auswahl geeigneter Bildkompressionsverfahren geachtet werden. Als grundsätzlich geeignet werden sowohl verlustfreie als auch verlustbehaftete Verfahren angesehen. Verfahren, die zur Bildkompression das sog. "Symbol Coding" verwenden, DÜRFEN NICHT eingesetzt werden."

Siehe BSI TR 03138 RESISCAN, A.SC.12 – Auswahl geeigneter Bildkompressionsverfahren.

Scanner-Einstellungen anpassen

Deaktivieren Sie derartige Komprimierungsverfahren bitte am Scanner. Prüfen Sie alte Scans und laden Sie eine aktuelle Firmware auf das Gerät. Sollten Sie Xerox Workcentre verwenden, dann beachten Sie bitte o. g. Blog-Artikel.

Bestehende Dokumente prüfen

In Archiven mit GoBD-Modus können Sie die Funkion Datei | Datenbank | Pflege | GoBD-Prüfung verwenden, um Dokumente mit diesem Kompressionsverfahren zu suchen. Aktivieren Sie vorher bitte in den Programmeinstellungen auf Seite Dokument | Revision die Option Warnung für ungeeignete Kompressionsverfahren.


KI - Künstliche Intelligenz

Navigation: »Kein übergeordnetes Kapitel«

KI - Künstliche Intelligenz

Verfügbar in diesen Editionen

Microsoft Azure Dienste

Office Manager DMS beinhaltet neben den flexiblen GPT-Funktionen auch eine Schnittstelle zu den Online-Diensten "Maschinelles Lernen" von Microsoft:

·Formularerkennung für Rechnungen und andere Belege,

·OCR- und ICR-Texterkennung für gedruckte Texte und Handschriften.

Voraussetzungen

Sie benötigen Office Manager Pro oder Enterprise ab Version 23.0 sowie ein Microsoft-Konto für Azure-Dienste. Da die Daten zur Auswertung an eine Drittanbieter-Cloud (Microsoft) übergeben werden, prüfen Sie bitte, ob der Datenschutz dies in Ihrem besonderen Fall zulässt. Für die Nutzung der Cloud-Funktionen können zusätzliche Kosten entstehen.

KI-Funktionen einrichten

Azure Cloud

1.Melden Sie sich bitte im Azure-Portal unter https://portal.azure.com/ an.

2.Klicken Sie auf Ressource erstellen und markieren Sie links die Kategorie "KI + Machine Learning".

3.Die Texterkennung finden Sie unter "Maschinelles Sehen" bzw. "Computer vision", die Formularerkennung (FormRecognizer) unter "Document intelligence".

4.Achten Sie auf die Region und wählen Sie einen Server in Deutschland bzw. in Ihrem Land.

OCR im DMS aktivieren

1.Die Einstellung der OCR (Text- bzw. Handschriftenerkennung) finden Sie im Menü Datei | Optionen | Einstellungen auf der Seite Volltextindex | OCR.

2.Wählen Sie "Azure Read Cloud-OCR/ICR" im Kombinationsfeld OCR-Software und klicken Sie auf den Mausschalter Optionen.

3.Geben Sie die API-Adresse (URL) und den Schlüssel für den Zugriff auf Ihre Cloud-Funktionen ein. Sie finden diesen im Azure-Portal unter dem Punkt "Keys and Endpoints".

Formularerkennung und Dokumentenanalyse

Die Formularerkennung können Sie in den Scan- und Importprofilen verwenden, um neue Belege von der KI beschreiben zu lassen.

1.Wählen Sie in Office Manager DMS den Menübefehl Datei | Optionen | Einstellungen und wechseln Sie zur Seite Profile unterhalb von Scannen oder Importieren.

2.Erstellen Sie ein neues Profil oder öffnen Sie ein vorhandenes.

3.Auf der Registerseite Feldwerte finden Sie das Kombinationsfeld Dokumentenerkennung. Hier können mehrere Erkennungsmethoden aktiviert werden; für die KI markieren Sie bitte "Azure Form Recognizer (Cloud)".

4.Klicken Sie auf den Schalter Optionen und geben Sie die API-Adresse sowie den Schlüssel ein. Sie finden diese im Azure-Portal unter dem Punkt "Keys and Endpoints".

5.Die Option Erkannte Rohdaten zeigen ist während der Entwicklungs- und Testphase des Erkennungsprofils hilfreich, sollte für den Normalbetrieb aber deaktiviert sein.

6.Tipp: Mit den Mausschaltern Kopieren und Einfügen lassen sich die Optionen einfach zwischen verschiedenen Profilen austauschen.

7.Standarddaten, wie das Belegdatum werden immer von der Auswertung übernommen.

8.Zusätzlich können Sie den einzelnen Datenfeldern die erkannten Daten zuweisen. Wählen Sie dazu in der Tabelle Daten für einzelne Felder ermitteln beim gewünschten Feldnamen den Eintrag "{AutoCaptAzureAI:PfadZumWert}" aus der Liste und ersetzen Sie "PfadZumWert" mit der entsprechenden Azure-Variablen (s. o. "Erkannte Rohdaten zeigen").
Zum Beispiel "{AutoCaptAzureAI:analyzeResult.documents[0].fields.CustomerAddressRecipient.valueString}" für den Kundennamen auf einer Rechnung.

Hinweis: Wenn Sie eine E-Mail importieren, dann wird, sofern vorhanden, die anliegende PDF-Datei an die Formularerkennung übergeben. Azure kann die Mail selbst nicht verarbeiten.


Layoutdesigner-Optionen

Navigation: »Kein übergeordnetes Kapitel«

Layoutdesigner-Optionen

Layoutdesigner-Optionen

Klicken Sie im Fenster des Layoutdesigners bitte auf den Schalter Optionen, um folgende Einstellungen vor zu nehmen:

Größe der Textfelder anpassen
Die Größe der Textfelder (Label) wird automatisch an die Schriftgröße angepasst.

Größe der Eingabefelder anpassen
Die Größe der Eingabefelder (Edit) wird automatisch an die Schriftgröße angepasst.

Liste der Datenfelder sortieren
Sortiert die Liste der Datenbankfelder alphabetisch.

Automatische Höhe des Suchfeld-Bereichs 1)
Wenn diese Option markiert ist, wird der Bereich der primären Suchfelder automatisch in der Höhe angepasst, sodass alle enthaltenen Eingabefelder sichtbar sind. Die Funktion wird beim Laden des Layouts ausgeführt und nicht sofort nach der Aktivierung im Layoutdesigner.

Hauptmenü im Layout speichern
Speichert die Einstellungen der Menüs im archivabhängigen Layout, sodass diese für alle Anwender fest vorgegeben werden (nur in Enterprise-Version und nur im Dokumentenlayout verfügbar).

Hauptmenü aus Layout löschen
Benutzerdefiniertes Hauptmenü aktivieren.

Fenstergröße zurücksetzen
Sie können die Größe des Programmfensters mit der Maus ändern und in der Layoutdatei speichern. Wählen Sie diesen Befehl, um die Größe wieder auf Standard zu setzen. Die Werte werden dann aus der Layoutdatei gelöscht.

Hilfe
Öffnet diese Hilfeseite.

1) nur im Layout der Suchfelder sichtbar


Kombinationsfeld "Dokumenttyp" ist leer

Navigation: »Kein übergeordnetes Kapitel«

Kombinationsfeld "Dokumenttyp" ist leer

Kein Dokumenttyp vorhanden

Wenn Sie im Office Manager ein neues Dokument erstellen, dann müssen Sie im Eigenschaftendialog den Dokumenttyp, wie Word, Adobe Acrobat o. a. angeben. In manchen Situationen kann es vorkommen, dass kein geeigneter Dokumenttyp vorhanden ist.

Ist die Anwendungsdatenbank geöffnet?

Prüfen Sie bitte im Menü Datei | Information auf Seite Dokumenttyp, ob die Anwendungsdatenbank geöffnet ist. Wählen Sie ggf. im Menü Datei den Befehl Archiv öffnen und öffnen Sie die Datei "appl.apl".
Ggf. hilft auch ein Programmneustart, weil die Datenbank beim Start automatisch geöffnet wird.

Tritt das Problem bei der Übernahme von Internetadressen auf?

Registrieren Sie bitte einen Internet-Browser, Menü Datei | Optionen | Dokumenttyp.

Tritt das Problem beim Scannen auf?

Definieren Sie bitte Dokumenttypen für PDF, TIFF und andere Grafikformate, die Sie verwenden möchten (Menü Datei | Optionen | Dokumenttyp). Wenn Sie OCR-Texterkennung einsetzen, müssen Sie vor allem den Grafiktypen registrieren, der von Ihrer OCR-Software unterstützt wird.

Tipp

Zum schnellen Registrieren von Dokumenttypen können Sie auch eine Datei des gewünschten Typs per Drag&Drop vom Explorer in den Office Manager importieren. Der Dokumenttyp wird dann automatisch registriert, wenn ausreichend Informationen in der Windows-Registrierdatenbank vorhanden sind.


Lexware Export

Navigation: »Kein übergeordnetes Kapitel«

Lexware Export

Starten Sie bitte den Buchhalter und prüfen Sie, ob die entsprechende Firma und das Buchungsjahr aktiviert sind. Wählen Sie im Menü Datei | Export den Befehl Text/ASCII. Wenn Sie den Export zum ersten Mal durchführen, dann achten Sie bitte darauf, dass Sie die Einstellungen aus den folgenden Screenshots übernehmen. Beim nächsten Export wählen Sie einfach das Profil "Office Manager".

Export Buchungsdaten: Auswahl

Buchungsdaten exportieren

Export Buchungsdaten: Datei und Zeitraum

Zeitraum und Zieldatei festlegen, z. B. "Eigene Dateien\Buchhalter 2007".

Export Buchungsdaten: Feldauswahl

Alle Felder für den Export wählen.

Export Buchungsdaten: Einstellungen

Trennzeichen Tab, keine Text-Kennzeichner, Feldnamen in den ersten Datensatz.

Profil für den nächsten Export anlegen

Siehe auch

Mit Buchhaltung synchronisieren

Entwicklernetzwerk: Beschreibung der Datei LxBuchhalter.ini


Lizenzmodelle

Navigation: »Kein übergeordnetes Kapitel«

Lizenzmodelle

Wenn Sie Office Manager kaufen, erhalten Sie eine zeitlich unbefristete Nutzungslizenz. Es handelt sich um eine Softwareüberlassung durch Kauf.

Enterprise-Edition: Concurrent-User-Lizenzmodell

Die Anzahl der gekauften Programmlizenzen legt fest, wie viele Anwender gleichzeitig mit dem Office Manager arbeiten können.

Wenn diese Anzahl verbraucht ist, können Sie sich nicht mehr am Office Manager anmelden. Sie müssen warten, bis sich ein anderer Anwender abmeldet.

Pro-Edition: Named-User-Lizenzmodell

Die Anzahl der gekauften Programmlizenzen legt fest, wie viele Anwender absolut mit dem Office Manager arbeiten können, Sie benötigen eine Lizenz für jeden Computer.

Wenn die Lizenzanzahl verbraucht ist, können sich keine weiteren Anwender mehr anmelden.

Tipp: Erwerben Sie ausreichende Lizenzen, damit dieses Problem nicht auftritt.


Datensätze in Speicher laden

Navigation: »Kein übergeordnetes Kapitel«

Datensätze in Speicher laden

Alle Dokumentdatensätze in den Arbeitsspeicher laden
(Menü Ansicht | Tabelle | Datensätze in Speicher laden).

Wenn diese Option markiert ist, werden alle Dokumentdatensätze der aktuellen Suche in den Arbeitsspeicher geladen. Die Suche nach Dokumenten kann dadurch -je nach Computer und Dokumentanzahl- beschleunigt, aber auch verlangsamt werden. Es wird mehr Arbeitsspeicher benötigt.

Vorteil: Wenn die Option markieren, können Sie die Dokumenttabelle gruppieren und sortieren.

Diese Einstellung ist benutzerspezifisch.


Condition

Navigation: »Kein übergeordnetes Kapitel«

Condition

Details zum Parameter "Condition".

Operatoren

Condition erlaubt die Operatoren =, <>, < und >.

Zwischen Groß- und Kleinschreibung wird nicht unterschieden.

Die Operatoren '=' und '<>' vergleichen den Text: '01' ist dabei ungleich '1'.
'<' und '>' sind nur für ganze Zahlen erlaubt: '01' ist dabei gleich '1'.

Platzhalter

Beim Textvergleich mit = oder <> können Sie im rechts vom Operator stehenden Wert die Jokerzeichen Stern und Fragezeichen verwenden: * steht als Platzhalter für beliebig viele Zeichen (auch für keines) und ? für ein einzelnes.

Bei vorhandenem Platzhalter wird mit einer Maske verglichen. Im rechts vom Operator stehenden Wert sind dann literalen Zeichen, Mengen und Platzhalter möglich. Beispielsweise "[0-9]" für eine Ziffer oder "[A-Z]" für einen Buchstaben.

Reserviertes Wort IsAutoFileName

'IsAutoFileName=' oder 'IsAutoFileName<>' prüft, ob der folgende Text mit "[automatisch]" oder einer übersetzen Variante, wie "[automatic]", beginnt bzw. nicht beginnt. Beachten Sie aber bitte, das auch "IsAutoFileName=IsAutoFileName" true ergibt.

Hiermit kann beispielsweise ein Makro sowohl für den Import als auch für bereits vorhandene Dokumente verwendet werden:

{SetPrivVar:MyFileName={IfThen:IsAutoFileName={Doc:FileName},{Source},{Doc:FileName}}}

Siehe auch

Makro-Referenz

Bedingte Ausführung

DBCheckFieldValue

Exit

IfThen

RaiseError


CLSID

Navigation: »Kein übergeordnetes Kapitel«

CLSID

CSIDL_FLAG_CREATE ($8000), Version 5.0

CSIDL_ADMINTOOLS ($0030), Version 5.0

CSIDL_ALTSTARTUP ($001d)

CSIDL_APPDATA ($001a), Version 4.71

CSIDL_BITBUCKET ($000a)

CSIDL_CDBURN_AREA ($003b), Version 6.0

CSIDL_COMMON_ADMINTOOLS ($002f), Version 5.0

CSIDL_COMMON_ALTSTARTUP ($001e)

CSIDL_COMMON_APPDATA ($0023), Version 5.0

CSIDL_COMMON_DESKTOPDIRECTORY ($0019)

CSIDL_COMMON_DOCUMENTS ($002e)

CSIDL_COMMON_FAVORITES ($001f)

CSIDL_COMMON_MUSIC ($0035), Version 6.0

CSIDL_COMMON_PICTURES ($0036), Version 6.0

CSIDL_COMMON_PROGRAMS ($0017)

CSIDL_COMMON_STARTMENU ($0016)

CSIDL_COMMON_STARTUP ($0018)

CSIDL_COMMON_TEMPLATES ($002d)

CSIDL_COMMON_VIDEO ($0037), Version 6.0

CSIDL_COMPUTERSNEARME ($003d)

CSIDL_CONNECTIONS ($0031)

CSIDL_CONTROLS ($0003)

CSIDL_COOKIES ($0021)

CSIDL_DESKTOP ($0000)

CSIDL_DESKTOPDIRECTORY ($0010)

CSIDL_DRIVES ($0011)

CSIDL_FAVORITES ($0006)

CSIDL_FLAG_DONT_UNEXPAND ($2000)

CSIDL_FLAG_DONT_VERIFY ($4000)

CSIDL_FONTS ($0014)

CSIDL_HISTORY ($0022)

CSIDL_INTERNET ($0001)

CSIDL_INTERNET_CACHE ($0020), Version 4.72

CSIDL_LOCAL_APPDATA ($001c), Version 5.0

CSIDL_MYDOCUMENTS ($000c), Version 6.0

CSIDL_MYMUSIC ($000d)

CSIDL_MYPICTURES ($0027), Version 5.0

CSIDL_MYVIDEO ($000e), Version 6.0

CSIDL_NETHOOD ($0013)

CSIDL_NETWORK ($0012)

CSIDL_PERSONAL ($0005), Version 6.0

CSIDL_PHOTOALBUMS ($0045), Windows Vista

CSIDL_PLAYLISTS ($003f), Windows Vista, typically username\My Music\Playlists.

CSIDL_PRINTERS ($0004)

CSIDL_PRINTHOOD ($001b)

CSIDL_PROFILE ($0028), Version 5.0

CSIDL_PROGRAM_FILES ($0026), Version 5.0

CSIDL_PROGRAM_FILES_COMMON ($002b), Version 5.0

CSIDL_PROGRAMS ($0002)

CSIDL_RECENT ($0008)

CSIDL_RESOURCES ($0038), Windows Vista

CSIDL_SAMPLE_MUSIC ($0040), Windows Vista

CSIDL_SAMPLE_PLAYLISTS ($0041), Windows Vista

CSIDL_SAMPLE_PICTURES ($0042), Windows Vista

CSIDL_SAMPLE_VIDEOS ($0043), Windows Vista

CSIDL_SENDTO ($0009)

CSIDL_STARTMENU ($000b)

CSIDL_STARTUP ($0007)

CSIDL_SYSTEM ($0025), Version 5.0

CSIDL_TEMPLATES ($0015)

CSIDL_WINDOWS ($0024), Version 5.0


Beispiel Formatparameter Separate

Navigation: »Kein übergeordnetes Kapitel«

Beispiel Formatparameter Separate

Beispiele zu den Formatparametern Separate und SeparateName

Die Formatparameter geben Teile eines Dateinamen oder Textes zurück.

Beispiel 1

Der Dateiname des aktuellen Dokuments lautet "C:\Dokumente\Angebot-Müller-Berlin.doc". Folgende Makrovariablen geben "Berlin" zurück:

{Doc:FileName,SeparateName,-,3} (3 = der dritte Teil von vorne)

{Doc:FileName,SeparateName,-,3,} (der dritte Teil von vorne oder leer, falls '-' nicht vorkommt)

{Doc:FileName,SeparateName,-,-1} (-1 = der erste Teil von hinten)

Beispiel 2

Das Datenfeld "Name" beinhaltet den Text "Softwarebüro Krekeler". Folgende Variable gibt "Softwarebüro" zurück:

{Doc:Name,Separate, ,1}


Manipulationssicherheit

Navigation: »Kein übergeordnetes Kapitel«

Manipulationssicherheit

GoBD-Modus und Blockchain

Office Manager beinhaltet als professionelle Archivierungssoftware Funktionen für die Revisionssicherheit. Dies bedeutet

·die Vermeidung unzulässiger Änderungen an archivierten Dokumenten.

·Die Nachvollziehbarkeit zulässiger Änderungen, wie beispielsweise das Verschlüsseln oder Signieren sowie die Versionsverwaltung bei nachträglichen Korrekturen.

·Die Bestätigung, wenn ein Dokument unverändert ist.

·Eine Fehlerausgabe in der Revision, wenn ein Dokument manipuliert wurde.

GoBD-Modus für Buchhaltungsarchive

Hierbei werden alle Dokumente des Archivs schreibgeschützt - einmal erfasste Dokumente sind unveränderbar. Wenn eine Korrektur nötig ist, weil beispielsweise eine veraltete Kundenanschrift auf einer Rechnung steht, kann diese mit der korrigierten Rechnung ersetzt werden. Die ursprüngliche bleibt aber unverändert als Version bestehen. Manipulationen mit administrativen Funktionen bzw. "Tricks" sind möglich, fallen aber bei einer Revisions auf.

Wenn ein Prüfer die Dokumentenrevision durchführt, kann er den Werdegang eines jeden Dokuments einsehen und beispielsweise vorhandenen Versionen überprüfen. Die Revision weist auf alle besonderen Vorkommnisse hin, nicht nachvollziehbare Änderungen werden als Manipulation gemeldet.

Blockchain für einzelne wichtige Dokumente

Datei-Checksummen (Hash) auf der manipulationssicheren Blockchain hinterlegen. Dies bringt den technischen Beweis, seit wann ein Dokument unverändert vorhanden ist und bietet vielfältige Möglichkeiten, wie beispielsweise im Urheberrecht.


Dateiimport automatisieren

Der Massenimport (Menü Erstellen | Importieren | Importieren) kann auch automatisch gestartet werden. Dies ist z. B. sinnvoll, wenn Sie das Dokumentenarchiv regelmäßig mit den Dateien auf den Datenträgern abgleichen möchten. Das Dokumentenmanagement kann hierzu von einer Batch-Datei oder dem Windows-Programm "Geplante Tasks" mit dem Parameter "ImportPath"gestartet werden:

Beispiel

Alle neuen Dateien im Verzeichnis "g:\Daten" sollen nachts automatisch in das Archiv "G:\DB\Archiv.omp" importiert werden:

C:\Program Files\..\om.exe G:\DB\Archiv.omsl /ImportPath=G:\Daten

Es werden auch Unterverzeichnisse durchsucht. Die Funktion importiert nur Dateien, die im Archiv noch nicht vorhanden sind. Eine ev. aktivierte automatische Hinterlegung auf der Blockchain wird deaktiviert.

Um mehrere Quellverzeichnisse anzugeben, trennen Sie diese bitte mit einem Komma.


Mausrad

Durch Drehen des Mausrades wird ein Bildlauf in geeigneten Komponenten durchgeführt.

Das Verhalten können Sie in den Programmeinstellungen auf Seite Ansicht Ihren eigenen Wünschen anpassen:

·Die Option Mausrad scrollt die Komponente unter der Maus ist markiert: Zum Scrollen zeigen Sie bitte mit der Maus auf die gewünschte und drehen Sie das Mausrad.

·Die Option ist nicht markiert: Klicken Sie die gewünschte Komponente an, sodass diese den Fokus hat. Scrollen Sie anschließend mit Hilfe des Mausrades. Dieses Verhalten entspricht dem Windows-Standard.


Maximale Dokumentenanzahl

Navigation: »Kein übergeordnetes Kapitel«

Maximale Dokumentenanzahl

Verfügbar in diesen Editionen

Maximal N Dokumente zurückgeben

Menü Datei | Optionen | Einstellungen, nur Enterprise-Edition.

Das Laden von vielen Tausend Datensätzen verbraucht unnötig Rechenzeit und Arbeitsspeicher. Es ist in der Regel auch nicht sinnvoll, ein sehr großes Archiv vollständig abzufragen.

Sie können hier die Anzahl der Dokumentdatensätze angeben, die dem Anwender bei einer Archivrecherche maximal zurückgegeben wird.

Sinnvoll ist ein Wert von 1000 oder auch mehreren Tausend.

Für das Zurücksetzen auf 0 (keine Beschränkung) muss die Archivdatenbank neu geladen oder das Programm neu gestartet werden.

Einmalig alle Daten abrufen

Anwender können bei Bedarf alle Datensätze abrufen, indem Sie über der Tabelle den Link "n Dokumente (von gesamt m)" anklicken. Die Suche wird dann einmal ohne die Beschränkung ausgeführt.

Für Pflegearbeiten als Administrator anmelden

Wenn Sie als Programm-Administrator angemeldet sind, werden unabhängig von dieser Einstellung alle Datensätze geladen. Für manche Pflegearbeiten ist es erforderlich, alle Daten zu laden - melden Sie sich also vorher als Administrator an (Datei | Optionen | Administrator) und führen Sie die Dokumentensuche erneut aus.


MegaCAD-Befehle

Benutzerdefinierte Befehle für MegaCAD

Der Einrichtungsassistent für MegaCAD erstellt folgende benutzerdefinierbare Befehle:

·Neu: erstellt Schriftköpfe für neue Zeichnungen.

·Plotten: öffnet die markierte Zeichnung im MegaCAD-Plotprogramm.

·Bauteil einfügen: fügt ein Bauteil (eh. Makro) in die geöffnete Zeichnung ein.

·Exportieren: exportiert eine MegaCAD-Zeichnung und konvertiert sie in das DXF- oder DWG-Format.

·ImportDxfDwg: konvertiert eine DXF- oder DWG-Datei in MegaCAD-Zeichnung.

·SendTo: konvertiert MegaCAD-Zeichnungen in das DXF- und DWG-Format.

·ExecuteCad: startet MegaCAD.

·ExecutePlot: startet das Plotprogramm.

Beispiel: der Befehl SendTo

Der Exportbefehl ermöglicht die automatische Konvertierung einer MegaCAD-Zeichnung in das DXF- oder DWG-Format. Wenn Sie im Office Manager eine MegaCAD-Zeichnung markiert haben und auf Senden an klicken, können Sie den Dateityp PRT, DXF oder DWG wählen. Wenn Sie nun DXF wählen, wird die Zeichnung im Hintergrund in eine DXF-Datei konvertiert.


Fritz!Box einrichten

Fritz!Box für Mobile Server einrichten

Navigation: »Kein übergeordnetes Kapitel«

Fritz!Box für Mobile Server einrichten

Diese Einstellung ist erforderlich, damit die sich die Mobile App von unterwegs mit dem heimischen Office Manager verbinden kann.

Port-Weiterleitung konfigurieren

1.Starten Sie bitte einen Browser und geben Sie "http://fritz.box" oder dessen IP-Nummer ein. Melden Sie sich mit Ihrem Kennwort an der Benutzeroberfläche an.

2.Klicken Sie links in der Navigationleiste auf Internet und dann auf den Unterpunkt Freigaben.

3.Wechseln Sie rechts zur Seite Portfreigaben - vermutlich ist diese Seite aber bereits vorgewählt.

4.Klicken Sie auf den Mausschalter Neue Portfreigabe:
FRITZ!BOX Dialog für Portfreigabe

5.Prortfreigabe aktiv für "Andere Anwednung", eine beliebige Bezeichnung, Protokoll "TCP".

6.Bei von Port und an Port bitte den Wert aus Office Manager Computer-Port eingeben.
Der erste Wert beschreibt den eingehenden Port, also den in der App eingegebenen. Der untere ist der Port des Zielcomputers. Diese müssen also nicht zwangsläufig gleich sein, sollten es zu Gunsten der besseren Übersicht aber.

7.In der Liste an Computer bitte den Computer wählen, auf dem der Office Manager läuft.

8.Mit OK speichern.

Dynamisches DNS einrichten

Mit der FRITZ!Box können Sie auch sehr einfach das dynamische DNS einrichten. Dies ist erforderlich, damit Ihr Office Manager-PC dauerhaft von der App erreicht werden kann. Siehe hierzu unter www.myfritz.net

Öffnen Sie, wie zuvor, den Knoten Internet | Freigaben. Wechseln Sie zur Registerseite Dynamic DNS, klicken Sie auf den Schalter Hilfe und folgen Sie der Anleitung. Falls die Registerseite nicht vorhanden ist, dann benötigen Sie ein Update der Fritz-Software.

Geben Sie Ihre myfritz.net-Adresse anschließend in der mobilen App, Seite Einstellungen bei Host ein.


Dokument bereits vorhanden

Dokument bereits im Archiv vorhanden

Beim Import eines Dokuments wurde festgestellt, dass dieses bzw. ein identisches bereits im Archiv enthalten ist. Klicken Sie auf

·Ja, um es trotzdem zu importieren, auf

·Nein, um das Dokument zu überspringen (nicht zu importieren) oder auf

·Alle Nein, um in diesem Importvorgang mit mehreren noch folgenden Dokumenten alle bereits vorhandenen zu überspringen.

Siehe auch Blog-Artikel: Ist die Datei bereits im Archiv?

Hintergrundinformation

Beim Import ermittelt das Programm eine Checksumme der Datei und sucht in der Datenbank nach identischen Summen. Wenn diese vorhanden sind, wird zusätzlich der Dateiinhalt verglichen. Der Hinweis erscheint also für alle identischen Dokumentdateien, außer:

"Mail mit derselben Message-ID"

Wenn die Rückfrage mit diesem Text beginnt, dann wurde keine identische Datei gefunden, aber eine Mail mit derselben "Message-ID". Dies kommt z. B. vor, wenn die Mail zuvor von einem anderen Arbeitsplatz archiviert wurde. Die Mail-Datei ist dann nicht unbedingt identisch, weil die E-Mail-Clients eigene Informationen hinzufügen.

Diese zusätzliche Abfrage erfolgt nur, wenn das Datenfeld MAILMSGID vorhanden ist.

Zukünftig ohne Rückfrage importieren

Wenn beim Import nicht nach bereits vorhandenen Dokumenten gesucht werden soll, dann können Sie die Einstellungen anpassen:

1.Menü Datei | Optionen | Einstellungen, Seite Importieren | Profile.

2.Doppelklicken Sie auf das gewünschte Profile, z. B. Standard oder E-Mail.

3.Deaktivieren Sie auf Seite Allgemein die Option Nur neue Dokumentdateien importieren und bestätigen Sie die Änderung mit OK.


ELOoffice Import

Navigation: »Kein übergeordnetes Kapitel«

ELOoffice Import

Wenn Sie im Öffnen-Dialog den Dateifilter "ELOoffice 9" wählen, dann wird immer ein ELO-Import versucht.

Haben Sie aber den allgemeinen Filter "Unterstützte Formate" oder "'MS Access" angegeben, dann wird vorab geprüft, ob es sich um eine ELO-Archivdatenbank handelt. Wenn ja, dann können Sie den Import entsprechend wählen:

·Klicken Sie auf Ja, wenn Sie das Archiv aus ELOoffice 9.0 mit den Dokumenten importieren möchten. Dies ist empfohlen und der Regelfall.

·Wenn Sie die Rückfrage mit Nein beantworten, wird ein normaler Datenbankimport gestartet. Dies ist nur in Ausnahmefällen sinnvoll, wenn Sie einzelne Daten aus einer Tabelle importieren möchten oder die Datenbank falsch erkannt wurde.

·Abbrechen: Jetzt nicht importieren.

Siehe auch Datenbankimport


Nachträgliche Dokumentenerkennung

Navigation: »Kein übergeordnetes Kapitel«

Nachträgliche Dokumentenerkennung

Verfügbar in diesen Editionen

Hintergrundinformation

Dokumente werden in der Archivdatenbank mit mehreren Eigenschaften beschrieben, um diese zum Beispiel schnell zu finden und die Aufbewahrungsfristen festzulegen. Eigenschaften sind unter anderem der Dokumentenname, das Belegdatum, eine Kategorie und das Projekt oder Buchungsjahr. Diese Daten können manuell eingegeben oder automatisch erkannt werden.

Ihre DMS-Lösung bietet mehrere Methoden, um Dokumente automatisch zu beschreiben. Dies spart viel Fleißarbeit bei der täglichen Archivierung. Die Analyse und Erkennung erfolgt in der Regel bereits beim Erfassen der Dokumente, die Erkennungsalgorithmen werden in den Import- und Scanprofile festgelegt.

Es besteht aber auch die Möglichkeit, um bereits archivierte Dokumente beschreiben zu lassen. Beispielsweise

·Kontakte zuordnen, weil dies bisher nicht geschehen ist,

·bereits vorhandene Digitalfotos mit der neue KI-Funktion katalogisieren,

·den Gesamtbetrag u. ä. aus elektronischen Rechnungen lesen.

Beachten Sie aber die Einschränkungen in revisionssicheren GoBD-Archiven.

Erkennung nachträglich ausführen

Markieren Sie die zu erkennenden Dokumente in der Tabelle und wählen Sie den Menübefehl Bearbeiten | Dokument | Erkennen | Dokumentenerkennung.

Das Dialogfenster "Dokumentenerkennung" wird eingeblendet:

Optionen für die Dokumntenerkennung festlegen

Auszuführende Algorithmen

Legen Sie fest, welche Funktionen ausgeführt werden sollen. Wenn genau ein Dokument markiert ist, dann sind nur die für dieses Dokument geeigneten wählbar. Bei mehreren markierten werden einzelne Algorithmen nur ausgeführt, sofern diese für das jeweilige Dokument sinnvoll sind.

·Standard sucht im Text nach einem Belegdatum, dem passendem Kontakt und in allen Auswahllisten nach Treffern.

·Elektronische Rechnung verarbeitet XRechnung sowie ZUGFeRD und übernimmt wichtige Rechnungsdaten.

·GPT - Generative Pre-trained Transformer analysieren die Textdokumente oder Bilder und geben die gewünschten Dokumenteigenschaften zurück.

Optionen

Nur Daten übernehmen, die bisher noch leer sind: Die Erkennung gibt Daten für einzelne Datenfelder des Archivs zurück. Wenn diese Option markiert ist, dann werden die erkannten Daten nur in die jeweiligen Datenfelder kopiert, wenn diese noch leer sind. Ist beispielsweise die Kategorie bereits angegeben, dann würde eine andere erkannte Kategorie nicht übernommen.

Vorschau mit Rückfrage vor der Datenübernahme: Sie werden nach der Dokumentenanalyse gefragt, ob Sie die erkannten Daten akzeptieren.

Mausschalter

OK startet die Dokumentenanalyse.

Abbrechen schließt das Dialogfenster.

Hilfe öffnet diese Dokumentation.


Neues Datenbankformat

Diese Meldung erhalten Sie nach der Installation eines Programmupdates, oder wenn Sie eine ältere Datenbank öffnen.

Das Dokumentenarchiv, die Kontakt- oder Anwendungsdatenbank muss für die neue Office Manager DMS-Version konvertiert werden. Klicken Sie bitte auf Update, um die Datenbank anzupassen. Vorab sollten auch eine Sicherungskopie erstellen.

Wenn ein Passwort für die Administratorebene vergeben ist, dann können Sie sich als Administrator anmelden, um nicht für jede Datenbank das Kennwort eingeben zu müssen.

Siehe auch

Updatehinweise

Support zur Softwareaktualisierung

Neuigkeiten in Version 25.0


OCR für Dateianlagen

Navigation: »Kein übergeordnetes Kapitel«

OCR für Dateianlagen

Verfügbar in diesen Editionen

Texterkennung auch für Dateianlagen ausführen

Datei | Optionen | Einstellungen, Seite Volltextindex | OCR

Die Dateianlagen von E-Mails und ZIP-Archiven werden grundsätzlich für die Volltextsuche indexiert. Wenn Sie beispielsweise eine PDF-Rechnung per E-Mail erhalten, dann können Sie auch nach dem Text dieser Rechnung suchen.

Falls Sie regelmäßig E-Mails mit gescannten Dateianlagen erhalten, dann können Sie zusätzlich diese Option aktivieren. Sie ist aber nur für gescannte Dokumente nötig und sinnvoll, wenn noch keine Texterkennung ausgeführt wurde.

Beachten Sie bitte, dass diese Option den Import von E-Mails spürbar verlangsamt.

Funktionsablauf

Beim Import einer E-Mail oder eine ZIP-Datei in das Archiv werden alle enthaltenen Dateianlagen extrahiert und ausgewertet. Für TIFF-Dateien und PDF-Dokumente wird während des Imports die OCR-Texterkennung ausgeführt. Der erkannte Text wird mit in die Datenbank aufgenommen, die Dateianlagen bleiben aber unverändert. OCR wird bei jeder Indexierung des Dokuments erneut ausgeführt.

Siehe auch

Einstellungen OCR

Erweiterte Einstellung IndexAttachments

Volltextindex prüfen, welche Texte wurden erfasst?


Office Manager Testversion

Dieses Programm ist nicht kostenlos. Es handelt sich vielmehr um eine eingeschränkte Testversion, die Sie 30 Tage kostenlos testen können. Ferner gibt es Sonderausgaben der Testversion, die keine zeitliche Einschränkung haben, dafür aber nur eine begrenzte Anzahl von Dokumenten verwalten können.

Beim Programmstart können Sie festlegen, ob Sie den Office Manager als Pro- oder Enterprise-Edition ausführen möchten, klicken Sie dazu bitte auf Testen (Enterprise) oder Testen (Pro).

Wählen Sie bitte im Bearbeiten Hilfe | Internet den Befehl Version registrieren, um jetzt online einen Freischaltcode für die uneingeschränkte Vollversion zu bestellen.

Siehe auch

Registrierung der Testversion


Vorlagendateien

Navigation: »Kein übergeordnetes Kapitel«

Vorlagendateien

Vorlagendateien (Menü Datei | Optionen | Dokumenttyp)

Jedem Dokumenttyp können mehrere Vorlagendateien zugeordnet werden. Wenn Sie ein Dokument erstellen, können Sie die gewünschte Vorlagendatei wählen.

Für den Dokumenttyp "Word" können Sie beispielsweise eine Vorlage "Brief" erstellen, in der bereits Ihr Firmen-Schriftkopf und der Grundaufbau des Briefes enthalten ist. Wenn Sie ein neues Dokument für "Word" erstellen und die Vorlage auswählen, ist die Grundstruktur des neuen Briefes bereits fertig. Sie können also Vorlagen für alle Standard-Dokumente (Brief, Angebot, Rechnung, Zeichnung, ...) erstellen.

Beachten Sie bitte, dass Vorlagen immer im Format der Dokumente vorliegen müssen. Bei Word sind dies beispielsweise ".doc"-Dateien und keine ".dot"!

Wenn beim Erstellen eines neuen Dokumentes keine Vorlage ausgewählt ist, wird die Standardvorlage (soweit vorhanden) verwendet. Beachten Sie bitte auch, dass manche Windows-Programme immer eine Vorlagendatei benötigen, wenn ein neues Dokument erstellt werden soll. In diesem Fall müssen Sie eine Standardvorlage definieren, auch wenn diese nur ein leeres Dokument ist.

Standardvorlage

Klicken Sie auf die Schaltfläche Durchsuchen hinter den Eingabefeldern, um das Kontextmenü zu öffnen, und wählen Sie:

·Keine Vorlagendatei: Es wird keine Vorlage verwendet. Beachten Sie bitte, dass Windows-Standardanwendungen immer eine Vorlagendatei benötigen. Wenn Sie keine Vorlagendatei verwenden, darf auf der Seite Anwendung nicht die Option "Windows-Standardanwendung verwenden" gewählt sein.

·Leere Datei (NullFile): Es wird eine leere Datei erzeugt. Diese Option wird z. B. für den Windows-Editor (Notepad.exe) verwendet.

·Windows-Standard: Diese Option steht nur zur Verfügung, wenn entsprechende Informationen in der Windows-Registrierdatenbank vorliegen. Wählen Sie diese Option, um die Standardeinstellung für dieses Anwendungsprogramm zu verwenden.

·Vorlagendatei wählen: Wählen Sie im Dateidialog eine Vorlagendatei aus. Diese Option ist sinnvoll, wenn Sie z. B. für einen spezielle Dokumenttyp wie Brief, Fax, Zeichnung eine vorbereitete Datei als Vorlage verwenden möchten.

Weitere Vorlagen

Erstellen Sie für alle Standarddokumente, die mit dieser Anwendung bearbeitet werden, eine Vorlage. So können Sie sehr schnell Briefe, Angebote u. a. erstellen.

Siehe auch

Dokumentvorlagen


Optionale Makrobefehle

Navigation: »Kein übergeordnetes Kapitel«

Optionale Makrobefehle

Bei der Dokumentenerfassung mit Importprofilen, beim Scannen mit Profilen und beim Erstellen neuer Dokumente aus Vorlagen können Makros für die Automatisierung von Arbeitsabläufen ausgeführt werden.

Optionale Makrobefehle

Auf der Optionsseite Makros stehen vier Eingabefelder für optionale Makros zur Verfügung:

·Vor Hinzufügen: Befehle, die vor dem Import der Dokumentdatei und vor einer eventuellen Stapeltrennung ausgeführt werden. Hier sind beispielsweise automatisierte Änderungen oder Überprüfungen der Datei sinnvoll.

·Nach Hinzufügen: Wird nach dem Hinzufügen (append) des Archivdatensatzes und vor dem Öffnen des Eigenschaftendialogs ausgeführt. Hier werden beispielsweise makrogesteuerte Attributvorgaben definiert.
Die Auswertung der Makrovariablen, welche auf der Seite Feldwerte hinterlegt sind, erfolgt bereits vor der Ausführung dieser Makros.

·Vor Speichern: Wird direkt nach Klick auf OK im Eigenschaftenfenster und noch vor dem Speichern des Datensatzes im Archiv ausgeführt.

·Nach Speichern: Makrobefehle, die nach dem Speichern in die Datenbank ausgeführt werden. Die Datei wurde zu diesem Zeitpunkt ggf. schon in das Dokumentenverzeichnis verschoben. Hier kann beispielsweise die Systemaufgabe für eine nachträgliche OCR-Texterkennung erstellt werden (siehe unten).

Zusätzlich bei den Importprofilen

Nachträgliche OCR-Texterkennung

Bei der Definition von Importprofilen können Sie "OCR-Texterkennung" im Kombinationsfeld Nach Speichern auswählen. Der Text wird nach der Bestätigung des Dialogfensters in den Makrobefehl "{AddSysTask:1100,{Doc:DocID},10}" für die nachträgliche Texterkennung umgewandelt. Dieser Befehl ist sinnvoll, wenn Sie Dokumente von einem Netzwerkscanner archivieren möchten. Die Texterkennung erfolgt dann nachträglich im Hintergrund.

Oder sofortige OCR

Soll auch die Standard-Dokumentenerkennung (Datum, Kontakte und andere Eigenschaften erkennen) ausgeführt werden, dann muss die OCR allerdings noch vor dem Import erfolgen: Geben Sie dann im Eingabefeld Vor Hinzufügen bitte "{ExecuteOCR:{Source}}" ein. Beachten Sie aber, dass der erkannte Text bereits vor dem Import in die Dokumentendatei geschrieben wird. Auch falls der Import anschließend abgebrochen wird.


Gültigkeit der Programmeinstellungen

Navigation: »Kein übergeordnetes Kapitel«

Gültigkeit der Programmeinstellungen

Verschiedenen Einstellungen

Gültigkeitsbereich

Das Programm unterscheidet zwischen benutzerspezifischen, lokalen, globalen und archivspezifischen Einstellungen. Diese werden mit Symbolen oberhalb der Eingabefelder gekennzeichnet:

Benutzer-Icon Benutzerspezifische Einstellung

Betrifft nur den Benutzer (Windows-Benutzerkonto), der die Einstellungen vornimmt.

Diese werden teils in der Windows-Registrierdatenbank unter dem Pfad hkey_current_user und teils im Verzeichnis "Gemeinsamen Dateien\User\Benutzername" gespeichert.

Compuer-Icon Lokale Einstellung

Gelten für alle Anwendenden des Computers, auf dem die Einstellungen vorgenommen wurden.

Diese werden in der Windows-Registrierdatenbank (Registry) unter dem Pfad hkey_local_machine gespeichert.

Archivicon Archivspezifische Einstellung

Betrifft nur die geöffnete Archivdatenbank und wird in der Datenbanktabelle dboption gespeichert.

Netzwerkicon Globale Einstellung

Gültig für alle Anwendenden an allen Computern, die lokal oder im Netzwerk mit dem Programm arbeiten.

Diese Optionen werden in der Datei admin.ini und anderen Konfigurationsdateien im Verzeichnis "Gemeinsame Dateien" gespeichert.

Geschütze Einstellung

Das Shieldsymbol UAC-Icon kennzeichnet Optionen, die Administrationsrechte unter Windows erfordern.


Dokumentenarchivierung

Navigation: »Kein übergeordnetes Kapitel«

Dokumentenarchivierung

Verfügbar in diesen Editionen

Einstellungen für Langzeitarchivierung

Menü Datei | Optionen | Einstellungen

Mit der Archivierungsfunktion werden Dokumentdatensätze für die Langzeitarchivierung in eine schreibgeschützte Datenbanktabelle verschoben. Für einen späteren Zugriff auf diese Dokumenten müssen Sie im Menü Ansicht den Befehl Archivierte Dokumente wählen.

In den Einstellungen können Sie festlegen, ob auch die Datei kopiert oder verschoben werden soll:

Klicken Sie im Bild auf die Komponenten, zu der Sie weitere Hilfe wünschen.

Für eine revisionssichere Archivierung können die Dateien beispielsweise auf ein schreibgeschütztes Medium (WORM-MO, RDX-WORM, Jukebox u. ä.) oder in einen mit Zugriffsrechten geschützten Festplattenbereich verschoben werden. Geben Sie dazu bitte den Speicherbereich bei Archivverzeichnis an und markieren Sie die Option Dokumentdateien in das Archivverzeichnis verschieben. Die Option in das Archivverzeichnis kopieren wird nicht empfohlen, da sie zu "Dateileichen" führt.

Beim Archivieren wird immer das Schreibschutz-Attribut der Datei gesetzt. Bei Verwendung von RDX mit erweitertem WORM-Modus führt dies automatisch zu einer revisionssicheren Dokumentdatei.

Markieren Sie Dokumentdateien komprimieren, wenn Sie Speicherplatz auf dem Zielmedium sparen möchten.

Siehe auch

Dokumente archivieren

GoBD-Archiv


Scanner-Papierformate definieren

Navigation: »Kein übergeordnetes Kapitel«

Scanner-Papierformate definieren

Papierformate für das Scannen mit TWAIN- und WIA-Geräten

Im Scandialog und den Profilen können Sie ein Papierformat wählen. Dieses legt den zu erfassenden Scan-Bereich und das Seitenformat für die erzeugten PDF-Dokumente im Archiv fest. Die wichtigsten Standardformate sind bereits vordefiniert.

Eigene Formate definieren

Wählen Sie bitte im Menü Menü Datei | Optionen | Einstellungen die Seite Scannen | Papierformate.

Die Liste zeigt die derzeit definierten Formate. Klicken Sie bitte auf:

Neu um ein neues Papierformat zu erstellen,

Kopieren zum Kopieren des markierten Eintrags,

Bearbeiten zur Bearbeitung des markierten Eintrags,

Löschen zum Löschen des markierten Eintrags.

Diese globale Einstellung gilt für alle DMS-Arbeitsplätze im Netzwerk.


Tabellenmenü Bearbeiten

Tabellen-Menü | Bearbeiten

Navigation: »Kein übergeordnetes Kapitel«

Tabellen-Menü | Bearbeiten

Klicken Sie bitte mit der sekundären (i. d. R. der rechten) Maustaste auf die Datentabelle, um das lokale Popupmenü zu öffnen. Sie finden hier u. a. das Untermenü Bearbeiten. Die zur Verfügung stehenden Funktionen unterscheiden sich je nach Datenquelle (Dokumente, Kontakte, Aufgaben).

Popup Untermenü "Bearbeiten"

Kopieren: Standardfunktion, kopiert die markierten Dokumente in die Zwischenablage. Sie können diese anschließend im Office Manager oder die Dateien im Explorer und anderen Programmen einfügen.
Kurztaste: Strg+C

Dateien kopieren: Kopiert nur die Dateien der markierten Dokumente in die Zwischenablage. Dies ist auch mit der Standardfunktion Kopieren möglich. Dateien ist aber schneller und spart Arbeitsspeicher, was bei sehr vielen markierten Dokumenten relevant ist.

Daten als Text: Kopiert die Spaltenüberschriften und den Inhalt aller markierten Zeilen als tabulatorgetrennten Text in die Zwischenablage. Sie können die Daten anschließend in einen Texteditor oder in eine Tabellenkalkulation wie Excel einfügen.

"(Zelleninhalt)" kopieren: Kopiert nur den Inhalt der angeklickten Zelle.

Einfügen: Wenn sich Dateien oder Office Manager-Dokumente in der Zwischenablage befinden, dann werden diese in das Dokumentenarchiv importiert.
Kurztaste: Strg+V

Alles markieren: Markiert alle Datensätze.

Löschen: Markierte Datensätze löschen.

Hilfe: Öffnet diese Hilfeseite.


Lokales Menü des Tabellenkopfes

Navigation: »Kein übergeordnetes Kapitel«

Lokales Menü des Tabellenkopfes

Klicken Sie bitte mit der sekundären (i. d. R. der rechten) Maustaste auf eine Spaltenüberschrift der Dokumenten- oder Aufgabentabelle. Das lokale Popupmenü wird geöffnet:

Sie finden hier Funktionen zum Sortieren und Gruppieren der Tabelle sowie Darstellungsoptionen. Wenn Sortieren und Gruppieren nicht möglich ist, dann aktivieren Sie im Menü Ansicht bitte die Option Datensätze in Speicher laden.

Aufsteigend sortieren: Sortiert die Daten nach der angeklickten Spalte in aufsteigender Richtung. Textfelder werden alphanumerisch, Zahlenfelder und Datum nach Wert sortiert.

Absteigend sortieren: Wie oben, jedoch in umgekehrter Richtung.

Sortierung zurücksetzen: Nicht mehr nach dieser Spalte sortieren.

Zum Sortieren können Sie auch mit der linken Maustaste auf die Überschrift klicken: Erster Klick zum aufsteigenden, erneuter Klick zum absteigenden Sortieren. Strg+Klick setzt die Sortierung zurück.

Nach diesem Feld gruppieren: Die Dokumente bzw. Aufgaben werden nach diesem Feld gruppiert in Knoten dargestellt.

Feld aus Gruppierung entfernen: Keine Gruppierung mehr nach diesem Feld. Der Befehl ist nur für gruppierte Felder sichtbar.

Gruppieren: Einen Gruppierungsbereich oberhalb der Tabelle ein- oder ausblenden. Sie können die Felder mit der Maus in diesen Bereich schieben, um danach zu gruppieren.

Fußzeile: Tabellen-Fußzeile ein- oder ausblenden. Fußzeilen bieten beispielsweise Spalten-Summen.

Gruppenfußzeile: Fußzeile für die Gruppierungsknoten ein- oder ausblenden

Feld ausblenden: Die Spalte aus der Tabelle entfernen.

Feldauswahl: Blendet die Spaltenliste ein. Sie können die Felder mit der Maus aus dieser in die Tabelle einfügen oder aus der Tabelle entfernen.

Ausrichtung: Die Daten der Spalte links, rechts oder zentriert ausrichten.

Optimale Breite: Die Breite der angeklickten Spalte optimieren, sodass der gesamte Text sichtbar sind.

Optimale Breite aller Spalten: Die Breite aller Tabellenspalten optimieren.

Datum-Gruppierung: Legt den Zeitraum fest, mit dem die Dokumente in den Knoten gruppiert werden. Der Befehl ist nur für Datumsfelder sichtbar.

Spalte verschieben: Tabellenspalten verschieben Sie i. d. R. per Drag&Drop mit der Maus. Alternativ können Sie hier die gewünschte Position eingeben, beispielsweise um eine neue Spalte von ganz rechts nach vorne zu schieben.


Projekte vorselektieren

Navigation: »Kein übergeordnetes Kapitel«

Projekte vorselektieren

Verfügbar in diesen Editionen

Wenn die Option Projekte vorselektieren (Menü Datei | Optionen | Einstellungen, Seite Optimieren) markiert ist, beziehen sich alle Abfragen auf das ausgewählte Projekt. Diese Option beschleunigt die Suchabfragen und verringert den Datenverkehr im Netzwerk.

Wenn die Option markiert ist und der Anwender z. B. die Funktion Alle Suchen aufruft, werden nur alle Dokumente des gewählten Projektes angezeigt. Ist die Option nicht markiert, ruft der Office Manager alle Dokumente der gesamten Archivdatenbank ab.

Wenn Sie zusätzlich die Option Abfrage "Alle Projekte zulassen" deaktivieren, kann der Anwender immer nur nach Dokumenten einzelner Projekte suchen. Dies stellt sicher, dass bei großen Datenbeständen das Netzwerk nicht unnötig belastet wird. Der erste Eintrag im Projektnavigator lautet dann nicht mehr "[alle Projekte]" sondern "[ohne Projekt]", mit dessen Auswahl die Dokumente ohne Projektzuordnung gefunden werden können.

Tipp zur Enterprise-Version

Diese Option ist vor allem bei großen Dokumentbeständen sinnvoll, wenn das Archiv auf einem SQL-Server gespeichert ist. Sie sollten dann die Option Projekte vorselektieren markieren und Abfrage "Alle Projekte" zulassen nicht markieren. Weisen Sie dem Datenfeld Projekt den Eingabestil "Nur Auswahl aus strukturierter Liste" zu (Menü Datei | Datenbank | Anpassen | Felder definieren), dies vermeidet Schreibfehler.

Entfernen Sie das Suchfeld Projekt aus dem Layout, damit nur über den Projektnavigator gesucht wird (Menü Ansicht | Anpassen | Layout entwerfen | Dokumenten-Suche).

Tipp: Navigator fixieren

Die Menübefehle Suchen | Zurücksetzen und Felder leeren löschen in der Standardkonfiguration den Inhalt der Suchfelder und markieren den Eintrag "alle Projekte" im Navigator. Wenn Sie einen der Befehle anklicken und gleichzeitig die Umschalttaste festhalten, dann wird die Projektmarkierung im Navigator nicht geändert.

Siehe auch

Beim Start alle Datensätze abrufen


Projektnavigator einblenden

Navigation: »Kein übergeordnetes Kapitel«

Projektnavigator einblenden

Der Projektnavigator ermöglicht Ihnen unter anderem eine schnelle Suche nach Dokumenten, die bestimmten Projekten zugeordnet sind.

Dauerhaft ein- oder ausblenden

Falls Sie den Navigator nicht nutzen, können Sie diesen ausblenden.

1.Wählen Sie dazu den Menübefehl Ansicht | Anpassen | Layout entwerfen | Bereiche positionieren.

2.Klicken Sie auf das oben rechts im Navigator auf das Kreuz zum Schließen oder im Menü Docking auf Projektnavigator.

Das Ausblenden ist nicht möglich, wenn die Option "Projekte vorselektieren" (Datei | Optionen | Einstellungen) markiert ist.

Um den Navigator wieder einzublenden, wählen Sie

1.Ansicht | Anpassen | Layout entwerfen | Bereiche positionieren und

2.im sich öffnenden Kontextmenü Docking den Befehl Projektnavigator.

Empfohlen: Automatisch minimieren

Eine empfehlenswerte Alternative zum dauerhaften Ausblenden ist das Minimieren. Im Docking-Modus (Menü Ansicht | Anpassen | Layout entwerfen | Bereiche positionieren) klicken Sie nicht auf das Kreuz, sondern oben rechts auf die Stecknadel.

Der Navigator wird minimiert und automatisch wieder eingeblendet, wenn Sie die Maus in den Bereich bewegen.


PDF-Dokumente schützen

Navigation: »Kein übergeordnetes Kapitel«

PDF-Dokumente schützen

Verfügbar in diesen Editionen

PDF-Dokumente vor Änderungen schützen

Menü Bearbeiten | Dokument | Verschlüsseln

Revisionssichere Archivierung

Eine revisionssichere Archivierung ist unter anderem durch die GoBD (Grundsätze zur ordnungsmäßigen Führung und Aufbewahrung von Büchern, Aufzeichnungen und Unterlagen in elektronischer Form sowie zum Datenzugriff) und für Belege bis 2014 durch die GDPdU bei steuerrelevanten Belegen vorgeschrieben. Sie müssen sicherstellen, dass ein Dokument nicht mehr verändert/manipuliert wird. Dies kann beispielsweise mit dem GoBD-Modus, durch Speicherung auf entsprechenden Medien (Hardwareschutz) oder durch digitale Signierung bzw. Verschlüsselung (Softwareschutz) geschehen.

Beachten Sie bitte, dass es derzeit keine explizite Zulassung eines Verfahrens für die Revisionssicherheit durch die Finanzbehörden gibt. Wir gehen davon aus, dass der hier verwendete Softwareschutz mit Verschlüsselung unter Verwendung eines Zufallskennwortes die Anforderungen erfüllt. Es kann hierfür aber keine Garantie übernommen werden.

Dokumente verschlüsseln

Markieren Sie bitte die gewünschten Acrobat-Dokumente in der Tabelle und wählen Sie den Menübefehl Bearbeiten | Dokument | Verschlüsseln. Die Dateien werden nun verschlüsselt und mit dem Kennwortschutz versehen. Das Kennwort ist niemandem bekannt, der Schutz kann nicht mehr aufgehoben und das Dokument nicht mehr geändert werden!

Sicherheitsinformation eines geschützten Dokuments

In der Dokumententabelle sind geschützte Dokumente (verschlüsselt und Änderung nicht zulässig) mit dem Schlosssymbol Schloss-Symbol gekennzeichnet.

Dokumente automatisch verschlüsseln

Im Scandialog und den Profilen können Sie die Option PDF-Dokument schützen markieren. Der Schutz wird dann nach dem Scan bzw. nach der OCR-Texterkennung aktiviert.

Mit Hilfe von Bearbeiten | Verschlüsseln und der Makro-Funktion PDFProtectDocument können Dokumente auch nachträglich geschützt werden.

Sicherungskopien

Bevor der Office Manager ein Acrobat-Dokument verschlüsselt, wird bei nicht genauer bekannten PDF-Formaten eine Sicherungskopie erstellt.

Es gibt eine Vielzahl an Programmen und Druckertreibern, die PDF-Dateien erzeugen. Es ist nicht sichergestellt, dass all diese Formate zu den Verschlüsselungsalgorithmen kompatibel sind, die Dateien könnten korrupt und unbrauchbar werden. In einem solchen Fall können Sie die Sicherungskopie (Dateiname_CopyN.pdf) wiederherstellen.

Hinweise

Die Funktion wird nicht ausgeführt, falls das Dokument bereits verschlüsselt ist.

Abhängig von der PDF-Version wird die Verschlüsselungsebene 40-bit RC4, 128-bit RC4 oder 128-bit AES verwendet.


Revisionssichere Archivierung auf RDX WORM

Navigation: »Kein übergeordnetes Kapitel«

Revisionssichere Archivierung auf RDX WORM

Verfügbar in diesen Editionen

Dies ist eine veraltete Funktion. Benutzen Sie alternativ den GoBD-Modus oder die Blockchainrevision.

WORM steht für "einmal schreiben und mehrfach lesen". Dateien, die auf einem WORM-Datenträger gespeichert werden, sind unveränderbar und somit revisionssicher archiviert. Grundsätzlich können Sie beliebige WORM-Datenträger mit dem Office Manager verwenden.

RDX WORM

RDX-Wechselfestplatten sind insbesondere für die Datensicherung bekannt. Die WORM-Medien machen diese Technik aber auch für die Dokumentenarchivierung interessant. Grundlegende Informationen finden Sie in unserem Supportartikel.

Sie können zwischen drei WORM-Modi wählen:

1.Standard: Alle auf dem Datenträger abgelegten Dateien werden automatisch "verwormt", also schreibgeschützt abgelegt.

2.Erweitert: Die Dokumente werden erst verwormt, wenn der Dateischreibschutz aktiviert wird. Zum Beispiel sobald Sie im Office Manager Enterprise die Archivierungsfunktion nutzen oder im Eigenschaftendialog den Schreibschutz setzen.

3.Retention: Wie im Modus "Erweitert" können veränderbare und revisionssichere Dokumente auf demselben Datenträger abgelegt werden. Zusätzlich wird die Aufbewahrungsfrist angegeben. Während dieser Aufbewahrungszeit (Dokumentlebenszyklus) sind die Dateien revisionssicher. Nach Ablauf der Frist können sie wieder gelöscht werden.

WORM-Modus "Retention" aktivieren

Systemvoraussetzung: RDX WORM mit Software rdxLock ab Version 2.3 (diese Version wurde 2015 veröffentlicht).

1.Stellen Sie sicher, dass dieser Modus in der rdxLock-Software aktiviert ist. Klicken Sie auf dem Server mit der rechten Maustaste auf das Laufwerk und wählen Sie den Menübefehl Eigenschaften. Auf der Registerseite rdxLOCK aktivieren Sie Single File Retention Policy mit den Werten Minimum 0 days, Default 4015 days und Maximum 3651770 days.

2.Öffnen Sie im Office Manager das Dokumentenarchiv, welches die Daten in diesem Modus archivieren soll.

3.Wählen Sie den Menübefehl Datei | Optionen | Einstellungen und wechseln Sie zur Registerseite Dokument.

4.Stellen Sie das Dokumentenverzeichnis so ein, dass die Dateien auf dem RDX gespeichert werden, beispielsweise
\\ServerName\WormFreigabe\Archive\{Self:DocDB,Name}\{Doc:Project}\
Anwender der Enterprise-Edition können auf der Registerseite mit dem Archivnamen (s. a. nächster Schritt) auch ein individuelles Dokumentenverzeichnis für dieses Archiv festlegen.

5.Die Einstellungsseite Dokument hat unten zwei Register: Allgemein und Archivname. Wechseln Sie zur Seite mit dem Archivnamen.

6.Klicken Sie unten auf den Mausschalter RDX WORM. Hinweise und Aktivierung.

7.Nach der Bestätigung mit Aktivieren wird die Option "RetentionMode" aktiviert und das Datenfeld "FILELASTACCESS" der Archivdatenbank hinzugefügt. Falls das Feld bereits vorhanden war, wird es geleert.

8.Passen Sie bitte die Auswahlliste der Kategorien an und hinterlegen Sie die jeweilige Aufbewahrungsfrist.

WORM-Modus "Retention" deaktivieren

Systemvoraussetzung: RDX WORM mit Software rdxLock ab Version 2.3 (diese Version wurde 2015 veröffentlicht).

1.Öffnen Sie im Office Manager das Dokumentenarchiv, in dem Sie den Modus deaktivieren möchten.

2.Wählen Sie den Menübefehl Datei | Optionen | Einstellungen und wechseln Sie zur Registerseite Dokument.

3.Die Einstellungsseite Dokument hat unten zwei Register: Allgemein und Archivname. Wechseln Sie zur Seite mit dem Archivnamen.

4.Klicken Sie unten auf den Mausschalter RDX WORM. Hinweise und Aktivierung.

Nach der Bestätigung mit Deaktivieren wird die Option "RetentionMode" entfernt. Das Datenfelder FILELASTACCESS wird nicht gelöscht. Sie können dieses mit der Funktion Felder definieren entfernen.

Funktionsablauf

Sobald eine Dokumentdatei des Status "revisionssicher" erhält, wird das Ablaufdatum der Aufbewahrungsfrist berechnet und in das Dateiattribut "Last access" geschrieben sowie der Schreibschutz gesetzt.

Die RDX-Software verwormt die Datei nach 10 Sekunden. Diese ist dann bis zum Ablauf der Aufbewahrungsfrist unveränderbar archiviert. Nach Fristablauf kann die Datei gelöscht werden.

Siehe auch

Supportrecherche Storage


Aufzählungsvariable initialisieren

Navigation: »Kein übergeordnetes Kapitel«

Aufzählungsvariable initialisieren

Aufzählungsvariable initialisieren

Den Startwert der Aufzählungsvariablen (Makro-Variable ReadIdentNo) können Sie direkt in der Datenbanktabelle festlegen.

Beispiel

Die Dokumentennummer wird mit der Makrovariablen {ReadIdentNo:AktDokNr} automatisch festgelegt, das erste Dokument soll die Nummer 1000 erhalten. Melden Sie sich bitte als Administrator an (Menü Datei | Optionen | Administrator), das neue Hauptmenü Administrator wird sichtbar. Wählen Sie nun im Menü Administrator | Tabelle anzeigen den Eintrag Dokumentenarchiv: identno.

Beachten Sie bitte, dass den Variablen der Text "macro_" voran gestellt wird.

Ist bereits eine Zeile mit dem idname "macro_aktdocnr" vorhanden?
Wenn nicht, dann bewegen Sie die Cursor-Taste nach unten, bis eine neue Zeile erstellt wird und tragen Sie "macro_aktdocnr" in der linken Spalte ein.
Tragen Sie den Startwert 1000 in der rechten Spalte ein

Wichtig: idname muss immer kleingeschrieben werden.

Siehe auch

Makro-Referenz


Index neu erstellen

Navigation: »Kein übergeordnetes Kapitel«

Index neu erstellen

Index neu erstellen

Menü Datei | Optionen | Einstellungen, Seite Volltextindex

Löscht den vorhandenen Volltextindex und baut ihn komplett neu auf. Diese Funktion ist sinnvoll, wenn Sie die Einstellungen geändert haben und diese sich auch auf bereits vorhandene Dokumente auswirken. Beachten Sie bitte, dass diese Funktion sehr zeitaufwändig sein kann. Bei großen Datenbanken sollte der Index über Nacht oder am Wochenende neu erstellt werden.

Hinweis: Wenn Sie während der Indexierung auf Abbrechen klicken, wird das aktuelle Dokument fertig gestellt und die Indexierung erst danach abgebrochen.

Tipp: Bei Access-Datenbanken (nicht bei SQL-Servern) ist die Indexierung etwas schneller, wenn die Archivdatenbank auf einer lokalen Festplatte liegt.

Siehe auch:

Menü Datenbankpflege, Option Volltextindex aktualisiert

Option UseAutoInc

Hotline-Blog: Wann muss der Volltextindex neu erstellt werden?


Reservierte SQL-Begriffe

Navigation: »Kein übergeordnetes Kapitel«

Reservierte SQL-Begriffe

Liste der wichtigsten reservierten Wörter im SQL

Diese Wörter dürfen nicht als Feldnamen in den Archivdatenbanken verwendet werden.

ACTIVE

ADD

ALL

AFTER

ALTER

AND

ANY

AS

ASC

ASCENDING

AT

AUTO

AUTOINC

AVG

BASE_NAME

BEFORE

BEGIN

BETWEEN

BLOB

BOOLEAN

BOTH

BY

BYTES

CACHE

CAST

CHAR

CHARACTER

CHECK

CHECK_POINT_LENGTH

CLONEGRP *

COLLATE

COLUMN

COMMIT

COMMITTED

COMPUTED

CONDITIONAL

CONSTRAINT

CONTAINING

COUNT

CREATE

CSTRING

CURRENT

CURSOR

DATABASE

DATE

DAY

DEBUG

DEC

DECIMAL

DECLARE

DEFAULT

DELETE

DESC

DESCENDING

DISTINCT

DO

DOMAIN

DOUBLE

DROP

ELSE

END

ENTRY_POINT

ESCAPE

EXCEPTION

EXECUTE

EXISTS

EXIT

EXTERNAL

EXTRACT

FILE

FILTER

FLOAT

FOR

FOREIGN

FROM

FULL

FUNCTION

GDSCODE

GENERATOR

GEN_ID

GRANT

GROUP

GROUP_COMMIT_WAIT_TIME

GUID

HAVING

HOUR

IF

IN

INT

INACTIVE

INDEX

INNER

INPUT_TYPE

INSERT

INTEGER

INTO

IS

ISOLATION

JOIN

KEY

LONG

LENGTH

LOGFILE

LOWER

LEADING

LEFT

LEVEL

LIKE

LOG_BUFFER_SIZE

MANUAL

MAX

MAXIMUM_SEGMENT

MERGE

MESSAGE

MIN

MINUTE

MODULE_NAME

MONEY

MONTH

NAMES

NATIONAL

NATURAL

NCHAR

NO

NOT

NULL

NUM_LOG_BUFFERS

NUMERIC

OF

ON

ONLY

OPTION

OR

ORDER

OUTER

OUTPUT_TYPE

OVERFLOW

PAGE_SIZE

PAGE

PAGES

PARAMETER

PASSWORD

PLAN

POSITION

POST_EVENT

PRECISION

PROCEDURE

PROTECTED

PRIMARY

PRIVILEGES

RAW_PARTITIONS

RDB$DB_KEY

READ

REAL

RECORD_VERSION

REFERENCES

RESERV

RESERVING

RETAIN

RETURNING_VALUES

RETURNS

REVOKE

RIGHT

ROLLBACK

RTFTEXT *

SECOND

SEGMENT

SELECT

SET

SHARED

SHADOW

SCHEMA

SHOWDLG *

SINGULAR

SIZE

SMALLINT

SNAPSHOT

SOME

SORT

SQLCODE

STABILITY

STARTING

STARTS

STATISTICS

SUB_TYPE

SUBSTRING

SUM

SUSPEND

TABLE

TEMPLATENAME *

TEMPLATETYPE *

THEN

TIME

TIMESTAMP

TIMEZONE_HOUR

TIMEZONE_MINUTE

TO

TRAILING

TRANSACTION

TRIGGER

TRIM

UNCOMMITTED

UNION

UNIQUE

UPDATE

UPPER

USER

VALUE

VALUES

VARCHAR

VARIABLE

VARYING

VIEW

WAIT

WHEN

WHERE

WHILE

WITH

WORK

WRITE

YEAR

* Besondere Felder des Office Managers


RSS-Feed

Navigation: »Kein übergeordnetes Kapitel«

RSS-Feed

Hilfe | Neuigkeiten

Mit dem Menübefehl Hilfe | Internet | Neuigkeiten können Sie direkt auf aktuelle RSS-Feeds des Office Manager und einen eigenen Feed zugreifen:

·Aktuelle Artikel im Hotline-Blog mit Antworten auf Anwenderfragen.

·Allgemeine Neuigkeiten zum Dokumentenmanagement.

·Einen zusätzlichen Feed können Sie mit dem Menüeintrag Eigener Feed hinzufügen. Beispielsweise die firmeneigenen Neuigkeiten oder "https://www.tagesschau.de/newsticker.rdf".

Öffnen und aktualisieren

Die Mausschaltfläche ist in zwei Bereiche aufgeteilt:

·Ein Klick auf die Grafik aktualisiert die Feeds aus dem Internet.

·Ein Klick auf den Pfeil öffnet die Liste, ohne diese zu aktualisieren.


PDF/A

Navigation: »Kein übergeordnetes Kapitel«

PDF/A

PDF/A ist ein Acrobat-Dokumentenformat für die Langzeitarchivierung. Office Manager DMS speichert gescannte Dokumente in PDF/A 1b, wenn die entsprechende Option auf Seite Scannen | Profile in den Programmeinstellungen aktiviert ist. Die Option hat keinen Einfluss, wenn die gescannten Belege als Bilddatei (z. B. TIFF) gespeichert werden.

OCR beachten

Gescannte Dokumente werden für die Texterkennung von einer OCR-Software bearbeitet. Hierbei kann der PDF/A-Modus je nach eingestellter Software wieder aufgehoben werden:

·Windows 10 RT: Der Modus bleibt erhalten.

·Kofax/Nuance OmniPage: PDF/A bleibt erhalten, wenn die Option Nur OCR markiert ist. Anderenfalls beachten Sie bitte die OmniPage-Einstellungen.

·Tesseract Open Source OCR Engine: PDF/A bleibt erhalten, wenn die Option Nur OCR markiert ist.

·ABBYY FineReader for ScanSnap: Der Modus geht vermutlich verloren, weil die Datei vom ABBYY neu erstellt wird.

·ABBYY Hot Folder, OmniPage Agent, ReadIRIS u. ä.: PDF/A geht vermutlich verloren, weil die Datei vom OCR neu erstellt wird.

·Transym OCR: Der Modus bleibt erhalten.


Geraderücken

Navigation: »Kein übergeordnetes Kapitel«

Geraderücken

Schräglagenkorrektur

Beim Scannen mit Einzelblatteinzug werden die Seiten häufig schief eingezogen. Zur Korrektur können Sie folgende Softwarelösungen verwenden:

1.Wenn Sie eine Bildverbesserungssoftware (z. B. Kofax VirtualReScan) verwenden, dann aktivieren Sie dort die Korrekturfunktion.

2.Oder prüfen Sie, ob die Scannersoftware eine entsprechende Option bietet. In die Twain-Einstellungen gelangen Sie z. B. über den Office Manager: markieren Sie im Scandialog Benutzeroberfläche des Scanners öffnen und klicken Sie auf Scannen.

3.Oder aktivieren Sie, wenn vorhanden, eine entsprechende Option in der verwendeten OCR-Software.

4.Oder nutzen Sie die Funktion des Office Managers: Option Geraderücken in den Scanprofilen und Befehl Geraderücken [Strg+G] im Scandialog.

Wählen Sie bitte nur eine der Möglichkeiten und vermeiden Sie mehrfache Korrekturen.

Siehe auch

Erweiterte Einstellung


Empfohlene Scan-Parameter für OCR

Empfohlene Scan-Parameter für gute OCR-Texterkennung

Navigation: »Kein übergeordnetes Kapitel«

Empfohlene Scan-Parameter für gute OCR-Texterkennung

Papierdokumente, die mit einem Scanner digitalisiert wurden, bestehen nur aus einer Grafik. Der Text, den wir Menschen auf dem Bild sehen, muss für das Archivierungssystem zuerst erkannt werden. Hier kommen OCR-Texterkennungsprogramme zum Einsatz, welche die Bildmuster auswerten, Zeichen erkennen und diese zu einem Text zusammensetzen. Die erkannten Wörter stehen anschließend für die Volltextsuche in den Archiven und die Dokumentenerkennung zur Verfügung.

Um eine möglichst gute Texterkennung zu gewährleisten, nehmen Sie bitte folgende Einstellungen im Scan-Dialog und den Scanprofilen vor:

·Die Auflösung sollte mindestens 300dpi betragen. Bei kleinen Schriften, z. B. AGB auf Rechnungsrückseiten, können auch 400dpi erforderlich sein.

·Bei Textdokumenten können Sie in der Regel in Schwarzweiß scannen. Die Dateien sind deutlich kleiner als Graustufen- und Farbdokumente. Stellen Sie aber bitte sicher, dass dabei keine Information verloren geht: Beispielsweise müssen Sie in Farbe scannen, wenn auf einem Dokument die rote Schrift für negative Zahlen verwendet wurde.

Die OCR-Texterkennung wird im Office Manager ausgeführt, wenn eine entsprechende Software eingestellt und die Option Volltextsuche ermöglichen aktiviert ist.

Im Lieferumfang ist "Tesseract Open Source Engine" enthalten und ab Windows 10 kann die systemeigene OCR "Windows RT" genutzt werden. Wenn Sie viel scannen und die Volltextsuche verwenden möchten, kann die Installation einer kommerziellen Lösung, wie beispielsweise "Kofax/Nuance OmniPage" noch bessere Ergebnisse erzielen.

Siehe auch

OCR-Supportseite


ScanSnap Standard-Profil

Navigation: »Kein übergeordnetes Kapitel«

ScanSnap Standard-Profil

Menü Datei | Optionen | Einstellungen, Seite Scannen | ScanSnap

Legen Sie hier fest, welches Profil verwendet wird, wenn Sie den Scan direkt am ScanSnap starten. Bei einen Gerät mit Touchscreen (iX1500) wird zum Scannen der große blaue Schalter auf dem Touchscreen berührt, bei älteren Scanner die Hardwaretaste gedrückt:

Touchscreen des ScanSnap iX1500

"Scan" auf dem Touchscreen eines iX1500

ScanSnap iX500 Bedienfeld

Scantaste am iX500

Beim Vorgabewert "zuletzt verwendetes Profil", wird jeweils das Scanprofil genutzt, welches Sie zuletzt im Menü Erstellen | Scanprofile gewählt haben. In diesem Fall können Sie das Profil für die Scan-Taste auch umstellen, indem Sie im Menü Erstellen | Scanprofile die Umschalttaste gedrückt halten und dann ein Scanprofil anklicken.

Im Menü ist das aktivierte Profil markiert (beachten Sie bitte die Hintergrundfarbe des Symbols). Im folgenden Beispiel ist Duplex-Scan das aktive:


ScanSnap-Manager starten

ScanSnap-Software starten

Navigation: »Kein übergeordnetes Kapitel«

ScanSnap-Software starten

A. ScanSnap Home

Scansoftware, die 2018 mit dem ScanSnap iX1500 herausgegeben wurde. Sie können diese im Windows-Startmenü aufrufen.

B. ScanSnap Manager

Zum Starten des ScanSnap-Managers klicken Sie bitte mit der rechten Maustaste auf das Tray-Icon ScanSnap-Icon in der Windows-Taskleiste.

Falls bei älteren Treibern die Option Quick-Menü verwenden markiert ist (z. B. ein Haken vor dem Text), dann klicken Sie ihn bitte einmal an, um die Markierung zu entfernen.

Wählen Sie anschließend den Menüpunkt Einstellungen der Scan-Taste.

Popupmenü des ScanSnap-Managers

Falls das Symbol nicht vorhanden ist, dann erweitern Sie im Windows-Startmenü bitte die ScanSnap-Programmgruppe.

·Ist dort ScanSnap Home enthalten, dann ist die neue Softwarevariante installiert (s. o.). Bei dieser wird kein Tray-Icon in der Taskleiste eingeblendet.

·Wenn ScanSnap Manager als Programm aufgeführt ist, dann starten Sie diesen bitte.

Siehe auch Internet Supportseiten zum ScanSnap Manager


Sendmail.txt

Navigation: »Kein übergeordnetes Kapitel«

Sendmail.txt

Die Datei Sendmail.txt

Sie können den Standard-Mailtext zum Versenden von Dokumenten und Kontakten per E-Mail anpassen, indem Sie eine Textdatei mit dem Namen sendmail.txt im Verzeichnis der gemeinsamen Dateien anlegen.

Innerhalb der Datei kann auf Makrovariablen zugegriffen werden, um die versandten Dateien mit den Dokumentattributen zu beschreiben.

In der ersten Dateizeile definieren Sie den E-Mail-Betreff: {Subject:Der EMail-Betreff}

Beispieldatei:

{Subject:Ihre angeforderten Dokumente}

Sehr geehrte Damen und Herren,

mit dieser Mail erhalten Sie folgende Dokumente:

{BeginLoop}

-Projekt {Doc:Project}, Dokument {Doc:Name} ({Doc:FileName,File})

{EndLoop}

Beachten Sie bitte die Zeilen {BeginLoop} und {EndLoop}: der Text zwischen diesen Schlagwörtern wird für jedes versandte Dokument wiederholt.

Im Verzeichnis der gemeinsamen Dateien finden Sie eine weitere Beispieldatei "sendmail-beispiel.txt". Sie können diese in "sendmail.txt" umbenennen und nach Ihren Wünschen anpassen.


Senden an CD

Navigation: »Kein übergeordnetes Kapitel«

Senden an CD

Dokumente auf CD oder DVD brennen

1.Sortieren Sie bitte die Dokumententabelle, wenn Sie auch einen HTML-Dokumentenindex schreiben möchten.

2.Markieren Sie die zu brennenden Dokumente in der Tabelle und wählen Sie den Menübefehl Start | Verwenden | Senden | Senden an CD.

Markierte Dokumente auf CD brennen

3.Legen Sie einen beschreibbaren CD- oder DVD-Rohling in das Rekorder-Laufwerk ein.

4.Wählen Sie den Rekorder aus der Liste.

5.Stellen Sie bitte die gewünschten Optionen ein:
Dokumentenindex: erstellt eine HTML-Dokumententabelle auf dem Datenträger.
Automatisch auswerfen: Laufwerksschublade nach dem Brennen öffnen.

6.Klicken Sie auf Brennen, um die Dokumente den Datenträger zu beschreiben.

7.Wenn Sie weitere Kopien erstellen möchten, legen Sie einfach einen neuen Rohling in das Laufwerk und klicken Sie erneut auf Brennen.

Siehe auch

Dokumentenindex

Menü Verwenden | Senden an


Serienbrief-Menü

Hauptmenü der Textverarbeitung

Navigation: »Kein übergeordnetes Kapitel«

Hauptmenü der Textverarbeitung

Menüreferenz der Textverarbeitung

Menü Datei

Neu: ein neues Dokument beginnen.

Öffnen: eine Dokumentdatei (rtf, doc, docx, html, txt) laden.

Speichern: Änderungen am Dokument speichern.

Speichern unter: das Dokument in einer (anderen) Datei speichern.

Als PDF speichern: erstellt ein PDF-Dokument.

Drucken: das geöffnete Dokument drucken.

Seite einrichten: Papierformat, Seitenränder und Layout anpassen.

Hilfe: Dokumentation und links zu Supportseiten.
Menü Start

Zwischenablage: Texte und andere Daten markieren, kopieren und einfügen.

Schriftart: Formatierungsmöglichkeiten für den Text.

Absatz: Formatierungsmöglichkeiten für Text-Absätze.

Formatvorlagen: vordefinierte Formatierungen.

Bearbeiten: im Text suchen und ersetzen sowie die letzten Funktionen rückgängig machen.
Menü Einfügen

Seite: fügt am Cursor einen Seitenumbruch ein, der folgende Text beginnt auf einer neuen Dokumentseite.

Tabelle: in einer Tabelle werden Daten in Zeilen und Spalten organisiert.

Bild: ein Bild aus einer Datei einfügen.

Textmarke: Sprungziel für einen Link erstellen.

Hyperlink: über einen Link kann zu einer Webseite oder Datei gesprungen werden.

Kopfzeile: für sich wiederholende Informationen auf Seitenanfang.

Fußzeile: für sich wiederholende Informationen auf Seitenende.

Seitenanzahl: Anzahl der Seiten im Dokument in eine Kopf- oder Fußzeile einfügen..

Seitenzahl: aktuelle Seitennummer.

Textfeld: zur Hervorhebung und Positionierung bestimmter Inhalte.

Symbol: Sonderzeichen einfügen.
Menü Layout

Seitenränder: die Breite der Seitenränder festlegen.

Ausrichtung: Seiten im Hoch- oder Querformat ausrichten..

Format: das Papierformat, zum Beispiel DIN A4, des Dokuments festlegen.

Spalten: Text in mehreren Spalten darstellen.

Umbrüche: Seiten- Abschnitts- und Spaltenumbrüche.

Zeilennummern: am Rand jeder Dokumentenzeile werden Nummern eingefügt.

Seitenfarbe: Hintergrundfarbe der Seite wählen.
Menü Sendung

Serienbrief-Feld einfügen: Platzhalter für ein Kontakt-Datenfeld im Dokument platzieren.

Adressblock einfügen: fügt die komplette Anschrift ein. Alternativ können Sie auch die Adresszeilen 1 bis 6 platzieren.

Daten anzeigen: schaltet zwischen der Darstellung als Seriendruckfelder und dem fertigen Brief mit Kontaktdaten um.

Alle Feld-Codes anzeigen: als Rich-Text-Codes darstellen.

Alle Feld-Ergebnisse anzeigen: dynamische Elemente darstellen.

In neues Dokument zusammenführen: den Serienbrief fertigstellen und alle Anschreiben in einem neuen Fenster oder einer Datei zusammenführen.

Fertigstellen und PDF archivieren: für jeden einzelnen Brief wird ein PDF-Dokument erstellt und in das Archiv importiert.
Menü Ansicht

Verkleinern: Zoom verkleinern, um mehr von der Seite zu sehen..

Heranzoomen: um Details zu erkennen.


Serienbrief schreiben

Navigation: »Kein übergeordnetes Kapitel«

Serienbrief schreiben

Verfügbar in diesen Editionen

Einen Serienbrief erstellen

Mit Hilfe von Briefvorlagen können Sie einzelne Kontakte anschreiben und umfangreiche Mailings erstellen.

Eine Vorlage erstellen

1.Öffnen Sie die Kontaktverwaltung mit dem MenübefehlAnsicht | Anzeigen | Kontakte oder klicken Sie am unteren Rand der Tabelle auf Kontakte.

2.Klicken Sie anschließend auf Kontakt | Serienbrief, um die Textverarbeitung zu öffnen:

3.Erstellen Sie bitte die Briefvorlage oder öffnen Sie einen vorhandenen Brief (.docx, .rtf).

4.Auf der Menüseite Sendungen finden Sie die Funktionen für Serienbriefe.

5.Bewegen Sie den Cursor an die Stelle im Dokument, an der die Adresse eingefügt werden soll und klicken Sie auf Sendungen | Adressblock einfügen. Diese sechs Zeilen werden bei der späteren Dokumentenerstellung durch die vollständige Kontaktadresse ersetzt.

6.Bewegen Sie den Cursor an die Stelle, an welcher das Briefdatum ausgegeben werden soll und fügen Sie "Datum" über Sendungen | Serienbrief-Feld einfügen ein.

7.Fügen Sie alle weiteren gewünschten Felder ein und speichern Sie die Briefvorlage. Hierfür wird ein Unterverzeichnis "MailMerge" vorgeschlagen. Wenn Sie in diesem speichern, wird die Vorlage auch im Programm-Hauptmenü Kontakt | Serienbrief gelistet und Sie können diese schnell für die Brieferstellung wählen.

Einen Brief schreiben

1.Suchen Sie den Kontakt bzw. die Kontakte, welche Sie anschreiben möchten. Die Funktion bezieht sich auf alle in der Tabelle vorhandenen Datensätze.

2.Der Mausschalter Kontakt | Serienbrief ist geteilt: Klicken Sie auf die obere Hälfte, um die Textverarbeitung mit einem leeren Dokument zu öffnen oder auf die untere Hälfte, um direkt eine Vorlage auszuwählen.

3.Klicken Sie im Menü Sendungen auf Daten anzeigen, um die Darstellung zwischen Platzhaltern und Kontaktdaten umzuschalten.

4.Für eine erste Vorschau können Sie links in der Liste zwischen den Kontakten wechseln.

5.Zum Fertigstellen des Serienbriefes wählen Sie bitte In neues Dokument zusammenführen oder Fertigstellen und PDF archivieren.

In neues Dokument zusammenführen

Die Briefe der gesuchten Kontakte werden in einem neuen Dokument zusammengefasst. Entweder in einem neuen Textverarbeitungsfenster oder in einer Datei, die Sie später verwenden können. Sie können die Briefe dann in einem gemeinsamen Druckauftrag ausgeben.

Fertigstellen und PDF archivieren

Für jeden Kontakt wird ein einzelnes PDF-Dokument erstellt. Anschließend öffnet sich der Eigenschaftendialog, in welchem Sie die Dokumente beschreiben können. Diese werden in das Dokumentenarchiv importiert und den jeweiligen Kontakten zugeordnet.


Serienbriefe

Navigation: »Kein übergeordnetes Kapitel«

Serienbriefe

Verfügbar in diesen Editionen

Serienbriefe

Briefe und Serienbriefe an Kontakte schreiben.

Zum Öffnen der Kontaktverwaltung wählen Sie den Befehl Ansicht | Anzeigen | Kontakte oder klicken Sie am unteren Rand der Tabelle auf Kontakte. Die Serienbrief-Funktion finden Sie dann im Menü Kontakt | Serienbrief.

Serienbriefe an Kontakte schreiben

Sie können die Briefvorlage in der Textverarbeitung erstellen oder bestehende Vorlagen aus Microsoft Word (*.docx) verwenden. Speichern Sie diese am besten im vorgeschlagenen Verzeichnis "MailMerge", die Dateien werden dann im Popupmenü Ansicht | Anzeigen | Kontakte eingeblendet und sind mit zwei Klicks erreichbar.

In diesem Kapitel:

Vorlagen erstellen und Briefe schreiben

Menüreferenz der Textverarbeitung


SetUpdateCriteria

Verfügbar in diesen Editionen

SetUpdateCriteria

Mit folgendem Eintrag in der Datenbankverbindungsdatei legen Sie den Modus fest:

[ConnectionOptions]

SetUpdateCriteria=2

Legt fest, wie Datensätze beim Eintragen von Aktualisierungen gesucht werden. Mögliche Werte:

0: alle Felder

1: Schlüsselfelder und ursprüngliche Feldwerte

2: nur Schlüsselfelder (Standardwert)

Wenn beim Speichern von Datensätzen der Fehler "Die zum Aktualisieren angegebene Zeile wurde nicht gefunden. Einige Werte wurden seit dem letzten Lesen ggf. geändert." auftritt, sollten den Standardwert 2 verwenden bzw. diesen INI-Schlüssel aus der Datei entfernen.


Sichtbarkeit festlegen

In diesem Dialogfenster können Sie die Sichtbarkeit des ausgewählten Menübefehls einstellen. Im oberen Bereich finden Sie eine kurze Beschreibung des Menübefehls, klicken Sie bitte auf das Hilfesymbol für weitere Informationen zu dem Befehl.

Sichtbarkeiten

Sichtbar für jeden: Der Befehl kann von allen Anwendern genutzt werden.

Sichtbar nur für den Office Manager-Administrator: Der Befehl ist nur sichtbar, wenn Sie sich im Office Manager als Administrator anmelden.

Sichtbar nur für folgende Windows-Benutzer oder Gruppen: (nur Enterprise-Edition) Fügen Sie der Liste bitte alle Benutzer oder Gruppen hinzu, für die der Befehl sichtbar sein soll. Andere Benutzer können den Befehl nicht ausführen.

Hinweise zur Benutzer- und Gruppenliste

In umfangreichen Netzwerkumgebungen kann das Laden der Windows-Benutzer und -Gruppen lange dauern. Beachten Sie in so einem Fall bitte folgende Tipps:

·Das Laden der Liste kann mit Esc abgebrochen werden, die Liste ist dann unvollständig.

·Die Liste wird nur einmal abgefragt. Wenn Sie diese aktualisieren möchten, schließen Sie bitte das Fenster der Programmeinstellungen und öffnen Sie es erneut.

·Wenn Sie den vollqualifizierten Namen des gewünschten Benutzers bzw. der Gruppe bereits kennen, können Sie diesen auch ohne Liste in einem einfachen Eingabedialog eingeben. Halten Sie hierzu bitte die Umschalt-Taste gedrückt, wenn Sie auf den Mausschalter Neu oder Bearbeiten klicken.


Speichermodus Darstellung

Speichermodus für Darstellungsanpassungen

Menü Datei | Optionen | Einstellungen, Seite Ansicht | Tabellen

Sie können die Tabellen mit der Maus anpassen - beispielsweise die Breite und Position von Spalten ändern. Legen Sie hier fest, wie diese Einstellungen gespeichert und nach einem Programmneustart wiederhergestellt werden:

1.Benutzerspezifisch
Die Anpassungen werden individuell für jeden Anwender gespeichert. Es gibt je Anwendenden eine Einstellung für alle Archive und eine Einstellung für alle Kontaktdatenbanken.

2.Benutzer- und datenbankspezifisch
Jeder Anwender verwendet individuelle Einstellungen für jede Archiv- und Kontaktdatenbank. Die Anpassung in einer Datenbank hat keinen Einfluss auf andere.

3.Global für alle Benutzer im Layout hinterlegt
Administrative Vorgabe für alle Benutzer. Der Anwender kann die Darstellung zwar anpassen, diese wird bei einem Neustart bzw. beim Archivwechsel aber wieder auf den Standard zurückgesetzt. Die Einstellungen werden im Layout hinterlegt.
Diese Option hat den Vorteil, dass Sie von zentraler Stelle ein optimiertes Tabellenlayout hinterlegen können. Einige Anwender werden sich aber wundern, dass ihre Anpassungen nicht gespeichert werden. Informieren Sie als Administrator bitte die Benutzer, wenn Sie diese Speicheroption wählen.
Es gibt eine Einstellung für alle Archive und eine Einstellung für alle Kontaktdatenbanken.

Unter Datei | Information, Seite Datenbanken | Archiv können Sie nachsehen, aus welcher Konfigurationsdatei die aktuellen Einstellungen gelesen wurden.

Anpassungen speichern

Im Modus 1 und 2 werden die Anpassungen der Tabellen automatisch gespeichert und wiederhergestellt.

Im Modus "Global für alle Benutzer" sind Sie als Administrator für das Design der Tabellen zuständig. Zum Speichern passen Sie die Tabellen bitte den Anforderungen entsprechend an: Spaltenbreite und -Position mit der Maus ändern sowie Spalten ein- und ausblenden. Anschließend wählen Sie den Menübefehl Datei | Optionen | Einstellungen und wechseln zur Seite Ansicht | Tabellen. Klicken Sie auf den Mausschalter Jetzt speichern.


Stapel-Scan

Navigation: »Kein übergeordnetes Kapitel«

Stapel-Scan

Trennfunktionen für Stapelscan und PDF-Import

Einen gescannten Papierstapel oder ein PDF-Sammeldokument in die jeweiligen Einzeldokumente aufteilen.

Scanprofil - Stapel

Office Manager Pro und Enterprise bieten folgende Trennfunktionen:

1.Manuell trennen: Sie können in einer Seitenvorschau markieren, wo ein neues Dokument beginnt.

2.Feste Seitenzahl: Empfohlen, wenn alle Dokumente im Stapel die gleiche Seitenanzahl haben.

Zusätzlich in der Enterprise-Edition:

3.Barcode-Trennung: Sie legen Trennblätter zwischen die Dokumente.

4.Makro-Trennung: Flexible Dokumententrennung anhand beliebiger Vorgaben.

Nutzen können Sie die Stapeltrennung

1.in den Scan-Profilen für lokal angeschlossene Scanner,

2.in Import-Profilen für Netzwerkscanner oder PDF-Sammeldokumente

3.sowie mit der Makrofunktion SplitDocument.

Aktivieren Sie die Dokumententrennung bitte im gewünschten Scan- oder Import-Profil auf der Registerseite Stapel. Wählen Sie dazu den Menübefehl Datei | Optionen | Einstellungen und wechseln Sie zur Seite Scannen | Profile bzw. Importieren | Profile.

1. Manuell trennen

In allen Editionen verfügbar

Bei einem Stapel mit mehreren Dokumenten unterschiedlicher Seitenzahl, empfiehlt sich die manuelle Methode. Es wird ein Dialogfenster mit den Vorschaubildern der einzelnen Seiten eingeblendet und Sie markieren dann mit der Maus (links oben den Haken setzen), wo ein neues Dokument beginnt.

Seiten können Sie mit der Maus per Drag&Drop verschieben und im lokalen Popupmenü (Rechtsklick) löschen. Die Vorschaugröße wird in diesem Menü, mit Strg und + bzw. - auf der Zehnertastatur oder den + und - Schaltern angepasst. Details lassen sich mit der Bildschirmlupe vergrößern.

Sie können zusätzliche Grafikdateien per Drag&Drop in das Vorschaufenster importieren.

Stapelscan mit manueller Dokumententrennung

Nach einem Klick auf OK werden die einzelnen Dokumente erstellt.

2. Feste Seitenzahl

In allen Editionen verfügbar

Wenn Sie einen Stapel mit mehreren einseitigen Dokumenten scannen möchten, dann ist diese Optionen empfohlen. Geben Sie eine Seitenanzahl von 1 ein. Beim Scannen wird dann für jede Seite ein neues Dokument erstellt, bis der Einzug leer ist.

Beim Duplex-Scan wird in der Regel eine Seitenzahl von 2 eingestellt, weil Vorder- und Rückseite erfasst werden. Sie können selbstverständlich auch eine andere Seitenzahl verwenden, sofern alle Dokumente im Stapel eine identische Seitenzahl haben.

3. Barcode-Trennung

Verfügbar in diesen Editionen

In der Enterprise-Version haben Sie auch die Möglichkeit, Trennblätter zwischen die Dokumente zu legen. Die Archivierungssoftware erstellt nach jedem Trennblatt ein neues Dokument, das Trennblatt selbst wird nicht übernommen.

1.Markieren Sie Standard-Barcode oder legen Sie einen anderen fest. Klicken Sie auf Drucken, um einige Trennblätter auf leerem weißen Papier auszudrucken.

2.Speichern Sie das Profil mit Klick auf OK.

3.Stellen Sie anschließend einen Stapel mit Dokumenten zusammen: Dokument 1 > Barcodetrennblatt > Dokument 2 > Barcodetrennblatt ... Dokument n.

4.Legen Sie diesen in den Einzelblatteinzug und wählen Sie das Profil im Hauptmenü Erstellen. Der Stapel wird eingezogen und die digitalisierten Dokumente in das Archiv übernommen.

Heben Sie die Trennblätter auf und verwenden Sie diese für den nächsten Stapel.

4. Makro-Trennung

Verfügbar in diesen Editionen

Office Manager Enterprise bietet auch eine flexible Trennung mit Makrofunktionen, beispielsweise einen Barcode oder einen Textausschnitt erkennen und abhängig vom Inhalt ein neues Dokument beginnen.

Es gibt zwei Eingabefelder: Makro und Trennen bei. Makrofunktionen werden in der Regel nur im ersten Feld eingegeben, sind aber in beiden möglich. Eine Seite wird als neues Dokument betrachtet, wenn die Werte beider Eingabefelder nach der Makro-Interpretation identisch sind.

Beispiel für Scan- und Importprofil

Makro: {ImgReadBarcode:StackScanImg,1,Code128}
Trennen bei: 500*

Wenn auf der Seite ein Barcode vom Typ Code128 gefunden wird und der Inhalt mit "500" beginnt, dann wird ein neues Dokument begonnen. Die Seite mit dem Barcode ist die erste Seite des neuen Dokuments.

Beispiel für Importprofil

Makro: {PDFGetTextFromRect:{Source},StackScanPage,70,90,60,66,1}
Trennen bei: 26.01.2019

Mit StackScanPage wird auf die aktuelle Seite der Quelldatei zugegriffen.

Syntax

Beim Vergleich sind Jokerzeichen und Masken in Trennen bei möglich: ? steht für ein einzelnes Zeichen, * für beliebig viele, [0-9] für alle Ziffern, [A-Z] für alle Buchstaben und [A7G] beispielsweise für A, 7 oder G.. Zwischen Groß- und Kleinschreibung wird nicht unterschieden.

Beim Scannen mit TWAIN- und WIA-Treibern ist zum Zeitpunkt der Makro-Interpretation die Dokumentdatei noch nicht vorhanden. In den Makrofunktionen ImgReadBarcode, ImgGetTextFromRect und einigen anderen wird aber ein Dateiname und eine Seitennummer erwartet. Geben Sie bitte StackScanImg als Dateiname und 1 als Seite an.

Hinweise zu Importprofilen

Ein derartiges Importprofil ermöglicht insbesondere die Trennung von gescannten Papierstapeln auch mit einem Netzwerkgerät, das nicht per Scanschnittstelle angesprochen wird, sondern die erfassten Dokumente in PDF-Dateien speichert. Die Trennung kann aber auch für andere PDF-Dokumente verwendet werden.

Das Quelldokument wird, sofern es in einzelne zerlegt wurde, anschließend gelöscht. Ausnahme: Aus Sicherheitsgründen wird nicht gelöscht, falls dieses im Dokumentenverzeichnis des Office Manager liegt.

Testen Sie die Funktion und insbesondere die erzeugten Dokumente vor einem produktiven Einsatz. Es ist nicht garantiert, dass alle PDF-Dateien der unterschiedlichen Scanner korrekt verarbeitet werden können. Falls die Trennung nicht funktioniert, dann versuchen Sie bitte die Angabe der Auflösung, beispielsweise "Code39,041319,300" für 300 dpi. Wenn diese optionale Auflösung angegeben ist, werden die einzelnen Seiten zur Erkennung in Bilder gedruckt, anstatt die Bilder aus dem PDF zu extrahieren.


Statusleiste

Navigation: »Kein übergeordnetes Kapitel«

Statusleiste

Status-Informationen in der Fußzeile

OCR-Systemaufgaben Systemaufgaben, wie z. B. OCR-Texterkennungen, laufen im Hintergrund.

GoBD-Revision Revisionssicheres Archiv (GoBD).

Warnung Warnung zum aktuellen Dokument, Datei nicht gefunden.


Gültige Dokumentdatei

Navigation: »Kein übergeordnetes Kapitel«

Gültige Dokumentdatei

Gültige Dokumentdatei

Legt fest, welche Datenbank die gültigen Dokumentdateien enthält:

Einzeln fragen: Sie müssen bei jeder Datei auswählen, welche gültig ist. Beachten Sie bitte, dass diese Option bei großen Datenbanken sehr zeitaufwendig sein kann.

Die neuere Datei: die Dateien mit dem neueren Bearbeitungsdatum sind gültig. Die älteren Dateien werden überschrieben.

Datei des geöffneten Archivs: die ursprünglichen Dateien (z. B. im Firmennetzwerk) sind gültig. Die ausgelagerten werden überschrieben.

Datei der Synchronarchivs: die ausgelagerten Dateien (z. B. auf dem Notebook) sind gültig. Die ursprünglichen werden überschrieben.

Die Dateien werden nur abgeglichen, wenn das Datum oder die Zeit der letzten Bearbeitung unterschiedlich ist.

Wenn eine Datei nicht existiert, wird die andere kopiert (z. B. wird die ausgelagert Datei immer kopiert, falls die ursprüngliche nicht mehr existiert).

Legen Sie die Dateipriorität sehr sorgfältig fest und markieren Sie die Option Sicherungskopien erstellen, um Datenverluste zu vermeiden.


System Data Format

Navigation: »Kein übergeordnetes Kapitel«

System Data Format

SDF-Format (System Data Format)

Die einzelnen Texteinträge sind durch ein Komma getrennt. Jeder Eintrag, der Leerzeichen, Kommata oder Anführungszeichen enthält, wird in Anführungszeichen (") gesetzt. Ist ein Anführungszeichen (") selbst Teil eines Strings, wird es verdoppelt.

Beispiel:

Stri,ng 1

Stri"ng 2

String 3

String4

wird im SDF-Format als

"Stri,ng 1","Stri""ng 2","String 3",String4

dargestellt.


Terminalserver

Navigation: »Kein übergeordnetes Kapitel«

Terminalserver

Verfügbar in diesen Editionen

Optimierung für Terminalserver

Office Manager DMS kann auf Terminalservern in einem optimierten Modus ausgeführt werden. Die Anwender benötigen dann keine Schreibrechte für die Windows-Registrierdatenbank (Registry).

Optimierungen und Einschränkungen

·Grafiken des Layouts werden nicht geladen.

·Beim Öffnen von Datenbanken wird immer vom Mehrbenutzerbetrieb ausgegangen und Archive auch dann nicht exklusiv geöffnet, wenn die Datenbank lokal gespeichert ist.

·Beim Öffnen des Archivs werden die Dokumente nicht automatisch abgefragt.

·Einstellungen werden nicht in der Registry, sondern in Dateien "Gemeinsame Dateien\User\Benutzer.Domäne\Terminalserver.*" gespeichert.

·Lokale und globale Einstellungen, sowie andere Menüs und Tabellen werden nur gespeichert, wenn Sie als Office Manager-Administrator angemeldet sind und Schreibrechte für die Registry und admin.ini besitzen.

·Ein Umschalten der Benutzersprache ist nur möglich, wenn der Anwender Schreibrechte in der Registrierungsdatenbank (HKEY_CURRENT_USER) besitzt.

Den Terminalserver-Modus aktivieren

Starten Sie das Programm bitte auf dem Terminalserver und melden Sie sich als Administrator an. Wählen Sie im Menü Datei | Optionen | Einstellungen. Aktivieren Sie auf der Seite Optimieren die Option "Dieser Rechner ist ein Terminalserver" und klicken Sie auf OK.


Terminplaner-Optionen

Navigation: »Kein übergeordnetes Kapitel«

Terminplaner-Optionen

Einstellungen der Aufgabenverwaltung

Menü Datei | Optionen | Einstellungen

Arbeitszeit

In den Kalenderansichten mit Uhrzeit kann der dargestellte Zeitraum für eine bessere Übersicht auf die Arbeitszeiten begrenzt werden (Menü Aufgaben | Ansicht). Stellen Sie hier die Standard-Arbeitszeit ein; bei Gleitzeiten vom frühesten Beginn bis zum spätesten Arbeitsende. Ausnahmen müssen nicht berücksichtigt werden, weil der Terminplaner auch die gesamte Tageszeit und nicht nur die Arbeitszeit darstellen kann.

Besondere Tasten im Zeit-Eingabefeld: Cursor aufwärts und abwärts ändert den markierten Zeitanteil um 1, Bild auf und ab um 10.


Verzeichnisüberwachung

Neues Dokument aus überwachtem Verzeichnis

Im überwachten Verzeichnis wurde eine neue Datei gespeichert. Geben Sie jetzt bitte die Attribute ein und klicken Sie auf OK, um die neue Datei in die Dokumentenverwaltung zu übernehmen. Wenn Sie die Datei nicht übernehmen möchten, klicken Sie Abbrechen.

Siehe auch

Dialogfenster Dokumenteigenschaften

Filter für die Verzeichnisüberwachung

Verzeichnis überwachen

Import-Optionen

Erweiterte Einstellungen


Volltextsuche mit MS SQL-Server

Navigation: »Kein übergeordnetes Kapitel«

Volltextsuche mit MS SQL-Server

Verfügbar in diesen Editionen

Suche im Volltextindex

Office Manager DMS ermöglicht Ihnen neben der Suche in den einzelnen Attributen auch eine sehr schnelle Abfrage über den Volltextindex. Hier sind die Wörter aus allen Attributen (Projekt, Name, usw.), den Notizen und je nach Einstellung auch der Dokumentinhalte enthalten.

Geben Sie im primären Suchfeld Volltext Wörter ein (Groß-/ Kleinschreibung wird nicht berücksichtigt) und drücken Sie die Eingabetaste oder klicken Sie auf den Schalter Suchen.

Die Dokumenttabelle enthält jetzt nur noch Dokumente, die alle gesuchten Wörter enthalten. Falls Sie Dokumente suchen, die nur eines der eingegebenen Wörter enthalten, dann geben Sie bitte den großgeschriebenen OR-Operator ein: wort1 OR wort2.

Alternativ können Sie auch auf den Schalter rechts im Eingabefeld klicken, um ein Dialogfenster für die Volltextrecherche zu öffnen:

Suche im MS SQL-Volltextindex

Mit diesem Dialog suchen Sie immer in allen Dokumenten. Beispielsweise wird die Markierung im Projektnavigator nicht berücksichtigt.

GPT-Chat

Wenn die KI-Funktionen mit GPT aktiviert sind, können Sie das Eingabefeld auch für Chats und Übersetzungen nutzen.

Besonderheiten der Volltextsuche mit MS SQL Server

Diese Funktion ist nur in der Enterprise-Edition verfügbar.

Die Server-Volltextsuche kann in MS SQL-Datenbanken aktiviert werden.

·Operatoren (AND, OR, ...) müssen großgeschrieben werden.

·Gesuchte Wörter sollten kleingeschrieben werden, um eine Verwechslung mit Operatoren zu vermeiden.

·Die Standard-Verknüpfung ist AND. Wenn die Suche mehrere Wörter enthält, dann werden nur Dokumente gefunden, die alle Wörter enthalten.

·Wenn keine Operatoren oder Anführungszeichen verwendet werden, dann werden auch ähnliche Wörter gefunden. (Die Abfrage erfolgt dann intern mit FREETEXT.)

·Wenn ein Operator, * oder Anführungszeichen verwendet werden, dann muss die Suche nach ähnlichen Wörter explizit angegeben werden (~, ~~, INFL, SYN). (Die Abfrage erfolgt intern mit CONTAINS.)

Einfache Suche nach einem oder mehreren Wörtern

Geben Sie die Wörter einfach mit Leerzeichen getrennt ein, z. B. wort1 wort2 wort3 . Es werden alle Dokumente gefunden, die alle gesuchten Wörter oder ähnliche Wörter beinhalten.

Suche nach einem Ausdruck (einer Phrase)

Geben Sie den gesuchten Ausdruck bitte in doppelten Anführungszeichen ein, z. B. "office manager dms". Es werden nur Dokumente gefunden, die genau diesen Wortlaut beinhalten.

Erweiterte Suche mit Operatoren

Beachten Sie bitte, dass die Operatoren GROSS geschrieben werden müssen.

·AND: sucht Dokumente, die alle Wörter beinhalten, z. B. wort1 AND wort2 .
Alternative Schreibweise: wort1 & wort2 .

·OR: sucht Dokumente, die mindestens ein Wort beinhalten, z. B.: wort1 OR wort2 .
Alternative Schreibweise: wort1 | wort2 .

·AND NOT: sucht Dokumente die das Wort 1 beinhalten. In dem Datenfeld, in welchem Wort 1 gefunden wurde, darf Wort 2 aber nicht vorkommen, z. B.: wort1 AND NOT wort2 .
Alternative Schreibweise: wort1 &! wort2 .

·NEAR: Wort 2 muss im selben Datenfeld und in der Nähe von Wort 1 stehen: wort1 NEAR wort2 .

·INFL: für Inflectional sucht ähnliche Wörter mit Hilfe der grammatikalischen Beugung, z. B. INFL gehen : findet Dokumente mit dem Wort gehen, ging oder geht.
Alternative Schreibweise: ~gehen .

·SYN für Synonym sucht ähnliche Wörter mit Hilfe eines Thesaurus, z. B. SYN auto findet Dokumente mit dem Wort auto, automobil oder pkw. Das Suchergebnis ist abhängig vom Thesaurus des SQL-Servers.
Alternative Schreibweise: ~~auto .

·*: sucht Wörter oder Phrasen, die mit dem eingegebenen Text beginnen, z. B. offi* findet Dokumente mit dem Wort office, offiziell u. a.

·COL begrenzt die folgende Suche auf ein Datenbankfeld, z. B. COL NAME wort findet nur Dokumente, in denen das Wort im Dokumentattribut (Datenbankfeld) NAME vorkommt. Das Datenfeld für den Dokumenteninhalt heißt contenttext, COL contenttext wort sucht also nur im Dokument selbst.
COL * wort sucht wieder in allen Datenbankfeldern.
Alternative Schreibweise für COL contenttext wort: DOCUMENT wort .

Beispiele

· raben fliegen : findet z. B. Dokumente mit dem Text "Raben können fliegen", "der Rabe fliegt nach Berlin" oder "die Raben flogen heute schnell".

· "raben können fliegen" : findet nur Dokumente mit dem genauen Ausdruck "Raben können fliegen".

· "raben können fliegen" COL applname acrobat : findet nur Dokumente, die den genauen Ausdruck "Raben können fliegen" enthalten und das Wort "Acrobat" im Datenfeld applname (Dokumenttyp) beinhalten.

· raben OR fliegen : Dokumente, in denen das Wort "Raben" oder "fliegen" vorkommt.

· ~raben OR ~fliegen oder INFL raben OR INFL fliegen : Dokumente, in denen eines der folgenden Wörter vorkommt: "Rabe", "Raben", "fliegt", "flog", "fliegen" u. ä.

· ~~rabe oder SYN rabe : abhängig vom verwendeten Thesaurus z. B. "Rabe", "Vogel", oder "Krähe".

· COL name raben : das Wort "Raben" muss im Dokumentattribut NAME enthalten sein.

· COL name raben COL * fliegen : Das Wort "Raben" muss im Dokumentattribut name und das Wort "fliegen" in einem beliebigen Attribut oder in der Dokumentdatei enthalten sein.

· COL contenttext "raben können fliegen" oder document "raben können fliegen" : der Ausdruck "Raben können fliegen" muss in der Dokumentdatei vorkommen.

· raben NEAR fliegen : beide Wörter "Raben" und "fliegen" müssen im selben Dokumentattribut (oder der Datei) enthalten sein und nahe beieinander stehen.

· rabe* OR krähe* : findet Dokumente, die ein Wort enthalten, das mit Rabe oder Krähe beginnt.

· pinguine &! fliegen : das Wort "Pinguine" muss vorhanden sein und das Wort "fliegen" darf nicht im selben Attribut vorkommen.

Expertensuche mit SQL-Anweisung

Wenn der eingegebene Suchtext mit CONTAINS( , FREETEXT( , CONTAINSTABLE( oder FREETEXTTABLE( beginnt, dann wird der gesamte Suchtext direkt im WHERE-Teil der SQL-Abfrage übergeben.

Diese Art der Suche ist für administrative Kontrollabfragen vorgesehen und für den Anwender nicht geeignet.

Siehe auch

SQL-Server Volltextsuche aktivieren

Einstellungen für den Volltextindex

Dokumente suchen

Info Volltextindex


Volltextsuche mit SQLite

Navigation: »Kein übergeordnetes Kapitel«

Volltextsuche mit SQLite

Suche im Volltextindex

Office Manager DMS ermöglicht Ihnen neben der Suche in den einzelnen Attributen auch eine sehr schnelle Abfrage über den Volltextindex. Hier sind die Wörter aus allen Attributen (Projekt, Name, usw.), den Notizen und je nach Einstellung auch der Dokumentinhalte enthalten.

Geben Sie im primären Suchfeld Volltext Wörter ein (Groß-/ Kleinschreibung wird nicht berücksichtigt) und drücken Sie die Eingabetaste oder klicken Sie auf den Schalter Suchen.

Die Dokumenttabelle enthält jetzt nur noch Dokumente, die alle gesuchten Wörter enthalten. Falls Sie Dokumente suchen, die nur eines der eingegebenen Wörter enthalten, dann geben Sie bitte den großgeschriebenen OR-Operator ein: wort1 OR wort2.

Alternativ können Sie auch auf den Schalter rechts im Eingabefeld klicken, um ein Dialogfenster für die Volltextrecherche zu öffnen:

Suche im SQLite-Volltextindex

Mit diesem Dialog suchen Sie immer in allen Dokumenten. Beispielsweise wird die Markierung im Projektnavigator nicht berücksichtigt.

GPT-Chat

Wenn die KI-Funktionen mit GPT aktiviert sind, können Sie das Eingabefeld auch für Chats und Übersetzungen nutzen.

Besonderheiten der Suche in einem SQLite-Archiv

Diese Suche wird in allen .omsl- und .omen-Dokumentenarchiven verwendet.

·Sie können das Jokerzeichen * am Ende eines Wortes verwenden.

·Operatoren (OR, NOT ...) müssen großgeschrieben werden.

·Gesuchte Wörter sollten kleingeschrieben werden, um eine Verwechslung mit Operatoren zu vermeiden.

·Deutsche Umlaute sind bezüglich der Groß- und Kleinschreibung aber problematisch. Wenn Sie z. B. nach "Übung" suchen, dann geben Sie den Begriff auch mit großen "Ü" ein

·Die Standard-Verknüpfung ist AND. Der Operator AND darf nicht mit angegeben werden, verwenden Sie einfach wort1 wort2, um nur die Dokumente zu finden, in denen alle Wörter vorkommen.

Einfache Suche nach einem oder mehreren Wörtern

Geben Sie die Wörter einfach mit Leerzeichen getrennt ein, z. B. wort1 wort2 wort3. Es werden alle Dokumente gefunden, die alle gesuchten Wörter oder ähnliche Wörter beinhalten.

Suche nach einem Ausdruck (einer Phrase)

Geben Sie den gesuchten Ausdruck bitte in doppelten Anführungszeichen ein, z. B. "office manager dms". Es werden nur Dokumente gefunden, die genau diesen Wortlaut beinhalten.

Erweiterte Suche mit Operatoren

Beachten Sie bitte, dass die Operatoren GROSS geschrieben werden müssen.

·OR: sucht Dokumente, die mindestens ein Wort beinhalten, z. B.: wort1 OR wort2

·NOT: sucht Dokumente die das Wort 1 beinhalten, aber das Wort 2 nicht, z. B.: wort1 NOT wort2 .

·NEAR: Wort 2 muss im selben Datenfeld und in der Nähe von Wort 1 stehen: wort1 NEAR wort2 .

·*: sucht Wörter oder Phrasen, die mit dem eingegebenen Text beginnen, z. B. offi* findet Dokumente mit dem Wort office, offiziell u. a.

Siehe auch

Einstellungen für den Volltextindex

Dokumente suchen

Info Volltextindex


Standard-Volltextsuche

Volltextsuche

Navigation: »Kein übergeordnetes Kapitel«

Volltextsuche

Suche im Volltextindex

Office Manager DMS ermöglicht Ihnen neben der Suche in den einzelnen Attributen auch eine sehr schnelle Abfrage über den Volltextindex. Hier sind die Wörter aus allen Attributen (Projekt, Name, usw.), den Notizen und je nach Einstellung auch der Dokumentinhalte enthalten.

Geben Sie im primären Suchfeld Volltext Wörter ein (Groß-/ Kleinschreibung wird nicht berücksichtigt) und drücken Sie die Eingabetaste oder klicken Sie auf den Schalter Suchen.

Die Dokumenttabelle enthält jetzt nur noch Dokumente, die alle gesuchten Wörter enthalten. Falls Sie Dokumente suchen, die nur eines der eingegebenen Wörter enthalten, dann geben Sie bitte den großgeschriebenen OR-Operator ein: wort1 OR wort2.

Alternativ können Sie auch auf den Schalter rechts im Eingabefeld klicken, um ein Dialogfenster für die Volltextrecherche zu öffnen:

Suche im SQLite-Volltextindex

Mit diesem Dialog suchen Sie immer in allen Dokumenten. Beispielsweise wird die Markierung im Projektnavigator nicht berücksichtigt.

GPT-Chat

Wenn die KI-Funktionen mit GPT aktiviert sind, können Sie das Eingabefeld auch für Chats und Übersetzungen nutzen.

Besonderheiten der Standard-Volltextsuche

Die Standardsuche wird in Access-Archiven (*.omp) sowie den SQL-Servern MySQL und Firebird verwendet. Bei MS SQL-Datenbanken können Sie den Modus festlegen.

Wenn Sie ein neues Dokument erstellen oder ein bestehendes ändern, wird der Index von Ihrem Client-Computer aktualisiert. Den Fortschritt dieser Hintergrundfunktion sehen Sie links unten in der Statusleiste.

Sie können Jokerzeichen verwenden: "me?er" sucht beispielsweise nach Wörtern, wie "meyer" und "meier".

Logische Verknüpfungen

Die Indexabfrage erlaubt UND-, ODER-, UND NICHT- Verknüpfungen, die UND-Verknüpfung ist Standard. Eine Kombination von UND, ODER innerhalb einer Abfrage ist nicht möglich.

Operatoren:

·UND-Verknüpfung ist Standard, es ist kein Operator nötig

·ODER-Verknüpfung: Operator "OR"

·UND NICHT: Operator "NOT" oder "!" oder " -" (Minuszeichen mit einem Leerzeichen davor)

Beispiele:

· Im Index: prinzenallee angebot Im Index: prinzenallee AND angebot
Sucht alle Dokumente, die ein Wort beginnend mit "prinzenallee" und ein Wort beginnend mit "angebot" enthalten. Der Operator "AND" braucht nicht angegeben zu werden.

· Im Index: prinzenallee OR angebot
Sucht alle Dokumente, die ein Wort beginnend mit "prinzenallee" oder ein Wort beginnend mit "angebot" beinhalten.

· Im Index: prinzenallee angebot NOT meyer
Sucht alle Dokumente, die "prinzenalle" und "angebot" enthalten. Dokumente, die "meyer" enthalten werden aber nicht gefunden. Statt "NOT meyer" können Sie auch " -meyer" oder "!meyer" eingeben.

Nicht erlaubt

ist eine "oder nicht" Abfrage, "prinzenallee OR NOT rechnung" verursacht eine Fehlermeldung oder wird ignoriert.

Siehe auch

Einstellungen für den Volltextindex

Dokumente suchen

Info Volltextindex


Vom integrierten Viewer unterstütze Grafikformate

Der interne Grafikviewer kann folgende Formate darstellen:

·TIFF Bitmap

·GIF Bitmap

·JPEG Bitmap

·JP2, J2K Jpeg2000

·PCX PaintBrush

·BMP Windows Bitmap

·ICO Windows Icon

·CUR Windows Cursor

·PNG Portable Network Graphics

·WMF Windows Metafile

·EMF Enhanced Windows Metafile

·TGA Targa Bitmap

·PXM Portable Pixmap, GreyMap, BitMap

·AVI video

·WBMP Wireless bitmap

·DCX Multipage PCX

·RAW Digital Camera RAW

·BMPRAW Bitmap RAW

·WMV Windows Media

·MPEG Video MPEG

·PSD Adobe Photoshop PSD

·IEV Vectorial objects

·LYR Layers (LayersSaveToFile)

·ALL Combined layers and vectorial objects (SaveToFileAll)

·DICOM medical imaging

·QRP QuickReport

Das Grafikformat wird auch bei falschen Dateiendungen erkannt.

Siehe auch

Dokumentenvorschau


Vorschauprogramm

Navigation: »Kein übergeordnetes Kapitel«

Vorschauprogramm

Einstellungen der Dokumentenvorschau
Menü Datei | Optionen | Dokumenttyp

Die Dokumente können in einem Vorschaufenster betrachtet werden. Wählen Sie:

Keine Vorschau: Eine Dokumentenvorschau ist nicht möglich.

Automatisch: Das Programm verwendet die am besten geeignete Vorschaumethode abhängig vom Dateitypen. Diese Option ist für alle Dokumenttypen empfohlen.

Windows-Miniaturansicht: Thumbnail des Windows-Explorer dargestellt.

Interner Grafik-Viewer: Grafikdateien (bmp, jpg u. a.) werden im internen Vorschaufenster gezeigt. Auch DXF-Zeichnungen können direkt dargestellt werden, allerdings nur ein Teilbereich des Sprachumfanges.

Interner CAD-Viewer: Verschiedene CAD-Dateien, AutoCAD und andere Formate. Diese Funktion ist nur in der Enterprise-Edition verfügbar.

Interner E-Mail, Text und RTF-Viewer: Texte, Word- und RTF-Dokumente, E-Mails sowie elektronische Rechnungen (XRechnung, Factur-X und ZUGFeRD) werden im internen Vorschaufenster gezeigt. Auch die Dateiliste von ZIP-Archiven und anderen Komprimierungsformaten werden dargestellt.

Interner PDF-Viewer: Schneller programminternen Viewer für Acrobat-Dokumente (pdf).

Web-Browser: Windows-Browser (Edge, sofern vorhanden, sonst Internet Explorer) im internen Vorschaufenster für HTML-Dateien und Webseiten verwenden. Bei Edge auch für PDF-Dokumente geeignet.

COM-Objekt (OLE) erstellen: Das Dokument wird als OLE-Objekt eingebunden. Das entsprechende Anwendungsprogramm muss auf dem Rechner installiert sein und die Fähigkeit besitzen, das Dokument als OLE-Objekt an andere Anwendungen zu übergeben.

Tipp zu Microsoft Office

Die Windows-Miniaturansicht ist nur möglich, wenn das Office-Programm diese speichert. Siehe hierzu z. B. im Menü Datei | Eigenschaften, Seite Zusammenfassung von Word oder Excel. Beachten Sie unseren Blog-Artikel mit ausführlichen Informationen. Für Word->Dokumente ist der interne Textviewer besser geeignet.

E-Mails als MS Outlook können im integrierten Textviewer dargestellt werden. Versuchen Sie aber auch die Windows-Miniaturansicht. Sie erhalten eine deutlich bessere Mail-Darstellung, sofern Outlook im Betriebssystem integriert ist.


Formulardaten

Wenn Sie beispielsweise die Online-Registrierung wählen, wird das entsprechende Webformular in Ihrem Browser geöffnet. Um zu vermeiden, dass Sie Ihre Daten in jedem Formular erneut eingeben müssen, werden diese mit der URL (Internet-Adresse) an Ihren Browser übergeben und das Formular ausgefüllt.


Dokumententyp für XRechnung

Navigation: »Kein übergeordnetes Kapitel«

Dokumententyp für XRechnung

Elektronische Rechnungen sind maschinenlesbare XML-Daten, die entweder einem PDF-Dokument anliegen oder, wie es bei XRechnung der Fall ist, nur als reine XML-Datei vorliegen. Für XRechnung sollte ein spezieller Dokumententyp im DMS registriert sein, damit die Daten in einer für die Anwendenden lesbaren Form visualisiert werden.

XML für XRechnung registrieren

1.Wählen Sie den Menübefehl Datei | Optionen | Dokumenttyp, um das Dialogfenster "Registrierte Dokumenttypen" zu öffnen:

Dialogfenster der Dokumenttypen

2.Klicken Sie auf den Menüschalter Neu und wählen Sie Neu für Dateiendung.

3.Geben Sie "xml" als Dateiendung ein und bestätigen Sie mit OK.

4.Sollte bereits ein Typ für XML vorhanden sein, dann werden Sie entsprechend informiert und der Dokumenttyp wird in der Liste markiert.

5.Eine sinnvolle Bezeichnung ist "XRechnung" oder allgemein "XML-Dokument".

6.Wählen Sie eine Grafik, um die Rechnungen in der Dokumententabelle gut erkennen zu können. Der Typ ist "Standard-Dokument in externer Datei".

7.Wechseln Sie zur Registerseite Vorschau und markieren Sie Interner E-Mail, Text und RTF-Viewer.

XRechnungen werden ab jetzt in einer Schnellansicht visualisiert. Für eine vollständige Darstellung aller Rechnungsdaten sollten Sie einen externen Viewer installieren:

Quba-Viewer

Quba ist ein quelloffenes Anzeigeprogramm für elektronische Rechnungen. Installieren Sie dieses und verknüpfen Sie das Programm mit dem Dokumententyp:

1.Laden Sie das Setup-Programm für Windows und installieren Sie Quba.

2.Wir benötigen jetzt den Dateipfad der quba.exe. Klicken Sie im Startmenü mit der rechten Maustaste auf die Programmverknüpfung und wählen Sie Dateispeicherort öffnen. Der Explorer öffnet sich und zeigt die Quba-Verknüpfung. Klicken Sie auch diese mit der rechten Maustaste an und wählen Sie Dateipfad öffnen. Dann Rechtsklick auf die Quba.exe und Als Pfad kopieren.

3.Wechseln Sie zurück zu Office Manager DMS in den oben beschriebenen Dialog "Registrierte Dokumenttypen".

4.Markieren Sie den zuvor erstellen Dokumententyp der XRechnung und wechseln Sie zur Registerseite Befehle.

5.Den Befehl "open" markieren und Benutzerdefinierte Steuerung der Anwendung aktivieren.

6.Im Eingabefeld Programmdatei den zuvor kopierten Dateipfad der Quba.exe mit Stg+V einfügen:

XRechnung mit Quba.exe verknüpfen

7.Das Fenster schließen und die Rückfrage zum Speichern bestätigen.

Wenn Sie jetzt eine XRechnung in der Dokumententabelle mit Doppelklick öffnen, dann wird diese im Quba-Viewer vollständig dargestellt.


Zugriffsgeschwindigkeit optimieren

Einstellungen zur Optimierung der Zugriffs-Geschwindigkeit.
(Menü Datei | Optionen | Einstellungen, Seite Optimieren).

Programmsymbole darstellen

Anzeige der Dokumentanzahl

Projekte vorselektieren

Dokumente automatisch abfragen

Datensätze in den Speicher laden

Maximale Dokumentenanzahl begrenzen

Terminalserver-Modus